PerpetuumSoft.ReportingServices.Viewer.Client Namespace

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PerpetuumSoft.ReportingServices.Viewer.Client Namespace
Send Feedback

Classes

Class | Description
BaseParameterControl | An abstract class. It is basic class for all report parameter and credential controls which realize displaying Report Parameters and Data-Sourse Credentials.
BooleanParameterControl | The BooleanParameterControl class is intended to encapsulate logic for report parameter controls with Boolean type and with single-value selection and without list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.
ContinuedPageModel | One column report view model. There can be displayed many pages on the screen simultaneously - as many pages as area sizes allow.
Credential | Represents credential for a DataSource
CredentialParameterControl | This class is intended to realize displaying Data-Sourse Credentials. Inherited from BaseParameterControl. It is used for the Report Viewer template creation.
CredentialsManager | The class wich realizes a credentials storage and management functionality.
Cursor | A cursor class.
CursorLayer | A layer class where cursor is displayed. It is used for the Report Viewer template creation.
DateTimeParameterControl | The DateTimeParameterControl class is intended to encapsulate logic for report parameter controls with DateTime type and with single-value selection and without list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.
DisabledTool | Realizes the tool which makes available any actions with the report. Inherited from Tool.
Document | A class which includes report data.
DocumentLoadedEventArgs | Parameters of the event which occurs when report is loaded.
DocumentPresenter | Report presenter.
DocumentViewModel | Report view model.
DynamicZoomTool | The class which realizes tool for view scaling with mouse move at pressed mouse left button.
ErrorMessagePresenter | A class for presentation of report view content when error occurs during report getting.
ExportListControl | Represents a selection control with a drop-down list of ToolButton that can be shown or hidden by clicking the arrow on the control. Selected element does not represented in drop-down list. It is used for the Report Viewer template creation.
LoadingPagePresenter | Loading presenter.
MouseWheelEventArgs | Provides data for various events that report changes to the mouse wheel delta value of a mouse device.
MouseWheelManager | Manager for working with mouse scroll-wheel.
MultiValidValueParameterControl | The MultiValidValueParameterControl class is intended to encapsulate logic for report parameter controls with multi-value selection and with list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.
MultiValidValueParameterControl..::.Data | The Data class is intended to encapsulate data for ComboBox binding.
MultiValueParameterControl | The MultiValueParameterControl class is intended to encapsulate logic for report parameter controls with multi-value selection and without list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.
NavigationHelper | The NavigationHelper class.
NoReportPresenter | A class for presentation of report view content when report is missing.
Page | A class for report page representation.
PageLoadedEventArgs | Report page loading event parameters.
PagePresenter | Report pages presenter.
PageSelectedEventArgs | Parameters of the event which occurs when the page is selected.
PanTool | The class which realizes tool for report scrolling with mouse pointer move at pressed right mouse button. Inherited from StandardTool.
Parameter | The class which describes a parameter.
ParametersPanel | Represents a panel control with list of BaseParameterControl that can be shown or hidden and have two buttons to accept or cancel BaseParameterControl controls changing. It is used for the Report Viewer template creation.
ParameterValueChangedEventArgs | Provides data for the ParameterValueChanged event.
Progress | This class realizes progress bar. Inherited from Control.
RegionZoomTool | Class for realization of the tool which is used for scaling the report in the selected area. Inherited from StandardTool.
ReportErrorEventArgs | Parameters of the event which occurs when there is generation error.
ReportHyperlinkEventArgs | Parameters of the event which occurs when hyperlink is clicked.
ReportParameterControl | An abstract class. This class is intended to encapsulate common logic for report parameter controls. Inherited from BaseParameterControl.
ReportState | The ReportState class.
ReportViewer | A control for report preview, navigation by pages, export and search.
Select | Control which is used for checking selection on toolbar. It is used for the Report Viewer template creation.
Separator | Separating control which is used in toolbar. It is used for the Report Viewer template creation.
SinglePageModel | Single page view mode.
SingleValidValueParameterControl | The SingleValidValueParameterControl class is intended to encapsulate logic for report parameter controls with single-value selection and with list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.
StandardTool | A basic class for all standard tools.
StringParameterControl | The StringParameterControl class is intended to encapsulate logic for report parameter controls with String type and with single-value selection and without list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.
ToggleToolButton | Toolbar button control. Inherited from ToggleButton.
Tool | An abstract class. It is basic class for all classes of tools which realize handling of ReportViewer special functionality.
ToolBalloon | Gets or sets toolbar balloon control. Inherited from Control.
ToolButton | Gets or sets toolbar button control. Inherited from Button.
ToolSlider | Slider control for reports view scaling. Inherited from Slider.
ViewManager | Report Viewer manager.
ViewModel | Report view model.
ViewOptions | Report Viewer parameters.
WaitTool | The WaitTool class. Inherits the Tool class.
ZoomChangeTool |
ZoomInTool | A class for realization of the tool which can be used for zooming in report view. Inherited from ZoomChangeTool.
ZoomOutTool | A class for tool (functionality) realization which is used for report zooming out. Inherited from ZoomChangeTool.

Structures

Structure | Description
ReportRegion | Report area.
Zoom | A strcture which includes data about current report scale.

Interfaces

Interface | Description
IView | Report Viewer control interface.

Enumerations

Enumeration | Description
ActiveTool | Report Viewer active tool type.
PageModel | Page view models list.
ZoomMode | Enumeration which includes scale modes list.


ActiveTool Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ActiveTool Enumeration
See Also Send Feedback
Report Viewer active tool type.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public enum ActiveTool
Visual Basic (Declaration)
Public Enumeration ActiveTool
Visual C++
public enum class ActiveTool

Members

Member name | Description
Pan | Report panning mode.
DynamicZoom | Dynamic scaling mode.
ZoomToRegion | Scaling mode by the set area.
ZoomIn | Zoom in mode.
ZoomOut | Zoom out mode.

See Also

PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BaseParameterControl Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
BaseParameterControl Class
Members See Also Send Feedback
An abstract class. It is basic class for all report parameter and credential controls which realize displaying Report Parameters and Data-Sourse Credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract class BaseParameterControl : Control
Visual Basic (Declaration)
Public MustInherit Class BaseParameterControl _
    Inherits Control
Visual C++
public ref class BaseParameterControl abstract : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.BaseParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.CredentialParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportParameterControl

See Also

BaseParameterControl Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BaseParameterControl Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
BaseParameterControl Members
BaseParameterControl Class Constructors Methods Properties Events See Also Send Feedback

The BaseParameterControl type exposes the following members.

Constructors

Name | Description
BaseParameterControl | Initializes a new instance of the BaseParameterControl class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Sets the focus on parameter control.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel.
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

BaseParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BaseParameterControl Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
BaseParameterControl Constructor
BaseParameterControl Class See Also Send Feedback
Initializes a new instance of the BaseParameterControl class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected BaseParameterControl()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
BaseParameterControl()

See Also

BaseParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BaseParameterControl Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
BaseParameterControl Methods
BaseParameterControl Class See Also Send Feedback

The BaseParameterControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Sets the focus on parameter control.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

BaseParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetFocus Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
BaseParameterControl..::.SetFocus Method
BaseParameterControl Class See Also Send Feedback
Sets the focus on parameter control.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void SetFocus()
Visual Basic (Declaration)
Public MustOverride Sub SetFocus
Visual C++
public:
virtual void SetFocus() abstract

See Also

BaseParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BaseParameterControl Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
BaseParameterControl Properties
BaseParameterControl Class See Also Send Feedback

The BaseParameterControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel.
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

BaseParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanel Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
BaseParameterControl..::.ParametersPanel Property
BaseParameterControl Class See Also Send Feedback
Gets or sets the parameters panel.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ParametersPanel ParametersPanel { get; set; }
Visual Basic (Declaration)
Public Property ParametersPanel As ParametersPanel
Visual C++
public:
property ParametersPanel^ ParametersPanel {
    ParametersPanel^ get ();
    void set (ParametersPanel^ value);
}

Field Value

The parameters panel.

See Also

BaseParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BaseParameterControl Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
BaseParameterControl Events
BaseParameterControl Class See Also Send Feedback

The BaseParameterControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

BaseParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BooleanParameterControl Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl Class
Members See Also Send Feedback
The BooleanParameterControl class is intended to encapsulate logic for report parameter controls with Boolean type and with single-value selection and without list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class BooleanParameterControl : ReportParameterControl
Visual Basic (Declaration)
Public Class BooleanParameterControl _
    Inherits ReportParameterControl
Visual C++
public ref class BooleanParameterControl : public ReportParameterControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.BaseParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.BooleanParameterControl

See Also

BooleanParameterControl Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BooleanParameterControl Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl Members
BooleanParameterControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The BooleanParameterControl type exposes the following members.

Constructors

Name | Description
BooleanParameterControl | Initializes a new instance of the BooleanParameterControl class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNullable | Gets or sets a value which indicates whether the value of the parameter can be null.
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

BooleanParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BooleanParameterControl Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl Constructor
BooleanParameterControl Class See Also Send Feedback
Initializes a new instance of the BooleanParameterControl class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public BooleanParameterControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BooleanParameterControl()

See Also

BooleanParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BooleanParameterControl Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl Fields
BooleanParameterControl Class See Also Send Feedback

The BooleanParameterControl type exposes the following members.

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

See Also

BooleanParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BooleanParameterControl Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl Methods
BooleanParameterControl Class See Also Send Feedback

The BooleanParameterControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

BooleanParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl..::.OnApplyTemplate Method
BooleanParameterControl Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

BooleanParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetFocus Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl..::.SetFocus Method
BooleanParameterControl Class See Also Send Feedback
Overridden. See SetFocus()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void SetFocus()
Visual Basic (Declaration)
Public Overrides Sub SetFocus
Visual C++
public:
virtual void SetFocus() override

See Also

BooleanParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BooleanParameterControl Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl Properties
BooleanParameterControl Class See Also Send Feedback

The BooleanParameterControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNullable | Gets or sets a value which indicates whether the value of the parameter can be null.
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

BooleanParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsNullable Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl..::.IsNullable Property
BooleanParameterControl Class See Also Send Feedback
Gets or sets a value which indicates whether the value of the parameter can be null.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsNullable { get; set; }
Visual Basic (Declaration)
Public Property IsNullable As Boolean
Visual C++
public:
property bool IsNullable {
    bool get ();
    void set (bool value);
}

Field Value

true if the value of the parameter can be null; otherwise, false.

See Also

BooleanParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Values Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl..::.Values Property
BooleanParameterControl Class See Also Send Feedback
Overridden. See Values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override List<ValidValue> Values { get; set; }
Visual Basic (Declaration)
Public Overrides Property Values As List(Of ValidValue)
Visual C++
public:
virtual property List<ValidValue^>^ Values {
    List<ValidValue^>^ get () override;
    void set (List<ValidValue^>^ value) override;
}

See Also

BooleanParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BooleanParameterControl Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
BooleanParameterControl Events
BooleanParameterControl Class See Also Send Feedback

The BooleanParameterControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

BooleanParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ContinuedPageModel Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel Class
Members See Also Send Feedback
One column report view model. There can be displayed many pages on the screen simultaneously - as many pages as area sizes allow.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ContinuedPageModel : DocumentViewModel
Visual Basic (Declaration)
Public Class ContinuedPageModel _
    Inherits DocumentViewModel
Visual C++
public ref class ContinuedPageModel : public DocumentViewModel

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewModel
PerpetuumSoft.ReportingServices.Viewer.Client..::.DocumentViewModel
PerpetuumSoft.ReportingServices.Viewer.Client..::.ContinuedPageModel

See Also

ContinuedPageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ContinuedPageModel Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel Members
ContinuedPageModel Class Constructors Methods Fields Properties See Also Send Feedback

The ContinuedPageModel type exposes the following members.

Constructors

Name | Description
ContinuedPageModel | Initializes a new instance of the ContinuedPageModel class.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Calculates the page location in the report preview area. (Inherited from DocumentViewModel.)
CalculateZoom | Calculates scale. (Inherited from DocumentViewModel.)
ChangeZoom | Overloaded.
Clone | Overridden. See Clone()()(). (Overrides ViewModel..::.Clone()()().)
CreateStoryboard | Creates Storyboard for animation. (Inherited from DocumentViewModel.)
DeleteUnusedPages | Deletes the unused pages. (Inherited from DocumentViewModel.)
DocumentEnd | Overridden. See DocumentEnd()()() (Overrides ViewModel..::.DocumentEnd()()().)
DocumentHome | Overridden. See DocumentHome()()() (Overrides ViewModel..::.DocumentHome()()().)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing. (Inherited from DocumentViewModel.)
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Overridden. See GetGap(Point). (Overrides DocumentViewModel..::.GetGap(Point).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Inherited from DocumentViewModel.)
GoToLastPage | Overridden. See GoToLastPage()()(). (Inherited from DocumentViewModel.)
GoToNextPage | Overridden. See GoToNextPage()()(). (Inherited from DocumentViewModel.)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Inherited from DocumentViewModel.)
HightlightSearchResult | Overridden. See HightlightSearchResult()()(). (Inherited from DocumentViewModel.)
Invalidate | Overloaded.
MakeClientSideSearch | Overridden. See MakeClientSideSearch(SearchResult, SearchResult). (Inherited from DocumentViewModel.)
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible. (Inherited from DocumentViewModel.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from DocumentViewModel.)
OnPageSizeChanged | Overridden. See OnPageSizeChanged()()(). (Overrides DocumentViewModel..::.OnPageSizeChanged()()().)
PageDown | Overridden. See PageDown()()(). (Inherited from DocumentViewModel.)
PageEnd | Overridden. See PageEnd()()(). (Overrides ViewModel..::.PageEnd()()().)
PageHome | Overridden. See PageHome()()() (Overrides ViewModel..::.PageHome()()().)
PageUp | Overridden. See PageUp()()(). (Inherited from DocumentViewModel.)
PanView | Overridden. See PanView(Point). (Inherited from DocumentViewModel.)
RectToScreen | Overridden. See RectToScreen(ReportRegion). (Overrides DocumentViewModel..::.RectToScreen(ReportRegion).)
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Inherited from DocumentViewModel.)
SetupPage | Sets the selected page parameters. (Inherited from DocumentViewModel.)
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Inherited from DocumentViewModel.)
StartAnimation | Starts the animation. (Inherited from DocumentViewModel.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | Overriden. See UpdateContent(ViewModel, Boolean) (Overrides ViewModel..::.UpdateContent(ViewModel, Boolean).)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Inherited from DocumentViewModel.)

Fields

Name | Description
_searchResult | (Inherited from DocumentViewModel.)
Gap | Gets the gap between pages. (Inherited from DocumentViewModel.)
Margin | Gets page margins. (Inherited from DocumentViewModel.)

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Inherited from DocumentViewModel.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Inherited from DocumentViewModel.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report. (Inherited from DocumentViewModel.)
HScrollBarActive | Overridden. See HScrollBarActive. (Inherited from DocumentViewModel.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Inherited from DocumentViewModel.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Inherited from DocumentViewModel.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Inherited from DocumentViewModel.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Inherited from DocumentViewModel.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Inherited from DocumentViewModel.)
PageNumber | Overridden. See PageNumber. (Overrides ViewModel..::.PageNumber.)
ScaledPageArea | Gets the page sizes subject to view scale. Overridden. See ScaledPageArea. (Overrides DocumentViewModel..::.ScaledPageArea.)
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Inherited from DocumentViewModel.)
VScrollBarLarge | Overridden. See VScrollBarLarge (Overrides DocumentViewModel..::.VScrollBarLarge.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Inherited from DocumentViewModel.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Inherited from DocumentViewModel.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Inherited from DocumentViewModel.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Inherited from DocumentViewModel.)
Zoom | Overridden. See Zoom. (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ContinuedPageModel Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel Constructor
ContinuedPageModel Class See Also Send Feedback
Initializes a new instance of the ContinuedPageModel class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ContinuedPageModel(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
ContinuedPageModel(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The manager.

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ContinuedPageModel Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel Fields
ContinuedPageModel Class See Also Send Feedback

The ContinuedPageModel type exposes the following members.

Fields

Name | Description
_searchResult | (Inherited from DocumentViewModel.)
Gap | Gets the gap between pages. (Inherited from DocumentViewModel.)
Margin | Gets page margins. (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ContinuedPageModel Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel Methods
ContinuedPageModel Class See Also Send Feedback

The ContinuedPageModel type exposes the following members.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Calculates the page location in the report preview area. (Inherited from DocumentViewModel.)
CalculateZoom | Calculates scale. (Inherited from DocumentViewModel.)
ChangeZoom | Overloaded.
Clone | Overridden. See Clone()()(). (Overrides ViewModel..::.Clone()()().)
CreateStoryboard | Creates Storyboard for animation. (Inherited from DocumentViewModel.)
DeleteUnusedPages | Deletes the unused pages. (Inherited from DocumentViewModel.)
DocumentEnd | Overridden. See DocumentEnd()()() (Overrides ViewModel..::.DocumentEnd()()().)
DocumentHome | Overridden. See DocumentHome()()() (Overrides ViewModel..::.DocumentHome()()().)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing. (Inherited from DocumentViewModel.)
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Overridden. See GetGap(Point). (Overrides DocumentViewModel..::.GetGap(Point).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Inherited from DocumentViewModel.)
GoToLastPage | Overridden. See GoToLastPage()()(). (Inherited from DocumentViewModel.)
GoToNextPage | Overridden. See GoToNextPage()()(). (Inherited from DocumentViewModel.)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Inherited from DocumentViewModel.)
HightlightSearchResult | Overridden. See HightlightSearchResult()()(). (Inherited from DocumentViewModel.)
Invalidate | Overloaded.
MakeClientSideSearch | Overridden. See MakeClientSideSearch(SearchResult, SearchResult). (Inherited from DocumentViewModel.)
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible. (Inherited from DocumentViewModel.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from DocumentViewModel.)
OnPageSizeChanged | Overridden. See OnPageSizeChanged()()(). (Overrides DocumentViewModel..::.OnPageSizeChanged()()().)
PageDown | Overridden. See PageDown()()(). (Inherited from DocumentViewModel.)
PageEnd | Overridden. See PageEnd()()(). (Overrides ViewModel..::.PageEnd()()().)
PageHome | Overridden. See PageHome()()() (Overrides ViewModel..::.PageHome()()().)
PageUp | Overridden. See PageUp()()(). (Inherited from DocumentViewModel.)
PanView | Overridden. See PanView(Point). (Inherited from DocumentViewModel.)
RectToScreen | Overridden. See RectToScreen(ReportRegion). (Overrides DocumentViewModel..::.RectToScreen(ReportRegion).)
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Inherited from DocumentViewModel.)
SetupPage | Sets the selected page parameters. (Inherited from DocumentViewModel.)
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Inherited from DocumentViewModel.)
StartAnimation | Starts the animation. (Inherited from DocumentViewModel.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | Overriden. See UpdateContent(ViewModel, Boolean) (Overrides ViewModel..::.UpdateContent(ViewModel, Boolean).)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ChangeZoom Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.ChangeZoom Method
ContinuedPageModel Class See Also Send Feedback

Overload List

Name | Description
ChangeZoom(ZoomMode, Boolean) | Overridden. See ChangeZoom(ZoomMode, Boolean). (Inherited from DocumentViewModel.)
ChangeZoom(Double, Boolean) | Performs scale and scale mode changing. (Inherited from ViewModel.)
ChangeZoom(Point, Double, Boolean) | Overridden. See ChangeZoom(Point, Double, Boolean). (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
ContinuedPageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Clone Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.Clone Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override ViewModel Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As ViewModel
Visual C++
public:
virtual ViewModel^ Clone() override

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentEnd Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.DocumentEnd Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See DocumentEnd()()()

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void DocumentEnd()
Visual Basic (Declaration)
Public Overrides Sub DocumentEnd
Visual C++
public:
virtual void DocumentEnd() override

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentHome Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.DocumentHome Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See DocumentHome()()()

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void DocumentHome()
Visual Basic (Declaration)
Public Overrides Sub DocumentHome
Visual C++
public:
virtual void DocumentHome() override

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


EnsureVisible Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.EnsureVisible Method
ContinuedPageModel Class See Also Send Feedback

Overload List

Name | Description
EnsureVisible(ReportRegion) | Shifts the visible area of the screen to guarantee that the specified report is visible. (Inherited from ViewModel.)
EnsureVisible(ReportRegion, Boolean) | Overridden. See EnsureVisible(ReportRegion, Boolean). (Overrides ViewModel..::.EnsureVisible(ReportRegion, Boolean).)

See Also

ContinuedPageModel Class
ContinuedPageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


EnsureVisible Method (ReportRegion, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.EnsureVisible Method (ReportRegion, Boolean)
ContinuedPageModel Class See Also Send Feedback
Overridden. See EnsureVisible(ReportRegion, Boolean).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void EnsureVisible(
    ReportRegion region,
    bool alignTop
)
Visual Basic (Declaration)
Public Overrides Sub EnsureVisible ( _
    region As ReportRegion, _
    alignTop As Boolean _
)
Visual C++
public:
virtual void EnsureVisible(
    ReportRegion region,
    bool alignTop
) override

Parameters

region
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportRegion
alignTop
Type: System..::.Boolean

See Also

ContinuedPageModel Class
EnsureVisible Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GetGap Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.GetGap Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See GetGap(Point).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override Size GetGap(
    Point center
)
Visual Basic (Declaration)
Protected Overrides Function GetGap ( _
    center As Point _
) As Size
Visual C++
protected:
virtual Size GetGap(
    Point center
) override

Parameters

center
Type: System.Windows..::.Point

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Invalidate Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.Invalidate Method
ContinuedPageModel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates report viewer. (Inherited from DocumentViewModel.)
Invalidate(Boolean) | Invalidates report viewer. (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
ContinuedPageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnPageSizeChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.OnPageSizeChanged Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See OnPageSizeChanged()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override double OnPageSizeChanged()
Visual Basic (Declaration)
Protected Overrides Function OnPageSizeChanged As Double
Visual C++
protected:
virtual double OnPageSizeChanged() override

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageEnd Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.PageEnd Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See PageEnd()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void PageEnd()
Visual Basic (Declaration)
Public Overrides Sub PageEnd
Visual C++
public:
virtual void PageEnd() override

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageHome Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.PageHome Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See PageHome()()()

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void PageHome()
Visual Basic (Declaration)
Public Overrides Sub PageHome
Visual C++
public:
virtual void PageHome() override

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RectToScreen Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.RectToScreen Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See RectToScreen(ReportRegion).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override Rect RectToScreen(
    ReportRegion region
)
Visual Basic (Declaration)
Protected Overrides Function RectToScreen ( _
    region As ReportRegion _
) As Rect
Visual C++
protected:
virtual Rect RectToScreen(
    ReportRegion region
) override

Parameters

region
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportRegion

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateContent Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.UpdateContent Method
ContinuedPageModel Class See Also Send Feedback
Overriden. See UpdateContent(ViewModel, Boolean)

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected internal override void UpdateContent(
    ViewModel prevViewModel,
    bool useAnimation
)
Visual Basic (Declaration)
Protected Friend Overrides Sub UpdateContent ( _
    prevViewModel As ViewModel, _
    useAnimation As Boolean _
)
Visual C++
protected public:
virtual void UpdateContent(
    ViewModel^ prevViewModel,
    bool useAnimation
) override

Parameters

prevViewModel
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewModel
useAnimation
Type: System..::.Boolean

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomIn Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.ZoomIn Method
ContinuedPageModel Class See Also Send Feedback

Overload List

Name | Description
ZoomIn(Boolean) | Performs zoom in. (Inherited from ViewModel.)
ZoomIn(Point, Boolean) | Performs zoom in. (Inherited from ViewModel.)

See Also

ContinuedPageModel Class
ContinuedPageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOut Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.ZoomOut Method
ContinuedPageModel Class See Also Send Feedback

Overload List

Name | Description
ZoomOut(Boolean) | Performs zoom out. (Inherited from ViewModel.)
ZoomOut(Point, Boolean) | Performs zoom out. (Inherited from ViewModel.)

See Also

ContinuedPageModel Class
ContinuedPageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ContinuedPageModel Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel Properties
ContinuedPageModel Class See Also Send Feedback

The ContinuedPageModel type exposes the following members.

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Inherited from DocumentViewModel.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Inherited from DocumentViewModel.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report. (Inherited from DocumentViewModel.)
HScrollBarActive | Overridden. See HScrollBarActive. (Inherited from DocumentViewModel.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Inherited from DocumentViewModel.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Inherited from DocumentViewModel.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Inherited from DocumentViewModel.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Inherited from DocumentViewModel.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Inherited from DocumentViewModel.)
PageNumber | Overridden. See PageNumber. (Overrides ViewModel..::.PageNumber.)
ScaledPageArea | Gets the page sizes subject to view scale. Overridden. See ScaledPageArea. (Overrides DocumentViewModel..::.ScaledPageArea.)
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Inherited from DocumentViewModel.)
VScrollBarLarge | Overridden. See VScrollBarLarge (Overrides DocumentViewModel..::.VScrollBarLarge.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Inherited from DocumentViewModel.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Inherited from DocumentViewModel.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Inherited from DocumentViewModel.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Inherited from DocumentViewModel.)
Zoom | Overridden. See Zoom. (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageNumber Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.PageNumber Property
ContinuedPageModel Class See Also Send Feedback
Overridden. See PageNumber.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override int PageNumber { get; set; }
Visual Basic (Declaration)
Public Overrides Property PageNumber As Integer
Visual C++
public:
virtual property int PageNumber {
    int get () override;
    void set (int value) override;
}

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ScaledPageArea Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.ScaledPageArea Property
ContinuedPageModel Class See Also Send Feedback
Gets the page sizes subject to view scale. Overridden. See ScaledPageArea.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override Size ScaledPageArea { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property ScaledPageArea As Size
Visual C++
protected:
virtual property Size ScaledPageArea {
    Size get () override;
}

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarLarge Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ContinuedPageModel..::.VScrollBarLarge Property
ContinuedPageModel Class See Also Send Feedback
Overridden. See VScrollBarLarge

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double VScrollBarLarge { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarLarge As Double
Visual C++
public:
virtual property double VScrollBarLarge {
    double get () override;
}

See Also

ContinuedPageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Credential Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Credential Class
Members See Also Send Feedback
Represents credential for a DataSource

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class Credential
Visual Basic (Declaration)
Public Class Credential
Visual C++
public ref class Credential

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Credential

See Also

Credential Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Credential Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Credential Members
Credential Class Constructors Methods Properties See Also Send Feedback

The Credential type exposes the following members.

Constructors

Name | Description
Credential | Initializes a new instance of the Credential class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataSourceName | DataSource name.
Password | Password.
UserName | User name.

See Also

Credential Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Credential Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Credential Constructor
Credential Class See Also Send Feedback
Initializes a new instance of the Credential class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Credential()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Credential()

See Also

Credential Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Credential Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Credential Methods
Credential Class See Also Send Feedback

The Credential type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Credential Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Credential Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Credential Properties
Credential Class See Also Send Feedback

The Credential type exposes the following members.

Properties

Name | Description
DataSourceName | DataSource name.
Password | Password.
UserName | User name.

See Also

Credential Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DataSourceName Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Credential..::.DataSourceName Property
Credential Class See Also Send Feedback
DataSource name.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string DataSourceName { get; set; }
Visual Basic (Declaration)
Public Property DataSourceName As String
Visual C++
public:
property String^ DataSourceName {
    String^ get ();
    void set (String^ value);
}

See Also

Credential Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Password Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Credential..::.Password Property
Credential Class See Also Send Feedback
Password.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

Credential Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UserName Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Credential..::.UserName Property
Credential Class See Also Send Feedback
User name.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

Credential Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialParameterControl Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl Class
Members See Also Send Feedback
This class is intended to realize displaying Data-Sourse Credentials. Inherited from BaseParameterControl. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class CredentialParameterControl : BaseParameterControl
Visual Basic (Declaration)
Public Class CredentialParameterControl _
    Inherits BaseParameterControl
Visual C++
public ref class CredentialParameterControl : public BaseParameterControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.BaseParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.CredentialParameterControl

See Also

CredentialParameterControl Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialParameterControl Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl Members
CredentialParameterControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The CredentialParameterControl type exposes the following members.

Constructors

Name | Description
CredentialParameterControl | Initializes a new instance of the CredentialParameterControl class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
PasswordTextProperty | Identifies the PasswordText dependency property.
PromptTextProperty | Identifies the PromptText dependency property.
UsernameTextProperty | Identifies the UsernameText dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
PasswordText | Gets or sets the password label text. This is a dependency property.
PasswordValue | Gets or sets the password value.
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for data-source credential. This is a dependency property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
UsernameText | Gets or sets the username label text. This is a dependency property.
UsernameValue | Gets or sets the username value.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialParameterControl Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl Constructor
CredentialParameterControl Class See Also Send Feedback
Initializes a new instance of the CredentialParameterControl class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public CredentialParameterControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CredentialParameterControl()

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialParameterControl Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl Fields
CredentialParameterControl Class See Also Send Feedback

The CredentialParameterControl type exposes the following members.

Fields

Name | Description
PasswordTextProperty | Identifies the PasswordText dependency property.
PromptTextProperty | Identifies the PromptText dependency property.
UsernameTextProperty | Identifies the UsernameText dependency property.

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PasswordTextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl..::.PasswordTextProperty Field
CredentialParameterControl Class See Also Send Feedback
Identifies the PasswordText dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty PasswordTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly PasswordTextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PasswordTextProperty

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PromptTextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl..::.PromptTextProperty Field
CredentialParameterControl Class See Also Send Feedback
Identifies the PromptText dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty PromptTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly PromptTextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PromptTextProperty

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UsernameTextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl..::.UsernameTextProperty Field
CredentialParameterControl Class See Also Send Feedback
Identifies the UsernameText dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty UsernameTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly UsernameTextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ UsernameTextProperty

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialParameterControl Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl Methods
CredentialParameterControl Class See Also Send Feedback

The CredentialParameterControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl..::.OnApplyTemplate Method
CredentialParameterControl Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetFocus Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl..::.SetFocus Method
CredentialParameterControl Class See Also Send Feedback
Overridden. See SetFocus()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void SetFocus()
Visual Basic (Declaration)
Public Overrides Sub SetFocus
Visual C++
public:
virtual void SetFocus() override

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialParameterControl Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl Properties
CredentialParameterControl Class See Also Send Feedback

The CredentialParameterControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
PasswordText | Gets or sets the password label text. This is a dependency property.
PasswordValue | Gets or sets the password value.
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for data-source credential. This is a dependency property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
UsernameText | Gets or sets the username label text. This is a dependency property.
UsernameValue | Gets or sets the username value.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PasswordText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl..::.PasswordText Property
CredentialParameterControl Class See Also Send Feedback
Gets or sets the password label text. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string PasswordText { get; set; }
Visual Basic (Declaration)
Public Property PasswordText As String
Visual C++
public:
property String^ PasswordText {
    String^ get ();
    void set (String^ value);
}

Field Value

The password label text.

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PasswordValue Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl..::.PasswordValue Property
CredentialParameterControl Class See Also Send Feedback
Gets or sets the password value.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string PasswordValue { get; set; }
Visual Basic (Declaration)
Public Property PasswordValue As String
Visual C++
public:
property String^ PasswordValue {
    String^ get ();
    void set (String^ value);
}

Field Value

The password value.

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PromptText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl..::.PromptText Property
CredentialParameterControl Class See Also Send Feedback
Gets or sets the prompt text for data-source credential. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string PromptText { get; set; }
Visual Basic (Declaration)
Public Property PromptText As String
Visual C++
public:
property String^ PromptText {
    String^ get ();
    void set (String^ value);
}

Field Value

The prompt text.

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UsernameText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl..::.UsernameText Property
CredentialParameterControl Class See Also Send Feedback
Gets or sets the username label text. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string UsernameText { get; set; }
Visual Basic (Declaration)
Public Property UsernameText As String
Visual C++
public:
property String^ UsernameText {
    String^ get ();
    void set (String^ value);
}

Field Value

The username label text.

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UsernameValue Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl..::.UsernameValue Property
CredentialParameterControl Class See Also Send Feedback
Gets or sets the username value.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string UsernameValue { get; set; }
Visual Basic (Declaration)
Public Property UsernameValue As String
Visual C++
public:
property String^ UsernameValue {
    String^ get ();
    void set (String^ value);
}

Field Value

The username value.

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialParameterControl Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialParameterControl Events
CredentialParameterControl Class See Also Send Feedback

The CredentialParameterControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

CredentialParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialsManager Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialsManager Class
Members See Also Send Feedback
The class wich realizes a credentials storage and management functionality.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class CredentialsManager
Visual Basic (Declaration)
Public Class CredentialsManager
Visual C++
public ref class CredentialsManager

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.CredentialsManager

See Also

CredentialsManager Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialsManager Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialsManager Members
CredentialsManager Class Methods Properties See Also Send Feedback

The CredentialsManager type exposes the following members.

Methods

Name | Description
AddCredential | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCredential | Get the credentials for specific data source.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Instance | The CredentialsManager instance.

See Also

CredentialsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialsManager Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialsManager Methods
CredentialsManager Class See Also Send Feedback

The CredentialsManager type exposes the following members.

Methods

Name | Description
AddCredential | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCredential | Get the credentials for specific data source.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CredentialsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AddCredential Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialsManager..::.AddCredential Method
CredentialsManager Class See Also Send Feedback

Overload List

Name | Description
AddCredential(ReportDataSourceCredential) | Add a credentials.
AddCredential(String, String, String) | Add a credentials.

See Also

CredentialsManager Class
CredentialsManager Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AddCredential Method (ReportDataSourceCredential)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialsManager..::.AddCredential Method (ReportDataSourceCredential)
CredentialsManager Class See Also Send Feedback
Add a credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void AddCredential(
    ReportDataSourceCredential credential
)
Visual Basic (Declaration)
Public Sub AddCredential ( _
    credential As ReportDataSourceCredential _
)
Visual C++
public:
void AddCredential(
    ReportDataSourceCredential^ credential
)

Parameters

credential
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ReportDataSourceCredential
A ReportDataSourceCredential class.

See Also

CredentialsManager Class
AddCredential Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AddCredential Method (String, String, String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialsManager..::.AddCredential Method (String, String, String)
CredentialsManager Class See Also Send Feedback
Add a credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void AddCredential(
    string dataSourceName,
    string userName,
    string password
)
Visual Basic (Declaration)
Public Sub AddCredential ( _
    dataSourceName As String, _
    userName As String, _
    password As String _
)
Visual C++
public:
void AddCredential(
    String^ dataSourceName,
    String^ userName,
    String^ password
)

Parameters

dataSourceName
Type: System..::.String
A data source name.
userName
Type: System..::.String
A user name.
password
Type: System..::.String
A password assotiated with the user.

See Also

CredentialsManager Class
AddCredential Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GetCredential Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialsManager..::.GetCredential Method
CredentialsManager Class See Also Send Feedback
Get the credentials for specific data source.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportDataSourceCredential GetCredential(
    string dataSourceName
)
Visual Basic (Declaration)
Public Function GetCredential ( _
    dataSourceName As String _
) As ReportDataSourceCredential
Visual C++
public:
ReportDataSourceCredential^ GetCredential(
    String^ dataSourceName
)

Parameters

dataSourceName
Type: System..::.String
The data source name.

Return Value

A ReportDataSourceCredential class.

See Also

CredentialsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialsManager Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialsManager Properties
CredentialsManager Class See Also Send Feedback

The CredentialsManager type exposes the following members.

Properties

Name | Description
Instance | The CredentialsManager instance.

See Also

CredentialsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Instance Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CredentialsManager..::.Instance Property
CredentialsManager Class See Also Send Feedback
The CredentialsManager instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static CredentialsManager Instance { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As CredentialsManager
Visual C++
public:
static property CredentialsManager^ Instance {
    CredentialsManager^ get ();
}

See Also

CredentialsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Cursor Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor Class
Members See Also Send Feedback
A cursor class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class Cursor : Control
Visual Basic (Declaration)
Public Class Cursor _
    Inherits Control
Visual C++
public ref class Cursor : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.Cursor

See Also

Cursor Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Cursor Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor Members
Cursor Class Constructors Methods Fields Properties Events See Also Send Feedback

The Cursor type exposes the following members.

Constructors

Name | Description
Cursor | Initializes a new instance of the Cursor class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CenterPointXProperty | Identifies the CenterPointX dependency property.
CenterPointYProperty | Identifies the CenterPointY dependency property.
CursorImageSourceProperty | Identifies the CursorImageSource dependency property.
IsCursorMouseDownProperty | Identifies the IsCursorMouseDown dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
CenterPointX | Gets or sets X coordinate of the cursor pointer on the image. Takes values from 0 to 1. This is a dependency property.
CenterPointY | Gets or sets Y coordinate of the cursor pointer on the image. Takes values from 0 to 1. This is a dependency property.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
CursorImageSource | Gets or sets the cursor image. This is a dependency property.
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsCursorMouseDown | Gets or sets the property which indicates that left mouse button is pressed. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Cursor Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor Constructor
Cursor Class See Also Send Feedback
Initializes a new instance of the Cursor class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Cursor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Cursor()

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Cursor Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor Fields
Cursor Class See Also Send Feedback

The Cursor type exposes the following members.

Fields

Name | Description
CenterPointXProperty | Identifies the CenterPointX dependency property.
CenterPointYProperty | Identifies the CenterPointY dependency property.
CursorImageSourceProperty | Identifies the CursorImageSource dependency property.
IsCursorMouseDownProperty | Identifies the IsCursorMouseDown dependency property.

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CenterPointXProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor..::.CenterPointXProperty Field
Cursor Class See Also Send Feedback
Identifies the CenterPointX dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static DependencyProperty CenterPointXProperty
Visual Basic (Declaration)
Public Shared CenterPointXProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ CenterPointXProperty

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CenterPointYProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor..::.CenterPointYProperty Field
Cursor Class See Also Send Feedback
Identifies the CenterPointY dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static DependencyProperty CenterPointYProperty
Visual Basic (Declaration)
Public Shared CenterPointYProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ CenterPointYProperty

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CursorImageSourceProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor..::.CursorImageSourceProperty Field
Cursor Class See Also Send Feedback
Identifies the CursorImageSource dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static DependencyProperty CursorImageSourceProperty
Visual Basic (Declaration)
Public Shared CursorImageSourceProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ CursorImageSourceProperty

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsCursorMouseDownProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor..::.IsCursorMouseDownProperty Field
Cursor Class See Also Send Feedback
Identifies the IsCursorMouseDown dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static DependencyProperty IsCursorMouseDownProperty
Visual Basic (Declaration)
Public Shared IsCursorMouseDownProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ IsCursorMouseDownProperty

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Cursor Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor Methods
Cursor Class See Also Send Feedback

The Cursor type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Cursor Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor Properties
Cursor Class See Also Send Feedback

The Cursor type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
CenterPointX | Gets or sets X coordinate of the cursor pointer on the image. Takes values from 0 to 1. This is a dependency property.
CenterPointY | Gets or sets Y coordinate of the cursor pointer on the image. Takes values from 0 to 1. This is a dependency property.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
CursorImageSource | Gets or sets the cursor image. This is a dependency property.
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsCursorMouseDown | Gets or sets the property which indicates that left mouse button is pressed. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CenterPointX Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor..::.CenterPointX Property
Cursor Class See Also Send Feedback
Gets or sets X coordinate of the cursor pointer on the image. Takes values from 0 to 1. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double CenterPointX { get; set; }
Visual Basic (Declaration)
Public Property CenterPointX As Double
Visual C++
public:
property double CenterPointX {
    double get ();
    void set (double value);
}

Field Value

The X coordinate of the cursor pointer on the image.

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CenterPointY Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor..::.CenterPointY Property
Cursor Class See Also Send Feedback
Gets or sets Y coordinate of the cursor pointer on the image. Takes values from 0 to 1. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double CenterPointY { get; set; }
Visual Basic (Declaration)
Public Property CenterPointY As Double
Visual C++
public:
property double CenterPointY {
    double get ();
    void set (double value);
}

Field Value

The Y coordinate of the cursor pointer on the image.

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CursorImageSource Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor..::.CursorImageSource Property
Cursor Class See Also Send Feedback
Gets or sets the cursor image. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ImageSource CursorImageSource { get; set; }
Visual Basic (Declaration)
Public Property CursorImageSource As ImageSource
Visual C++
public:
property ImageSource^ CursorImageSource {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Field Value

The cursor image source.

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsCursorMouseDown Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor..::.IsCursorMouseDown Property
Cursor Class See Also Send Feedback
Gets or sets the property which indicates that left mouse button is pressed. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsCursorMouseDown { get; set; }
Visual Basic (Declaration)
Public Property IsCursorMouseDown As Boolean
Visual C++
public:
property bool IsCursorMouseDown {
    bool get ();
    void set (bool value);
}

Field Value

true if left mouse button is pressed; otherwise, false.

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Cursor Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Cursor Events
Cursor Class See Also Send Feedback

The Cursor type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Cursor Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CursorLayer Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer Class
Members See Also Send Feedback
A layer class where cursor is displayed. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class CursorLayer : Canvas
Visual Basic (Declaration)
Public Class CursorLayer _
    Inherits Canvas
Visual C++
public ref class CursorLayer : public Canvas

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
System.Windows.Controls..::.Canvas
PerpetuumSoft.ReportingServices.Viewer.Client..::.CursorLayer

See Also

CursorLayer Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CursorLayer Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer Members
CursorLayer Class Constructors Methods Properties Events See Also Send Feedback

The CursorLayer type exposes the following members.

Constructors

Name | Description
CursorLayer | Initializes a new instance of the CursorLayer class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from Canvas.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from Canvas.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnMouseDown | Occurs when the mouse left button is pressed when the pointer is in report viewer bounds.
OnMouseLeave | Occurs when the pointer leaves report viewer bounds.
OnMouseMove | Occurs when the pointer is moving in report viewer bounds.
OnMouseUp | Occurs when the mouse left button is released when the pointer is in report viewer bounds.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetCursor | Sets active cursor.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
CacheMode | (Inherited from UIElement.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
CurrentCursor | Gets or sets Cursor which is current cursor.
Cursor | (Inherited from FrameworkElement.)
CustomCursorsUsing | Gets or sets a value indicating if custom cursors are used.
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsCursorUnderHyperlink | Gets or sets the property which indicates that cursor is above the hyperlink.
IsHitTestVisible | (Inherited from UIElement.)
IsItemsHost | (Inherited from Panel.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
ViewManager | Gets or sets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CursorLayer Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer Constructor
CursorLayer Class See Also Send Feedback
Initializes a new instance of the CursorLayer class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public CursorLayer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CursorLayer()

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CursorLayer Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer Methods
CursorLayer Class See Also Send Feedback

The CursorLayer type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from Canvas.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from Canvas.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnMouseDown | Occurs when the mouse left button is pressed when the pointer is in report viewer bounds.
OnMouseLeave | Occurs when the pointer leaves report viewer bounds.
OnMouseMove | Occurs when the pointer is moving in report viewer bounds.
OnMouseUp | Occurs when the mouse left button is released when the pointer is in report viewer bounds.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetCursor | Sets active cursor.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnMouseDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer..::.OnMouseDown Method
CursorLayer Class See Also Send Feedback
Occurs when the mouse left button is pressed when the pointer is in report viewer bounds.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void OnMouseDown()
Visual Basic (Declaration)
Public Sub OnMouseDown
Visual C++
public:
void OnMouseDown()

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnMouseLeave Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer..::.OnMouseLeave Method
CursorLayer Class See Also Send Feedback
Occurs when the pointer leaves report viewer bounds.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void OnMouseLeave()
Visual Basic (Declaration)
Public Sub OnMouseLeave
Visual C++
public:
void OnMouseLeave()

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnMouseMove Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer..::.OnMouseMove Method
CursorLayer Class See Also Send Feedback
Occurs when the pointer is moving in report viewer bounds.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void OnMouseMove(
    Point position
)
Visual Basic (Declaration)
Public Sub OnMouseMove ( _
    position As Point _
)
Visual C++
public:
void OnMouseMove(
    Point position
)

Parameters

position
Type: System.Windows..::.Point
The position. The instance of Point class.

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnMouseUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer..::.OnMouseUp Method
CursorLayer Class See Also Send Feedback
Occurs when the mouse left button is released when the pointer is in report viewer bounds.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void OnMouseUp()
Visual Basic (Declaration)
Public Sub OnMouseUp
Visual C++
public:
void OnMouseUp()

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetCursor Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer..::.SetCursor Method
CursorLayer Class See Also Send Feedback
Sets active cursor.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public virtual void SetCursor(
    BitmapImage bitmapImage,
    double centerX,
    double centerY
)
Visual Basic (Declaration)
Public Overridable Sub SetCursor ( _
    bitmapImage As BitmapImage, _
    centerX As Double, _
    centerY As Double _
)
Visual C++
public:
virtual void SetCursor(
    BitmapImage^ bitmapImage,
    double centerX,
    double centerY
)

Parameters

bitmapImage
Type: System.Windows.Media.Imaging..::.BitmapImage
The bitmap image. The instance of BitmapImage class.
centerX
Type: System..::.Double
The center X.
centerY
Type: System..::.Double
The center Y.

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CursorLayer Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer Properties
CursorLayer Class See Also Send Feedback

The CursorLayer type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
CacheMode | (Inherited from UIElement.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
CurrentCursor | Gets or sets Cursor which is current cursor.
Cursor | (Inherited from FrameworkElement.)
CustomCursorsUsing | Gets or sets a value indicating if custom cursors are used.
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsCursorUnderHyperlink | Gets or sets the property which indicates that cursor is above the hyperlink.
IsHitTestVisible | (Inherited from UIElement.)
IsItemsHost | (Inherited from Panel.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
ViewManager | Gets or sets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CurrentCursor Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer..::.CurrentCursor Property
CursorLayer Class See Also Send Feedback
Gets or sets Cursor which is current cursor.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Cursor CurrentCursor { get; set; }
Visual Basic (Declaration)
Public Property CurrentCursor As Cursor
Visual C++
public:
property Cursor^ CurrentCursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

Field Value

The current cursor.

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CustomCursorsUsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer..::.CustomCursorsUsing Property
CursorLayer Class See Also Send Feedback
Gets or sets a value indicating if custom cursors are used.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool CustomCursorsUsing { get; set; }
Visual Basic (Declaration)
Public Property CustomCursorsUsing As Boolean
Visual C++
public:
property bool CustomCursorsUsing {
    bool get ();
    void set (bool value);
}

Field Value

true if custom cursors are used; otherwise, false.

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsCursorUnderHyperlink Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer..::.IsCursorUnderHyperlink Property
CursorLayer Class See Also Send Feedback
Gets or sets the property which indicates that cursor is above the hyperlink.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsCursorUnderHyperlink { get; internal set; }
Visual Basic (Declaration)
Public Property IsCursorUnderHyperlink As Boolean
Visual C++
public:
property bool IsCursorUnderHyperlink {
    bool get ();
    void set (bool value);
}

Field Value

true if the cursor is above the hyperlink; otherwise, false.

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer..::.ViewManager Property
CursorLayer Class See Also Send Feedback
Gets or sets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewManager ViewManager { get; set; }
Visual Basic (Declaration)
Public Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
    void set (ViewManager^ value);
}

Field Value

The view manager.

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CursorLayer Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CursorLayer Events
CursorLayer Class See Also Send Feedback

The CursorLayer type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

CursorLayer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DateTimeParameterControl Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl Class
Members See Also Send Feedback
The DateTimeParameterControl class is intended to encapsulate logic for report parameter controls with DateTime type and with single-value selection and without list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class DateTimeParameterControl : ReportParameterControl
Visual Basic (Declaration)
Public Class DateTimeParameterControl _
    Inherits ReportParameterControl
Visual C++
public ref class DateTimeParameterControl : public ReportParameterControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.BaseParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.DateTimeParameterControl

See Also

DateTimeParameterControl Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DateTimeParameterControl Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl Members
DateTimeParameterControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The DateTimeParameterControl type exposes the following members.

Constructors

Name | Description
DateTimeParameterControl | Initializes a new instance of the DateTimeParameterControl class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNullable | Gets or sets a value indicates whether the value of the parameter can be null.
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DateTimeParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DateTimeParameterControl Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl Constructor
DateTimeParameterControl Class See Also Send Feedback
Initializes a new instance of the DateTimeParameterControl class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DateTimeParameterControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateTimeParameterControl()

See Also

DateTimeParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DateTimeParameterControl Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl Fields
DateTimeParameterControl Class See Also Send Feedback

The DateTimeParameterControl type exposes the following members.

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

See Also

DateTimeParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DateTimeParameterControl Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl Methods
DateTimeParameterControl Class See Also Send Feedback

The DateTimeParameterControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DateTimeParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl..::.OnApplyTemplate Method
DateTimeParameterControl Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

DateTimeParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetFocus Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl..::.SetFocus Method
DateTimeParameterControl Class See Also Send Feedback
Overridden. See SetFocus()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void SetFocus()
Visual Basic (Declaration)
Public Overrides Sub SetFocus
Visual C++
public:
virtual void SetFocus() override

See Also

DateTimeParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DateTimeParameterControl Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl Properties
DateTimeParameterControl Class See Also Send Feedback

The DateTimeParameterControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNullable | Gets or sets a value indicates whether the value of the parameter can be null.
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DateTimeParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsNullable Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl..::.IsNullable Property
DateTimeParameterControl Class See Also Send Feedback
Gets or sets a value indicates whether the value of the parameter can be null.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsNullable { get; set; }
Visual Basic (Declaration)
Public Property IsNullable As Boolean
Visual C++
public:
property bool IsNullable {
    bool get ();
    void set (bool value);
}

Field Value

true if the value of the parameter can be null; otherwise, false.

See Also

DateTimeParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Values Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl..::.Values Property
DateTimeParameterControl Class See Also Send Feedback
Overridden. See Values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override List<ValidValue> Values { get; set; }
Visual Basic (Declaration)
Public Overrides Property Values As List(Of ValidValue)
Visual C++
public:
virtual property List<ValidValue^>^ Values {
    List<ValidValue^>^ get () override;
    void set (List<ValidValue^>^ value) override;
}

See Also

DateTimeParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DateTimeParameterControl Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DateTimeParameterControl Events
DateTimeParameterControl Class See Also Send Feedback

The DateTimeParameterControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DateTimeParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DisabledTool Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool Class
Members See Also Send Feedback
Realizes the tool which makes available any actions with the report. Inherited from Tool.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public sealed class DisabledTool : Tool
Visual Basic (Declaration)
Public NotInheritable Class DisabledTool _
    Inherits Tool
Visual C++
public ref class DisabledTool sealed : public Tool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
PerpetuumSoft.ReportingServices.Viewer.Client..::.DisabledTool

See Also

DisabledTool Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DisabledTool Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool Members
DisabledTool Class Constructors Methods Properties See Also Send Feedback

The DisabledTool type exposes the following members.

Constructors

Name | Description
DisabledTool | Initializes a new instance of the DisabledTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Overrides Tool..::.KeyDown(KeyEventArgs).)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Overrides Tool..::.KeyUp(KeyEventArgs).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides Tool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseDown(MouseEventArgs). (Overrides Tool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides Tool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides Tool..::.MouseWheel(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

DisabledTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DisabledTool Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool Constructor
DisabledTool Class See Also Send Feedback
Initializes a new instance of the DisabledTool class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DisabledTool()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DisabledTool()

See Also

DisabledTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DisabledTool Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool Methods
DisabledTool Class See Also Send Feedback

The DisabledTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Overrides Tool..::.KeyDown(KeyEventArgs).)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Overrides Tool..::.KeyUp(KeyEventArgs).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides Tool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseDown(MouseEventArgs). (Overrides Tool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides Tool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides Tool..::.MouseWheel(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

See Also

DisabledTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


KeyDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool..::.KeyDown Method
DisabledTool Class See Also Send Feedback
Overridden. See KeyDown(KeyEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void KeyDown(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub KeyDown ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyDown(
    KeyEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

DisabledTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


KeyUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool..::.KeyUp Method
DisabledTool Class See Also Send Feedback
Overridden. See KeyUp(KeyEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void KeyUp(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub KeyUp ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyUp(
    KeyEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

DisabledTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool..::.MouseDown Method
DisabledTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DisabledTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseMove Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool..::.MouseMove Method
DisabledTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DisabledTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool..::.MouseUp Method
DisabledTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DisabledTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheel Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool..::.MouseWheel Method
DisabledTool Class See Also Send Feedback
Overridden. See MouseWheel(Double).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public Overrides Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) override

Parameters

delta
Type: System..::.Double

See Also

DisabledTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DisabledTool Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DisabledTool Properties
DisabledTool Class See Also Send Feedback

The DisabledTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

DisabledTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Document Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Document Class
Members See Also Send Feedback
A class which includes report data.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Document

See Also

Document Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Document Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Document Members
Document Class Constructors Methods Properties See Also Send Feedback

The Document type exposes the following members.

Constructors

Name | Description
Document | Initializes a new instance of the Document class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id | Gets or sets document ID.
Pages | Gets or sets IList<(Of <(T>)>) which are report pages.
Title | Gets or sets document title.

See Also

Document Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Document Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Document Constructor
Document Class See Also Send Feedback
Initializes a new instance of the Document class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Document()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Document()

See Also

Document Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Document Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Document Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Document Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

Name | Description
Id | Gets or sets document ID.
Pages | Gets or sets IList<(Of <(T>)>) which are report pages.
Title | Gets or sets document title.

See Also

Document Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Id Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Document..::.Id Property
Document Class See Also Send Feedback
Gets or sets document ID.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Field Value

The document ID.

See Also

Document Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Pages Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Document..::.Pages Property
Document Class See Also Send Feedback
Gets or sets IList<(Of <(T>)>) which are report pages.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public IList<Page> Pages { get; private set; }
Visual Basic (Declaration)
Public Property Pages As IList(Of Page)
Visual C++
public:
property IList<Page^>^ Pages {
    IList<Page^>^ get ();
    void set (IList<Page^>^ value);
}

Field Value

The pages.

See Also

Document Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Title Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Document..::.Title Property
Document Class See Also Send Feedback
Gets or sets document title.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Field Value

The title text.

See Also

Document Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentLoadedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentLoadedEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when report is loaded.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class DocumentLoadedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DocumentLoadedEventArgs _
    Inherits EventArgs
Visual C++
public ref class DocumentLoadedEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.ReportingServices.Viewer.Client..::.DocumentLoadedEventArgs

See Also

DocumentLoadedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentLoadedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentLoadedEventArgs Members
DocumentLoadedEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentLoadedEventArgs type exposes the following members.

Constructors

Name | Description
DocumentLoadedEventArgs | Initializes a new instance of the DocumentLoadedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Document | Gets or sets Document which is a document.

See Also

DocumentLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentLoadedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentLoadedEventArgs Constructor
DocumentLoadedEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentLoadedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DocumentLoadedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentLoadedEventArgs()

See Also

DocumentLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentLoadedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentLoadedEventArgs Methods
DocumentLoadedEventArgs Class See Also Send Feedback

The DocumentLoadedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentLoadedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentLoadedEventArgs Properties
DocumentLoadedEventArgs Class See Also Send Feedback

The DocumentLoadedEventArgs type exposes the following members.

Properties

Name | Description
Document | Gets or sets Document which is a document.

See Also

DocumentLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Document Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentLoadedEventArgs..::.Document Property
DocumentLoadedEventArgs Class See Also Send Feedback
Gets or sets Document which is a document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Document Document { get; set; }
Visual Basic (Declaration)
Public Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
    void set (Document^ value);
}

Field Value

The document.

See Also

DocumentLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentPresenter Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter Class
Members See Also Send Feedback
Report presenter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class DocumentPresenter : Control
Visual Basic (Declaration)
Public Class DocumentPresenter _
    Inherits Control
Visual C++
public ref class DocumentPresenter : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.DocumentPresenter

See Also

DocumentPresenter Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentPresenter Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter Members
DocumentPresenter Class Constructors Methods Properties Events See Also Send Feedback

The DocumentPresenter type exposes the following members.

Constructors

Name | Description
DocumentPresenter | Initializes a new instance of the DocumentPresenter class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)
UpdateView | Updates the report view.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AdornersLayer | Gets Canvas which is the borders layout.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
ClientSize | Gets Size which is the сlient area size.
Clip | (Inherited from UIElement.)
ContentLayer | Gets Canvas which is the content layer.
Cursor | (Inherited from FrameworkElement.)
CustomCursorsUsing | Gets or sets a value indicating if custom cursors are used.
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Gets or sets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentPresenter Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter Constructor
DocumentPresenter Class See Also Send Feedback
Initializes a new instance of the DocumentPresenter class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DocumentPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentPresenter()

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentPresenter Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter Methods
DocumentPresenter Class See Also Send Feedback

The DocumentPresenter type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)
UpdateView | Updates the report view.

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter..::.OnApplyTemplate Method
DocumentPresenter Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateView Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter..::.UpdateView Method
DocumentPresenter Class See Also Send Feedback
Updates the report view.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void UpdateView()
Visual Basic (Declaration)
Public Sub UpdateView
Visual C++
public:
void UpdateView()

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentPresenter Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter Properties
DocumentPresenter Class See Also Send Feedback

The DocumentPresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AdornersLayer | Gets Canvas which is the borders layout.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
ClientSize | Gets Size which is the сlient area size.
Clip | (Inherited from UIElement.)
ContentLayer | Gets Canvas which is the content layer.
Cursor | (Inherited from FrameworkElement.)
CustomCursorsUsing | Gets or sets a value indicating if custom cursors are used.
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Gets or sets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AdornersLayer Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter..::.AdornersLayer Property
DocumentPresenter Class See Also Send Feedback
Gets Canvas which is the borders layout.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Canvas AdornersLayer { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdornersLayer As Canvas
Visual C++
public:
property Canvas^ AdornersLayer {
    Canvas^ get ();
}

Field Value

The borders layout.

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ClientSize Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter..::.ClientSize Property
DocumentPresenter Class See Also Send Feedback
Gets Size which is the сlient area size.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Size ClientSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientSize As Size
Visual C++
public:
property Size ClientSize {
    Size get ();
}

Field Value

The сlient area size.

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ContentLayer Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter..::.ContentLayer Property
DocumentPresenter Class See Also Send Feedback
Gets Canvas which is the content layer.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Canvas ContentLayer { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentLayer As Canvas
Visual C++
public:
property Canvas^ ContentLayer {
    Canvas^ get ();
}

Field Value

The content layer.

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CustomCursorsUsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter..::.CustomCursorsUsing Property
DocumentPresenter Class See Also Send Feedback
Gets or sets a value indicating if custom cursors are used.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool CustomCursorsUsing { get; set; }
Visual Basic (Declaration)
Public Property CustomCursorsUsing As Boolean
Visual C++
public:
property bool CustomCursorsUsing {
    bool get ();
    void set (bool value);
}

Field Value

true if custom cursors are used; otherwise, false.

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter..::.ViewManager Property
DocumentPresenter Class See Also Send Feedback
Gets or sets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewManager ViewManager { get; set; }
Visual Basic (Declaration)
Public Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
    void set (ViewManager^ value);
}

Field Value

The view manager.

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentPresenter Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentPresenter Events
DocumentPresenter Class See Also Send Feedback

The DocumentPresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DocumentPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentViewModel Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel Class
Members See Also Send Feedback
Report view model.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract class DocumentViewModel : ViewModel
Visual Basic (Declaration)
Public MustInherit Class DocumentViewModel _
    Inherits ViewModel
Visual C++
public ref class DocumentViewModel abstract : public ViewModel

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewModel
PerpetuumSoft.ReportingServices.Viewer.Client..::.DocumentViewModel
PerpetuumSoft.ReportingServices.Viewer.Client..::.ContinuedPageModel
PerpetuumSoft.ReportingServices.Viewer.Client..::.SinglePageModel

See Also

DocumentViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentViewModel Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel Members
DocumentViewModel Class Constructors Methods Fields Properties See Also Send Feedback

The DocumentViewModel type exposes the following members.

Constructors

Name | Description
DocumentViewModel | Initializes a new instance of the DocumentViewModel class.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Calculates the page location in the report preview area.
CalculateZoom | Calculates scale.
ChangeZoom | Overloaded.
Clone | Creates object clone. (Inherited from ViewModel.)
CreateStoryboard | Creates Storyboard for animation.
DeleteUnusedPages | Deletes the unused pages.
DocumentEnd | Performs switching to the end of the report. (Inherited from ViewModel.)
DocumentHome | Performs switching to the begining of the report. (Inherited from ViewModel.)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing.
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Gets the gap between pages.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Overrides ViewModel..::.GoToFirstPage()()().)
GoToLastPage | Overridden. See GoToLastPage()()(). (Overrides ViewModel..::.GoToLastPage()()().)
GoToNextPage | Overridden. See GoToNextPage()()(). (Overrides ViewModel..::.GoToNextPage()()().)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Overrides ViewModel..::.GoToPrevPage()()().)
HightlightSearchResult | Overridden. See HightlightSearchResult()()(). (Overrides ViewModel..::.HightlightSearchResult()()().)
Invalidate | Overloaded.
MakeClientSideSearch | Overridden. See MakeClientSideSearch(SearchResult, SearchResult). (Overrides ViewModel..::.MakeClientSideSearch(SearchResult, SearchResult).)
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides ViewModel..::.MouseWheel(Double).)
OnPageSizeChanged | Called when page size is changed.
PageDown | Overridden. See PageDown()()(). (Overrides ViewModel..::.PageDown()()().)
PageEnd | Performs switching to the bottom of the page. (Inherited from ViewModel.)
PageHome | Performs switching to the top of the page. (Inherited from ViewModel.)
PageUp | Overridden. See PageUp()()(). (Overrides ViewModel..::.PageUp()()().)
PanView | Overridden. See PanView(Point). (Overrides ViewModel..::.PanView(Point).)
RectToScreen | Gets the screen coordinates of the selected area.
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Overrides ViewModel..::.ResetSearchResult()()().)
SetupPage | Sets the selected page parameters.
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Overrides ViewModel..::.ShowSearchResult(ReportRegion).)
StartAnimation | Starts the animation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | Updates the content. (Inherited from ViewModel.)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Overrides ViewModel..::.ZoomWindow(Rect, Boolean).)

Fields

Name | Description
_searchResult |
Gap | Gets the gap between pages.
Margin | Gets page margins.

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Overrides ViewModel..::.CanGoToNextPage.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Overrides ViewModel..::.CanGoToPrevPage.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report.
HScrollBarActive | Overridden. See HScrollBarActive. (Overrides ViewModel..::.HScrollBarActive.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Overrides ViewModel..::.HScrollBarLarge.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Overrides ViewModel..::.HScrollBarMaximum.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Overrides ViewModel..::.HScrollBarPosition.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Overrides ViewModel..::.HScrollBarSmall.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Overrides ViewModel..::.HScrollBarViewPort.)
PageNumber | Gets or sets the page number. (Inherited from ViewModel.)
ScaledPageArea | Gets page view area.
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Overrides ViewModel..::.VScrollBarActive.)
VScrollBarLarge | Overridden. See VScrollBarLarge. (Overrides ViewModel..::.VScrollBarLarge.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Overrides ViewModel..::.VScrollBarMaximum.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Overrides ViewModel..::.VScrollBarPosition.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Overrides ViewModel..::.VScrollBarSmall.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Overrides ViewModel..::.VScrollBarViewPort.)
Zoom | Overridden. See Zoom. (Overrides ViewModel..::.Zoom.)

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentViewModel Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel Constructor
DocumentViewModel Class See Also Send Feedback
Initializes a new instance of the DocumentViewModel class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected DocumentViewModel(
    ViewManager viewManager
)
Visual Basic (Declaration)
Protected Sub New ( _
    viewManager As ViewManager _
)
Visual C++
protected:
DocumentViewModel(
    ViewManager^ viewManager
)

Parameters

viewManager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The view manager.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentViewModel Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel Fields
DocumentViewModel Class See Also Send Feedback

The DocumentViewModel type exposes the following members.

Fields

Name | Description
_searchResult |
Gap | Gets the gap between pages.
Margin | Gets page margins.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


_searchResult Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::._searchResult Field
DocumentViewModel Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected internal SearchResult _searchResult
Visual Basic (Declaration)
Protected Friend _searchResult As SearchResult
Visual C++
protected public:
SearchResult^ _searchResult

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Gap Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.Gap Field
DocumentViewModel Class See Also Send Feedback
Gets the gap between pages.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected readonly double Gap
Visual Basic (Declaration)
Protected ReadOnly Gap As Double
Visual C++
protected:
initonly double Gap

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Margin Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.Margin Field
DocumentViewModel Class See Also Send Feedback
Gets page margins.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected readonly double Margin
Visual Basic (Declaration)
Protected ReadOnly Margin As Double
Visual C++
protected:
initonly double Margin

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentViewModel Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel Methods
DocumentViewModel Class See Also Send Feedback

The DocumentViewModel type exposes the following members.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Calculates the page location in the report preview area.
CalculateZoom | Calculates scale.
ChangeZoom | Overloaded.
Clone | Creates object clone. (Inherited from ViewModel.)
CreateStoryboard | Creates Storyboard for animation.
DeleteUnusedPages | Deletes the unused pages.
DocumentEnd | Performs switching to the end of the report. (Inherited from ViewModel.)
DocumentHome | Performs switching to the begining of the report. (Inherited from ViewModel.)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing.
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Gets the gap between pages.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Overrides ViewModel..::.GoToFirstPage()()().)
GoToLastPage | Overridden. See GoToLastPage()()(). (Overrides ViewModel..::.GoToLastPage()()().)
GoToNextPage | Overridden. See GoToNextPage()()(). (Overrides ViewModel..::.GoToNextPage()()().)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Overrides ViewModel..::.GoToPrevPage()()().)
HightlightSearchResult | Overridden. See HightlightSearchResult()()(). (Overrides ViewModel..::.HightlightSearchResult()()().)
Invalidate | Overloaded.
MakeClientSideSearch | Overridden. See MakeClientSideSearch(SearchResult, SearchResult). (Overrides ViewModel..::.MakeClientSideSearch(SearchResult, SearchResult).)
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides ViewModel..::.MouseWheel(Double).)
OnPageSizeChanged | Called when page size is changed.
PageDown | Overridden. See PageDown()()(). (Overrides ViewModel..::.PageDown()()().)
PageEnd | Performs switching to the bottom of the page. (Inherited from ViewModel.)
PageHome | Performs switching to the top of the page. (Inherited from ViewModel.)
PageUp | Overridden. See PageUp()()(). (Overrides ViewModel..::.PageUp()()().)
PanView | Overridden. See PanView(Point). (Overrides ViewModel..::.PanView(Point).)
RectToScreen | Gets the screen coordinates of the selected area.
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Overrides ViewModel..::.ResetSearchResult()()().)
SetupPage | Sets the selected page parameters.
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Overrides ViewModel..::.ShowSearchResult(ReportRegion).)
StartAnimation | Starts the animation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | Updates the content. (Inherited from ViewModel.)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Overrides ViewModel..::.ZoomWindow(Rect, Boolean).)

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CalculateOrigin Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.CalculateOrigin Method
DocumentViewModel Class See Also Send Feedback
Calculates the page location in the report preview area.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void CalculateOrigin()
Visual Basic (Declaration)
Protected Overridable Sub CalculateOrigin
Visual C++
protected:
virtual void CalculateOrigin()

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CalculateZoom Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.CalculateZoom Method
DocumentViewModel Class See Also Send Feedback
Calculates scale.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void CalculateZoom()
Visual Basic (Declaration)
Protected Sub CalculateZoom
Visual C++
protected:
void CalculateZoom()

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ChangeZoom Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.ChangeZoom Method
DocumentViewModel Class See Also Send Feedback

Overload List

Name | Description
ChangeZoom(ZoomMode, Boolean) | Overridden. See ChangeZoom(ZoomMode, Boolean). (Overrides ViewModel..::.ChangeZoom(ZoomMode, Boolean).)
ChangeZoom(Double, Boolean) | Performs scale and scale mode changing. (Inherited from ViewModel.)
ChangeZoom(Point, Double, Boolean) | Overridden. See ChangeZoom(Point, Double, Boolean). (Overrides ViewModel..::.ChangeZoom(Point, Double, Boolean).)

See Also

DocumentViewModel Class
DocumentViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ChangeZoom Method (ZoomMode, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.ChangeZoom Method (ZoomMode, Boolean)
DocumentViewModel Class See Also Send Feedback
Overridden. See ChangeZoom(ZoomMode, Boolean).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void ChangeZoom(
    ZoomMode mode,
    bool useAnimation
)
Visual Basic (Declaration)
Public Overrides Sub ChangeZoom ( _
    mode As ZoomMode, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ChangeZoom(
    ZoomMode mode,
    bool useAnimation
) override

Parameters

mode
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomMode
useAnimation
Type: System..::.Boolean

See Also

DocumentViewModel Class
ChangeZoom Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ChangeZoom Method (Point, Double, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.ChangeZoom Method (Point, Double, Boolean)
DocumentViewModel Class See Also Send Feedback
Overridden. See ChangeZoom(Point, Double, Boolean).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void ChangeZoom(
    Point center,
    double scale,
    bool useAnimation
)
Visual Basic (Declaration)
Public Overrides Sub ChangeZoom ( _
    center As Point, _
    scale As Double, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ChangeZoom(
    Point center,
    double scale,
    bool useAnimation
) override

Parameters

center
Type: System.Windows..::.Point
scale
Type: System..::.Double
useAnimation
Type: System..::.Boolean

See Also

DocumentViewModel Class
ChangeZoom Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CreateStoryboard Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.CreateStoryboard Method
DocumentViewModel Class See Also Send Feedback
Creates Storyboard for animation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected Storyboard CreateStoryboard(
    bool useAnimation
)
Visual Basic (Declaration)
Protected Function CreateStoryboard ( _
    useAnimation As Boolean _
) As Storyboard
Visual C++
protected:
Storyboard^ CreateStoryboard(
    bool useAnimation
)

Parameters

useAnimation
Type: System..::.Boolean
If it is set to true then it is used animation to change view.

Return Value

The storyboard. The instance of Storyboard class.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DeleteUnusedPages Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.DeleteUnusedPages Method
DocumentViewModel Class See Also Send Feedback
Deletes the unused pages.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void DeleteUnusedPages(
    int firstPage,
    int lastPage
)
Visual Basic (Declaration)
Protected Sub DeleteUnusedPages ( _
    firstPage As Integer, _
    lastPage As Integer _
)
Visual C++
protected:
void DeleteUnusedPages(
    int firstPage,
    int lastPage
)

Parameters

firstPage
Type: System..::.Int32
The first page number.
lastPage
Type: System..::.Int32
The last page number.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


EnsurePageView Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.EnsurePageView Method
DocumentViewModel Class See Also Send Feedback
Creates the presenter for the selected page if the presenter is missing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected PagePresenter EnsurePageView(
    int pageNumber
)
Visual Basic (Declaration)
Protected Function EnsurePageView ( _
    pageNumber As Integer _
) As PagePresenter
Visual C++
protected:
PagePresenter^ EnsurePageView(
    int pageNumber
)

Parameters

pageNumber
Type: System..::.Int32
The page number.

Return Value

Report pages presenter. The instance of PagePresenter class.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


EnsureVisible Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.EnsureVisible Method
DocumentViewModel Class See Also Send Feedback

Overload List

Name | Description
EnsureVisible(ReportRegion) | Shifts the visible area of the screen to guarantee that the specified report is visible. (Inherited from ViewModel.)
EnsureVisible(ReportRegion, Boolean) | Shifts the visible area of the screen to guarantee that the specified report is visible. (Inherited from ViewModel.)

See Also

DocumentViewModel Class
DocumentViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GetGap Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.GetGap Method
DocumentViewModel Class See Also Send Feedback
Gets the gap between pages.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected abstract Size GetGap(
    Point center
)
Visual Basic (Declaration)
Protected MustOverride Function GetGap ( _
    center As Point _
) As Size
Visual C++
protected:
virtual Size GetGap(
    Point center
) abstract

Parameters

center
Type: System.Windows..::.Point
The center of report preview area. The instance of Point class.

Return Value

The size of gap. The instance of Size class.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GoToFirstPage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.GoToFirstPage Method
DocumentViewModel Class See Also Send Feedback
Overridden. See GoToFirstPage()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void GoToFirstPage()
Visual Basic (Declaration)
Public Overrides Sub GoToFirstPage
Visual C++
public:
virtual void GoToFirstPage() override

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GoToLastPage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.GoToLastPage Method
DocumentViewModel Class See Also Send Feedback
Overridden. See GoToLastPage()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void GoToLastPage()
Visual Basic (Declaration)
Public Overrides Sub GoToLastPage
Visual C++
public:
virtual void GoToLastPage() override

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GoToNextPage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.GoToNextPage Method
DocumentViewModel Class See Also Send Feedback
Overridden. See GoToNextPage()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void GoToNextPage()
Visual Basic (Declaration)
Public Overrides Sub GoToNextPage
Visual C++
public:
virtual void GoToNextPage() override

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GoToPrevPage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.GoToPrevPage Method
DocumentViewModel Class See Also Send Feedback
Overridden. See GoToPrevPage()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void GoToPrevPage()
Visual Basic (Declaration)
Public Overrides Sub GoToPrevPage
Visual C++
public:
virtual void GoToPrevPage() override

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HightlightSearchResult Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.HightlightSearchResult Method
DocumentViewModel Class See Also Send Feedback
Overridden. See HightlightSearchResult()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void HightlightSearchResult()
Visual Basic (Declaration)
Public Overrides Sub HightlightSearchResult
Visual C++
public:
virtual void HightlightSearchResult() override

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Invalidate Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.Invalidate Method
DocumentViewModel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates report viewer.
Invalidate(Boolean) | Invalidates report viewer.

See Also

DocumentViewModel Class
DocumentViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Invalidate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.Invalidate Method
DocumentViewModel Class See Also Send Feedback
Invalidates report viewer.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void Invalidate()
Visual Basic (Declaration)
Protected Sub Invalidate
Visual C++
protected:
void Invalidate()

See Also

DocumentViewModel Class
Invalidate Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Invalidate Method (Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.Invalidate Method (Boolean)
DocumentViewModel Class See Also Send Feedback
Invalidates report viewer.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void Invalidate(
    bool useAnimation
)
Visual Basic (Declaration)
Protected Sub Invalidate ( _
    useAnimation As Boolean _
)
Visual C++
protected:
void Invalidate(
    bool useAnimation
)

Parameters

useAnimation
Type: System..::.Boolean
If it is set to true then it is used animation to change view.

See Also

DocumentViewModel Class
Invalidate Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MakeClientSideSearch Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.MakeClientSideSearch Method
DocumentViewModel Class See Also Send Feedback
Overridden. See MakeClientSideSearch(SearchResult, SearchResult).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override bool MakeClientSideSearch(
    SearchResult oldSearchResult,
    SearchResult newSearchResult
)
Visual Basic (Declaration)
Public Overrides Function MakeClientSideSearch ( _
    oldSearchResult As SearchResult, _
    newSearchResult As SearchResult _
) As Boolean
Visual C++
public:
virtual bool MakeClientSideSearch(
    SearchResult^ oldSearchResult,
    SearchResult^ newSearchResult
) override

Parameters

oldSearchResult
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SearchResult
newSearchResult
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SearchResult

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MakeVisible Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.MakeVisible Method
DocumentViewModel Class See Also Send Feedback
Forces content to scroll until the coordinate space of a specific rectangle is visible.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void MakeVisible(
    ReportRegion region,
    bool alignTop
)
Visual Basic (Declaration)
Protected Sub MakeVisible ( _
    region As ReportRegion, _
    alignTop As Boolean _
)
Visual C++
protected:
void MakeVisible(
    ReportRegion region,
    bool alignTop
)

Parameters

region
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportRegion
The report region. The instance of ReportRegion class.
alignTop
Type: System..::.Boolean
If it is set to true then scrolling is to top align.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheel Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.MouseWheel Method
DocumentViewModel Class See Also Send Feedback
Overridden. See MouseWheel(Double).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public Overrides Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) override

Parameters

delta
Type: System..::.Double

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnPageSizeChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.OnPageSizeChanged Method
DocumentViewModel Class See Also Send Feedback
Called when page size is changed.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected virtual double OnPageSizeChanged()
Visual Basic (Declaration)
Protected Overridable Function OnPageSizeChanged As Double
Visual C++
protected:
virtual double OnPageSizeChanged()

Return Value

The delta for the page location correction.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.PageDown Method
DocumentViewModel Class See Also Send Feedback
Overridden. See PageDown()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void PageDown()
Visual Basic (Declaration)
Public Overrides Sub PageDown
Visual C++
public:
virtual void PageDown() override

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.PageUp Method
DocumentViewModel Class See Also Send Feedback
Overridden. See PageUp()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void PageUp()
Visual Basic (Declaration)
Public Overrides Sub PageUp
Visual C++
public:
virtual void PageUp() override

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PanView Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.PanView Method
DocumentViewModel Class See Also Send Feedback
Overridden. See PanView(Point).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void PanView(
    Point point
)
Visual Basic (Declaration)
Public Overrides Sub PanView ( _
    point As Point _
)
Visual C++
public:
virtual void PanView(
    Point point
) override

Parameters

point
Type: System.Windows..::.Point

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RectToScreen Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.RectToScreen Method
DocumentViewModel Class See Also Send Feedback
Gets the screen coordinates of the selected area.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected abstract Rect RectToScreen(
    ReportRegion region
)
Visual Basic (Declaration)
Protected MustOverride Function RectToScreen ( _
    region As ReportRegion _
) As Rect
Visual C++
protected:
virtual Rect RectToScreen(
    ReportRegion region
) abstract

Parameters

region
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportRegion
The report region. The instance of ReportRegion class.

Return Value

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ResetSearchResult Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.ResetSearchResult Method
DocumentViewModel Class See Also Send Feedback
Overridden. See ResetSearchResult()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void ResetSearchResult()
Visual Basic (Declaration)
Public Overrides Sub ResetSearchResult
Visual C++
public:
virtual void ResetSearchResult() override

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetupPage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.SetupPage Method
DocumentViewModel Class See Also Send Feedback
Sets the selected page parameters.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void SetupPage(
    int pageNumber,
    double scale,
    Point pos,
    double oldScale,
    Point oldPos,
    Storyboard storyboard
)
Visual Basic (Declaration)
Protected Sub SetupPage ( _
    pageNumber As Integer, _
    scale As Double, _
    pos As Point, _
    oldScale As Double, _
    oldPos As Point, _
    storyboard As Storyboard _
)
Visual C++
protected:
void SetupPage(
    int pageNumber,
    double scale,
    Point pos,
    double oldScale,
    Point oldPos,
    Storyboard^ storyboard
)

Parameters

pageNumber
Type: System..::.Int32
The page number.
scale
Type: System..::.Double
The scale.
pos
Type: System.Windows..::.Point
The position. The instance of Point class.
oldScale
Type: System..::.Double
The old scale.
oldPos
Type: System.Windows..::.Point
The old position. The instance of Point class.
storyboard
Type: System.Windows.Media.Animation..::.Storyboard
The storyboard. The instance of Storyboard class.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ShowSearchResult Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.ShowSearchResult Method
DocumentViewModel Class See Also Send Feedback
Overridden. See ShowSearchResult(ReportRegion).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void ShowSearchResult(
    ReportRegion region
)
Visual Basic (Declaration)
Public Overrides Sub ShowSearchResult ( _
    region As ReportRegion _
)
Visual C++
public:
virtual void ShowSearchResult(
    ReportRegion region
) override

Parameters

region
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportRegion

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StartAnimation Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.StartAnimation Method
DocumentViewModel Class See Also Send Feedback
Starts the animation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void StartAnimation(
    Storyboard storyboard
)
Visual Basic (Declaration)
Protected Sub StartAnimation ( _
    storyboard As Storyboard _
)
Visual C++
protected:
void StartAnimation(
    Storyboard^ storyboard
)

Parameters

storyboard
Type: System.Windows.Media.Animation..::.Storyboard
The storyboard. The instance of Storyboard class.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomIn Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.ZoomIn Method
DocumentViewModel Class See Also Send Feedback

Overload List

Name | Description
ZoomIn(Boolean) | Performs zoom in. (Inherited from ViewModel.)
ZoomIn(Point, Boolean) | Performs zoom in. (Inherited from ViewModel.)

See Also

DocumentViewModel Class
DocumentViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOut Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.ZoomOut Method
DocumentViewModel Class See Also Send Feedback

Overload List

Name | Description
ZoomOut(Boolean) | Performs zoom out. (Inherited from ViewModel.)
ZoomOut(Point, Boolean) | Performs zoom out. (Inherited from ViewModel.)

See Also

DocumentViewModel Class
DocumentViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomWindow Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.ZoomWindow Method
DocumentViewModel Class See Also Send Feedback
Overridden. See ZoomWindow(Rect, Boolean).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void ZoomWindow(
    Rect rect,
    bool useAnimation
)
Visual Basic (Declaration)
Public Overrides Sub ZoomWindow ( _
    rect As Rect, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ZoomWindow(
    Rect rect,
    bool useAnimation
) override

Parameters

rect
Type: System.Windows..::.Rect
useAnimation
Type: System..::.Boolean

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentViewModel Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel Properties
DocumentViewModel Class See Also Send Feedback

The DocumentViewModel type exposes the following members.

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Overrides ViewModel..::.CanGoToNextPage.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Overrides ViewModel..::.CanGoToPrevPage.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report.
HScrollBarActive | Overridden. See HScrollBarActive. (Overrides ViewModel..::.HScrollBarActive.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Overrides ViewModel..::.HScrollBarLarge.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Overrides ViewModel..::.HScrollBarMaximum.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Overrides ViewModel..::.HScrollBarPosition.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Overrides ViewModel..::.HScrollBarSmall.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Overrides ViewModel..::.HScrollBarViewPort.)
PageNumber | Gets or sets the page number. (Inherited from ViewModel.)
ScaledPageArea | Gets page view area.
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Overrides ViewModel..::.VScrollBarActive.)
VScrollBarLarge | Overridden. See VScrollBarLarge. (Overrides ViewModel..::.VScrollBarLarge.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Overrides ViewModel..::.VScrollBarMaximum.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Overrides ViewModel..::.VScrollBarPosition.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Overrides ViewModel..::.VScrollBarSmall.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Overrides ViewModel..::.VScrollBarViewPort.)
Zoom | Overridden. See Zoom. (Overrides ViewModel..::.Zoom.)

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CanGoToNextPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.CanGoToNextPage Property
DocumentViewModel Class See Also Send Feedback
Overridden. See CanGoToNextPage.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override bool CanGoToNextPage { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGoToNextPage As Boolean
Visual C++
public:
virtual property bool CanGoToNextPage {
    bool get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CanGoToPrevPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.CanGoToPrevPage Property
DocumentViewModel Class See Also Send Feedback
Overridden. See CanGoToPrevPage.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override bool CanGoToPrevPage { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGoToPrevPage As Boolean
Visual C++
public:
virtual property bool CanGoToPrevPage {
    bool get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Document Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.Document Property
DocumentViewModel Class See Also Send Feedback
Gets Document which is a report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected Document Document { get; }
Visual Basic (Declaration)
Protected ReadOnly Property Document As Document
Visual C++
protected:
property Document^ Document {
    Document^ get ();
}

Field Value

The document.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarActive Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.HScrollBarActive Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarActive.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override bool HScrollBarActive { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HScrollBarActive As Boolean
Visual C++
public:
virtual property bool HScrollBarActive {
    bool get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarLarge Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.HScrollBarLarge Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarLarge.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double HScrollBarLarge { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HScrollBarLarge As Double
Visual C++
public:
virtual property double HScrollBarLarge {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarMaximum Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.HScrollBarMaximum Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarMaximum.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double HScrollBarMaximum { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HScrollBarMaximum As Double
Visual C++
public:
virtual property double HScrollBarMaximum {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarPosition Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.HScrollBarPosition Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarPosition.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double HScrollBarPosition { get; set; }
Visual Basic (Declaration)
Public Overrides Property HScrollBarPosition As Double
Visual C++
public:
virtual property double HScrollBarPosition {
    double get () override;
    void set (double value) override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarSmall Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.HScrollBarSmall Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarSmall.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double HScrollBarSmall { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HScrollBarSmall As Double
Visual C++
public:
virtual property double HScrollBarSmall {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarViewPort Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.HScrollBarViewPort Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarViewPort.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double HScrollBarViewPort { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HScrollBarViewPort As Double
Visual C++
public:
virtual property double HScrollBarViewPort {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ScaledPageArea Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.ScaledPageArea Property
DocumentViewModel Class See Also Send Feedback
Gets page view area.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected abstract Size ScaledPageArea { get; }
Visual Basic (Declaration)
Protected MustOverride ReadOnly Property ScaledPageArea As Size
Visual C++
protected:
virtual property Size ScaledPageArea {
    Size get () abstract;
}

Field Value

The scaled page area. The instance of Size struct.

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarActive Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.VScrollBarActive Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarActive.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override bool VScrollBarActive { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarActive As Boolean
Visual C++
public:
virtual property bool VScrollBarActive {
    bool get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarLarge Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.VScrollBarLarge Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarLarge.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double VScrollBarLarge { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarLarge As Double
Visual C++
public:
virtual property double VScrollBarLarge {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarMaximum Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.VScrollBarMaximum Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarMaximum.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double VScrollBarMaximum { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarMaximum As Double
Visual C++
public:
virtual property double VScrollBarMaximum {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarPosition Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.VScrollBarPosition Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarPosition.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double VScrollBarPosition { get; set; }
Visual Basic (Declaration)
Public Overrides Property VScrollBarPosition As Double
Visual C++
public:
virtual property double VScrollBarPosition {
    double get () override;
    void set (double value) override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarSmall Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.VScrollBarSmall Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarSmall.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double VScrollBarSmall { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarSmall As Double
Visual C++
public:
virtual property double VScrollBarSmall {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarViewPort Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.VScrollBarViewPort Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarViewPort.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override double VScrollBarViewPort { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarViewPort As Double
Visual C++
public:
virtual property double VScrollBarViewPort {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Zoom Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentViewModel..::.Zoom Property
DocumentViewModel Class See Also Send Feedback
Overridden. See Zoom.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override Zoom Zoom { get; set; }
Visual Basic (Declaration)
Public Overrides Property Zoom As Zoom
Visual C++
public:
virtual property Zoom Zoom {
    Zoom get () override;
    void set (Zoom value) override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DynamicZoomTool Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DynamicZoomTool Class
Members See Also Send Feedback
The class which realizes tool for view scaling with mouse move at pressed mouse left button.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class DynamicZoomTool : StandardTool
Visual Basic (Declaration)
Public Class DynamicZoomTool _
    Inherits StandardTool
Visual C++
public ref class DynamicZoomTool : public StandardTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
PerpetuumSoft.ReportingServices.Viewer.Client..::.StandardTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.DynamicZoomTool

See Also

DynamicZoomTool Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DynamicZoomTool Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DynamicZoomTool Members
DynamicZoomTool Class Constructors Methods Properties See Also Send Feedback

The DynamicZoomTool type exposes the following members.

Constructors

Name | Description
DynamicZoomTool | Initializes a new instance of the DynamicZoomTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

DynamicZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DynamicZoomTool Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DynamicZoomTool Constructor
DynamicZoomTool Class See Also Send Feedback
Initializes a new instance of the DynamicZoomTool class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DynamicZoomTool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
DynamicZoomTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The manager.

See Also

DynamicZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DynamicZoomTool Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DynamicZoomTool Methods
DynamicZoomTool Class See Also Send Feedback

The DynamicZoomTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

See Also

DynamicZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DynamicZoomTool..::.MouseDown Method
DynamicZoomTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DynamicZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseMove Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DynamicZoomTool..::.MouseMove Method
DynamicZoomTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DynamicZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DynamicZoomTool..::.MouseUp Method
DynamicZoomTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DynamicZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateCursor Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DynamicZoomTool..::.UpdateCursor Method
DynamicZoomTool Class See Also Send Feedback
Overridden. See UpdateCursor()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

DynamicZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DynamicZoomTool Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DynamicZoomTool Properties
DynamicZoomTool Class See Also Send Feedback

The DynamicZoomTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

DynamicZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ErrorMessagePresenter Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter Class
Members See Also Send Feedback
A class for presentation of report view content when error occurs during report getting.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ErrorMessagePresenter : Control
Visual Basic (Declaration)
Public Class ErrorMessagePresenter _
    Inherits Control
Visual C++
public ref class ErrorMessagePresenter : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.ErrorMessagePresenter

See Also

ErrorMessagePresenter Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ErrorMessagePresenter Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter Members
ErrorMessagePresenter Class Constructors Methods Fields Properties Events See Also Send Feedback

The ErrorMessagePresenter type exposes the following members.

Constructors

Name | Description
ErrorMessagePresenter | Initializes a new instance of the ErrorMessagePresenter class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CaptionProperty | Identifies the Caption dependency property.
TextProperty | Identifies the Text dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Caption | Gets or sets the error caption. This is a dependency property.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets error description. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ErrorMessagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ErrorMessagePresenter Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter Constructor
ErrorMessagePresenter Class See Also Send Feedback
Initializes a new instance of the ErrorMessagePresenter class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ErrorMessagePresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ErrorMessagePresenter()

See Also

ErrorMessagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ErrorMessagePresenter Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter Fields
ErrorMessagePresenter Class See Also Send Feedback

The ErrorMessagePresenter type exposes the following members.

Fields

Name | Description
CaptionProperty | Identifies the Caption dependency property.
TextProperty | Identifies the Text dependency property.

See Also

ErrorMessagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CaptionProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter..::.CaptionProperty Field
ErrorMessagePresenter Class See Also Send Feedback
Identifies the Caption dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty CaptionProperty
Visual Basic (Declaration)
Public Shared ReadOnly CaptionProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CaptionProperty

See Also

ErrorMessagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter..::.TextProperty Field
ErrorMessagePresenter Class See Also Send Feedback
Identifies the Text dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty TextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TextProperty

See Also

ErrorMessagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ErrorMessagePresenter Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter Methods
ErrorMessagePresenter Class See Also Send Feedback

The ErrorMessagePresenter type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ErrorMessagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ErrorMessagePresenter Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter Properties
ErrorMessagePresenter Class See Also Send Feedback

The ErrorMessagePresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Caption | Gets or sets the error caption. This is a dependency property.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets error description. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ErrorMessagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Caption Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter..::.Caption Property
ErrorMessagePresenter Class See Also Send Feedback
Gets or sets the error caption. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

Field Value

The error caption text.

See Also

ErrorMessagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Text Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter..::.Text Property
ErrorMessagePresenter Class See Also Send Feedback
Gets or sets error description. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The error description text.

See Also

ErrorMessagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ErrorMessagePresenter Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ErrorMessagePresenter Events
ErrorMessagePresenter Class See Also Send Feedback

The ErrorMessagePresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ErrorMessagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ExportListControl Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl Class
Members See Also Send Feedback
Represents a selection control with a drop-down list of ToolButton that can be shown or hidden by clicking the arrow on the control. Selected element does not represented in drop-down list. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ExportListControl : Control
Visual Basic (Declaration)
Public Class ExportListControl _
    Inherits Control
Visual C++
public ref class ExportListControl : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.ExportListControl

See Also

ExportListControl Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ExportListControl Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl Members
ExportListControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The ExportListControl type exposes the following members.

Constructors

Name | Description
ExportListControl | Initializes a new instance of the ExportListControl class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | Overriden. (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | Overriden. (Overrides ControlOnGotFocus(RoutedEventArgs).)
OnKeyDown | Overriden. (Overrides ControlOnKeyDown(KeyEventArgs).)
OnKeyUp | (Inherited from Control.)
OnLostFocus | Overriden. (Overrides ControlOnLostFocus(RoutedEventArgs).)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ExportItemsProperty | Identifies the ExportItems dependency property.
IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
SelectedToolButtonProperty | Identifies the SelectedToolButton dependency property.
TextForegroundProperty | Identifies the TextForeground dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
ExportItems | Gets or sets the collection used to generate the content of the ExportListControl. This is a dependency property.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a export list control is currently open. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property.
SelectedToolButton | Gets or sets the first ToolButton in the current selection or returns null if the selection is empty. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextForeground | Gets or sets a brush that describes the test foreground color for content of export list control. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DropDownClosed | Occurs when the drop-down list of the export list control is closed.
DropDownOpened | Occurs when the drop-down list of the export list control is opened.
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectionChanged | Occurs when the selection of the export list control is changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ExportListControl Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl Constructor
ExportListControl Class See Also Send Feedback
Initializes a new instance of the ExportListControl class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExportListControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExportListControl()

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ExportListControl Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl Fields
ExportListControl Class See Also Send Feedback

The ExportListControl type exposes the following members.

Fields

Name | Description
ExportItemsProperty | Identifies the ExportItems dependency property.
IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
SelectedToolButtonProperty | Identifies the SelectedToolButton dependency property.
TextForegroundProperty | Identifies the TextForeground dependency property.

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ExportItemsProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.ExportItemsProperty Field
ExportListControl Class See Also Send Feedback
Identifies the ExportItems dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ExportItemsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ExportItemsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ExportItemsProperty

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsDropDownOpenProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.IsDropDownOpenProperty Field
ExportListControl Class See Also Send Feedback
Identifies the IsDropDownOpen dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty IsDropDownOpenProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsDropDownOpenProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsDropDownOpenProperty

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SelectedIndexProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.SelectedIndexProperty Field
ExportListControl Class See Also Send Feedback
Identifies the SelectedIndex dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty SelectedIndexProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedIndexProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedIndexProperty

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SelectedToolButtonProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.SelectedToolButtonProperty Field
ExportListControl Class See Also Send Feedback
Identifies the SelectedToolButton dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty SelectedToolButtonProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedToolButtonProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedToolButtonProperty

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TextForegroundProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.TextForegroundProperty Field
ExportListControl Class See Also Send Feedback
Identifies the TextForeground dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty TextForegroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextForegroundProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TextForegroundProperty

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ExportListControl Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl Methods
ExportListControl Class See Also Send Feedback

The ExportListControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | Overriden. (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | Overriden. (Overrides ControlOnGotFocus(RoutedEventArgs).)
OnKeyDown | Overriden. (Overrides ControlOnKeyDown(KeyEventArgs).)
OnKeyUp | (Inherited from Control.)
OnLostFocus | Overriden. (Overrides ControlOnLostFocus(RoutedEventArgs).)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ArrangeOverride Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.ArrangeOverride Method
ExportListControl Class See Also Send Feedback
Overriden.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override Size ArrangeOverride(
    Size arrangeBounds
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    arrangeBounds As Size _
) As Size
Visual C++
protected:
virtual Size ArrangeOverride(
    Size arrangeBounds
) override

Parameters

arrangeBounds
Type: System.Windows..::.Size

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.OnApplyTemplate Method
ExportListControl Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnGotFocus Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.OnGotFocus Method
ExportListControl Class See Also Send Feedback
Overriden.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override void OnGotFocus(
    RoutedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnGotFocus ( _
    e As RoutedEventArgs _
)
Visual C++
protected:
virtual void OnGotFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.Windows..::.RoutedEventArgs

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnKeyDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.OnKeyDown Method
ExportListControl Class See Also Send Feedback
Overriden.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.KeyEventArgs

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnLostFocus Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.OnLostFocus Method
ExportListControl Class See Also Send Feedback
Overriden.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override void OnLostFocus(
    RoutedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLostFocus ( _
    e As RoutedEventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.Windows..::.RoutedEventArgs

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ExportListControl Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl Properties
ExportListControl Class See Also Send Feedback

The ExportListControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
ExportItems | Gets or sets the collection used to generate the content of the ExportListControl. This is a dependency property.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a export list control is currently open. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property.
SelectedToolButton | Gets or sets the first ToolButton in the current selection or returns null if the selection is empty. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextForeground | Gets or sets a brush that describes the test foreground color for content of export list control. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ExportItems Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.ExportItems Property
ExportListControl Class See Also Send Feedback
Gets or sets the collection used to generate the content of the ExportListControl. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public List<ToolButton> ExportItems { get; set; }
Visual Basic (Declaration)
Public Property ExportItems As List(Of ToolButton)
Visual C++
public:
property List<ToolButton^>^ ExportItems {
    List<ToolButton^>^ get ();
    void set (List<ToolButton^>^ value);
}

Field Value

The export items.

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsDropDownOpen Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.IsDropDownOpen Property
ExportListControl Class See Also Send Feedback
Gets or sets a value that indicates whether the drop-down for a export list control is currently open. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic (Declaration)
Public Property IsDropDownOpen As Boolean
Visual C++
public:
property bool IsDropDownOpen {
    bool get ();
    void set (bool value);
}

Field Value

true if the drop-down for a export list control is currently opened; otherwise, false.

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SelectedIndex Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.SelectedIndex Property
ExportListControl Class See Also Send Feedback
Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

Field Value

The index of the selected.

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SelectedToolButton Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.SelectedToolButton Property
ExportListControl Class See Also Send Feedback
Gets or sets the first ToolButton in the current selection or returns null if the selection is empty. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ToolButton SelectedToolButton { get; set; }
Visual Basic (Declaration)
Public Property SelectedToolButton As ToolButton
Visual C++
public:
property ToolButton^ SelectedToolButton {
    ToolButton^ get ();
    void set (ToolButton^ value);
}

Field Value

The selected tool button.

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TextForeground Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.TextForeground Property
ExportListControl Class See Also Send Feedback
Gets or sets a brush that describes the test foreground color for content of export list control. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Brush TextForeground { get; set; }
Visual Basic (Declaration)
Public Property TextForeground As Brush
Visual C++
public:
property Brush^ TextForeground {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The text foreground.

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ExportListControl Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl Events
ExportListControl Class See Also Send Feedback

The ExportListControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DropDownClosed | Occurs when the drop-down list of the export list control is closed.
DropDownOpened | Occurs when the drop-down list of the export list control is opened.
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectionChanged | Occurs when the selection of the export list control is changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DropDownClosed Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.DropDownClosed Event
ExportListControl Class See Also Send Feedback
Occurs when the drop-down list of the export list control is closed.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event RoutedEventHandler DropDownClosed
Visual Basic (Declaration)
Public Event DropDownClosed As RoutedEventHandler
Visual C++
public:
 event RoutedEventHandler^ DropDownClosed {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DropDownOpened Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.DropDownOpened Event
ExportListControl Class See Also Send Feedback
Occurs when the drop-down list of the export list control is opened.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event RoutedEventHandler DropDownOpened
Visual Basic (Declaration)
Public Event DropDownOpened As RoutedEventHandler
Visual C++
public:
 event RoutedEventHandler^ DropDownOpened {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SelectionChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportListControl..::.SelectionChanged Event
ExportListControl Class See Also Send Feedback
Occurs when the selection of the export list control is changed.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event SelectionChangedEventHandler SelectionChanged
Visual Basic (Declaration)
Public Event SelectionChanged As SelectionChangedEventHandler
Visual C++
public:
 event SelectionChangedEventHandler^ SelectionChanged {
    void add (SelectionChangedEventHandler^ value);
    void remove (SelectionChangedEventHandler^ value);
}

See Also

ExportListControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IView Interface

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IView Interface
Members See Also Send Feedback
Report Viewer control interface.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public interface IView
Visual Basic (Declaration)
Public Interface IView
Visual C++
public interface class IView

See Also

IView Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IView Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IView Members
IView Interface Methods Properties See Also Send Feedback

The IView type exposes the following members.

Methods

Name | Description
UpdateView | Updates view of the displayed report.

Properties

Name | Description
AdornersLayer | Gets Canvas which is the layer for borders which highlight the selected report element.
ClientSize | Gets Size which is the report display area size.
ContentLayer | Gets Canvas which is the report content layer.
ViewManager | Gets ViewManager which is Report Viewer manager.

See Also

IView Interface
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IView Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IView Methods
IView Interface See Also Send Feedback

The IView type exposes the following members.

Methods

Name | Description
UpdateView | Updates view of the displayed report.

See Also

IView Interface
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateView Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IView..::.UpdateView Method
IView Interface See Also Send Feedback
Updates view of the displayed report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
void UpdateView()
Visual Basic (Declaration)
Sub UpdateView
Visual C++
void UpdateView()

See Also

IView Interface
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IView Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IView Properties
IView Interface See Also Send Feedback

The IView type exposes the following members.

Properties

Name | Description
AdornersLayer | Gets Canvas which is the layer for borders which highlight the selected report element.
ClientSize | Gets Size which is the report display area size.
ContentLayer | Gets Canvas which is the report content layer.
ViewManager | Gets ViewManager which is Report Viewer manager.

See Also

IView Interface
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AdornersLayer Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IView..::.AdornersLayer Property
IView Interface See Also Send Feedback
Gets Canvas which is the layer for borders which highlight the selected report element.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
Canvas AdornersLayer { get; }
Visual Basic (Declaration)
ReadOnly Property AdornersLayer As Canvas
Visual C++
property Canvas^ AdornersLayer {
    Canvas^ get ();
}

Field Value

The report adorners layer.

See Also

IView Interface
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ClientSize Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IView..::.ClientSize Property
IView Interface See Also Send Feedback
Gets Size which is the report display area size.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
Size ClientSize { get; }
Visual Basic (Declaration)
ReadOnly Property ClientSize As Size
Visual C++
property Size ClientSize {
    Size get ();
}

Field Value

The report display area size.

See Also

IView Interface
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ContentLayer Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IView..::.ContentLayer Property
IView Interface See Also Send Feedback
Gets Canvas which is the report content layer.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
Canvas ContentLayer { get; }
Visual Basic (Declaration)
ReadOnly Property ContentLayer As Canvas
Visual C++
property Canvas^ ContentLayer {
    Canvas^ get ();
}

Field Value

The report content layer.

See Also

IView Interface
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IView..::.ViewManager Property
IView Interface See Also Send Feedback
Gets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
ViewManager ViewManager { get; }
Visual Basic (Declaration)
ReadOnly Property ViewManager As ViewManager
Visual C++
property ViewManager^ ViewManager {
    ViewManager^ get ();
}

Field Value

The view manager.

See Also

IView Interface
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingPagePresenter Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadingPagePresenter Class
Members See Also Send Feedback
Loading presenter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class LoadingPagePresenter : Control
Visual Basic (Declaration)
Public Class LoadingPagePresenter _
    Inherits Control
Visual C++
public ref class LoadingPagePresenter : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.LoadingPagePresenter

See Also

LoadingPagePresenter Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingPagePresenter Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadingPagePresenter Members
LoadingPagePresenter Class Constructors Methods Fields Properties Events See Also Send Feedback

The LoadingPagePresenter type exposes the following members.

Constructors

Name | Description
LoadingPagePresenter | Initializes a new instance of the LoadingPagePresenter class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
LoadingTextProperty | Identifies the LoadingText dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LoadingText | Gets or sets the text which is displayed during loading. This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

LoadingPagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingPagePresenter Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadingPagePresenter Constructor
LoadingPagePresenter Class See Also Send Feedback
Initializes a new instance of the LoadingPagePresenter class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public LoadingPagePresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadingPagePresenter()

See Also

LoadingPagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingPagePresenter Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadingPagePresenter Fields
LoadingPagePresenter Class See Also Send Feedback

The LoadingPagePresenter type exposes the following members.

Fields

Name | Description
LoadingTextProperty | Identifies the LoadingText dependency property.

See Also

LoadingPagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingTextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadingPagePresenter..::.LoadingTextProperty Field
LoadingPagePresenter Class See Also Send Feedback
Identifies the LoadingText dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public readonly DependencyProperty LoadingTextProperty
Visual Basic (Declaration)
Public ReadOnly LoadingTextProperty As DependencyProperty
Visual C++
public:
initonly DependencyProperty^ LoadingTextProperty

See Also

LoadingPagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingPagePresenter Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadingPagePresenter Methods
LoadingPagePresenter Class See Also Send Feedback

The LoadingPagePresenter type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

LoadingPagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadingPagePresenter..::.OnApplyTemplate Method
LoadingPagePresenter Class See Also Send Feedback
When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

LoadingPagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingPagePresenter Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadingPagePresenter Properties
LoadingPagePresenter Class See Also Send Feedback

The LoadingPagePresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LoadingText | Gets or sets the text which is displayed during loading. This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

LoadingPagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadingPagePresenter..::.LoadingText Property
LoadingPagePresenter Class See Also Send Feedback
Gets or sets the text which is displayed during loading. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string LoadingText { get; set; }
Visual Basic (Declaration)
Public Property LoadingText As String
Visual C++
public:
property String^ LoadingText {
    String^ get ();
    void set (String^ value);
}

Field Value

The loading text.

See Also

LoadingPagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingPagePresenter Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadingPagePresenter Events
LoadingPagePresenter Class See Also Send Feedback

The LoadingPagePresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

LoadingPagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelEventArgs Class
Members See Also Send Feedback
Provides data for various events that report changes to the mouse wheel delta value of a mouse device.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class MouseWheelEventArgs : EventArgs
Visual Basic (Declaration)
Public Class MouseWheelEventArgs _
    Inherits EventArgs
Visual C++
public ref class MouseWheelEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.ReportingServices.Viewer.Client..::.MouseWheelEventArgs

See Also

MouseWheelEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelEventArgs Members
MouseWheelEventArgs Class Constructors Methods Properties See Also Send Feedback

The MouseWheelEventArgs type exposes the following members.

Constructors

Name | Description
MouseWheelEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Delta | Gets or sets a value that indicates the amount that the mouse wheel has changed.
Handled | Gets or sets a value that indicates the present state of the event handling.
Location | Gets or sets mouse pointer location.

See Also

MouseWheelEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelEventArgs Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelEventArgs Constructor
MouseWheelEventArgs Class See Also Send Feedback

Overload List

Name | Description
MouseWheelEventArgs(Double) | Initializes a new instance of the MouseWheelEventArgs class.
MouseWheelEventArgs(Double, Point) | Initializes a new instance of the MouseWheelEventArgs class.

See Also

MouseWheelEventArgs Class
MouseWheelEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelEventArgs Constructor (Double)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelEventArgs Constructor (Double)
MouseWheelEventArgs Class See Also Send Feedback
Initializes a new instance of the MouseWheelEventArgs class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public MouseWheelEventArgs(
    double delta
)
Visual Basic (Declaration)
Public Sub New ( _
    delta As Double _
)
Visual C++
public:
MouseWheelEventArgs(
    double delta
)

Parameters

delta
Type: System..::.Double
The delta.

See Also

MouseWheelEventArgs Class
MouseWheelEventArgs Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelEventArgs Constructor (Double, Point)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelEventArgs Constructor (Double, Point)
MouseWheelEventArgs Class See Also Send Feedback
Initializes a new instance of the MouseWheelEventArgs class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public MouseWheelEventArgs(
    double delta,
    Point location
)
Visual Basic (Declaration)
Public Sub New ( _
    delta As Double, _
    location As Point _
)
Visual C++
public:
MouseWheelEventArgs(
    double delta,
    Point location
)

Parameters

delta
Type: System..::.Double
The delta.
location
Type: System.Windows..::.Point
The location.

See Also

MouseWheelEventArgs Class
MouseWheelEventArgs Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelEventArgs Methods
MouseWheelEventArgs Class See Also Send Feedback

The MouseWheelEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseWheelEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelEventArgs Properties
MouseWheelEventArgs Class See Also Send Feedback

The MouseWheelEventArgs type exposes the following members.

Properties

Name | Description
Delta | Gets or sets a value that indicates the amount that the mouse wheel has changed.
Handled | Gets or sets a value that indicates the present state of the event handling.
Location | Gets or sets mouse pointer location.

See Also

MouseWheelEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Delta Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelEventArgs..::.Delta Property
MouseWheelEventArgs Class See Also Send Feedback
Gets or sets a value that indicates the amount that the mouse wheel has changed.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double Delta { get; private set; }
Visual Basic (Declaration)
Public Property Delta As Double
Visual C++
public:
property double Delta {
    double get ();
    void set (double value);
}

Field Value

The delta.

See Also

MouseWheelEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Handled Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelEventArgs..::.Handled Property
MouseWheelEventArgs Class See Also Send Feedback
Gets or sets a value that indicates the present state of the event handling.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Field Value

true if handled; otherwise, false.

See Also

MouseWheelEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Location Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelEventArgs..::.Location Property
MouseWheelEventArgs Class See Also Send Feedback
Gets or sets mouse pointer location.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Point Location { get; private set; }
Visual Basic (Declaration)
Public Property Location As Point
Visual C++
public:
property Point Location {
    Point get ();
    void set (Point value);
}

Field Value

The location. The instance of Point class.

See Also

MouseWheelEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelManager Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelManager Class
Members See Also Send Feedback
Manager for working with mouse scroll-wheel.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class MouseWheelManager
Visual Basic (Declaration)
Public Class MouseWheelManager
Visual C++
public ref class MouseWheelManager

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.MouseWheelManager

See Also

MouseWheelManager Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelManager Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelManager Members
MouseWheelManager Class Constructors Methods See Also Send Feedback

The MouseWheelManager type exposes the following members.

Constructors

Name | Description
MouseWheelManager | Initializes a new instance of the MouseWheelManager class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseWheelManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelManager Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelManager Constructor
MouseWheelManager Class See Also Send Feedback
Initializes a new instance of the MouseWheelManager class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public MouseWheelManager(
    UIElement rootVisual
)
Visual Basic (Declaration)
Public Sub New ( _
    rootVisual As UIElement _
)
Visual C++
public:
MouseWheelManager(
    UIElement^ rootVisual
)

Parameters

rootVisual
Type: System.Windows..::.UIElement
The root visual. The instance of UIElement class.

See Also

MouseWheelManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelManager Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MouseWheelManager Methods
MouseWheelManager Class See Also Send Feedback

The MouseWheelManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseWheelManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl Class
Members See Also Send Feedback
The MultiValidValueParameterControl class is intended to encapsulate logic for report parameter controls with multi-value selection and with list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class MultiValidValueParameterControl : ReportParameterControl
Visual Basic (Declaration)
Public Class MultiValidValueParameterControl _
    Inherits ReportParameterControl
Visual C++
public ref class MultiValidValueParameterControl : public ReportParameterControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.BaseParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.MultiValidValueParameterControl

See Also

MultiValidValueParameterControl Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl Members
MultiValidValueParameterControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The MultiValidValueParameterControl type exposes the following members.

Constructors

Name | Description
MultiValidValueParameterControl | Initializes a new instance of the MultiValidValueParameterControl class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
ValidValues | Gets or sets the values that can be chosen as parameter values.
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

MultiValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl Constructor
MultiValidValueParameterControl Class See Also Send Feedback
Initializes a new instance of the MultiValidValueParameterControl class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public MultiValidValueParameterControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MultiValidValueParameterControl()

See Also

MultiValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl Fields
MultiValidValueParameterControl Class See Also Send Feedback

The MultiValidValueParameterControl type exposes the following members.

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

See Also

MultiValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl Methods
MultiValidValueParameterControl Class See Also Send Feedback

The MultiValidValueParameterControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

MultiValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.OnApplyTemplate Method
MultiValidValueParameterControl Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

MultiValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetFocus Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.SetFocus Method
MultiValidValueParameterControl Class See Also Send Feedback
Overridden. See SetFocus()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void SetFocus()
Visual Basic (Declaration)
Public Overrides Sub SetFocus
Visual C++
public:
virtual void SetFocus() override

See Also

MultiValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl Properties
MultiValidValueParameterControl Class See Also Send Feedback

The MultiValidValueParameterControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
ValidValues | Gets or sets the values that can be chosen as parameter values.
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

MultiValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ValidValues Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.ValidValues Property
MultiValidValueParameterControl Class See Also Send Feedback
Gets or sets the values that can be chosen as parameter values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public List<ValidValue> ValidValues { get; set; }
Visual Basic (Declaration)
Public Property ValidValues As List(Of ValidValue)
Visual C++
public:
property List<ValidValue^>^ ValidValues {
    List<ValidValue^>^ get ();
    void set (List<ValidValue^>^ value);
}

Field Value

The valid values.

See Also

MultiValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Values Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Values Property
MultiValidValueParameterControl Class See Also Send Feedback
Overridden. See Values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override List<ValidValue> Values { get; set; }
Visual Basic (Declaration)
Public Overrides Property Values As List(Of ValidValue)
Visual C++
public:
virtual property List<ValidValue^>^ Values {
    List<ValidValue^>^ get () override;
    void set (List<ValidValue^>^ value) override;
}

See Also

MultiValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl Events
MultiValidValueParameterControl Class See Also Send Feedback

The MultiValidValueParameterControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

MultiValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl.Data Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data Class
MultiValidValueParameterControl Class Members See Also Send Feedback
The Data class is intended to encapsulate data for ComboBox binding.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class Data : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class Data _
    Implements INotifyPropertyChanged
Visual C++
public ref class Data : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.MultiValidValueParameterControl..::.Data

See Also

MultiValidValueParameterControl..::.Data Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl.Data Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data Members
MultiValidValueParameterControl..::.Data Class Constructors Methods Properties Events See Also Send Feedback

The MultiValidValueParameterControl class is intended to encapsulate logic for report parameter controls with multi-value selection and with list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.

The MultiValidValueParameterControl..::.Data type exposes the following members.

Constructors

Name | Description
MultiValidValueParameterControl..::.Data | Initializes a new instance of the MultiValidValueParameterControl..::.Data class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsChecked | Gets or sets a value indicating whether this instance is checked.
Label | Gets or sets the label.
ValidValue | Gets the valid value.
Value | Gets or sets the value.

Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

MultiValidValueParameterControl..::.Data Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl.Data Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data Constructor
MultiValidValueParameterControl..::.Data Class See Also Send Feedback
Initializes a new instance of the MultiValidValueParameterControl..::.Data class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Data(
    ValidValue validValue
)
Visual Basic (Declaration)
Public Sub New ( _
    validValue As ValidValue _
)
Visual C++
public:
Data(
    ValidValue^ validValue
)

Parameters

validValue
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ValidValue
The valid value.

See Also

MultiValidValueParameterControl..::.Data Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl.Data Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data Methods
MultiValidValueParameterControl..::.Data Class See Also Send Feedback

The MultiValidValueParameterControl..::.Data type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiValidValueParameterControl..::.Data Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl.Data Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data Properties
MultiValidValueParameterControl..::.Data Class See Also Send Feedback

The MultiValidValueParameterControl..::.Data type exposes the following members.

Properties

Name | Description
IsChecked | Gets or sets a value indicating whether this instance is checked.
Label | Gets or sets the label.
ValidValue | Gets the valid value.
Value | Gets or sets the value.

See Also

MultiValidValueParameterControl..::.Data Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsChecked Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data..::.IsChecked Property
MultiValidValueParameterControl..::.Data Class See Also Send Feedback
Gets or sets a value indicating whether this instance is checked.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsChecked { get; set; }
Visual Basic (Declaration)
Public Property IsChecked As Boolean
Visual C++
public:
property bool IsChecked {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is checked; otherwise, false.

See Also

MultiValidValueParameterControl..::.Data Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Label Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data..::.Label Property
MultiValidValueParameterControl..::.Data Class See Also Send Feedback
Gets or sets the label.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Label { get; set; }
Visual Basic (Declaration)
Public Property Label As String
Visual C++
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}

Field Value

The label.

See Also

MultiValidValueParameterControl..::.Data Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ValidValue Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data..::.ValidValue Property
MultiValidValueParameterControl..::.Data Class See Also Send Feedback
Gets the valid value.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ValidValue ValidValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property ValidValue As ValidValue
Visual C++
public:
property ValidValue^ ValidValue {
    ValidValue^ get ();
}

Field Value

The valid value.

See Also

MultiValidValueParameterControl..::.Data Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Value Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data..::.Value Property
MultiValidValueParameterControl..::.Data Class See Also Send Feedback
Gets or sets the value.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

MultiValidValueParameterControl..::.Data Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControl.Data Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data Events
MultiValidValueParameterControl..::.Data Class See Also Send Feedback

The MultiValidValueParameterControl..::.Data type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

MultiValidValueParameterControl..::.Data Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValidValueParameterControl..::.Data..::.PropertyChanged Event
MultiValidValueParameterControl..::.Data Class See Also Send Feedback
Occurs when a property value changes.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

MultiValidValueParameterControl..::.Data Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValueParameterControl Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl Class
Members See Also Send Feedback
The MultiValueParameterControl class is intended to encapsulate logic for report parameter controls with multi-value selection and without list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class MultiValueParameterControl : ReportParameterControl
Visual Basic (Declaration)
Public Class MultiValueParameterControl _
    Inherits ReportParameterControl
Visual C++
public ref class MultiValueParameterControl : public ReportParameterControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.BaseParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.MultiValueParameterControl

See Also

MultiValueParameterControl Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValueParameterControl Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl Members
MultiValueParameterControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The MultiValueParameterControl type exposes the following members.

Constructors

Name | Description
MultiValueParameterControl | Initializes a new instance of the MultiValueParameterControl class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
HelpTextProperty | Identifies the HelpText dependency property.
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HelpText | Gets or sets the help icon tooltip text. This is a dependency property.
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValueParameterControl Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl Constructor
MultiValueParameterControl Class See Also Send Feedback
Initializes a new instance of the MultiValueParameterControl class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public MultiValueParameterControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MultiValueParameterControl()

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValueParameterControl Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl Fields
MultiValueParameterControl Class See Also Send Feedback

The MultiValueParameterControl type exposes the following members.

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
HelpTextProperty | Identifies the HelpText dependency property.
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HelpTextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl..::.HelpTextProperty Field
MultiValueParameterControl Class See Also Send Feedback
Identifies the HelpText dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty HelpTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly HelpTextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ HelpTextProperty

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValueParameterControl Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl Methods
MultiValueParameterControl Class See Also Send Feedback

The MultiValueParameterControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl..::.OnApplyTemplate Method
MultiValueParameterControl Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetFocus Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl..::.SetFocus Method
MultiValueParameterControl Class See Also Send Feedback
Overridden. See SetFocus()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void SetFocus()
Visual Basic (Declaration)
Public Overrides Sub SetFocus
Visual C++
public:
virtual void SetFocus() override

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValueParameterControl Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl Properties
MultiValueParameterControl Class See Also Send Feedback

The MultiValueParameterControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HelpText | Gets or sets the help icon tooltip text. This is a dependency property.
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HelpText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl..::.HelpText Property
MultiValueParameterControl Class See Also Send Feedback
Gets or sets the help icon tooltip text. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string HelpText { get; set; }
Visual Basic (Declaration)
Public Property HelpText As String
Visual C++
public:
property String^ HelpText {
    String^ get ();
    void set (String^ value);
}

Field Value

The help text.

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Values Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl..::.Values Property
MultiValueParameterControl Class See Also Send Feedback
Overridden. See Values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override List<ValidValue> Values { get; set; }
Visual Basic (Declaration)
Public Overrides Property Values As List(Of ValidValue)
Visual C++
public:
virtual property List<ValidValue^>^ Values {
    List<ValidValue^>^ get () override;
    void set (List<ValidValue^>^ value) override;
}

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValueParameterControl Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
MultiValueParameterControl Events
MultiValueParameterControl Class See Also Send Feedback

The MultiValueParameterControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

MultiValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NavigationHelper Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NavigationHelper Class
Members See Also Send Feedback
The NavigationHelper class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static class NavigationHelper
Visual Basic (Declaration)
Public NotInheritable Class NavigationHelper
Visual C++
public ref class NavigationHelper abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.NavigationHelper

See Also

NavigationHelper Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NavigationHelper Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NavigationHelper Members
NavigationHelper Class Methods See Also Send Feedback

Methods

Name | Description
Navigate | Overloaded.

See Also

NavigationHelper Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NavigationHelper Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NavigationHelper Methods
NavigationHelper Class See Also Send Feedback

Methods

Name | Description
Navigate | Overloaded.

See Also

NavigationHelper Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Navigate Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NavigationHelper..::.Navigate Method
NavigationHelper Class See Also Send Feedback

Overload List

Name | Description
Navigate(Uri) | Navigate to an Uri.
Navigate(Uri, Boolean) | Navigate to an Uri.

See Also

NavigationHelper Class
NavigationHelper Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Navigate Method (Uri)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NavigationHelper..::.Navigate Method (Uri)
NavigationHelper Class See Also Send Feedback
Navigate to an Uri.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static void Navigate(
    Uri navigationUri
)
Visual Basic (Declaration)
Public Shared Sub Navigate ( _
    navigationUri As Uri _
)
Visual C++
public:
static void Navigate(
    Uri^ navigationUri
)

Parameters

navigationUri
Type: System..::.Uri
An Uri class.

See Also

NavigationHelper Class
Navigate Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Navigate Method (Uri, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NavigationHelper..::.Navigate Method (Uri, Boolean)
NavigationHelper Class See Also Send Feedback
Navigate to an Uri.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static void Navigate(
    Uri navigationUri,
    bool maximize
)
Visual Basic (Declaration)
Public Shared Sub Navigate ( _
    navigationUri As Uri, _
    maximize As Boolean _
)
Visual C++
public:
static void Navigate(
    Uri^ navigationUri,
    bool maximize
)

Parameters

navigationUri
Type: System..::.Uri
An Uri class.
maximize
Type: System..::.Boolean
True if it needs to maximize a window.

See Also

NavigationHelper Class
Navigate Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NoReportPresenter Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoReportPresenter Class
Members See Also Send Feedback
A class for presentation of report view content when report is missing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class NoReportPresenter : Control
Visual Basic (Declaration)
Public Class NoReportPresenter _
    Inherits Control
Visual C++
public ref class NoReportPresenter : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.NoReportPresenter

See Also

NoReportPresenter Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NoReportPresenter Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoReportPresenter Members
NoReportPresenter Class Constructors Methods Properties Events See Also Send Feedback

The NoReportPresenter type exposes the following members.

Constructors

Name | Description
NoReportPresenter | Initializes a new instance of the NoReportPresenter class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

NoReportPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NoReportPresenter Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoReportPresenter Constructor
NoReportPresenter Class See Also Send Feedback
Initializes a new instance of the NoReportPresenter class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public NoReportPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoReportPresenter()

See Also

NoReportPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NoReportPresenter Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoReportPresenter Methods
NoReportPresenter Class See Also Send Feedback

The NoReportPresenter type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

NoReportPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NoReportPresenter Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoReportPresenter Properties
NoReportPresenter Class See Also Send Feedback

The NoReportPresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

NoReportPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NoReportPresenter Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoReportPresenter Events
NoReportPresenter Class See Also Send Feedback

The NoReportPresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

NoReportPresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Page Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page Class
Members See Also Send Feedback
A class for report page representation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Page
Visual Basic (Declaration)
Public NotInheritable Class Page
Visual C++
public ref class Page sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Page

See Also

Page Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Page Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page Members
Page Class Methods Properties Events See Also Send Feedback

The Page type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Document | Gets or sets Document which is the report to which the page belongs.
Height | Gets or sets page height.
IsLoaded | Gets the property which indicates that the page is loaded.
IsLoading | Gets or sets the property which indicates that the page is loading.
PageNumber | Gets or sets page number.
Size | Gets page size.
Width | Gets or sets page width.
XamlContent | Gets or sets page content in Xaml representation.

Events

Name | Description
Loaded | Occurs when the page is loaded.
SizeChanged | Occurs when the page size is changed.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Page Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page Methods
Page Class See Also Send Feedback

The Page type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Page Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page Properties
Page Class See Also Send Feedback

The Page type exposes the following members.

Properties

Name | Description
Document | Gets or sets Document which is the report to which the page belongs.
Height | Gets or sets page height.
IsLoaded | Gets the property which indicates that the page is loaded.
IsLoading | Gets or sets the property which indicates that the page is loading.
PageNumber | Gets or sets page number.
Size | Gets page size.
Width | Gets or sets page width.
XamlContent | Gets or sets page content in Xaml representation.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Document Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page..::.Document Property
Page Class See Also Send Feedback
Gets or sets Document which is the report to which the page belongs.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Document Document { get; private set; }
Visual Basic (Declaration)
Public Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
    void set (Document^ value);
}

Field Value

The document. The instance of Document class.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Height Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page..::.Height Property
Page Class See Also Send Feedback
Gets or sets page height.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double Height { get; private set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Field Value

The height.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsLoaded Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page..::.IsLoaded Property
Page Class See Also Send Feedback
Gets the property which indicates that the page is loaded.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsLoaded { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLoaded As Boolean
Visual C++
public:
property bool IsLoaded {
    bool get ();
}

Field Value

true if the page is loaded; otherwise, false.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsLoading Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page..::.IsLoading Property
Page Class See Also Send Feedback
Gets or sets the property which indicates that the page is loading.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsLoading { get; internal set; }
Visual Basic (Declaration)
Public Property IsLoading As Boolean
Visual C++
public:
property bool IsLoading {
    bool get ();
    void set (bool value);
}

Field Value

true if the page is loading; otherwise, false.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageNumber Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page..::.PageNumber Property
Page Class See Also Send Feedback
Gets or sets page number.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int PageNumber { get; private set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

Field Value

The page number.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Size Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page..::.Size Property
Page Class See Also Send Feedback
Gets page size.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Size Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As Size
Visual C++
public:
property Size Size {
    Size get ();
}

Field Value

The size. The instance of Size class.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Width Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page..::.Width Property
Page Class See Also Send Feedback
Gets or sets page width.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double Width { get; private set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Field Value

The width.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


XamlContent Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page..::.XamlContent Property
Page Class See Also Send Feedback
Gets or sets page content in Xaml representation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string XamlContent { get; internal set; }
Visual Basic (Declaration)
Public Property XamlContent As String
Visual C++
public:
property String^ XamlContent {
    String^ get ();
    void set (String^ value);
}

Field Value

The page content in Xaml.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Page Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page Events
Page Class See Also Send Feedback

The Page type exposes the following members.

Events

Name | Description
Loaded | Occurs when the page is loaded.
SizeChanged | Occurs when the page size is changed.

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Loaded Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page..::.Loaded Event
Page Class See Also Send Feedback
Occurs when the page is loaded.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler Loaded
Visual Basic (Declaration)
Public Event Loaded As EventHandler
Visual C++
public:
 event EventHandler^ Loaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SizeChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Page..::.SizeChanged Event
Page Class See Also Send Feedback
Occurs when the page size is changed.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler SizeChanged
Visual Basic (Declaration)
Public Event SizeChanged As EventHandler
Visual C++
public:
 event EventHandler^ SizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Page Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageLoadedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageLoadedEventArgs Class
Members See Also Send Feedback
Report page loading event parameters.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class PageLoadedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class PageLoadedEventArgs _
    Inherits EventArgs
Visual C++
public ref class PageLoadedEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.ReportingServices.Viewer.Client..::.PageLoadedEventArgs

See Also

PageLoadedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageLoadedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageLoadedEventArgs Members
PageLoadedEventArgs Class Constructors Methods Properties See Also Send Feedback

The PageLoadedEventArgs type exposes the following members.

Constructors

Name | Description
PageLoadedEventArgs | Initializes a new instance of the PageLoadedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Document | Gets or sets Document which is a loaded report.
PageNumber | Gets or sets page number.

See Also

PageLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageLoadedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageLoadedEventArgs Constructor
PageLoadedEventArgs Class See Also Send Feedback
Initializes a new instance of the PageLoadedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public PageLoadedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageLoadedEventArgs()

See Also

PageLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageLoadedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageLoadedEventArgs Methods
PageLoadedEventArgs Class See Also Send Feedback

The PageLoadedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageLoadedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageLoadedEventArgs Properties
PageLoadedEventArgs Class See Also Send Feedback

The PageLoadedEventArgs type exposes the following members.

Properties

Name | Description
Document | Gets or sets Document which is a loaded report.
PageNumber | Gets or sets page number.

See Also

PageLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Document Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageLoadedEventArgs..::.Document Property
PageLoadedEventArgs Class See Also Send Feedback
Gets or sets Document which is a loaded report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Document Document { get; set; }
Visual Basic (Declaration)
Public Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
    void set (Document^ value);
}

Field Value

The document.

See Also

PageLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageNumber Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageLoadedEventArgs..::.PageNumber Property
PageLoadedEventArgs Class See Also Send Feedback
Gets or sets page number.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

Field Value

The page number.

See Also

PageLoadedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageModel Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageModel Enumeration
See Also Send Feedback
Page view models list.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public enum PageModel
Visual Basic (Declaration)
Public Enumeration PageModel
Visual C++
public enum class PageModel

Members

Member name | Description
Single | Gets the property which indicates that only one page is viewed each time.
Continued | Gets the property which indicates that there viewed as many pages as possible.

See Also

PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PagePresenter Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter Class
Members See Also Send Feedback
Report pages presenter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class PagePresenter : Control
Visual Basic (Declaration)
Public Class PagePresenter _
    Inherits Control
Visual C++
public ref class PagePresenter : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.PagePresenter

See Also

PagePresenter Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PagePresenter Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter Members
PagePresenter Class Constructors Methods Properties Events See Also Send Feedback

The PagePresenter type exposes the following members.

Constructors

Name | Description
PagePresenter | Initializes a new instance of the PagePresenter class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
HideSearch | Removes the highlight from the selected area.
Init | Performs page presenter initialization.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
MakeClientSideSearch | Executes the client side search. Find TextBlock control at Page content which contains searched text and save it in newSearchResult.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ShowSearch | Shifts the visible area of the screen to guarantee that the specified report area is visible and highlights it.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
Hightlight | Gets or sets the element for highlighting.
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Page | Gets or sets Page which is a page.
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Gets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PagePresenter Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter Constructor
PagePresenter Class See Also Send Feedback
Initializes a new instance of the PagePresenter class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public PagePresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PagePresenter()

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PagePresenter Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter Methods
PagePresenter Class See Also Send Feedback

The PagePresenter type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
HideSearch | Removes the highlight from the selected area.
Init | Performs page presenter initialization.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
MakeClientSideSearch | Executes the client side search. Find TextBlock control at Page content which contains searched text and save it in newSearchResult.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ShowSearch | Shifts the visible area of the screen to guarantee that the specified report area is visible and highlights it.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HideSearch Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter..::.HideSearch Method
PagePresenter Class See Also Send Feedback
Removes the highlight from the selected area.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void HideSearch()
Visual Basic (Declaration)
Public Sub HideSearch
Visual C++
public:
void HideSearch()

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Init Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter..::.Init Method
PagePresenter Class See Also Send Feedback
Performs page presenter initialization.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void Init(
    Page page,
    Style loadingPageStyle
)
Visual Basic (Declaration)
Public Sub Init ( _
    page As Page, _
    loadingPageStyle As Style _
)
Visual C++
public:
void Init(
    Page^ page,
    Style^ loadingPageStyle
)

Parameters

page
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.Page
The page. The instance of Page class.
loadingPageStyle
Type: System.Windows..::.Style
The loading page style. The instance of Style class.

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MakeClientSideSearch Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter..::.MakeClientSideSearch Method
PagePresenter Class See Also Send Feedback
Executes the client side search. Find TextBlock control at Page content which contains searched text and save it in newSearchResult.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool MakeClientSideSearch(
    SearchResult oldSearchResult,
    SearchResult newSearchResult
)
Visual Basic (Declaration)
Public Function MakeClientSideSearch ( _
    oldSearchResult As SearchResult, _
    newSearchResult As SearchResult _
) As Boolean
Visual C++
public:
bool MakeClientSideSearch(
    SearchResult^ oldSearchResult,
    SearchResult^ newSearchResult
)

Parameters

oldSearchResult
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SearchResult
The old search result.
newSearchResult
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SearchResult
A new search result.

Return Value

true if client side search is completed successfully; otherwise, false.

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter..::.OnApplyTemplate Method
PagePresenter Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ShowSearch Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter..::.ShowSearch Method
PagePresenter Class See Also Send Feedback
Shifts the visible area of the screen to guarantee that the specified report area is visible and highlights it.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ShowSearch(
    Rect rect
)
Visual Basic (Declaration)
Public Sub ShowSearch ( _
    rect As Rect _
)
Visual C++
public:
void ShowSearch(
    Rect rect
)

Parameters

rect
Type: System.Windows..::.Rect
The rect.

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PagePresenter Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter Properties
PagePresenter Class See Also Send Feedback

The PagePresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
Hightlight | Gets or sets the element for highlighting.
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Page | Gets or sets Page which is a page.
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Gets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Hightlight Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter..::.Hightlight Property
PagePresenter Class See Also Send Feedback
Gets or sets the element for highlighting.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public FrameworkElement Hightlight { get; private set; }
Visual Basic (Declaration)
Public Property Hightlight As FrameworkElement
Visual C++
public:
property FrameworkElement^ Hightlight {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Field Value

The hightlight. The instance of FrameworkElement class.

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Page Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter..::.Page Property
PagePresenter Class See Also Send Feedback
Gets or sets Page which is a page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Page Page { get; private set; }
Visual Basic (Declaration)
Public Property Page As Page
Visual C++
public:
property Page^ Page {
    Page^ get ();
    void set (Page^ value);
}

Field Value

The page. The instance of Page class.

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter..::.ViewManager Property
PagePresenter Class See Also Send Feedback
Gets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewManager ViewManager { get; internal set; }
Visual Basic (Declaration)
Public Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
    void set (ViewManager^ value);
}

Field Value

The view manager. The instance of ViewManager class.

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PagePresenter Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PagePresenter Events
PagePresenter Class See Also Send Feedback

The PagePresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

PagePresenter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageSelectedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageSelectedEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when the page is selected.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class PageSelectedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class PageSelectedEventArgs _
    Inherits EventArgs
Visual C++
public ref class PageSelectedEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.ReportingServices.Viewer.Client..::.PageSelectedEventArgs

See Also

PageSelectedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageSelectedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageSelectedEventArgs Members
PageSelectedEventArgs Class Constructors Methods Properties See Also Send Feedback

The PageSelectedEventArgs type exposes the following members.

Constructors

Name | Description
PageSelectedEventArgs | Initializes a new instance of the PageSelectedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PageNumber | Gets the page number.

See Also

PageSelectedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageSelectedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageSelectedEventArgs Constructor
PageSelectedEventArgs Class See Also Send Feedback
Initializes a new instance of the PageSelectedEventArgs class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public PageSelectedEventArgs(
    int pageNumber
)
Visual Basic (Declaration)
Public Sub New ( _
    pageNumber As Integer _
)
Visual C++
public:
PageSelectedEventArgs(
    int pageNumber
)

Parameters

pageNumber
Type: System..::.Int32
The page number.

See Also

PageSelectedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageSelectedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageSelectedEventArgs Methods
PageSelectedEventArgs Class See Also Send Feedback

The PageSelectedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageSelectedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageSelectedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageSelectedEventArgs Properties
PageSelectedEventArgs Class See Also Send Feedback

The PageSelectedEventArgs type exposes the following members.

Properties

Name | Description
PageNumber | Gets the page number.

See Also

PageSelectedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageNumber Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageSelectedEventArgs..::.PageNumber Property
PageSelectedEventArgs Class See Also Send Feedback
Gets the page number.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int PageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
}

Field Value

The page number.

See Also

PageSelectedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PanTool Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PanTool Class
Members See Also Send Feedback
The class which realizes tool for report scrolling with mouse pointer move at pressed right mouse button. Inherited from StandardTool.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class PanTool : StandardTool
Visual Basic (Declaration)
Public Class PanTool _
    Inherits StandardTool
Visual C++
public ref class PanTool : public StandardTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
PerpetuumSoft.ReportingServices.Viewer.Client..::.StandardTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.PanTool

See Also

PanTool Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PanTool Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PanTool Members
PanTool Class Constructors Methods Properties See Also Send Feedback

The PanTool type exposes the following members.

Constructors

Name | Description
PanTool | Initializes a new instance of the PanTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs) (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseDown(MouseEventArgs) (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()() (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

PanTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PanTool Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PanTool Constructor
PanTool Class See Also Send Feedback
Initializes a new instance of the PanTool class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public PanTool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
PanTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The manager.

See Also

PanTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PanTool Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PanTool Methods
PanTool Class See Also Send Feedback

The PanTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs) (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseDown(MouseEventArgs) (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()() (Overrides Tool..::.UpdateCursor()()().)

See Also

PanTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PanTool..::.MouseDown Method
PanTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs)

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

PanTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseMove Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PanTool..::.MouseMove Method
PanTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

PanTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PanTool..::.MouseUp Method
PanTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs)

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

PanTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateCursor Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PanTool..::.UpdateCursor Method
PanTool Class See Also Send Feedback
Overridden. See UpdateCursor()()()

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

PanTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PanTool Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PanTool Properties
PanTool Class See Also Send Feedback

The PanTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

PanTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Parameter Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Parameter Class
Members See Also Send Feedback
The class which describes a parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class Parameter
Visual Basic (Declaration)
Public Class Parameter
Visual C++
public ref class Parameter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Parameter

See Also

Parameter Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Parameter Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Parameter Members
Parameter Class Constructors Methods Properties See Also Send Feedback

The Parameter type exposes the following members.

Constructors

Name | Description
Parameter | Initializes a new instance of the Parameter class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Gets or sets the parameter name.
Value | Gets or sets the parameter value.

See Also

Parameter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Parameter Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Parameter Constructor
Parameter Class See Also Send Feedback
Initializes a new instance of the Parameter class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Parameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Parameter()

See Also

Parameter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Parameter Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parameter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Parameter Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
Name | Gets or sets the parameter name.
Value | Gets or sets the parameter value.

See Also

Parameter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Name Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Parameter..::.Name Property
Parameter Class See Also Send Feedback
Gets or sets the parameter name.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Value Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Parameter..::.Value Property
Parameter Class See Also Send Feedback
Gets or sets the parameter value.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

Parameter Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanel Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel Class
Members See Also Send Feedback
Represents a panel control with list of BaseParameterControl that can be shown or hidden and have two buttons to accept or cancel BaseParameterControl controls changing. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ParametersPanel : Control
Visual Basic (Declaration)
Public Class ParametersPanel _
    Inherits Control
Visual C++
public ref class ParametersPanel : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.ParametersPanel

See Also

ParametersPanel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanel Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel Members
ParametersPanel Class Constructors Methods Fields Properties Events See Also Send Feedback

The ParametersPanel type exposes the following members.

Constructors

Name | Description
ParametersPanel | Initializes a new instance of the ParametersPanel class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillDataSourceCredentials | Fills the content panel by the data-source credentials.
FillParameterValues | Fills the content panel by the parameter values.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
LoadDataSourceCredentials | Loads the data-source credentials.
LoadParameterValues | Loads the parameter values.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SaveDataSourceCredentials | Saves the data-source credentials.
SaveParameterValues | Saves the parameter values.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AcceptButtonProperty | Identifies the AcceptButton dependency property.
BooleanParameterControlStyleProperty | Identifies the BooleanParameterControlStyle dependency property.
CancelButtonProperty | Identifies the CancelButton dependency property.
ClipToBoundsProperty | Identifies the ClipToBounds dependency property.
ContentPanelProperty | Identifies the ContentPanel dependency property.
CredentialControlStyleProperty | Identifies the CredentialControlStyle dependency property.
DateTimeParameterControlStyleProperty | Identifies the DateTimeParameterControlStyle dependency property.
IsHiddenProperty | Identifies the IsHidden dependency property.
MultiValidValueParameterControlStyleProperty |
MultiValueParameterControlStyleProperty | Identifies the MultiValueParameterControlStyle dependency property.
SingleValidValueParameterControlStyleProperty | Identifies the SingleValidValueParameterControlStyle dependency property.
StringParameterControlStyleProperty | Identifies the StringParameterControlStyle dependency property.
TextForegroundProperty | Identifies the TextForeground dependency property.

Properties

Name | Description
AcceptButton | Gets or sets the accept button. This is a dependency property.
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BooleanParameterControlStyle | Gets or sets the boolean parameter control style. This is a dependency property.
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
CancelButton | Gets or sets the cancel button. This is a dependency property.
Clip | (Inherited from UIElement.)
ClipToBounds | Gets or sets a value indicating whether panel will clip to bounds. This is a dependency property.
ContentPanel | Gets or sets the content panel. This is a dependency property.
CredentialControlStyle | Gets or sets the credential control style. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateTimeParameterControlStyle | Gets or sets the date time parameter control style. This is a dependency property.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHidden | Gets or sets a value indicating whether this panel is hidden. This is a dependency property.
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MultiValidValueParameterControlStyle | Gets or sets the multi valid value parameter control style. This is a dependency property.
MultiValueParameterControlStyle | Gets or sets the multi value parameter control style. This is a dependency property.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SingleValidValueParameterControlStyle | Gets or sets the single valid value parameter control style. This is a dependency property.
StringParameterControlStyle | Gets or sets the string parameter control style. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextForeground | Gets or sets the foreground for text of panel content. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
ParameterValueChanged | Occurs when any parameter value is changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanel Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel Constructor
ParametersPanel Class See Also Send Feedback
Initializes a new instance of the ParametersPanel class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ParametersPanel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParametersPanel()

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanel Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel Fields
ParametersPanel Class See Also Send Feedback

The ParametersPanel type exposes the following members.

Fields

Name | Description
AcceptButtonProperty | Identifies the AcceptButton dependency property.
BooleanParameterControlStyleProperty | Identifies the BooleanParameterControlStyle dependency property.
CancelButtonProperty | Identifies the CancelButton dependency property.
ClipToBoundsProperty | Identifies the ClipToBounds dependency property.
ContentPanelProperty | Identifies the ContentPanel dependency property.
CredentialControlStyleProperty | Identifies the CredentialControlStyle dependency property.
DateTimeParameterControlStyleProperty | Identifies the DateTimeParameterControlStyle dependency property.
IsHiddenProperty | Identifies the IsHidden dependency property.
MultiValidValueParameterControlStyleProperty |
MultiValueParameterControlStyleProperty | Identifies the MultiValueParameterControlStyle dependency property.
SingleValidValueParameterControlStyleProperty | Identifies the SingleValidValueParameterControlStyle dependency property.
StringParameterControlStyleProperty | Identifies the StringParameterControlStyle dependency property.
TextForegroundProperty | Identifies the TextForeground dependency property.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AcceptButtonProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.AcceptButtonProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the AcceptButton dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty AcceptButtonProperty
Visual Basic (Declaration)
Public Shared ReadOnly AcceptButtonProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AcceptButtonProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BooleanParameterControlStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.BooleanParameterControlStyleProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the BooleanParameterControlStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty BooleanParameterControlStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly BooleanParameterControlStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ BooleanParameterControlStyleProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CancelButtonProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.CancelButtonProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the CancelButton dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty CancelButtonProperty
Visual Basic (Declaration)
Public Shared ReadOnly CancelButtonProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CancelButtonProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ClipToBoundsProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.ClipToBoundsProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the ClipToBounds dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ClipToBoundsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ClipToBoundsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ClipToBoundsProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ContentPanelProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.ContentPanelProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the ContentPanel dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ContentPanelProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentPanelProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ContentPanelProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialControlStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.CredentialControlStyleProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the CredentialControlStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty CredentialControlStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly CredentialControlStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CredentialControlStyleProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DateTimeParameterControlStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.DateTimeParameterControlStyleProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the DateTimeParameterControlStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty DateTimeParameterControlStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DateTimeParameterControlStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DateTimeParameterControlStyleProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsHiddenProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.IsHiddenProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the IsHidden dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty IsHiddenProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsHiddenProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsHiddenProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControlStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.MultiValidValueParameterControlStyleProperty Field
ParametersPanel Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty MultiValidValueParameterControlStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly MultiValidValueParameterControlStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MultiValidValueParameterControlStyleProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValueParameterControlStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.MultiValueParameterControlStyleProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the MultiValueParameterControlStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty MultiValueParameterControlStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly MultiValueParameterControlStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MultiValueParameterControlStyleProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SingleValidValueParameterControlStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.SingleValidValueParameterControlStyleProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the SingleValidValueParameterControlStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty SingleValidValueParameterControlStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly SingleValidValueParameterControlStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SingleValidValueParameterControlStyleProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StringParameterControlStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.StringParameterControlStyleProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the StringParameterControlStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty StringParameterControlStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly StringParameterControlStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ StringParameterControlStyleProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TextForegroundProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.TextForegroundProperty Field
ParametersPanel Class See Also Send Feedback
Identifies the TextForeground dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty TextForegroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextForegroundProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TextForegroundProperty

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanel Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel Methods
ParametersPanel Class See Also Send Feedback

The ParametersPanel type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillDataSourceCredentials | Fills the content panel by the data-source credentials.
FillParameterValues | Fills the content panel by the parameter values.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
LoadDataSourceCredentials | Loads the data-source credentials.
LoadParameterValues | Loads the parameter values.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SaveDataSourceCredentials | Saves the data-source credentials.
SaveParameterValues | Saves the parameter values.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


FillDataSourceCredentials Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.FillDataSourceCredentials Method
ParametersPanel Class See Also Send Feedback
Fills the content panel by the data-source credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public List<ReportDataSourceCredential> FillDataSourceCredentials(
    List<ReportDataSource> credentials,
    LocalizationManager localizationManager
)
Visual Basic (Declaration)
Public Function FillDataSourceCredentials ( _
    credentials As List(Of ReportDataSource), _
    localizationManager As LocalizationManager _
) As List(Of ReportDataSourceCredential)
Visual C++
public:
List<ReportDataSourceCredential^>^ FillDataSourceCredentials(
    List<ReportDataSource^>^ credentials,
    LocalizationManager^ localizationManager
)

Parameters

credentials
Type: System.Collections.Generic..::.List <(Of <( ReportDataSource >)>)
The credentials.
localizationManager
Type: PerpetuumSoft.ReportingServices.Viewer.Client.Localization..::.LocalizationManager
The localization manager.

Return Value

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


FillParameterValues Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.FillParameterValues Method
ParametersPanel Class See Also Send Feedback
Fills the content panel by the parameter values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public List<ReportParameterValue> FillParameterValues(
    List<ReportParameter> parameters,
    LocalizationManager localizationManager
)
Visual Basic (Declaration)
Public Function FillParameterValues ( _
    parameters As List(Of ReportParameter), _
    localizationManager As LocalizationManager _
) As List(Of ReportParameterValue)
Visual C++
public:
List<ReportParameterValue^>^ FillParameterValues(
    List<ReportParameter^>^ parameters,
    LocalizationManager^ localizationManager
)

Parameters

parameters
Type: System.Collections.Generic..::.List <(Of <( ReportParameter >)>)
The parameters.
localizationManager
Type: PerpetuumSoft.ReportingServices.Viewer.Client.Localization..::.LocalizationManager
The localization manager.

Return Value

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadDataSourceCredentials Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.LoadDataSourceCredentials Method
ParametersPanel Class See Also Send Feedback
Loads the data-source credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void LoadDataSourceCredentials(
    List<ReportDataSourceCredential> credentialValues
)
Visual Basic (Declaration)
Public Sub LoadDataSourceCredentials ( _
    credentialValues As List(Of ReportDataSourceCredential) _
)
Visual C++
public:
void LoadDataSourceCredentials(
    List<ReportDataSourceCredential^>^ credentialValues
)

Parameters

credentialValues
Type: System.Collections.Generic..::.List <(Of <( ReportDataSourceCredential >)>)
The credential values.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadParameterValues Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.LoadParameterValues Method
ParametersPanel Class See Also Send Feedback
Loads the parameter values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void LoadParameterValues(
    List<ReportParameterValue> parameterValues
)
Visual Basic (Declaration)
Public Sub LoadParameterValues ( _
    parameterValues As List(Of ReportParameterValue) _
)
Visual C++
public:
void LoadParameterValues(
    List<ReportParameterValue^>^ parameterValues
)

Parameters

parameterValues
Type: System.Collections.Generic..::.List <(Of <( ReportParameterValue >)>)
The parameter values.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SaveDataSourceCredentials Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.SaveDataSourceCredentials Method
ParametersPanel Class See Also Send Feedback
Saves the data-source credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public List<ReportDataSourceCredential> SaveDataSourceCredentials()
Visual Basic (Declaration)
Public Function SaveDataSourceCredentials As List(Of ReportDataSourceCredential)
Visual C++
public:
List<ReportDataSourceCredential^>^ SaveDataSourceCredentials()

Return Value

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SaveParameterValues Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.SaveParameterValues Method
ParametersPanel Class See Also Send Feedback
Saves the parameter values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public List<ReportParameterValue> SaveParameterValues()
Visual Basic (Declaration)
Public Function SaveParameterValues As List(Of ReportParameterValue)
Visual C++
public:
List<ReportParameterValue^>^ SaveParameterValues()

Return Value

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanel Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel Properties
ParametersPanel Class See Also Send Feedback

The ParametersPanel type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the accept button. This is a dependency property.
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BooleanParameterControlStyle | Gets or sets the boolean parameter control style. This is a dependency property.
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
CancelButton | Gets or sets the cancel button. This is a dependency property.
Clip | (Inherited from UIElement.)
ClipToBounds | Gets or sets a value indicating whether panel will clip to bounds. This is a dependency property.
ContentPanel | Gets or sets the content panel. This is a dependency property.
CredentialControlStyle | Gets or sets the credential control style. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateTimeParameterControlStyle | Gets or sets the date time parameter control style. This is a dependency property.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHidden | Gets or sets a value indicating whether this panel is hidden. This is a dependency property.
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MultiValidValueParameterControlStyle | Gets or sets the multi valid value parameter control style. This is a dependency property.
MultiValueParameterControlStyle | Gets or sets the multi value parameter control style. This is a dependency property.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SingleValidValueParameterControlStyle | Gets or sets the single valid value parameter control style. This is a dependency property.
StringParameterControlStyle | Gets or sets the string parameter control style. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextForeground | Gets or sets the foreground for text of panel content. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AcceptButton Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.AcceptButton Property
ParametersPanel Class See Also Send Feedback
Gets or sets the accept button. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ButtonBase AcceptButton { get; set; }
Visual Basic (Declaration)
Public Property AcceptButton As ButtonBase
Visual C++
public:
property ButtonBase^ AcceptButton {
    ButtonBase^ get ();
    void set (ButtonBase^ value);
}

Field Value

The accept button.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BooleanParameterControlStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.BooleanParameterControlStyle Property
ParametersPanel Class See Also Send Feedback
Gets or sets the boolean parameter control style. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style BooleanParameterControlStyle { get; set; }
Visual Basic (Declaration)
Public Property BooleanParameterControlStyle As Style
Visual C++
public:
property Style^ BooleanParameterControlStyle {
    Style^ get ();
    void set (Style^ value);
}

Field Value

The boolean parameter control style.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CancelButton Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.CancelButton Property
ParametersPanel Class See Also Send Feedback
Gets or sets the cancel button. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ButtonBase CancelButton { get; set; }
Visual Basic (Declaration)
Public Property CancelButton As ButtonBase
Visual C++
public:
property ButtonBase^ CancelButton {
    ButtonBase^ get ();
    void set (ButtonBase^ value);
}

Field Value

The cancel button.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ClipToBounds Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.ClipToBounds Property
ParametersPanel Class See Also Send Feedback
Gets or sets a value indicating whether panel will clip to bounds. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool ClipToBounds { get; set; }
Visual Basic (Declaration)
Public Property ClipToBounds As Boolean
Visual C++
public:
property bool ClipToBounds {
    bool get ();
    void set (bool value);
}

Field Value

true if panel will clip to bounds; otherwise, false.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ContentPanel Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.ContentPanel Property
ParametersPanel Class See Also Send Feedback
Gets or sets the content panel. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Panel ContentPanel { get; set; }
Visual Basic (Declaration)
Public Property ContentPanel As Panel
Visual C++
public:
property Panel^ ContentPanel {
    Panel^ get ();
    void set (Panel^ value);
}

Field Value

The content panel.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialControlStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.CredentialControlStyle Property
ParametersPanel Class See Also Send Feedback
Gets or sets the credential control style. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style CredentialControlStyle { get; set; }
Visual Basic (Declaration)
Public Property CredentialControlStyle As Style
Visual C++
public:
property Style^ CredentialControlStyle {
    Style^ get ();
    void set (Style^ value);
}

Field Value

The credential control style.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DateTimeParameterControlStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.DateTimeParameterControlStyle Property
ParametersPanel Class See Also Send Feedback
Gets or sets the date time parameter control style. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style DateTimeParameterControlStyle { get; set; }
Visual Basic (Declaration)
Public Property DateTimeParameterControlStyle As Style
Visual C++
public:
property Style^ DateTimeParameterControlStyle {
    Style^ get ();
    void set (Style^ value);
}

Field Value

The date time parameter control style.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsHidden Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.IsHidden Property
ParametersPanel Class See Also Send Feedback
Gets or sets a value indicating whether this panel is hidden. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsHidden { get; set; }
Visual Basic (Declaration)
Public Property IsHidden As Boolean
Visual C++
public:
property bool IsHidden {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is hidden; otherwise, false.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValidValueParameterControlStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.MultiValidValueParameterControlStyle Property
ParametersPanel Class See Also Send Feedback
Gets or sets the multi valid value parameter control style. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style MultiValidValueParameterControlStyle { get; set; }
Visual Basic (Declaration)
Public Property MultiValidValueParameterControlStyle As Style
Visual C++
public:
property Style^ MultiValidValueParameterControlStyle {
    Style^ get ();
    void set (Style^ value);
}

Field Value

The multi valid value parameter control style.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MultiValueParameterControlStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.MultiValueParameterControlStyle Property
ParametersPanel Class See Also Send Feedback
Gets or sets the multi value parameter control style. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style MultiValueParameterControlStyle { get; set; }
Visual Basic (Declaration)
Public Property MultiValueParameterControlStyle As Style
Visual C++
public:
property Style^ MultiValueParameterControlStyle {
    Style^ get ();
    void set (Style^ value);
}

Field Value

The multi value parameter control style.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SingleValidValueParameterControlStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.SingleValidValueParameterControlStyle Property
ParametersPanel Class See Also Send Feedback
Gets or sets the single valid value parameter control style. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style SingleValidValueParameterControlStyle { get; set; }
Visual Basic (Declaration)
Public Property SingleValidValueParameterControlStyle As Style
Visual C++
public:
property Style^ SingleValidValueParameterControlStyle {
    Style^ get ();
    void set (Style^ value);
}

Field Value

The single valid value parameter control style.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StringParameterControlStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.StringParameterControlStyle Property
ParametersPanel Class See Also Send Feedback
Gets or sets the string parameter control style. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style StringParameterControlStyle { get; set; }
Visual Basic (Declaration)
Public Property StringParameterControlStyle As Style
Visual C++
public:
property Style^ StringParameterControlStyle {
    Style^ get ();
    void set (Style^ value);
}

Field Value

The string parameter control style.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TextForeground Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.TextForeground Property
ParametersPanel Class See Also Send Feedback
Gets or sets the foreground for text of panel content. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Brush TextForeground { get; set; }
Visual Basic (Declaration)
Public Property TextForeground As Brush
Visual C++
public:
property Brush^ TextForeground {
    Brush^ get ();
    void set (Brush^ value);
}

Field Value

The text foreground.

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanel Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel Events
ParametersPanel Class See Also Send Feedback

The ParametersPanel type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
ParameterValueChanged | Occurs when any parameter value is changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParameterValueChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParametersPanel..::.ParameterValueChanged Event
ParametersPanel Class See Also Send Feedback
Occurs when any parameter value is changed.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<ParameterValueChangedEventArgs> ParameterValueChanged
Visual Basic (Declaration)
Public Event ParameterValueChanged As EventHandler(Of ParameterValueChangedEventArgs)
Visual C++
public:
 event EventHandler<ParameterValueChangedEventArgs^>^ ParameterValueChanged {
    void add (EventHandler<ParameterValueChangedEventArgs^>^ value);
    void remove (EventHandler<ParameterValueChangedEventArgs^>^ value);
}

See Also

ParametersPanel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParameterValueChangedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParameterValueChangedEventArgs Class
Members See Also Send Feedback
Provides data for the ParameterValueChanged event.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ParameterValueChangedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ParameterValueChangedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ParameterValueChangedEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.ReportingServices.Viewer.Client..::.ParameterValueChangedEventArgs

See Also

ParameterValueChangedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParameterValueChangedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParameterValueChangedEventArgs Members
ParameterValueChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ParameterValueChangedEventArgs type exposes the following members.

Constructors

Name | Description
ParameterValueChangedEventArgs | Initializes a new instance of the ParameterValueChangedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NewParameterValueList | Gets or sets a new parameter value list.

See Also

ParameterValueChangedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParameterValueChangedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParameterValueChangedEventArgs Constructor
ParameterValueChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the ParameterValueChangedEventArgs class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ParameterValueChangedEventArgs(
    List<ReportParameterValue> newParameterValueList
)
Visual Basic (Declaration)
Public Sub New ( _
    newParameterValueList As List(Of ReportParameterValue) _
)
Visual C++
public:
ParameterValueChangedEventArgs(
    List<ReportParameterValue^>^ newParameterValueList
)

Parameters

newParameterValueList
Type: System.Collections.Generic..::.List <(Of <( ReportParameterValue >)>)
A new parameter value.

See Also

ParameterValueChangedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParameterValueChangedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParameterValueChangedEventArgs Methods
ParameterValueChangedEventArgs Class See Also Send Feedback

The ParameterValueChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterValueChangedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParameterValueChangedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParameterValueChangedEventArgs Properties
ParameterValueChangedEventArgs Class See Also Send Feedback

The ParameterValueChangedEventArgs type exposes the following members.

Properties

Name | Description
NewParameterValueList | Gets or sets a new parameter value list.

See Also

ParameterValueChangedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NewParameterValueList Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParameterValueChangedEventArgs..::.NewParameterValueList Property
ParameterValueChangedEventArgs Class See Also Send Feedback
Gets or sets a new parameter value list.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public List<ReportParameterValue> NewParameterValueList { get; private set; }
Visual Basic (Declaration)
Public Property NewParameterValueList As List(Of ReportParameterValue)
Visual C++
public:
property List<ReportParameterValue^>^ NewParameterValueList {
    List<ReportParameterValue^>^ get ();
    void set (List<ReportParameterValue^>^ value);
}

See Also

ParameterValueChangedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Progress Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Progress Class
Members See Also Send Feedback
This class realizes progress bar. Inherited from Control.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class Progress : Control
Visual Basic (Declaration)
Public Class Progress _
    Inherits Control
Visual C++
public ref class Progress : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.Progress

See Also

Progress Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Progress Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Progress Members
Progress Class Constructors Methods Fields Properties Events See Also Send Feedback

The Progress type exposes the following members.

Constructors

Name | Description
Progress | Initializes a new instance of the Progress class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
TextProperty | Identifies the Text dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text which is displayed in progress bar. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Progress Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Progress Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Progress Constructor
Progress Class See Also Send Feedback
Initializes a new instance of the Progress class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Progress()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Progress()

See Also

Progress Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Progress Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Progress Fields
Progress Class See Also Send Feedback

The Progress type exposes the following members.

Fields

Name | Description
TextProperty | Identifies the Text dependency property.

See Also

Progress Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Progress..::.TextProperty Field
Progress Class See Also Send Feedback
Identifies the Text dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty TextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TextProperty

See Also

Progress Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Progress Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Progress Methods
Progress Class See Also Send Feedback

The Progress type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Progress Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Progress..::.OnApplyTemplate Method
Progress Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

Progress Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Progress Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Progress Properties
Progress Class See Also Send Feedback

The Progress type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text which is displayed in progress bar. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Progress Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Text Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Progress..::.Text Property
Progress Class See Also Send Feedback
Gets or sets the text which is displayed in progress bar. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

Progress Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Progress Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Progress Events
Progress Class See Also Send Feedback

The Progress type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Progress Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RegionZoomTool Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
RegionZoomTool Class
Members See Also Send Feedback
Class for realization of the tool which is used for scaling the report in the selected area. Inherited from StandardTool.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class RegionZoomTool : StandardTool
Visual Basic (Declaration)
Public Class RegionZoomTool _
    Inherits StandardTool
Visual C++
public ref class RegionZoomTool : public StandardTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
PerpetuumSoft.ReportingServices.Viewer.Client..::.StandardTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.RegionZoomTool

See Also

RegionZoomTool Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RegionZoomTool Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
RegionZoomTool Members
RegionZoomTool Class Constructors Methods Properties See Also Send Feedback

The RegionZoomTool type exposes the following members.

Constructors

Name | Description
RegionZoomTool | Initializes a new instance of the RegionZoomTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

RegionZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RegionZoomTool Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
RegionZoomTool Constructor
RegionZoomTool Class See Also Send Feedback
Initializes a new instance of the RegionZoomTool class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public RegionZoomTool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
RegionZoomTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The manager.

See Also

RegionZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RegionZoomTool Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
RegionZoomTool Methods
RegionZoomTool Class See Also Send Feedback

The RegionZoomTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

See Also

RegionZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
RegionZoomTool..::.MouseDown Method
RegionZoomTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

RegionZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseMove Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
RegionZoomTool..::.MouseMove Method
RegionZoomTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

RegionZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
RegionZoomTool..::.MouseUp Method
RegionZoomTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

RegionZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateCursor Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
RegionZoomTool..::.UpdateCursor Method
RegionZoomTool Class See Also Send Feedback
Overridden. See UpdateCursor()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

RegionZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RegionZoomTool Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
RegionZoomTool Properties
RegionZoomTool Class See Also Send Feedback

The RegionZoomTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

RegionZoomTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportErrorEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportErrorEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when there is generation error.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportErrorEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ReportErrorEventArgs _
    Inherits EventArgs
Visual C++
public ref class ReportErrorEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportErrorEventArgs

See Also

ReportErrorEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportErrorEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportErrorEventArgs Members
ReportErrorEventArgs Class Constructors Methods Properties See Also Send Feedback

The ReportErrorEventArgs type exposes the following members.

Constructors

Name | Description
ReportErrorEventArgs | Initializes a new instance of the ReportErrorEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets or sets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Handled | Gets or sets a value that indicates the present state of the event handling.
ViewModel | Gets or sets ViewModel which is the report view model.

See Also

ReportErrorEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportErrorEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportErrorEventArgs Constructor
ReportErrorEventArgs Class See Also Send Feedback
Initializes a new instance of the ReportErrorEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportErrorEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportErrorEventArgs()

See Also

ReportErrorEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportErrorEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportErrorEventArgs Methods
ReportErrorEventArgs Class See Also Send Feedback

The ReportErrorEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportErrorEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportErrorEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportErrorEventArgs Properties
ReportErrorEventArgs Class See Also Send Feedback

The ReportErrorEventArgs type exposes the following members.

Properties

Name | Description
Exception | Gets or sets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Handled | Gets or sets a value that indicates the present state of the event handling.
ViewModel | Gets or sets ViewModel which is the report view model.

See Also

ReportErrorEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Exception Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportErrorEventArgs..::.Exception Property
ReportErrorEventArgs Class See Also Send Feedback
Gets or sets ExceptionDetailBase which is wrapper of exception occurred during operation execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase Exception { get; set; }
Visual Basic (Declaration)
Public Property Exception As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ Exception {
    ExceptionDetailBase^ get ();
    void set (ExceptionDetailBase^ value);
}

Field Value

The exception.

See Also

ReportErrorEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Handled Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportErrorEventArgs..::.Handled Property
ReportErrorEventArgs Class See Also Send Feedback
Gets or sets a value that indicates the present state of the event handling.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Field Value

true if it is handled; otherwise, false.

See Also

ReportErrorEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewModel Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportErrorEventArgs..::.ViewModel Property
ReportErrorEventArgs Class See Also Send Feedback
Gets or sets ViewModel which is the report view model.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewModel ViewModel { get; set; }
Visual Basic (Declaration)
Public Property ViewModel As ViewModel
Visual C++
public:
property ViewModel^ ViewModel {
    ViewModel^ get ();
    void set (ViewModel^ value);
}

Field Value

The view model.

See Also

ReportErrorEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportHyperlinkEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportHyperlinkEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when hyperlink is clicked.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportHyperlinkEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ReportHyperlinkEventArgs _
    Inherits EventArgs
Visual C++
public ref class ReportHyperlinkEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportHyperlinkEventArgs

See Also

ReportHyperlinkEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportHyperlinkEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportHyperlinkEventArgs Members
ReportHyperlinkEventArgs Class Constructors Methods Properties See Also Send Feedback

The ReportHyperlinkEventArgs type exposes the following members.

Constructors

Name | Description
ReportHyperlinkEventArgs | Initializes a new instance of the ReportHyperlinkEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Handled | Gets or sets a value that indicates the present state of the event handling.
Hyperlink | Gets or sets hyperlink text.

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportHyperlinkEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportHyperlinkEventArgs Constructor
ReportHyperlinkEventArgs Class See Also Send Feedback
Initializes a new instance of the ReportHyperlinkEventArgs class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportHyperlinkEventArgs(
    string hyperlink
)
Visual Basic (Declaration)
Public Sub New ( _
    hyperlink As String _
)
Visual C++
public:
ReportHyperlinkEventArgs(
    String^ hyperlink
)

Parameters

hyperlink
Type: System..::.String
The hyperlink.

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportHyperlinkEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportHyperlinkEventArgs Methods
ReportHyperlinkEventArgs Class See Also Send Feedback

The ReportHyperlinkEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportHyperlinkEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportHyperlinkEventArgs Properties
ReportHyperlinkEventArgs Class See Also Send Feedback

The ReportHyperlinkEventArgs type exposes the following members.

Properties

Name | Description
Handled | Gets or sets a value that indicates the present state of the event handling.
Hyperlink | Gets or sets hyperlink text.

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Handled Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportHyperlinkEventArgs..::.Handled Property
ReportHyperlinkEventArgs Class See Also Send Feedback
Gets or sets a value that indicates the present state of the event handling.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Field Value

true if it is handled; otherwise, false.

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Hyperlink Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportHyperlinkEventArgs..::.Hyperlink Property
ReportHyperlinkEventArgs Class See Also Send Feedback
Gets or sets hyperlink text.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Hyperlink { get; private set; }
Visual Basic (Declaration)
Public Property Hyperlink As String
Visual C++
public:
property String^ Hyperlink {
    String^ get ();
    void set (String^ value);
}

Field Value

The hyperlink text.

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportParameterControl Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl Class
Members See Also Send Feedback
An abstract class. This class is intended to encapsulate common logic for report parameter controls. Inherited from BaseParameterControl.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract class ReportParameterControl : BaseParameterControl
Visual Basic (Declaration)
Public MustInherit Class ReportParameterControl _
    Inherits BaseParameterControl
Visual C++
public ref class ReportParameterControl abstract : public BaseParameterControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.BaseParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.BooleanParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.DateTimeParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.MultiValidValueParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.MultiValueParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.SingleValidValueParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.StringParameterControl

See Also

ReportParameterControl Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportParameterControl Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl Members
ReportParameterControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The ReportParameterControl type exposes the following members.

Constructors

Name | Description
ReportParameterControl | Initializes a new instance of the ReportParameterControl class

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Sets the focus on parameter control. (Inherited from BaseParameterControl.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_values |
ParameterValueChanged | Occurs when parameter value changes in parameter control.
PromptTextProperty | Identifies the PromptText dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsRequired | Gets or sets a value indicating whether the parameter is required.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Values | Gets or sets the values for parameter.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportParameterControl Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl Constructor
ReportParameterControl Class See Also Send Feedback
Initializes a new instance of the ReportParameterControl class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected ReportParameterControl()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ReportParameterControl()

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportParameterControl Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl Fields
ReportParameterControl Class See Also Send Feedback

The ReportParameterControl type exposes the following members.

Fields

Name | Description
_values |
ParameterValueChanged | Occurs when parameter value changes in parameter control.
PromptTextProperty | Identifies the PromptText dependency property.

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


_values Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl..::._values Field
ReportParameterControl Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected List<ValidValue> _values
Visual Basic (Declaration)
Protected _values As List(Of ValidValue)
Visual C++
protected:
List<ValidValue^>^ _values

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParameterValueChanged Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl..::.ParameterValueChanged Field
ReportParameterControl Class See Also Send Feedback
Occurs when parameter value changes in parameter control.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public EventHandler<ParameterValueChangedEventArgs> ParameterValueChanged
Visual Basic (Declaration)
Public ParameterValueChanged As EventHandler(Of ParameterValueChangedEventArgs)
Visual C++
public:
EventHandler<ParameterValueChangedEventArgs^>^ ParameterValueChanged

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PromptTextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl..::.PromptTextProperty Field
ReportParameterControl Class See Also Send Feedback
Identifies the PromptText dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty PromptTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly PromptTextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PromptTextProperty

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportParameterControl Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl Methods
ReportParameterControl Class See Also Send Feedback

The ReportParameterControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Sets the focus on parameter control. (Inherited from BaseParameterControl.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CompareValidValueLists Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl..::.CompareValidValueLists Method
ReportParameterControl Class See Also Send Feedback
Compares the valid value lists.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected bool CompareValidValueLists(
    List<ValidValue> xList,
    List<ValidValue> yList
)
Visual Basic (Declaration)
Protected Function CompareValidValueLists ( _
    xList As List(Of ValidValue), _
    yList As List(Of ValidValue) _
) As Boolean
Visual C++
protected:
bool CompareValidValueLists(
    List<ValidValue^>^ xList,
    List<ValidValue^>^ yList
)

Parameters

xList
Type: System.Collections.Generic..::.List <(Of <( ValidValue >)>)
The x list.
yList
Type: System.Collections.Generic..::.List <(Of <( ValidValue >)>)
The y list.

Return Value

true if lists are identical; otherwise false.

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnParameterValueChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl..::.OnParameterValueChanged Method
ReportParameterControl Class See Also Send Feedback
Called when parameter value changed.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void OnParameterValueChanged(
    List<ReportParameterValue> parameterValues
)
Visual Basic (Declaration)
Public Sub OnParameterValueChanged ( _
    parameterValues As List(Of ReportParameterValue) _
)
Visual C++
public:
void OnParameterValueChanged(
    List<ReportParameterValue^>^ parameterValues
)

Parameters

parameterValues
Type: System.Collections.Generic..::.List <(Of <( ReportParameterValue >)>)
The parameter values.

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportParameterControl Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl Properties
ReportParameterControl Class See Also Send Feedback

The ReportParameterControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsRequired | Gets or sets a value indicating whether the parameter is required.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Values | Gets or sets the values for parameter.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsRequired Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl..::.IsRequired Property
ReportParameterControl Class See Also Send Feedback
Gets or sets a value indicating whether the parameter is required.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool IsRequired { get; set; }
Visual Basic (Declaration)
Public Overridable Property IsRequired As Boolean
Visual C++
public:
virtual property bool IsRequired {
    bool get ();
    void set (bool value);
}

Field Value

true if the parameter is required; otherwise, false.

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PromptText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl..::.PromptText Property
ReportParameterControl Class See Also Send Feedback
Gets or sets the prompt text for parameter. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string PromptText { get; set; }
Visual Basic (Declaration)
Public Property PromptText As String
Visual C++
public:
property String^ PromptText {
    String^ get ();
    void set (String^ value);
}

Field Value

The prompt text.

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Values Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl..::.Values Property
ReportParameterControl Class See Also Send Feedback
Gets or sets the values for parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public virtual List<ValidValue> Values { get; set; }
Visual Basic (Declaration)
Public Overridable Property Values As List(Of ValidValue)
Visual C++
public:
virtual property List<ValidValue^>^ Values {
    List<ValidValue^>^ get ();
    void set (List<ValidValue^>^ value);
}

Field Value

The values.

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportParameterControl Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterControl Events
ReportParameterControl Class See Also Send Feedback

The ReportParameterControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ReportParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportRegion Structure

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportRegion Structure
Members See Also Send Feedback
Report area.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public struct ReportRegion
Visual Basic (Declaration)
Public Structure ReportRegion
Visual C++
public value class ReportRegion

See Also

ReportRegion Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportRegion Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportRegion Members
ReportRegion Structure Constructors Methods Properties See Also Send Feedback

The ReportRegion type exposes the following members.

Constructors

Name | Description
ReportRegion | Initializes a new instance of the ReportRegion struct.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
PageNumber | Gets the page number.
Rectangle | Gets area coordinates.

See Also

ReportRegion Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportRegion Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportRegion Constructor
ReportRegion Structure See Also Send Feedback
Initializes a new instance of the ReportRegion struct.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportRegion(
    int pageNumber,
    Rect rectangle
)
Visual Basic (Declaration)
Public Sub New ( _
    pageNumber As Integer, _
    rectangle As Rect _
)
Visual C++
public:
ReportRegion(
    int pageNumber,
    Rect rectangle
)

Parameters

pageNumber
Type: System..::.Int32
The page number.
rectangle
Type: System.Windows..::.Rect
The rectangle. The instance of Rect structure.

See Also

ReportRegion Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportRegion Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportRegion Methods
ReportRegion Structure See Also Send Feedback

The ReportRegion type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ReportRegion Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportRegion Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportRegion Properties
ReportRegion Structure See Also Send Feedback

The ReportRegion type exposes the following members.

Properties

Name | Description
PageNumber | Gets the page number.
Rectangle | Gets area coordinates.

See Also

ReportRegion Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageNumber Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportRegion..::.PageNumber Property
ReportRegion Structure See Also Send Feedback
Gets the page number.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int PageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
}

Field Value

The page number.

See Also

ReportRegion Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Rectangle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportRegion..::.Rectangle Property
ReportRegion Structure See Also Send Feedback
Gets area coordinates.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Rect Rectangle { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rectangle As Rect
Visual C++
public:
property Rect Rectangle {
    Rect get ();
}

Field Value

The area coordinates. The instance of Rect struct.

See Also

ReportRegion Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportState Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportState Class
Members See Also Send Feedback
The ReportState class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportState
Visual Basic (Declaration)
Public Class ReportState
Visual C++
public ref class ReportState

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportState

See Also

ReportState Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportState Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportState Members
ReportState Class Constructors Methods Properties See Also Send Feedback

The ReportState type exposes the following members.

Constructors

Name | Description
ReportState | Initializes the ReportState class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ReportExecutionInfo | Get the ReportExecutionInfo assotiates with the report state.
ViewModel | Gets the ViewModel assotiated with the report state.

See Also

ReportState Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportState Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportState Constructor
ReportState Class See Also Send Feedback
Initializes the ReportState class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportState(
    ViewModel viewModel,
    ReportExecutionInfo reportExecutionInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    viewModel As ViewModel, _
    reportExecutionInfo As ReportExecutionInfo _
)
Visual C++
public:
ReportState(
    ViewModel^ viewModel,
    ReportExecutionInfo^ reportExecutionInfo
)

Parameters

viewModel
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewModel
A ViewModel class.
reportExecutionInfo
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ReportExecutionInfo
A ReportExecutionInfo class.

See Also

ReportState Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportState Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportState Methods
ReportState Class See Also Send Feedback

The ReportState type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportState Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportState Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportState Properties
ReportState Class See Also Send Feedback

The ReportState type exposes the following members.

Properties

Name | Description
ReportExecutionInfo | Get the ReportExecutionInfo assotiates with the report state.
ViewModel | Gets the ViewModel assotiated with the report state.

See Also

ReportState Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportExecutionInfo Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportState..::.ReportExecutionInfo Property
ReportState Class See Also Send Feedback
Get the ReportExecutionInfo assotiates with the report state.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportExecutionInfo ReportExecutionInfo { get; private set; }
Visual Basic (Declaration)
Public Property ReportExecutionInfo As ReportExecutionInfo
Visual C++
public:
property ReportExecutionInfo^ ReportExecutionInfo {
    ReportExecutionInfo^ get ();
    void set (ReportExecutionInfo^ value);
}

See Also

ReportState Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewModel Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportState..::.ViewModel Property
ReportState Class See Also Send Feedback
Gets the ViewModel assotiated with the report state.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewModel ViewModel { get; private set; }
Visual Basic (Declaration)
Public Property ViewModel As ViewModel
Visual C++
public:
property ViewModel^ ViewModel {
    ViewModel^ get ();
    void set (ViewModel^ value);
}

See Also

ReportState Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportViewer Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer Class
Members See Also Send Feedback
A control for report preview, navigation by pages, export and search.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportViewer : Control,
    IView
Visual Basic (Declaration)
Public Class ReportViewer _
    Inherits Control _
    Implements IView
Visual C++
public ref class ReportViewer : public Control,
    IView

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportViewer

See Also

ReportViewer Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportViewer Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer Members
ReportViewer Class Constructors Methods Fields Properties Events See Also Send Feedback

The ReportViewer type exposes the following members.

Constructors

Name | Description
ReportViewer | Initializes a new instance of the ReportViewer class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDocumentLoaded | Raises the DocumentLoaded event.
OnGotFocus | (Inherited from Control.)
OnHyperlinkClick | Raises the HyperlinkClick event.
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPageLoaded | Raises the PageLoaded event.
OnReportError | Raises the ReportError event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RenderDocument | Overloaded.
SaveInHistory | Saves the current report display state.
Search | Executes text search through report.
SetBinding | (Inherited from FrameworkElement.)
SetReportServiceClientBinding | Sets the report service client binding.
SetValue | (Inherited from DependencyObject.)
SetZoom | Sets view scale.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AnimationDurationProperty | Identifies the AnimationDuration dependency property.
DebugModeProperty | Identifies the DebugMode dependency property.
ErrorPresenterStyleProperty | Identifies the ErrorPresenterStyle dependency property.
InitializingStateStyleProperty | Identifies the InitializingStateStyle dependency property.
LoadingPageStyleProperty | Identifies the LoadingPageStyle dependency property.
LoadingStateStyleProperty | Identifies the LoadingStateStyle dependency property.
MouseWheelSpeedProperty | Identifies the MouseWheelSpeed dependency property.
NoReportStyleProperty | Identifies the NoReportStyle dependency property.
PageGapProperty | Identifies the PageGap dependency property.
PageMarginProperty | Identifies the PageMargin dependency property.
PagePresenterStyleProperty | Identifies the PagePresenterStyle dependency property.
ParametersPanelBackgroundProperty | Identifies the ParametersPanelBackground dependency property.
ParametersPanelForegroundProperty | Identifies the ParametersPanelForeground dependency property.
RenderingStateStyleProperty | Identifies the RenderingStateStyle dependency property.
ReportNameProperty | Identifies the ReportName dependency property.
SelectStyleProperty | Identifies the SelectStyle dependency property.
ServiceUrlProperty | Identifies the ServiceUrl dependency property.
StatusBarVisibleProperty | Identifies the StatusBarVisible dependency property.
ToolBarBackgroundProperty | Identifies the ToolBarBackground dependency property.
ToolBarForegroundProperty | Identifies the ToolBarForeground dependency property.
ToolBarVisibleProperty | Identifies the ToolBarVisible dependency property.
ViewOptionsProperty | Identifies the ViewOptions dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AnimationDuration | Implements AnimationDuration()()(). This is a dependency property.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Credentials | Gets or sets List<(Of <(T>)>) which are active report data-source credentials.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DebugMode | Gets or sets Report Viewer debug mode. This is a dependency property. Implements DebugMode()()().
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
ErrorPresenterStyle | Implements ErrorPresenterStyle()()(). This is a dependency property.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InitializingStateStyle | Implements InitializingStateStyle()()(). This is a dependency property.
IsDesignMode | Gets the value indicating that the viewer in design mode state.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LoadingPageStyle | Implements LoadingPageStyle()()(). This is a dependency property.
LoadingStateStyle | Implements LoadingStateStyle()()(). This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseWheelSpeed | Implements MouseWheelSpeed()()(). This is a dependency property.
Name | (Inherited from FrameworkElement.)
NoReportStyle | Implements NoReportStyle()()(). This is a dependency property.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
PageGap | Implements PageGap()()(). This is a dependency property.
PageMargin | Implements PageMargin()()(). This is a dependency property.
PagePresenterStyle | Implements PagePresenterStyle()()(). This is a dependency property.
Parameters | Gets or sets List<(Of <(T>)>) which are report parameters for report indicated by ReportName.
ParametersPanelBackground | Gets or sets the parameters panel background. This is a dependency property.
ParametersPanelForeground | Gets or sets the labels colors on parameters panel. This is a dependency property.
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderingStateStyle | Implements RenderingStateStyle()()(). This is a dependency property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
ReportName | Gets or sets active report name. This is a dependency property.
Resources | (Inherited from FrameworkElement.)
SearchText | Gets or sets search text.
SelectStyle | Implements SelectStyle()()(). This is a dependency property.
ServiceUrl | Gets or sets reports WCF service url. This is a dependency property. Implements ServiceUrl()()().
StatusBarVisible | Gets or sets the property which indicates if status bar is visible. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
ToolBarBackground | Gets or sets the toolbar background. This is a dependency property.
ToolBarForeground | Gets or sets the labels colors on toolbar. This is a dependency property.
ToolBarVisible | Gets or sets the property which indicates if toolbar is visible. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Implements ViewManager.
ViewOptions | Gets or sets ViewOptions which are report preview options (switch on/off element functions used for preview). This is a dependency property.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DocumentLoaded | Occurs when document is loaded.
GotFocus | (Inherited from UIElement.)
HyperlinkClick | Occurs when hyperlink is clicked.
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PageLoaded | Occurs when page is loaded.
ReportError | Occurs when report error happens.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportViewer Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer Constructor
ReportViewer Class See Also Send Feedback
Initializes a new instance of the ReportViewer class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportViewer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportViewer()

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportViewer Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer Fields
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Fields

Name | Description
AnimationDurationProperty | Identifies the AnimationDuration dependency property.
DebugModeProperty | Identifies the DebugMode dependency property.
ErrorPresenterStyleProperty | Identifies the ErrorPresenterStyle dependency property.
InitializingStateStyleProperty | Identifies the InitializingStateStyle dependency property.
LoadingPageStyleProperty | Identifies the LoadingPageStyle dependency property.
LoadingStateStyleProperty | Identifies the LoadingStateStyle dependency property.
MouseWheelSpeedProperty | Identifies the MouseWheelSpeed dependency property.
NoReportStyleProperty | Identifies the NoReportStyle dependency property.
PageGapProperty | Identifies the PageGap dependency property.
PageMarginProperty | Identifies the PageMargin dependency property.
PagePresenterStyleProperty | Identifies the PagePresenterStyle dependency property.
ParametersPanelBackgroundProperty | Identifies the ParametersPanelBackground dependency property.
ParametersPanelForegroundProperty | Identifies the ParametersPanelForeground dependency property.
RenderingStateStyleProperty | Identifies the RenderingStateStyle dependency property.
ReportNameProperty | Identifies the ReportName dependency property.
SelectStyleProperty | Identifies the SelectStyle dependency property.
ServiceUrlProperty | Identifies the ServiceUrl dependency property.
StatusBarVisibleProperty | Identifies the StatusBarVisible dependency property.
ToolBarBackgroundProperty | Identifies the ToolBarBackground dependency property.
ToolBarForegroundProperty | Identifies the ToolBarForeground dependency property.
ToolBarVisibleProperty | Identifies the ToolBarVisible dependency property.
ViewOptionsProperty | Identifies the ViewOptions dependency property.

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AnimationDurationProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.AnimationDurationProperty Field
ReportViewer Class See Also Send Feedback
Identifies the AnimationDuration dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty AnimationDurationProperty
Visual Basic (Declaration)
Public Shared ReadOnly AnimationDurationProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AnimationDurationProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DebugModeProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.DebugModeProperty Field
ReportViewer Class See Also Send Feedback
Identifies the DebugMode dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static DependencyProperty DebugModeProperty
Visual Basic (Declaration)
Public Shared DebugModeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DebugModeProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ErrorPresenterStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ErrorPresenterStyleProperty Field
ReportViewer Class See Also Send Feedback
Identifies the ErrorPresenterStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ErrorPresenterStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ErrorPresenterStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ErrorPresenterStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


InitializingStateStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.InitializingStateStyleProperty Field
ReportViewer Class See Also Send Feedback
Identifies the InitializingStateStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty InitializingStateStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly InitializingStateStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ InitializingStateStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingPageStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.LoadingPageStyleProperty Field
ReportViewer Class See Also Send Feedback
Identifies the LoadingPageStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty LoadingPageStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly LoadingPageStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LoadingPageStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingStateStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.LoadingStateStyleProperty Field
ReportViewer Class See Also Send Feedback
Identifies the LoadingStateStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty LoadingStateStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly LoadingStateStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LoadingStateStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelSpeedProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.MouseWheelSpeedProperty Field
ReportViewer Class See Also Send Feedback
Identifies the MouseWheelSpeed dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty MouseWheelSpeedProperty
Visual Basic (Declaration)
Public Shared ReadOnly MouseWheelSpeedProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MouseWheelSpeedProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NoReportStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.NoReportStyleProperty Field
ReportViewer Class See Also Send Feedback
Identifies the NoReportStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty NoReportStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly NoReportStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ NoReportStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageGapProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.PageGapProperty Field
ReportViewer Class See Also Send Feedback
Identifies the PageGap dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty PageGapProperty
Visual Basic (Declaration)
Public Shared ReadOnly PageGapProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PageGapProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageMarginProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.PageMarginProperty Field
ReportViewer Class See Also Send Feedback
Identifies the PageMargin dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty PageMarginProperty
Visual Basic (Declaration)
Public Shared ReadOnly PageMarginProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PageMarginProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PagePresenterStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.PagePresenterStyleProperty Field
ReportViewer Class See Also Send Feedback
Identifies the PagePresenterStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty PagePresenterStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly PagePresenterStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PagePresenterStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanelBackgroundProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ParametersPanelBackgroundProperty Field
ReportViewer Class See Also Send Feedback
Identifies the ParametersPanelBackground dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ParametersPanelBackgroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly ParametersPanelBackgroundProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ParametersPanelBackgroundProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanelForegroundProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ParametersPanelForegroundProperty Field
ReportViewer Class See Also Send Feedback
Identifies the ParametersPanelForeground dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ParametersPanelForegroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly ParametersPanelForegroundProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ParametersPanelForegroundProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RenderingStateStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.RenderingStateStyleProperty Field
ReportViewer Class See Also Send Feedback
Identifies the RenderingStateStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty RenderingStateStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly RenderingStateStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ RenderingStateStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportNameProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ReportNameProperty Field
ReportViewer Class See Also Send Feedback
Identifies the ReportName dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static DependencyProperty ReportNameProperty
Visual Basic (Declaration)
Public Shared ReportNameProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ReportNameProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SelectStyleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.SelectStyleProperty Field
ReportViewer Class See Also Send Feedback
Identifies the SelectStyle dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty SelectStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ServiceUrlProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ServiceUrlProperty Field
ReportViewer Class See Also Send Feedback
Identifies the ServiceUrl dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static DependencyProperty ServiceUrlProperty
Visual Basic (Declaration)
Public Shared ServiceUrlProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ServiceUrlProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StatusBarVisibleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.StatusBarVisibleProperty Field
ReportViewer Class See Also Send Feedback
Identifies the StatusBarVisible dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty StatusBarVisibleProperty
Visual Basic (Declaration)
Public Shared ReadOnly StatusBarVisibleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ StatusBarVisibleProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBarBackgroundProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ToolBarBackgroundProperty Field
ReportViewer Class See Also Send Feedback
Identifies the ToolBarBackground dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ToolBarBackgroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToolBarBackgroundProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ToolBarBackgroundProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBarForegroundProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ToolBarForegroundProperty Field
ReportViewer Class See Also Send Feedback
Identifies the ToolBarForeground dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ToolBarForegroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToolBarForegroundProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ToolBarForegroundProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBarVisibleProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ToolBarVisibleProperty Field
ReportViewer Class See Also Send Feedback
Identifies the ToolBarVisible dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ToolBarVisibleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToolBarVisibleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ToolBarVisibleProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewOptionsProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ViewOptionsProperty Field
ReportViewer Class See Also Send Feedback
Identifies the ViewOptions dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ViewOptionsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ViewOptionsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ViewOptionsProperty

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportViewer Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer Methods
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDocumentLoaded | Raises the DocumentLoaded event.
OnGotFocus | (Inherited from Control.)
OnHyperlinkClick | Raises the HyperlinkClick event.
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPageLoaded | Raises the PageLoaded event.
OnReportError | Raises the ReportError event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RenderDocument | Overloaded.
SaveInHistory | Saves the current report display state.
Search | Executes text search through report.
SetBinding | (Inherited from FrameworkElement.)
SetReportServiceClientBinding | Sets the report service client binding.
SetValue | (Inherited from DependencyObject.)
SetZoom | Sets view scale.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.OnApplyTemplate Method
ReportViewer Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnDocumentLoaded Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.OnDocumentLoaded Method
ReportViewer Class See Also Send Feedback
Raises the DocumentLoaded event.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void OnDocumentLoaded(
    DocumentLoadedEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnDocumentLoaded ( _
    args As DocumentLoadedEventArgs _
)
Visual C++
protected:
virtual void OnDocumentLoaded(
    DocumentLoadedEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.DocumentLoadedEventArgs
The DocumentLoadedEventArgs instance containing the event data.

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnHyperlinkClick Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.OnHyperlinkClick Method
ReportViewer Class See Also Send Feedback
Raises the HyperlinkClick event.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void OnHyperlinkClick(
    ReportHyperlinkEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnHyperlinkClick ( _
    args As ReportHyperlinkEventArgs _
)
Visual C++
protected:
virtual void OnHyperlinkClick(
    ReportHyperlinkEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportHyperlinkEventArgs
The ReportHyperlinkEventArgs instance containing the event data.

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnPageLoaded Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.OnPageLoaded Method
ReportViewer Class See Also Send Feedback
Raises the PageLoaded event.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void OnPageLoaded(
    PageLoadedEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnPageLoaded ( _
    args As PageLoadedEventArgs _
)
Visual C++
protected:
virtual void OnPageLoaded(
    PageLoadedEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.PageLoadedEventArgs
The PageLoadedEventArgs instance containing the event data.

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnReportError Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.OnReportError Method
ReportViewer Class See Also Send Feedback
Raises the ReportError event.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void OnReportError(
    ReportErrorEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnReportError ( _
    args As ReportErrorEventArgs _
)
Visual C++
protected:
virtual void OnReportError(
    ReportErrorEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportErrorEventArgs
The ReportErrorEventArgs instance containing the event data.

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RenderDocument Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.RenderDocument Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
RenderDocument()()() | Performs report rendering.
RenderDocument(Boolean) | Performs report rendering.

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RenderDocument Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.RenderDocument Method
ReportViewer Class See Also Send Feedback
Performs report rendering.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void RenderDocument()
Visual Basic (Declaration)
Public Sub RenderDocument
Visual C++
public:
void RenderDocument()

See Also

ReportViewer Class
RenderDocument Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RenderDocument Method (Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.RenderDocument Method (Boolean)
ReportViewer Class See Also Send Feedback
Performs report rendering.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void RenderDocument(
    bool needClearHistory
)
Visual Basic (Declaration)
Public Sub RenderDocument ( _
    needClearHistory As Boolean _
)
Visual C++
public:
void RenderDocument(
    bool needClearHistory
)

Parameters

needClearHistory
Type: System..::.Boolean
if set to true if need clear report history.

See Also

ReportViewer Class
RenderDocument Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SaveInHistory Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.SaveInHistory Method
ReportViewer Class See Also Send Feedback
Saves the current report display state.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SaveInHistory()
Visual Basic (Declaration)
Public Sub SaveInHistory
Visual C++
public:
void SaveInHistory()

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Search Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.Search Method
ReportViewer Class See Also Send Feedback
Executes text search through report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void Search(
    string text,
    SearchDirectionEnum direction,
    bool fromBeginning
)
Visual Basic (Declaration)
Public Sub Search ( _
    text As String, _
    direction As SearchDirectionEnum, _
    fromBeginning As Boolean _
)
Visual C++
public:
void Search(
    String^ text,
    SearchDirectionEnum direction,
    bool fromBeginning
)

Parameters

text
Type: System..::.String
The text.
direction
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SearchDirectionEnum
The direction.
fromBeginning
Type: System..::.Boolean
If it is set to true then the search will be started from beginning of report.

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetReportServiceClientBinding Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.SetReportServiceClientBinding Method
ReportViewer Class See Also Send Feedback
Sets the report service client binding.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SetReportServiceClientBinding(
    Binding binding
)
Visual Basic (Declaration)
Public Sub SetReportServiceClientBinding ( _
    binding As Binding _
)
Visual C++
public:
void SetReportServiceClientBinding(
    Binding^ binding
)

Parameters

binding
Type: System.ServiceModel.Channels..::.Binding
The binding.

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetZoom Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.SetZoom Method
ReportViewer Class See Also Send Feedback
Sets view scale.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SetZoom(
    ZoomMode mode,
    double scale
)
Visual Basic (Declaration)
Public Sub SetZoom ( _
    mode As ZoomMode, _
    scale As Double _
)
Visual C++
public:
void SetZoom(
    ZoomMode mode,
    double scale
)

Parameters

mode
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomMode
The mode. The instance of the ZoomMode class.
scale
Type: System..::.Double
The scale.

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportViewer Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer Properties
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AnimationDuration | Implements AnimationDuration()()(). This is a dependency property.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Credentials | Gets or sets List<(Of <(T>)>) which are active report data-source credentials.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DebugMode | Gets or sets Report Viewer debug mode. This is a dependency property. Implements DebugMode()()().
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
ErrorPresenterStyle | Implements ErrorPresenterStyle()()(). This is a dependency property.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InitializingStateStyle | Implements InitializingStateStyle()()(). This is a dependency property.
IsDesignMode | Gets the value indicating that the viewer in design mode state.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LoadingPageStyle | Implements LoadingPageStyle()()(). This is a dependency property.
LoadingStateStyle | Implements LoadingStateStyle()()(). This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseWheelSpeed | Implements MouseWheelSpeed()()(). This is a dependency property.
Name | (Inherited from FrameworkElement.)
NoReportStyle | Implements NoReportStyle()()(). This is a dependency property.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
PageGap | Implements PageGap()()(). This is a dependency property.
PageMargin | Implements PageMargin()()(). This is a dependency property.
PagePresenterStyle | Implements PagePresenterStyle()()(). This is a dependency property.
Parameters | Gets or sets List<(Of <(T>)>) which are report parameters for report indicated by ReportName.
ParametersPanelBackground | Gets or sets the parameters panel background. This is a dependency property.
ParametersPanelForeground | Gets or sets the labels colors on parameters panel. This is a dependency property.
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderingStateStyle | Implements RenderingStateStyle()()(). This is a dependency property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
ReportName | Gets or sets active report name. This is a dependency property.
Resources | (Inherited from FrameworkElement.)
SearchText | Gets or sets search text.
SelectStyle | Implements SelectStyle()()(). This is a dependency property.
ServiceUrl | Gets or sets reports WCF service url. This is a dependency property. Implements ServiceUrl()()().
StatusBarVisible | Gets or sets the property which indicates if status bar is visible. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
ToolBarBackground | Gets or sets the toolbar background. This is a dependency property.
ToolBarForeground | Gets or sets the labels colors on toolbar. This is a dependency property.
ToolBarVisible | Gets or sets the property which indicates if toolbar is visible. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Implements ViewManager.
ViewOptions | Gets or sets ViewOptions which are report preview options (switch on/off element functions used for preview). This is a dependency property.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AnimationDuration Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.AnimationDuration Property
ReportViewer Class See Also Send Feedback
Implements AnimationDuration()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Duration AnimationDuration { get; set; }
Visual Basic (Declaration)
Public Property AnimationDuration As Duration
Visual C++
public:
virtual property Duration AnimationDuration {
    Duration get () sealed;
    void set (Duration value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Credentials Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.Credentials Property
ReportViewer Class See Also Send Feedback
Gets or sets List<(Of <(T>)>) which are active report data-source credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public List<Credential> Credentials { get; set; }
Visual Basic (Declaration)
Public Property Credentials As List(Of Credential)
Visual C++
public:
property List<Credential^>^ Credentials {
    List<Credential^>^ get ();
    void set (List<Credential^>^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DebugMode Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.DebugMode Property
ReportViewer Class See Also Send Feedback
Gets or sets Report Viewer debug mode. This is a dependency property. Implements DebugMode()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DebugModeEnum DebugMode { get; set; }
Visual Basic (Declaration)
Public Property DebugMode As DebugModeEnum
Visual C++
public:
virtual property DebugModeEnum DebugMode {
    DebugModeEnum get () sealed;
    void set (DebugModeEnum value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ErrorPresenterStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ErrorPresenterStyle Property
ReportViewer Class See Also Send Feedback
Implements ErrorPresenterStyle()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style ErrorPresenterStyle { get; set; }
Visual Basic (Declaration)
Public Property ErrorPresenterStyle As Style
Visual C++
public:
virtual property Style^ ErrorPresenterStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


InitializingStateStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.InitializingStateStyle Property
ReportViewer Class See Also Send Feedback
Implements InitializingStateStyle()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style InitializingStateStyle { get; set; }
Visual Basic (Declaration)
Public Property InitializingStateStyle As Style
Visual C++
public:
virtual property Style^ InitializingStateStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsDesignMode Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.IsDesignMode Property
ReportViewer Class See Also Send Feedback
Gets the value indicating that the viewer in design mode state.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected static bool IsDesignMode { get; }
Visual Basic (Declaration)
Protected Shared ReadOnly Property IsDesignMode As Boolean
Visual C++
protected:
static property bool IsDesignMode {
    bool get ();
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingPageStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.LoadingPageStyle Property
ReportViewer Class See Also Send Feedback
Implements LoadingPageStyle()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style LoadingPageStyle { get; set; }
Visual Basic (Declaration)
Public Property LoadingPageStyle As Style
Visual C++
public:
virtual property Style^ LoadingPageStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


LoadingStateStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.LoadingStateStyle Property
ReportViewer Class See Also Send Feedback
Implements LoadingStateStyle()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style LoadingStateStyle { get; set; }
Visual Basic (Declaration)
Public Property LoadingStateStyle As Style
Visual C++
public:
virtual property Style^ LoadingStateStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheelSpeed Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.MouseWheelSpeed Property
ReportViewer Class See Also Send Feedback
Implements MouseWheelSpeed()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double MouseWheelSpeed { get; set; }
Visual Basic (Declaration)
Public Property MouseWheelSpeed As Double
Visual C++
public:
virtual property double MouseWheelSpeed {
    double get () sealed;
    void set (double value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


NoReportStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.NoReportStyle Property
ReportViewer Class See Also Send Feedback
Implements NoReportStyle()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style NoReportStyle { get; set; }
Visual Basic (Declaration)
Public Property NoReportStyle As Style
Visual C++
public:
virtual property Style^ NoReportStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageGap Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.PageGap Property
ReportViewer Class See Also Send Feedback
Implements PageGap()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double PageGap { get; set; }
Visual Basic (Declaration)
Public Property PageGap As Double
Visual C++
public:
virtual property double PageGap {
    double get () sealed;
    void set (double value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageMargin Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.PageMargin Property
ReportViewer Class See Also Send Feedback
Implements PageMargin()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double PageMargin { get; set; }
Visual Basic (Declaration)
Public Property PageMargin As Double
Visual C++
public:
virtual property double PageMargin {
    double get () sealed;
    void set (double value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PagePresenterStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.PagePresenterStyle Property
ReportViewer Class See Also Send Feedback
Implements PagePresenterStyle()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style PagePresenterStyle { get; set; }
Visual Basic (Declaration)
Public Property PagePresenterStyle As Style
Visual C++
public:
virtual property Style^ PagePresenterStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Parameters Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.Parameters Property
ReportViewer Class See Also Send Feedback
Gets or sets List<(Of <(T>)>) which are report parameters for report indicated by ReportName.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public List<Parameter> Parameters { get; set; }
Visual Basic (Declaration)
Public Property Parameters As List(Of Parameter)
Visual C++
public:
property List<Parameter^>^ Parameters {
    List<Parameter^>^ get ();
    void set (List<Parameter^>^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanelBackground Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ParametersPanelBackground Property
ReportViewer Class See Also Send Feedback
Gets or sets the parameters panel background. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Brush ParametersPanelBackground { get; set; }
Visual Basic (Declaration)
Public Property ParametersPanelBackground As Brush
Visual C++
public:
property Brush^ ParametersPanelBackground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersPanelForeground Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ParametersPanelForeground Property
ReportViewer Class See Also Send Feedback
Gets or sets the labels colors on parameters panel. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Brush ParametersPanelForeground { get; set; }
Visual Basic (Declaration)
Public Property ParametersPanelForeground As Brush
Visual C++
public:
property Brush^ ParametersPanelForeground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RenderingStateStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.RenderingStateStyle Property
ReportViewer Class See Also Send Feedback
Implements RenderingStateStyle()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style RenderingStateStyle { get; set; }
Visual Basic (Declaration)
Public Property RenderingStateStyle As Style
Visual C++
public:
virtual property Style^ RenderingStateStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportName Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ReportName Property
ReportViewer Class See Also Send Feedback
Gets or sets active report name. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string ReportName { get; set; }
Visual Basic (Declaration)
Public Property ReportName As String
Visual C++
public:
property String^ ReportName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SearchText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.SearchText Property
ReportViewer Class See Also Send Feedback
Gets or sets search text.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string SearchText { get; set; }
Visual Basic (Declaration)
Public Property SearchText As String
Visual C++
public:
property String^ SearchText {
    String^ get ();
    void set (String^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SelectStyle Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.SelectStyle Property
ReportViewer Class See Also Send Feedback
Implements SelectStyle()()(). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Style SelectStyle { get; set; }
Visual Basic (Declaration)
Public Property SelectStyle As Style
Visual C++
public:
virtual property Style^ SelectStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ServiceUrl Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ServiceUrl Property
ReportViewer Class See Also Send Feedback
Gets or sets reports WCF service url. This is a dependency property. Implements ServiceUrl()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string ServiceUrl { get; set; }
Visual Basic (Declaration)
Public Property ServiceUrl As String
Visual C++
public:
virtual property String^ ServiceUrl {
    String^ get () sealed;
    void set (String^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StatusBarVisible Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.StatusBarVisible Property
ReportViewer Class See Also Send Feedback
Gets or sets the property which indicates if status bar is visible. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Visibility StatusBarVisible { get; set; }
Visual Basic (Declaration)
Public Property StatusBarVisible As Visibility
Visual C++
public:
property Visibility StatusBarVisible {
    Visibility get ();
    void set (Visibility value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBarBackground Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ToolBarBackground Property
ReportViewer Class See Also Send Feedback
Gets or sets the toolbar background. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Brush ToolBarBackground { get; set; }
Visual Basic (Declaration)
Public Property ToolBarBackground As Brush
Visual C++
public:
property Brush^ ToolBarBackground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBarForeground Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ToolBarForeground Property
ReportViewer Class See Also Send Feedback
Gets or sets the labels colors on toolbar. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Brush ToolBarForeground { get; set; }
Visual Basic (Declaration)
Public Property ToolBarForeground As Brush
Visual C++
public:
property Brush^ ToolBarForeground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBarVisible Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ToolBarVisible Property
ReportViewer Class See Also Send Feedback
Gets or sets the property which indicates if toolbar is visible. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Visibility ToolBarVisible { get; set; }
Visual Basic (Declaration)
Public Property ToolBarVisible As Visibility
Visual C++
public:
property Visibility ToolBarVisible {
    Visibility get ();
    void set (Visibility value);
}

Field Value

The tool bar visible.

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ViewManager Property
ReportViewer Class See Also Send Feedback
Implements ViewManager.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewManager ViewManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewOptions Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ViewOptions Property
ReportViewer Class See Also Send Feedback
Gets or sets ViewOptions which are report preview options (switch on/off element functions used for preview). This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewOptions ViewOptions { get; set; }
Visual Basic (Declaration)
Public Property ViewOptions As ViewOptions
Visual C++
public:
property ViewOptions^ ViewOptions {
    ViewOptions^ get ();
    void set (ViewOptions^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportViewer Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer Events
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DocumentLoaded | Occurs when document is loaded.
GotFocus | (Inherited from UIElement.)
HyperlinkClick | Occurs when hyperlink is clicked.
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PageLoaded | Occurs when page is loaded.
ReportError | Occurs when report error happens.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentLoaded Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.DocumentLoaded Event
ReportViewer Class See Also Send Feedback
Occurs when document is loaded.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<DocumentLoadedEventArgs> DocumentLoaded
Visual Basic (Declaration)
Public Event DocumentLoaded As EventHandler(Of DocumentLoadedEventArgs)
Visual C++
public:
 event EventHandler<DocumentLoadedEventArgs^>^ DocumentLoaded {
    void add (EventHandler<DocumentLoadedEventArgs^>^ value);
    void remove (EventHandler<DocumentLoadedEventArgs^>^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HyperlinkClick Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.HyperlinkClick Event
ReportViewer Class See Also Send Feedback
Occurs when hyperlink is clicked.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<ReportHyperlinkEventArgs> HyperlinkClick
Visual Basic (Declaration)
Public Event HyperlinkClick As EventHandler(Of ReportHyperlinkEventArgs)
Visual C++
public:
 event EventHandler<ReportHyperlinkEventArgs^>^ HyperlinkClick {
    void add (EventHandler<ReportHyperlinkEventArgs^>^ value);
    void remove (EventHandler<ReportHyperlinkEventArgs^>^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageLoaded Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.PageLoaded Event
ReportViewer Class See Also Send Feedback
Occurs when page is loaded.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<PageLoadedEventArgs> PageLoaded
Visual Basic (Declaration)
Public Event PageLoaded As EventHandler(Of PageLoadedEventArgs)
Visual C++
public:
 event EventHandler<PageLoadedEventArgs^>^ PageLoaded {
    void add (EventHandler<PageLoadedEventArgs^>^ value);
    void remove (EventHandler<PageLoadedEventArgs^>^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ReportError Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportViewer..::.ReportError Event
ReportViewer Class See Also Send Feedback
Occurs when report error happens.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<ReportErrorEventArgs> ReportError
Visual Basic (Declaration)
Public Event ReportError As EventHandler(Of ReportErrorEventArgs)
Visual C++
public:
 event EventHandler<ReportErrorEventArgs^>^ ReportError {
    void add (EventHandler<ReportErrorEventArgs^>^ value);
    void remove (EventHandler<ReportErrorEventArgs^>^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Select Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Select Class
Members See Also Send Feedback
Control which is used for checking selection on toolbar. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class Select : Control
Visual Basic (Declaration)
Public Class Select _
    Inherits Control
Visual C++
public ref class Select : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.Select

See Also

Select Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Select Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Select Members
Select Class Constructors Methods Properties Events See Also Send Feedback

The Select type exposes the following members.

Constructors

Name | Description
Select | Initializes a new instance of the Select class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Select Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Select Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Select Constructor
Select Class See Also Send Feedback
Initializes a new instance of the Select class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Select()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Select()

See Also

Select Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Select Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Select Methods
Select Class See Also Send Feedback

The Select type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Select Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Select Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Select Properties
Select Class See Also Send Feedback

The Select type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Select Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Select Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Select Events
Select Class See Also Send Feedback

The Select type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Select Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Separator Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Separator Class
Members See Also Send Feedback
Separating control which is used in toolbar. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class Separator : Control
Visual Basic (Declaration)
Public Class Separator _
    Inherits Control
Visual C++
public ref class Separator : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.Separator

See Also

Separator Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Separator Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Separator Members
Separator Class Constructors Methods Properties Events See Also Send Feedback

The Separator type exposes the following members.

Constructors

Name | Description
Separator | Initializes a new instance of the Separator class

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Separator Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Separator Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Separator Constructor
Separator Class See Also Send Feedback
Initializes a new instance of the Separator class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Separator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Separator()

See Also

Separator Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Separator Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Separator Methods
Separator Class See Also Send Feedback

The Separator type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Separator Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Separator Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Separator Properties
Separator Class See Also Send Feedback

The Separator type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Separator Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Separator Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Separator Events
Separator Class See Also Send Feedback

The Separator type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Separator Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SinglePageModel Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel Class
Members See Also Send Feedback
Single page view mode.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class SinglePageModel : DocumentViewModel
Visual Basic (Declaration)
Public Class SinglePageModel _
    Inherits DocumentViewModel
Visual C++
public ref class SinglePageModel : public DocumentViewModel

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewModel
PerpetuumSoft.ReportingServices.Viewer.Client..::.DocumentViewModel
PerpetuumSoft.ReportingServices.Viewer.Client..::.SinglePageModel

See Also

SinglePageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SinglePageModel Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel Members
SinglePageModel Class Constructors Methods Fields Properties See Also Send Feedback

The SinglePageModel type exposes the following members.

Constructors

Name | Description
SinglePageModel | Initializes a new instance of the SinglePageModel class.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Overridden. See CalculateOrigin()()(). (Overrides DocumentViewModel..::.CalculateOrigin()()().)
CalculateZoom | Calculates scale. (Inherited from DocumentViewModel.)
ChangeZoom | Overloaded.
Clone | Overridden. See Clone()()(). (Overrides ViewModel..::.Clone()()().)
CreateStoryboard | Creates Storyboard for animation. (Inherited from DocumentViewModel.)
DeleteUnusedPages | Deletes the unused pages. (Inherited from DocumentViewModel.)
DocumentEnd | Overridden. See DocumentEnd()()(). (Overrides ViewModel..::.DocumentEnd()()().)
DocumentHome | Overridden. See DocumentHome()()(). (Overrides ViewModel..::.DocumentHome()()().)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing. (Inherited from DocumentViewModel.)
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Overridden. See GetGap(Point). (Overrides DocumentViewModel..::.GetGap(Point).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Inherited from DocumentViewModel.)
GoToLastPage | Overridden. See GoToLastPage()()(). (Inherited from DocumentViewModel.)
GoToNextPage | Overridden. See GoToNextPage()()(). (Inherited from DocumentViewModel.)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Inherited from DocumentViewModel.)
HightlightSearchResult | Overridden. See HightlightSearchResult()()(). (Inherited from DocumentViewModel.)
Invalidate | Overloaded.
MakeClientSideSearch | Overridden. See MakeClientSideSearch(SearchResult, SearchResult). (Inherited from DocumentViewModel.)
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible. (Inherited from DocumentViewModel.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from DocumentViewModel.)
OnPageSizeChanged | Called when page size is changed. (Inherited from DocumentViewModel.)
PageDown | Overridden. See PageDown()()(). (Inherited from DocumentViewModel.)
PageEnd | Overridden. See PageEnd()()(). (Overrides ViewModel..::.PageEnd()()().)
PageHome | Overridden. See PageHome()()(). (Overrides ViewModel..::.PageHome()()().)
PageUp | Overridden. See PageUp()()(). (Inherited from DocumentViewModel.)
PanView | Overridden. See PanView(Point). (Inherited from DocumentViewModel.)
RectToScreen | Gets the page area screen coordinates. (Overrides DocumentViewModel..::.RectToScreen(ReportRegion).)
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Inherited from DocumentViewModel.)
SetupPage | Sets the selected page parameters. (Inherited from DocumentViewModel.)
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Inherited from DocumentViewModel.)
StartAnimation | Starts the animation. (Inherited from DocumentViewModel.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | Overridden. See UpdateContent(ViewModel, Boolean). (Overrides ViewModel..::.UpdateContent(ViewModel, Boolean).)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Inherited from DocumentViewModel.)

Fields

Name | Description
_searchResult | (Inherited from DocumentViewModel.)
Gap | Gets the gap between pages. (Inherited from DocumentViewModel.)
Margin | Gets page margins. (Inherited from DocumentViewModel.)

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Inherited from DocumentViewModel.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Inherited from DocumentViewModel.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report. (Inherited from DocumentViewModel.)
HScrollBarActive | Overridden. See HScrollBarActive. (Inherited from DocumentViewModel.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Inherited from DocumentViewModel.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Inherited from DocumentViewModel.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Inherited from DocumentViewModel.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Inherited from DocumentViewModel.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Inherited from DocumentViewModel.)
PageNumber | Overridden. See PageNumber. (Overrides ViewModel..::.PageNumber.)
ScaledPageArea | Overridden. See ScaledPageArea. (Overrides DocumentViewModel..::.ScaledPageArea.)
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Inherited from DocumentViewModel.)
VScrollBarLarge | Overridden. See VScrollBarLarge. (Inherited from DocumentViewModel.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Inherited from DocumentViewModel.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Inherited from DocumentViewModel.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Inherited from DocumentViewModel.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Inherited from DocumentViewModel.)
Zoom | Overridden. See Zoom. (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SinglePageModel Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel Constructor
SinglePageModel Class See Also Send Feedback
Initializes a new instance of the SinglePageModel class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SinglePageModel(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
SinglePageModel(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The manager.

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SinglePageModel Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel Fields
SinglePageModel Class See Also Send Feedback

The SinglePageModel type exposes the following members.

Fields

Name | Description
_searchResult | (Inherited from DocumentViewModel.)
Gap | Gets the gap between pages. (Inherited from DocumentViewModel.)
Margin | Gets page margins. (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SinglePageModel Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel Methods
SinglePageModel Class See Also Send Feedback

The SinglePageModel type exposes the following members.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Overridden. See CalculateOrigin()()(). (Overrides DocumentViewModel..::.CalculateOrigin()()().)
CalculateZoom | Calculates scale. (Inherited from DocumentViewModel.)
ChangeZoom | Overloaded.
Clone | Overridden. See Clone()()(). (Overrides ViewModel..::.Clone()()().)
CreateStoryboard | Creates Storyboard for animation. (Inherited from DocumentViewModel.)
DeleteUnusedPages | Deletes the unused pages. (Inherited from DocumentViewModel.)
DocumentEnd | Overridden. See DocumentEnd()()(). (Overrides ViewModel..::.DocumentEnd()()().)
DocumentHome | Overridden. See DocumentHome()()(). (Overrides ViewModel..::.DocumentHome()()().)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing. (Inherited from DocumentViewModel.)
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Overridden. See GetGap(Point). (Overrides DocumentViewModel..::.GetGap(Point).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Inherited from DocumentViewModel.)
GoToLastPage | Overridden. See GoToLastPage()()(). (Inherited from DocumentViewModel.)
GoToNextPage | Overridden. See GoToNextPage()()(). (Inherited from DocumentViewModel.)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Inherited from DocumentViewModel.)
HightlightSearchResult | Overridden. See HightlightSearchResult()()(). (Inherited from DocumentViewModel.)
Invalidate | Overloaded.
MakeClientSideSearch | Overridden. See MakeClientSideSearch(SearchResult, SearchResult). (Inherited from DocumentViewModel.)
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible. (Inherited from DocumentViewModel.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from DocumentViewModel.)
OnPageSizeChanged | Called when page size is changed. (Inherited from DocumentViewModel.)
PageDown | Overridden. See PageDown()()(). (Inherited from DocumentViewModel.)
PageEnd | Overridden. See PageEnd()()(). (Overrides ViewModel..::.PageEnd()()().)
PageHome | Overridden. See PageHome()()(). (Overrides ViewModel..::.PageHome()()().)
PageUp | Overridden. See PageUp()()(). (Inherited from DocumentViewModel.)
PanView | Overridden. See PanView(Point). (Inherited from DocumentViewModel.)
RectToScreen | Gets the page area screen coordinates. (Overrides DocumentViewModel..::.RectToScreen(ReportRegion).)
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Inherited from DocumentViewModel.)
SetupPage | Sets the selected page parameters. (Inherited from DocumentViewModel.)
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Inherited from DocumentViewModel.)
StartAnimation | Starts the animation. (Inherited from DocumentViewModel.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | Overridden. See UpdateContent(ViewModel, Boolean). (Overrides ViewModel..::.UpdateContent(ViewModel, Boolean).)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CalculateOrigin Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.CalculateOrigin Method
SinglePageModel Class See Also Send Feedback
Overridden. See CalculateOrigin()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override void CalculateOrigin()
Visual Basic (Declaration)
Protected Overrides Sub CalculateOrigin
Visual C++
protected:
virtual void CalculateOrigin() override

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ChangeZoom Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.ChangeZoom Method
SinglePageModel Class See Also Send Feedback

Overload List

Name | Description
ChangeZoom(ZoomMode, Boolean) | Overridden. See ChangeZoom(ZoomMode, Boolean). (Inherited from DocumentViewModel.)
ChangeZoom(Double, Boolean) | Performs scale and scale mode changing. (Inherited from ViewModel.)
ChangeZoom(Point, Double, Boolean) | Overridden. See ChangeZoom(Point, Double, Boolean). (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
SinglePageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Clone Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.Clone Method
SinglePageModel Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override ViewModel Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As ViewModel
Visual C++
public:
virtual ViewModel^ Clone() override

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentEnd Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.DocumentEnd Method
SinglePageModel Class See Also Send Feedback
Overridden. See DocumentEnd()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void DocumentEnd()
Visual Basic (Declaration)
Public Overrides Sub DocumentEnd
Visual C++
public:
virtual void DocumentEnd() override

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentHome Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.DocumentHome Method
SinglePageModel Class See Also Send Feedback
Overridden. See DocumentHome()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void DocumentHome()
Visual Basic (Declaration)
Public Overrides Sub DocumentHome
Visual C++
public:
virtual void DocumentHome() override

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


EnsureVisible Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.EnsureVisible Method
SinglePageModel Class See Also Send Feedback

Overload List

Name | Description
EnsureVisible(ReportRegion) | Shifts the visible area of the screen to guarantee that the specified report is visible. (Inherited from ViewModel.)
EnsureVisible(ReportRegion, Boolean) | Overridden. See EnsureVisible(ReportRegion, Boolean). (Overrides ViewModel..::.EnsureVisible(ReportRegion, Boolean).)

See Also

SinglePageModel Class
SinglePageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


EnsureVisible Method (ReportRegion, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.EnsureVisible Method (ReportRegion, Boolean)
SinglePageModel Class See Also Send Feedback
Overridden. See EnsureVisible(ReportRegion, Boolean).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void EnsureVisible(
    ReportRegion region,
    bool alignTop
)
Visual Basic (Declaration)
Public Overrides Sub EnsureVisible ( _
    region As ReportRegion, _
    alignTop As Boolean _
)
Visual C++
public:
virtual void EnsureVisible(
    ReportRegion region,
    bool alignTop
) override

Parameters

region
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportRegion
alignTop
Type: System..::.Boolean

See Also

SinglePageModel Class
EnsureVisible Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GetGap Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.GetGap Method
SinglePageModel Class See Also Send Feedback
Overridden. See GetGap(Point).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override Size GetGap(
    Point center
)
Visual Basic (Declaration)
Protected Overrides Function GetGap ( _
    center As Point _
) As Size
Visual C++
protected:
virtual Size GetGap(
    Point center
) override

Parameters

center
Type: System.Windows..::.Point

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Invalidate Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.Invalidate Method
SinglePageModel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates report viewer. (Inherited from DocumentViewModel.)
Invalidate(Boolean) | Invalidates report viewer. (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
SinglePageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageEnd Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.PageEnd Method
SinglePageModel Class See Also Send Feedback
Overridden. See PageEnd()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void PageEnd()
Visual Basic (Declaration)
Public Overrides Sub PageEnd
Visual C++
public:
virtual void PageEnd() override

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageHome Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.PageHome Method
SinglePageModel Class See Also Send Feedback
Overridden. See PageHome()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void PageHome()
Visual Basic (Declaration)
Public Overrides Sub PageHome
Visual C++
public:
virtual void PageHome() override

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RectToScreen Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.RectToScreen Method
SinglePageModel Class See Also Send Feedback
Gets the page area screen coordinates.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override Rect RectToScreen(
    ReportRegion region
)
Visual Basic (Declaration)
Protected Overrides Function RectToScreen ( _
    region As ReportRegion _
) As Rect
Visual C++
protected:
virtual Rect RectToScreen(
    ReportRegion region
) override

Parameters

region
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportRegion

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateContent Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.UpdateContent Method
SinglePageModel Class See Also Send Feedback
Overridden. See UpdateContent(ViewModel, Boolean).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected internal override void UpdateContent(
    ViewModel prevViewModel,
    bool useAnimation
)
Visual Basic (Declaration)
Protected Friend Overrides Sub UpdateContent ( _
    prevViewModel As ViewModel, _
    useAnimation As Boolean _
)
Visual C++
protected public:
virtual void UpdateContent(
    ViewModel^ prevViewModel,
    bool useAnimation
) override

Parameters

prevViewModel
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewModel
useAnimation
Type: System..::.Boolean

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomIn Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.ZoomIn Method
SinglePageModel Class See Also Send Feedback

Overload List

Name | Description
ZoomIn(Boolean) | Performs zoom in. (Inherited from ViewModel.)
ZoomIn(Point, Boolean) | Performs zoom in. (Inherited from ViewModel.)

See Also

SinglePageModel Class
SinglePageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOut Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.ZoomOut Method
SinglePageModel Class See Also Send Feedback

Overload List

Name | Description
ZoomOut(Boolean) | Performs zoom out. (Inherited from ViewModel.)
ZoomOut(Point, Boolean) | Performs zoom out. (Inherited from ViewModel.)

See Also

SinglePageModel Class
SinglePageModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SinglePageModel Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel Properties
SinglePageModel Class See Also Send Feedback

The SinglePageModel type exposes the following members.

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Inherited from DocumentViewModel.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Inherited from DocumentViewModel.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report. (Inherited from DocumentViewModel.)
HScrollBarActive | Overridden. See HScrollBarActive. (Inherited from DocumentViewModel.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Inherited from DocumentViewModel.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Inherited from DocumentViewModel.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Inherited from DocumentViewModel.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Inherited from DocumentViewModel.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Inherited from DocumentViewModel.)
PageNumber | Overridden. See PageNumber. (Overrides ViewModel..::.PageNumber.)
ScaledPageArea | Overridden. See ScaledPageArea. (Overrides DocumentViewModel..::.ScaledPageArea.)
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Inherited from DocumentViewModel.)
VScrollBarLarge | Overridden. See VScrollBarLarge. (Inherited from DocumentViewModel.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Inherited from DocumentViewModel.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Inherited from DocumentViewModel.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Inherited from DocumentViewModel.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Inherited from DocumentViewModel.)
Zoom | Overridden. See Zoom. (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageNumber Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.PageNumber Property
SinglePageModel Class See Also Send Feedback
Overridden. See PageNumber.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override int PageNumber { get; set; }
Visual Basic (Declaration)
Public Overrides Property PageNumber As Integer
Visual C++
public:
virtual property int PageNumber {
    int get () override;
    void set (int value) override;
}

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ScaledPageArea Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SinglePageModel..::.ScaledPageArea Property
SinglePageModel Class See Also Send Feedback
Overridden. See ScaledPageArea.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override Size ScaledPageArea { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property ScaledPageArea As Size
Visual C++
protected:
virtual property Size ScaledPageArea {
    Size get () override;
}

See Also

SinglePageModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SingleValidValueParameterControl Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl Class
Members See Also Send Feedback
The SingleValidValueParameterControl class is intended to encapsulate logic for report parameter controls with single-value selection and with list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class SingleValidValueParameterControl : ReportParameterControl
Visual Basic (Declaration)
Public Class SingleValidValueParameterControl _
    Inherits ReportParameterControl
Visual C++
public ref class SingleValidValueParameterControl : public ReportParameterControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.BaseParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.SingleValidValueParameterControl

See Also

SingleValidValueParameterControl Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SingleValidValueParameterControl Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl Members
SingleValidValueParameterControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The SingleValidValueParameterControl type exposes the following members.

Constructors

Name | Description
SingleValidValueParameterControl | Initializes a new instance of the SingleValidValueParameterControl class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
ValidValues | Gets or sets the values that can be chosen as parameter values.
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

SingleValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SingleValidValueParameterControl Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl Constructor
SingleValidValueParameterControl Class See Also Send Feedback
Initializes a new instance of the SingleValidValueParameterControl class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SingleValidValueParameterControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SingleValidValueParameterControl()

See Also

SingleValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SingleValidValueParameterControl Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl Fields
SingleValidValueParameterControl Class See Also Send Feedback

The SingleValidValueParameterControl type exposes the following members.

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

See Also

SingleValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SingleValidValueParameterControl Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl Methods
SingleValidValueParameterControl Class See Also Send Feedback

The SingleValidValueParameterControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

SingleValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl..::.OnApplyTemplate Method
SingleValidValueParameterControl Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

SingleValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetFocus Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl..::.SetFocus Method
SingleValidValueParameterControl Class See Also Send Feedback
Overridden. See SetFocus()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void SetFocus()
Visual Basic (Declaration)
Public Overrides Sub SetFocus
Visual C++
public:
virtual void SetFocus() override

See Also

SingleValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SingleValidValueParameterControl Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl Properties
SingleValidValueParameterControl Class See Also Send Feedback

The SingleValidValueParameterControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
ValidValues | Gets or sets the values that can be chosen as parameter values.
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

SingleValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ValidValues Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl..::.ValidValues Property
SingleValidValueParameterControl Class See Also Send Feedback
Gets or sets the values that can be chosen as parameter values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public List<ValidValue> ValidValues { get; set; }
Visual Basic (Declaration)
Public Property ValidValues As List(Of ValidValue)
Visual C++
public:
property List<ValidValue^>^ ValidValues {
    List<ValidValue^>^ get ();
    void set (List<ValidValue^>^ value);
}

Field Value

The valid values.

See Also

SingleValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Values Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl..::.Values Property
SingleValidValueParameterControl Class See Also Send Feedback
Overridden. See Values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override List<ValidValue> Values { get; set; }
Visual Basic (Declaration)
Public Overrides Property Values As List(Of ValidValue)
Visual C++
public:
virtual property List<ValidValue^>^ Values {
    List<ValidValue^>^ get () override;
    void set (List<ValidValue^>^ value) override;
}

See Also

SingleValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SingleValidValueParameterControl Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SingleValidValueParameterControl Events
SingleValidValueParameterControl Class See Also Send Feedback

The SingleValidValueParameterControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

SingleValidValueParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StandardTool Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StandardTool Class
Members See Also Send Feedback
A basic class for all standard tools.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class StandardTool : Tool
Visual Basic (Declaration)
Public Class StandardTool _
    Inherits Tool
Visual C++
public ref class StandardTool : public Tool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
PerpetuumSoft.ReportingServices.Viewer.Client..::.StandardTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.DynamicZoomTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.PanTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.RegionZoomTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomChangeTool

See Also

StandardTool Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StandardTool Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
StandardTool Members
StandardTool Class Methods Properties See Also Send Feedback

The StandardTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Overrides Tool..::.KeyDown(KeyEventArgs).)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Overrides Tool..::.KeyUp(KeyEventArgs).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides Tool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides Tool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides Tool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides Tool..::.MouseWheel(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

StandardTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StandardTool Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
StandardTool Methods
StandardTool Class See Also Send Feedback

The StandardTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Overrides Tool..::.KeyDown(KeyEventArgs).)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Overrides Tool..::.KeyUp(KeyEventArgs).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides Tool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides Tool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides Tool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides Tool..::.MouseWheel(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

See Also

StandardTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


KeyDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StandardTool..::.KeyDown Method
StandardTool Class See Also Send Feedback
Overridden. See KeyDown(KeyEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void KeyDown(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub KeyDown ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyDown(
    KeyEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

StandardTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


KeyUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StandardTool..::.KeyUp Method
StandardTool Class See Also Send Feedback
Overridden. See KeyUp(KeyEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void KeyUp(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub KeyUp ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyUp(
    KeyEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

StandardTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StandardTool..::.MouseDown Method
StandardTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

StandardTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseMove Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StandardTool..::.MouseMove Method
StandardTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

StandardTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StandardTool..::.MouseUp Method
StandardTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

StandardTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheel Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StandardTool..::.MouseWheel Method
StandardTool Class See Also Send Feedback
Overridden. See MouseWheel(Double).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public Overrides Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) override

Parameters

delta
Type: System..::.Double

See Also

StandardTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StandardTool Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
StandardTool Properties
StandardTool Class See Also Send Feedback

The StandardTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

StandardTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StringParameterControl Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl Class
Members See Also Send Feedback
The StringParameterControl class is intended to encapsulate logic for report parameter controls with String type and with single-value selection and without list of available values. Inherited from ReportParameterControl. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class StringParameterControl : ReportParameterControl
Visual Basic (Declaration)
Public Class StringParameterControl _
    Inherits ReportParameterControl
Visual C++
public ref class StringParameterControl : public ReportParameterControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.BaseParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportParameterControl
PerpetuumSoft.ReportingServices.Viewer.Client..::.StringParameterControl

See Also

StringParameterControl Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StringParameterControl Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl Members
StringParameterControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The StringParameterControl type exposes the following members.

Constructors

Name | Description
StringParameterControl | Initializes a new instance of the StringParameterControl class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNullable | Gets or sets a value indicates whether the value of the parameter can be null.
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

StringParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StringParameterControl Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl Constructor
StringParameterControl Class See Also Send Feedback
Initializes a new instance of the StringParameterControl class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public StringParameterControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StringParameterControl()

See Also

StringParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StringParameterControl Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl Fields
StringParameterControl Class See Also Send Feedback

The StringParameterControl type exposes the following members.

Fields

Name | Description
_values | (Inherited from ReportParameterControl.)
ParameterValueChanged | Occurs when parameter value changes in parameter control. (Inherited from ReportParameterControl.)

See Also

StringParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StringParameterControl Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl Methods
StringParameterControl Class See Also Send Feedback

The StringParameterControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CompareValidValueLists | Compares the valid value lists. (Inherited from ReportParameterControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnParameterValueChanged | Called when parameter value changed. (Inherited from ReportParameterControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetFocus | Overridden. See SetFocus()()(). (Overrides BaseParameterControl..::.SetFocus()()().)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

StringParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl..::.OnApplyTemplate Method
StringParameterControl Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

StringParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetFocus Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl..::.SetFocus Method
StringParameterControl Class See Also Send Feedback
Overridden. See SetFocus()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void SetFocus()
Visual Basic (Declaration)
Public Overrides Sub SetFocus
Visual C++
public:
virtual void SetFocus() override

See Also

StringParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StringParameterControl Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl Properties
StringParameterControl Class See Also Send Feedback

The StringParameterControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNullable | Gets or sets a value indicates whether the value of the parameter can be null.
IsRequired | Gets or sets a value indicating whether the parameter is required. (Inherited from ReportParameterControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
ParametersPanel | Gets or sets the parameters panel. (Inherited from BaseParameterControl.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
PromptText | Gets or sets the prompt text for parameter. This is a dependency property. (Inherited from ReportParameterControl.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Values | Overridden. See Values. (Overrides ReportParameterControl..::.Values.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

StringParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsNullable Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl..::.IsNullable Property
StringParameterControl Class See Also Send Feedback
Gets or sets a value indicates whether the value of the parameter can be null.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsNullable { get; set; }
Visual Basic (Declaration)
Public Property IsNullable As Boolean
Visual C++
public:
property bool IsNullable {
    bool get ();
    void set (bool value);
}

Field Value

true if the value of the parameter can be null; otherwise, false.

See Also

StringParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Values Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl..::.Values Property
StringParameterControl Class See Also Send Feedback
Overridden. See Values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override List<ValidValue> Values { get; set; }
Visual Basic (Declaration)
Public Overrides Property Values As List(Of ValidValue)
Visual C++
public:
virtual property List<ValidValue^>^ Values {
    List<ValidValue^>^ get () override;
    void set (List<ValidValue^>^ value) override;
}

See Also

StringParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StringParameterControl Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
StringParameterControl Events
StringParameterControl Class See Also Send Feedback

The StringParameterControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

StringParameterControl Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToggleToolButton Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton Class
Members See Also Send Feedback
Toolbar button control. Inherited from ToggleButton.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ToggleToolButton : ToggleButton
Visual Basic (Declaration)
Public Class ToggleToolButton _
    Inherits ToggleButton
Visual C++
public ref class ToggleToolButton : public ToggleButton

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls.Primitives..::.ButtonBase
System.Windows.Controls.Primitives..::.ToggleButton
PerpetuumSoft.ReportingServices.Viewer.Client..::.ToggleToolButton

See Also

ToggleToolButton Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToggleToolButton Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton Members
ToggleToolButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The ToggleToolButton type exposes the following members.

Constructors

Name | Description
ToggleToolButton | Initializes a new instance of the ToggleToolButton class

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ToggleButton.)
OnClick | (Inherited from ToggleButton.)
OnContentChanged | (Inherited from ToggleButton.)
OnCreateAutomationPeer | (Inherited from ToggleButton.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnLostMouseCapture | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
OnMouseWheel | (Inherited from Control.)
OnToggle | (Inherited from ToggleButton.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from ToggleButton.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
DisabledContentProperty | Identifies the DisabledContent dependency property.
TooltipTextProperty | Identifies the TooltipText dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledContent | Gets or sets disabled button state content. This is a dependency property.
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
IsThreeState | (Inherited from ToggleButton.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TooltipText | Gets or sets the button text. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Checked | (Inherited from ToggleButton.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
Indeterminate | (Inherited from ToggleButton.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
Unchecked | (Inherited from ToggleButton.)

See Also

ToggleToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToggleToolButton Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton Constructor
ToggleToolButton Class See Also Send Feedback
Initializes a new instance of the ToggleToolButton class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ToggleToolButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToggleToolButton()

See Also

ToggleToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToggleToolButton Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton Fields
ToggleToolButton Class See Also Send Feedback

The ToggleToolButton type exposes the following members.

Fields

Name | Description
DisabledContentProperty | Identifies the DisabledContent dependency property.
TooltipTextProperty | Identifies the TooltipText dependency property.

See Also

ToggleToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DisabledContentProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton..::.DisabledContentProperty Field
ToggleToolButton Class See Also Send Feedback
Identifies the DisabledContent dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty DisabledContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledContentProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DisabledContentProperty

See Also

ToggleToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TooltipTextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton..::.TooltipTextProperty Field
ToggleToolButton Class See Also Send Feedback
Identifies the TooltipText dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty TooltipTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TooltipTextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TooltipTextProperty

See Also

ToggleToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToggleToolButton Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton Methods
ToggleToolButton Class See Also Send Feedback

The ToggleToolButton type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ToggleButton.)
OnClick | (Inherited from ToggleButton.)
OnContentChanged | (Inherited from ToggleButton.)
OnCreateAutomationPeer | (Inherited from ToggleButton.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnLostMouseCapture | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
OnMouseWheel | (Inherited from Control.)
OnToggle | (Inherited from ToggleButton.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from ToggleButton.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ToggleToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToggleToolButton Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton Properties
ToggleToolButton Class See Also Send Feedback

The ToggleToolButton type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledContent | Gets or sets disabled button state content. This is a dependency property.
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
IsThreeState | (Inherited from ToggleButton.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TooltipText | Gets or sets the button text. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ToggleToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DisabledContent Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton..::.DisabledContent Property
ToggleToolButton Class See Also Send Feedback
Gets or sets disabled button state content. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Object DisabledContent { get; set; }
Visual Basic (Declaration)
Public Property DisabledContent As Object
Visual C++
public:
property Object^ DisabledContent {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The disabled button state content.

See Also

ToggleToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TooltipText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton..::.TooltipText Property
ToggleToolButton Class See Also Send Feedback
Gets or sets the button text. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipText { get; set; }
Visual Basic (Declaration)
Public Property TooltipText As String
Visual C++
public:
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}

Field Value

The button text.

See Also

ToggleToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToggleToolButton Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleToolButton Events
ToggleToolButton Class See Also Send Feedback

The ToggleToolButton type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Checked | (Inherited from ToggleButton.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
Indeterminate | (Inherited from ToggleButton.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
Unchecked | (Inherited from ToggleButton.)

See Also

ToggleToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Tool Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool Class
Members See Also Send Feedback
An abstract class. It is basic class for all classes of tools which realize handling of ReportViewer special functionality.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract class Tool
Visual Basic (Declaration)
Public MustInherit Class Tool
Visual C++
public ref class Tool abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
PerpetuumSoft.ReportingServices.Viewer.Client..::.DisabledTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.StandardTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.WaitTool

See Also

Tool Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Tool Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool Members
Tool Class Constructors Methods Properties See Also Send Feedback

The Tool type exposes the following members.

Constructors

Name | Description
Tool | Initializes a new instance of the Tool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Handles keyboard key pressing.
KeyUp | Handles keyboard key releasing.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Handles mouse click.
MouseMove | Handles mouse pointer moving.
MouseUp | Handles mouse button release.
MouseWheel | Handles mouse scroll-wheel.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Tool Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool Constructor
Tool Class See Also Send Feedback
Initializes a new instance of the Tool class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected Tool(
    ViewManager manager
)
Visual Basic (Declaration)
Protected Sub New ( _
    manager As ViewManager _
)
Visual C++
protected:
Tool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The manager.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Tool Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool Methods
Tool Class See Also Send Feedback

The Tool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Handles keyboard key pressing.
KeyUp | Handles keyboard key releasing.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Handles mouse click.
MouseMove | Handles mouse pointer moving.
MouseUp | Handles mouse button release.
MouseWheel | Handles mouse scroll-wheel.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


KeyDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool..::.KeyDown Method
Tool Class See Also Send Feedback
Handles keyboard key pressing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void KeyDown(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public MustOverride Sub KeyDown ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyDown(
    KeyEventArgs^ args
) abstract

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


KeyUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool..::.KeyUp Method
Tool Class See Also Send Feedback
Handles keyboard key releasing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void KeyUp(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public MustOverride Sub KeyUp ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyUp(
    KeyEventArgs^ args
) abstract

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs
The KeyEventArgs instance containing the event data.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool..::.MouseDown Method
Tool Class See Also Send Feedback
Handles mouse click.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public MustOverride Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) abstract

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs
The MouseEventArgs instance containing the event data.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseMove Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool..::.MouseMove Method
Tool Class See Also Send Feedback
Handles mouse pointer moving.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public MustOverride Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) abstract

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs
The MouseEventArgs instance containing the event data.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool..::.MouseUp Method
Tool Class See Also Send Feedback
Handles mouse button release.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public MustOverride Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) abstract

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs
The MouseEventArgs instance containing the event data.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheel Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool..::.MouseWheel Method
Tool Class See Also Send Feedback
Handles mouse scroll-wheel.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public MustOverride Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) abstract

Parameters

delta
Type: System..::.Double
The delta.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateCursor Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool..::.UpdateCursor Method
Tool Class See Also Send Feedback
Updates active cursor.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public virtual void UpdateCursor()
Visual Basic (Declaration)
Public Overridable Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor()

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Tool Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool Properties
Tool Class See Also Send Feedback

The Tool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Tool..::.ViewManager Property
Tool Class See Also Send Feedback
Gets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewManager ViewManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
}

Field Value

The view manager.

See Also

Tool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBalloon Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon Class
Members See Also Send Feedback
Gets or sets toolbar balloon control. Inherited from Control.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ToolBalloon : Control
Visual Basic (Declaration)
Public Class ToolBalloon _
    Inherits Control
Visual C++
public ref class ToolBalloon : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.ReportingServices.Viewer.Client..::.ToolBalloon

See Also

ToolBalloon Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBalloon Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon Members
ToolBalloon Class Constructors Methods Fields Properties Events See Also Send Feedback

The ToolBalloon type exposes the following members.

Constructors

Name | Description
ToolBalloon | Initializes a new instance of the ToolBalloon class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CloseIntervalProperty | Identifies the CloseInterval dependency property.
IsBalloonOpenProperty | Identifies the IsBalloonOpen dependency property.
TextProperty | Identifies the Text dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
CloseInterval | Gets or sets the amount of time before closing balloon control.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsBalloonOpen | Gets or sets a value that indicates whether the balloon control is currently open. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets a text that displayed in the balloon control. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBalloon Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon Constructor
ToolBalloon Class See Also Send Feedback
Initializes a new instance of the ToolBalloon class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ToolBalloon()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolBalloon()

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBalloon Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon Fields
ToolBalloon Class See Also Send Feedback

The ToolBalloon type exposes the following members.

Fields

Name | Description
CloseIntervalProperty | Identifies the CloseInterval dependency property.
IsBalloonOpenProperty | Identifies the IsBalloonOpen dependency property.
TextProperty | Identifies the Text dependency property.

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CloseIntervalProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon..::.CloseIntervalProperty Field
ToolBalloon Class See Also Send Feedback
Identifies the CloseInterval dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty CloseIntervalProperty
Visual Basic (Declaration)
Public Shared ReadOnly CloseIntervalProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CloseIntervalProperty

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsBalloonOpenProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon..::.IsBalloonOpenProperty Field
ToolBalloon Class See Also Send Feedback
Identifies the IsBalloonOpen dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty IsBalloonOpenProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsBalloonOpenProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsBalloonOpenProperty

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon..::.TextProperty Field
ToolBalloon Class See Also Send Feedback
Identifies the Text dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty TextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TextProperty

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBalloon Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon Methods
ToolBalloon Class See Also Send Feedback

The ToolBalloon type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon..::.OnApplyTemplate Method
ToolBalloon Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBalloon Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon Properties
ToolBalloon Class See Also Send Feedback

The ToolBalloon type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
CloseInterval | Gets or sets the amount of time before closing balloon control.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsBalloonOpen | Gets or sets a value that indicates whether the balloon control is currently open. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets a text that displayed in the balloon control. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CloseInterval Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon..::.CloseInterval Property
ToolBalloon Class See Also Send Feedback
Gets or sets the amount of time before closing balloon control.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int CloseInterval { get; set; }
Visual Basic (Declaration)
Public Property CloseInterval As Integer
Visual C++
public:
property int CloseInterval {
    int get ();
    void set (int value);
}

Field Value

The close interval.

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


IsBalloonOpen Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon..::.IsBalloonOpen Property
ToolBalloon Class See Also Send Feedback
Gets or sets a value that indicates whether the balloon control is currently open. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsBalloonOpen { get; set; }
Visual Basic (Declaration)
Public Property IsBalloonOpen As Boolean
Visual C++
public:
property bool IsBalloonOpen {
    bool get ();
    void set (bool value);
}

Field Value

true if the balloon control is currently opened; otherwise, false.

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Text Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon..::.Text Property
ToolBalloon Class See Also Send Feedback
Gets or sets a text that displayed in the balloon control. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolBalloon Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolBalloon Events
ToolBalloon Class See Also Send Feedback

The ToolBalloon type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ToolBalloon Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolButton Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton Class
Members See Also Send Feedback
Gets or sets toolbar button control. Inherited from Button.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ToolButton : Button
Visual Basic (Declaration)
Public Class ToolButton _
    Inherits Button
Visual C++
public ref class ToolButton : public Button

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls.Primitives..::.ButtonBase
System.Windows.Controls..::.Button
PerpetuumSoft.ReportingServices.Viewer.Client..::.ToolButton

See Also

ToolButton Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolButton Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton Members
ToolButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The ToolButton type exposes the following members.

Constructors

Name | Description
ToolButton | Initializes a new instance of the ToolButton class

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Button.)
OnClick | (Inherited from Button.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from Button.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnLostMouseCapture | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
OnMouseWheel | (Inherited from Control.)
PerformClick | Performs the button click.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
DisabledContentProperty | Identifies the DisabledContent dependency property.
TooltipTextProperty | Identifies the TooltipText dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledContent | Gets or sets disabled button state content. This is a dependency property.
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TooltipText | Gets or sets the button text. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolButton Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton Constructor
ToolButton Class See Also Send Feedback
Initializes a new instance of the ToolButton class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ToolButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolButton()

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolButton Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton Fields
ToolButton Class See Also Send Feedback

The ToolButton type exposes the following members.

Fields

Name | Description
DisabledContentProperty | Identifies the DisabledContent dependency property.
TooltipTextProperty | Identifies the TooltipText dependency property.

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DisabledContentProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton..::.DisabledContentProperty Field
ToolButton Class See Also Send Feedback
Identifies the DisabledContent dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty DisabledContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledContentProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DisabledContentProperty

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TooltipTextProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton..::.TooltipTextProperty Field
ToolButton Class See Also Send Feedback
Identifies the TooltipText dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty TooltipTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TooltipTextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TooltipTextProperty

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolButton Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton Methods
ToolButton Class See Also Send Feedback

The ToolButton type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Button.)
OnClick | (Inherited from Button.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from Button.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnLostMouseCapture | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
OnMouseWheel | (Inherited from Control.)
PerformClick | Performs the button click.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PerformClick Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton..::.PerformClick Method
ToolButton Class See Also Send Feedback
Performs the button click.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void PerformClick()
Visual Basic (Declaration)
Public Sub PerformClick
Visual C++
public:
void PerformClick()

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolButton Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton Properties
ToolButton Class See Also Send Feedback

The ToolButton type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledContent | Gets or sets disabled button state content. This is a dependency property.
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TooltipText | Gets or sets the button text. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DisabledContent Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton..::.DisabledContent Property
ToolButton Class See Also Send Feedback
Gets or sets disabled button state content. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Object DisabledContent { get; set; }
Visual Basic (Declaration)
Public Property DisabledContent As Object
Visual C++
public:
property Object^ DisabledContent {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The disabled button state content.

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TooltipText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton..::.TooltipText Property
ToolButton Class See Also Send Feedback
Gets or sets the button text. This is a dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipText { get; set; }
Visual Basic (Declaration)
Public Property TooltipText As String
Visual C++
public:
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}

Field Value

The button text.

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolButton Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolButton Events
ToolButton Class See Also Send Feedback

The ToolButton type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ToolButton Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolSlider Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolSlider Class
Members See Also Send Feedback
Slider control for reports view scaling. Inherited from Slider.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ToolSlider : Slider
Visual Basic (Declaration)
Public Class ToolSlider _
    Inherits Slider
Visual C++
public ref class ToolSlider : public Slider

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.RangeBase
System.Windows.Controls..::.Slider
PerpetuumSoft.ReportingServices.Viewer.Client..::.ToolSlider

See Also

ToolSlider Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolSlider Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolSlider Members
ToolSlider Class Constructors Methods Properties Events See Also Send Feedback

The ToolSlider type exposes the following members.

Constructors

Name | Description
ToolSlider | Initializes a new instance of the ToolSlider class

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides Slider..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from Slider.)
OnGotFocus | (Inherited from Slider.)
OnKeyDown | (Inherited from Slider.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Slider.)
OnLostMouseCapture | (Inherited from Slider.)
OnMaximumChanged | (Inherited from Slider.)
OnMinimumChanged | (Inherited from Slider.)
OnMouseEnter | (Inherited from Slider.)
OnMouseLeave | (Inherited from Slider.)
OnMouseLeftButtonDown | (Inherited from Slider.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnValueChanged | (Inherited from Slider.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from RangeBase.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDirectionReversed | (Inherited from Slider.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from Slider.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | (Inherited from Slider.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SmallChange | (Inherited from RangeBase.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DragCompleted | Occurs when the slider's scroll box dragging is finished.
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | (Inherited from RangeBase.)

See Also

ToolSlider Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolSlider Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolSlider Constructor
ToolSlider Class See Also Send Feedback
Initializes a new instance of the ToolSlider class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ToolSlider()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolSlider()

See Also

ToolSlider Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolSlider Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolSlider Methods
ToolSlider Class See Also Send Feedback

The ToolSlider type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides Slider..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from Slider.)
OnGotFocus | (Inherited from Slider.)
OnKeyDown | (Inherited from Slider.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Slider.)
OnLostMouseCapture | (Inherited from Slider.)
OnMaximumChanged | (Inherited from Slider.)
OnMinimumChanged | (Inherited from Slider.)
OnMouseEnter | (Inherited from Slider.)
OnMouseLeave | (Inherited from Slider.)
OnMouseLeftButtonDown | (Inherited from Slider.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnValueChanged | (Inherited from Slider.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from RangeBase.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ToolSlider Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


OnApplyTemplate Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolSlider..::.OnApplyTemplate Method
ToolSlider Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

ToolSlider Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolSlider Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolSlider Properties
ToolSlider Class See Also Send Feedback

The ToolSlider type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDirectionReversed | (Inherited from Slider.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from Slider.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | (Inherited from Slider.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SmallChange | (Inherited from RangeBase.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ToolSlider Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ToolSlider Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolSlider Events
ToolSlider Class See Also Send Feedback

The ToolSlider type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DragCompleted | Occurs when the slider's scroll box dragging is finished.
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | (Inherited from RangeBase.)

See Also

ToolSlider Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DragCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToolSlider..::.DragCompleted Event
ToolSlider Class See Also Send Feedback
Occurs when the slider's scroll box dragging is finished.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler DragCompleted
Visual Basic (Declaration)
Public Event DragCompleted As EventHandler
Visual C++
public:
 event EventHandler^ DragCompleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ToolSlider Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager Class
Members See Also Send Feedback
Report Viewer manager.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ViewManager
Visual Basic (Declaration)
Public Class ViewManager
Visual C++
public ref class ViewManager

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager

See Also

ViewManager Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager Members
ViewManager Class Methods Properties See Also Send Feedback

The ViewManager type exposes the following members.

Methods

Name | Description
AddService | Registers the service.
Backward | Returns the view state to the previous state saved in history.
BeginAnimation | Starts the animation.
ClearHistory | Clears the history of saved states.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FocusSearchTextBox | Focuses on the search text box.
Forward | Switches the view state to the next state saved in history.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetService<(Of <(T>)>) | Gets the service.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrintNotFound | Shows the message which states that the report was not found.
RememberViewModel | Saves the current view state.
SetViewModel | Sets report view model.
StopAnimation | Stops the animation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateView | Updates report view.

Properties

Name | Description
CanBackward | Gets the property which defines possibility of switching backward through display state history.
CanForward | Gets the property which defines possibility of switching forward through display state history.
FontsManager | Gets FontsManager which is fonts manager.
Tool | Gets or sets Tool which is active tool.
View | Gets or sets IView which is the element used for report view.
ViewModel | Gets ViewModel which is report view model.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager Methods
ViewManager Class See Also Send Feedback

The ViewManager type exposes the following members.

Methods

Name | Description
AddService | Registers the service.
Backward | Returns the view state to the previous state saved in history.
BeginAnimation | Starts the animation.
ClearHistory | Clears the history of saved states.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FocusSearchTextBox | Focuses on the search text box.
Forward | Switches the view state to the next state saved in history.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetService<(Of <(T>)>) | Gets the service.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrintNotFound | Shows the message which states that the report was not found.
RememberViewModel | Saves the current view state.
SetViewModel | Sets report view model.
StopAnimation | Stops the animation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateView | Updates report view.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AddService Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.AddService Method
ViewManager Class See Also Send Feedback
Registers the service.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void AddService(
    Type type,
    Object service
)
Visual Basic (Declaration)
Public Sub AddService ( _
    type As Type, _
    service As Object _
)
Visual C++
public:
void AddService(
    Type^ type,
    Object^ service
)

Parameters

type
Type: System..::.Type
The type. The instance of Type class.
service
Type: System..::.Object
The service.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Backward Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.Backward Method
ViewManager Class See Also Send Feedback
Returns the view state to the previous state saved in history.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void Backward()
Visual Basic (Declaration)
Public Sub Backward
Visual C++
public:
void Backward()

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


BeginAnimation Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.BeginAnimation Method
ViewManager Class See Also Send Feedback
Starts the animation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void BeginAnimation(
    Storyboard storyboard
)
Visual Basic (Declaration)
Public Sub BeginAnimation ( _
    storyboard As Storyboard _
)
Visual C++
public:
void BeginAnimation(
    Storyboard^ storyboard
)

Parameters

storyboard
Type: System.Windows.Media.Animation..::.Storyboard
The storyboard. The instance of Storyboard class.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ClearHistory Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.ClearHistory Method
ViewManager Class See Also Send Feedback
Clears the history of saved states.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ClearHistory()
Visual Basic (Declaration)
Public Sub ClearHistory
Visual C++
public:
void ClearHistory()

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


FocusSearchTextBox Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.FocusSearchTextBox Method
ViewManager Class See Also Send Feedback
Focuses on the search text box.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void FocusSearchTextBox()
Visual Basic (Declaration)
Public Sub FocusSearchTextBox
Visual C++
public:
void FocusSearchTextBox()

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Forward Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.Forward Method
ViewManager Class See Also Send Feedback
Switches the view state to the next state saved in history.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void Forward()
Visual Basic (Declaration)
Public Sub Forward
Visual C++
public:
void Forward()

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GetService(T) Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.GetService<(Of <(T>)>) Method
ViewManager Class See Also Send Feedback
Gets the service.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public T GetService<T>()
where T : class
Visual Basic (Declaration)
Public Function GetService(Of T As Class) As T
Visual C++
public:
generic<typename T>
where T : ref class
T GetService()

Type Parameters

T
The type of service.

Return Value

The service object defined by type.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PrintNotFound Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.PrintNotFound Method
ViewManager Class See Also Send Feedback
Shows the message which states that the report was not found.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void PrintNotFound()
Visual Basic (Declaration)
Public Sub PrintNotFound
Visual C++
public:
void PrintNotFound()

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RememberViewModel Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.RememberViewModel Method
ViewManager Class See Also Send Feedback
Saves the current view state.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void RememberViewModel()
Visual Basic (Declaration)
Public Sub RememberViewModel
Visual C++
public:
void RememberViewModel()

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SetViewModel Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.SetViewModel Method
ViewManager Class See Also Send Feedback
Sets report view model.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SetViewModel(
    ViewModel viewModel,
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub SetViewModel ( _
    viewModel As ViewModel, _
    useAnimation As Boolean _
)
Visual C++
public:
void SetViewModel(
    ViewModel^ viewModel,
    bool useAnimation
)

Parameters

viewModel
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewModel
The view model. The instance of ViewModel class.
useAnimation
Type: System..::.Boolean
If it is set to true then it is used animation to change view.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


StopAnimation Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.StopAnimation Method
ViewManager Class See Also Send Feedback
Stops the animation.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void StopAnimation()
Visual Basic (Declaration)
Public Sub StopAnimation
Visual C++
public:
void StopAnimation()

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateView Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.UpdateView Method
ViewManager Class See Also Send Feedback
Updates report view.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void UpdateView(
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub UpdateView ( _
    useAnimation As Boolean _
)
Visual C++
public:
void UpdateView(
    bool useAnimation
)

Parameters

useAnimation
Type: System..::.Boolean
If it is set to true then it is used animation to change view.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager Properties
ViewManager Class See Also Send Feedback

The ViewManager type exposes the following members.

Properties

Name | Description
CanBackward | Gets the property which defines possibility of switching backward through display state history.
CanForward | Gets the property which defines possibility of switching forward through display state history.
FontsManager | Gets FontsManager which is fonts manager.
Tool | Gets or sets Tool which is active tool.
View | Gets or sets IView which is the element used for report view.
ViewModel | Gets ViewModel which is report view model.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CanBackward Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.CanBackward Property
ViewManager Class See Also Send Feedback
Gets the property which defines possibility of switching backward through display state history.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool CanBackward { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanBackward As Boolean
Visual C++
public:
property bool CanBackward {
    bool get ();
}

Field Value

true if it is possible to switch backward through display state history; otherwise, false.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CanForward Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.CanForward Property
ViewManager Class See Also Send Feedback
Gets the property which defines possibility of switching forward through display state history.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool CanForward { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanForward As Boolean
Visual C++
public:
property bool CanForward {
    bool get ();
}

Field Value

true if it is possibile to switch forward through display state history; otherwise, false.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


FontsManager Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.FontsManager Property
ViewManager Class See Also Send Feedback
Gets FontsManager which is fonts manager.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public FontsManager FontsManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property FontsManager As FontsManager
Visual C++
public:
property FontsManager^ FontsManager {
    FontsManager^ get ();
}

Field Value

The fonts manager.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Tool Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.Tool Property
ViewManager Class See Also Send Feedback
Gets or sets Tool which is active tool.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Tool Tool { get; set; }
Visual Basic (Declaration)
Public Property Tool As Tool
Visual C++
public:
property Tool^ Tool {
    Tool^ get ();
    void set (Tool^ value);
}

Field Value

The tool.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


View Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.View Property
ViewManager Class See Also Send Feedback
Gets or sets IView which is the element used for report view.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public IView View { get; set; }
Visual Basic (Declaration)
Public Property View As IView
Visual C++
public:
property IView^ View {
    IView^ get ();
    void set (IView^ value);
}

Field Value

The view.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewModel Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewManager..::.ViewModel Property
ViewManager Class See Also Send Feedback
Gets ViewModel which is report view model.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewModel ViewModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewModel As ViewModel
Visual C++
public:
property ViewModel^ ViewModel {
    ViewModel^ get ();
}

Field Value

The view model.

See Also

ViewManager Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewModel Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel Class
Members See Also Send Feedback
Report view model.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract class ViewModel
Visual Basic (Declaration)
Public MustInherit Class ViewModel
Visual C++
public ref class ViewModel abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewModel
PerpetuumSoft.ReportingServices.Viewer.Client..::.DocumentViewModel

See Also

ViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewModel Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel Members
ViewModel Class Constructors Methods Fields Properties See Also Send Feedback

The ViewModel type exposes the following members.

Constructors

Name | Description
ViewModel | Initializes a new instance of the ViewModel class.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model.
ChangeZoom | Overloaded.
Clone | Creates object clone.
DocumentEnd | Performs switching to the end of the report.
DocumentHome | Performs switching to the begining of the report.
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Initiates switching to the first page.
GoToLastPage | Initiates switching to the last page.
GoToNextPage | Initiates switching to the next page.
GoToPrevPage | Initiates switching to the previous page.
HightlightSearchResult | Hightlights the search result.
MakeClientSideSearch | Executes the client side search.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus.
PageDown | Performs page scroll down.
PageEnd | Performs switching to the bottom of the page.
PageHome | Performs switching to the top of the page.
PageUp | Performs page scroll up.
PanView | Performs report scrolling.
ResetSearchResult | Resets the search result.
ShowSearchResult | Shows area with text search results.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | Updates the content.
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Performs scaling by the selected area.

Fields

Name | Description
MaxZoom | Gets max scale.
MinZoom | Gets min scale.

Properties

Name | Description
CanGoToNextPage | Gets the property which indicates if it is possible to switch to the next page.
CanGoToPrevPage | Gets the property which indicates if it is possible to switch to the previous page.
ClientSize | Gets the client area size.
HScrollBarActive | Gets the property which indicates if horizontal scrolling is active.
HScrollBarLarge | Gets value to be added to value property when the scroll box is moved at a large distance.
HScrollBarMaximum | Gets max value of the Value scrolling control.
HScrollBarPosition | Gets or sets the scroll box position on horizontal scroll bar.
HScrollBarSmall | Gets value to be added to value property when the scroll box is moved at a small distance.
HScrollBarViewPort | Gets a part of visible content of horizontal scroll bar.
PageNumber | Gets or sets the page number.
View | Gets IView which is report preview control.
ViewManager | Gets ViewManager which is Report Viewer manager.
VScrollBarActive | Gets the property which indicates if vertical scrolling is active.
VScrollBarLarge | Gets value to be added to value property when the scroll box is moved at a large distance.
VScrollBarMaximum | Gets max value of the Value scroll bar.
VScrollBarPosition | Gets or sets scroll box position on vertical scroll bar.
VScrollBarSmall | Gets value to be added to value property when the scroll box is moved at a small distance.
VScrollBarViewPort | Gets a part of visible content of vertical scroll bar.
Zoom | Gets or sets Zoom which is report scale.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewModel Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel Constructor
ViewModel Class See Also Send Feedback
Initializes a new instance of the ViewModel class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected ViewModel(
    ViewManager viewManager
)
Visual Basic (Declaration)
Protected Sub New ( _
    viewManager As ViewManager _
)
Visual C++
protected:
ViewModel(
    ViewManager^ viewManager
)

Parameters

viewManager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The view manager.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewModel Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel Fields
ViewModel Class See Also Send Feedback

The ViewModel type exposes the following members.

Fields

Name | Description
MaxZoom | Gets max scale.
MinZoom | Gets min scale.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MaxZoom Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.MaxZoom Field
ViewModel Class See Also Send Feedback
Gets max scale.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public const double MaxZoom
Visual Basic (Declaration)
Public Const MaxZoom As Double
Visual C++
public:
literal double MaxZoom

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MinZoom Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.MinZoom Field
ViewModel Class See Also Send Feedback
Gets min scale.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public const double MinZoom
Visual Basic (Declaration)
Public Const MinZoom As Double
Visual C++
public:
literal double MinZoom

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewModel Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel Methods
ViewModel Class See Also Send Feedback

The ViewModel type exposes the following members.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model.
ChangeZoom | Overloaded.
Clone | Creates object clone.
DocumentEnd | Performs switching to the end of the report.
DocumentHome | Performs switching to the begining of the report.
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Initiates switching to the first page.
GoToLastPage | Initiates switching to the last page.
GoToNextPage | Initiates switching to the next page.
GoToPrevPage | Initiates switching to the previous page.
HightlightSearchResult | Hightlights the search result.
MakeClientSideSearch | Executes the client side search.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus.
PageDown | Performs page scroll down.
PageEnd | Performs switching to the bottom of the page.
PageHome | Performs switching to the top of the page.
PageUp | Performs page scroll up.
PanView | Performs report scrolling.
ResetSearchResult | Resets the search result.
ShowSearchResult | Shows area with text search results.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | Updates the content.
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Performs scaling by the selected area.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


AssignParameters Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.AssignParameters Method
ViewModel Class See Also Send Feedback
Sets the model display parameters subject to the previous active model.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void AssignParameters(
    ViewModel previousModel
)
Visual Basic (Declaration)
Public Sub AssignParameters ( _
    previousModel As ViewModel _
)
Visual C++
public:
void AssignParameters(
    ViewModel^ previousModel
)

Parameters

previousModel
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewModel
The previous view model. (see ViewModel)

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ChangeZoom Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ChangeZoom Method
ViewModel Class See Also Send Feedback

Overload List

Name | Description
ChangeZoom(ZoomMode, Boolean) | Performs scale and scale mode changing.
ChangeZoom(Double, Boolean) | Performs scale and scale mode changing.
ChangeZoom(Point, Double, Boolean) | Performs scale and scale mode changing.

See Also

ViewModel Class
ViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ChangeZoom Method (ZoomMode, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ChangeZoom Method (ZoomMode, Boolean)
ViewModel Class See Also Send Feedback
Performs scale and scale mode changing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void ChangeZoom(
    ZoomMode mode,
    bool useAnimation
)
Visual Basic (Declaration)
Public MustOverride Sub ChangeZoom ( _
    mode As ZoomMode, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ChangeZoom(
    ZoomMode mode,
    bool useAnimation
) abstract

Parameters

mode
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomMode
The zoom mode. (see ZoomMode()()())
useAnimation
Type: System..::.Boolean
If it is set to true it is used animation to change view.

See Also

ViewModel Class
ChangeZoom Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ChangeZoom Method (Double, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ChangeZoom Method (Double, Boolean)
ViewModel Class See Also Send Feedback
Performs scale and scale mode changing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ChangeZoom(
    double scale,
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub ChangeZoom ( _
    scale As Double, _
    useAnimation As Boolean _
)
Visual C++
public:
void ChangeZoom(
    double scale,
    bool useAnimation
)

Parameters

scale
Type: System..::.Double
The scale.
useAnimation
Type: System..::.Boolean
If it is set to true it is used animation to change view.

See Also

ViewModel Class
ChangeZoom Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ChangeZoom Method (Point, Double, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ChangeZoom Method (Point, Double, Boolean)
ViewModel Class See Also Send Feedback
Performs scale and scale mode changing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void ChangeZoom(
    Point center,
    double scale,
    bool useAnimation
)
Visual Basic (Declaration)
Public MustOverride Sub ChangeZoom ( _
    center As Point, _
    scale As Double, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ChangeZoom(
    Point center,
    double scale,
    bool useAnimation
) abstract

Parameters

center
Type: System.Windows..::.Point
The center. The instance of Point structure.
scale
Type: System..::.Double
The scale.
useAnimation
Type: System..::.Boolean
If it is set to true it is used animation to change view.

See Also

ViewModel Class
ChangeZoom Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Clone Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.Clone Method
ViewModel Class See Also Send Feedback
Creates object clone.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract ViewModel Clone()
Visual Basic (Declaration)
Public MustOverride Function Clone As ViewModel
Visual C++
public:
virtual ViewModel^ Clone() abstract

Return Value

A ViewModel class.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentEnd Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.DocumentEnd Method
ViewModel Class See Also Send Feedback
Performs switching to the end of the report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void DocumentEnd()
Visual Basic (Declaration)
Public MustOverride Sub DocumentEnd
Visual C++
public:
virtual void DocumentEnd() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


DocumentHome Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.DocumentHome Method
ViewModel Class See Also Send Feedback
Performs switching to the begining of the report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void DocumentHome()
Visual Basic (Declaration)
Public MustOverride Sub DocumentHome
Visual C++
public:
virtual void DocumentHome() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


EnsureVisible Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.EnsureVisible Method
ViewModel Class See Also Send Feedback

Overload List

Name | Description
EnsureVisible(ReportRegion) | Shifts the visible area of the screen to guarantee that the specified report is visible.
EnsureVisible(ReportRegion, Boolean) | Shifts the visible area of the screen to guarantee that the specified report is visible.

See Also

ViewModel Class
ViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


EnsureVisible Method (ReportRegion)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.EnsureVisible Method (ReportRegion)
ViewModel Class See Also Send Feedback
Shifts the visible area of the screen to guarantee that the specified report is visible.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void EnsureVisible(
    ReportRegion region
)
Visual Basic (Declaration)
Public Sub EnsureVisible ( _
    region As ReportRegion _
)
Visual C++
public:
void EnsureVisible(
    ReportRegion region
)

Parameters

region
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportRegion
The region. The instance of ReportRegion class.

See Also

ViewModel Class
EnsureVisible Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


EnsureVisible Method (ReportRegion, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.EnsureVisible Method (ReportRegion, Boolean)
ViewModel Class See Also Send Feedback
Shifts the visible area of the screen to guarantee that the specified report is visible.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void EnsureVisible(
    ReportRegion region,
    bool alignTop
)
Visual Basic (Declaration)
Public MustOverride Sub EnsureVisible ( _
    region As ReportRegion, _
    alignTop As Boolean _
)
Visual C++
public:
virtual void EnsureVisible(
    ReportRegion region,
    bool alignTop
) abstract

Parameters

region
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportRegion
The region. The instance of ReportRegion class.
alignTop
Type: System..::.Boolean
If it is set to true then it is aligned to top.

See Also

ViewModel Class
EnsureVisible Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GoToFirstPage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.GoToFirstPage Method
ViewModel Class See Also Send Feedback
Initiates switching to the first page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void GoToFirstPage()
Visual Basic (Declaration)
Public MustOverride Sub GoToFirstPage
Visual C++
public:
virtual void GoToFirstPage() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GoToLastPage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.GoToLastPage Method
ViewModel Class See Also Send Feedback
Initiates switching to the last page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void GoToLastPage()
Visual Basic (Declaration)
Public MustOverride Sub GoToLastPage
Visual C++
public:
virtual void GoToLastPage() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GoToNextPage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.GoToNextPage Method
ViewModel Class See Also Send Feedback
Initiates switching to the next page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void GoToNextPage()
Visual Basic (Declaration)
Public MustOverride Sub GoToNextPage
Visual C++
public:
virtual void GoToNextPage() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GoToPrevPage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.GoToPrevPage Method
ViewModel Class See Also Send Feedback
Initiates switching to the previous page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void GoToPrevPage()
Visual Basic (Declaration)
Public MustOverride Sub GoToPrevPage
Visual C++
public:
virtual void GoToPrevPage() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HightlightSearchResult Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.HightlightSearchResult Method
ViewModel Class See Also Send Feedback
Hightlights the search result.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void HightlightSearchResult()
Visual Basic (Declaration)
Public MustOverride Sub HightlightSearchResult
Visual C++
public:
virtual void HightlightSearchResult() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MakeClientSideSearch Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.MakeClientSideSearch Method
ViewModel Class See Also Send Feedback
Executes the client side search.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract bool MakeClientSideSearch(
    SearchResult oldSearchResult,
    SearchResult newSearchResult
)
Visual Basic (Declaration)
Public MustOverride Function MakeClientSideSearch ( _
    oldSearchResult As SearchResult, _
    newSearchResult As SearchResult _
) As Boolean
Visual C++
public:
virtual bool MakeClientSideSearch(
    SearchResult^ oldSearchResult,
    SearchResult^ newSearchResult
) abstract

Parameters

oldSearchResult
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SearchResult
The old search result.
newSearchResult
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SearchResult
A new search result.

Return Value

True is found; otherwise False

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheel Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.MouseWheel Method
ViewModel Class See Also Send Feedback
Occurs when the mouse wheel moves while the control has focus.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public MustOverride Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) abstract

Parameters

delta
Type: System..::.Double
The delta.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.PageDown Method
ViewModel Class See Also Send Feedback
Performs page scroll down.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void PageDown()
Visual Basic (Declaration)
Public MustOverride Sub PageDown
Visual C++
public:
virtual void PageDown() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageEnd Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.PageEnd Method
ViewModel Class See Also Send Feedback
Performs switching to the bottom of the page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void PageEnd()
Visual Basic (Declaration)
Public MustOverride Sub PageEnd
Visual C++
public:
virtual void PageEnd() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageHome Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.PageHome Method
ViewModel Class See Also Send Feedback
Performs switching to the top of the page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void PageHome()
Visual Basic (Declaration)
Public MustOverride Sub PageHome
Visual C++
public:
virtual void PageHome() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.PageUp Method
ViewModel Class See Also Send Feedback
Performs page scroll up.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void PageUp()
Visual Basic (Declaration)
Public MustOverride Sub PageUp
Visual C++
public:
virtual void PageUp() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PanView Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.PanView Method
ViewModel Class See Also Send Feedback
Performs report scrolling.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void PanView(
    Point point
)
Visual Basic (Declaration)
Public MustOverride Sub PanView ( _
    point As Point _
)
Visual C++
public:
virtual void PanView(
    Point point
) abstract

Parameters

point
Type: System.Windows..::.Point
The Point to scroll.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ResetSearchResult Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ResetSearchResult Method
ViewModel Class See Also Send Feedback
Resets the search result.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void ResetSearchResult()
Visual Basic (Declaration)
Public MustOverride Sub ResetSearchResult
Visual C++
public:
virtual void ResetSearchResult() abstract

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ShowSearchResult Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ShowSearchResult Method
ViewModel Class See Also Send Feedback
Shows area with text search results.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void ShowSearchResult(
    ReportRegion region
)
Visual Basic (Declaration)
Public MustOverride Sub ShowSearchResult ( _
    region As ReportRegion _
)
Visual C++
public:
virtual void ShowSearchResult(
    ReportRegion region
) abstract

Parameters

region
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ReportRegion
The region. (see ReportRegion)

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateContent Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.UpdateContent Method
ViewModel Class See Also Send Feedback
Updates the content.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected internal abstract void UpdateContent(
    ViewModel prevViewModel,
    bool useAnimation
)
Visual Basic (Declaration)
Protected Friend MustOverride Sub UpdateContent ( _
    prevViewModel As ViewModel, _
    useAnimation As Boolean _
)
Visual C++
protected public:
virtual void UpdateContent(
    ViewModel^ prevViewModel,
    bool useAnimation
) abstract

Parameters

prevViewModel
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewModel
The previous view model. (see ViewModel)
useAnimation
Type: System..::.Boolean
If it is set to true it is used animation to change view.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomIn Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ZoomIn Method
ViewModel Class See Also Send Feedback

Overload List

Name | Description
ZoomIn(Boolean) | Performs zoom in.
ZoomIn(Point, Boolean) | Performs zoom in.

See Also

ViewModel Class
ViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomIn Method (Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ZoomIn Method (Boolean)
ViewModel Class See Also Send Feedback
Performs zoom in.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ZoomIn(
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub ZoomIn ( _
    useAnimation As Boolean _
)
Visual C++
public:
void ZoomIn(
    bool useAnimation
)

Parameters

useAnimation
Type: System..::.Boolean
If it is set to true it is used animation to change view.

See Also

ViewModel Class
ZoomIn Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomIn Method (Point, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ZoomIn Method (Point, Boolean)
ViewModel Class See Also Send Feedback
Performs zoom in.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ZoomIn(
    Point center,
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub ZoomIn ( _
    center As Point, _
    useAnimation As Boolean _
)
Visual C++
public:
void ZoomIn(
    Point center,
    bool useAnimation
)

Parameters

center
Type: System.Windows..::.Point
The center. The instance of Point struct.
useAnimation
Type: System..::.Boolean
If it is set to true it is used animation to change view.

See Also

ViewModel Class
ZoomIn Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOut Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ZoomOut Method
ViewModel Class See Also Send Feedback

Overload List

Name | Description
ZoomOut(Boolean) | Performs zoom out.
ZoomOut(Point, Boolean) | Performs zoom out.

See Also

ViewModel Class
ViewModel Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOut Method (Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ZoomOut Method (Boolean)
ViewModel Class See Also Send Feedback
Performs zoom out.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ZoomOut(
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub ZoomOut ( _
    useAnimation As Boolean _
)
Visual C++
public:
void ZoomOut(
    bool useAnimation
)

Parameters

useAnimation
Type: System..::.Boolean
If it is set to true it is used animation to change view.

See Also

ViewModel Class
ZoomOut Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOut Method (Point, Boolean)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ZoomOut Method (Point, Boolean)
ViewModel Class See Also Send Feedback
Performs zoom out.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ZoomOut(
    Point center,
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub ZoomOut ( _
    center As Point, _
    useAnimation As Boolean _
)
Visual C++
public:
void ZoomOut(
    Point center,
    bool useAnimation
)

Parameters

center
Type: System.Windows..::.Point
The center. The instance of Point struct.
useAnimation
Type: System..::.Boolean
If it is set to true it is used animation to change view.

See Also

ViewModel Class
ZoomOut Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomWindow Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ZoomWindow Method
ViewModel Class See Also Send Feedback
Performs scaling by the selected area.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract void ZoomWindow(
    Rect rect,
    bool useAnimation
)
Visual Basic (Declaration)
Public MustOverride Sub ZoomWindow ( _
    rect As Rect, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ZoomWindow(
    Rect rect,
    bool useAnimation
) abstract

Parameters

rect
Type: System.Windows..::.Rect
The rect. The instance of Rect struct.
useAnimation
Type: System..::.Boolean
If it is set to true it is used animation to change view.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewModel Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel Properties
ViewModel Class See Also Send Feedback

The ViewModel type exposes the following members.

Properties

Name | Description
CanGoToNextPage | Gets the property which indicates if it is possible to switch to the next page.
CanGoToPrevPage | Gets the property which indicates if it is possible to switch to the previous page.
ClientSize | Gets the client area size.
HScrollBarActive | Gets the property which indicates if horizontal scrolling is active.
HScrollBarLarge | Gets value to be added to value property when the scroll box is moved at a large distance.
HScrollBarMaximum | Gets max value of the Value scrolling control.
HScrollBarPosition | Gets or sets the scroll box position on horizontal scroll bar.
HScrollBarSmall | Gets value to be added to value property when the scroll box is moved at a small distance.
HScrollBarViewPort | Gets a part of visible content of horizontal scroll bar.
PageNumber | Gets or sets the page number.
View | Gets IView which is report preview control.
ViewManager | Gets ViewManager which is Report Viewer manager.
VScrollBarActive | Gets the property which indicates if vertical scrolling is active.
VScrollBarLarge | Gets value to be added to value property when the scroll box is moved at a large distance.
VScrollBarMaximum | Gets max value of the Value scroll bar.
VScrollBarPosition | Gets or sets scroll box position on vertical scroll bar.
VScrollBarSmall | Gets value to be added to value property when the scroll box is moved at a small distance.
VScrollBarViewPort | Gets a part of visible content of vertical scroll bar.
Zoom | Gets or sets Zoom which is report scale.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CanGoToNextPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.CanGoToNextPage Property
ViewModel Class See Also Send Feedback
Gets the property which indicates if it is possible to switch to the next page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract bool CanGoToNextPage { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CanGoToNextPage As Boolean
Visual C++
public:
virtual property bool CanGoToNextPage {
    bool get () abstract;
}

Field Value

true if it is possible to switch to the next page; otherwise, false.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CanGoToPrevPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.CanGoToPrevPage Property
ViewModel Class See Also Send Feedback
Gets the property which indicates if it is possible to switch to the previous page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract bool CanGoToPrevPage { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CanGoToPrevPage As Boolean
Visual C++
public:
virtual property bool CanGoToPrevPage {
    bool get () abstract;
}

Field Value

true if it is possible to switch to the previous page; otherwise, false.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ClientSize Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ClientSize Property
ViewModel Class See Also Send Feedback
Gets the client area size.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected Size ClientSize { get; }
Visual Basic (Declaration)
Protected ReadOnly Property ClientSize As Size
Visual C++
protected:
property Size ClientSize {
    Size get ();
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarActive Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.HScrollBarActive Property
ViewModel Class See Also Send Feedback
Gets the property which indicates if horizontal scrolling is active.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract bool HScrollBarActive { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HScrollBarActive As Boolean
Visual C++
public:
virtual property bool HScrollBarActive {
    bool get () abstract;
}

Field Value

true if horizontal scrolling is active; otherwise, false.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarLarge Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.HScrollBarLarge Property
ViewModel Class See Also Send Feedback
Gets value to be added to value property when the scroll box is moved at a large distance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract double HScrollBarLarge { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HScrollBarLarge As Double
Visual C++
public:
virtual property double HScrollBarLarge {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarMaximum Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.HScrollBarMaximum Property
ViewModel Class See Also Send Feedback
Gets max value of the Value scrolling control.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract double HScrollBarMaximum { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HScrollBarMaximum As Double
Visual C++
public:
virtual property double HScrollBarMaximum {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarPosition Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.HScrollBarPosition Property
ViewModel Class See Also Send Feedback
Gets or sets the scroll box position on horizontal scroll bar.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract double HScrollBarPosition { get; set; }
Visual Basic (Declaration)
Public MustOverride Property HScrollBarPosition As Double
Visual C++
public:
virtual property double HScrollBarPosition {
    double get () abstract;
    void set (double value) abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarSmall Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.HScrollBarSmall Property
ViewModel Class See Also Send Feedback
Gets value to be added to value property when the scroll box is moved at a small distance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract double HScrollBarSmall { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HScrollBarSmall As Double
Visual C++
public:
virtual property double HScrollBarSmall {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HScrollBarViewPort Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.HScrollBarViewPort Property
ViewModel Class See Also Send Feedback
Gets a part of visible content of horizontal scroll bar.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract double HScrollBarViewPort { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HScrollBarViewPort As Double
Visual C++
public:
virtual property double HScrollBarViewPort {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageNumber Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.PageNumber Property
ViewModel Class See Also Send Feedback
Gets or sets the page number.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract int PageNumber { get; set; }
Visual Basic (Declaration)
Public MustOverride Property PageNumber As Integer
Visual C++
public:
virtual property int PageNumber {
    int get () abstract;
    void set (int value) abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


View Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.View Property
ViewModel Class See Also Send Feedback
Gets IView which is report preview control.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public IView View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As IView
Visual C++
public:
property IView^ View {
    IView^ get ();
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewManager Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.ViewManager Property
ViewModel Class See Also Send Feedback
Gets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewManager ViewManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarActive Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.VScrollBarActive Property
ViewModel Class See Also Send Feedback
Gets the property which indicates if vertical scrolling is active.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract bool VScrollBarActive { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property VScrollBarActive As Boolean
Visual C++
public:
virtual property bool VScrollBarActive {
    bool get () abstract;
}

Field Value

true if vertical scrolling is active; otherwise false.

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarLarge Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.VScrollBarLarge Property
ViewModel Class See Also Send Feedback
Gets value to be added to value property when the scroll box is moved at a large distance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract double VScrollBarLarge { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property VScrollBarLarge As Double
Visual C++
public:
virtual property double VScrollBarLarge {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarMaximum Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.VScrollBarMaximum Property
ViewModel Class See Also Send Feedback
Gets max value of the Value scroll bar.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract double VScrollBarMaximum { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property VScrollBarMaximum As Double
Visual C++
public:
virtual property double VScrollBarMaximum {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarPosition Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.VScrollBarPosition Property
ViewModel Class See Also Send Feedback
Gets or sets scroll box position on vertical scroll bar.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract double VScrollBarPosition { get; set; }
Visual Basic (Declaration)
Public MustOverride Property VScrollBarPosition As Double
Visual C++
public:
virtual property double VScrollBarPosition {
    double get () abstract;
    void set (double value) abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarSmall Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.VScrollBarSmall Property
ViewModel Class See Also Send Feedback
Gets value to be added to value property when the scroll box is moved at a small distance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract double VScrollBarSmall { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property VScrollBarSmall As Double
Visual C++
public:
virtual property double VScrollBarSmall {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


VScrollBarViewPort Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.VScrollBarViewPort Property
ViewModel Class See Also Send Feedback
Gets a part of visible content of vertical scroll bar.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract double VScrollBarViewPort { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property VScrollBarViewPort As Double
Visual C++
public:
virtual property double VScrollBarViewPort {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Zoom Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewModel..::.Zoom Property
ViewModel Class See Also Send Feedback
Gets or sets Zoom which is report scale.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract Zoom Zoom { get; set; }
Visual Basic (Declaration)
Public MustOverride Property Zoom As Zoom
Visual C++
public:
virtual property Zoom Zoom {
    Zoom get () abstract;
    void set (Zoom value) abstract;
}

See Also

ViewModel Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewOptions Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions Class
Members See Also Send Feedback
Report Viewer parameters.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ViewOptions : DependencyObject
Visual Basic (Declaration)
Public Class ViewOptions _
    Inherits DependencyObject
Visual C++
public ref class ViewOptions : public DependencyObject

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewOptions

See Also

ViewOptions Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewOptions Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions Members
ViewOptions Class Constructors Methods Properties See Also Send Feedback

The ViewOptions type exposes the following members.

Constructors

Name | Description
ViewOptions | Initializes a new instance of the ViewOptions class.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CredentialsElementBrowsing | Gets or sets the property which indicates that changing credentials element are available.
CSVExportBrowsing | Gets or sets the property which indicates that export to CSV is available.
CustomCursorsUsing | Gets or sets the property which indicates if custom cursors are used.
Dispatcher | (Inherited from DependencyObject.)
ExcelExportBrowsing | Gets or sets the property which indicates that export to Excel is available.
HistoryNavigatorBrowsing | Gets or sets the property which indicates that view status history navigation buttons are available.
HtmlExportBrowsing | Gets or sets the property which indicates that export to HTML is available.
MHTMLExportBrowsing | Gets or sets the property which indicates that export to MHTML is available.
PageModelNavigatorBrowsing | Gets or sets the property which indicates that page display model changing element are available.
PageNavigatorBrowsing | Gets or sets the property which indicates that page navigation elements are available.
ParametersElementBrowsing | Gets or sets the property which indicates that changing parameters element are available.
PDFExportBrowsing | Gets or sets the property which indicates that export to PDF is available.
PrintElementBrowsing | Gets or sets the property which indicates that printing element is available.
RTFExportBrowsing | Gets or sets the property which indicates that export to RTF is available.
SearchElementsBrowsing | Gets or sets the property which indicates that search elements are available.
TIFFExportBrowsing | Gets or sets the property which indicates that export to TIFF is available.
WordExportBrowsing | Gets or sets the property which indicates that export to Word is available.
XMLExportBrowsing | Gets or sets the property which indicates that export to XML is available.
XPSExportBrowsing | Gets or sets the property which indicates that export to XPS is available.
ZoomElementsBrowsing | Gets or sets the property which indicates that display scaling elements are available.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewOptions Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions Constructor
ViewOptions Class See Also Send Feedback
Initializes a new instance of the ViewOptions class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ViewOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewOptions()

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewOptions Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions Methods
ViewOptions Class See Also Send Feedback

The ViewOptions type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ViewOptions Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions Properties
ViewOptions Class See Also Send Feedback

The ViewOptions type exposes the following members.

Properties

Name | Description
CredentialsElementBrowsing | Gets or sets the property which indicates that changing credentials element are available.
CSVExportBrowsing | Gets or sets the property which indicates that export to CSV is available.
CustomCursorsUsing | Gets or sets the property which indicates if custom cursors are used.
Dispatcher | (Inherited from DependencyObject.)
ExcelExportBrowsing | Gets or sets the property which indicates that export to Excel is available.
HistoryNavigatorBrowsing | Gets or sets the property which indicates that view status history navigation buttons are available.
HtmlExportBrowsing | Gets or sets the property which indicates that export to HTML is available.
MHTMLExportBrowsing | Gets or sets the property which indicates that export to MHTML is available.
PageModelNavigatorBrowsing | Gets or sets the property which indicates that page display model changing element are available.
PageNavigatorBrowsing | Gets or sets the property which indicates that page navigation elements are available.
ParametersElementBrowsing | Gets or sets the property which indicates that changing parameters element are available.
PDFExportBrowsing | Gets or sets the property which indicates that export to PDF is available.
PrintElementBrowsing | Gets or sets the property which indicates that printing element is available.
RTFExportBrowsing | Gets or sets the property which indicates that export to RTF is available.
SearchElementsBrowsing | Gets or sets the property which indicates that search elements are available.
TIFFExportBrowsing | Gets or sets the property which indicates that export to TIFF is available.
WordExportBrowsing | Gets or sets the property which indicates that export to Word is available.
XMLExportBrowsing | Gets or sets the property which indicates that export to XML is available.
XPSExportBrowsing | Gets or sets the property which indicates that export to XPS is available.
ZoomElementsBrowsing | Gets or sets the property which indicates that display scaling elements are available.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CredentialsElementBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.CredentialsElementBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that changing credentials element are available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool CredentialsElementBrowsing { get; set; }
Visual Basic (Declaration)
Public Property CredentialsElementBrowsing As Boolean
Visual C++
public:
property bool CredentialsElementBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if changing credentials element are available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CSVExportBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.CSVExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to CSV is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool CSVExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property CSVExportBrowsing As Boolean
Visual C++
public:
property bool CSVExportBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if export to CSV is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


CustomCursorsUsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.CustomCursorsUsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates if custom cursors are used.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool CustomCursorsUsing { get; set; }
Visual Basic (Declaration)
Public Property CustomCursorsUsing As Boolean
Visual C++
public:
property bool CustomCursorsUsing {
    bool get ();
    void set (bool value);
}

Field Value

true if custom cursors are used; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ExcelExportBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.ExcelExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to Excel is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool ExcelExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property ExcelExportBrowsing As Boolean
Visual C++
public:
property bool ExcelExportBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if export to Excel is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HistoryNavigatorBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.HistoryNavigatorBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that view status history navigation buttons are available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool HistoryNavigatorBrowsing { get; set; }
Visual Basic (Declaration)
Public Property HistoryNavigatorBrowsing As Boolean
Visual C++
public:
property bool HistoryNavigatorBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if view status history navigation buttons are available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


HtmlExportBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.HtmlExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to HTML is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool HtmlExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property HtmlExportBrowsing As Boolean
Visual C++
public:
property bool HtmlExportBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if export to HTML is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MHTMLExportBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.MHTMLExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to MHTML is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool MHTMLExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property MHTMLExportBrowsing As Boolean
Visual C++
public:
property bool MHTMLExportBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if export to MHTML is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageModelNavigatorBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.PageModelNavigatorBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that page display model changing element are available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool PageModelNavigatorBrowsing { get; set; }
Visual Basic (Declaration)
Public Property PageModelNavigatorBrowsing As Boolean
Visual C++
public:
property bool PageModelNavigatorBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if page display model changing element are available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PageNavigatorBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.PageNavigatorBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that page navigation elements are available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool PageNavigatorBrowsing { get; set; }
Visual Basic (Declaration)
Public Property PageNavigatorBrowsing As Boolean
Visual C++
public:
property bool PageNavigatorBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if page navigation elements are available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ParametersElementBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.ParametersElementBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that changing parameters element are available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool ParametersElementBrowsing { get; set; }
Visual Basic (Declaration)
Public Property ParametersElementBrowsing As Boolean
Visual C++
public:
property bool ParametersElementBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if changing parameters element are available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PDFExportBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.PDFExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to PDF is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool PDFExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property PDFExportBrowsing As Boolean
Visual C++
public:
property bool PDFExportBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if export to PDF is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PrintElementBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.PrintElementBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that printing element is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool PrintElementBrowsing { get; set; }
Visual Basic (Declaration)
Public Property PrintElementBrowsing As Boolean
Visual C++
public:
property bool PrintElementBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if printing is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


RTFExportBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.RTFExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to RTF is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool RTFExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property RTFExportBrowsing As Boolean
Visual C++
public:
property bool RTFExportBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if export to RTF is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


SearchElementsBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.SearchElementsBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that search elements are available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool SearchElementsBrowsing { get; set; }
Visual Basic (Declaration)
Public Property SearchElementsBrowsing As Boolean
Visual C++
public:
property bool SearchElementsBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if search elements are available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


TIFFExportBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.TIFFExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to TIFF is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool TIFFExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property TIFFExportBrowsing As Boolean
Visual C++
public:
property bool TIFFExportBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if export to TIFF is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


WordExportBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.WordExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to Word is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool WordExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property WordExportBrowsing As Boolean
Visual C++
public:
property bool WordExportBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if export to Word is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


XMLExportBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.XMLExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to XML is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool XMLExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property XMLExportBrowsing As Boolean
Visual C++
public:
property bool XMLExportBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if export to XML is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


XPSExportBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.XPSExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to XPS is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool XPSExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property XPSExportBrowsing As Boolean
Visual C++
public:
property bool XPSExportBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if export to XPS is available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomElementsBrowsing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ViewOptions..::.ZoomElementsBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that display scaling elements are available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool ZoomElementsBrowsing { get; set; }
Visual Basic (Declaration)
Public Property ZoomElementsBrowsing As Boolean
Visual C++
public:
property bool ZoomElementsBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

true if display scaling elements are available; otherwise, false.

See Also

ViewOptions Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


WaitTool Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool Class
Members See Also Send Feedback
The WaitTool class. Inherits the Tool class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class WaitTool : Tool
Visual Basic (Declaration)
Public Class WaitTool _
    Inherits Tool
Visual C++
public ref class WaitTool : public Tool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
PerpetuumSoft.ReportingServices.Viewer.Client..::.WaitTool

See Also

WaitTool Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


WaitTool Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool Members
WaitTool Class Constructors Methods Properties See Also Send Feedback

The WaitTool type exposes the following members.

Constructors

Name | Description
WaitTool | Initializes the WaitTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overriden. (Overrides Tool..::.KeyDown(KeyEventArgs).)
KeyUp | Overriden. (Overrides Tool..::.KeyUp(KeyEventArgs).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overriden. (Overrides Tool..::.MouseDown(MouseEventArgs).)
MouseMove | Overriden. (Overrides Tool..::.MouseMove(MouseEventArgs).)
MouseUp | Overriden. (Overrides Tool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overriden. (Overrides Tool..::.MouseWheel(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates cursor. (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
PrevTool | Gets a previous tool.
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


WaitTool Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool Constructor
WaitTool Class See Also Send Feedback
Initializes the WaitTool class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public WaitTool(
    ViewManager manager,
    Tool prevTool
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager, _
    prevTool As Tool _
)
Visual C++
public:
WaitTool(
    ViewManager^ manager,
    Tool^ prevTool
)

Parameters

manager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The ViewManager class.
prevTool
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
The Tool class

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


WaitTool Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool Methods
WaitTool Class See Also Send Feedback

The WaitTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overriden. (Overrides Tool..::.KeyDown(KeyEventArgs).)
KeyUp | Overriden. (Overrides Tool..::.KeyUp(KeyEventArgs).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overriden. (Overrides Tool..::.MouseDown(MouseEventArgs).)
MouseMove | Overriden. (Overrides Tool..::.MouseMove(MouseEventArgs).)
MouseUp | Overriden. (Overrides Tool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overriden. (Overrides Tool..::.MouseWheel(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates cursor. (Overrides Tool..::.UpdateCursor()()().)

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


KeyDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool..::.KeyDown Method
WaitTool Class See Also Send Feedback
Overriden.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void KeyDown(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub KeyDown ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyDown(
    KeyEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


KeyUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool..::.KeyUp Method
WaitTool Class See Also Send Feedback
Overriden.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void KeyUp(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub KeyUp ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyUp(
    KeyEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseDown Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool..::.MouseDown Method
WaitTool Class See Also Send Feedback
Overriden.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseMove Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool..::.MouseMove Method
WaitTool Class See Also Send Feedback
Overriden.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool..::.MouseUp Method
WaitTool Class See Also Send Feedback
Overriden.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseWheel Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool..::.MouseWheel Method
WaitTool Class See Also Send Feedback
Overriden.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public Overrides Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) override

Parameters

delta
Type: System..::.Double

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateCursor Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool..::.UpdateCursor Method
WaitTool Class See Also Send Feedback
Updates cursor.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


WaitTool Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool Properties
WaitTool Class See Also Send Feedback

The WaitTool type exposes the following members.

Properties

Name | Description
PrevTool | Gets a previous tool.
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PrevTool Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
WaitTool..::.PrevTool Property
WaitTool Class See Also Send Feedback
Gets a previous tool.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Tool PrevTool { get; private set; }
Visual Basic (Declaration)
Public Property PrevTool As Tool
Visual C++
public:
property Tool^ PrevTool {
    Tool^ get ();
    void set (Tool^ value);
}

Remarks

See Tool.

See Also

WaitTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Zoom Structure

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom Structure
Members See Also Send Feedback
A strcture which includes data about current report scale.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public struct Zoom
Visual Basic (Declaration)
Public Structure Zoom
Visual C++
public value class Zoom

See Also

Zoom Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Zoom Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom Members
Zoom Structure Constructors Methods Properties See Also Send Feedback

The Zoom type exposes the following members.

Constructors

Name | Description
Zoom | Overloaded.

Methods

Name | Description
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Mode | Gets ZoomMode which is scale mode.
Scale | Gets scale value.

See Also

Zoom Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Zoom Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom Constructor
Zoom Structure See Also Send Feedback

Overload List

Name | Description
Zoom(ZoomMode) | Initializes a new instance of the Zoom structure.
Zoom(Double) | Initializes a new instance of the Zoom structure.
Zoom(ZoomMode, Double) | Initializes a new instance of the Zoom structure.

See Also

Zoom Structure
Zoom Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Zoom Constructor (ZoomMode)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom Constructor (ZoomMode)
Zoom Structure See Also Send Feedback
Initializes a new instance of the Zoom structure.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Zoom(
    ZoomMode mode
)
Visual Basic (Declaration)
Public Sub New ( _
    mode As ZoomMode _
)
Visual C++
public:
Zoom(
    ZoomMode mode
)

Parameters

mode
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomMode
The zoom mode. (see ZoomMode).

See Also

Zoom Structure
Zoom Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Zoom Constructor (Double)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom Constructor (Double)
Zoom Structure See Also Send Feedback
Initializes a new instance of the Zoom structure.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Zoom(
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    scale As Double _
)
Visual C++
public:
Zoom(
    double scale
)

Parameters

scale
Type: System..::.Double
The scale.

See Also

Zoom Structure
Zoom Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Zoom Constructor (ZoomMode, Double)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom Constructor (ZoomMode, Double)
Zoom Structure See Also Send Feedback
Initializes a new instance of the Zoom structure.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Zoom(
    ZoomMode mode,
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    mode As ZoomMode, _
    scale As Double _
)
Visual C++
public:
Zoom(
    ZoomMode mode,
    double scale
)

Parameters

mode
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomMode
The zoom mode. (see ZoomMode)
scale
Type: System..::.Double
The scale.

See Also

Zoom Structure
Zoom Overload
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Zoom Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom Methods
Zoom Structure See Also Send Feedback

The Zoom type exposes the following members.

Methods

Name | Description
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Zoom Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Equals Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom..::.Equals Method
Zoom Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Zoom Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GetHashCode Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom..::.GetHashCode Method
Zoom Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Zoom Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Zoom Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom Properties
Zoom Structure See Also Send Feedback

The Zoom type exposes the following members.

Properties

Name | Description
Mode | Gets ZoomMode which is scale mode.
Scale | Gets scale value.

See Also

Zoom Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Mode Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom..::.Mode Property
Zoom Structure See Also Send Feedback
Gets ZoomMode which is scale mode.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ZoomMode Mode { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mode As ZoomMode
Visual C++
public:
property ZoomMode Mode {
    ZoomMode get ();
}

See Also

Zoom Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


Scale Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Zoom..::.Scale Property
Zoom Structure See Also Send Feedback
Gets scale value.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double Scale { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scale As Double
Visual C++
public:
property double Scale {
    double get ();
}

See Also

Zoom Structure
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomChangeTool Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomChangeTool Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public abstract class ZoomChangeTool : StandardTool
Visual Basic (Declaration)
Public MustInherit Class ZoomChangeTool _
    Inherits StandardTool
Visual C++
public ref class ZoomChangeTool abstract : public StandardTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
PerpetuumSoft.ReportingServices.Viewer.Client..::.StandardTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomChangeTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomInTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomOutTool

See Also

ZoomChangeTool Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomChangeTool Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomChangeTool Members
ZoomChangeTool Class Constructors Methods Properties See Also Send Feedback

The ZoomChangeTool type exposes the following members.

Constructors

Name | Description
ZoomChangeTool | Initializes a new instance of the ZoomChangeTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step.
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomChangeTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomChangeTool Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomChangeTool Constructor
ZoomChangeTool Class See Also Send Feedback
Initializes a new instance of the ZoomChangeTool class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected ZoomChangeTool(
    ViewManager manager
)
Visual Basic (Declaration)
Protected Sub New ( _
    manager As ViewManager _
)
Visual C++
protected:
ZoomChangeTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The view manager.

See Also

ZoomChangeTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomChangeTool Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomChangeTool Methods
ZoomChangeTool Class See Also Send Feedback

The ZoomChangeTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step.
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

See Also

ZoomChangeTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


GetZoomFactor Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomChangeTool..::.GetZoomFactor Method
ZoomChangeTool Class See Also Send Feedback
Gets the scale step.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected abstract double GetZoomFactor()
Visual Basic (Declaration)
Protected MustOverride Function GetZoomFactor As Double
Visual C++
protected:
virtual double GetZoomFactor() abstract

Return Value

The scale step.

See Also

ZoomChangeTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseMove Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomChangeTool..::.MouseMove Method
ZoomChangeTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs
The MouseEventArgs instance containing the event data.

See Also

ZoomChangeTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


MouseUp Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomChangeTool..::.MouseUp Method
ZoomChangeTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs
The MouseEventArgs instance containing the event data.

See Also

ZoomChangeTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomChangeTool Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomChangeTool Properties
ZoomChangeTool Class See Also Send Feedback

The ZoomChangeTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomChangeTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomInTool Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomInTool Class
Members See Also Send Feedback
A class for realization of the tool which can be used for zooming in report view. Inherited from ZoomChangeTool.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ZoomInTool : ZoomChangeTool
Visual Basic (Declaration)
Public NotInheritable Class ZoomInTool _
    Inherits ZoomChangeTool
Visual C++
public ref class ZoomInTool sealed : public ZoomChangeTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
PerpetuumSoft.ReportingServices.Viewer.Client..::.StandardTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomChangeTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomInTool

See Also

ZoomInTool Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomInTool Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomInTool Members
ZoomInTool Class Constructors Methods Properties See Also Send Feedback

The ZoomInTool type exposes the following members.

Constructors

Name | Description
ZoomInTool | Initializes a new instance of the ZoomInTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step. (Inherited from ZoomChangeTool.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates the cursor. Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomInTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomInTool Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomInTool Constructor
ZoomInTool Class See Also Send Feedback
Initializes a new instance of the ZoomInTool class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ZoomInTool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
ZoomInTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The view manager.

See Also

ZoomInTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomInTool Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomInTool Methods
ZoomInTool Class See Also Send Feedback

The ZoomInTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step. (Inherited from ZoomChangeTool.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates the cursor. Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

See Also

ZoomInTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateCursor Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomInTool..::.UpdateCursor Method
ZoomInTool Class See Also Send Feedback
Updates the cursor. Overridden. See UpdateCursor()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

ZoomInTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomInTool Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomInTool Properties
ZoomInTool Class See Also Send Feedback

The ZoomInTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomInTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomMode Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomMode Enumeration
See Also Send Feedback
Enumeration which includes scale modes list.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public enum ZoomMode
Visual Basic (Declaration)
Public Enumeration ZoomMode
Visual C++
public enum class ZoomMode

Members

Member name | Description
Scale | Scale mode which is set by fractional number.
WholePage | Scale mode by page sizes.
PageWidth | Scale mode by page width.

See Also

PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOutTool Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomOutTool Class
Members See Also Send Feedback
A class for tool (functionality) realization which is used for report zooming out. Inherited from ZoomChangeTool.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ZoomOutTool : ZoomChangeTool
Visual Basic (Declaration)
Public NotInheritable Class ZoomOutTool _
    Inherits ZoomChangeTool
Visual C++
public ref class ZoomOutTool sealed : public ZoomChangeTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client..::.Tool
PerpetuumSoft.ReportingServices.Viewer.Client..::.StandardTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomChangeTool
PerpetuumSoft.ReportingServices.Viewer.Client..::.ZoomOutTool

See Also

ZoomOutTool Members
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOutTool Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomOutTool Members
ZoomOutTool Class Constructors Methods Properties See Also Send Feedback

The ZoomOutTool type exposes the following members.

Constructors

Name | Description
ZoomOutTool | Initializes a new instance of the ZoomOutTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step. (Inherited from ZoomChangeTool.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overriden. See UpdateCursor()()() (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomOutTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOutTool Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomOutTool Constructor
ZoomOutTool Class See Also Send Feedback
Initializes a new instance of the ZoomOutTool class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ZoomOutTool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
ZoomOutTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The manager.

See Also

ZoomOutTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOutTool Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomOutTool Methods
ZoomOutTool Class See Also Send Feedback

The ZoomOutTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step. (Inherited from ZoomChangeTool.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overriden. See UpdateCursor()()() (Overrides Tool..::.UpdateCursor()()().)

See Also

ZoomOutTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


UpdateCursor Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomOutTool..::.UpdateCursor Method
ZoomOutTool Class See Also Send Feedback
Overriden. See UpdateCursor()()()

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

ZoomOutTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


ZoomOutTool Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ZoomOutTool Properties
ZoomOutTool Class See Also Send Feedback

The ZoomOutTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomOutTool Class
PerpetuumSoft.ReportingServices.Viewer.Client Namespace


PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace
Send Feedback

Classes

Class | Description
ActionInfo | ActionInfo class.


ActionInfo Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ActionInfo Class
Members See Also Send Feedback
ActionInfo class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Extenders
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static class ActionInfo
Visual Basic (Declaration)
Public NotInheritable Class ActionInfo
Visual C++
public ref class ActionInfo abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders..::.ActionInfo

See Also

ActionInfo Members
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace


ActionInfo Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ActionInfo Members
ActionInfo Class Methods Fields Attached Properties See Also Send Feedback

The ActionInfo type exposes the following members.

Methods

Name | Description
GetValue | Gets the value of Value dependency property.
SetValue | Sets a value of Value dependency property.

Fields

Name | Description
ValueProperty | Identifies the Value dependency property.

Attached Properties

Name | Description
Value |

See Also

ActionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace


ActionInfo Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ActionInfo Fields
ActionInfo Class See Also Send Feedback

The ActionInfo type exposes the following members.

Fields

Name | Description
ValueProperty | Identifies the Value dependency property.

See Also

ActionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace


ValueProperty Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ActionInfo..::.ValueProperty Field
ActionInfo Class See Also Send Feedback
Identifies the Value dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Extenders
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static readonly DependencyProperty ValueProperty
Visual Basic (Declaration)
Public Shared ReadOnly ValueProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ValueProperty

See Also

ActionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace


ActionInfo Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ActionInfo Methods
ActionInfo Class See Also Send Feedback

The ActionInfo type exposes the following members.

Methods

Name | Description
GetValue | Gets the value of Value dependency property.
SetValue | Sets a value of Value dependency property.

See Also

ActionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace


GetValue Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ActionInfo..::.GetValue Method
ActionInfo Class See Also Send Feedback
Gets the value of Value dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Extenders
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static string GetValue(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetValue ( _
    obj As DependencyObject _
) As String
Visual C++
public:
static String^ GetValue(
    DependencyObject^ obj
)

Parameters

obj
Type: System.Windows..::.DependencyObject
DependencyProperty.

See Also

ActionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace


SetValue Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ActionInfo..::.SetValue Method
ActionInfo Class See Also Send Feedback
Sets a value of Value dependency property.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Extenders
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static void SetValue(
    DependencyObject obj,
    string value
)
Visual Basic (Declaration)
Public Shared Sub SetValue ( _
    obj As DependencyObject, _
    value As String _
)
Visual C++
public:
static void SetValue(
    DependencyObject^ obj,
    String^ value
)

Parameters

obj
Type: System.Windows..::.DependencyObject
DependencyProperty.
value
Type: System..::.String
The value to set.

See Also

ActionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace


ActionInfo Attached Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ActionInfo Attached Properties
ActionInfo Class See Also Send Feedback

The ActionInfo type exposes the following members.

Attached Properties

Name | Description
Value |

See Also

ActionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace


Value Attached Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ActionInfo..::.Value Attached Property
ActionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Extenders
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
See GetValue, SetValue
Visual Basic (Declaration)
See GetValue, SetValue
Visual C++
See GetValue, SetValue

See Also

ActionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.Extenders Namespace


PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace
Send Feedback

Classes

Class | Description
FontsManager | Fonts manager.
FontUtils | A static class for working with fonts.

Structures

Structure | Description
FontKey | Font key for its unique identification.


FontKey Structure

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontKey Structure
Members See Also Send Feedback
Font key for its unique identification.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public struct FontKey
Visual Basic (Declaration)
Public Structure FontKey
Visual C++
public value class FontKey

See Also

FontKey Members
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


FontKey Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontKey Members
FontKey Structure Methods Fields See Also Send Feedback

The FontKey type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

Fields

Name | Description
Family | Gets or sets font family.
Weight | Gets or sets font weight.

See Also

FontKey Structure
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


FontKey Fields

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontKey Fields
FontKey Structure See Also Send Feedback

The FontKey type exposes the following members.

Fields

Name | Description
Family | Gets or sets font family.
Weight | Gets or sets font weight.

See Also

FontKey Structure
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


Family Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontKey..::.Family Field
FontKey Structure See Also Send Feedback
Gets or sets font family.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Family
Visual Basic (Declaration)
Public Family As String
Visual C++
public:
String^ Family

See Also

FontKey Structure
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


Weight Field

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontKey..::.Weight Field
FontKey Structure See Also Send Feedback
Gets or sets font weight.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public FontWeight Weight
Visual Basic (Declaration)
Public Weight As FontWeight
Visual C++
public:
FontWeight Weight

See Also

FontKey Structure
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


FontKey Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontKey Methods
FontKey Structure See Also Send Feedback

The FontKey type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

See Also

FontKey Structure
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


GetHashCode Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontKey..::.GetHashCode Method
FontKey Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

FontKey Structure
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


ToString Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontKey..::.ToString Method
FontKey Structure See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

FontKey Structure
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


FontsManager Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsManager Class
Members See Also Send Feedback
Fonts manager.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class FontsManager
Visual Basic (Declaration)
Public Class FontsManager
Visual C++
public ref class FontsManager

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts..::.FontsManager

See Also

FontsManager Members
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


FontsManager Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsManager Members
FontsManager Class Methods See Also Send Feedback

The FontsManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultFont | Gets value which indicates that the font family is Silverlight standard font.
IsLoadedFont | Gets the value which indicates if font is loaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
QueryFontSource | Requires font loading source from server.
SetFontSource | Sets the font loading source for control.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


FontsManager Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsManager Methods
FontsManager Class See Also Send Feedback

The FontsManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultFont | Gets value which indicates that the font family is Silverlight standard font.
IsLoadedFont | Gets the value which indicates if font is loaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
QueryFontSource | Requires font loading source from server.
SetFontSource | Sets the font loading source for control.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


IsDefaultFont Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsManager..::.IsDefaultFont Method
FontsManager Class See Also Send Feedback
Gets value which indicates that the font family is Silverlight standard font.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static bool IsDefaultFont(
    string fontFamily
)
Visual Basic (Declaration)
Public Shared Function IsDefaultFont ( _
    fontFamily As String _
) As Boolean
Visual C++
public:
static bool IsDefaultFont(
    String^ fontFamily
)

Parameters

fontFamily
Type: System..::.String
The font family name.

Return Value

true if the font family is Silverlight standard font; otherwise, false.

See Also

FontsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


IsLoadedFont Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsManager..::.IsLoadedFont Method
FontsManager Class See Also Send Feedback
Gets the value which indicates if font is loaded.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool IsLoadedFont(
    FontKey fontKey
)
Visual Basic (Declaration)
Public Function IsLoadedFont ( _
    fontKey As FontKey _
) As Boolean
Visual C++
public:
bool IsLoadedFont(
    FontKey fontKey
)

Parameters

fontKey
Type: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts..::.FontKey
The font key.

Return Value

true if font is loaded; otherwise, false.

See Also

FontsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


QueryFontSource Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsManager..::.QueryFontSource Method
FontsManager Class See Also Send Feedback
Requires font loading source from server.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void QueryFontSource(
    FontKey fontKey,
    Action<FontKey, FontSource> callBack
)
Visual Basic (Declaration)
Public Sub QueryFontSource ( _
    fontKey As FontKey, _
    callBack As Action(Of FontKey, FontSource) _
)
Visual C++
public:
void QueryFontSource(
    FontKey fontKey,
    Action<FontKey, FontSource^>^ callBack
)

Parameters

fontKey
Type: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts..::.FontKey
The font key. The instance of FontKey class.
callBack
Type: System..::.Action <(Of <( FontKey, FontSource>)>)
The call-back action. The instance of Action<(Of <(T1, T2>)>) class.

See Also

FontsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


SetFontSource Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsManager..::.SetFontSource Method
FontsManager Class See Also Send Feedback
Sets the font loading source for control.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SetFontSource(
    DependencyObject control
)
Visual Basic (Declaration)
Public Sub SetFontSource ( _
    control As DependencyObject _
)
Visual C++
public:
void SetFontSource(
    DependencyObject^ control
)

Parameters

control
Type: System.Windows..::.DependencyObject
The control. The instance of DependencyObject class.

See Also

FontsManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


FontUtils Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontUtils Class
Members See Also Send Feedback
A static class for working with fonts.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static class FontUtils
Visual Basic (Declaration)
Public NotInheritable Class FontUtils
Visual C++
public ref class FontUtils abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts..::.FontUtils

See Also

FontUtils Members
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


FontUtils Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontUtils Members
FontUtils Class Methods See Also Send Feedback

The FontUtils type exposes the following members.

Methods

Name | Description
SetFontSource | Sets the font source.

See Also

FontUtils Class
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


FontUtils Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontUtils Methods
FontUtils Class See Also Send Feedback

The FontUtils type exposes the following members.

Methods

Name | Description
SetFontSource | Sets the font source.

See Also

FontUtils Class
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


SetFontSource Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontUtils..::.SetFontSource Method
FontUtils Class See Also Send Feedback
Sets the font source.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Fonts
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static void SetFontSource(
    DependencyObject control,
    FontSource fontSource
)
Visual Basic (Declaration)
Public Shared Sub SetFontSource ( _
    control As DependencyObject, _
    fontSource As FontSource _
)
Visual C++
public:
static void SetFontSource(
    DependencyObject^ control,
    FontSource^ fontSource
)

Parameters

control
Type: System.Windows..::.DependencyObject
The control. The instance of DependencyObject class.
fontSource
Type: FontSource
The font source. The instance of FontSource class.

See Also

FontUtils Class
PerpetuumSoft.ReportingServices.Viewer.Client.Fonts Namespace


PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace
Send Feedback

Classes

Class | Description
LocalizationManager | The class which realizes methods for the ReportViewer interface localization.


LocalizationManager Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager Class
Members See Also Send Feedback
The class which realizes methods for the ReportViewer interface localization.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class LocalizationManager : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class LocalizationManager _
    Implements INotifyPropertyChanged
Visual C++
public ref class LocalizationManager : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.Localization..::.LocalizationManager

See Also

LocalizationManager Members
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


LocalizationManager Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager Members
LocalizationManager Class Constructors Methods Properties Events See Also Send Feedback

The LocalizationManager type exposes the following members.

Constructors

Name | Description
LocalizationManager | Initializes a new instance of the LocalizationManager class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CredentialsPassword | Gets the credentials password label text for CredentialParameterControl.
CredentialsUsername | Gets the credentials username label text for CredentialParameterControl.
NoReportToDisplay | Gets the message which states that selected report is not available.
PageLoading | Gets the page loading message.
ProgressInitializing | Gets text which informs about report initializing process.
ProgressLoading | Gets text which informs about report loading process.
ProgressRendering | Gets text which informs about report rendering process.
SearchNotFound | Gets the text which is displayed when search was unsuccessful.
SearchWatermark | Gets the text which is displayed when no search text is available.
ServerError | Gets the server error message.
ServerErrorText | Gets the server error common message text.
TooltipBackward | Gets the tooltip for the control which is responsible for switching to the previous state saved in history.
TooltipContinuedPageMode | Gets the tooltip for the control which is responsible for switching to the continued page viewing mode.
TooltipCredentials | Gets the tooltip for the control which is responsible for data-source credentials panel showing.
TooltipCurrentPage | Gets the tooltip for the control which is responsible for displaying the current page number.
TooltipExportToCSV | Gets tooltip for the control which is responsible for export to CSV.
TooltipExportToExcel | Gets tooltip for the control which is responsible for export to Excel.
TooltipExportToHtml | Gets tooltip for the control which is responsible for export to HTML.
TooltipExportToMHTML | Gets tooltip for the control which is responsible for export to MHTML.
TooltipExportToPDF | Gets tooltip for the control which is responsible for export to PDF.
TooltipExportToRTF | Gets tooltip for the control which is responsible for export to RTF.
TooltipExportToTIFF | Gets tooltip for the control which is responsible for export to TIFF.
TooltipExportToWord | Gets tooltip for the control which is responsible for export to Word.
TooltipExportToXML | Gets tooltip for the control which is responsible for export to XML.
TooltipExportToXPS | Gets tooltip for the control which is responsible for export to XPS.
TooltipFind | Gets the tooltip for the control which is responsible for search starting.
TooltipFindNext | Gets the tooltip for the control which is responsible for the next search result.
TooltipFindPrevious | Gets the tooltip for the control which is responsible for the previous search result.
TooltipFirstPage | Gets tooltip for the control which is responsible for switching to the first page.
TooltipForward | Gets the tooltip for the control which is responsible for switching to the next state saved in history.
TooltipLastPage | Gets the tooltip for the control which is responsible for switching to the last page.
TooltipMultiPageMode | Gets the tooltip for the control which is responsible for the multipage viewing mode.
TooltipMultiValueParameterHelp | Gets the tooltip for MultiValueParameterControl help icon.
TooltipNextPage | Gets the tooltip for the control which is responsible for switching to the next page.
TooltipPageWidth | Gets the tooltip for the control which is responsible for scaling equal to the page width.
TooltipPan | Gets the tooltip for the control which is responsible for report panning mode.
TooltipParameters | Gets the tooltip for the control which is responsible for report parameters panel showing.
TooltipPreviousPage | Gets the tooltip for the control which is responsible for switching to the previous search result.
TooltipPrint | Gets tooltip for the control which is responsible for printing document.
TooltipSearch | Gets the tooltip for the control which is responsible for the search text input.
TooltipSelect | Gets the tooltip for the control which is responsible for setting mode of the report elements selection.
TooltipSinglePageMode | Gets tooltip for the control which is responsible for switching to report single page viewing mode.
TooltipWholePage | Gets the tooltip for the control which is responsible for scaling equal to the whole page.
TooltipZoom100 | Gets the tooltip for the control which is responsible for 100% scaling of original.
TooltipZoomDecrease | Gets the tooltip for the control which is responsible for the scale decreasing.
TooltipZoomDynamic | Gets the tooltip for the control which is responsible for dynamic scaling. The scaling is performed by pressing the left mouse button and moving pointer.
TooltipZoomIn | Gets the tooltip for the control which is responsible for zooming in the report.
TooltipZoomIncrease | Gets the tooltip for the control which is responsible for the scale increasing.
TooltipZoomOut | Gets the tooltip for the control which is responsible for zooming out the report.
TooltipZoomToRegion | Gets the tooltip for the control which is responsible for scaling in the selected region.

Events

Name | Description
Loaded | Occurs when the dictionary is loaded.
PropertyChanged | Occurs when localization strings are changed.

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


LocalizationManager Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager Constructor
LocalizationManager Class See Also Send Feedback
Initializes a new instance of the LocalizationManager class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public LocalizationManager(
    ViewManager viewManager
)
Visual Basic (Declaration)
Public Sub New ( _
    viewManager As ViewManager _
)
Visual C++
public:
LocalizationManager(
    ViewManager^ viewManager
)

Parameters

viewManager
Type: PerpetuumSoft.ReportingServices.Viewer.Client..::.ViewManager
The view manager.

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


LocalizationManager Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager Methods
LocalizationManager Class See Also Send Feedback

The LocalizationManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


LocalizationManager Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager Properties
LocalizationManager Class See Also Send Feedback

The LocalizationManager type exposes the following members.

Properties

Name | Description
CredentialsPassword | Gets the credentials password label text for CredentialParameterControl.
CredentialsUsername | Gets the credentials username label text for CredentialParameterControl.
NoReportToDisplay | Gets the message which states that selected report is not available.
PageLoading | Gets the page loading message.
ProgressInitializing | Gets text which informs about report initializing process.
ProgressLoading | Gets text which informs about report loading process.
ProgressRendering | Gets text which informs about report rendering process.
SearchNotFound | Gets the text which is displayed when search was unsuccessful.
SearchWatermark | Gets the text which is displayed when no search text is available.
ServerError | Gets the server error message.
ServerErrorText | Gets the server error common message text.
TooltipBackward | Gets the tooltip for the control which is responsible for switching to the previous state saved in history.
TooltipContinuedPageMode | Gets the tooltip for the control which is responsible for switching to the continued page viewing mode.
TooltipCredentials | Gets the tooltip for the control which is responsible for data-source credentials panel showing.
TooltipCurrentPage | Gets the tooltip for the control which is responsible for displaying the current page number.
TooltipExportToCSV | Gets tooltip for the control which is responsible for export to CSV.
TooltipExportToExcel | Gets tooltip for the control which is responsible for export to Excel.
TooltipExportToHtml | Gets tooltip for the control which is responsible for export to HTML.
TooltipExportToMHTML | Gets tooltip for the control which is responsible for export to MHTML.
TooltipExportToPDF | Gets tooltip for the control which is responsible for export to PDF.
TooltipExportToRTF | Gets tooltip for the control which is responsible for export to RTF.
TooltipExportToTIFF | Gets tooltip for the control which is responsible for export to TIFF.
TooltipExportToWord | Gets tooltip for the control which is responsible for export to Word.
TooltipExportToXML | Gets tooltip for the control which is responsible for export to XML.
TooltipExportToXPS | Gets tooltip for the control which is responsible for export to XPS.
TooltipFind | Gets the tooltip for the control which is responsible for search starting.
TooltipFindNext | Gets the tooltip for the control which is responsible for the next search result.
TooltipFindPrevious | Gets the tooltip for the control which is responsible for the previous search result.
TooltipFirstPage | Gets tooltip for the control which is responsible for switching to the first page.
TooltipForward | Gets the tooltip for the control which is responsible for switching to the next state saved in history.
TooltipLastPage | Gets the tooltip for the control which is responsible for switching to the last page.
TooltipMultiPageMode | Gets the tooltip for the control which is responsible for the multipage viewing mode.
TooltipMultiValueParameterHelp | Gets the tooltip for MultiValueParameterControl help icon.
TooltipNextPage | Gets the tooltip for the control which is responsible for switching to the next page.
TooltipPageWidth | Gets the tooltip for the control which is responsible for scaling equal to the page width.
TooltipPan | Gets the tooltip for the control which is responsible for report panning mode.
TooltipParameters | Gets the tooltip for the control which is responsible for report parameters panel showing.
TooltipPreviousPage | Gets the tooltip for the control which is responsible for switching to the previous search result.
TooltipPrint | Gets tooltip for the control which is responsible for printing document.
TooltipSearch | Gets the tooltip for the control which is responsible for the search text input.
TooltipSelect | Gets the tooltip for the control which is responsible for setting mode of the report elements selection.
TooltipSinglePageMode | Gets tooltip for the control which is responsible for switching to report single page viewing mode.
TooltipWholePage | Gets the tooltip for the control which is responsible for scaling equal to the whole page.
TooltipZoom100 | Gets the tooltip for the control which is responsible for 100% scaling of original.
TooltipZoomDecrease | Gets the tooltip for the control which is responsible for the scale decreasing.
TooltipZoomDynamic | Gets the tooltip for the control which is responsible for dynamic scaling. The scaling is performed by pressing the left mouse button and moving pointer.
TooltipZoomIn | Gets the tooltip for the control which is responsible for zooming in the report.
TooltipZoomIncrease | Gets the tooltip for the control which is responsible for the scale increasing.
TooltipZoomOut | Gets the tooltip for the control which is responsible for zooming out the report.
TooltipZoomToRegion | Gets the tooltip for the control which is responsible for scaling in the selected region.

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


CredentialsPassword Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.CredentialsPassword Property
LocalizationManager Class See Also Send Feedback
Gets the credentials password label text for CredentialParameterControl.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string CredentialsPassword { get; }
Visual Basic (Declaration)
Public ReadOnly Property CredentialsPassword As String
Visual C++
public:
property String^ CredentialsPassword {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


CredentialsUsername Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.CredentialsUsername Property
LocalizationManager Class See Also Send Feedback
Gets the credentials username label text for CredentialParameterControl.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string CredentialsUsername { get; }
Visual Basic (Declaration)
Public ReadOnly Property CredentialsUsername As String
Visual C++
public:
property String^ CredentialsUsername {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


NoReportToDisplay Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.NoReportToDisplay Property
LocalizationManager Class See Also Send Feedback
Gets the message which states that selected report is not available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string NoReportToDisplay { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoReportToDisplay As String
Visual C++
public:
property String^ NoReportToDisplay {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


PageLoading Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.PageLoading Property
LocalizationManager Class See Also Send Feedback
Gets the page loading message.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string PageLoading { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageLoading As String
Visual C++
public:
property String^ PageLoading {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


ProgressInitializing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.ProgressInitializing Property
LocalizationManager Class See Also Send Feedback
Gets text which informs about report initializing process.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string ProgressInitializing { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressInitializing As String
Visual C++
public:
property String^ ProgressInitializing {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


ProgressLoading Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.ProgressLoading Property
LocalizationManager Class See Also Send Feedback
Gets text which informs about report loading process.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string ProgressLoading { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressLoading As String
Visual C++
public:
property String^ ProgressLoading {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


ProgressRendering Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.ProgressRendering Property
LocalizationManager Class See Also Send Feedback
Gets text which informs about report rendering process.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string ProgressRendering { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressRendering As String
Visual C++
public:
property String^ ProgressRendering {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


SearchNotFound Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.SearchNotFound Property
LocalizationManager Class See Also Send Feedback
Gets the text which is displayed when search was unsuccessful.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string SearchNotFound { get; }
Visual Basic (Declaration)
Public ReadOnly Property SearchNotFound As String
Visual C++
public:
property String^ SearchNotFound {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


SearchWatermark Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.SearchWatermark Property
LocalizationManager Class See Also Send Feedback
Gets the text which is displayed when no search text is available.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string SearchWatermark { get; }
Visual Basic (Declaration)
Public ReadOnly Property SearchWatermark As String
Visual C++
public:
property String^ SearchWatermark {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


ServerError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.ServerError Property
LocalizationManager Class See Also Send Feedback
Gets the server error message.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string ServerError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ServerError As String
Visual C++
public:
property String^ ServerError {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


ServerErrorText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.ServerErrorText Property
LocalizationManager Class See Also Send Feedback
Gets the server error common message text.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string ServerErrorText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ServerErrorText As String
Visual C++
public:
property String^ ServerErrorText {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipBackward Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipBackward Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the previous state saved in history.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipBackward { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipBackward As String
Visual C++
public:
property String^ TooltipBackward {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipContinuedPageMode Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipContinuedPageMode Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the continued page viewing mode.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipContinuedPageMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipContinuedPageMode As String
Visual C++
public:
property String^ TooltipContinuedPageMode {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipCredentials Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipCredentials Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for data-source credentials panel showing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipCredentials { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipCredentials As String
Visual C++
public:
property String^ TooltipCredentials {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipCurrentPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipCurrentPage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for displaying the current page number.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipCurrentPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipCurrentPage As String
Visual C++
public:
property String^ TooltipCurrentPage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipExportToCSV Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipExportToCSV Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for export to CSV.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipExportToCSV { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToCSV As String
Visual C++
public:
property String^ TooltipExportToCSV {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipExportToExcel Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipExportToExcel Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for export to Excel.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipExportToExcel { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToExcel As String
Visual C++
public:
property String^ TooltipExportToExcel {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipExportToHtml Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipExportToHtml Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for export to HTML.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipExportToHtml { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToHtml As String
Visual C++
public:
property String^ TooltipExportToHtml {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipExportToMHTML Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipExportToMHTML Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for export to MHTML.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipExportToMHTML { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToMHTML As String
Visual C++
public:
property String^ TooltipExportToMHTML {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipExportToPDF Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipExportToPDF Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for export to PDF.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipExportToPDF { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToPDF As String
Visual C++
public:
property String^ TooltipExportToPDF {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipExportToRTF Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipExportToRTF Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for export to RTF.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipExportToRTF { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToRTF As String
Visual C++
public:
property String^ TooltipExportToRTF {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipExportToTIFF Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipExportToTIFF Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for export to TIFF.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipExportToTIFF { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToTIFF As String
Visual C++
public:
property String^ TooltipExportToTIFF {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipExportToWord Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipExportToWord Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for export to Word.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipExportToWord { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToWord As String
Visual C++
public:
property String^ TooltipExportToWord {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipExportToXML Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipExportToXML Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for export to XML.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipExportToXML { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToXML As String
Visual C++
public:
property String^ TooltipExportToXML {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipExportToXPS Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipExportToXPS Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for export to XPS.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipExportToXPS { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToXPS As String
Visual C++
public:
property String^ TooltipExportToXPS {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipFind Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipFind Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for search starting.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipFind { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipFind As String
Visual C++
public:
property String^ TooltipFind {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipFindNext Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipFindNext Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for the next search result.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipFindNext { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipFindNext As String
Visual C++
public:
property String^ TooltipFindNext {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipFindPrevious Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipFindPrevious Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for the previous search result.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipFindPrevious { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipFindPrevious As String
Visual C++
public:
property String^ TooltipFindPrevious {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipFirstPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipFirstPage Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for switching to the first page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipFirstPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipFirstPage As String
Visual C++
public:
property String^ TooltipFirstPage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipForward Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipForward Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the next state saved in history.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipForward { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipForward As String
Visual C++
public:
property String^ TooltipForward {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipLastPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipLastPage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the last page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipLastPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipLastPage As String
Visual C++
public:
property String^ TooltipLastPage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipMultiPageMode Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipMultiPageMode Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for the multipage viewing mode.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipMultiPageMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipMultiPageMode As String
Visual C++
public:
property String^ TooltipMultiPageMode {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipMultiValueParameterHelp Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipMultiValueParameterHelp Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for MultiValueParameterControl help icon.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipMultiValueParameterHelp { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipMultiValueParameterHelp As String
Visual C++
public:
property String^ TooltipMultiValueParameterHelp {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipNextPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipNextPage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the next page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipNextPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipNextPage As String
Visual C++
public:
property String^ TooltipNextPage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipPageWidth Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipPageWidth Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for scaling equal to the page width.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipPageWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipPageWidth As String
Visual C++
public:
property String^ TooltipPageWidth {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipPan Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipPan Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for report panning mode.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipPan { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipPan As String
Visual C++
public:
property String^ TooltipPan {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipParameters Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipParameters Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for report parameters panel showing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipParameters As String
Visual C++
public:
property String^ TooltipParameters {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipPreviousPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipPreviousPage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the previous search result.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipPreviousPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipPreviousPage As String
Visual C++
public:
property String^ TooltipPreviousPage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipPrint Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipPrint Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for printing document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipPrint { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipPrint As String
Visual C++
public:
property String^ TooltipPrint {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipSearch Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipSearch Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for the search text input.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipSearch { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipSearch As String
Visual C++
public:
property String^ TooltipSearch {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipSelect Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipSelect Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for setting mode of the report elements selection.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipSelect { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipSelect As String
Visual C++
public:
property String^ TooltipSelect {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipSinglePageMode Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipSinglePageMode Property
LocalizationManager Class See Also Send Feedback
Gets tooltip for the control which is responsible for switching to report single page viewing mode.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipSinglePageMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipSinglePageMode As String
Visual C++
public:
property String^ TooltipSinglePageMode {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipWholePage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipWholePage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for scaling equal to the whole page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipWholePage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipWholePage As String
Visual C++
public:
property String^ TooltipWholePage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipZoom100 Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipZoom100 Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for 100% scaling of original.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipZoom100 { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoom100 As String
Visual C++
public:
property String^ TooltipZoom100 {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipZoomDecrease Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipZoomDecrease Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for the scale decreasing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipZoomDecrease { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomDecrease As String
Visual C++
public:
property String^ TooltipZoomDecrease {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipZoomDynamic Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipZoomDynamic Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for dynamic scaling. The scaling is performed by pressing the left mouse button and moving pointer.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipZoomDynamic { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomDynamic As String
Visual C++
public:
property String^ TooltipZoomDynamic {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipZoomIn Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipZoomIn Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for zooming in the report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipZoomIn { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomIn As String
Visual C++
public:
property String^ TooltipZoomIn {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipZoomIncrease Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipZoomIncrease Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for the scale increasing.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipZoomIncrease { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomIncrease As String
Visual C++
public:
property String^ TooltipZoomIncrease {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipZoomOut Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipZoomOut Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for zooming out the report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipZoomOut { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomOut As String
Visual C++
public:
property String^ TooltipZoomOut {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


TooltipZoomToRegion Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.TooltipZoomToRegion Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for scaling in the selected region.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string TooltipZoomToRegion { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomToRegion As String
Visual C++
public:
property String^ TooltipZoomToRegion {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


LocalizationManager Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager Events
LocalizationManager Class See Also Send Feedback

The LocalizationManager type exposes the following members.

Events

Name | Description
Loaded | Occurs when the dictionary is loaded.
PropertyChanged | Occurs when localization strings are changed.

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


Loaded Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.Loaded Event
LocalizationManager Class See Also Send Feedback
Occurs when the dictionary is loaded.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler Loaded
Visual Basic (Declaration)
Public Event Loaded As EventHandler
Visual C++
public:
 event EventHandler^ Loaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LocalizationManager..::.PropertyChanged Event
LocalizationManager Class See Also Send Feedback
Occurs when localization strings are changed.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Localization
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

LocalizationManager Class
PerpetuumSoft.ReportingServices.Viewer.Client.Localization Namespace


PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace
Send Feedback

Classes

Class | Description
DocumentInfo |
ExceptionDetailBase |
ExecutionNotFoundExceptionDetail |
ExportCompletedEventArgs |
FindCompletedEventArgs |
GetDocumentInfoCompletedEventArgs |
GetFontCompletedEventArgs |
GetHtmlImageCompletedEventArgs |
GetImageStreamCompletedEventArgs |
GetPageInfoCompletedEventArgs |
GetResourceCompletedEventArgs |
ListExportsFormatsCompletedEventArgs |
LoadDrillthroughTargetCompletedEventArgs |
LoadReportCompletedEventArgs |
NoCachedDocumentExceptionDetail |
PageInfo |
PrintCompletedEventArgs |
ProcessingExceptionDetail |
RenderCompletedEventArgs |
ReportDataSource |
ReportDataSourceCredential |
ReportExecutionInfo |
ReportParameter |
ReportParameterValue |
ReportServiceClient |
ReportServiceResourcesClient |
SearchResult | Represents text search results.
SetDataSourcesCredentialsCompletedEventArgs |
SetParametersCompletedEventArgs |
SortCompletedEventArgs |
ToggleItemCompletedEventArgs |
ValidValue |

Structures

Structure | Description
FindOptions |
SizeF |

Interfaces

Interface | Description
IReportService |
IReportServiceChannel |
IReportServiceResources |
IReportServiceResourcesChannel |

Enumerations

Enumeration | Description
ExportsEnum |
ParameterStateEnum |
ParameterTypeEnum |
SearchDirectionEnum |
SearchTypeEnum |
SortDirectionEnum |


DocumentInfo Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class DocumentInfo : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class DocumentInfo _
    Implements INotifyPropertyChanged
Visual C++
public ref class DocumentInfo : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.DocumentInfo

See Also

DocumentInfo Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


DocumentInfo Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Members
DocumentInfo Class Constructors Methods Properties Events See Also Send Feedback

The DocumentInfo type exposes the following members.

Constructors

Name | Description
DocumentInfo | Initializes a new instance of the DocumentInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PagesSizes |
Title |

Events

Name | Description
PropertyChanged |

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


DocumentInfo Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Constructor
DocumentInfo Class See Also Send Feedback
Initializes a new instance of the DocumentInfo class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DocumentInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentInfo()

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


DocumentInfo Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Methods
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo..::.RaisePropertyChanged Method
DocumentInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


DocumentInfo Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Properties
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Properties

Name | Description
PagesSizes |
Title |

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PagesSizes Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo..::.PagesSizes Property
DocumentInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ObservableCollection<SizeF> PagesSizes { get; set; }
Visual Basic (Declaration)
Public Property PagesSizes As ObservableCollection(Of SizeF)
Visual C++
public:
property ObservableCollection<SizeF>^ PagesSizes {
    ObservableCollection<SizeF>^ get ();
    void set (ObservableCollection<SizeF>^ value);
}

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Title Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo..::.Title Property
DocumentInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


DocumentInfo Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Events
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo..::.PropertyChanged Event
DocumentInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExceptionDetailBase Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ExceptionDetailBase : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ExceptionDetailBase _
    Implements INotifyPropertyChanged
Visual C++
public ref class ExceptionDetailBase : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExecutionNotFoundExceptionDetail
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.NoCachedDocumentExceptionDetail
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ProcessingExceptionDetail

See Also

ExceptionDetailBase Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExceptionDetailBase Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Members
ExceptionDetailBase Class Constructors Methods Properties Events See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Constructors

Name | Description
ExceptionDetailBase | Initializes a new instance of the ExceptionDetailBase class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InnerException |
Message |

Events

Name | Description
PropertyChanged |

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExceptionDetailBase Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Constructor
ExceptionDetailBase Class See Also Send Feedback
Initializes a new instance of the ExceptionDetailBase class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExceptionDetailBase()

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExceptionDetailBase Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Methods
ExceptionDetailBase Class See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase..::.RaisePropertyChanged Method
ExceptionDetailBase Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExceptionDetailBase Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Properties
ExceptionDetailBase Class See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Properties

Name | Description
InnerException |
Message |

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


InnerException Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase..::.InnerException Property
ExceptionDetailBase Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase InnerException { get; set; }
Visual Basic (Declaration)
Public Property InnerException As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ InnerException {
    ExceptionDetailBase^ get ();
    void set (ExceptionDetailBase^ value);
}

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Message Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase..::.Message Property
ExceptionDetailBase Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Message { get; set; }
Visual Basic (Declaration)
Public Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExceptionDetailBase Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Events
ExceptionDetailBase Class See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase..::.PropertyChanged Event
ExceptionDetailBase Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExecutionNotFoundExceptionDetail Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ExecutionNotFoundExceptionDetail : ExceptionDetailBase
Visual Basic (Declaration)
Public Class ExecutionNotFoundExceptionDetail _
    Inherits ExceptionDetailBase
Visual C++
public ref class ExecutionNotFoundExceptionDetail : public ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExecutionNotFoundExceptionDetail

See Also

ExecutionNotFoundExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExecutionNotFoundExceptionDetail Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Members
ExecutionNotFoundExceptionDetail Class Constructors Methods Properties Events See Also Send Feedback

The ExecutionNotFoundExceptionDetail type exposes the following members.

Constructors

Name | Description
ExecutionNotFoundExceptionDetail | Initializes a new instance of the ExecutionNotFoundExceptionDetail class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | (Inherited from ExceptionDetailBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InnerException | (Inherited from ExceptionDetailBase.)
Message | (Inherited from ExceptionDetailBase.)

Events

Name | Description
PropertyChanged | (Inherited from ExceptionDetailBase.)

See Also

ExecutionNotFoundExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExecutionNotFoundExceptionDetail Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Constructor
ExecutionNotFoundExceptionDetail Class See Also Send Feedback
Initializes a new instance of the ExecutionNotFoundExceptionDetail class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExecutionNotFoundExceptionDetail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExecutionNotFoundExceptionDetail()

See Also

ExecutionNotFoundExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExecutionNotFoundExceptionDetail Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Methods
ExecutionNotFoundExceptionDetail Class See Also Send Feedback

The ExecutionNotFoundExceptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | (Inherited from ExceptionDetailBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutionNotFoundExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExecutionNotFoundExceptionDetail Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Properties
ExecutionNotFoundExceptionDetail Class See Also Send Feedback

The ExecutionNotFoundExceptionDetail type exposes the following members.

Properties

Name | Description
InnerException | (Inherited from ExceptionDetailBase.)
Message | (Inherited from ExceptionDetailBase.)

See Also

ExecutionNotFoundExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExecutionNotFoundExceptionDetail Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Events
ExecutionNotFoundExceptionDetail Class See Also Send Feedback

The ExecutionNotFoundExceptionDetail type exposes the following members.

Events

Name | Description
PropertyChanged | (Inherited from ExceptionDetailBase.)

See Also

ExecutionNotFoundExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExportCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ExportCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class ExportCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class ExportCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExportCompletedEventArgs

See Also

ExportCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExportCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportCompletedEventArgs Members
ExportCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ExportCompletedEventArgs type exposes the following members.

Constructors

Name | Description
ExportCompletedEventArgs | Initializes a new instance of the ExportCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ExportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExportCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportCompletedEventArgs Constructor
ExportCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the ExportCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExportCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
ExportCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

ExportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExportCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportCompletedEventArgs Methods
ExportCompletedEventArgs Class See Also Send Feedback

The ExportCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExportCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportCompletedEventArgs Properties
ExportCompletedEventArgs Class See Also Send Feedback

The ExportCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ExportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportCompletedEventArgs..::.Result Property
ExportCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public byte[] Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Byte()
Visual C++
public:
property array<unsigned char>^ Result {
    array<unsigned char>^ get ();
}

See Also

ExportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExportsEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportsEnum Enumeration
See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public enum ExportsEnum
Visual Basic (Declaration)
Public Enumeration ExportsEnum
Visual C++
public enum class ExportsEnum

Members

Member name | Description
Pdf |
Rtf |
Html |
Xps |
Excel |
Word |
Image |
Csv |
Mhtml |
Xml |
Null |

See Also

PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class FindCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class FindCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class FindCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.FindCompletedEventArgs

See Also

FindCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindCompletedEventArgs Members
FindCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The FindCompletedEventArgs type exposes the following members.

Constructors

Name | Description
FindCompletedEventArgs | Initializes a new instance of the FindCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

FindCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindCompletedEventArgs Constructor
FindCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the FindCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public FindCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
FindCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

FindCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindCompletedEventArgs Methods
FindCompletedEventArgs Class See Also Send Feedback

The FindCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindCompletedEventArgs Properties
FindCompletedEventArgs Class See Also Send Feedback

The FindCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

FindCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindCompletedEventArgs..::.ReportError Property
FindCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

FindCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindCompletedEventArgs..::.Result Property
FindCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SearchResult Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As SearchResult
Visual C++
public:
property SearchResult^ Result {
    SearchResult^ get ();
}

See Also

FindCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindOptions Structure

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions Structure
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public struct FindOptions : INotifyPropertyChanged
Visual Basic (Declaration)
Public Structure FindOptions _
    Implements INotifyPropertyChanged
Visual C++
public value class FindOptions : INotifyPropertyChanged

See Also

FindOptions Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindOptions Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions Members
FindOptions Structure Methods Properties Events See Also Send Feedback

The FindOptions type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Direction |
FindText |
FromBegining |
StartLocation |

Events

Name | Description
PropertyChanged |

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindOptions Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions Methods
FindOptions Structure See Also Send Feedback

The FindOptions type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindOptions Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions Properties
FindOptions Structure See Also Send Feedback

The FindOptions type exposes the following members.

Properties

Name | Description
Direction |
FindText |
FromBegining |
StartLocation |

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Direction Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions..::.Direction Property
FindOptions Structure See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SearchDirectionEnum Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As SearchDirectionEnum
Visual C++
public:
property SearchDirectionEnum Direction {
    SearchDirectionEnum get ();
    void set (SearchDirectionEnum value);
}

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions..::.FindText Property
FindOptions Structure See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string FindText { get; set; }
Visual Basic (Declaration)
Public Property FindText As String
Visual C++
public:
property String^ FindText {
    String^ get ();
    void set (String^ value);
}

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FromBegining Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions..::.FromBegining Property
FindOptions Structure See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool FromBegining { get; set; }
Visual Basic (Declaration)
Public Property FromBegining As Boolean
Visual C++
public:
property bool FromBegining {
    bool get ();
    void set (bool value);
}

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


StartLocation Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions..::.StartLocation Property
FindOptions Structure See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SearchResult StartLocation { get; set; }
Visual Basic (Declaration)
Public Property StartLocation As SearchResult
Visual C++
public:
property SearchResult^ StartLocation {
    SearchResult^ get ();
    void set (SearchResult^ value);
}

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindOptions Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions Events
FindOptions Structure See Also Send Feedback

The FindOptions type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions..::.PropertyChanged Event
FindOptions Structure See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetDocumentInfoCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetDocumentInfoCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class GetDocumentInfoCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetDocumentInfoCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetDocumentInfoCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.GetDocumentInfoCompletedEventArgs

See Also

GetDocumentInfoCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetDocumentInfoCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetDocumentInfoCompletedEventArgs Members
GetDocumentInfoCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetDocumentInfoCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetDocumentInfoCompletedEventArgs | Initializes a new instance of the GetDocumentInfoCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetDocumentInfoCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetDocumentInfoCompletedEventArgs Constructor
GetDocumentInfoCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetDocumentInfoCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public GetDocumentInfoCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetDocumentInfoCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetDocumentInfoCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetDocumentInfoCompletedEventArgs Methods
GetDocumentInfoCompletedEventArgs Class See Also Send Feedback

The GetDocumentInfoCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetDocumentInfoCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetDocumentInfoCompletedEventArgs Properties
GetDocumentInfoCompletedEventArgs Class See Also Send Feedback

The GetDocumentInfoCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetDocumentInfoCompletedEventArgs..::.ReportError Property
GetDocumentInfoCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetDocumentInfoCompletedEventArgs..::.Result Property
GetDocumentInfoCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DocumentInfo Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As DocumentInfo
Visual C++
public:
property DocumentInfo^ Result {
    DocumentInfo^ get ();
}

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetFontCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetFontCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class GetFontCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetFontCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetFontCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.GetFontCompletedEventArgs

See Also

GetFontCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetFontCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetFontCompletedEventArgs Members
GetFontCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetFontCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetFontCompletedEventArgs | Initializes a new instance of the GetFontCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetFontCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetFontCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetFontCompletedEventArgs Constructor
GetFontCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetFontCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public GetFontCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetFontCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetFontCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetFontCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetFontCompletedEventArgs Methods
GetFontCompletedEventArgs Class See Also Send Feedback

The GetFontCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetFontCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetFontCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetFontCompletedEventArgs Properties
GetFontCompletedEventArgs Class See Also Send Feedback

The GetFontCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetFontCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetFontCompletedEventArgs..::.Result Property
GetFontCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public byte[] Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Byte()
Visual C++
public:
property array<unsigned char>^ Result {
    array<unsigned char>^ get ();
}

See Also

GetFontCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetHtmlImageCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetHtmlImageCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class GetHtmlImageCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetHtmlImageCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetHtmlImageCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.GetHtmlImageCompletedEventArgs

See Also

GetHtmlImageCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetHtmlImageCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetHtmlImageCompletedEventArgs Members
GetHtmlImageCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetHtmlImageCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetHtmlImageCompletedEventArgs | Initializes a new instance of the GetHtmlImageCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetHtmlImageCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetHtmlImageCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetHtmlImageCompletedEventArgs Constructor
GetHtmlImageCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetHtmlImageCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public GetHtmlImageCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetHtmlImageCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetHtmlImageCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetHtmlImageCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetHtmlImageCompletedEventArgs Methods
GetHtmlImageCompletedEventArgs Class See Also Send Feedback

The GetHtmlImageCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetHtmlImageCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetHtmlImageCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetHtmlImageCompletedEventArgs Properties
GetHtmlImageCompletedEventArgs Class See Also Send Feedback

The GetHtmlImageCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetHtmlImageCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetHtmlImageCompletedEventArgs..::.Result Property
GetHtmlImageCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public byte[] Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Byte()
Visual C++
public:
property array<unsigned char>^ Result {
    array<unsigned char>^ get ();
}

See Also

GetHtmlImageCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetImageStreamCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetImageStreamCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class GetImageStreamCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetImageStreamCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetImageStreamCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.GetImageStreamCompletedEventArgs

See Also

GetImageStreamCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetImageStreamCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetImageStreamCompletedEventArgs Members
GetImageStreamCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetImageStreamCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetImageStreamCompletedEventArgs | Initializes a new instance of the GetImageStreamCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetImageStreamCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetImageStreamCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetImageStreamCompletedEventArgs Constructor
GetImageStreamCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetImageStreamCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public GetImageStreamCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetImageStreamCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetImageStreamCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetImageStreamCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetImageStreamCompletedEventArgs Methods
GetImageStreamCompletedEventArgs Class See Also Send Feedback

The GetImageStreamCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetImageStreamCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetImageStreamCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetImageStreamCompletedEventArgs Properties
GetImageStreamCompletedEventArgs Class See Also Send Feedback

The GetImageStreamCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetImageStreamCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetImageStreamCompletedEventArgs..::.Result Property
GetImageStreamCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public byte[] Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Byte()
Visual C++
public:
property array<unsigned char>^ Result {
    array<unsigned char>^ get ();
}

See Also

GetImageStreamCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetPageInfoCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetPageInfoCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class GetPageInfoCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetPageInfoCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetPageInfoCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.GetPageInfoCompletedEventArgs

See Also

GetPageInfoCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetPageInfoCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetPageInfoCompletedEventArgs Members
GetPageInfoCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetPageInfoCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetPageInfoCompletedEventArgs | Initializes a new instance of the GetPageInfoCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetPageInfoCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetPageInfoCompletedEventArgs Constructor
GetPageInfoCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetPageInfoCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public GetPageInfoCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetPageInfoCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetPageInfoCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetPageInfoCompletedEventArgs Methods
GetPageInfoCompletedEventArgs Class See Also Send Feedback

The GetPageInfoCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetPageInfoCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetPageInfoCompletedEventArgs Properties
GetPageInfoCompletedEventArgs Class See Also Send Feedback

The GetPageInfoCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetPageInfoCompletedEventArgs..::.ReportError Property
GetPageInfoCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetPageInfoCompletedEventArgs..::.Result Property
GetPageInfoCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public PageInfo Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As PageInfo
Visual C++
public:
property PageInfo^ Result {
    PageInfo^ get ();
}

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetResourceCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetResourceCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class GetResourceCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetResourceCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetResourceCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.GetResourceCompletedEventArgs

See Also

GetResourceCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetResourceCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetResourceCompletedEventArgs Members
GetResourceCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetResourceCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetResourceCompletedEventArgs | Initializes a new instance of the GetResourceCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetResourceCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetResourceCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetResourceCompletedEventArgs Constructor
GetResourceCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetResourceCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public GetResourceCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetResourceCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetResourceCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetResourceCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetResourceCompletedEventArgs Methods
GetResourceCompletedEventArgs Class See Also Send Feedback

The GetResourceCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetResourceCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetResourceCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetResourceCompletedEventArgs Properties
GetResourceCompletedEventArgs Class See Also Send Feedback

The GetResourceCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetResourceCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
GetResourceCompletedEventArgs..::.Result Property
GetResourceCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public byte[] Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Byte()
Visual C++
public:
property array<unsigned char>^ Result {
    array<unsigned char>^ get ();
}

See Also

GetResourceCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportService Interface

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService Interface
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public interface IReportService
Visual Basic (Declaration)
Public Interface IReportService
Visual C++
public interface class IReportService

See Also

IReportService Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportService Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService Members
IReportService Interface Methods See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
BeginFind |
BeginGetDocumentInfo |
BeginGetPageInfo |
BeginInit |
BeginListExportsFormats |
BeginLoadDrillthroughTarget |
BeginLoadReport |
BeginRender |
BeginSetDataSourcesCredentials |
BeginSetParameters |
BeginSort |
BeginToggleItem |
EndFind |
EndGetDocumentInfo |
EndGetPageInfo |
EndInit |
EndListExportsFormats |
EndLoadDrillthroughTarget |
EndLoadReport |
EndRender |
EndSetDataSourcesCredentials |
EndSetParameters |
EndSort |
EndToggleItem |

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportService Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService Methods
IReportService Interface See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
BeginFind |
BeginGetDocumentInfo |
BeginGetPageInfo |
BeginInit |
BeginListExportsFormats |
BeginLoadDrillthroughTarget |
BeginLoadReport |
BeginRender |
BeginSetDataSourcesCredentials |
BeginSetParameters |
BeginSort |
BeginToggleItem |
EndFind |
EndGetDocumentInfo |
EndGetPageInfo |
EndInit |
EndListExportsFormats |
EndLoadDrillthroughTarget |
EndLoadReport |
EndRender |
EndSetDataSourcesCredentials |
EndSetParameters |
EndSort |
EndToggleItem |

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginFind Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginFind Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginFind(
    string id,
    FindOptions findOptions,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginFind ( _
    id As String, _
    findOptions As FindOptions, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginFind(
    String^ id,
    FindOptions findOptions,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
findOptions
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.FindOptions
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginGetDocumentInfo Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginGetDocumentInfo Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginGetDocumentInfo(
    string id,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetDocumentInfo ( _
    id As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetDocumentInfo(
    String^ id,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginGetPageInfo Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginGetPageInfo Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginGetPageInfo(
    string id,
    int pageNumber,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetPageInfo ( _
    id As String, _
    pageNumber As Integer, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetPageInfo(
    String^ id,
    int pageNumber,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
pageNumber
Type: System..::.Int32
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginInit Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginInit Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginInit(
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginInit ( _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginInit(
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginListExportsFormats Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginListExportsFormats Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginListExportsFormats(
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginListExportsFormats ( _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginListExportsFormats(
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginLoadDrillthroughTarget Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginLoadDrillthroughTarget Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginLoadDrillthroughTarget(
    string id,
    string DrillthroughID,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginLoadDrillthroughTarget ( _
    id As String, _
    DrillthroughID As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLoadDrillthroughTarget(
    String^ id,
    String^ DrillthroughID,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
DrillthroughID
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginLoadReport Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginLoadReport Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginLoadReport(
    string report,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginLoadReport ( _
    report As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLoadReport(
    String^ report,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

report
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginRender Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginRender Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginRender(
    string id,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginRender ( _
    id As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginRender(
    String^ id,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginSetDataSourcesCredentials Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginSetDataSourcesCredentials Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginSetDataSourcesCredentials(
    string id,
    ObservableCollection<ReportDataSourceCredential> credentials,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginSetDataSourcesCredentials ( _
    id As String, _
    credentials As ObservableCollection(Of ReportDataSourceCredential), _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDataSourcesCredentials(
    String^ id,
    ObservableCollection<ReportDataSourceCredential^>^ credentials,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
credentials
Type: System.Collections.ObjectModel..::.ObservableCollection <(Of <( ReportDataSourceCredential >)>)
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginSetParameters Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginSetParameters Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginSetParameters(
    string id,
    ObservableCollection<ReportParameterValue> paramatersValues,
    string parametersLanguage,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginSetParameters ( _
    id As String, _
    paramatersValues As ObservableCollection(Of ReportParameterValue), _
    parametersLanguage As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetParameters(
    String^ id,
    ObservableCollection<ReportParameterValue^>^ paramatersValues,
    String^ parametersLanguage,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
paramatersValues
Type: System.Collections.ObjectModel..::.ObservableCollection <(Of <( ReportParameterValue >)>)
parametersLanguage
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginSort Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginSort Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginSort(
    string id,
    string elementId,
    SortDirectionEnum sortDirection,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginSort ( _
    id As String, _
    elementId As String, _
    sortDirection As SortDirectionEnum, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSort(
    String^ id,
    String^ elementId,
    SortDirectionEnum sortDirection,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
elementId
Type: System..::.String
sortDirection
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SortDirectionEnum
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginToggleItem Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.BeginToggleItem Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginToggleItem(
    string id,
    string elementId,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginToggleItem ( _
    id As String, _
    elementId As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginToggleItem(
    String^ id,
    String^ elementId,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
elementId
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndFind Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndFind Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
SearchResult EndFind(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndFind ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As SearchResult
Visual C++
SearchResult^ EndFind(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndGetDocumentInfo Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndGetDocumentInfo Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
DocumentInfo EndGetDocumentInfo(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetDocumentInfo ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As DocumentInfo
Visual C++
DocumentInfo^ EndGetDocumentInfo(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndGetPageInfo Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndGetPageInfo Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
PageInfo EndGetPageInfo(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetPageInfo ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As PageInfo
Visual C++
PageInfo^ EndGetPageInfo(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndInit Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndInit Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
void EndInit(
    IAsyncResult result
)
Visual Basic (Declaration)
Sub EndInit ( _
    result As IAsyncResult _
)
Visual C++
void EndInit(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndListExportsFormats Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndListExportsFormats Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
ObservableCollection<ExportsEnum> EndListExportsFormats(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndListExportsFormats ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As ObservableCollection(Of ExportsEnum)
Visual C++
ObservableCollection<ExportsEnum>^ EndListExportsFormats(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndLoadDrillthroughTarget Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndLoadDrillthroughTarget Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
ReportExecutionInfo EndLoadDrillthroughTarget(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndLoadDrillthroughTarget ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As ReportExecutionInfo
Visual C++
ReportExecutionInfo^ EndLoadDrillthroughTarget(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndLoadReport Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndLoadReport Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
ReportExecutionInfo EndLoadReport(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndLoadReport ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As ReportExecutionInfo
Visual C++
ReportExecutionInfo^ EndLoadReport(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndRender Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndRender Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
string EndRender(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndRender ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As String
Visual C++
String^ EndRender(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndSetDataSourcesCredentials Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndSetDataSourcesCredentials Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
ReportExecutionInfo EndSetDataSourcesCredentials(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndSetDataSourcesCredentials ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As ReportExecutionInfo
Visual C++
ReportExecutionInfo^ EndSetDataSourcesCredentials(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndSetParameters Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndSetParameters Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
ReportExecutionInfo EndSetParameters(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndSetParameters ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As ReportExecutionInfo
Visual C++
ReportExecutionInfo^ EndSetParameters(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndSort Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndSort Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
int EndSort(
    out ExceptionDetailBase reportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndSort ( _
    <OutAttribute> ByRef reportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As Integer
Visual C++
int EndSort(
    [OutAttribute] ExceptionDetailBase^% reportError,
    IAsyncResult^ result
)

Parameters

reportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndToggleItem Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.EndToggleItem Method
IReportService Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
bool EndToggleItem(
    out ExceptionDetailBase reportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndToggleItem ( _
    <OutAttribute> ByRef reportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As Boolean
Visual C++
bool EndToggleItem(
    [OutAttribute] ExceptionDetailBase^% reportError,
    IAsyncResult^ result
)

Parameters

reportError
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceChannel Interface

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceChannel Interface
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public interface IReportServiceChannel : IReportService,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel>,
    IDisposable
Visual Basic (Declaration)
Public Interface IReportServiceChannel _
    Implements IReportService, IClientChannel, IContextChannel, IChannel,  _
    ICommunicationObject, IExtensibleObject(Of IContextChannel), IDisposable
Visual C++
public interface class IReportServiceChannel : IReportService,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel^>,
    IDisposable

See Also

IReportServiceChannel Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceChannel Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceChannel Members
IReportServiceChannel Interface Methods Properties Events See Also Send Feedback

The IReportServiceChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginFind | (Inherited from IReportService.)
BeginGetDocumentInfo | (Inherited from IReportService.)
BeginGetPageInfo | (Inherited from IReportService.)
BeginInit | (Inherited from IReportService.)
BeginListExportsFormats | (Inherited from IReportService.)
BeginLoadDrillthroughTarget | (Inherited from IReportService.)
BeginLoadReport | (Inherited from IReportService.)
BeginOpen | Overloaded.
BeginRender | (Inherited from IReportService.)
BeginSetDataSourcesCredentials | (Inherited from IReportService.)
BeginSetParameters | (Inherited from IReportService.)
BeginSort | (Inherited from IReportService.)
BeginToggleItem | (Inherited from IReportService.)
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndFind | (Inherited from IReportService.)
EndGetDocumentInfo | (Inherited from IReportService.)
EndGetPageInfo | (Inherited from IReportService.)
EndInit | (Inherited from IReportService.)
EndListExportsFormats | (Inherited from IReportService.)
EndLoadDrillthroughTarget | (Inherited from IReportService.)
EndLoadReport | (Inherited from IReportService.)
EndOpen | (Inherited from ICommunicationObject.)
EndRender | (Inherited from IReportService.)
EndSetDataSourcesCredentials | (Inherited from IReportService.)
EndSetParameters | (Inherited from IReportService.)
EndSort | (Inherited from IReportService.)
EndToggleItem | (Inherited from IReportService.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

IReportServiceChannel Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceChannel Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceChannel Methods
IReportServiceChannel Interface See Also Send Feedback

The IReportServiceChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginFind | (Inherited from IReportService.)
BeginGetDocumentInfo | (Inherited from IReportService.)
BeginGetPageInfo | (Inherited from IReportService.)
BeginInit | (Inherited from IReportService.)
BeginListExportsFormats | (Inherited from IReportService.)
BeginLoadDrillthroughTarget | (Inherited from IReportService.)
BeginLoadReport | (Inherited from IReportService.)
BeginOpen | Overloaded.
BeginRender | (Inherited from IReportService.)
BeginSetDataSourcesCredentials | (Inherited from IReportService.)
BeginSetParameters | (Inherited from IReportService.)
BeginSort | (Inherited from IReportService.)
BeginToggleItem | (Inherited from IReportService.)
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndFind | (Inherited from IReportService.)
EndGetDocumentInfo | (Inherited from IReportService.)
EndGetPageInfo | (Inherited from IReportService.)
EndInit | (Inherited from IReportService.)
EndListExportsFormats | (Inherited from IReportService.)
EndLoadDrillthroughTarget | (Inherited from IReportService.)
EndLoadReport | (Inherited from IReportService.)
EndOpen | (Inherited from ICommunicationObject.)
EndRender | (Inherited from IReportService.)
EndSetDataSourcesCredentials | (Inherited from IReportService.)
EndSetParameters | (Inherited from IReportService.)
EndSort | (Inherited from IReportService.)
EndToggleItem | (Inherited from IReportService.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.

See Also

IReportServiceChannel Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginClose Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceChannel..::.BeginClose Method
IReportServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginClose(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginClose(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

IReportServiceChannel Interface
IReportServiceChannel Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginOpen Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceChannel..::.BeginOpen Method
IReportServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginOpen(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginOpen(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

IReportServiceChannel Interface
IReportServiceChannel Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Close Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceChannel..::.Close Method
IReportServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
Close()()() | (Inherited from ICommunicationObject.)
Close(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

IReportServiceChannel Interface
IReportServiceChannel Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Open Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceChannel..::.Open Method
IReportServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
Open()()() | (Inherited from ICommunicationObject.)
Open(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

IReportServiceChannel Interface
IReportServiceChannel Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceChannel Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceChannel Properties
IReportServiceChannel Interface See Also Send Feedback

The IReportServiceChannel type exposes the following members.

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

See Also

IReportServiceChannel Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceChannel Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceChannel Events
IReportServiceChannel Interface See Also Send Feedback

The IReportServiceChannel type exposes the following members.

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

IReportServiceChannel Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceResources Interface

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources Interface
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public interface IReportServiceResources
Visual Basic (Declaration)
Public Interface IReportServiceResources
Visual C++
public interface class IReportServiceResources

See Also

IReportServiceResources Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceResources Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources Members
IReportServiceResources Interface Methods See Also Send Feedback

The IReportServiceResources type exposes the following members.

Methods

Name | Description
BeginExport |
BeginGetFont |
BeginGetHtmlImage |
BeginGetImageStream |
BeginGetResource |
BeginPrint |
EndExport |
EndGetFont |
EndGetHtmlImage |
EndGetImageStream |
EndGetResource |
EndPrint |

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceResources Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources Methods
IReportServiceResources Interface See Also Send Feedback

The IReportServiceResources type exposes the following members.

Methods

Name | Description
BeginExport |
BeginGetFont |
BeginGetHtmlImage |
BeginGetImageStream |
BeginGetResource |
BeginPrint |
EndExport |
EndGetFont |
EndGetHtmlImage |
EndGetImageStream |
EndGetResource |
EndPrint |

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginExport Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.BeginExport Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginExport(
    string id,
    string documentName,
    string format,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginExport ( _
    id As String, _
    documentName As String, _
    format As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginExport(
    String^ id,
    String^ documentName,
    String^ format,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
documentName
Type: System..::.String
format
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginGetFont Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.BeginGetFont Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginGetFont(
    string resourceKey,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetFont ( _
    resourceKey As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetFont(
    String^ resourceKey,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

resourceKey
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginGetHtmlImage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.BeginGetHtmlImage Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginGetHtmlImage(
    string executionId,
    string imageId,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetHtmlImage ( _
    executionId As String, _
    imageId As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetHtmlImage(
    String^ executionId,
    String^ imageId,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

executionId
Type: System..::.String
imageId
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginGetImageStream Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.BeginGetImageStream Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginGetImageStream(
    string id,
    string resourceId,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetImageStream ( _
    id As String, _
    resourceId As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetImageStream(
    String^ id,
    String^ resourceId,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
resourceId
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginGetResource Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.BeginGetResource Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginGetResource(
    string culture,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetResource ( _
    culture As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetResource(
    String^ culture,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

culture
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginPrint Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.BeginPrint Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
IAsyncResult BeginPrint(
    string id,
    string documentName,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginPrint ( _
    id As String, _
    documentName As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginPrint(
    String^ id,
    String^ documentName,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
documentName
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndExport Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.EndExport Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
byte[] EndExport(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndExport ( _
    result As IAsyncResult _
) As Byte()
Visual C++
array<unsigned char>^ EndExport(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndGetFont Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.EndGetFont Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
byte[] EndGetFont(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetFont ( _
    result As IAsyncResult _
) As Byte()
Visual C++
array<unsigned char>^ EndGetFont(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndGetHtmlImage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.EndGetHtmlImage Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
byte[] EndGetHtmlImage(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetHtmlImage ( _
    result As IAsyncResult _
) As Byte()
Visual C++
array<unsigned char>^ EndGetHtmlImage(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndGetImageStream Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.EndGetImageStream Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
byte[] EndGetImageStream(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetImageStream ( _
    result As IAsyncResult _
) As Byte()
Visual C++
array<unsigned char>^ EndGetImageStream(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndGetResource Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.EndGetResource Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
byte[] EndGetResource(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetResource ( _
    result As IAsyncResult _
) As Byte()
Visual C++
array<unsigned char>^ EndGetResource(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndPrint Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.EndPrint Method
IReportServiceResources Interface See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
byte[] EndPrint(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndPrint ( _
    result As IAsyncResult _
) As Byte()
Visual C++
array<unsigned char>^ EndPrint(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceResourcesChannel Interface

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResourcesChannel Interface
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public interface IReportServiceResourcesChannel : IReportServiceResources,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel>,
    IDisposable
Visual Basic (Declaration)
Public Interface IReportServiceResourcesChannel _
    Implements IReportServiceResources, IClientChannel, IContextChannel, IChannel,  _
    ICommunicationObject, IExtensibleObject(Of IContextChannel), IDisposable
Visual C++
public interface class IReportServiceResourcesChannel : IReportServiceResources,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel^>,
    IDisposable

See Also

IReportServiceResourcesChannel Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceResourcesChannel Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResourcesChannel Members
IReportServiceResourcesChannel Interface Methods Properties Events See Also Send Feedback

The IReportServiceResourcesChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginExport | (Inherited from IReportServiceResources.)
BeginGetFont | (Inherited from IReportServiceResources.)
BeginGetHtmlImage | (Inherited from IReportServiceResources.)
BeginGetImageStream | (Inherited from IReportServiceResources.)
BeginGetResource | (Inherited from IReportServiceResources.)
BeginOpen | Overloaded.
BeginPrint | (Inherited from IReportServiceResources.)
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndExport | (Inherited from IReportServiceResources.)
EndGetFont | (Inherited from IReportServiceResources.)
EndGetHtmlImage | (Inherited from IReportServiceResources.)
EndGetImageStream | (Inherited from IReportServiceResources.)
EndGetResource | (Inherited from IReportServiceResources.)
EndOpen | (Inherited from ICommunicationObject.)
EndPrint | (Inherited from IReportServiceResources.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

IReportServiceResourcesChannel Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceResourcesChannel Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResourcesChannel Methods
IReportServiceResourcesChannel Interface See Also Send Feedback

The IReportServiceResourcesChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginExport | (Inherited from IReportServiceResources.)
BeginGetFont | (Inherited from IReportServiceResources.)
BeginGetHtmlImage | (Inherited from IReportServiceResources.)
BeginGetImageStream | (Inherited from IReportServiceResources.)
BeginGetResource | (Inherited from IReportServiceResources.)
BeginOpen | Overloaded.
BeginPrint | (Inherited from IReportServiceResources.)
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndExport | (Inherited from IReportServiceResources.)
EndGetFont | (Inherited from IReportServiceResources.)
EndGetHtmlImage | (Inherited from IReportServiceResources.)
EndGetImageStream | (Inherited from IReportServiceResources.)
EndGetResource | (Inherited from IReportServiceResources.)
EndOpen | (Inherited from ICommunicationObject.)
EndPrint | (Inherited from IReportServiceResources.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.

See Also

IReportServiceResourcesChannel Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginClose Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResourcesChannel..::.BeginClose Method
IReportServiceResourcesChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginClose(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginClose(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

IReportServiceResourcesChannel Interface
IReportServiceResourcesChannel Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


BeginOpen Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResourcesChannel..::.BeginOpen Method
IReportServiceResourcesChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginOpen(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginOpen(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

IReportServiceResourcesChannel Interface
IReportServiceResourcesChannel Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Close Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResourcesChannel..::.Close Method
IReportServiceResourcesChannel Interface See Also Send Feedback

Overload List

Name | Description
Close()()() | (Inherited from ICommunicationObject.)
Close(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

IReportServiceResourcesChannel Interface
IReportServiceResourcesChannel Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Open Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResourcesChannel..::.Open Method
IReportServiceResourcesChannel Interface See Also Send Feedback

Overload List

Name | Description
Open()()() | (Inherited from ICommunicationObject.)
Open(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

IReportServiceResourcesChannel Interface
IReportServiceResourcesChannel Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceResourcesChannel Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResourcesChannel Properties
IReportServiceResourcesChannel Interface See Also Send Feedback

The IReportServiceResourcesChannel type exposes the following members.

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

See Also

IReportServiceResourcesChannel Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


IReportServiceResourcesChannel Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResourcesChannel Events
IReportServiceResourcesChannel Interface See Also Send Feedback

The IReportServiceResourcesChannel type exposes the following members.

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

IReportServiceResourcesChannel Interface
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ListExportsFormatsCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ListExportsFormatsCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ListExportsFormatsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class ListExportsFormatsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class ListExportsFormatsCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ListExportsFormatsCompletedEventArgs

See Also

ListExportsFormatsCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ListExportsFormatsCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ListExportsFormatsCompletedEventArgs Members
ListExportsFormatsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ListExportsFormatsCompletedEventArgs type exposes the following members.

Constructors

Name | Description
ListExportsFormatsCompletedEventArgs | Initializes a new instance of the ListExportsFormatsCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ListExportsFormatsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ListExportsFormatsCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ListExportsFormatsCompletedEventArgs Constructor
ListExportsFormatsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the ListExportsFormatsCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ListExportsFormatsCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
ListExportsFormatsCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

ListExportsFormatsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ListExportsFormatsCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ListExportsFormatsCompletedEventArgs Methods
ListExportsFormatsCompletedEventArgs Class See Also Send Feedback

The ListExportsFormatsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListExportsFormatsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ListExportsFormatsCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ListExportsFormatsCompletedEventArgs Properties
ListExportsFormatsCompletedEventArgs Class See Also Send Feedback

The ListExportsFormatsCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ListExportsFormatsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ListExportsFormatsCompletedEventArgs..::.ReportError Property
ListExportsFormatsCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

ListExportsFormatsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ListExportsFormatsCompletedEventArgs..::.Result Property
ListExportsFormatsCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ObservableCollection<ExportsEnum> Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As ObservableCollection(Of ExportsEnum)
Visual C++
public:
property ObservableCollection<ExportsEnum>^ Result {
    ObservableCollection<ExportsEnum>^ get ();
}

See Also

ListExportsFormatsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadDrillthroughTargetCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadDrillthroughTargetCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class LoadDrillthroughTargetCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class LoadDrillthroughTargetCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class LoadDrillthroughTargetCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.LoadDrillthroughTargetCompletedEventArgs

See Also

LoadDrillthroughTargetCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadDrillthroughTargetCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadDrillthroughTargetCompletedEventArgs Members
LoadDrillthroughTargetCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The LoadDrillthroughTargetCompletedEventArgs type exposes the following members.

Constructors

Name | Description
LoadDrillthroughTargetCompletedEventArgs | Initializes a new instance of the LoadDrillthroughTargetCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

LoadDrillthroughTargetCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadDrillthroughTargetCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadDrillthroughTargetCompletedEventArgs Constructor
LoadDrillthroughTargetCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the LoadDrillthroughTargetCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public LoadDrillthroughTargetCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
LoadDrillthroughTargetCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

LoadDrillthroughTargetCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadDrillthroughTargetCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadDrillthroughTargetCompletedEventArgs Methods
LoadDrillthroughTargetCompletedEventArgs Class See Also Send Feedback

The LoadDrillthroughTargetCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadDrillthroughTargetCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadDrillthroughTargetCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadDrillthroughTargetCompletedEventArgs Properties
LoadDrillthroughTargetCompletedEventArgs Class See Also Send Feedback

The LoadDrillthroughTargetCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

LoadDrillthroughTargetCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadDrillthroughTargetCompletedEventArgs..::.ReportError Property
LoadDrillthroughTargetCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

LoadDrillthroughTargetCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadDrillthroughTargetCompletedEventArgs..::.Result Property
LoadDrillthroughTargetCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportExecutionInfo Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As ReportExecutionInfo
Visual C++
public:
property ReportExecutionInfo^ Result {
    ReportExecutionInfo^ get ();
}

See Also

LoadDrillthroughTargetCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadReportCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadReportCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class LoadReportCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class LoadReportCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class LoadReportCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.LoadReportCompletedEventArgs

See Also

LoadReportCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadReportCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadReportCompletedEventArgs Members
LoadReportCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The LoadReportCompletedEventArgs type exposes the following members.

Constructors

Name | Description
LoadReportCompletedEventArgs | Initializes a new instance of the LoadReportCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

LoadReportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadReportCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadReportCompletedEventArgs Constructor
LoadReportCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the LoadReportCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public LoadReportCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
LoadReportCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

LoadReportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadReportCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadReportCompletedEventArgs Methods
LoadReportCompletedEventArgs Class See Also Send Feedback

The LoadReportCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadReportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadReportCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadReportCompletedEventArgs Properties
LoadReportCompletedEventArgs Class See Also Send Feedback

The LoadReportCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

LoadReportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadReportCompletedEventArgs..::.ReportError Property
LoadReportCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

LoadReportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
LoadReportCompletedEventArgs..::.Result Property
LoadReportCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportExecutionInfo Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As ReportExecutionInfo
Visual C++
public:
property ReportExecutionInfo^ Result {
    ReportExecutionInfo^ get ();
}

See Also

LoadReportCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class NoCachedDocumentExceptionDetail : ExceptionDetailBase
Visual Basic (Declaration)
Public Class NoCachedDocumentExceptionDetail _
    Inherits ExceptionDetailBase
Visual C++
public ref class NoCachedDocumentExceptionDetail : public ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.NoCachedDocumentExceptionDetail

See Also

NoCachedDocumentExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Members
NoCachedDocumentExceptionDetail Class Constructors Methods Properties Events See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Constructors

Name | Description
NoCachedDocumentExceptionDetail | Initializes a new instance of the NoCachedDocumentExceptionDetail class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | (Inherited from ExceptionDetailBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InnerException | (Inherited from ExceptionDetailBase.)
Message | (Inherited from ExceptionDetailBase.)

Events

Name | Description
PropertyChanged | (Inherited from ExceptionDetailBase.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Constructor
NoCachedDocumentExceptionDetail Class See Also Send Feedback
Initializes a new instance of the NoCachedDocumentExceptionDetail class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public NoCachedDocumentExceptionDetail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoCachedDocumentExceptionDetail()

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Methods
NoCachedDocumentExceptionDetail Class See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | (Inherited from ExceptionDetailBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Properties
NoCachedDocumentExceptionDetail Class See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Properties

Name | Description
InnerException | (Inherited from ExceptionDetailBase.)
Message | (Inherited from ExceptionDetailBase.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Events
NoCachedDocumentExceptionDetail Class See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Events

Name | Description
PropertyChanged | (Inherited from ExceptionDetailBase.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PageInfo Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class PageInfo : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class PageInfo _
    Implements INotifyPropertyChanged
Visual C++
public ref class PageInfo : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.PageInfo

See Also

PageInfo Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PageInfo Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Members
PageInfo Class Constructors Methods Properties Events See Also Send Feedback

The PageInfo type exposes the following members.

Constructors

Name | Description
PageInfo | Initializes a new instance of the PageInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CompresedXamlPage |
DocumentId |
PageNumber |

Events

Name | Description
PropertyChanged |

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PageInfo Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Constructor
PageInfo Class See Also Send Feedback
Initializes a new instance of the PageInfo class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public PageInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageInfo()

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PageInfo Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Methods
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo..::.RaisePropertyChanged Method
PageInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PageInfo Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Properties
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Properties

Name | Description
CompresedXamlPage |
DocumentId |
PageNumber |

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CompresedXamlPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo..::.CompresedXamlPage Property
PageInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public byte[] CompresedXamlPage { get; set; }
Visual Basic (Declaration)
Public Property CompresedXamlPage As Byte()
Visual C++
public:
property array<unsigned char>^ CompresedXamlPage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


DocumentId Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo..::.DocumentId Property
PageInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string DocumentId { get; set; }
Visual Basic (Declaration)
Public Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
    void set (String^ value);
}

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PageNumber Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo..::.PageNumber Property
PageInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PageInfo Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Events
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo..::.PropertyChanged Event
PageInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ParameterStateEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParameterStateEnum Enumeration
See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public enum ParameterStateEnum
Visual Basic (Declaration)
Public Enumeration ParameterStateEnum
Visual C++
public enum class ParameterStateEnum

Members

Member name | Description
DynamicValuesUnavailable |
HasOutstandingDependencies |
HasValidValue |
MissingValidValue |

See Also

PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ParameterTypeEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParameterTypeEnum Enumeration
See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public enum ParameterTypeEnum
Visual Basic (Declaration)
Public Enumeration ParameterTypeEnum
Visual C++
public enum class ParameterTypeEnum

Members

Member name | Description
Boolean |
DateTime |
Float |
Integer |
String |

See Also

PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PrintCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PrintCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class PrintCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class PrintCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class PrintCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.PrintCompletedEventArgs

See Also

PrintCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PrintCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PrintCompletedEventArgs Members
PrintCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The PrintCompletedEventArgs type exposes the following members.

Constructors

Name | Description
PrintCompletedEventArgs | Initializes a new instance of the PrintCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

PrintCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PrintCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PrintCompletedEventArgs Constructor
PrintCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the PrintCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public PrintCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
PrintCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

PrintCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PrintCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PrintCompletedEventArgs Methods
PrintCompletedEventArgs Class See Also Send Feedback

The PrintCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PrintCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PrintCompletedEventArgs Properties
PrintCompletedEventArgs Class See Also Send Feedback

The PrintCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

PrintCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PrintCompletedEventArgs..::.Result Property
PrintCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public byte[] Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Byte()
Visual C++
public:
property array<unsigned char>^ Result {
    array<unsigned char>^ get ();
}

See Also

PrintCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ProcessingExceptionDetail Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ProcessingExceptionDetail : ExceptionDetailBase
Visual Basic (Declaration)
Public Class ProcessingExceptionDetail _
    Inherits ExceptionDetailBase
Visual C++
public ref class ProcessingExceptionDetail : public ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ExceptionDetailBase
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ProcessingExceptionDetail

See Also

ProcessingExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ProcessingExceptionDetail Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Members
ProcessingExceptionDetail Class Constructors Methods Properties Events See Also Send Feedback

The ProcessingExceptionDetail type exposes the following members.

Constructors

Name | Description
ProcessingExceptionDetail | Initializes a new instance of the ProcessingExceptionDetail class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | (Inherited from ExceptionDetailBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InnerException | (Inherited from ExceptionDetailBase.)
Message | (Inherited from ExceptionDetailBase.)

Events

Name | Description
PropertyChanged | (Inherited from ExceptionDetailBase.)

See Also

ProcessingExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ProcessingExceptionDetail Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Constructor
ProcessingExceptionDetail Class See Also Send Feedback
Initializes a new instance of the ProcessingExceptionDetail class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ProcessingExceptionDetail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProcessingExceptionDetail()

See Also

ProcessingExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ProcessingExceptionDetail Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Methods
ProcessingExceptionDetail Class See Also Send Feedback

The ProcessingExceptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | (Inherited from ExceptionDetailBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessingExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ProcessingExceptionDetail Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Properties
ProcessingExceptionDetail Class See Also Send Feedback

The ProcessingExceptionDetail type exposes the following members.

Properties

Name | Description
InnerException | (Inherited from ExceptionDetailBase.)
Message | (Inherited from ExceptionDetailBase.)

See Also

ProcessingExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ProcessingExceptionDetail Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Events
ProcessingExceptionDetail Class See Also Send Feedback

The ProcessingExceptionDetail type exposes the following members.

Events

Name | Description
PropertyChanged | (Inherited from ExceptionDetailBase.)

See Also

ProcessingExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RenderCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
RenderCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class RenderCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class RenderCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class RenderCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.RenderCompletedEventArgs

See Also

RenderCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RenderCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
RenderCompletedEventArgs Members
RenderCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The RenderCompletedEventArgs type exposes the following members.

Constructors

Name | Description
RenderCompletedEventArgs | Initializes a new instance of the RenderCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RenderCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
RenderCompletedEventArgs Constructor
RenderCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the RenderCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public RenderCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
RenderCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RenderCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
RenderCompletedEventArgs Methods
RenderCompletedEventArgs Class See Also Send Feedback

The RenderCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RenderCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
RenderCompletedEventArgs Properties
RenderCompletedEventArgs Class See Also Send Feedback

The RenderCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
RenderCompletedEventArgs..::.ReportError Property
RenderCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
RenderCompletedEventArgs..::.Result Property
RenderCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As String
Visual C++
public:
property String^ Result {
    String^ get ();
}

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSource Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportDataSource : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ReportDataSource _
    Implements INotifyPropertyChanged
Visual C++
public ref class ReportDataSource : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ReportDataSource

See Also

ReportDataSource Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSource Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Members
ReportDataSource Class Constructors Methods Properties Events See Also Send Feedback

The ReportDataSource type exposes the following members.

Constructors

Name | Description
ReportDataSource | Initializes a new instance of the ReportDataSource class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataSourceID |
Name |
Prompt |

Events

Name | Description
PropertyChanged |

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSource Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Constructor
ReportDataSource Class See Also Send Feedback
Initializes a new instance of the ReportDataSource class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportDataSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportDataSource()

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSource Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Methods
ReportDataSource Class See Also Send Feedback

The ReportDataSource type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource..::.RaisePropertyChanged Method
ReportDataSource Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSource Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Properties
ReportDataSource Class See Also Send Feedback

The ReportDataSource type exposes the following members.

Properties

Name | Description
DataSourceID |
Name |
Prompt |

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


DataSourceID Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource..::.DataSourceID Property
ReportDataSource Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string DataSourceID { get; set; }
Visual Basic (Declaration)
Public Property DataSourceID As String
Visual C++
public:
property String^ DataSourceID {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Name Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource..::.Name Property
ReportDataSource Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Prompt Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource..::.Prompt Property
ReportDataSource Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Prompt { get; set; }
Visual Basic (Declaration)
Public Property Prompt As String
Visual C++
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSource Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Events
ReportDataSource Class See Also Send Feedback

The ReportDataSource type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource..::.PropertyChanged Event
ReportDataSource Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSourceCredential Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportDataSourceCredential : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ReportDataSourceCredential _
    Implements INotifyPropertyChanged
Visual C++
public ref class ReportDataSourceCredential : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ReportDataSourceCredential

See Also

ReportDataSourceCredential Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSourceCredential Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Members
ReportDataSourceCredential Class Constructors Methods Properties Events See Also Send Feedback

The ReportDataSourceCredential type exposes the following members.

Constructors

Name | Description
ReportDataSourceCredential | Initializes a new instance of the ReportDataSourceCredential class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataSourceName |
Password |
UserName |

Events

Name | Description
PropertyChanged |

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSourceCredential Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Constructor
ReportDataSourceCredential Class See Also Send Feedback
Initializes a new instance of the ReportDataSourceCredential class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportDataSourceCredential()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportDataSourceCredential()

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSourceCredential Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Methods
ReportDataSourceCredential Class See Also Send Feedback

The ReportDataSourceCredential type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential..::.RaisePropertyChanged Method
ReportDataSourceCredential Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSourceCredential Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Properties
ReportDataSourceCredential Class See Also Send Feedback

The ReportDataSourceCredential type exposes the following members.

Properties

Name | Description
DataSourceName |
Password |
UserName |

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


DataSourceName Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential..::.DataSourceName Property
ReportDataSourceCredential Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string DataSourceName { get; set; }
Visual Basic (Declaration)
Public Property DataSourceName As String
Visual C++
public:
property String^ DataSourceName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Password Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential..::.Password Property
ReportDataSourceCredential Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


UserName Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential..::.UserName Property
ReportDataSourceCredential Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportDataSourceCredential Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Events
ReportDataSourceCredential Class See Also Send Feedback

The ReportDataSourceCredential type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential..::.PropertyChanged Event
ReportDataSourceCredential Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportExecutionInfo Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportExecutionInfo : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ReportExecutionInfo _
    Implements INotifyPropertyChanged
Visual C++
public ref class ReportExecutionInfo : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ReportExecutionInfo

See Also

ReportExecutionInfo Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportExecutionInfo Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Members
ReportExecutionInfo Class Constructors Methods Properties Events See Also Send Feedback

The ReportExecutionInfo type exposes the following members.

Constructors

Name | Description
ReportExecutionInfo | Initializes a new instance of the ReportExecutionInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CredentialsRequired |
DataSourcePrompts |
ExecutionDateTime |
ExecutionID |
ExpirationDateTime |
NeedProcessing |
Parameters |
ParametersRequired |
ReportName |

Events

Name | Description
PropertyChanged |

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportExecutionInfo Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Constructor
ReportExecutionInfo Class See Also Send Feedback
Initializes a new instance of the ReportExecutionInfo class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportExecutionInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportExecutionInfo()

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportExecutionInfo Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Methods
ReportExecutionInfo Class See Also Send Feedback

The ReportExecutionInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.RaisePropertyChanged Method
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportExecutionInfo Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Properties
ReportExecutionInfo Class See Also Send Feedback

The ReportExecutionInfo type exposes the following members.

Properties

Name | Description
CredentialsRequired |
DataSourcePrompts |
ExecutionDateTime |
ExecutionID |
ExpirationDateTime |
NeedProcessing |
Parameters |
ParametersRequired |
ReportName |

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CredentialsRequired Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.CredentialsRequired Property
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool CredentialsRequired { get; set; }
Visual Basic (Declaration)
Public Property CredentialsRequired As Boolean
Visual C++
public:
property bool CredentialsRequired {
    bool get ();
    void set (bool value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


DataSourcePrompts Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.DataSourcePrompts Property
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ObservableCollection<ReportDataSource> DataSourcePrompts { get; set; }
Visual Basic (Declaration)
Public Property DataSourcePrompts As ObservableCollection(Of ReportDataSource)
Visual C++
public:
property ObservableCollection<ReportDataSource^>^ DataSourcePrompts {
    ObservableCollection<ReportDataSource^>^ get ();
    void set (ObservableCollection<ReportDataSource^>^ value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExecutionDateTime Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.ExecutionDateTime Property
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DateTime ExecutionDateTime { get; set; }
Visual Basic (Declaration)
Public Property ExecutionDateTime As DateTime
Visual C++
public:
property DateTime ExecutionDateTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExecutionID Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.ExecutionID Property
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string ExecutionID { get; set; }
Visual Basic (Declaration)
Public Property ExecutionID As String
Visual C++
public:
property String^ ExecutionID {
    String^ get ();
    void set (String^ value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExpirationDateTime Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.ExpirationDateTime Property
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DateTime ExpirationDateTime { get; set; }
Visual Basic (Declaration)
Public Property ExpirationDateTime As DateTime
Visual C++
public:
property DateTime ExpirationDateTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


NeedProcessing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.NeedProcessing Property
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool NeedProcessing { get; set; }
Visual Basic (Declaration)
Public Property NeedProcessing As Boolean
Visual C++
public:
property bool NeedProcessing {
    bool get ();
    void set (bool value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Parameters Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.Parameters Property
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ObservableCollection<ReportParameter> Parameters { get; set; }
Visual Basic (Declaration)
Public Property Parameters As ObservableCollection(Of ReportParameter)
Visual C++
public:
property ObservableCollection<ReportParameter^>^ Parameters {
    ObservableCollection<ReportParameter^>^ get ();
    void set (ObservableCollection<ReportParameter^>^ value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ParametersRequired Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.ParametersRequired Property
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool ParametersRequired { get; set; }
Visual Basic (Declaration)
Public Property ParametersRequired As Boolean
Visual C++
public:
property bool ParametersRequired {
    bool get ();
    void set (bool value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportName Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.ReportName Property
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string ReportName { get; set; }
Visual Basic (Declaration)
Public Property ReportName As String
Visual C++
public:
property String^ ReportName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportExecutionInfo Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Events
ReportExecutionInfo Class See Also Send Feedback

The ReportExecutionInfo type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.PropertyChanged Event
ReportExecutionInfo Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameter Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportParameter : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ReportParameter _
    Implements INotifyPropertyChanged
Visual C++
public ref class ReportParameter : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ReportParameter

See Also

ReportParameter Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameter Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Members
ReportParameter Class Constructors Methods Properties Events See Also Send Feedback

The ReportParameter type exposes the following members.

Constructors

Name | Description
ReportParameter | Initializes a new instance of the ReportParameter class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowBlank |
DefaultValues |
Dependencies |
MultiValue |
Name |
Nullable |
Prompt |
PromptUser |
State |
Type |
ValidValues |

Events

Name | Description
PropertyChanged |

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameter Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Constructor
ReportParameter Class See Also Send Feedback
Initializes a new instance of the ReportParameter class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportParameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportParameter()

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameter Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Methods
ReportParameter Class See Also Send Feedback

The ReportParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.RaisePropertyChanged Method
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameter Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Properties
ReportParameter Class See Also Send Feedback

The ReportParameter type exposes the following members.

Properties

Name | Description
AllowBlank |
DefaultValues |
Dependencies |
MultiValue |
Name |
Nullable |
Prompt |
PromptUser |
State |
Type |
ValidValues |

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


AllowBlank Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.AllowBlank Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowBlank { get; set; }
Visual Basic (Declaration)
Public Property AllowBlank As Boolean
Visual C++
public:
property bool AllowBlank {
    bool get ();
    void set (bool value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


DefaultValues Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.DefaultValues Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ObservableCollection<string> DefaultValues { get; set; }
Visual Basic (Declaration)
Public Property DefaultValues As ObservableCollection(Of String)
Visual C++
public:
property ObservableCollection<String^>^ DefaultValues {
    ObservableCollection<String^>^ get ();
    void set (ObservableCollection<String^>^ value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Dependencies Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.Dependencies Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ObservableCollection<string> Dependencies { get; set; }
Visual Basic (Declaration)
Public Property Dependencies As ObservableCollection(Of String)
Visual C++
public:
property ObservableCollection<String^>^ Dependencies {
    ObservableCollection<String^>^ get ();
    void set (ObservableCollection<String^>^ value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


MultiValue Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.MultiValue Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool MultiValue { get; set; }
Visual Basic (Declaration)
Public Property MultiValue As Boolean
Visual C++
public:
property bool MultiValue {
    bool get ();
    void set (bool value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Name Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.Name Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Nullable Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.Nullable Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool Nullable { get; set; }
Visual Basic (Declaration)
Public Property Nullable As Boolean
Visual C++
public:
property bool Nullable {
    bool get ();
    void set (bool value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Prompt Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.Prompt Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Prompt { get; set; }
Visual Basic (Declaration)
Public Property Prompt As String
Visual C++
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PromptUser Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.PromptUser Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool PromptUser { get; set; }
Visual Basic (Declaration)
Public Property PromptUser As Boolean
Visual C++
public:
property bool PromptUser {
    bool get ();
    void set (bool value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


State Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.State Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ParameterStateEnum State { get; set; }
Visual Basic (Declaration)
Public Property State As ParameterStateEnum
Visual C++
public:
property ParameterStateEnum State {
    ParameterStateEnum get ();
    void set (ParameterStateEnum value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Type Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.Type Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ParameterTypeEnum Type { get; set; }
Visual Basic (Declaration)
Public Property Type As ParameterTypeEnum
Visual C++
public:
property ParameterTypeEnum Type {
    ParameterTypeEnum get ();
    void set (ParameterTypeEnum value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ValidValues Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.ValidValues Property
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ObservableCollection<ValidValue> ValidValues { get; set; }
Visual Basic (Declaration)
Public Property ValidValues As ObservableCollection(Of ValidValue)
Visual C++
public:
property ObservableCollection<ValidValue^>^ ValidValues {
    ObservableCollection<ValidValue^>^ get ();
    void set (ObservableCollection<ValidValue^>^ value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameter Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Events
ReportParameter Class See Also Send Feedback

The ReportParameter type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.PropertyChanged Event
ReportParameter Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameterValue Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportParameterValue : ValidValue
Visual Basic (Declaration)
Public Class ReportParameterValue _
    Inherits ValidValue
Visual C++
public ref class ReportParameterValue : public ValidValue

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ValidValue
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ReportParameterValue

See Also

ReportParameterValue Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameterValue Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Members
ReportParameterValue Class Constructors Methods Properties Events See Also Send Feedback

The ReportParameterValue type exposes the following members.

Constructors

Name | Description
ReportParameterValue | Initializes a new instance of the ReportParameterValue class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | (Inherited from ValidValue.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Label | (Inherited from ValidValue.)
Name |
Value | (Inherited from ValidValue.)

Events

Name | Description
PropertyChanged | (Inherited from ValidValue.)

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameterValue Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Constructor
ReportParameterValue Class See Also Send Feedback
Initializes a new instance of the ReportParameterValue class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportParameterValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportParameterValue()

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameterValue Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Methods
ReportParameterValue Class See Also Send Feedback

The ReportParameterValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | (Inherited from ValidValue.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameterValue Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Properties
ReportParameterValue Class See Also Send Feedback

The ReportParameterValue type exposes the following members.

Properties

Name | Description
Label | (Inherited from ValidValue.)
Name |
Value | (Inherited from ValidValue.)

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Name Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue..::.Name Property
ReportParameterValue Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportParameterValue Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Events
ReportParameterValue Class See Also Send Feedback

The ReportParameterValue type exposes the following members.

Events

Name | Description
PropertyChanged | (Inherited from ValidValue.)

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportServiceClient : ClientBase<IReportService>,
    IReportService
Visual Basic (Declaration)
Public Class ReportServiceClient _
    Inherits ClientBase(Of IReportService) _
    Implements IReportService
Visual C++
public ref class ReportServiceClient : public ClientBase<IReportService^>,
    IReportService

Inheritance Hierarchy

System..::.Object
System.ServiceModel..::.ClientBase <(Of <( IReportService >)>)
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ReportServiceClient

See Also

ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Members
ReportServiceClient Class Constructors Methods Properties Events See Also Send Feedback

The ReportServiceClient type exposes the following members.

Constructors

Name | Description
ReportServiceClient | Overloaded.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( IReportService >)>).)
CloseAsync | Overloaded.
CreateChannel | (Overrides ClientBase<(Of <(TChannel>)>)..::.CreateChannel()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAsync | Overloaded.
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( IReportService >)>).)
GetDocumentInfoAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPageInfoAsync | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitAsync | Overloaded.
InvokeAsync | (Inherited from ClientBase <(Of <( IReportService >)>).)
ListExportsFormatsAsync | Overloaded.
LoadDrillthroughTargetAsync | Overloaded.
LoadReportAsync | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenAsync | Overloaded.
RenderAsync | Overloaded.
SetDataSourcesCredentialsAsync | Overloaded.
SetParametersAsync | Overloaded.
SortAsync | Overloaded.
ToggleItemAsync | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( IReportService >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( IReportService >)>).)
ClientCredentials | (Inherited from ClientBase <(Of <( IReportService >)>).)
CookieContainer |
Endpoint | (Inherited from ClientBase <(Of <( IReportService >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( IReportService >)>).)
State | (Inherited from ClientBase <(Of <( IReportService >)>).)

Events

Name | Description
CloseCompleted |
FindCompleted |
GetDocumentInfoCompleted |
GetPageInfoCompleted |
InitCompleted |
ListExportsFormatsCompleted |
LoadDrillthroughTargetCompleted |
LoadReportCompleted |
OpenCompleted |
RenderCompleted |
SetDataSourcesCredentialsCompleted |
SetParametersCompleted |
SortCompleted |
ToggleItemCompleted |

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Constructor
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
ReportServiceClient()()() | Initializes a new instance of the ReportServiceClient class
ReportServiceClient(String) | Initializes a new instance of the ReportServiceClient class
ReportServiceClient(Binding, EndpointAddress) | Initializes a new instance of the ReportServiceClient class
ReportServiceClient(String, EndpointAddress) | Initializes a new instance of the ReportServiceClient class
ReportServiceClient(String, String) | Initializes a new instance of the ReportServiceClient class

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Constructor
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportServiceClient()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportServiceClient()

See Also

ReportServiceClient Class
ReportServiceClient Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Constructor (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Constructor (String)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportServiceClient(
    string endpointConfigurationName
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String _
)
Visual C++
public:
ReportServiceClient(
    String^ endpointConfigurationName
)

Parameters

endpointConfigurationName
Type: System..::.String

See Also

ReportServiceClient Class
ReportServiceClient Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Constructor (Binding, EndpointAddress)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Constructor (Binding, EndpointAddress)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportServiceClient(
    Binding binding,
    EndpointAddress remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    binding As Binding, _
    remoteAddress As EndpointAddress _
)
Visual C++
public:
ReportServiceClient(
    Binding^ binding,
    EndpointAddress^ remoteAddress
)

Parameters

binding
Type: System.ServiceModel.Channels..::.Binding
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

ReportServiceClient Class
ReportServiceClient Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Constructor (String, EndpointAddress)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Constructor (String, EndpointAddress)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportServiceClient(
    string endpointConfigurationName,
    EndpointAddress remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As EndpointAddress _
)
Visual C++
public:
ReportServiceClient(
    String^ endpointConfigurationName,
    EndpointAddress^ remoteAddress
)

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

ReportServiceClient Class
ReportServiceClient Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Constructor (String, String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Constructor (String, String)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportServiceClient(
    string endpointConfigurationName,
    string remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As String _
)
Visual C++
public:
ReportServiceClient(
    String^ endpointConfigurationName,
    String^ remoteAddress
)

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System..::.String

See Also

ReportServiceClient Class
ReportServiceClient Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Methods
ReportServiceClient Class See Also Send Feedback

The ReportServiceClient type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( IReportService >)>).)
CloseAsync | Overloaded.
CreateChannel | (Overrides ClientBase<(Of <(TChannel>)>)..::.CreateChannel()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAsync | Overloaded.
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( IReportService >)>).)
GetDocumentInfoAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPageInfoAsync | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitAsync | Overloaded.
InvokeAsync | (Inherited from ClientBase <(Of <( IReportService >)>).)
ListExportsFormatsAsync | Overloaded.
LoadDrillthroughTargetAsync | Overloaded.
LoadReportAsync | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenAsync | Overloaded.
RenderAsync | Overloaded.
SetDataSourcesCredentialsAsync | Overloaded.
SetParametersAsync | Overloaded.
SortAsync | Overloaded.
ToggleItemAsync | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CloseAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.CloseAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
CloseAsync()()() |
CloseAsync(Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CloseAsync Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.CloseAsync Method
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void CloseAsync()
Visual Basic (Declaration)
Public Sub CloseAsync
Visual C++
public:
void CloseAsync()

See Also

ReportServiceClient Class
CloseAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CloseAsync Method (Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.CloseAsync Method (Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void CloseAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub CloseAsync ( _
    userState As Object _
)
Visual C++
public:
void CloseAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceClient Class
CloseAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CreateChannel Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.CreateChannel Method
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override IReportService CreateChannel()
Visual Basic (Declaration)
Protected Overrides Function CreateChannel As IReportService
Visual C++
protected:
virtual IReportService^ CreateChannel() override

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.FindAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
FindAsync(String, FindOptions) |
FindAsync(String, FindOptions, Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindAsync Method (String, FindOptions)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.FindAsync Method (String, FindOptions)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void FindAsync(
    string id,
    FindOptions findOptions
)
Visual Basic (Declaration)
Public Sub FindAsync ( _
    id As String, _
    findOptions As FindOptions _
)
Visual C++
public:
void FindAsync(
    String^ id,
    FindOptions findOptions
)

Parameters

id
Type: System..::.String
findOptions
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.FindOptions

See Also

ReportServiceClient Class
FindAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindAsync Method (String, FindOptions, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.FindAsync Method (String, FindOptions, Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void FindAsync(
    string id,
    FindOptions findOptions,
    Object userState
)
Visual Basic (Declaration)
Public Sub FindAsync ( _
    id As String, _
    findOptions As FindOptions, _
    userState As Object _
)
Visual C++
public:
void FindAsync(
    String^ id,
    FindOptions findOptions,
    Object^ userState
)

Parameters

id
Type: System..::.String
findOptions
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.FindOptions
userState
Type: System..::.Object

See Also

ReportServiceClient Class
FindAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetDocumentInfoAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.GetDocumentInfoAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
GetDocumentInfoAsync(String) |
GetDocumentInfoAsync(String, Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetDocumentInfoAsync Method (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.GetDocumentInfoAsync Method (String)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetDocumentInfoAsync(
    string id
)
Visual Basic (Declaration)
Public Sub GetDocumentInfoAsync ( _
    id As String _
)
Visual C++
public:
void GetDocumentInfoAsync(
    String^ id
)

Parameters

id
Type: System..::.String

See Also

ReportServiceClient Class
GetDocumentInfoAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetDocumentInfoAsync Method (String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.GetDocumentInfoAsync Method (String, Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetDocumentInfoAsync(
    string id,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetDocumentInfoAsync ( _
    id As String, _
    userState As Object _
)
Visual C++
public:
void GetDocumentInfoAsync(
    String^ id,
    Object^ userState
)

Parameters

id
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceClient Class
GetDocumentInfoAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetPageInfoAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.GetPageInfoAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
GetPageInfoAsync(String, Int32) |
GetPageInfoAsync(String, Int32, Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetPageInfoAsync Method (String, Int32)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.GetPageInfoAsync Method (String, Int32)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetPageInfoAsync(
    string id,
    int pageNumber
)
Visual Basic (Declaration)
Public Sub GetPageInfoAsync ( _
    id As String, _
    pageNumber As Integer _
)
Visual C++
public:
void GetPageInfoAsync(
    String^ id,
    int pageNumber
)

Parameters

id
Type: System..::.String
pageNumber
Type: System..::.Int32

See Also

ReportServiceClient Class
GetPageInfoAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetPageInfoAsync Method (String, Int32, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.GetPageInfoAsync Method (String, Int32, Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetPageInfoAsync(
    string id,
    int pageNumber,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetPageInfoAsync ( _
    id As String, _
    pageNumber As Integer, _
    userState As Object _
)
Visual C++
public:
void GetPageInfoAsync(
    String^ id,
    int pageNumber,
    Object^ userState
)

Parameters

id
Type: System..::.String
pageNumber
Type: System..::.Int32
userState
Type: System..::.Object

See Also

ReportServiceClient Class
GetPageInfoAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


InitAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.InitAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
InitAsync()()() |
InitAsync(Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


InitAsync Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.InitAsync Method
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void InitAsync()
Visual Basic (Declaration)
Public Sub InitAsync
Visual C++
public:
void InitAsync()

See Also

ReportServiceClient Class
InitAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


InitAsync Method (Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.InitAsync Method (Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void InitAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub InitAsync ( _
    userState As Object _
)
Visual C++
public:
void InitAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceClient Class
InitAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ListExportsFormatsAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.ListExportsFormatsAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
ListExportsFormatsAsync()()() |
ListExportsFormatsAsync(Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ListExportsFormatsAsync Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.ListExportsFormatsAsync Method
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ListExportsFormatsAsync()
Visual Basic (Declaration)
Public Sub ListExportsFormatsAsync
Visual C++
public:
void ListExportsFormatsAsync()

See Also

ReportServiceClient Class
ListExportsFormatsAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ListExportsFormatsAsync Method (Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.ListExportsFormatsAsync Method (Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ListExportsFormatsAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub ListExportsFormatsAsync ( _
    userState As Object _
)
Visual C++
public:
void ListExportsFormatsAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceClient Class
ListExportsFormatsAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadDrillthroughTargetAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.LoadDrillthroughTargetAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
LoadDrillthroughTargetAsync(String, String) |
LoadDrillthroughTargetAsync(String, String, Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadDrillthroughTargetAsync Method (String, String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.LoadDrillthroughTargetAsync Method (String, String)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void LoadDrillthroughTargetAsync(
    string id,
    string DrillthroughID
)
Visual Basic (Declaration)
Public Sub LoadDrillthroughTargetAsync ( _
    id As String, _
    DrillthroughID As String _
)
Visual C++
public:
void LoadDrillthroughTargetAsync(
    String^ id,
    String^ DrillthroughID
)

Parameters

id
Type: System..::.String
DrillthroughID
Type: System..::.String

See Also

ReportServiceClient Class
LoadDrillthroughTargetAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadDrillthroughTargetAsync Method (String, String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.LoadDrillthroughTargetAsync Method (String, String, Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void LoadDrillthroughTargetAsync(
    string id,
    string DrillthroughID,
    Object userState
)
Visual Basic (Declaration)
Public Sub LoadDrillthroughTargetAsync ( _
    id As String, _
    DrillthroughID As String, _
    userState As Object _
)
Visual C++
public:
void LoadDrillthroughTargetAsync(
    String^ id,
    String^ DrillthroughID,
    Object^ userState
)

Parameters

id
Type: System..::.String
DrillthroughID
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceClient Class
LoadDrillthroughTargetAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadReportAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.LoadReportAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
LoadReportAsync(String) |
LoadReportAsync(String, Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadReportAsync Method (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.LoadReportAsync Method (String)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void LoadReportAsync(
    string report
)
Visual Basic (Declaration)
Public Sub LoadReportAsync ( _
    report As String _
)
Visual C++
public:
void LoadReportAsync(
    String^ report
)

Parameters

report
Type: System..::.String

See Also

ReportServiceClient Class
LoadReportAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadReportAsync Method (String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.LoadReportAsync Method (String, Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void LoadReportAsync(
    string report,
    Object userState
)
Visual Basic (Declaration)
Public Sub LoadReportAsync ( _
    report As String, _
    userState As Object _
)
Visual C++
public:
void LoadReportAsync(
    String^ report,
    Object^ userState
)

Parameters

report
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceClient Class
LoadReportAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


OpenAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.OpenAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
OpenAsync()()() |
OpenAsync(Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


OpenAsync Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.OpenAsync Method
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void OpenAsync()
Visual Basic (Declaration)
Public Sub OpenAsync
Visual C++
public:
void OpenAsync()

See Also

ReportServiceClient Class
OpenAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


OpenAsync Method (Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.OpenAsync Method (Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void OpenAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub OpenAsync ( _
    userState As Object _
)
Visual C++
public:
void OpenAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceClient Class
OpenAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RenderAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.RenderAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
RenderAsync(String) |
RenderAsync(String, Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RenderAsync Method (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.RenderAsync Method (String)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void RenderAsync(
    string id
)
Visual Basic (Declaration)
Public Sub RenderAsync ( _
    id As String _
)
Visual C++
public:
void RenderAsync(
    String^ id
)

Parameters

id
Type: System..::.String

See Also

ReportServiceClient Class
RenderAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RenderAsync Method (String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.RenderAsync Method (String, Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void RenderAsync(
    string id,
    Object userState
)
Visual Basic (Declaration)
Public Sub RenderAsync ( _
    id As String, _
    userState As Object _
)
Visual C++
public:
void RenderAsync(
    String^ id,
    Object^ userState
)

Parameters

id
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceClient Class
RenderAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetDataSourcesCredentialsAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SetDataSourcesCredentialsAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
SetDataSourcesCredentialsAsync(String, ObservableCollection<(Of <(ReportDataSourceCredential>)>)) |
SetDataSourcesCredentialsAsync(String, ObservableCollection<(Of <(ReportDataSourceCredential>)>), Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetDataSourcesCredentialsAsync Method (String, ObservableCollection(ReportDataSourceCredential))

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SetDataSourcesCredentialsAsync Method (String, ObservableCollection<(Of <(ReportDataSourceCredential>)>))
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SetDataSourcesCredentialsAsync(
    string id,
    ObservableCollection<ReportDataSourceCredential> credentials
)
Visual Basic (Declaration)
Public Sub SetDataSourcesCredentialsAsync ( _
    id As String, _
    credentials As ObservableCollection(Of ReportDataSourceCredential) _
)
Visual C++
public:
void SetDataSourcesCredentialsAsync(
    String^ id,
    ObservableCollection<ReportDataSourceCredential^>^ credentials
)

Parameters

id
Type: System..::.String
credentials
Type: System.Collections.ObjectModel..::.ObservableCollection <(Of <( ReportDataSourceCredential >)>)

See Also

ReportServiceClient Class
SetDataSourcesCredentialsAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetDataSourcesCredentialsAsync Method (String, ObservableCollection(ReportDataSourceCredential), Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SetDataSourcesCredentialsAsync Method (String, ObservableCollection<(Of <(ReportDataSourceCredential>)>), Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SetDataSourcesCredentialsAsync(
    string id,
    ObservableCollection<ReportDataSourceCredential> credentials,
    Object userState
)
Visual Basic (Declaration)
Public Sub SetDataSourcesCredentialsAsync ( _
    id As String, _
    credentials As ObservableCollection(Of ReportDataSourceCredential), _
    userState As Object _
)
Visual C++
public:
void SetDataSourcesCredentialsAsync(
    String^ id,
    ObservableCollection<ReportDataSourceCredential^>^ credentials,
    Object^ userState
)

Parameters

id
Type: System..::.String
credentials
Type: System.Collections.ObjectModel..::.ObservableCollection <(Of <( ReportDataSourceCredential >)>)
userState
Type: System..::.Object

See Also

ReportServiceClient Class
SetDataSourcesCredentialsAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetParametersAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SetParametersAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
SetParametersAsync(String, ObservableCollection<(Of <(ReportParameterValue>)>), String) |
SetParametersAsync(String, ObservableCollection<(Of <(ReportParameterValue>)>), String, Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetParametersAsync Method (String, ObservableCollection(ReportParameterValue), String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SetParametersAsync Method (String, ObservableCollection<(Of <(ReportParameterValue>)>), String)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SetParametersAsync(
    string id,
    ObservableCollection<ReportParameterValue> paramatersValues,
    string parametersLanguage
)
Visual Basic (Declaration)
Public Sub SetParametersAsync ( _
    id As String, _
    paramatersValues As ObservableCollection(Of ReportParameterValue), _
    parametersLanguage As String _
)
Visual C++
public:
void SetParametersAsync(
    String^ id,
    ObservableCollection<ReportParameterValue^>^ paramatersValues,
    String^ parametersLanguage
)

Parameters

id
Type: System..::.String
paramatersValues
Type: System.Collections.ObjectModel..::.ObservableCollection <(Of <( ReportParameterValue >)>)
parametersLanguage
Type: System..::.String

See Also

ReportServiceClient Class
SetParametersAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetParametersAsync Method (String, ObservableCollection(ReportParameterValue), String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SetParametersAsync Method (String, ObservableCollection<(Of <(ReportParameterValue>)>), String, Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SetParametersAsync(
    string id,
    ObservableCollection<ReportParameterValue> paramatersValues,
    string parametersLanguage,
    Object userState
)
Visual Basic (Declaration)
Public Sub SetParametersAsync ( _
    id As String, _
    paramatersValues As ObservableCollection(Of ReportParameterValue), _
    parametersLanguage As String, _
    userState As Object _
)
Visual C++
public:
void SetParametersAsync(
    String^ id,
    ObservableCollection<ReportParameterValue^>^ paramatersValues,
    String^ parametersLanguage,
    Object^ userState
)

Parameters

id
Type: System..::.String
paramatersValues
Type: System.Collections.ObjectModel..::.ObservableCollection <(Of <( ReportParameterValue >)>)
parametersLanguage
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceClient Class
SetParametersAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SortAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SortAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
SortAsync(String, String, SortDirectionEnum) |
SortAsync(String, String, SortDirectionEnum, Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SortAsync Method (String, String, SortDirectionEnum)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SortAsync Method (String, String, SortDirectionEnum)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SortAsync(
    string id,
    string elementId,
    SortDirectionEnum sortDirection
)
Visual Basic (Declaration)
Public Sub SortAsync ( _
    id As String, _
    elementId As String, _
    sortDirection As SortDirectionEnum _
)
Visual C++
public:
void SortAsync(
    String^ id,
    String^ elementId,
    SortDirectionEnum sortDirection
)

Parameters

id
Type: System..::.String
elementId
Type: System..::.String
sortDirection
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SortDirectionEnum

See Also

ReportServiceClient Class
SortAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SortAsync Method (String, String, SortDirectionEnum, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SortAsync Method (String, String, SortDirectionEnum, Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void SortAsync(
    string id,
    string elementId,
    SortDirectionEnum sortDirection,
    Object userState
)
Visual Basic (Declaration)
Public Sub SortAsync ( _
    id As String, _
    elementId As String, _
    sortDirection As SortDirectionEnum, _
    userState As Object _
)
Visual C++
public:
void SortAsync(
    String^ id,
    String^ elementId,
    SortDirectionEnum sortDirection,
    Object^ userState
)

Parameters

id
Type: System..::.String
elementId
Type: System..::.String
sortDirection
Type: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SortDirectionEnum
userState
Type: System..::.Object

See Also

ReportServiceClient Class
SortAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ToggleItemAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.ToggleItemAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
ToggleItemAsync(String, String) |
ToggleItemAsync(String, String, Object) |

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ToggleItemAsync Method (String, String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.ToggleItemAsync Method (String, String)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ToggleItemAsync(
    string id,
    string elementId
)
Visual Basic (Declaration)
Public Sub ToggleItemAsync ( _
    id As String, _
    elementId As String _
)
Visual C++
public:
void ToggleItemAsync(
    String^ id,
    String^ elementId
)

Parameters

id
Type: System..::.String
elementId
Type: System..::.String

See Also

ReportServiceClient Class
ToggleItemAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ToggleItemAsync Method (String, String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.ToggleItemAsync Method (String, String, Object)
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ToggleItemAsync(
    string id,
    string elementId,
    Object userState
)
Visual Basic (Declaration)
Public Sub ToggleItemAsync ( _
    id As String, _
    elementId As String, _
    userState As Object _
)
Visual C++
public:
void ToggleItemAsync(
    String^ id,
    String^ elementId,
    Object^ userState
)

Parameters

id
Type: System..::.String
elementId
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceClient Class
ToggleItemAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Properties
ReportServiceClient Class See Also Send Feedback

The ReportServiceClient type exposes the following members.

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( IReportService >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( IReportService >)>).)
ClientCredentials | (Inherited from ClientBase <(Of <( IReportService >)>).)
CookieContainer |
Endpoint | (Inherited from ClientBase <(Of <( IReportService >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( IReportService >)>).)
State | (Inherited from ClientBase <(Of <( IReportService >)>).)

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CookieContainer Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.CookieContainer Property
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public CookieContainer CookieContainer { get; set; }
Visual Basic (Declaration)
Public Property CookieContainer As CookieContainer
Visual C++
public:
property CookieContainer^ CookieContainer {
    CookieContainer^ get ();
    void set (CookieContainer^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceClient Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient Events
ReportServiceClient Class See Also Send Feedback

The ReportServiceClient type exposes the following members.

Events

Name | Description
CloseCompleted |
FindCompleted |
GetDocumentInfoCompleted |
GetPageInfoCompleted |
InitCompleted |
ListExportsFormatsCompleted |
LoadDrillthroughTargetCompleted |
LoadReportCompleted |
OpenCompleted |
RenderCompleted |
SetDataSourcesCredentialsCompleted |
SetParametersCompleted |
SortCompleted |
ToggleItemCompleted |

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CloseCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.CloseCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<AsyncCompletedEventArgs> CloseCompleted
Visual Basic (Declaration)
Public Event CloseCompleted As EventHandler(Of AsyncCompletedEventArgs)
Visual C++
public:
 event EventHandler<AsyncCompletedEventArgs^>^ CloseCompleted {
    void add (EventHandler<AsyncCompletedEventArgs^>^ value);
    void remove (EventHandler<AsyncCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.FindCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<FindCompletedEventArgs> FindCompleted
Visual Basic (Declaration)
Public Event FindCompleted As EventHandler(Of FindCompletedEventArgs)
Visual C++
public:
 event EventHandler<FindCompletedEventArgs^>^ FindCompleted {
    void add (EventHandler<FindCompletedEventArgs^>^ value);
    void remove (EventHandler<FindCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetDocumentInfoCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.GetDocumentInfoCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<GetDocumentInfoCompletedEventArgs> GetDocumentInfoCompleted
Visual Basic (Declaration)
Public Event GetDocumentInfoCompleted As EventHandler(Of GetDocumentInfoCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetDocumentInfoCompletedEventArgs^>^ GetDocumentInfoCompleted {
    void add (EventHandler<GetDocumentInfoCompletedEventArgs^>^ value);
    void remove (EventHandler<GetDocumentInfoCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetPageInfoCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.GetPageInfoCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<GetPageInfoCompletedEventArgs> GetPageInfoCompleted
Visual Basic (Declaration)
Public Event GetPageInfoCompleted As EventHandler(Of GetPageInfoCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetPageInfoCompletedEventArgs^>^ GetPageInfoCompleted {
    void add (EventHandler<GetPageInfoCompletedEventArgs^>^ value);
    void remove (EventHandler<GetPageInfoCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


InitCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.InitCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<AsyncCompletedEventArgs> InitCompleted
Visual Basic (Declaration)
Public Event InitCompleted As EventHandler(Of AsyncCompletedEventArgs)
Visual C++
public:
 event EventHandler<AsyncCompletedEventArgs^>^ InitCompleted {
    void add (EventHandler<AsyncCompletedEventArgs^>^ value);
    void remove (EventHandler<AsyncCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ListExportsFormatsCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.ListExportsFormatsCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<ListExportsFormatsCompletedEventArgs> ListExportsFormatsCompleted
Visual Basic (Declaration)
Public Event ListExportsFormatsCompleted As EventHandler(Of ListExportsFormatsCompletedEventArgs)
Visual C++
public:
 event EventHandler<ListExportsFormatsCompletedEventArgs^>^ ListExportsFormatsCompleted {
    void add (EventHandler<ListExportsFormatsCompletedEventArgs^>^ value);
    void remove (EventHandler<ListExportsFormatsCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadDrillthroughTargetCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.LoadDrillthroughTargetCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<LoadDrillthroughTargetCompletedEventArgs> LoadDrillthroughTargetCompleted
Visual Basic (Declaration)
Public Event LoadDrillthroughTargetCompleted As EventHandler(Of LoadDrillthroughTargetCompletedEventArgs)
Visual C++
public:
 event EventHandler<LoadDrillthroughTargetCompletedEventArgs^>^ LoadDrillthroughTargetCompleted {
    void add (EventHandler<LoadDrillthroughTargetCompletedEventArgs^>^ value);
    void remove (EventHandler<LoadDrillthroughTargetCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


LoadReportCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.LoadReportCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<LoadReportCompletedEventArgs> LoadReportCompleted
Visual Basic (Declaration)
Public Event LoadReportCompleted As EventHandler(Of LoadReportCompletedEventArgs)
Visual C++
public:
 event EventHandler<LoadReportCompletedEventArgs^>^ LoadReportCompleted {
    void add (EventHandler<LoadReportCompletedEventArgs^>^ value);
    void remove (EventHandler<LoadReportCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


OpenCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.OpenCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<AsyncCompletedEventArgs> OpenCompleted
Visual Basic (Declaration)
Public Event OpenCompleted As EventHandler(Of AsyncCompletedEventArgs)
Visual C++
public:
 event EventHandler<AsyncCompletedEventArgs^>^ OpenCompleted {
    void add (EventHandler<AsyncCompletedEventArgs^>^ value);
    void remove (EventHandler<AsyncCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RenderCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.RenderCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<RenderCompletedEventArgs> RenderCompleted
Visual Basic (Declaration)
Public Event RenderCompleted As EventHandler(Of RenderCompletedEventArgs)
Visual C++
public:
 event EventHandler<RenderCompletedEventArgs^>^ RenderCompleted {
    void add (EventHandler<RenderCompletedEventArgs^>^ value);
    void remove (EventHandler<RenderCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetDataSourcesCredentialsCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SetDataSourcesCredentialsCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<SetDataSourcesCredentialsCompletedEventArgs> SetDataSourcesCredentialsCompleted
Visual Basic (Declaration)
Public Event SetDataSourcesCredentialsCompleted As EventHandler(Of SetDataSourcesCredentialsCompletedEventArgs)
Visual C++
public:
 event EventHandler<SetDataSourcesCredentialsCompletedEventArgs^>^ SetDataSourcesCredentialsCompleted {
    void add (EventHandler<SetDataSourcesCredentialsCompletedEventArgs^>^ value);
    void remove (EventHandler<SetDataSourcesCredentialsCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetParametersCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SetParametersCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<SetParametersCompletedEventArgs> SetParametersCompleted
Visual Basic (Declaration)
Public Event SetParametersCompleted As EventHandler(Of SetParametersCompletedEventArgs)
Visual C++
public:
 event EventHandler<SetParametersCompletedEventArgs^>^ SetParametersCompleted {
    void add (EventHandler<SetParametersCompletedEventArgs^>^ value);
    void remove (EventHandler<SetParametersCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SortCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.SortCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<SortCompletedEventArgs> SortCompleted
Visual Basic (Declaration)
Public Event SortCompleted As EventHandler(Of SortCompletedEventArgs)
Visual C++
public:
 event EventHandler<SortCompletedEventArgs^>^ SortCompleted {
    void add (EventHandler<SortCompletedEventArgs^>^ value);
    void remove (EventHandler<SortCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ToggleItemCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceClient..::.ToggleItemCompleted Event
ReportServiceClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<ToggleItemCompletedEventArgs> ToggleItemCompleted
Visual Basic (Declaration)
Public Event ToggleItemCompleted As EventHandler(Of ToggleItemCompletedEventArgs)
Visual C++
public:
 event EventHandler<ToggleItemCompletedEventArgs^>^ ToggleItemCompleted {
    void add (EventHandler<ToggleItemCompletedEventArgs^>^ value);
    void remove (EventHandler<ToggleItemCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ReportServiceResourcesClient : ClientBase<IReportServiceResources>,
    IReportServiceResources
Visual Basic (Declaration)
Public Class ReportServiceResourcesClient _
    Inherits ClientBase(Of IReportServiceResources) _
    Implements IReportServiceResources
Visual C++
public ref class ReportServiceResourcesClient : public ClientBase<IReportServiceResources^>,
    IReportServiceResources

Inheritance Hierarchy

System..::.Object
System.ServiceModel..::.ClientBase <(Of <( IReportServiceResources >)>)
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ReportServiceResourcesClient

See Also

ReportServiceResourcesClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Members
ReportServiceResourcesClient Class Constructors Methods Properties Events See Also Send Feedback

The ReportServiceResourcesClient type exposes the following members.

Constructors

Name | Description
ReportServiceResourcesClient | Overloaded.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
CloseAsync | Overloaded.
CreateChannel | (Overrides ClientBase<(Of <(TChannel>)>)..::.CreateChannel()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportAsync | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
GetFontAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHtmlImageAsync | Overloaded.
GetImageStreamAsync | Overloaded.
GetResourceAsync | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeAsync | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenAsync | Overloaded.
PrintAsync | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
ClientCredentials | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
CookieContainer |
Endpoint | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
State | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)

Events

Name | Description
CloseCompleted |
ExportCompleted |
GetFontCompleted |
GetHtmlImageCompleted |
GetImageStreamCompleted |
GetResourceCompleted |
OpenCompleted |
PrintCompleted |

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Constructor
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
ReportServiceResourcesClient()()() | Initializes a new instance of the ReportServiceResourcesClient class
ReportServiceResourcesClient(String) | Initializes a new instance of the ReportServiceResourcesClient class
ReportServiceResourcesClient(Binding, EndpointAddress) | Initializes a new instance of the ReportServiceResourcesClient class
ReportServiceResourcesClient(String, EndpointAddress) | Initializes a new instance of the ReportServiceResourcesClient class
ReportServiceResourcesClient(String, String) | Initializes a new instance of the ReportServiceResourcesClient class

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Constructor
ReportServiceResourcesClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceResourcesClient class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportServiceResourcesClient()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportServiceResourcesClient()

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Constructor (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Constructor (String)
ReportServiceResourcesClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceResourcesClient class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportServiceResourcesClient(
    string endpointConfigurationName
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String _
)
Visual C++
public:
ReportServiceResourcesClient(
    String^ endpointConfigurationName
)

Parameters

endpointConfigurationName
Type: System..::.String

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Constructor (Binding, EndpointAddress)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Constructor (Binding, EndpointAddress)
ReportServiceResourcesClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceResourcesClient class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportServiceResourcesClient(
    Binding binding,
    EndpointAddress remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    binding As Binding, _
    remoteAddress As EndpointAddress _
)
Visual C++
public:
ReportServiceResourcesClient(
    Binding^ binding,
    EndpointAddress^ remoteAddress
)

Parameters

binding
Type: System.ServiceModel.Channels..::.Binding
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Constructor (String, EndpointAddress)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Constructor (String, EndpointAddress)
ReportServiceResourcesClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceResourcesClient class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportServiceResourcesClient(
    string endpointConfigurationName,
    EndpointAddress remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As EndpointAddress _
)
Visual C++
public:
ReportServiceResourcesClient(
    String^ endpointConfigurationName,
    EndpointAddress^ remoteAddress
)

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Constructor (String, String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Constructor (String, String)
ReportServiceResourcesClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceResourcesClient class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportServiceResourcesClient(
    string endpointConfigurationName,
    string remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As String _
)
Visual C++
public:
ReportServiceResourcesClient(
    String^ endpointConfigurationName,
    String^ remoteAddress
)

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System..::.String

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Methods
ReportServiceResourcesClient Class See Also Send Feedback

The ReportServiceResourcesClient type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
CloseAsync | Overloaded.
CreateChannel | (Overrides ClientBase<(Of <(TChannel>)>)..::.CreateChannel()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportAsync | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
GetFontAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHtmlImageAsync | Overloaded.
GetImageStreamAsync | Overloaded.
GetResourceAsync | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeAsync | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenAsync | Overloaded.
PrintAsync | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CloseAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.CloseAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
CloseAsync()()() |
CloseAsync(Object) |

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CloseAsync Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.CloseAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void CloseAsync()
Visual Basic (Declaration)
Public Sub CloseAsync
Visual C++
public:
void CloseAsync()

See Also

ReportServiceResourcesClient Class
CloseAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CloseAsync Method (Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.CloseAsync Method (Object)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void CloseAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub CloseAsync ( _
    userState As Object _
)
Visual C++
public:
void CloseAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
CloseAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CreateChannel Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.CreateChannel Method
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected override IReportServiceResources CreateChannel()
Visual Basic (Declaration)
Protected Overrides Function CreateChannel As IReportServiceResources
Visual C++
protected:
virtual IReportServiceResources^ CreateChannel() override

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExportAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.ExportAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
ExportAsync(String, String, String) |
ExportAsync(String, String, String, Object) |

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExportAsync Method (String, String, String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.ExportAsync Method (String, String, String)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ExportAsync(
    string id,
    string documentName,
    string format
)
Visual Basic (Declaration)
Public Sub ExportAsync ( _
    id As String, _
    documentName As String, _
    format As String _
)
Visual C++
public:
void ExportAsync(
    String^ id,
    String^ documentName,
    String^ format
)

Parameters

id
Type: System..::.String
documentName
Type: System..::.String
format
Type: System..::.String

See Also

ReportServiceResourcesClient Class
ExportAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExportAsync Method (String, String, String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.ExportAsync Method (String, String, String, Object)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void ExportAsync(
    string id,
    string documentName,
    string format,
    Object userState
)
Visual Basic (Declaration)
Public Sub ExportAsync ( _
    id As String, _
    documentName As String, _
    format As String, _
    userState As Object _
)
Visual C++
public:
void ExportAsync(
    String^ id,
    String^ documentName,
    String^ format,
    Object^ userState
)

Parameters

id
Type: System..::.String
documentName
Type: System..::.String
format
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
ExportAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetFontAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetFontAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
GetFontAsync(String) |
GetFontAsync(String, Object) |

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetFontAsync Method (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetFontAsync Method (String)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetFontAsync(
    string resourceKey
)
Visual Basic (Declaration)
Public Sub GetFontAsync ( _
    resourceKey As String _
)
Visual C++
public:
void GetFontAsync(
    String^ resourceKey
)

Parameters

resourceKey
Type: System..::.String

See Also

ReportServiceResourcesClient Class
GetFontAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetFontAsync Method (String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetFontAsync Method (String, Object)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetFontAsync(
    string resourceKey,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetFontAsync ( _
    resourceKey As String, _
    userState As Object _
)
Visual C++
public:
void GetFontAsync(
    String^ resourceKey,
    Object^ userState
)

Parameters

resourceKey
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
GetFontAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetHtmlImageAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetHtmlImageAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
GetHtmlImageAsync(String, String) |
GetHtmlImageAsync(String, String, Object) |

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetHtmlImageAsync Method (String, String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetHtmlImageAsync Method (String, String)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetHtmlImageAsync(
    string executionId,
    string imageId
)
Visual Basic (Declaration)
Public Sub GetHtmlImageAsync ( _
    executionId As String, _
    imageId As String _
)
Visual C++
public:
void GetHtmlImageAsync(
    String^ executionId,
    String^ imageId
)

Parameters

executionId
Type: System..::.String
imageId
Type: System..::.String

See Also

ReportServiceResourcesClient Class
GetHtmlImageAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetHtmlImageAsync Method (String, String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetHtmlImageAsync Method (String, String, Object)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetHtmlImageAsync(
    string executionId,
    string imageId,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetHtmlImageAsync ( _
    executionId As String, _
    imageId As String, _
    userState As Object _
)
Visual C++
public:
void GetHtmlImageAsync(
    String^ executionId,
    String^ imageId,
    Object^ userState
)

Parameters

executionId
Type: System..::.String
imageId
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
GetHtmlImageAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetImageStreamAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetImageStreamAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
GetImageStreamAsync(String, String) |
GetImageStreamAsync(String, String, Object) |

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetImageStreamAsync Method (String, String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetImageStreamAsync Method (String, String)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetImageStreamAsync(
    string id,
    string resourceId
)
Visual Basic (Declaration)
Public Sub GetImageStreamAsync ( _
    id As String, _
    resourceId As String _
)
Visual C++
public:
void GetImageStreamAsync(
    String^ id,
    String^ resourceId
)

Parameters

id
Type: System..::.String
resourceId
Type: System..::.String

See Also

ReportServiceResourcesClient Class
GetImageStreamAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetImageStreamAsync Method (String, String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetImageStreamAsync Method (String, String, Object)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetImageStreamAsync(
    string id,
    string resourceId,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetImageStreamAsync ( _
    id As String, _
    resourceId As String, _
    userState As Object _
)
Visual C++
public:
void GetImageStreamAsync(
    String^ id,
    String^ resourceId,
    Object^ userState
)

Parameters

id
Type: System..::.String
resourceId
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
GetImageStreamAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetResourceAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetResourceAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
GetResourceAsync(String) |
GetResourceAsync(String, Object) |

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetResourceAsync Method (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetResourceAsync Method (String)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetResourceAsync(
    string culture
)
Visual Basic (Declaration)
Public Sub GetResourceAsync ( _
    culture As String _
)
Visual C++
public:
void GetResourceAsync(
    String^ culture
)

Parameters

culture
Type: System..::.String

See Also

ReportServiceResourcesClient Class
GetResourceAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetResourceAsync Method (String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetResourceAsync Method (String, Object)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void GetResourceAsync(
    string culture,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetResourceAsync ( _
    culture As String, _
    userState As Object _
)
Visual C++
public:
void GetResourceAsync(
    String^ culture,
    Object^ userState
)

Parameters

culture
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
GetResourceAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


OpenAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.OpenAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
OpenAsync()()() |
OpenAsync(Object) |

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


OpenAsync Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.OpenAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void OpenAsync()
Visual Basic (Declaration)
Public Sub OpenAsync
Visual C++
public:
void OpenAsync()

See Also

ReportServiceResourcesClient Class
OpenAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


OpenAsync Method (Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.OpenAsync Method (Object)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void OpenAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub OpenAsync ( _
    userState As Object _
)
Visual C++
public:
void OpenAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
OpenAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PrintAsync Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.PrintAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
PrintAsync(String, String) |
PrintAsync(String, String, Object) |

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PrintAsync Method (String, String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.PrintAsync Method (String, String)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void PrintAsync(
    string id,
    string documentName
)
Visual Basic (Declaration)
Public Sub PrintAsync ( _
    id As String, _
    documentName As String _
)
Visual C++
public:
void PrintAsync(
    String^ id,
    String^ documentName
)

Parameters

id
Type: System..::.String
documentName
Type: System..::.String

See Also

ReportServiceResourcesClient Class
PrintAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PrintAsync Method (String, String, Object)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.PrintAsync Method (String, String, Object)
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public void PrintAsync(
    string id,
    string documentName,
    Object userState
)
Visual Basic (Declaration)
Public Sub PrintAsync ( _
    id As String, _
    documentName As String, _
    userState As Object _
)
Visual C++
public:
void PrintAsync(
    String^ id,
    String^ documentName,
    Object^ userState
)

Parameters

id
Type: System..::.String
documentName
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
PrintAsync Overload
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Properties
ReportServiceResourcesClient Class See Also Send Feedback

The ReportServiceResourcesClient type exposes the following members.

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
ClientCredentials | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
CookieContainer |
Endpoint | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
State | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CookieContainer Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.CookieContainer Property
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public CookieContainer CookieContainer { get; set; }
Visual Basic (Declaration)
Public Property CookieContainer As CookieContainer
Visual C++
public:
property CookieContainer^ CookieContainer {
    CookieContainer^ get ();
    void set (CookieContainer^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportServiceResourcesClient Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient Events
ReportServiceResourcesClient Class See Also Send Feedback

The ReportServiceResourcesClient type exposes the following members.

Events

Name | Description
CloseCompleted |
ExportCompleted |
GetFontCompleted |
GetHtmlImageCompleted |
GetImageStreamCompleted |
GetResourceCompleted |
OpenCompleted |
PrintCompleted |

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


CloseCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.CloseCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<AsyncCompletedEventArgs> CloseCompleted
Visual Basic (Declaration)
Public Event CloseCompleted As EventHandler(Of AsyncCompletedEventArgs)
Visual C++
public:
 event EventHandler<AsyncCompletedEventArgs^>^ CloseCompleted {
    void add (EventHandler<AsyncCompletedEventArgs^>^ value);
    void remove (EventHandler<AsyncCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ExportCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.ExportCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<ExportCompletedEventArgs> ExportCompleted
Visual Basic (Declaration)
Public Event ExportCompleted As EventHandler(Of ExportCompletedEventArgs)
Visual C++
public:
 event EventHandler<ExportCompletedEventArgs^>^ ExportCompleted {
    void add (EventHandler<ExportCompletedEventArgs^>^ value);
    void remove (EventHandler<ExportCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetFontCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetFontCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<GetFontCompletedEventArgs> GetFontCompleted
Visual Basic (Declaration)
Public Event GetFontCompleted As EventHandler(Of GetFontCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetFontCompletedEventArgs^>^ GetFontCompleted {
    void add (EventHandler<GetFontCompletedEventArgs^>^ value);
    void remove (EventHandler<GetFontCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetHtmlImageCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetHtmlImageCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<GetHtmlImageCompletedEventArgs> GetHtmlImageCompleted
Visual Basic (Declaration)
Public Event GetHtmlImageCompleted As EventHandler(Of GetHtmlImageCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetHtmlImageCompletedEventArgs^>^ GetHtmlImageCompleted {
    void add (EventHandler<GetHtmlImageCompletedEventArgs^>^ value);
    void remove (EventHandler<GetHtmlImageCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetImageStreamCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetImageStreamCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<GetImageStreamCompletedEventArgs> GetImageStreamCompleted
Visual Basic (Declaration)
Public Event GetImageStreamCompleted As EventHandler(Of GetImageStreamCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetImageStreamCompletedEventArgs^>^ GetImageStreamCompleted {
    void add (EventHandler<GetImageStreamCompletedEventArgs^>^ value);
    void remove (EventHandler<GetImageStreamCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


GetResourceCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.GetResourceCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<GetResourceCompletedEventArgs> GetResourceCompleted
Visual Basic (Declaration)
Public Event GetResourceCompleted As EventHandler(Of GetResourceCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetResourceCompletedEventArgs^>^ GetResourceCompleted {
    void add (EventHandler<GetResourceCompletedEventArgs^>^ value);
    void remove (EventHandler<GetResourceCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


OpenCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.OpenCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<AsyncCompletedEventArgs> OpenCompleted
Visual Basic (Declaration)
Public Event OpenCompleted As EventHandler(Of AsyncCompletedEventArgs)
Visual C++
public:
 event EventHandler<AsyncCompletedEventArgs^>^ OpenCompleted {
    void add (EventHandler<AsyncCompletedEventArgs^>^ value);
    void remove (EventHandler<AsyncCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PrintCompleted Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceResourcesClient..::.PrintCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<PrintCompletedEventArgs> PrintCompleted
Visual Basic (Declaration)
Public Event PrintCompleted As EventHandler(Of PrintCompletedEventArgs)
Visual C++
public:
 event EventHandler<PrintCompletedEventArgs^>^ PrintCompleted {
    void add (EventHandler<PrintCompletedEventArgs^>^ value);
    void remove (EventHandler<PrintCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SearchDirectionEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchDirectionEnum Enumeration
See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public enum SearchDirectionEnum
Visual Basic (Declaration)
Public Enumeration SearchDirectionEnum
Visual C++
public enum class SearchDirectionEnum

Members

Member name | Description
Forward |
Backward |

See Also

PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SearchResult Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Class
Members See Also Send Feedback
Represents text search results.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class SearchResult : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class SearchResult _
    Implements INotifyPropertyChanged
Visual C++
public ref class SearchResult : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SearchResult

See Also

SearchResult Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SearchResult Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Members
SearchResult Class Constructors Methods Properties Events See Also Send Feedback

The SearchResult type exposes the following members.

Constructors

Name | Description
SearchResult | Initializes a new instance of the SearchResult class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ClientSideControl | Gets or sets control where the required text is located on client side.
ControlIndex |
Direction |
EndPageIndex |
FindText |
FromBegining |
Height |
PageIndex |
Region | Gets ReportRegion the report area where the element with the required text is located.
SearchType |
TextFound |
Width |
X |
Y |

Events

Name | Description
PropertyChanged |

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SearchResult Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Constructor
SearchResult Class See Also Send Feedback
Initializes a new instance of the SearchResult class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SearchResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchResult()

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SearchResult Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Methods
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.RaisePropertyChanged Method
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SearchResult Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Properties
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Properties

Name | Description
ClientSideControl | Gets or sets control where the required text is located on client side.
ControlIndex |
Direction |
EndPageIndex |
FindText |
FromBegining |
Height |
PageIndex |
Region | Gets ReportRegion the report area where the element with the required text is located.
SearchType |
TextFound |
Width |
X |
Y |

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ClientSideControl Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.ClientSideControl Property
SearchResult Class See Also Send Feedback
Gets or sets control where the required text is located on client side.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public Object ClientSideControl { get; set; }
Visual Basic (Declaration)
Public Property ClientSideControl As Object
Visual C++
public:
property Object^ ClientSideControl {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The client side control.

Remarks

It is used for client side search.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ControlIndex Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.ControlIndex Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int ControlIndex { get; set; }
Visual Basic (Declaration)
Public Property ControlIndex As Integer
Visual C++
public:
property int ControlIndex {
    int get ();
    void set (int value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Direction Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.Direction Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SearchDirectionEnum Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As SearchDirectionEnum
Visual C++
public:
property SearchDirectionEnum Direction {
    SearchDirectionEnum get ();
    void set (SearchDirectionEnum value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


EndPageIndex Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.EndPageIndex Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int EndPageIndex { get; set; }
Visual Basic (Declaration)
Public Property EndPageIndex As Integer
Visual C++
public:
property int EndPageIndex {
    int get ();
    void set (int value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FindText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.FindText Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string FindText { get; set; }
Visual Basic (Declaration)
Public Property FindText As String
Visual C++
public:
property String^ FindText {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


FromBegining Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.FromBegining Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool FromBegining { get; set; }
Visual Basic (Declaration)
Public Property FromBegining As Boolean
Visual C++
public:
property bool FromBegining {
    bool get ();
    void set (bool value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Height Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.Height Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PageIndex Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.PageIndex Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int PageIndex { get; set; }
Visual Basic (Declaration)
Public Property PageIndex As Integer
Visual C++
public:
property int PageIndex {
    int get ();
    void set (int value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Region Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.Region Property
SearchResult Class See Also Send Feedback
Gets ReportRegion the report area where the element with the required text is located.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportRegion Region { get; }
Visual Basic (Declaration)
Public ReadOnly Property Region As ReportRegion
Visual C++
public:
property ReportRegion Region {
    ReportRegion get ();
}

Field Value

The report region. The instance of ReportRegion class.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SearchType Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.SearchType Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SearchTypeEnum SearchType { get; set; }
Visual Basic (Declaration)
Public Property SearchType As SearchTypeEnum
Visual C++
public:
property SearchTypeEnum SearchType {
    SearchTypeEnum get ();
    void set (SearchTypeEnum value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


TextFound Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.TextFound Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool TextFound { get; set; }
Visual Basic (Declaration)
Public Property TextFound As Boolean
Visual C++
public:
property bool TextFound {
    bool get ();
    void set (bool value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Width Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.Width Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


X Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.X Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Y Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.Y Property
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SearchResult Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Events
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.PropertyChanged Event
SearchResult Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SearchTypeEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchTypeEnum Enumeration
See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public enum SearchTypeEnum
Visual Basic (Declaration)
Public Enumeration SearchTypeEnum
Visual C++
public enum class SearchTypeEnum

Members

Member name | Description
Reporting |
Shooter |

See Also

PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetDataSourcesCredentialsCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetDataSourcesCredentialsCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class SetDataSourcesCredentialsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class SetDataSourcesCredentialsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class SetDataSourcesCredentialsCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SetDataSourcesCredentialsCompletedEventArgs

See Also

SetDataSourcesCredentialsCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetDataSourcesCredentialsCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetDataSourcesCredentialsCompletedEventArgs Members
SetDataSourcesCredentialsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The SetDataSourcesCredentialsCompletedEventArgs type exposes the following members.

Constructors

Name | Description
SetDataSourcesCredentialsCompletedEventArgs | Initializes a new instance of the SetDataSourcesCredentialsCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SetDataSourcesCredentialsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetDataSourcesCredentialsCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetDataSourcesCredentialsCompletedEventArgs Constructor
SetDataSourcesCredentialsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the SetDataSourcesCredentialsCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SetDataSourcesCredentialsCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
SetDataSourcesCredentialsCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

SetDataSourcesCredentialsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetDataSourcesCredentialsCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetDataSourcesCredentialsCompletedEventArgs Methods
SetDataSourcesCredentialsCompletedEventArgs Class See Also Send Feedback

The SetDataSourcesCredentialsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetDataSourcesCredentialsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetDataSourcesCredentialsCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetDataSourcesCredentialsCompletedEventArgs Properties
SetDataSourcesCredentialsCompletedEventArgs Class See Also Send Feedback

The SetDataSourcesCredentialsCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SetDataSourcesCredentialsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetDataSourcesCredentialsCompletedEventArgs..::.ReportError Property
SetDataSourcesCredentialsCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

SetDataSourcesCredentialsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetDataSourcesCredentialsCompletedEventArgs..::.Result Property
SetDataSourcesCredentialsCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportExecutionInfo Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As ReportExecutionInfo
Visual C++
public:
property ReportExecutionInfo^ Result {
    ReportExecutionInfo^ get ();
}

See Also

SetDataSourcesCredentialsCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetParametersCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetParametersCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class SetParametersCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class SetParametersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class SetParametersCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SetParametersCompletedEventArgs

See Also

SetParametersCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetParametersCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetParametersCompletedEventArgs Members
SetParametersCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The SetParametersCompletedEventArgs type exposes the following members.

Constructors

Name | Description
SetParametersCompletedEventArgs | Initializes a new instance of the SetParametersCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SetParametersCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetParametersCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetParametersCompletedEventArgs Constructor
SetParametersCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the SetParametersCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SetParametersCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
SetParametersCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

SetParametersCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetParametersCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetParametersCompletedEventArgs Methods
SetParametersCompletedEventArgs Class See Also Send Feedback

The SetParametersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SetParametersCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SetParametersCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetParametersCompletedEventArgs Properties
SetParametersCompletedEventArgs Class See Also Send Feedback

The SetParametersCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SetParametersCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ReportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetParametersCompletedEventArgs..::.ReportError Property
SetParametersCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

SetParametersCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SetParametersCompletedEventArgs..::.Result Property
SetParametersCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ReportExecutionInfo Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As ReportExecutionInfo
Visual C++
public:
property ReportExecutionInfo^ Result {
    ReportExecutionInfo^ get ();
}

See Also

SetParametersCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SizeF Structure

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SizeF Structure
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public struct SizeF : INotifyPropertyChanged
Visual Basic (Declaration)
Public Structure SizeF _
    Implements INotifyPropertyChanged
Visual C++
public value class SizeF : INotifyPropertyChanged

See Also

SizeF Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SizeF Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SizeF Members
SizeF Structure Methods Properties Events See Also Send Feedback

The SizeF type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
height |
width |

Events

Name | Description
PropertyChanged |

See Also

SizeF Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SizeF Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SizeF Methods
SizeF Structure See Also Send Feedback

The SizeF type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SizeF Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SizeF Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SizeF Properties
SizeF Structure See Also Send Feedback

The SizeF type exposes the following members.

Properties

Name | Description
height |
width |

See Also

SizeF Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


height Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SizeF..::.height Property
SizeF Structure See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public float height { get; set; }
Visual Basic (Declaration)
Public Property height As Single
Visual C++
public:
property float height {
    float get ();
    void set (float value);
}

See Also

SizeF Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


width Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SizeF..::.width Property
SizeF Structure See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public float width { get; set; }
Visual Basic (Declaration)
Public Property width As Single
Visual C++
public:
property float width {
    float get ();
    void set (float value);
}

See Also

SizeF Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SizeF Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SizeF Events
SizeF Structure See Also Send Feedback

The SizeF type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

SizeF Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SizeF..::.PropertyChanged Event
SizeF Structure See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

SizeF Structure
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SortCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SortCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class SortCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class SortCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class SortCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.SortCompletedEventArgs

See Also

SortCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SortCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SortCompletedEventArgs Members
SortCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The SortCompletedEventArgs type exposes the following members.

Constructors

Name | Description
SortCompletedEventArgs | Initializes a new instance of the SortCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
reportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SortCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SortCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SortCompletedEventArgs Constructor
SortCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the SortCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SortCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
SortCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

SortCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SortCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SortCompletedEventArgs Methods
SortCompletedEventArgs Class See Also Send Feedback

The SortCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SortCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SortCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SortCompletedEventArgs Properties
SortCompletedEventArgs Class See Also Send Feedback

The SortCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
reportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SortCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


reportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SortCompletedEventArgs..::.reportError Property
SortCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase reportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property reportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ reportError {
    ExceptionDetailBase^ get ();
}

See Also

SortCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SortCompletedEventArgs..::.Result Property
SortCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public int Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Integer
Visual C++
public:
property int Result {
    int get ();
}

See Also

SortCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


SortDirectionEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SortDirectionEnum Enumeration
See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public enum SortDirectionEnum
Visual Basic (Declaration)
Public Enumeration SortDirectionEnum
Visual C++
public enum class SortDirectionEnum

Members

Member name | Description
Ascending |
Descending |
None |

See Also

PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ToggleItemCompletedEventArgs Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleItemCompletedEventArgs Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ToggleItemCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class ToggleItemCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class ToggleItemCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ToggleItemCompletedEventArgs

See Also

ToggleItemCompletedEventArgs Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ToggleItemCompletedEventArgs Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleItemCompletedEventArgs Members
ToggleItemCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ToggleItemCompletedEventArgs type exposes the following members.

Constructors

Name | Description
ToggleItemCompletedEventArgs | Initializes a new instance of the ToggleItemCompletedEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
reportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ToggleItemCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ToggleItemCompletedEventArgs Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleItemCompletedEventArgs Constructor
ToggleItemCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the ToggleItemCompletedEventArgs class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ToggleItemCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
ToggleItemCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

ToggleItemCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ToggleItemCompletedEventArgs Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleItemCompletedEventArgs Methods
ToggleItemCompletedEventArgs Class See Also Send Feedback

The ToggleItemCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ToggleItemCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ToggleItemCompletedEventArgs Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleItemCompletedEventArgs Properties
ToggleItemCompletedEventArgs Class See Also Send Feedback

The ToggleItemCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
reportError |
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ToggleItemCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


reportError Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleItemCompletedEventArgs..::.reportError Property
ToggleItemCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ExceptionDetailBase reportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property reportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ reportError {
    ExceptionDetailBase^ get ();
}

See Also

ToggleItemCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Result Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ToggleItemCompletedEventArgs..::.Result Property
ToggleItemCompletedEventArgs Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public bool Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Boolean
Visual C++
public:
property bool Result {
    bool get ();
}

See Also

ToggleItemCompletedEventArgs Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ValidValue Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Class
Members See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class ValidValue : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ValidValue _
    Implements INotifyPropertyChanged
Visual C++
public ref class ValidValue : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ValidValue
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService..::.ReportParameterValue

See Also

ValidValue Members
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ValidValue Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Members
ValidValue Class Constructors Methods Properties Events See Also Send Feedback

The ValidValue type exposes the following members.

Constructors

Name | Description
ValidValue | Initializes a new instance of the ValidValue class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Label |
Value |

Events

Name | Description
PropertyChanged |

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ValidValue Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Constructor
ValidValue Class See Also Send Feedback
Initializes a new instance of the ValidValue class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public ValidValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ValidValue()

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ValidValue Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Methods
ValidValue Class See Also Send Feedback

The ValidValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue..::.RaisePropertyChanged Method
ValidValue Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ValidValue Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Properties
ValidValue Class See Also Send Feedback

The ValidValue type exposes the following members.

Properties

Name | Description
Label |
Value |

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Label Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue..::.Label Property
ValidValue Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Label { get; set; }
Visual Basic (Declaration)
Public Property Label As String
Visual C++
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


Value Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue..::.Value Property
ValidValue Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


ValidValue Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Events
ValidValue Class See Also Send Feedback

The ValidValue type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PropertyChanged Event

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue..::.PropertyChanged Event
ValidValue Class See Also Send Feedback

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.ReportService
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Client.ReportService Namespace


PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace
Send Feedback

Classes

Class | Description
IsolatedStorageUtils | A static class which includes methods for working with isolated cash data storage.
SilverlightInitParamsHelper | Utility class to parse and extract an initial parameters of the ReportViewer

Enumerations

Enumeration | Description
DebugModeEnum | Describes a debub mode.


DebugModeEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DebugModeEnum Enumeration
See Also Send Feedback
Describes a debub mode.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Utils
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public enum DebugModeEnum
Visual Basic (Declaration)
Public Enumeration DebugModeEnum
Visual C++
public enum class DebugModeEnum

Members

Member name | Description
Full | Full debug information.
Simple | Short debug information.

See Also

PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


IsolatedStorageUtils Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IsolatedStorageUtils Class
Members See Also Send Feedback
A static class which includes methods for working with isolated cash data storage.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Utils
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static class IsolatedStorageUtils
Visual Basic (Declaration)
Public NotInheritable Class IsolatedStorageUtils
Visual C++
public ref class IsolatedStorageUtils abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.Utils..::.IsolatedStorageUtils

See Also

IsolatedStorageUtils Members
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


IsolatedStorageUtils Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IsolatedStorageUtils Members
IsolatedStorageUtils Class Methods See Also Send Feedback

The IsolatedStorageUtils type exposes the following members.

Methods

Name | Description
GetNewQuota | Gets a new quota value for a storage.
IncreaseQuotaTo | Increases a quota value for a storage file.
SafeCreateFile | Creates storage file and writes data in it.
SafeWrite | Writes cash data in the storage.

See Also

IsolatedStorageUtils Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


IsolatedStorageUtils Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IsolatedStorageUtils Methods
IsolatedStorageUtils Class See Also Send Feedback

The IsolatedStorageUtils type exposes the following members.

Methods

Name | Description
GetNewQuota | Gets a new quota value for a storage.
IncreaseQuotaTo | Increases a quota value for a storage file.
SafeCreateFile | Creates storage file and writes data in it.
SafeWrite | Writes cash data in the storage.

See Also

IsolatedStorageUtils Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


GetNewQuota Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IsolatedStorageUtils..::.GetNewQuota Method
IsolatedStorageUtils Class See Also Send Feedback
Gets a new quota value for a storage.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Utils
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static long GetNewQuota(
    IsolatedStorageFile storage,
    long needSize
)
Visual Basic (Declaration)
Public Shared Function GetNewQuota ( _
    storage As IsolatedStorageFile, _
    needSize As Long _
) As Long
Visual C++
public:
static long long GetNewQuota(
    IsolatedStorageFile^ storage,
    long long needSize
)

Parameters

storage
Type: System.IO.IsolatedStorage..::.IsolatedStorageFile
The storage.
needSize
Type: System..::.Int64
The needed quota size.

Return Value

See Also

IsolatedStorageUtils Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


IncreaseQuotaTo Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IsolatedStorageUtils..::.IncreaseQuotaTo Method
IsolatedStorageUtils Class See Also Send Feedback
Increases a quota value for a storage file.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Utils
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static bool IncreaseQuotaTo(
    IsolatedStorageFile storage,
    long needSize
)
Visual Basic (Declaration)
Public Shared Function IncreaseQuotaTo ( _
    storage As IsolatedStorageFile, _
    needSize As Long _
) As Boolean
Visual C++
public:
static bool IncreaseQuotaTo(
    IsolatedStorageFile^ storage,
    long long needSize
)

Parameters

storage
Type: System.IO.IsolatedStorage..::.IsolatedStorageFile
The storage.
needSize
Type: System..::.Int64
The needed quota size.

Return Value

See Also

IsolatedStorageUtils Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


SafeCreateFile Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IsolatedStorageUtils..::.SafeCreateFile Method
IsolatedStorageUtils Class See Also Send Feedback
Creates storage file and writes data in it.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Utils
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static bool SafeCreateFile(
    IsolatedStorageFile storage,
    string filePath,
    byte[] data
)
Visual Basic (Declaration)
Public Shared Function SafeCreateFile ( _
    storage As IsolatedStorageFile, _
    filePath As String, _
    data As Byte() _
) As Boolean
Visual C++
public:
static bool SafeCreateFile(
    IsolatedStorageFile^ storage,
    String^ filePath,
    array<unsigned char>^ data
)

Parameters

storage
Type: System.IO.IsolatedStorage..::.IsolatedStorageFile
The storage.
filePath
Type: System..::.String
The file path.
data
Type: array< System..::.Byte >[]()[]
The data.

Return Value

See Also

IsolatedStorageUtils Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


SafeWrite Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IsolatedStorageUtils..::.SafeWrite Method
IsolatedStorageUtils Class See Also Send Feedback
Writes cash data in the storage.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Utils
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public static bool SafeWrite(
    IsolatedStorageFile storage,
    IsolatedStorageFileStream stream,
    byte[] buffer,
    int offset,
    int count
)
Visual Basic (Declaration)
Public Shared Function SafeWrite ( _
    storage As IsolatedStorageFile, _
    stream As IsolatedStorageFileStream, _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Boolean
Visual C++
public:
static bool SafeWrite(
    IsolatedStorageFile^ storage,
    IsolatedStorageFileStream^ stream,
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

storage
Type: System.IO.IsolatedStorage..::.IsolatedStorageFile
The storage.
stream
Type: System.IO.IsolatedStorage..::.IsolatedStorageFileStream
The stream.
buffer
Type: array< System..::.Byte >[]()[]
The buffer.
offset
Type: System..::.Int32
The offset.
count
Type: System..::.Int32
The count.

Return Value

See Also

IsolatedStorageUtils Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


SilverlightInitParamsHelper Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SilverlightInitParamsHelper Class
Members See Also Send Feedback
Utility class to parse and extract an initial parameters of the ReportViewer

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Utils
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public class SilverlightInitParamsHelper
Visual Basic (Declaration)
Public Class SilverlightInitParamsHelper
Visual C++
public ref class SilverlightInitParamsHelper

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Client.Utils..::.SilverlightInitParamsHelper

See Also

SilverlightInitParamsHelper Members
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


SilverlightInitParamsHelper Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SilverlightInitParamsHelper Members
SilverlightInitParamsHelper Class Constructors Methods Properties See Also Send Feedback

The SilverlightInitParamsHelper type exposes the following members.

Constructors

Name | Description
SilverlightInitParamsHelper | Initializes a new instance of the SilverlightInitParamsHelper class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DebugMode | Gets or sets the debug mode.
ServiceUrl | Gets or sets the WCF Service URL.

See Also

SilverlightInitParamsHelper Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


SilverlightInitParamsHelper Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SilverlightInitParamsHelper Constructor
SilverlightInitParamsHelper Class See Also Send Feedback
Initializes a new instance of the SilverlightInitParamsHelper class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Utils
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public SilverlightInitParamsHelper(
    string initParams
)
Visual Basic (Declaration)
Public Sub New ( _
    initParams As String _
)
Visual C++
public:
SilverlightInitParamsHelper(
    String^ initParams
)

Parameters

initParams
Type: System..::.String
An initial parameters.

See Also

SilverlightInitParamsHelper Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


SilverlightInitParamsHelper Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SilverlightInitParamsHelper Methods
SilverlightInitParamsHelper Class See Also Send Feedback

The SilverlightInitParamsHelper type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SilverlightInitParamsHelper Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


SilverlightInitParamsHelper Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SilverlightInitParamsHelper Properties
SilverlightInitParamsHelper Class See Also Send Feedback

The SilverlightInitParamsHelper type exposes the following members.

Properties

Name | Description
DebugMode | Gets or sets the debug mode.
ServiceUrl | Gets or sets the WCF Service URL.

See Also

SilverlightInitParamsHelper Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


DebugMode Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SilverlightInitParamsHelper..::.DebugMode Property
SilverlightInitParamsHelper Class See Also Send Feedback
Gets or sets the debug mode.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Utils
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public DebugModeEnum DebugMode { get; set; }
Visual Basic (Declaration)
Public Property DebugMode As DebugModeEnum
Visual C++
public:
property DebugModeEnum DebugMode {
    DebugModeEnum get ();
    void set (DebugModeEnum value);
}

See Also

SilverlightInitParamsHelper Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


ServiceUrl Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SilverlightInitParamsHelper..::.ServiceUrl Property
SilverlightInitParamsHelper Class See Also Send Feedback
Gets or sets the WCF Service URL.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Client.Utils
Assembly: PerpetuumSoft.ReportingServices.Viewer.Client (in PerpetuumSoft.ReportingServices.Viewer.Client.dll) Version: 1.0.0.0

Syntax

C#
public string ServiceUrl { get; set; }
Visual Basic (Declaration)
Public Property ServiceUrl As String
Visual C++
public:
property String^ ServiceUrl {
    String^ get ();
    void set (String^ value);
}

See Also

SilverlightInitParamsHelper Class
PerpetuumSoft.ReportingServices.Viewer.Client.Utils Namespace


PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace
Send Feedback
It is used as bridge between Xaml Rendering Extension and Reporting Services server.

Classes

Class | Description
DocumentEx | Represents the metadata of a document.
DocumentInfoEx | Represents a document information.
PageInfoEx | Represents page information of a document.
ResourceEx | Represents the metadata of a report resource.

Enumerations

Enumeration | Description
DocumentExTypeEnum | Describes a type of a document.


DocumentEx Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx Class
Members See Also Send Feedback
Represents the metadata of a document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class DocumentEx
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DocumentEx
Visual C++
[SerializableAttribute]
public ref class DocumentEx

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink..::.DocumentEx

See Also

DocumentEx Members
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentEx Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx Members
DocumentEx Class Constructors Methods Properties See Also Send Feedback

The DocumentEx type exposes the following members.

Constructors

Name | Description
DocumentEx | Initializes a new instance.

Methods

Name | Description
AddResource | Adds a resource into dictionary.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsResourceExist | Checks whether an resource added into dictionary.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentId | Gets identifier of the document.
DocumentInfo | Gets document information (see DocumentInfoEx class).
DocumentType | Gets or set type of the document.
FindDictionary | Gets the search dictionary.
LinkDictionary | Gets the search dictionary.
Pages | Gets Dictionary<(Of <(TKey, TValue>)>) of pages of the document (see PageInfoEx class).
Resources | Gets Dictionary<(Of <(TKey, TValue>)>) of resources of the document (see ResourceEx class).

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentEx Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx Constructor
DocumentEx Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentEx(
    string documentTitle,
    float pageWidth,
    float pageHeight
)
Visual Basic (Declaration)
Public Sub New ( _
    documentTitle As String, _
    pageWidth As Single, _
    pageHeight As Single _
)
Visual C++
public:
DocumentEx(
    String^ documentTitle,
    float pageWidth,
    float pageHeight
)

Parameters

documentTitle
Type: System..::.String
Document title.
pageWidth
Type: System..::.Single
Document Page Width
pageHeight
Type: System..::.Single
Document Page Height

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentEx Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx Methods
DocumentEx Class See Also Send Feedback

The DocumentEx type exposes the following members.

Methods

Name | Description
AddResource | Adds a resource into dictionary.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsResourceExist | Checks whether an resource added into dictionary.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


AddResource Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx..::.AddResource Method
DocumentEx Class See Also Send Feedback
Adds a resource into dictionary.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddResource(
    ResourceEx resource
)
Visual Basic (Declaration)
Public Sub AddResource ( _
    resource As ResourceEx _
)
Visual C++
public:
void AddResource(
    ResourceEx^ resource
)

Parameters

resource
Type: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink..::.ResourceEx
ResourceEx class.

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


IsResourceExist Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx..::.IsResourceExist Method
DocumentEx Class See Also Send Feedback
Checks whether an resource added into dictionary.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsResourceExist(
    string resource_id
)
Visual Basic (Declaration)
Public Function IsResourceExist ( _
    resource_id As String _
) As Boolean
Visual C++
public:
bool IsResourceExist(
    String^ resource_id
)

Parameters

resource_id
Type: System..::.String
Identifier of the resource

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentEx Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx Properties
DocumentEx Class See Also Send Feedback

The DocumentEx type exposes the following members.

Properties

Name | Description
DocumentId | Gets identifier of the document.
DocumentInfo | Gets document information (see DocumentInfoEx class).
DocumentType | Gets or set type of the document.
FindDictionary | Gets the search dictionary.
LinkDictionary | Gets the search dictionary.
Pages | Gets Dictionary<(Of <(TKey, TValue>)>) of pages of the document (see PageInfoEx class).
Resources | Gets Dictionary<(Of <(TKey, TValue>)>) of resources of the document (see ResourceEx class).

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentId Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx..::.DocumentId Property
DocumentEx Class See Also Send Feedback
Gets identifier of the document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DocumentId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
}

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentInfo Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx..::.DocumentInfo Property
DocumentEx Class See Also Send Feedback
Gets document information (see DocumentInfoEx class).

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentInfoEx DocumentInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentInfo As DocumentInfoEx
Visual C++
public:
property DocumentInfoEx^ DocumentInfo {
    DocumentInfoEx^ get ();
}

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentType Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx..::.DocumentType Property
DocumentEx Class See Also Send Feedback
Gets or set type of the document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentExTypeEnum DocumentType { get; set; }
Visual Basic (Declaration)
Public Property DocumentType As DocumentExTypeEnum
Visual C++
public:
property DocumentExTypeEnum DocumentType {
    DocumentExTypeEnum get ();
    void set (DocumentExTypeEnum value);
}

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


FindDictionary Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx..::.FindDictionary Property
DocumentEx Class See Also Send Feedback
Gets the search dictionary.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Dictionary<int, Dictionary<string, int>> FindDictionary { get; }
Visual Basic (Declaration)
Public ReadOnly Property FindDictionary As Dictionary(Of Integer, Dictionary(Of String, Integer))
Visual C++
public:
property Dictionary<int, Dictionary<String^, int>^>^ FindDictionary {
    Dictionary<int, Dictionary<String^, int>^>^ get ();
}

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


LinkDictionary Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx..::.LinkDictionary Property
DocumentEx Class See Also Send Feedback
Gets the search dictionary.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Dictionary<int, Dictionary<string, int>> LinkDictionary { get; }
Visual Basic (Declaration)
Public ReadOnly Property LinkDictionary As Dictionary(Of Integer, Dictionary(Of String, Integer))
Visual C++
public:
property Dictionary<int, Dictionary<String^, int>^>^ LinkDictionary {
    Dictionary<int, Dictionary<String^, int>^>^ get ();
}

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


Pages Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx..::.Pages Property
DocumentEx Class See Also Send Feedback
Gets Dictionary<(Of <(TKey, TValue>)>) of pages of the document (see PageInfoEx class).

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Dictionary<int, PageInfoEx> Pages { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pages As Dictionary(Of Integer, PageInfoEx)
Visual C++
public:
property Dictionary<int, PageInfoEx^>^ Pages {
    Dictionary<int, PageInfoEx^>^ get ();
}

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


Resources Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentEx..::.Resources Property
DocumentEx Class See Also Send Feedback
Gets Dictionary<(Of <(TKey, TValue>)>) of resources of the document (see ResourceEx class).

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Dictionary<string, ResourceEx> Resources { get; }
Visual Basic (Declaration)
Public ReadOnly Property Resources As Dictionary(Of String, ResourceEx)
Visual C++
public:
property Dictionary<String^, ResourceEx^>^ Resources {
    Dictionary<String^, ResourceEx^>^ get ();
}

See Also

DocumentEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentExTypeEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentExTypeEnum Enumeration
See Also Send Feedback
Describes a type of a document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DocumentExTypeEnum
Visual Basic (Declaration)
Public Enumeration DocumentExTypeEnum
Visual C++
public enum class DocumentExTypeEnum

Members

Member name | Description
Error | An error document.
Report | An ordinary document.

See Also

PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentInfoEx Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfoEx Class
Members See Also Send Feedback
Represents a document information.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class DocumentInfoEx
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DocumentInfoEx
Visual C++
[SerializableAttribute]
public ref class DocumentInfoEx

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink..::.DocumentInfoEx

See Also

DocumentInfoEx Members
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentInfoEx Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfoEx Members
DocumentInfoEx Class Constructors Methods Properties See Also Send Feedback

The DocumentInfoEx type exposes the following members.

Constructors

Name | Description
DocumentInfoEx | Initializes a new instance of the DocumentInfoEx class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PagesSizes | Gets or sets list of pages sizes.
Title | Gets or sets the title of a document.

See Also

DocumentInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentInfoEx Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfoEx Constructor
DocumentInfoEx Class See Also Send Feedback
Initializes a new instance of the DocumentInfoEx class

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentInfoEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentInfoEx()

See Also

DocumentInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentInfoEx Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfoEx Methods
DocumentInfoEx Class See Also Send Feedback

The DocumentInfoEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentInfoEx Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfoEx Properties
DocumentInfoEx Class See Also Send Feedback

The DocumentInfoEx type exposes the following members.

Properties

Name | Description
PagesSizes | Gets or sets list of pages sizes.
Title | Gets or sets the title of a document.

See Also

DocumentInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


PagesSizes Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfoEx..::.PagesSizes Property
DocumentInfoEx Class See Also Send Feedback
Gets or sets list of pages sizes.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SizeF[] PagesSizes { get; set; }
Visual Basic (Declaration)
Public Property PagesSizes As SizeF()
Visual C++
public:
property array<SizeF>^ PagesSizes {
    array<SizeF>^ get ();
    void set (array<SizeF>^ value);
}

See Also

DocumentInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


Title Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfoEx..::.Title Property
DocumentInfoEx Class See Also Send Feedback
Gets or sets the title of a document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


PageInfoEx Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfoEx Class
Members See Also Send Feedback
Represents page information of a document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class PageInfoEx
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PageInfoEx
Visual C++
[SerializableAttribute]
public ref class PageInfoEx

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink..::.PageInfoEx

See Also

PageInfoEx Members
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


PageInfoEx Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfoEx Members
PageInfoEx Class Constructors Methods Properties See Also Send Feedback

The PageInfoEx type exposes the following members.

Constructors

Name | Description
PageInfoEx | Initializes a new instance of the PageInfoEx class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentId | Gets or sets an identifier of the document.
PageNumber | Gets or sets page number.
XamlPage | Gets or sets bytes array of the page XAML content.

See Also

PageInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


PageInfoEx Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfoEx Constructor
PageInfoEx Class See Also Send Feedback
Initializes a new instance of the PageInfoEx class

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageInfoEx()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageInfoEx()

See Also

PageInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


PageInfoEx Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfoEx Methods
PageInfoEx Class See Also Send Feedback

The PageInfoEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


PageInfoEx Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfoEx Properties
PageInfoEx Class See Also Send Feedback

The PageInfoEx type exposes the following members.

Properties

Name | Description
DocumentId | Gets or sets an identifier of the document.
PageNumber | Gets or sets page number.
XamlPage | Gets or sets bytes array of the page XAML content.

See Also

PageInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


DocumentId Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfoEx..::.DocumentId Property
PageInfoEx Class See Also Send Feedback
Gets or sets an identifier of the document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DocumentId { get; set; }
Visual Basic (Declaration)
Public Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
    void set (String^ value);
}

See Also

PageInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


PageNumber Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfoEx..::.PageNumber Property
PageInfoEx Class See Also Send Feedback
Gets or sets page number.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

PageInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


XamlPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfoEx..::.XamlPage Property
PageInfoEx Class See Also Send Feedback
Gets or sets bytes array of the page XAML content.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte[] XamlPage { get; set; }
Visual Basic (Declaration)
Public Property XamlPage As Byte()
Visual C++
public:
property array<unsigned char>^ XamlPage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

PageInfoEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


ResourceEx Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ResourceEx Class
Members See Also Send Feedback
Represents the metadata of a report resource.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ResourceEx
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ResourceEx
Visual C++
[SerializableAttribute]
public ref class ResourceEx

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink..::.ResourceEx

See Also

ResourceEx Members
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


ResourceEx Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ResourceEx Members
ResourceEx Class Constructors Methods Properties See Also Send Feedback

The ResourceEx type exposes the following members.

Constructors

Name | Description
ResourceEx | Initalizes a new instance.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MimeType | Gets or sets a MimeType of the resource.
ResourceData | Gets or sets a data for the resource
ResourceID | Gets or sets an unique identifier of the resource.

See Also

ResourceEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


ResourceEx Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ResourceEx Constructor
ResourceEx Class See Also Send Feedback
Initalizes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceEx(
    string resourceID,
    string mimeType,
    byte[] resourceData
)
Visual Basic (Declaration)
Public Sub New ( _
    resourceID As String, _
    mimeType As String, _
    resourceData As Byte() _
)
Visual C++
public:
ResourceEx(
    String^ resourceID,
    String^ mimeType,
    array<unsigned char>^ resourceData
)

Parameters

resourceID
Type: System..::.String
Identifier of the Resource.
mimeType
Type: System..::.String
MimeType of the resource.
resourceData
Type: array< System..::.Byte >[]()[]
Resource data.

See Also

ResourceEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


ResourceEx Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ResourceEx Methods
ResourceEx Class See Also Send Feedback

The ResourceEx type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResourceEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


ResourceEx Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ResourceEx Properties
ResourceEx Class See Also Send Feedback

The ResourceEx type exposes the following members.

Properties

Name | Description
MimeType | Gets or sets a MimeType of the resource.
ResourceData | Gets or sets a data for the resource
ResourceID | Gets or sets an unique identifier of the resource.

See Also

ResourceEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


MimeType Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ResourceEx..::.MimeType Property
ResourceEx Class See Also Send Feedback
Gets or sets a MimeType of the resource.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MimeType { get; set; }
Visual Basic (Declaration)
Public Property MimeType As String
Visual C++
public:
property String^ MimeType {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


ResourceData Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ResourceEx..::.ResourceData Property
ResourceEx Class See Also Send Feedback
Gets or sets a data for the resource

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte[] ResourceData { get; set; }
Visual Basic (Declaration)
Public Property ResourceData As Byte()
Visual C++
public:
property array<unsigned char>^ ResourceData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

ResourceEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


ResourceID Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ResourceEx..::.ResourceID Property
ResourceEx Class See Also Send Feedback
Gets or sets an unique identifier of the resource.

Namespace: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink
Assembly: PerpetuumSoft.ReportingServices.Viewer.ExtensionLink (in PerpetuumSoft.ReportingServices.Viewer.ExtensionLink.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ResourceID { get; set; }
Visual Basic (Declaration)
Public Property ResourceID As String
Visual C++
public:
property String^ ResourceID {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceEx Class
PerpetuumSoft.ReportingServices.Viewer.ExtensionLink Namespace


PerpetuumSoft.ReportingServices.Viewer.Server Namespace

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PerpetuumSoft.ReportingServices.Viewer.Server Namespace
Send Feedback

Classes

Class | Description
CoreLogger | Utility class for logging server activity.
DocumentInfo | Represents a document data.
ExceptionBuilder | Utility class for generated some helpful exeption.
ExceptionDetailBase | Represents a basic class for all exceptions wrappers generated by server.
ExecutionCacheObject | Represents the cache object to the stored data for the report execution.
ExecutionNotFoundException | Represents ExecutionNotFoundException exception.
ExecutionNotFoundExceptionDetail | Exceptions are generated when the required execution is not found.
ExecutionOutOfCacheException | Represents ExecutionOutOfCacheException exception.
FontsProvider | Represents a set of methods for the work with fonts.
InvalidParametersException | Represents an InvalidParametersException exception.
InvalidParametersExceptionDetail | Exceptions are generated when parameters invalid.
NoCachedDocumentException | Represents NoCachedDocumentException exeption.
NoCachedDocumentExceptionDetail | Exceptions are generated when the required document is not found in cache.
NoDocumentException | Represents NoDocumentException exeption.
NoDocumentExceptionDetail | Exceptions are generated when the required document is not found.
Packaging | Contains helper methods to compress or decompress a stream
PageInfo | Represents a page metadata.
ProcessingExceptionDetail | Exceptions are generated when the Microsoft SQL Reporting Services throws a processing exception.
ReportDataSource | Represents the name of a data source and the prompt to display to a user.
ReportDataSourceCredential | Represents report data source credentials.
ReportExecutionInfo | Describes the state of the current report execution.
ReportParameter | Represents a report parameter.
ReportParameterValue | Represents data that is used in parameterized reports or in delivery extension settings.
ReportProcessingException | Represents ReportProcessingException exeption.
ReportService | Represents service for report generation and getting data about the generated report.
ReportServiceRemote | Represents service for report generation and getting data about generated report. Remote mode.
SearchResult | Represents text search results.
ValidValue | Represents a valid value for an extension setting.

Structures

Structure | Description
FindOptions | Represents data for search.

Interfaces

Interface | Description
IReportCache | Exposes a method for working with cache.
IReportService | Exposes a method for getting report.
IReportServiceResources | Exposes a method for report resources getting.

Enumerations

Enumeration | Description
ExportsEnum | Specifies all valid exports formats.
ParameterStateEnum | Specifies the state of a parameter.
ParameterTypeEnum | Specifies the data type of a parameter.
SearchDirectionEnum | Specifies search direction.
SearchTypeEnum | Specifies a search type.
SortDirectionEnum | Specifies sorting directions.


CoreLogger Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CoreLogger Class
Members See Also Send Feedback
Utility class for logging server activity.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CoreLogger
Visual Basic (Declaration)
Public Class CoreLogger
Visual C++
public ref class CoreLogger

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.CoreLogger

See Also

CoreLogger Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CoreLogger Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CoreLogger Members
CoreLogger Class Constructors Methods See Also Send Feedback

The CoreLogger type exposes the following members.

Constructors

Name | Description
CoreLogger | Initializes a new instance of the CoreLogger class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Error | Server log error.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Info | Log information of server activity.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetLogMode | Sets a log mode.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CoreLogger Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CoreLogger Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CoreLogger Constructor
CoreLogger Class See Also Send Feedback
Initializes a new instance of the CoreLogger class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CoreLogger()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CoreLogger()

See Also

CoreLogger Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CoreLogger Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
CoreLogger Methods
CoreLogger Class See Also Send Feedback

The CoreLogger type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Error | Server log error.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Info | Log information of server activity.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetLogMode | Sets a log mode.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CoreLogger Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Error Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CoreLogger..::.Error Method
CoreLogger Class See Also Send Feedback
Server log error.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Error(
    string methodName,
    Exception exception
)
Visual Basic (Declaration)
Public Shared Sub Error ( _
    methodName As String, _
    exception As Exception _
)
Visual C++
public:
static void Error(
    String^ methodName,
    Exception^ exception
)

Parameters

methodName
Type: System..::.String
Server method name
exception
Type: System..::.Exception
Exception class.

See Also

CoreLogger Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Info Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CoreLogger..::.Info Method
CoreLogger Class See Also Send Feedback
Log information of server activity.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Info(
    string methodName,
    string message
)
Visual Basic (Declaration)
Public Shared Sub Info ( _
    methodName As String, _
    message As String _
)
Visual C++
public:
static void Info(
    String^ methodName,
    String^ message
)

Parameters

methodName
Type: System..::.String
Server method name.
message
Type: System..::.String
Message to log.

See Also

CoreLogger Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SetLogMode Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
CoreLogger..::.SetLogMode Method
CoreLogger Class See Also Send Feedback
Sets a log mode.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SetLogMode(
    bool enable
)
Visual Basic (Declaration)
Public Shared Sub SetLogMode ( _
    enable As Boolean _
)
Visual C++
public:
static void SetLogMode(
    bool enable
)

Parameters

enable
Type: System..::.Boolean
true if the log mode is enabled, otherwise false.

See Also

CoreLogger Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DocumentInfo Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Class
Members See Also Send Feedback
Represents a document data.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class DocumentInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DocumentInfo
Visual C++
[SerializableAttribute]
public ref class DocumentInfo

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.DocumentInfo

See Also

DocumentInfo Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DocumentInfo Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Members
DocumentInfo Class Constructors Methods Properties See Also Send Feedback

The DocumentInfo type exposes the following members.

Constructors

Name | Description
DocumentInfo | Initializes a new instance of the DocumentInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PagesSizes | Gets or sets list of pages sizes.
Title | Gets or sets a document title.

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DocumentInfo Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Constructor
DocumentInfo Class See Also Send Feedback
Initializes a new instance of the DocumentInfo class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentInfo()

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DocumentInfo Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Methods
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DocumentInfo Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo Properties
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Properties

Name | Description
PagesSizes | Gets or sets list of pages sizes.
Title | Gets or sets a document title.

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


PagesSizes Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo..::.PagesSizes Property
DocumentInfo Class See Also Send Feedback
Gets or sets list of pages sizes.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SizeF[] PagesSizes { get; set; }
Visual Basic (Declaration)
Public Property PagesSizes As SizeF()
Visual C++
public:
property array<SizeF>^ PagesSizes {
    array<SizeF>^ get ();
    void set (array<SizeF>^ value);
}

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Title Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
DocumentInfo..::.Title Property
DocumentInfo Class See Also Send Feedback
Gets or sets a document title.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExceptionBuilder Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionBuilder Class
Members See Also Send Feedback
Utility class for generated some helpful exeption.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class ExceptionBuilder
Visual Basic (Declaration)
Public NotInheritable Class ExceptionBuilder
Visual C++
public ref class ExceptionBuilder abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionBuilder

See Also

ExceptionBuilder Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExceptionBuilder Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionBuilder Members
ExceptionBuilder Class Methods See Also Send Feedback

The ExceptionBuilder type exposes the following members.

Methods

Name | Description
DocumentNotFound | Generates DocumentNotFound exception.
DocumentOutOfCache | Generates DocumentOutOfCache exception.
ExecutionOutOfCache | Generates ExecutionOutOfCache exception.
GetConcreteException | Parses an exception and generates new exception if it is SoapException.

See Also

ExceptionBuilder Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExceptionBuilder Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionBuilder Methods
ExceptionBuilder Class See Also Send Feedback

The ExceptionBuilder type exposes the following members.

Methods

Name | Description
DocumentNotFound | Generates DocumentNotFound exception.
DocumentOutOfCache | Generates DocumentOutOfCache exception.
ExecutionOutOfCache | Generates ExecutionOutOfCache exception.
GetConcreteException | Parses an exception and generates new exception if it is SoapException.

See Also

ExceptionBuilder Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DocumentNotFound Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionBuilder..::.DocumentNotFound Method
ExceptionBuilder Class See Also Send Feedback
Generates DocumentNotFound exception.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Exception DocumentNotFound()
Visual Basic (Declaration)
Public Shared Function DocumentNotFound As Exception
Visual C++
public:
static Exception^ DocumentNotFound()

Return Value

NoDocumentException class.

See Also

ExceptionBuilder Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DocumentOutOfCache Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionBuilder..::.DocumentOutOfCache Method
ExceptionBuilder Class See Also Send Feedback
Generates DocumentOutOfCache exception.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Exception DocumentOutOfCache()
Visual Basic (Declaration)
Public Shared Function DocumentOutOfCache As Exception
Visual C++
public:
static Exception^ DocumentOutOfCache()

Return Value

NoCachedDocumentException class.

See Also

ExceptionBuilder Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionOutOfCache Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionBuilder..::.ExecutionOutOfCache Method
ExceptionBuilder Class See Also Send Feedback
Generates ExecutionOutOfCache exception.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Exception ExecutionOutOfCache()
Visual Basic (Declaration)
Public Shared Function ExecutionOutOfCache As Exception
Visual C++
public:
static Exception^ ExecutionOutOfCache()

Return Value

ExecutionOutOfCacheException class.

See Also

ExceptionBuilder Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetConcreteException Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionBuilder..::.GetConcreteException Method
ExceptionBuilder Class See Also Send Feedback
Parses an exception and generates new exception if it is SoapException.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Exception GetConcreteException(
    Exception exception
)
Visual Basic (Declaration)
Public Shared Function GetConcreteException ( _
    exception As Exception _
) As Exception
Visual C++
public:
static Exception^ GetConcreteException(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
A exception to parse.

Return Value

A Exception class.

See Also

ExceptionBuilder Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExceptionDetailBase Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Class
Members See Also Send Feedback
Represents a basic class for all exceptions wrappers generated by server.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ExceptionDetailBase
Visual Basic (Declaration)
Public Class ExceptionDetailBase
Visual C++
public ref class ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExecutionNotFoundExceptionDetail
PerpetuumSoft.ReportingServices.Viewer.Server..::.InvalidParametersExceptionDetail
PerpetuumSoft.ReportingServices.Viewer.Server..::.NoCachedDocumentExceptionDetail
PerpetuumSoft.ReportingServices.Viewer.Server..::.NoDocumentExceptionDetail
PerpetuumSoft.ReportingServices.Viewer.Server..::.ProcessingExceptionDetail

See Also

ExceptionDetailBase Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExceptionDetailBase Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Members
ExceptionDetailBase Class Constructors Methods Properties See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Constructors

Name | Description
ExceptionDetailBase | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets or sets an Exception generated by server.
InnerException | Gets or sets inner exception wrapper.
Message | Gets or sets error message.

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExceptionDetailBase Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Constructor
ExceptionDetailBase Class See Also Send Feedback

Overload List

Name | Description
ExceptionDetailBase(Exception) | Initializes a new instance of the ExceptionDetailBase class.
ExceptionDetailBase(Exception, ExceptionDetailBase) | Initializes a new instance of the ExceptionDetailBase class.

See Also

ExceptionDetailBase Class
ExceptionDetailBase Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExceptionDetailBase Constructor (Exception)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Constructor (Exception)
ExceptionDetailBase Class See Also Send Feedback
Initializes a new instance of the ExceptionDetailBase class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ExceptionDetailBase(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
ExceptionDetailBase(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
Exception class.

See Also

ExceptionDetailBase Class
ExceptionDetailBase Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExceptionDetailBase Constructor (Exception, ExceptionDetailBase)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Constructor (Exception, ExceptionDetailBase)
ExceptionDetailBase Class See Also Send Feedback
Initializes a new instance of the ExceptionDetailBase class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ExceptionDetailBase(
    Exception exception,
    ExceptionDetailBase innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception, _
    innerException As ExceptionDetailBase _
)
Visual C++
public:
ExceptionDetailBase(
    Exception^ exception,
    ExceptionDetailBase^ innerException
)

Parameters

exception
Type: System..::.Exception
Exception class.
innerException
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
ExceptionDetailBase class.

See Also

ExceptionDetailBase Class
ExceptionDetailBase Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExceptionDetailBase Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Methods
ExceptionDetailBase Class See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExceptionDetailBase Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase Properties
ExceptionDetailBase Class See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Properties

Name | Description
Exception | Gets or sets an Exception generated by server.
InnerException | Gets or sets inner exception wrapper.
Message | Gets or sets error message.

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Exception Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase..::.Exception Property
ExceptionDetailBase Class See Also Send Feedback
Gets or sets an Exception generated by server.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Exception Exception { get; private set; }
Visual Basic (Declaration)
Public Property Exception As Exception
Visual C++
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InnerException Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase..::.InnerException Property
ExceptionDetailBase Class See Also Send Feedback
Gets or sets inner exception wrapper.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ExceptionDetailBase InnerException { get; set; }
Visual Basic (Declaration)
Public Property InnerException As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ InnerException {
    ExceptionDetailBase^ get ();
    void set (ExceptionDetailBase^ value);
}

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Message Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExceptionDetailBase..::.Message Property
ExceptionDetailBase Class See Also Send Feedback
Gets or sets error message.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Message { get; private set; }
Visual Basic (Declaration)
Public Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

See Also

ExceptionDetailBase Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionCacheObject Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionCacheObject Class
Members See Also Send Feedback
Represents the cache object to the stored data for the report execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ExecutionCacheObject
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExecutionCacheObject
Visual C++
[SerializableAttribute]
public ref class ExecutionCacheObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExecutionCacheObject

See Also

ExecutionCacheObject Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionCacheObject Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionCacheObject Members
ExecutionCacheObject Class Constructors Methods Properties See Also Send Feedback

The ExecutionCacheObject type exposes the following members.

Constructors

Name | Description
ExecutionCacheObject | Initializes a new instance.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentId | Gets or sets the document identifier.
DocumentName | Gets or sets the document name.
ExecutionID | Gets or sets the execution ID.

See Also

ExecutionCacheObject Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionCacheObject Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionCacheObject Constructor
ExecutionCacheObject Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ExecutionCacheObject(
    string executionId,
    string documentName
)
Visual Basic (Declaration)
Public Sub New ( _
    executionId As String, _
    documentName As String _
)
Visual C++
public:
ExecutionCacheObject(
    String^ executionId,
    String^ documentName
)

Parameters

executionId
Type: System..::.String
Execution ID.
documentName
Type: System..::.String
Document name.

See Also

ExecutionCacheObject Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionCacheObject Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionCacheObject Methods
ExecutionCacheObject Class See Also Send Feedback

The ExecutionCacheObject type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutionCacheObject Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionCacheObject Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionCacheObject Properties
ExecutionCacheObject Class See Also Send Feedback

The ExecutionCacheObject type exposes the following members.

Properties

Name | Description
DocumentId | Gets or sets the document identifier.
DocumentName | Gets or sets the document name.
ExecutionID | Gets or sets the execution ID.

See Also

ExecutionCacheObject Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DocumentId Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionCacheObject..::.DocumentId Property
ExecutionCacheObject Class See Also Send Feedback
Gets or sets the document identifier.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DocumentId { get; set; }
Visual Basic (Declaration)
Public Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
    void set (String^ value);
}

See Also

ExecutionCacheObject Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DocumentName Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionCacheObject..::.DocumentName Property
ExecutionCacheObject Class See Also Send Feedback
Gets or sets the document name.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DocumentName { get; set; }
Visual Basic (Declaration)
Public Property DocumentName As String
Visual C++
public:
property String^ DocumentName {
    String^ get ();
    void set (String^ value);
}

See Also

ExecutionCacheObject Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionID Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionCacheObject..::.ExecutionID Property
ExecutionCacheObject Class See Also Send Feedback
Gets or sets the execution ID.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExecutionID { get; set; }
Visual Basic (Declaration)
Public Property ExecutionID As String
Visual C++
public:
property String^ ExecutionID {
    String^ get ();
    void set (String^ value);
}

See Also

ExecutionCacheObject Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundException Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundException Class
Members See Also Send Feedback
Represents ExecutionNotFoundException exception.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ExecutionNotFoundException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExecutionNotFoundException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ExecutionNotFoundException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExecutionNotFoundException

See Also

ExecutionNotFoundException Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundException Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundException Members
ExecutionNotFoundException Class Constructors Methods Properties See Also Send Feedback

The ExecutionNotFoundException type exposes the following members.

Constructors

Name | Description
ExecutionNotFoundException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExecutionNotFoundException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundException Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundException Constructor
ExecutionNotFoundException Class See Also Send Feedback

Overload List

Name | Description
ExecutionNotFoundException()()() | Initializes a new instance.
ExecutionNotFoundException(String) | Initializes a new instance.

See Also

ExecutionNotFoundException Class
ExecutionNotFoundException Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundException Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundException Constructor
ExecutionNotFoundException Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ExecutionNotFoundException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExecutionNotFoundException()

See Also

ExecutionNotFoundException Class
ExecutionNotFoundException Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundException Constructor (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundException Constructor (String)
ExecutionNotFoundException Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ExecutionNotFoundException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ExecutionNotFoundException(
    String^ message
)

Parameters

message
Type: System..::.String
A message.

See Also

ExecutionNotFoundException Class
ExecutionNotFoundException Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundException Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundException Methods
ExecutionNotFoundException Class See Also Send Feedback

The ExecutionNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ExecutionNotFoundException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundException Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundException Properties
ExecutionNotFoundException Class See Also Send Feedback

The ExecutionNotFoundException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExecutionNotFoundException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundExceptionDetail Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Class
Members See Also Send Feedback
Exceptions are generated when the required execution is not found.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ExecutionNotFoundExceptionDetail : ExceptionDetailBase
Visual Basic (Declaration)
Public Class ExecutionNotFoundExceptionDetail _
    Inherits ExceptionDetailBase
Visual C++
public ref class ExecutionNotFoundExceptionDetail : public ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExecutionNotFoundExceptionDetail

See Also

ExecutionNotFoundExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundExceptionDetail Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Members
ExecutionNotFoundExceptionDetail Class Constructors Methods Properties See Also Send Feedback

The ExecutionNotFoundExceptionDetail type exposes the following members.

Constructors

Name | Description
ExecutionNotFoundExceptionDetail | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets or sets an Exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

ExecutionNotFoundExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundExceptionDetail Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Constructor
ExecutionNotFoundExceptionDetail Class See Also Send Feedback

Overload List

Name | Description
ExecutionNotFoundExceptionDetail(Exception) | Initializes a new instance.
ExecutionNotFoundExceptionDetail(Exception, ExceptionDetailBase) | Initializes a new instance.

See Also

ExecutionNotFoundExceptionDetail Class
ExecutionNotFoundExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundExceptionDetail Constructor (Exception)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Constructor (Exception)
ExecutionNotFoundExceptionDetail Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ExecutionNotFoundExceptionDetail(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
ExecutionNotFoundExceptionDetail(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
A Exception class.

See Also

ExecutionNotFoundExceptionDetail Class
ExecutionNotFoundExceptionDetail Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundExceptionDetail Constructor (Exception, ExceptionDetailBase)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Constructor (Exception, ExceptionDetailBase)
ExecutionNotFoundExceptionDetail Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ExecutionNotFoundExceptionDetail(
    Exception exception,
    ExceptionDetailBase innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception, _
    innerException As ExceptionDetailBase _
)
Visual C++
public:
ExecutionNotFoundExceptionDetail(
    Exception^ exception,
    ExceptionDetailBase^ innerException
)

Parameters

exception
Type: System..::.Exception
A class.
innerException
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
Inner ExceptionDetailBase.

See Also

ExecutionNotFoundExceptionDetail Class
ExecutionNotFoundExceptionDetail Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundExceptionDetail Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Methods
ExecutionNotFoundExceptionDetail Class See Also Send Feedback

The ExecutionNotFoundExceptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutionNotFoundExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionNotFoundExceptionDetail Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionNotFoundExceptionDetail Properties
ExecutionNotFoundExceptionDetail Class See Also Send Feedback

The ExecutionNotFoundExceptionDetail type exposes the following members.

Properties

Name | Description
Exception | Gets or sets an Exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

ExecutionNotFoundExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionOutOfCacheException Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionOutOfCacheException Class
Members See Also Send Feedback
Represents ExecutionOutOfCacheException exception.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ExecutionOutOfCacheException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExecutionOutOfCacheException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ExecutionOutOfCacheException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExecutionOutOfCacheException

See Also

ExecutionOutOfCacheException Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionOutOfCacheException Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionOutOfCacheException Members
ExecutionOutOfCacheException Class Methods Properties See Also Send Feedback

The ExecutionOutOfCacheException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExecutionOutOfCacheException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionOutOfCacheException Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionOutOfCacheException Methods
ExecutionOutOfCacheException Class See Also Send Feedback

The ExecutionOutOfCacheException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ExecutionOutOfCacheException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionOutOfCacheException Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExecutionOutOfCacheException Properties
ExecutionOutOfCacheException Class See Also Send Feedback

The ExecutionOutOfCacheException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExecutionOutOfCacheException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExportsEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ExportsEnum Enumeration
See Also Send Feedback
Specifies all valid exports formats.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ExportsEnum
Visual Basic (Declaration)
Public Enumeration ExportsEnum
Visual C++
public enum class ExportsEnum

Members

Member name | Description
Pdf | Specifies Pdf.
Rtf | Specifies Rtf.
Html | Specifies Html.
Xps | Specifies Xps.
Excel | Specifies Excel.
Word | Specifies Word.
Image | Specifies Image (TIFF image format).
Csv | Specifies Csv.
Mhtml | Specifies MHTML.
Xml | Specifies Xml.
Null | Specifies Null.

See Also

PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FindOptions Structure

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions Structure
Members See Also Send Feedback
Represents data for search.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct FindOptions
Visual Basic (Declaration)
Public Structure FindOptions
Visual C++
public value class FindOptions

See Also

FindOptions Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FindOptions Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions Members
FindOptions Structure Methods Properties See Also Send Feedback

The FindOptions type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Direction | Gets or sets SearchDirectionEnum which defines search direction.
FindText | Gets or sets the required text.
FromBegining | Gets or sets the value which indicates if the search should start from begining.
StartLocation | Gets or sets SearchResult which sets where to begin text search from.

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FindOptions Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions Methods
FindOptions Structure See Also Send Feedback

The FindOptions type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FindOptions Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions Properties
FindOptions Structure See Also Send Feedback

The FindOptions type exposes the following members.

Properties

Name | Description
Direction | Gets or sets SearchDirectionEnum which defines search direction.
FindText | Gets or sets the required text.
FromBegining | Gets or sets the value which indicates if the search should start from begining.
StartLocation | Gets or sets SearchResult which sets where to begin text search from.

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Direction Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions..::.Direction Property
FindOptions Structure See Also Send Feedback
Gets or sets SearchDirectionEnum which defines search direction.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchDirectionEnum Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As SearchDirectionEnum
Visual C++
public:
property SearchDirectionEnum Direction {
    SearchDirectionEnum get ();
    void set (SearchDirectionEnum value);
}

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FindText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions..::.FindText Property
FindOptions Structure See Also Send Feedback
Gets or sets the required text.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FindText { get; set; }
Visual Basic (Declaration)
Public Property FindText As String
Visual C++
public:
property String^ FindText {
    String^ get ();
    void set (String^ value);
}

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FromBegining Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions..::.FromBegining Property
FindOptions Structure See Also Send Feedback
Gets or sets the value which indicates if the search should start from begining.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool FromBegining { get; set; }
Visual Basic (Declaration)
Public Property FromBegining As Boolean
Visual C++
public:
property bool FromBegining {
    bool get ();
    void set (bool value);
}

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


StartLocation Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FindOptions..::.StartLocation Property
FindOptions Structure See Also Send Feedback
Gets or sets SearchResult which sets where to begin text search from.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchResult StartLocation { get; set; }
Visual Basic (Declaration)
Public Property StartLocation As SearchResult
Visual C++
public:
property SearchResult^ StartLocation {
    SearchResult^ get ();
    void set (SearchResult^ value);
}

See Also

FindOptions Structure
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FontsProvider Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsProvider Class
Members See Also Send Feedback
Represents a set of methods for the work with fonts.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FontsProvider
Visual Basic (Declaration)
Public Class FontsProvider
Visual C++
public ref class FontsProvider

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.FontsProvider

See Also

FontsProvider Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FontsProvider Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsProvider Members
FontsProvider Class Constructors Methods See Also Send Feedback

The FontsProvider type exposes the following members.

Constructors

Name | Description
FontsProvider | Initializes a new instance of the FontsProvider class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFontFamilyKey | Returns font name by family name and its weight.
GetFontSource | Writes a font definition by name to stream.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultFont | Defines if font with the set name is a default font.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontsProvider Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FontsProvider Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsProvider Constructor
FontsProvider Class See Also Send Feedback
Initializes a new instance of the FontsProvider class.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FontsProvider()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FontsProvider()

See Also

FontsProvider Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FontsProvider Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsProvider Methods
FontsProvider Class See Also Send Feedback

The FontsProvider type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFontFamilyKey | Returns font name by family name and its weight.
GetFontSource | Writes a font definition by name to stream.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultFont | Defines if font with the set name is a default font.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontsProvider Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetFontFamilyKey Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsProvider..::.GetFontFamilyKey Method
FontsProvider Class See Also Send Feedback
Returns font name by family name and its weight.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string GetFontFamilyKey(
    string familyName,
    FontWeight fontWeight
)
Visual Basic (Declaration)
Public Shared Function GetFontFamilyKey ( _
    familyName As String, _
    fontWeight As FontWeight _
) As String
Visual C++
public:
static String^ GetFontFamilyKey(
    String^ familyName,
    FontWeight fontWeight
)

Parameters

familyName
Type: System..::.String
Font Family name.
fontWeight
Type: System.Windows..::.FontWeight
Font weight.

Return Value

Font family key like "familyName; fontWeight".

Remarks

Sample of return value:
Tahoma; Bold.

See Also

FontsProvider Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetFontSource Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsProvider..::.GetFontSource Method
FontsProvider Class See Also Send Feedback
Writes a font definition by name to stream.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void GetFontSource(
    string fontFamilyKey,
    Stream outStream
)
Visual Basic (Declaration)
Public Sub GetFontSource ( _
    fontFamilyKey As String, _
    outStream As Stream _
)
Visual C++
public:
void GetFontSource(
    String^ fontFamilyKey,
    Stream^ outStream
)

Parameters

fontFamilyKey
Type: System..::.String
Font family key.
outStream
Type: System.IO..::.Stream
Output stream.

See Also

FontsProvider Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


IsDefaultFont Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
FontsProvider..::.IsDefaultFont Method
FontsProvider Class See Also Send Feedback
Defines if font with the set name is a default font.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool IsDefaultFont(
    string fontFamily
)
Visual Basic (Declaration)
Public Shared Function IsDefaultFont ( _
    fontFamily As String _
) As Boolean
Visual C++
public:
static bool IsDefaultFont(
    String^ fontFamily
)

Parameters

fontFamily
Type: System..::.String
Font Family name.

Return Value

True if the font family is default for Silverlight engine; otherwise False.

See Also

FontsProvider Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersException Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersException Class
Members See Also Send Feedback
Represents an InvalidParametersException exception.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class InvalidParametersException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InvalidParametersException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class InvalidParametersException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.ReportingServices.Viewer.Server..::.InvalidParametersException

See Also

InvalidParametersException Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersException Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersException Members
InvalidParametersException Class Constructors Methods Properties See Also Send Feedback

The InvalidParametersException type exposes the following members.

Constructors

Name | Description
InvalidParametersException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidParametersException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersException Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersException Constructor
InvalidParametersException Class See Also Send Feedback

Overload List

Name | Description
InvalidParametersException()()() | Initializes a new instance.
InvalidParametersException(String) | Initializes a new instance.

See Also

InvalidParametersException Class
InvalidParametersException Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersException Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersException Constructor
InvalidParametersException Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InvalidParametersException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InvalidParametersException()

See Also

InvalidParametersException Class
InvalidParametersException Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersException Constructor (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersException Constructor (String)
InvalidParametersException Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InvalidParametersException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
InvalidParametersException(
    String^ message
)

Parameters

message
Type: System..::.String
Exception message.

See Also

InvalidParametersException Class
InvalidParametersException Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersException Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersException Methods
InvalidParametersException Class See Also Send Feedback

The InvalidParametersException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidParametersException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersException Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersException Properties
InvalidParametersException Class See Also Send Feedback

The InvalidParametersException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidParametersException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersExceptionDetail Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersExceptionDetail Class
Members See Also Send Feedback
Exceptions are generated when parameters invalid.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class InvalidParametersExceptionDetail : ExceptionDetailBase
Visual Basic (Declaration)
Public Class InvalidParametersExceptionDetail _
    Inherits ExceptionDetailBase
Visual C++
public ref class InvalidParametersExceptionDetail : public ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
PerpetuumSoft.ReportingServices.Viewer.Server..::.InvalidParametersExceptionDetail

See Also

InvalidParametersExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersExceptionDetail Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersExceptionDetail Members
InvalidParametersExceptionDetail Class Constructors Methods Properties See Also Send Feedback

The InvalidParametersExceptionDetail type exposes the following members.

Constructors

Name | Description
InvalidParametersExceptionDetail | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets or sets an Exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

InvalidParametersExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersExceptionDetail Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersExceptionDetail Constructor
InvalidParametersExceptionDetail Class See Also Send Feedback

Overload List

Name | Description
InvalidParametersExceptionDetail(Exception) | Initializes a new instance.
InvalidParametersExceptionDetail(Exception, ExceptionDetailBase) | Initializes a new instance.

See Also

InvalidParametersExceptionDetail Class
InvalidParametersExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersExceptionDetail Constructor (Exception)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersExceptionDetail Constructor (Exception)
InvalidParametersExceptionDetail Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InvalidParametersExceptionDetail(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
InvalidParametersExceptionDetail(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
A Exception class.

See Also

InvalidParametersExceptionDetail Class
InvalidParametersExceptionDetail Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersExceptionDetail Constructor (Exception, ExceptionDetailBase)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersExceptionDetail Constructor (Exception, ExceptionDetailBase)
InvalidParametersExceptionDetail Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public InvalidParametersExceptionDetail(
    Exception exception,
    ExceptionDetailBase innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception, _
    innerException As ExceptionDetailBase _
)
Visual C++
public:
InvalidParametersExceptionDetail(
    Exception^ exception,
    ExceptionDetailBase^ innerException
)

Parameters

exception
Type: System..::.Exception
A Exception class.
innerException
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
Inner ExceptionDetailBase.

See Also

InvalidParametersExceptionDetail Class
InvalidParametersExceptionDetail Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersExceptionDetail Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersExceptionDetail Methods
InvalidParametersExceptionDetail Class See Also Send Feedback

The InvalidParametersExceptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InvalidParametersExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


InvalidParametersExceptionDetail Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
InvalidParametersExceptionDetail Properties
InvalidParametersExceptionDetail Class See Also Send Feedback

The InvalidParametersExceptionDetail type exposes the following members.

Properties

Name | Description
Exception | Gets or sets an Exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

InvalidParametersExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


IReportCache Interface

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportCache Interface
Members See Also Send Feedback
Exposes a method for working with cache.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IReportCache
Visual Basic (Declaration)
Public Interface IReportCache
Visual C++
public interface class IReportCache

See Also

IReportCache Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


IReportCache Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportCache Members
IReportCache Interface Methods See Also Send Feedback

The IReportCache type exposes the following members.

Methods

Name | Description
AddDocumentToCache | Adds a document to cache.
AddExecutionToCache | Adds execution object to cache.
AddPageToCache | Adds document page to cache.
GetDocumentFromCache | Gets a document object from cache.
GetExecutionFromCache | Gets execution object from cache.
GetPageFromCache | Gets a page object from cache.

See Also

IReportCache Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


IReportCache Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportCache Methods
IReportCache Interface See Also Send Feedback

The IReportCache type exposes the following members.

Methods

Name | Description
AddDocumentToCache | Adds a document to cache.
AddExecutionToCache | Adds execution object to cache.
AddPageToCache | Adds document page to cache.
GetDocumentFromCache | Gets a document object from cache.
GetExecutionFromCache | Gets execution object from cache.
GetPageFromCache | Gets a page object from cache.

See Also

IReportCache Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


AddDocumentToCache Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportCache..::.AddDocumentToCache Method
IReportCache Interface See Also Send Feedback
Adds a document to cache.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void AddDocumentToCache(
    string key,
    Object value,
    params Object[] parameters
)
Visual Basic (Declaration)
Sub AddDocumentToCache ( _
    key As String, _
    value As Object, _
    ParamArray parameters As Object() _
)
Visual C++
void AddDocumentToCache(
    String^ key,
    Object^ value,
    ... array<Object^>^ parameters
)

Parameters

key
Type: System..::.String
Document identifier.
value
Type: System..::.Object
The Document object.
parameters
Type: array< System..::.Object >[]()[]
List of parameters of the specified document.

See Also

IReportCache Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


AddExecutionToCache Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportCache..::.AddExecutionToCache Method
IReportCache Interface See Also Send Feedback
Adds execution object to cache.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void AddExecutionToCache(
    string executionId,
    Object executionCacheObject
)
Visual Basic (Declaration)
Sub AddExecutionToCache ( _
    executionId As String, _
    executionCacheObject As Object _
)
Visual C++
void AddExecutionToCache(
    String^ executionId,
    Object^ executionCacheObject
)

Parameters

executionId
Type: System..::.String
Execution ID.
executionCacheObject
Type: System..::.Object
Execution cache object.

See Also

IReportCache Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


AddPageToCache Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportCache..::.AddPageToCache Method
IReportCache Interface See Also Send Feedback
Adds document page to cache.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void AddPageToCache(
    string key,
    PageInfo value,
    params Object[] parameters
)
Visual Basic (Declaration)
Sub AddPageToCache ( _
    key As String, _
    value As PageInfo, _
    ParamArray parameters As Object() _
)
Visual C++
void AddPageToCache(
    String^ key,
    PageInfo^ value,
    ... array<Object^>^ parameters
)

Parameters

key
Type: System..::.String
Page identifier.
value
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.PageInfo
The Page object.
parameters
Type: array< System..::.Object >[]()[]
List of parameters of specified document for given page.

See Also

IReportCache Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetDocumentFromCache Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportCache..::.GetDocumentFromCache Method
IReportCache Interface See Also Send Feedback
Gets a document object from cache.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Object GetDocumentFromCache(
    string key
)
Visual Basic (Declaration)
Function GetDocumentFromCache ( _
    key As String _
) As Object
Visual C++
Object^ GetDocumentFromCache(
    String^ key
)

Parameters

key
Type: System..::.String
Document identifier.

Return Value

The cached object.

See Also

IReportCache Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetExecutionFromCache Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportCache..::.GetExecutionFromCache Method
IReportCache Interface See Also Send Feedback
Gets execution object from cache.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Object GetExecutionFromCache(
    string executionId
)
Visual Basic (Declaration)
Function GetExecutionFromCache ( _
    executionId As String _
) As Object
Visual C++
Object^ GetExecutionFromCache(
    String^ executionId
)

Parameters

executionId
Type: System..::.String
Execution ID.

Return Value

Execution cached object.

See Also

IReportCache Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetPageFromCache Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportCache..::.GetPageFromCache Method
IReportCache Interface See Also Send Feedback
Gets a page object from cache.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Object GetPageFromCache(
    string key
)
Visual Basic (Declaration)
Function GetPageFromCache ( _
    key As String _
) As Object
Visual C++
Object^ GetPageFromCache(
    String^ key
)

Parameters

key
Type: System..::.String
Page identifier.

Return Value

The cached object.

See Also

IReportCache Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


IReportService Interface

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService Interface
Members See Also Send Feedback
Exposes a method for getting report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IReportService
Visual Basic (Declaration)
Public Interface IReportService
Visual C++
public interface class IReportService

See Also

IReportService Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


IReportService Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService Members
IReportService Interface Methods See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
Find | Returns search results in the document set by identificator.
GetDocumentInfo | Returns report metadata.
GetPageInfo | Returns page metadata by report identificator and page number.
Init | It is invoked for initialization.
ListExportsFormats | Returns list of available exports formats.
LoadDrillthroughTarget | Creates a report execution from a drill through action.
LoadReport | Loads report into a new execution.
Render | Generates the report and gets identificator of the generated and saved in cash report.
SetDataSourcesCredentials | Sets data sources credentials associated with the current report execution.
SetParameters | Sets and validates parameter values associated with the current report execution.
Sort | Applies or removes a sorting for the execution based on a user sorting action.
ToggleItem | Toggles the show/hide item in a report.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


IReportService Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService Methods
IReportService Interface See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
Find | Returns search results in the document set by identificator.
GetDocumentInfo | Returns report metadata.
GetPageInfo | Returns page metadata by report identificator and page number.
Init | It is invoked for initialization.
ListExportsFormats | Returns list of available exports formats.
LoadDrillthroughTarget | Creates a report execution from a drill through action.
LoadReport | Loads report into a new execution.
Render | Generates the report and gets identificator of the generated and saved in cash report.
SetDataSourcesCredentials | Sets data sources credentials associated with the current report execution.
SetParameters | Sets and validates parameter values associated with the current report execution.
Sort | Applies or removes a sorting for the execution based on a user sorting action.
ToggleItem | Toggles the show/hide item in a report.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Find Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.Find Method
IReportService Interface See Also Send Feedback
Returns search results in the document set by identificator.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
SearchResult Find(
    string id,
    FindOptions findOptions,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function Find ( _
    id As String, _
    findOptions As FindOptions, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As SearchResult
Visual C++
SearchResult^ Find(
    String^ id,
    FindOptions findOptions,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
Report identifier.
findOptions
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.FindOptions
Search options (see FindOptions).
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

Search result (see SearchResult).

Remarks

If error occurs then ReportError is not null.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetDocumentInfo Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.GetDocumentInfo Method
IReportService Interface See Also Send Feedback
Returns report metadata.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
DocumentInfo GetDocumentInfo(
    string id,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function GetDocumentInfo ( _
    id As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As DocumentInfo
Visual C++
DocumentInfo^ GetDocumentInfo(
    String^ id,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
Report identifier.
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

DocumentInfo class.

Remarks

If error occurs then ReportError is not null.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetPageInfo Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.GetPageInfo Method
IReportService Interface See Also Send Feedback
Returns page metadata by report identificator and page number.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
PageInfo GetPageInfo(
    string id,
    int pageNumber,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function GetPageInfo ( _
    id As String, _
    pageNumber As Integer, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As PageInfo
Visual C++
PageInfo^ GetPageInfo(
    String^ id,
    int pageNumber,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
Report identifier.
pageNumber
Type: System..::.Int32
The page number which should be get.
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

PageInfo class.

Remarks

If error occurs then ReportError is not null.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Init Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.Init Method
IReportService Interface See Also Send Feedback
It is invoked for initialization.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void Init()
Visual Basic (Declaration)
Sub Init
Visual C++
void Init()

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ListExportsFormats Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.ListExportsFormats Method
IReportService Interface See Also Send Feedback
Returns list of available exports formats.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
ExportsEnum[] ListExportsFormats(
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function ListExportsFormats ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ExportsEnum()
Visual C++
array<ExportsEnum>^ ListExportsFormats(
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

List of ExportsEnum.

Remarks

If error occurs then ReportError is not null.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


LoadDrillthroughTarget Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.LoadDrillthroughTarget Method
IReportService Interface See Also Send Feedback
Creates a report execution from a drill through action.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
ReportExecutionInfo LoadDrillthroughTarget(
    string id,
    string DrillthroughID,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function LoadDrillthroughTarget ( _
    id As String, _
    DrillthroughID As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
ReportExecutionInfo^ LoadDrillthroughTarget(
    String^ id,
    String^ DrillthroughID,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
Report identifier
DrillthroughID
Type: System..::.String
The drillthrough identifier.
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class.

Remarks

If error occurs then ReportError is not null.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


LoadReport Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.LoadReport Method
IReportService Interface See Also Send Feedback
Loads report into a new execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
ReportExecutionInfo LoadReport(
    string report,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function LoadReport ( _
    report As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
ReportExecutionInfo^ LoadReport(
    String^ report,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

report
Type: System..::.String
Report name.
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class

Remarks

If error occurs then ReportError is not null.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Render Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.Render Method
IReportService Interface See Also Send Feedback
Generates the report and gets identificator of the generated and saved in cash report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
string Render(
    string id,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function Render ( _
    id As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As String
Visual C++
String^ Render(
    String^ id,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
Report identifier
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

Generated document identifier.

Remarks

If error occurs then ReportError is not null.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SetDataSourcesCredentials Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.SetDataSourcesCredentials Method
IReportService Interface See Also Send Feedback
Sets data sources credentials associated with the current report execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
ReportExecutionInfo SetDataSourcesCredentials(
    string id,
    ReportDataSourceCredential[] credentials,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function SetDataSourcesCredentials ( _
    id As String, _
    credentials As ReportDataSourceCredential(), _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
ReportExecutionInfo^ SetDataSourcesCredentials(
    String^ id,
    array<ReportDataSourceCredential^>^ credentials,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
Report identifier.
credentials
Type: array< PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportDataSourceCredential >[]()[]
List of data sources credentials (see ReportDataSourceCredential).
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class.

Remarks

If error occurs then ReportError is not null.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SetParameters Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.SetParameters Method
IReportService Interface See Also Send Feedback
Sets and validates parameter values associated with the current report execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
ReportExecutionInfo SetParameters(
    string id,
    ReportParameterValue[] paramatersValues,
    string parametersLanguage,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function SetParameters ( _
    id As String, _
    paramatersValues As ReportParameterValue(), _
    parametersLanguage As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
ReportExecutionInfo^ SetParameters(
    String^ id,
    array<ReportParameterValue^>^ paramatersValues,
    String^ parametersLanguage,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
Report identifier.
paramatersValues
Type: array< PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportParameterValue >[]()[]
List of parameters values (see ReportParameterValue)
parametersLanguage
Type: System..::.String
Parameter language. It must be CultureInfo.CurrentUICulture.Name value. (Name)
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class.

Remarks

If error occurs then ReportError is not null.
If ParameterLanguage is specified, parameters are interpreted in this language. If ParameterLanguage is not specified, the default behavior is used.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Sort Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.Sort Method
IReportService Interface See Also Send Feedback
Applies or removes a sorting for the execution based on a user sorting action.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int Sort(
    string id,
    string elementId,
    SortDirectionEnum sortDirection,
    out ExceptionDetailBase reportError
)
Visual Basic (Declaration)
Function Sort ( _
    id As String, _
    elementId As String, _
    sortDirection As SortDirectionEnum, _
    <OutAttribute> ByRef reportError As ExceptionDetailBase _
) As Integer
Visual C++
int Sort(
    String^ id,
    String^ elementId,
    SortDirectionEnum sortDirection,
    [OutAttribute] ExceptionDetailBase^% reportError
)

Parameters

id
Type: System..::.String
Report identifier./
elementId
Type: System..::.String
The element identifier to specify user sorting action.
sortDirection
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.SortDirectionEnum
Sorting direction (see SortDirectionEnum).
reportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

New page index.

Remarks

If error occurs then ReportError is not null.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ToggleItem Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportService..::.ToggleItem Method
IReportService Interface See Also Send Feedback
Toggles the show/hide item in a report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool ToggleItem(
    string id,
    string elementId,
    out ExceptionDetailBase reportError
)
Visual Basic (Declaration)
Function ToggleItem ( _
    id As String, _
    elementId As String, _
    <OutAttribute> ByRef reportError As ExceptionDetailBase _
) As Boolean
Visual C++
bool ToggleItem(
    String^ id,
    String^ elementId,
    [OutAttribute] ExceptionDetailBase^% reportError
)

Parameters

id
Type: System..::.String
Report identifier./
elementId
Type: System..::.String
The element identifier to specify toggle item action.
reportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

A Boolean value indicating whether the item was found.

See Also

IReportService Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


IReportServiceResources Interface

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources Interface
Members See Also Send Feedback
Exposes a method for report resources getting.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IReportServiceResources
Visual Basic (Declaration)
Public Interface IReportServiceResources
Visual C++
public interface class IReportServiceResources

See Also

IReportServiceResources Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


IReportServiceResources Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources Members
IReportServiceResources Interface Methods See Also Send Feedback

The IReportServiceResources type exposes the following members.

Methods

Name | Description
Export | Returns result of document export to the specified format.
GetFont | Returns font definition by the font name.
GetHtmlImage | Returns image from a document by image stream identificator.
GetImageStream | Returns image from a document.
GetResource | Returns a resource by set culture.
Print | Returns printable document in html format.

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


IReportServiceResources Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources Methods
IReportServiceResources Interface See Also Send Feedback

The IReportServiceResources type exposes the following members.

Methods

Name | Description
Export | Returns result of document export to the specified format.
GetFont | Returns font definition by the font name.
GetHtmlImage | Returns image from a document by image stream identificator.
GetImageStream | Returns image from a document.
GetResource | Returns a resource by set culture.
Print | Returns printable document in html format.

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Export Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.Export Method
IReportServiceResources Interface See Also Send Feedback
Returns result of document export to the specified format.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Stream Export(
    string id,
    string documentName,
    string format
)
Visual Basic (Declaration)
Function Export ( _
    id As String, _
    documentName As String, _
    format As String _
) As Stream
Visual C++
Stream^ Export(
    String^ id,
    String^ documentName,
    String^ format
)

Parameters

id
Type: System..::.String
Document identifier.
documentName
Type: System..::.String
The name of document.
format
Type: System..::.String
The format to export.

Return Value

Stream class.

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetFont Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.GetFont Method
IReportServiceResources Interface See Also Send Feedback
Returns font definition by the font name.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Stream GetFont(
    string resourceKey
)
Visual Basic (Declaration)
Function GetFont ( _
    resourceKey As String _
) As Stream
Visual C++
Stream^ GetFont(
    String^ resourceKey
)

Parameters

resourceKey
Type: System..::.String
The font name.

Return Value

Stream class.

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetHtmlImage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.GetHtmlImage Method
IReportServiceResources Interface See Also Send Feedback
Returns image from a document by image stream identificator.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Stream GetHtmlImage(
    string executionId,
    string imageId
)
Visual Basic (Declaration)
Function GetHtmlImage ( _
    executionId As String, _
    imageId As String _
) As Stream
Visual C++
Stream^ GetHtmlImage(
    String^ executionId,
    String^ imageId
)

Parameters

executionId
Type: System..::.String
Report identifier.
imageId
Type: System..::.String
The image identifier.

Return Value

Stream class.

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetImageStream Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.GetImageStream Method
IReportServiceResources Interface See Also Send Feedback
Returns image from a document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Stream GetImageStream(
    string id,
    string resourceId
)
Visual Basic (Declaration)
Function GetImageStream ( _
    id As String, _
    resourceId As String _
) As Stream
Visual C++
Stream^ GetImageStream(
    String^ id,
    String^ resourceId
)

Parameters

id
Type: System..::.String
The document identifier.
resourceId
Type: System..::.String
The resource identifier.

Return Value

Stream class.

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetResource Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.GetResource Method
IReportServiceResources Interface See Also Send Feedback
Returns a resource by set culture.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Stream GetResource(
    string culture
)
Visual Basic (Declaration)
Function GetResource ( _
    culture As String _
) As Stream
Visual C++
Stream^ GetResource(
    String^ culture
)

Parameters

culture
Type: System..::.String
Resource culture.

Return Value

Stream class.

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Print Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
IReportServiceResources..::.Print Method
IReportServiceResources Interface See Also Send Feedback
Returns printable document in html format.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Stream Print(
    string id,
    string documentName
)
Visual Basic (Declaration)
Function Print ( _
    id As String, _
    documentName As String _
) As Stream
Visual C++
Stream^ Print(
    String^ id,
    String^ documentName
)

Parameters

id
Type: System..::.String
The id.
documentName
Type: System..::.String
Name of the document.

Return Value

Stream class.

See Also

IReportServiceResources Interface
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentException Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentException Class
Members See Also Send Feedback
Represents NoCachedDocumentException exeption.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class NoCachedDocumentException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class NoCachedDocumentException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class NoCachedDocumentException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.ReportingServices.Viewer.Server..::.NoCachedDocumentException

See Also

NoCachedDocumentException Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentException Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentException Members
NoCachedDocumentException Class Methods Properties See Also Send Feedback

The NoCachedDocumentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NoCachedDocumentException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentException Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentException Methods
NoCachedDocumentException Class See Also Send Feedback

The NoCachedDocumentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NoCachedDocumentException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentException Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentException Properties
NoCachedDocumentException Class See Also Send Feedback

The NoCachedDocumentException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NoCachedDocumentException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentExceptionDetail Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Class
Members See Also Send Feedback
Exceptions are generated when the required document is not found in cache.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NoCachedDocumentExceptionDetail : ExceptionDetailBase
Visual Basic (Declaration)
Public Class NoCachedDocumentExceptionDetail _
    Inherits ExceptionDetailBase
Visual C++
public ref class NoCachedDocumentExceptionDetail : public ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
PerpetuumSoft.ReportingServices.Viewer.Server..::.NoCachedDocumentExceptionDetail

See Also

NoCachedDocumentExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentExceptionDetail Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Members
NoCachedDocumentExceptionDetail Class Constructors Methods Properties See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Constructors

Name | Description
NoCachedDocumentExceptionDetail | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets or sets an Exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentExceptionDetail Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Constructor
NoCachedDocumentExceptionDetail Class See Also Send Feedback

Overload List

Name | Description
NoCachedDocumentExceptionDetail(Exception) | Initializes a new instance.
NoCachedDocumentExceptionDetail(Exception, ExceptionDetailBase) | Initializes a new instance.

See Also

NoCachedDocumentExceptionDetail Class
NoCachedDocumentExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentExceptionDetail Constructor (Exception)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Constructor (Exception)
NoCachedDocumentExceptionDetail Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NoCachedDocumentExceptionDetail(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
NoCachedDocumentExceptionDetail(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
A Exception class.

See Also

NoCachedDocumentExceptionDetail Class
NoCachedDocumentExceptionDetail Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentExceptionDetail Constructor (Exception, ExceptionDetailBase)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Constructor (Exception, ExceptionDetailBase)
NoCachedDocumentExceptionDetail Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NoCachedDocumentExceptionDetail(
    Exception exception,
    ExceptionDetailBase innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception, _
    innerException As ExceptionDetailBase _
)
Visual C++
public:
NoCachedDocumentExceptionDetail(
    Exception^ exception,
    ExceptionDetailBase^ innerException
)

Parameters

exception
Type: System..::.Exception
A class.
innerException
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
Inner ExceptionDetailBase.

See Also

NoCachedDocumentExceptionDetail Class
NoCachedDocumentExceptionDetail Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentExceptionDetail Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Methods
NoCachedDocumentExceptionDetail Class See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoCachedDocumentExceptionDetail Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoCachedDocumentExceptionDetail Properties
NoCachedDocumentExceptionDetail Class See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Properties

Name | Description
Exception | Gets or sets an Exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentException Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentException Class
Members See Also Send Feedback
Represents NoDocumentException exeption.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class NoDocumentException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class NoDocumentException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class NoDocumentException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.ReportingServices.Viewer.Server..::.NoDocumentException

See Also

NoDocumentException Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentException Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentException Members
NoDocumentException Class Constructors Methods Properties See Also Send Feedback

The NoDocumentException type exposes the following members.

Constructors

Name | Description
NoDocumentException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NoDocumentException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentException Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentException Constructor
NoDocumentException Class See Also Send Feedback

Overload List

Name | Description
NoDocumentException()()() | Initializes a new instance.
NoDocumentException(String) | Initializes a new instance.
NoDocumentException(SerializationInfo, StreamingContext) | Initializes a new instance of the NoDocumentException class
NoDocumentException(String, Exception) | Initializes a new instance.

See Also

NoDocumentException Class
NoDocumentException Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentException Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentException Constructor
NoDocumentException Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NoDocumentException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoDocumentException()

See Also

NoDocumentException Class
NoDocumentException Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentException Constructor (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentException Constructor (String)
NoDocumentException Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NoDocumentException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
NoDocumentException(
    String^ message
)

Parameters

message
Type: System..::.String
Exception message.

See Also

NoDocumentException Class
NoDocumentException Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentException Constructor (SerializationInfo, StreamingContext)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentException Constructor (SerializationInfo, StreamingContext)
NoDocumentException Class See Also Send Feedback
Initializes a new instance of the NoDocumentException class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected NoDocumentException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
NoDocumentException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
context
Type: System.Runtime.Serialization..::.StreamingContext

See Also

NoDocumentException Class
NoDocumentException Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentException Constructor (String, Exception)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentException Constructor (String, Exception)
NoDocumentException Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NoDocumentException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
NoDocumentException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
Exception message.
inner
Type: System..::.Exception
Inner Exception.

See Also

NoDocumentException Class
NoDocumentException Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentException Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentException Methods
NoDocumentException Class See Also Send Feedback

The NoDocumentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NoDocumentException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentException Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentException Properties
NoDocumentException Class See Also Send Feedback

The NoDocumentException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NoDocumentException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentExceptionDetail Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentExceptionDetail Class
Members See Also Send Feedback
Exceptions are generated when the required document is not found.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NoDocumentExceptionDetail : ExceptionDetailBase
Visual Basic (Declaration)
Public Class NoDocumentExceptionDetail _
    Inherits ExceptionDetailBase
Visual C++
public ref class NoDocumentExceptionDetail : public ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
PerpetuumSoft.ReportingServices.Viewer.Server..::.NoDocumentExceptionDetail

See Also

NoDocumentExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentExceptionDetail Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentExceptionDetail Members
NoDocumentExceptionDetail Class Constructors Methods Properties See Also Send Feedback

The NoDocumentExceptionDetail type exposes the following members.

Constructors

Name | Description
NoDocumentExceptionDetail | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets or sets an Exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

NoDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentExceptionDetail Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentExceptionDetail Constructor
NoDocumentExceptionDetail Class See Also Send Feedback

Overload List

Name | Description
NoDocumentExceptionDetail(Exception) | Initializes a new instance.
NoDocumentExceptionDetail(Exception, ExceptionDetailBase) | Initializes a new instance.

See Also

NoDocumentExceptionDetail Class
NoDocumentExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentExceptionDetail Constructor (Exception)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentExceptionDetail Constructor (Exception)
NoDocumentExceptionDetail Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NoDocumentExceptionDetail(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
NoDocumentExceptionDetail(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
class.

See Also

NoDocumentExceptionDetail Class
NoDocumentExceptionDetail Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentExceptionDetail Constructor (Exception, ExceptionDetailBase)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentExceptionDetail Constructor (Exception, ExceptionDetailBase)
NoDocumentExceptionDetail Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NoDocumentExceptionDetail(
    Exception exception,
    ExceptionDetailBase innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception, _
    innerException As ExceptionDetailBase _
)
Visual C++
public:
NoDocumentExceptionDetail(
    Exception^ exception,
    ExceptionDetailBase^ innerException
)

Parameters

exception
Type: System..::.Exception
class.
innerException
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
Inner ExceptionDetailBase.

See Also

NoDocumentExceptionDetail Class
NoDocumentExceptionDetail Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentExceptionDetail Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentExceptionDetail Methods
NoDocumentExceptionDetail Class See Also Send Feedback

The NoDocumentExceptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NoDocumentExceptionDetail Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
NoDocumentExceptionDetail Properties
NoDocumentExceptionDetail Class See Also Send Feedback

The NoDocumentExceptionDetail type exposes the following members.

Properties

Name | Description
Exception | Gets or sets an Exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

NoDocumentExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Packaging Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Packaging Class
Members See Also Send Feedback
Contains helper methods to compress or decompress a stream

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class Packaging
Visual Basic (Declaration)
Public NotInheritable Class Packaging
Visual C++
public ref class Packaging abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.Packaging

See Also

Packaging Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Packaging Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Packaging Members
Packaging Class Methods See Also Send Feedback

The Packaging type exposes the following members.

Methods

Name | Description
CreatePackage | Overloaded.
UnpackErrorPackage | Decompresses a stream to string

See Also

Packaging Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Packaging Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Packaging Methods
Packaging Class See Also Send Feedback

The Packaging type exposes the following members.

Methods

Name | Description
CreatePackage | Overloaded.
UnpackErrorPackage | Decompresses a stream to string

See Also

Packaging Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CreatePackage Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
Packaging..::.CreatePackage Method
Packaging Class See Also Send Feedback

Overload List

Name | Description
CreatePackage(MemoryStream) | Compresses a memory stream.
CreatePackage(array<String>[]()[]) | Compresses files to bytes array.
CreatePackage(MemoryStream, Stream) | Compresses a memory stream to other stream.
CreatePackage(array<String>[]()[], Stream, CompressionOption) | Compresses files to stream.

See Also

Packaging Class
Packaging Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CreatePackage Method (MemoryStream)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Packaging..::.CreatePackage Method (MemoryStream)
Packaging Class See Also Send Feedback
Compresses a memory stream.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static byte[] CreatePackage(
    MemoryStream xamlStream
)
Visual Basic (Declaration)
Public Shared Function CreatePackage ( _
    xamlStream As MemoryStream _
) As Byte()
Visual C++
public:
static array<unsigned char>^ CreatePackage(
    MemoryStream^ xamlStream
)

Parameters

xamlStream
Type: System.IO..::.MemoryStream
A memory stream to compress.

Return Value

Compressed bytes array.

See Also

Packaging Class
CreatePackage Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CreatePackage Method (String[])

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Packaging..::.CreatePackage Method (array<String>[]()[])
Packaging Class See Also Send Feedback
Compresses files to bytes array.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static byte[] CreatePackage(
    string[] fileNames
)
Visual Basic (Declaration)
Public Shared Function CreatePackage ( _
    fileNames As String() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ CreatePackage(
    array<String^>^ fileNames
)

Parameters

fileNames
Type: array< System..::.String >[]()[]
List of files.

Return Value

Compressed bytes array.

See Also

Packaging Class
CreatePackage Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CreatePackage Method (MemoryStream, Stream)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Packaging..::.CreatePackage Method (MemoryStream, Stream)
Packaging Class See Also Send Feedback
Compresses a memory stream to other stream.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void CreatePackage(
    MemoryStream xamlStream,
    Stream outStream
)
Visual Basic (Declaration)
Public Shared Sub CreatePackage ( _
    xamlStream As MemoryStream, _
    outStream As Stream _
)
Visual C++
public:
static void CreatePackage(
    MemoryStream^ xamlStream,
    Stream^ outStream
)

Parameters

xamlStream
Type: System.IO..::.MemoryStream
A memory stream to compress.
outStream
Type: System.IO..::.Stream
The compressed stream.

See Also

Packaging Class
CreatePackage Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CreatePackage Method (String[], Stream, CompressionOption)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Packaging..::.CreatePackage Method (array<String>[]()[], Stream, CompressionOption)
Packaging Class See Also Send Feedback
Compresses files to stream.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void CreatePackage(
    string[] fileNames,
    Stream outStream,
    CompressionOption compressionOption
)
Visual Basic (Declaration)
Public Shared Sub CreatePackage ( _
    fileNames As String(), _
    outStream As Stream, _
    compressionOption As CompressionOption _
)
Visual C++
public:
static void CreatePackage(
    array<String^>^ fileNames,
    Stream^ outStream,
    CompressionOption compressionOption
)

Parameters

fileNames
Type: array< System..::.String >[]()[]
List of fils.
outStream
Type: System.IO..::.Stream
Output Stream for compressed bytes.
compressionOption
Type: System.IO.Packaging..::.CompressionOption
CompressionOption enumeration.

See Also

Packaging Class
CreatePackage Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


UnpackErrorPackage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
Packaging..::.UnpackErrorPackage Method
Packaging Class See Also Send Feedback
Decompresses a stream to string

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string UnpackErrorPackage(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function UnpackErrorPackage ( _
    stream As Stream _
) As String
Visual C++
public:
static String^ UnpackErrorPackage(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to decompress

Return Value

Error message

See Also

Packaging Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


PageInfo Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Class
Members See Also Send Feedback
Represents a page metadata.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class PageInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PageInfo
Visual C++
[SerializableAttribute]
public ref class PageInfo

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.PageInfo

See Also

PageInfo Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


PageInfo Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Members
PageInfo Class Constructors Methods Properties See Also Send Feedback

The PageInfo type exposes the following members.

Constructors

Name | Description
PageInfo | Initializes a new instance of the PageInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CompresedXamlPage | Gets or sets a compressed XAML definition for page as array of bytes.
DocumentId | Gets or sets a document identifier.
PageNumber | Gets or sets a page number.

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


PageInfo Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Constructor
PageInfo Class See Also Send Feedback
Initializes a new instance of the PageInfo class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PageInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageInfo()

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


PageInfo Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Methods
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


PageInfo Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo Properties
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Properties

Name | Description
CompresedXamlPage | Gets or sets a compressed XAML definition for page as array of bytes.
DocumentId | Gets or sets a document identifier.
PageNumber | Gets or sets a page number.

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CompresedXamlPage Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo..::.CompresedXamlPage Property
PageInfo Class See Also Send Feedback
Gets or sets a compressed XAML definition for page as array of bytes.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte[] CompresedXamlPage { get; set; }
Visual Basic (Declaration)
Public Property CompresedXamlPage As Byte()
Visual C++
public:
property array<unsigned char>^ CompresedXamlPage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DocumentId Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo..::.DocumentId Property
PageInfo Class See Also Send Feedback
Gets or sets a document identifier.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DocumentId { get; set; }
Visual Basic (Declaration)
Public Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
    void set (String^ value);
}

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


PageNumber Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
PageInfo..::.PageNumber Property
PageInfo Class See Also Send Feedback
Gets or sets a page number.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

PageInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ParameterStateEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParameterStateEnum Enumeration
See Also Send Feedback
Specifies the state of a parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ParameterStateEnum
Visual Basic (Declaration)
Public Enumeration ParameterStateEnum
Visual C++
public enum class ParameterStateEnum

Members

Member name | Description
DynamicValuesUnavailable | The parameter values are unavailable. This state indicates that no valid, query-based values were returned as a result of the query.
HasOutstandingDependencies | The parameter has outstanding dependencies.
HasValidValue | A valid value for the parameter exists.
MissingValidValue | A valid value for the parameter does not exist.

See Also

PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ParameterTypeEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ParameterTypeEnum Enumeration
See Also Send Feedback
Specifies the data type of a parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ParameterTypeEnum
Visual Basic (Declaration)
Public Enumeration ParameterTypeEnum
Visual C++
public enum class ParameterTypeEnum

Members

Member name | Description
Boolean | A Boolean data type that represents true or false condition.
DateTime | A DateTime data type that represents the date and time.
Float | A Float data type that represents a floating point decimal value.
Integer | An Integer data type. Valid values range from -2,147,483,648 to 2,147,483,647.
String | A String data type that represents an array of characters.

See Also

PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ProcessingExceptionDetail Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Class
Members See Also Send Feedback
Exceptions are generated when the Microsoft SQL Reporting Services throws a processing exception.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ProcessingExceptionDetail : ExceptionDetailBase
Visual Basic (Declaration)
Public Class ProcessingExceptionDetail _
    Inherits ExceptionDetailBase
Visual C++
public ref class ProcessingExceptionDetail : public ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
PerpetuumSoft.ReportingServices.Viewer.Server..::.ProcessingExceptionDetail

See Also

ProcessingExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ProcessingExceptionDetail Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Members
ProcessingExceptionDetail Class Constructors Methods Properties See Also Send Feedback

The ProcessingExceptionDetail type exposes the following members.

Constructors

Name | Description
ProcessingExceptionDetail | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets or sets an Exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

ProcessingExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ProcessingExceptionDetail Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Constructor
ProcessingExceptionDetail Class See Also Send Feedback

Overload List

Name | Description
ProcessingExceptionDetail(Exception) | Initializes a new instance.
ProcessingExceptionDetail(Exception, ExceptionDetailBase) | Initializes a new instance.

See Also

ProcessingExceptionDetail Class
ProcessingExceptionDetail Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ProcessingExceptionDetail Constructor (Exception)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Constructor (Exception)
ProcessingExceptionDetail Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ProcessingExceptionDetail(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
ProcessingExceptionDetail(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception
A Exception class.

See Also

ProcessingExceptionDetail Class
ProcessingExceptionDetail Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ProcessingExceptionDetail Constructor (Exception, ExceptionDetailBase)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Constructor (Exception, ExceptionDetailBase)
ProcessingExceptionDetail Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ProcessingExceptionDetail(
    Exception exception,
    ExceptionDetailBase innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception, _
    innerException As ExceptionDetailBase _
)
Visual C++
public:
ProcessingExceptionDetail(
    Exception^ exception,
    ExceptionDetailBase^ innerException
)

Parameters

exception
Type: System..::.Exception
A class.
innerException
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase
Inner ExceptionDetailBase.

See Also

ProcessingExceptionDetail Class
ProcessingExceptionDetail Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ProcessingExceptionDetail Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Methods
ProcessingExceptionDetail Class See Also Send Feedback

The ProcessingExceptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessingExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ProcessingExceptionDetail Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ProcessingExceptionDetail Properties
ProcessingExceptionDetail Class See Also Send Feedback

The ProcessingExceptionDetail type exposes the following members.

Properties

Name | Description
Exception | Gets or sets an Exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

ProcessingExceptionDetail Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportDataSource Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Class
Members See Also Send Feedback
Represents the name of a data source and the prompt to display to a user.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ReportDataSource
Visual Basic (Declaration)
Public Class ReportDataSource
Visual C++
public ref class ReportDataSource

Remarks

ReportDataSource is return as property by ReportExecutionInfo class.

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportDataSource

See Also

ReportDataSource Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportDataSource Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Members
ReportDataSource Class Constructors Methods Properties See Also Send Feedback

The ReportDataSource type exposes the following members.

Constructors

Name | Description
ReportDataSource | Initializes a new instance of the ReportDataSource class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataSourceID | Gets or sets the unique ID of a data source.
Name | Gets or sets the name of a data source.
Prompt | The prompt that the report server displays when prompting for user credentials.

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportDataSource Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Constructor
ReportDataSource Class See Also Send Feedback
Initializes a new instance of the ReportDataSource class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportDataSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportDataSource()

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportDataSource Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Methods
ReportDataSource Class See Also Send Feedback

The ReportDataSource type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportDataSource Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource Properties
ReportDataSource Class See Also Send Feedback

The ReportDataSource type exposes the following members.

Properties

Name | Description
DataSourceID | Gets or sets the unique ID of a data source.
Name | Gets or sets the name of a data source.
Prompt | The prompt that the report server displays when prompting for user credentials.

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DataSourceID Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource..::.DataSourceID Property
ReportDataSource Class See Also Send Feedback
Gets or sets the unique ID of a data source.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DataSourceID { get; set; }
Visual Basic (Declaration)
Public Property DataSourceID As String
Visual C++
public:
property String^ DataSourceID {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Name Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource..::.Name Property
ReportDataSource Class See Also Send Feedback
Gets or sets the name of a data source.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Prompt Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSource..::.Prompt Property
ReportDataSource Class See Also Send Feedback
The prompt that the report server displays when prompting for user credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Prompt { get; set; }
Visual Basic (Declaration)
Public Property Prompt As String
Visual C++
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSource Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportDataSourceCredential Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Class
Members See Also Send Feedback
Represents report data source credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ReportDataSourceCredential
Visual Basic (Declaration)
Public Class ReportDataSourceCredential
Visual C++
public ref class ReportDataSourceCredential

Remarks

Use the ReportDataSourceCredential class with the SetDataSourcesCredentials(String, array<ReportDataSourceCredential>[]()[], ExceptionDetailBase%) method to pass credentials to an external data source.

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportDataSourceCredential

See Also

ReportDataSourceCredential Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportDataSourceCredential Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Members
ReportDataSourceCredential Class Constructors Methods Properties See Also Send Feedback

The ReportDataSourceCredential type exposes the following members.

Constructors

Name | Description
ReportDataSourceCredential | Initializes a new instance of the ReportDataSourceCredential class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataSourceName | Gets or sets the name of the data source to which credentials should be passed.
Password | Gets or sets the password that the report server uses to connect to an external data source.
UserName | Gets or sets the user name that the report server uses to connect to an external data source.

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportDataSourceCredential Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Constructor
ReportDataSourceCredential Class See Also Send Feedback
Initializes a new instance of the ReportDataSourceCredential class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportDataSourceCredential()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportDataSourceCredential()

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportDataSourceCredential Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Methods
ReportDataSourceCredential Class See Also Send Feedback

The ReportDataSourceCredential type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportDataSourceCredential Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential Properties
ReportDataSourceCredential Class See Also Send Feedback

The ReportDataSourceCredential type exposes the following members.

Properties

Name | Description
DataSourceName | Gets or sets the name of the data source to which credentials should be passed.
Password | Gets or sets the password that the report server uses to connect to an external data source.
UserName | Gets or sets the user name that the report server uses to connect to an external data source.

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DataSourceName Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential..::.DataSourceName Property
ReportDataSourceCredential Class See Also Send Feedback
Gets or sets the name of the data source to which credentials should be passed.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DataSourceName { get; set; }
Visual Basic (Declaration)
Public Property DataSourceName As String
Visual C++
public:
property String^ DataSourceName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Password Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential..::.Password Property
ReportDataSourceCredential Class See Also Send Feedback
Gets or sets the password that the report server uses to connect to an external data source.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


UserName Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportDataSourceCredential..::.UserName Property
ReportDataSourceCredential Class See Also Send Feedback
Gets or sets the user name that the report server uses to connect to an external data source.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataSourceCredential Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportExecutionInfo Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Class
Members See Also Send Feedback
Describes the state of the current report execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ReportExecutionInfo
Visual Basic (Declaration)
Public Class ReportExecutionInfo
Visual C++
public ref class ReportExecutionInfo

Remarks

This is returned by several methods of MsReportServiceBase class.

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportExecutionInfo

See Also

ReportExecutionInfo Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportExecutionInfo Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Members
ReportExecutionInfo Class Constructors Methods Properties See Also Send Feedback

The ReportExecutionInfo type exposes the following members.

Constructors

Name | Description
ReportExecutionInfo | Initializes a new instance of the ReportExecutionInfo class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CredentialsRequired | Indicates whether the report needs to be supplied with credentials.
DataSourcePrompts | Gets or sets the prompt strings for each data source associated with a report.
ExecutionDateTime | Gets or sets the date and time that the snapshot associated with the created execution.
ExecutionID | Gets or sets a string that uniquely identifies the current execution.
ExpirationDateTime | Gets or sets the date and time that the execution expires.
NeedProcessing | Indicates whether the snapshot associated with the execution needs to be created or reprocessed.
Parameters | Contains the current parameter information for the execution.
ParametersRequired | Indicates whether the report requires parameter values to be supplied.
ReportName | Gets or sets the full path to the report on the server.

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportExecutionInfo Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Constructor
ReportExecutionInfo Class See Also Send Feedback
Initializes a new instance of the ReportExecutionInfo class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportExecutionInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportExecutionInfo()

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportExecutionInfo Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Methods
ReportExecutionInfo Class See Also Send Feedback

The ReportExecutionInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportExecutionInfo Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo Properties
ReportExecutionInfo Class See Also Send Feedback

The ReportExecutionInfo type exposes the following members.

Properties

Name | Description
CredentialsRequired | Indicates whether the report needs to be supplied with credentials.
DataSourcePrompts | Gets or sets the prompt strings for each data source associated with a report.
ExecutionDateTime | Gets or sets the date and time that the snapshot associated with the created execution.
ExecutionID | Gets or sets a string that uniquely identifies the current execution.
ExpirationDateTime | Gets or sets the date and time that the execution expires.
NeedProcessing | Indicates whether the snapshot associated with the execution needs to be created or reprocessed.
Parameters | Contains the current parameter information for the execution.
ParametersRequired | Indicates whether the report requires parameter values to be supplied.
ReportName | Gets or sets the full path to the report on the server.

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CredentialsRequired Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.CredentialsRequired Property
ReportExecutionInfo Class See Also Send Feedback
Indicates whether the report needs to be supplied with credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CredentialsRequired { get; set; }
Visual Basic (Declaration)
Public Property CredentialsRequired As Boolean
Visual C++
public:
property bool CredentialsRequired {
    bool get ();
    void set (bool value);
}

Remarks

The report will not run if the CredentialsRequired property is true.

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DataSourcePrompts Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.DataSourcePrompts Property
ReportExecutionInfo Class See Also Send Feedback
Gets or sets the prompt strings for each data source associated with a report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportDataSource[] DataSourcePrompts { get; set; }
Visual Basic (Declaration)
Public Property DataSourcePrompts As ReportDataSource()
Visual C++
public:
property array<ReportDataSource^>^ DataSourcePrompts {
    array<ReportDataSource^>^ get ();
    void set (array<ReportDataSource^>^ value);
}

Remarks

These prompts are for data sources that can potentially accept credentials. You may still provide different credentials even if credentials have already been provided in the session and the CredentialsRequired property is false.

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionDateTime Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.ExecutionDateTime Property
ReportExecutionInfo Class See Also Send Feedback
Gets or sets the date and time that the snapshot associated with the created execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime ExecutionDateTime { get; set; }
Visual Basic (Declaration)
Public Property ExecutionDateTime As DateTime
Visual C++
public:
property DateTime ExecutionDateTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExecutionID Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.ExecutionID Property
ReportExecutionInfo Class See Also Send Feedback
Gets or sets a string that uniquely identifies the current execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ExecutionID { get; set; }
Visual Basic (Declaration)
Public Property ExecutionID As String
Visual C++
public:
property String^ ExecutionID {
    String^ get ();
    void set (String^ value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ExpirationDateTime Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.ExpirationDateTime Property
ReportExecutionInfo Class See Also Send Feedback
Gets or sets the date and time that the execution expires.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime ExpirationDateTime { get; set; }
Visual Basic (Declaration)
Public Property ExpirationDateTime As DateTime
Visual C++
public:
property DateTime ExpirationDateTime {
    DateTime get ();
    void set (DateTime value);
}

Remarks

This is the expiration date and time of the execution, not the snapshot.

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


NeedProcessing Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.NeedProcessing Property
ReportExecutionInfo Class See Also Send Feedback
Indicates whether the snapshot associated with the execution needs to be created or reprocessed.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool NeedProcessing { get; set; }
Visual Basic (Declaration)
Public Property NeedProcessing As Boolean
Visual C++
public:
property bool NeedProcessing {
    bool get ();
    void set (bool value);
}

Remarks

This is true when:
  • Render has been called for a report.
  • When any parameter values for a report have been changed.
  • If a new set of credentials have been set.
  • If ResetExecution is called on a live or ad-hoc snapshot.
  • When this property is true, the next call to the Render method will cause the snapshot to be created or reprocessed.

    • See Also

    ReportExecutionInfo Class
    PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Parameters Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.Parameters Property
ReportExecutionInfo Class See Also Send Feedback
Contains the current parameter information for the execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportParameter[] Parameters { get; set; }
Visual Basic (Declaration)
Public Property Parameters As ReportParameter()
Visual C++
public:
property array<ReportParameter^>^ Parameters {
    array<ReportParameter^>^ get ();
    void set (array<ReportParameter^>^ value);
}

Remarks

For processed reports or parameters that have been specified, this will contain the parameter values and other information necessary for iterating through the parameter hierarchy.

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ParametersRequired Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.ParametersRequired Property
ReportExecutionInfo Class See Also Send Feedback
Indicates whether the report requires parameter values to be supplied.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ParametersRequired { get; set; }
Visual Basic (Declaration)
Public Property ParametersRequired As Boolean
Visual C++
public:
property bool ParametersRequired {
    bool get ();
    void set (bool value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportName Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportExecutionInfo..::.ReportName Property
ReportExecutionInfo Class See Also Send Feedback
Gets or sets the full path to the report on the server.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ReportName { get; set; }
Visual Basic (Declaration)
Public Property ReportName As String
Visual C++
public:
property String^ ReportName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportExecutionInfo Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportParameter Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Class
Members See Also Send Feedback
Represents a report parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ReportParameter
Visual Basic (Declaration)
Public Class ReportParameter
Visual C++
public ref class ReportParameter

Remarks

A ReportParameter object is passed as input to the SetParameters method.

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportParameter

See Also

ReportParameter Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportParameter Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Members
ReportParameter Class Constructors Methods Properties See Also Send Feedback

The ReportParameter type exposes the following members.

Constructors

Name | Description
ReportParameter | Initializes a new instance of the ReportParameter class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowBlank | Indicates whether an empty string is a valid value for the parameter.
DefaultValues | Gets or sets the default values of the parameter.
Dependencies | Gets or sets a list of parameters which values are used to retrieve additional parameter values in a query.
MultiValue | Indicates if the parameter can be a multivalue parameter.
Name | Gets or sets the name of the parameter.
Nullable | Indicates whether the value of the parameter can be null.
Prompt | Gets or sets the text that prompts the user to provide parameter values.
PromptUser | Indicates if the user is prompted for the value of the parameter.
State | Describes the state (ParameterStateEnum) of the parameter.
Type | The data type (ParameterTypeEnum) of the parameter.
ValidValues | The available valid values for a parameter.

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportParameter Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Constructor
ReportParameter Class See Also Send Feedback
Initializes a new instance of the ReportParameter class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportParameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportParameter()

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportParameter Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Methods
ReportParameter Class See Also Send Feedback

The ReportParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportParameter Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter Properties
ReportParameter Class See Also Send Feedback

The ReportParameter type exposes the following members.

Properties

Name | Description
AllowBlank | Indicates whether an empty string is a valid value for the parameter.
DefaultValues | Gets or sets the default values of the parameter.
Dependencies | Gets or sets a list of parameters which values are used to retrieve additional parameter values in a query.
MultiValue | Indicates if the parameter can be a multivalue parameter.
Name | Gets or sets the name of the parameter.
Nullable | Indicates whether the value of the parameter can be null.
Prompt | Gets or sets the text that prompts the user to provide parameter values.
PromptUser | Indicates if the user is prompted for the value of the parameter.
State | Describes the state (ParameterStateEnum) of the parameter.
Type | The data type (ParameterTypeEnum) of the parameter.
ValidValues | The available valid values for a parameter.

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


AllowBlank Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.AllowBlank Property
ReportParameter Class See Also Send Feedback
Indicates whether an empty string is a valid value for the parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AllowBlank { get; set; }
Visual Basic (Declaration)
Public Property AllowBlank As Boolean
Visual C++
public:
property bool AllowBlank {
    bool get ();
    void set (bool value);
}

Remarks

The AllowBlank property is ignored if the value of the Type property is not a string.

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


DefaultValues Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.DefaultValues Property
ReportParameter Class See Also Send Feedback
Gets or sets the default values of the parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string[] DefaultValues { get; set; }
Visual Basic (Declaration)
Public Property DefaultValues As String()
Visual C++
public:
property array<String^>^ DefaultValues {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Dependencies Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.Dependencies Property
ReportParameter Class See Also Send Feedback
Gets or sets a list of parameters which values are used to retrieve additional parameter values in a query.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string[] Dependencies { get; set; }
Visual Basic (Declaration)
Public Property Dependencies As String()
Visual C++
public:
property array<String^>^ Dependencies {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


MultiValue Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.MultiValue Property
ReportParameter Class See Also Send Feedback
Indicates if the parameter can be a multivalue parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool MultiValue { get; set; }
Visual Basic (Declaration)
Public Property MultiValue As Boolean
Visual C++
public:
property bool MultiValue {
    bool get ();
    void set (bool value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Name Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.Name Property
ReportParameter Class See Also Send Feedback
Gets or sets the name of the parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Nullable Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.Nullable Property
ReportParameter Class See Also Send Feedback
Indicates whether the value of the parameter can be null.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Nullable { get; set; }
Visual Basic (Declaration)
Public Property Nullable As Boolean
Visual C++
public:
property bool Nullable {
    bool get ();
    void set (bool value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Prompt Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.Prompt Property
ReportParameter Class See Also Send Feedback
Gets or sets the text that prompts the user to provide parameter values.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Prompt { get; set; }
Visual Basic (Declaration)
Public Property Prompt As String
Visual C++
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}

Remarks

The default value for the Prompt property which is retrieved from the report definition when a report is firstly published to the report server.

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


PromptUser Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.PromptUser Property
ReportParameter Class See Also Send Feedback
Indicates if the user is prompted for the value of the parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool PromptUser { get; set; }
Visual Basic (Declaration)
Public Property PromptUser As Boolean
Visual C++
public:
property bool PromptUser {
    bool get ();
    void set (bool value);
}

Remarks

Report parameters that contain a value of false for the PromptUser property cannot be submitted as input arguments. In case if you submit a value for the parameter the error is returned.

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


State Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.State Property
ReportParameter Class See Also Send Feedback
Describes the state (ParameterStateEnum) of the parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ParameterStateEnum State { get; set; }
Visual Basic (Declaration)
Public Property State As ParameterStateEnum
Visual C++
public:
property ParameterStateEnum State {
    ParameterStateEnum get ();
    void set (ParameterStateEnum value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Type Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.Type Property
ReportParameter Class See Also Send Feedback
The data type (ParameterTypeEnum) of the parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ParameterTypeEnum Type { get; set; }
Visual Basic (Declaration)
Public Property Type As ParameterTypeEnum
Visual C++
public:
property ParameterTypeEnum Type {
    ParameterTypeEnum get ();
    void set (ParameterTypeEnum value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ValidValues Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameter..::.ValidValues Property
ReportParameter Class See Also Send Feedback
The available valid values for a parameter.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ValidValue[] ValidValues { get; set; }
Visual Basic (Declaration)
Public Property ValidValues As ValidValue()
Visual C++
public:
property array<ValidValue^>^ ValidValues {
    array<ValidValue^>^ get ();
    void set (array<ValidValue^>^ value);
}

See Also

ReportParameter Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportParameterValue Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Class
Members See Also Send Feedback
Represents data that is used in parameterized reports or in delivery extension settings.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ReportParameterValue : ValidValue
Visual Basic (Declaration)
Public Class ReportParameterValue _
    Inherits ValidValue
Visual C++
public ref class ReportParameterValue : public ValidValue

Remarks

ReportParameterValue objects which are used for passing report parameters to reports.

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ValidValue
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportParameterValue

See Also

ReportParameterValue Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportParameterValue Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Members
ReportParameterValue Class Constructors Methods Properties See Also Send Feedback

The ReportParameterValue type exposes the following members.

Constructors

Name | Description
ReportParameterValue | Initializes a new instance of the ReportParameterValue class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Label | Gets or sets the label for the valid value. (Inherited from ValidValue.)
Name | Gets or sets the value name.
Value | Gets or sets a valid value for the setting. (Inherited from ValidValue.)

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportParameterValue Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Constructor
ReportParameterValue Class See Also Send Feedback
Initializes a new instance of the ReportParameterValue class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportParameterValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportParameterValue()

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportParameterValue Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Methods
ReportParameterValue Class See Also Send Feedback

The ReportParameterValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportParameterValue Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue Properties
ReportParameterValue Class See Also Send Feedback

The ReportParameterValue type exposes the following members.

Properties

Name | Description
Label | Gets or sets the label for the valid value. (Inherited from ValidValue.)
Name | Gets or sets the value name.
Value | Gets or sets a valid value for the setting. (Inherited from ValidValue.)

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Name Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportParameterValue..::.Name Property
ReportParameterValue Class See Also Send Feedback
Gets or sets the value name.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ReportParameterValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportProcessingException Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportProcessingException Class
Members See Also Send Feedback
Represents ReportProcessingException exeption.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ReportProcessingException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ReportProcessingException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ReportProcessingException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportProcessingException

See Also

ReportProcessingException Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportProcessingException Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportProcessingException Members
ReportProcessingException Class Constructors Methods Properties See Also Send Feedback

The ReportProcessingException type exposes the following members.

Constructors

Name | Description
ReportProcessingException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ReportProcessingException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportProcessingException Constructor

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportProcessingException Constructor
ReportProcessingException Class See Also Send Feedback

Overload List

Name | Description
ReportProcessingException()()() | Initializes a new instance.
ReportProcessingException(String) | Initializes a new instance.

See Also

ReportProcessingException Class
ReportProcessingException Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportProcessingException Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportProcessingException Constructor
ReportProcessingException Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportProcessingException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportProcessingException()

See Also

ReportProcessingException Class
ReportProcessingException Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportProcessingException Constructor (String)

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportProcessingException Constructor (String)
ReportProcessingException Class See Also Send Feedback
Initializes a new instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportProcessingException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ReportProcessingException(
    String^ message
)

Parameters

message
Type: System..::.String
Exception message.

See Also

ReportProcessingException Class
ReportProcessingException Overload
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportProcessingException Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportProcessingException Methods
ReportProcessingException Class See Also Send Feedback

The ReportProcessingException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ReportProcessingException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportProcessingException Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportProcessingException Properties
ReportProcessingException Class See Also Send Feedback

The ReportProcessingException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ReportProcessingException Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportService Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService Class
Members See Also Send Feedback
Represents service for report generation and getting data about the generated report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ReportService : Component,
    IReportService, IReportServiceResources
Visual Basic (Declaration)
Public MustInherit Class ReportService _
    Inherits Component _
    Implements IReportService, IReportServiceResources
Visual C++
public ref class ReportService abstract : public Component,
    IReportService, IReportServiceResources

Remarks

This is an abstract class and it cannot to be instanced directly.

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportService
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportServiceRemote

See Also

ReportService Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportService Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService Members
ReportService Class Constructors Methods Properties Events See Also Send Feedback

The ReportService type exposes the following members.

Constructors

Name | Description
ReportService | Initializes a new instance. Must be called by inheritors.

Methods

Name | Description
CreateCache | Creates a report cache instance.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Returns result of document export to the specified format.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Find | Returns search results in the document set by identificator.
GetDocumentInfo | Returns report metadata.
GetFont | Returns font definition by the font name.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHtmlExport | Returns result of document export to the HTML format
GetHtmlImage | Returns image from a document by image stream identificator.
GetImageStream | Returns image from a document.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPageInfo | Returns page metadata by report identificator and page number.
GetResource | Returns a resource by set culture.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleError | It is evoked if there is report generation error.
Init | It is invoked for initialization.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
ListExportsFormats | Returns list of available exports formats.
LoadDrillthroughTarget | Creates a report execution from a drill through action.
LoadReport | Loads report into a new execution.
MemberwiseClone | Overloaded.
Print | Returns printable document in html format.
Render | Generates the report and gets identificator of the generated and saved in cash report.
SetDataSourcesCredentials | Sets data sources credentials associated with the current report execution.
SetParameters | Sets and validates parameter values associated with the current report execution.
Sort | Applies or removes a sorting for the execution based on a user sorting action.
ToggleItem | Toggles the show/hide item in a report.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ReportCache | Gets IReportCache instance
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportService Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService Constructor
ReportService Class See Also Send Feedback
Initializes a new instance. Must be called by inheritors.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ReportService()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ReportService()

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportService Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService Methods
ReportService Class See Also Send Feedback

The ReportService type exposes the following members.

Methods

Name | Description
CreateCache | Creates a report cache instance.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Returns result of document export to the specified format.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Find | Returns search results in the document set by identificator.
GetDocumentInfo | Returns report metadata.
GetFont | Returns font definition by the font name.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHtmlExport | Returns result of document export to the HTML format
GetHtmlImage | Returns image from a document by image stream identificator.
GetImageStream | Returns image from a document.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPageInfo | Returns page metadata by report identificator and page number.
GetResource | Returns a resource by set culture.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleError | It is evoked if there is report generation error.
Init | It is invoked for initialization.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
ListExportsFormats | Returns list of available exports formats.
LoadDrillthroughTarget | Creates a report execution from a drill through action.
LoadReport | Loads report into a new execution.
MemberwiseClone | Overloaded.
Print | Returns printable document in html format.
Render | Generates the report and gets identificator of the generated and saved in cash report.
SetDataSourcesCredentials | Sets data sources credentials associated with the current report execution.
SetParameters | Sets and validates parameter values associated with the current report execution.
Sort | Applies or removes a sorting for the execution based on a user sorting action.
ToggleItem | Toggles the show/hide item in a report.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


CreateCache Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.CreateCache Method
ReportService Class See Also Send Feedback
Creates a report cache instance.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual IReportCache CreateCache()
Visual Basic (Declaration)
Protected Overridable Function CreateCache As IReportCache
Visual C++
protected:
virtual IReportCache^ CreateCache()

Return Value

IReportCache interface.

Remarks

It uses session cache by default.
To change default cache behaviour override this method.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Dispose Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.Dispose Method
ReportService Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ReportService Class
ReportService Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Export Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.Export Method
ReportService Class See Also Send Feedback
Returns result of document export to the specified format.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract Stream Export(
    string id,
    string documentName,
    string format
)
Visual Basic (Declaration)
Public MustOverride Function Export ( _
    id As String, _
    documentName As String, _
    format As String _
) As Stream
Visual C++
public:
virtual Stream^ Export(
    String^ id,
    String^ documentName,
    String^ format
) abstract

Parameters

id
Type: System..::.String
Document identifier.
documentName
Type: System..::.String
The name of document.
format
Type: System..::.String
The format to export.

Return Value

Stream class.

Implements

IReportServiceResources..::.Export(String, String, String)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Find Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.Find Method
ReportService Class See Also Send Feedback
Returns search results in the document set by identificator.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract SearchResult Find(
    string id,
    FindOptions findOptions,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public MustOverride Function Find ( _
    id As String, _
    findOptions As FindOptions, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As SearchResult
Visual C++
public:
virtual SearchResult^ Find(
    String^ id,
    FindOptions findOptions,
    [OutAttribute] ExceptionDetailBase^% ReportError
) abstract

Parameters

id
Type: System..::.String
Report identifier.
findOptions
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.FindOptions
Search options (see FindOptions).
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

Search result (see SearchResult).

Implements

IReportService..::.Find(String, FindOptions, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetDocumentInfo Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.GetDocumentInfo Method
ReportService Class See Also Send Feedback
Returns report metadata.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual DocumentInfo GetDocumentInfo(
    string id,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Overridable Function GetDocumentInfo ( _
    id As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As DocumentInfo
Visual C++
public:
virtual DocumentInfo^ GetDocumentInfo(
    String^ id,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
Report identifier.
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

DocumentInfo class.

Implements

IReportService..::.GetDocumentInfo(String, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetFont Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.GetFont Method
ReportService Class See Also Send Feedback
Returns font definition by the font name.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual Stream GetFont(
    string resourceKey
)
Visual Basic (Declaration)
Public Overridable Function GetFont ( _
    resourceKey As String _
) As Stream
Visual C++
public:
virtual Stream^ GetFont(
    String^ resourceKey
)

Parameters

resourceKey
Type: System..::.String
The font name.

Return Value

Stream class.

Implements

IReportServiceResources..::.GetFont(String)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetHtmlExport Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.GetHtmlExport Method
ReportService Class See Also Send Feedback
Returns result of document export to the HTML format

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal virtual Stream GetHtmlExport(
    string id,
    string documentName
)
Visual Basic (Declaration)
Protected Friend Overridable Function GetHtmlExport ( _
    id As String, _
    documentName As String _
) As Stream
Visual C++
protected public:
virtual Stream^ GetHtmlExport(
    String^ id,
    String^ documentName
)

Parameters

id
Type: System..::.String
The execution ID.
documentName
Type: System..::.String
Name of the document.

Return Value

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetHtmlImage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.GetHtmlImage Method
ReportService Class See Also Send Feedback
Returns image from a document by image stream identificator.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract Stream GetHtmlImage(
    string executionId,
    string imageId
)
Visual Basic (Declaration)
Public MustOverride Function GetHtmlImage ( _
    executionId As String, _
    imageId As String _
) As Stream
Visual C++
public:
virtual Stream^ GetHtmlImage(
    String^ executionId,
    String^ imageId
) abstract

Parameters

executionId
Type: System..::.String
Report identifier.
imageId
Type: System..::.String
The image identifier.

Return Value

Stream class.

Implements

IReportServiceResources..::.GetHtmlImage(String, String)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetImageStream Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.GetImageStream Method
ReportService Class See Also Send Feedback
Returns image from a document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual Stream GetImageStream(
    string id,
    string resourceId
)
Visual Basic (Declaration)
Public Overridable Function GetImageStream ( _
    id As String, _
    resourceId As String _
) As Stream
Visual C++
public:
virtual Stream^ GetImageStream(
    String^ id,
    String^ resourceId
)

Parameters

id
Type: System..::.String
The document identifier.
resourceId
Type: System..::.String
The resource identifier.

Return Value

Stream class.

Implements

IReportServiceResources..::.GetImageStream(String, String)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetPageInfo Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.GetPageInfo Method
ReportService Class See Also Send Feedback
Returns page metadata by report identificator and page number.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual PageInfo GetPageInfo(
    string id,
    int pageNumber,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Overridable Function GetPageInfo ( _
    id As String, _
    pageNumber As Integer, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As PageInfo
Visual C++
public:
virtual PageInfo^ GetPageInfo(
    String^ id,
    int pageNumber,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
Report identifier.
pageNumber
Type: System..::.Int32
The page number which should be get.
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

PageInfo class.

Implements

IReportService..::.GetPageInfo(String, Int32, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetResource Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.GetResource Method
ReportService Class See Also Send Feedback
Returns a resource by set culture.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual Stream GetResource(
    string culture
)
Visual Basic (Declaration)
Public Overridable Function GetResource ( _
    culture As String _
) As Stream
Visual C++
public:
virtual Stream^ GetResource(
    String^ culture
)

Parameters

culture
Type: System..::.String
Resource culture.

Return Value

Stream class.

Implements

IReportServiceResources..::.GetResource(String)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


HandleError Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.HandleError Method
ReportService Class See Also Send Feedback
It is evoked if there is report generation error.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual ExceptionDetailBase HandleError(
    Exception e
)
Visual Basic (Declaration)
Protected Overridable Function HandleError ( _
    e As Exception _
) As ExceptionDetailBase
Visual C++
protected:
virtual ExceptionDetailBase^ HandleError(
    Exception^ e
)

Parameters

e
Type: System..::.Exception
Exception class.

Return Value

ExceptionDetailBase class.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Init Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.Init Method
ReportService Class See Also Send Feedback
It is invoked for initialization.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual void Init()
Visual Basic (Declaration)
Public Overridable Sub Init
Visual C++
public:
virtual void Init()

Implements

IReportService..::.Init()()()

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ListExportsFormats Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.ListExportsFormats Method
ReportService Class See Also Send Feedback
Returns list of available exports formats.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract ExportsEnum[] ListExportsFormats(
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public MustOverride Function ListExportsFormats ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ExportsEnum()
Visual C++
public:
virtual array<ExportsEnum>^ ListExportsFormats(
    [OutAttribute] ExceptionDetailBase^% ReportError
) abstract

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

List of ExportsEnum.

Implements

IReportService..::.ListExportsFormats(ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


LoadDrillthroughTarget Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.LoadDrillthroughTarget Method
ReportService Class See Also Send Feedback
Creates a report execution from a drill through action.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract ReportExecutionInfo LoadDrillthroughTarget(
    string id,
    string DrillthroughID,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public MustOverride Function LoadDrillthroughTarget ( _
    id As String, _
    DrillthroughID As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
public:
virtual ReportExecutionInfo^ LoadDrillthroughTarget(
    String^ id,
    String^ DrillthroughID,
    [OutAttribute] ExceptionDetailBase^% ReportError
) abstract

Parameters

id
Type: System..::.String
Report identifier
DrillthroughID
Type: System..::.String
The drillthrough identifier.
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class.

Implements

IReportService..::.LoadDrillthroughTarget(String, String, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


LoadReport Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.LoadReport Method
ReportService Class See Also Send Feedback
Loads report into a new execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract ReportExecutionInfo LoadReport(
    string report,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public MustOverride Function LoadReport ( _
    report As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
public:
virtual ReportExecutionInfo^ LoadReport(
    String^ report,
    [OutAttribute] ExceptionDetailBase^% ReportError
) abstract

Parameters

report
Type: System..::.String
Report name.
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class

Implements

IReportService..::.LoadReport(String, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


MemberwiseClone Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.MemberwiseClone Method
ReportService Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportService Class
ReportService Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Print Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.Print Method
ReportService Class See Also Send Feedback
Returns printable document in html format.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual Stream Print(
    string id,
    string documentName
)
Visual Basic (Declaration)
Public Overridable Function Print ( _
    id As String, _
    documentName As String _
) As Stream
Visual C++
public:
virtual Stream^ Print(
    String^ id,
    String^ documentName
)

Parameters

id
Type: System..::.String
The id.
documentName
Type: System..::.String
Name of the document.

Return Value

Stream class.

Implements

IReportServiceResources..::.Print(String, String)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Render Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.Render Method
ReportService Class See Also Send Feedback
Generates the report and gets identificator of the generated and saved in cash report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract string Render(
    string id,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public MustOverride Function Render ( _
    id As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As String
Visual C++
public:
virtual String^ Render(
    String^ id,
    [OutAttribute] ExceptionDetailBase^% ReportError
) abstract

Parameters

id
Type: System..::.String
Report identifier
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

Generated document identifier.

Implements

IReportService..::.Render(String, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SetDataSourcesCredentials Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.SetDataSourcesCredentials Method
ReportService Class See Also Send Feedback
Sets data sources credentials associated with the current report execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract ReportExecutionInfo SetDataSourcesCredentials(
    string id,
    ReportDataSourceCredential[] credentials,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public MustOverride Function SetDataSourcesCredentials ( _
    id As String, _
    credentials As ReportDataSourceCredential(), _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
public:
virtual ReportExecutionInfo^ SetDataSourcesCredentials(
    String^ id,
    array<ReportDataSourceCredential^>^ credentials,
    [OutAttribute] ExceptionDetailBase^% ReportError
) abstract

Parameters

id
Type: System..::.String
Report identifier.
credentials
Type: array< PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportDataSourceCredential >[]()[]
List of data sources credentials (see ReportDataSourceCredential).
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class.

Implements

IReportService..::.SetDataSourcesCredentials(String, array<ReportDataSourceCredential>[]()[], ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SetParameters Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.SetParameters Method
ReportService Class See Also Send Feedback
Sets and validates parameter values associated with the current report execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract ReportExecutionInfo SetParameters(
    string id,
    ReportParameterValue[] paramatersValues,
    string parametersLanguage,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public MustOverride Function SetParameters ( _
    id As String, _
    paramatersValues As ReportParameterValue(), _
    parametersLanguage As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
public:
virtual ReportExecutionInfo^ SetParameters(
    String^ id,
    array<ReportParameterValue^>^ paramatersValues,
    String^ parametersLanguage,
    [OutAttribute] ExceptionDetailBase^% ReportError
) abstract

Parameters

id
Type: System..::.String
Report identifier.
paramatersValues
Type: array< PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportParameterValue >[]()[]
List of parameters values (see ReportParameterValue)
parametersLanguage
Type: System..::.String
Parameter language. It must be CultureInfo.CurrentUICulture.Name value. (Name)
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class.

Implements

IReportService..::.SetParameters(String, array<ReportParameterValue>[]()[], String, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.
If ParameterLanguage is specified, parameters are interpreted in this language. If ParameterLanguage is not specified, the default behavior is used.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Sort Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.Sort Method
ReportService Class See Also Send Feedback
Applies or removes a sorting for the execution based on a user sorting action.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract int Sort(
    string id,
    string elementId,
    SortDirectionEnum sortDirection,
    out ExceptionDetailBase reportError
)
Visual Basic (Declaration)
Public MustOverride Function Sort ( _
    id As String, _
    elementId As String, _
    sortDirection As SortDirectionEnum, _
    <OutAttribute> ByRef reportError As ExceptionDetailBase _
) As Integer
Visual C++
public:
virtual int Sort(
    String^ id,
    String^ elementId,
    SortDirectionEnum sortDirection,
    [OutAttribute] ExceptionDetailBase^% reportError
) abstract

Parameters

id
Type: System..::.String
Report identifier./
elementId
Type: System..::.String
The element identifier to specify user sorting action.
sortDirection
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.SortDirectionEnum
Sorting direction (see SortDirectionEnum).
reportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

New page index.

Implements

IReportService..::.Sort(String, String, SortDirectionEnum, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ToggleItem Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.ToggleItem Method
ReportService Class See Also Send Feedback
Toggles the show/hide item in a report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract bool ToggleItem(
    string id,
    string elementId,
    out ExceptionDetailBase reportError
)
Visual Basic (Declaration)
Public MustOverride Function ToggleItem ( _
    id As String, _
    elementId As String, _
    <OutAttribute> ByRef reportError As ExceptionDetailBase _
) As Boolean
Visual C++
public:
virtual bool ToggleItem(
    String^ id,
    String^ elementId,
    [OutAttribute] ExceptionDetailBase^% reportError
) abstract

Parameters

id
Type: System..::.String
Report identifier./
elementId
Type: System..::.String
The element identifier to specify toggle item action.
reportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

A Boolean value indicating whether the item was found.

Implements

IReportService..::.ToggleItem(String, String, ExceptionDetailBase%)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportService Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService Properties
ReportService Class See Also Send Feedback

The ReportService type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ReportCache | Gets IReportCache instance
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportCache Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService..::.ReportCache Property
ReportService Class See Also Send Feedback
Gets IReportCache instance

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected IReportCache ReportCache { get; private set; }
Visual Basic (Declaration)
Protected Property ReportCache As IReportCache
Visual C++
protected:
property IReportCache^ ReportCache {
    IReportCache^ get ();
    void set (IReportCache^ value);
}

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportService Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportService Events
ReportService Class See Also Send Feedback

The ReportService type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ReportService Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportServiceRemote Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote Class
Members See Also Send Feedback
Represents service for report generation and getting data about generated report. Remote mode.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ReportServiceRemote : ReportService
Visual Basic (Declaration)
Public Class ReportServiceRemote _
    Inherits ReportService
Visual C++
public ref class ReportServiceRemote : public ReportService

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportService
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportServiceRemote

See Also

ReportServiceRemote Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportServiceRemote Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote Members
ReportServiceRemote Class Constructors Methods Properties Events See Also Send Feedback

The ReportServiceRemote type exposes the following members.

Constructors

Name | Description
ReportServiceRemote | Initializes a new instance of the ReportServiceRemote class

Methods

Name | Description
CreateCache | Creates a report cache instance. (Inherited from ReportService.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Returns result of document export to the specified format. (Overrides ReportService..::.Export(String, String, String).)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Find | Returns search results in the document set by identificator. (Overrides ReportService..::.Find(String, FindOptions, ExceptionDetailBase%).)
GetDocumentInfo | Returns report metadata. (Inherited from ReportService.)
GetFont | Returns font definition by the font name. (Inherited from ReportService.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHtmlExport | Returns result of document export to the HTML format (Overrides ReportService..::.GetHtmlExport(String, String).)
GetHtmlImage | Returns image from a document by image stream identificator. (Overrides ReportService..::.GetHtmlImage(String, String).)
GetImageStream | Returns image from a document. (Inherited from ReportService.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPageInfo | Returns page metadata by report identificator and page number. (Inherited from ReportService.)
GetResource | Returns a resource by set culture. (Inherited from ReportService.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetServiceCredentials | Returns service credentials.
GetServiceUrl | Returns service Url.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleError | It is evoked if there is report generation error. (Inherited from ReportService.)
Init | It is invoked for initialization. (Inherited from ReportService.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
ListExportsFormats | Returns list of available exports formats. (Overrides ReportService..::.ListExportsFormats(ExceptionDetailBase%).)
LoadDrillthroughTarget | Creates a report execution from a drill through action. (Overrides ReportService..::.LoadDrillthroughTarget(String, String, ExceptionDetailBase%).)
LoadReport | Loads report into a new execution. (Overrides ReportService..::.LoadReport(String, ExceptionDetailBase%).)
MemberwiseClone | Overloaded.
Print | Returns printable document in html format. (Inherited from ReportService.)
Render | Generates the report and gets identificator of the generated and saved in cash report. (Overrides ReportService..::.Render(String, ExceptionDetailBase%).)
SetDataSourcesCredentials | Sets data sources credentials associated with the current report execution. (Overrides ReportService..::.SetDataSourcesCredentials(String, array<ReportDataSourceCredential>[]()[], ExceptionDetailBase%).)
SetParameters | Sets and validates parameter values associated with the current report execution. (Overrides ReportService..::.SetParameters(String, array<ReportParameterValue>[]()[], String, ExceptionDetailBase%).)
Sort | Applies or removes a sorting for the execution based on a user sorting action. (Overrides ReportService..::.Sort(String, String, SortDirectionEnum, ExceptionDetailBase%).)
ToggleItem | Toggles the show/hide item in a report. (Overrides ReportService..::.ToggleItem(String, String, ExceptionDetailBase%).)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ReportCache | Gets IReportCache instance (Inherited from ReportService.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportServiceRemote Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote Constructor
ReportServiceRemote Class See Also Send Feedback
Initializes a new instance of the ReportServiceRemote class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReportServiceRemote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportServiceRemote()

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportServiceRemote Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote Methods
ReportServiceRemote Class See Also Send Feedback

The ReportServiceRemote type exposes the following members.

Methods

Name | Description
CreateCache | Creates a report cache instance. (Inherited from ReportService.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Returns result of document export to the specified format. (Overrides ReportService..::.Export(String, String, String).)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Find | Returns search results in the document set by identificator. (Overrides ReportService..::.Find(String, FindOptions, ExceptionDetailBase%).)
GetDocumentInfo | Returns report metadata. (Inherited from ReportService.)
GetFont | Returns font definition by the font name. (Inherited from ReportService.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHtmlExport | Returns result of document export to the HTML format (Overrides ReportService..::.GetHtmlExport(String, String).)
GetHtmlImage | Returns image from a document by image stream identificator. (Overrides ReportService..::.GetHtmlImage(String, String).)
GetImageStream | Returns image from a document. (Inherited from ReportService.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPageInfo | Returns page metadata by report identificator and page number. (Inherited from ReportService.)
GetResource | Returns a resource by set culture. (Inherited from ReportService.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetServiceCredentials | Returns service credentials.
GetServiceUrl | Returns service Url.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleError | It is evoked if there is report generation error. (Inherited from ReportService.)
Init | It is invoked for initialization. (Inherited from ReportService.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
ListExportsFormats | Returns list of available exports formats. (Overrides ReportService..::.ListExportsFormats(ExceptionDetailBase%).)
LoadDrillthroughTarget | Creates a report execution from a drill through action. (Overrides ReportService..::.LoadDrillthroughTarget(String, String, ExceptionDetailBase%).)
LoadReport | Loads report into a new execution. (Overrides ReportService..::.LoadReport(String, ExceptionDetailBase%).)
MemberwiseClone | Overloaded.
Print | Returns printable document in html format. (Inherited from ReportService.)
Render | Generates the report and gets identificator of the generated and saved in cash report. (Overrides ReportService..::.Render(String, ExceptionDetailBase%).)
SetDataSourcesCredentials | Sets data sources credentials associated with the current report execution. (Overrides ReportService..::.SetDataSourcesCredentials(String, array<ReportDataSourceCredential>[]()[], ExceptionDetailBase%).)
SetParameters | Sets and validates parameter values associated with the current report execution. (Overrides ReportService..::.SetParameters(String, array<ReportParameterValue>[]()[], String, ExceptionDetailBase%).)
Sort | Applies or removes a sorting for the execution based on a user sorting action. (Overrides ReportService..::.Sort(String, String, SortDirectionEnum, ExceptionDetailBase%).)
ToggleItem | Toggles the show/hide item in a report. (Overrides ReportService..::.ToggleItem(String, String, ExceptionDetailBase%).)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Dispose Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.Dispose Method
ReportServiceRemote Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ReportServiceRemote Class
ReportServiceRemote Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Export Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.Export Method
ReportServiceRemote Class See Also Send Feedback
Returns result of document export to the specified format.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override Stream Export(
    string id,
    string documentName,
    string format
)
Visual Basic (Declaration)
Public Overrides Function Export ( _
    id As String, _
    documentName As String, _
    format As String _
) As Stream
Visual C++
public:
virtual Stream^ Export(
    String^ id,
    String^ documentName,
    String^ format
) override

Parameters

id
Type: System..::.String
Document identifier.
documentName
Type: System..::.String
The name of document.
format
Type: System..::.String
The format to export.

Return Value

Stream class.

Implements

IReportServiceResources..::.Export(String, String, String)

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Find Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.Find Method
ReportServiceRemote Class See Also Send Feedback
Returns search results in the document set by identificator.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override SearchResult Find(
    string id,
    FindOptions findOptions,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Overrides Function Find ( _
    id As String, _
    findOptions As FindOptions, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As SearchResult
Visual C++
public:
virtual SearchResult^ Find(
    String^ id,
    FindOptions findOptions,
    [OutAttribute] ExceptionDetailBase^% ReportError
) override

Parameters

id
Type: System..::.String
Report identifier.
findOptions
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.FindOptions
Search options (see FindOptions).
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

Search result (see SearchResult).

Implements

IReportService..::.Find(String, FindOptions, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetHtmlExport Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.GetHtmlExport Method
ReportServiceRemote Class See Also Send Feedback
Returns result of document export to the HTML format

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal override Stream GetHtmlExport(
    string id,
    string documentName
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetHtmlExport ( _
    id As String, _
    documentName As String _
) As Stream
Visual C++
protected public:
virtual Stream^ GetHtmlExport(
    String^ id,
    String^ documentName
) override

Parameters

id
Type: System..::.String
The execution ID.
documentName
Type: System..::.String
Name of the document.

Return Value

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetHtmlImage Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.GetHtmlImage Method
ReportServiceRemote Class See Also Send Feedback
Returns image from a document by image stream identificator.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override Stream GetHtmlImage(
    string executionId,
    string imageId
)
Visual Basic (Declaration)
Public Overrides Function GetHtmlImage ( _
    executionId As String, _
    imageId As String _
) As Stream
Visual C++
public:
virtual Stream^ GetHtmlImage(
    String^ executionId,
    String^ imageId
) override

Parameters

executionId
Type: System..::.String
Report identifier.
imageId
Type: System..::.String
The image identifier.

Return Value

Stream class.

Implements

IReportServiceResources..::.GetHtmlImage(String, String)

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetServiceCredentials Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.GetServiceCredentials Method
ReportServiceRemote Class See Also Send Feedback
Returns service credentials.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual ICredentials GetServiceCredentials()
Visual Basic (Declaration)
Protected Overridable Function GetServiceCredentials As ICredentials
Visual C++
protected:
virtual ICredentials^ GetServiceCredentials()

Return Value

ICredentials interface.

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


GetServiceUrl Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.GetServiceUrl Method
ReportServiceRemote Class See Also Send Feedback
Returns service Url.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual string GetServiceUrl()
Visual Basic (Declaration)
Protected Overridable Function GetServiceUrl As String
Visual C++
protected:
virtual String^ GetServiceUrl()

Return Value

service Url.

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ListExportsFormats Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.ListExportsFormats Method
ReportServiceRemote Class See Also Send Feedback
Returns list of available exports formats.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override ExportsEnum[] ListExportsFormats(
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Overrides Function ListExportsFormats ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ExportsEnum()
Visual C++
public:
virtual array<ExportsEnum>^ ListExportsFormats(
    [OutAttribute] ExceptionDetailBase^% ReportError
) override

Parameters

ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

List of ExportsEnum.

Implements

IReportService..::.ListExportsFormats(ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


LoadDrillthroughTarget Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.LoadDrillthroughTarget Method
ReportServiceRemote Class See Also Send Feedback
Creates a report execution from a drill through action.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override ReportExecutionInfo LoadDrillthroughTarget(
    string id,
    string DrillthroughID,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Overrides Function LoadDrillthroughTarget ( _
    id As String, _
    DrillthroughID As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
public:
virtual ReportExecutionInfo^ LoadDrillthroughTarget(
    String^ id,
    String^ DrillthroughID,
    [OutAttribute] ExceptionDetailBase^% ReportError
) override

Parameters

id
Type: System..::.String
Report identifier
DrillthroughID
Type: System..::.String
The drillthrough identifier.
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class.

Implements

IReportService..::.LoadDrillthroughTarget(String, String, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


LoadReport Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.LoadReport Method
ReportServiceRemote Class See Also Send Feedback
Loads report into a new execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override ReportExecutionInfo LoadReport(
    string report,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Overrides Function LoadReport ( _
    report As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
public:
virtual ReportExecutionInfo^ LoadReport(
    String^ report,
    [OutAttribute] ExceptionDetailBase^% ReportError
) override

Parameters

report
Type: System..::.String
Report name.
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class

Implements

IReportService..::.LoadReport(String, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


MemberwiseClone Method

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.MemberwiseClone Method
ReportServiceRemote Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportServiceRemote Class
ReportServiceRemote Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Render Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.Render Method
ReportServiceRemote Class See Also Send Feedback
Generates the report and gets identificator of the generated and saved in cash report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string Render(
    string id,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Overrides Function Render ( _
    id As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As String
Visual C++
public:
virtual String^ Render(
    String^ id,
    [OutAttribute] ExceptionDetailBase^% ReportError
) override

Parameters

id
Type: System..::.String
Report identifier
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

Generated document identifier.

Implements

IReportService..::.Render(String, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SetDataSourcesCredentials Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.SetDataSourcesCredentials Method
ReportServiceRemote Class See Also Send Feedback
Sets data sources credentials associated with the current report execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override ReportExecutionInfo SetDataSourcesCredentials(
    string id,
    ReportDataSourceCredential[] credentials,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Overrides Function SetDataSourcesCredentials ( _
    id As String, _
    credentials As ReportDataSourceCredential(), _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
public:
virtual ReportExecutionInfo^ SetDataSourcesCredentials(
    String^ id,
    array<ReportDataSourceCredential^>^ credentials,
    [OutAttribute] ExceptionDetailBase^% ReportError
) override

Parameters

id
Type: System..::.String
Report identifier.
credentials
Type: array< PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportDataSourceCredential >[]()[]
List of data sources credentials (see ReportDataSourceCredential).
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class.

Implements

IReportService..::.SetDataSourcesCredentials(String, array<ReportDataSourceCredential>[]()[], ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SetParameters Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.SetParameters Method
ReportServiceRemote Class See Also Send Feedback
Sets and validates parameter values associated with the current report execution.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override ReportExecutionInfo SetParameters(
    string id,
    ReportParameterValue[] paramatersValues,
    string parametersLanguage,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Overrides Function SetParameters ( _
    id As String, _
    paramatersValues As ReportParameterValue(), _
    parametersLanguage As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As ReportExecutionInfo
Visual C++
public:
virtual ReportExecutionInfo^ SetParameters(
    String^ id,
    array<ReportParameterValue^>^ paramatersValues,
    String^ parametersLanguage,
    [OutAttribute] ExceptionDetailBase^% ReportError
) override

Parameters

id
Type: System..::.String
Report identifier.
paramatersValues
Type: array< PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportParameterValue >[]()[]
List of parameters values (see ReportParameterValue)
parametersLanguage
Type: System..::.String
Parameter language. It must be CultureInfo.CurrentUICulture.Name value. (Name)
ReportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

ReportExecutionInfo class.

Implements

IReportService..::.SetParameters(String, array<ReportParameterValue>[]()[], String, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.
If ParameterLanguage is specified, parameters are interpreted in this language. If ParameterLanguage is not specified, the default behavior is used.

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Sort Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.Sort Method
ReportServiceRemote Class See Also Send Feedback
Applies or removes a sorting for the execution based on a user sorting action.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int Sort(
    string id,
    string elementId,
    SortDirectionEnum sortDirection,
    out ExceptionDetailBase reportError
)
Visual Basic (Declaration)
Public Overrides Function Sort ( _
    id As String, _
    elementId As String, _
    sortDirection As SortDirectionEnum, _
    <OutAttribute> ByRef reportError As ExceptionDetailBase _
) As Integer
Visual C++
public:
virtual int Sort(
    String^ id,
    String^ elementId,
    SortDirectionEnum sortDirection,
    [OutAttribute] ExceptionDetailBase^% reportError
) override

Parameters

id
Type: System..::.String
Report identifier./
elementId
Type: System..::.String
The element identifier to specify user sorting action.
sortDirection
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.SortDirectionEnum
Sorting direction (see SortDirectionEnum).
reportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

New page index.

Implements

IReportService..::.Sort(String, String, SortDirectionEnum, ExceptionDetailBase%)

Remarks

If error occurs then ReportError is not null.

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ToggleItem Method

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote..::.ToggleItem Method
ReportServiceRemote Class See Also Send Feedback
Toggles the show/hide item in a report.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool ToggleItem(
    string id,
    string elementId,
    out ExceptionDetailBase reportError
)
Visual Basic (Declaration)
Public Overrides Function ToggleItem ( _
    id As String, _
    elementId As String, _
    <OutAttribute> ByRef reportError As ExceptionDetailBase _
) As Boolean
Visual C++
public:
virtual bool ToggleItem(
    String^ id,
    String^ elementId,
    [OutAttribute] ExceptionDetailBase^% reportError
) override

Parameters

id
Type: System..::.String
Report identifier./
elementId
Type: System..::.String
The element identifier to specify toggle item action.
reportError
Type: PerpetuumSoft.ReportingServices.Viewer.Server..::.ExceptionDetailBase %
ExceptionDetailBase class.

Return Value

A Boolean value indicating whether the item was found.

Implements

IReportService..::.ToggleItem(String, String, ExceptionDetailBase%)

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportServiceRemote Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote Properties
ReportServiceRemote Class See Also Send Feedback

The ReportServiceRemote type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ReportCache | Gets IReportCache instance (Inherited from ReportService.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ReportServiceRemote Events

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ReportServiceRemote Events
ReportServiceRemote Class See Also Send Feedback

The ReportServiceRemote type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ReportServiceRemote Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SearchDirectionEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchDirectionEnum Enumeration
See Also Send Feedback
Specifies search direction.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum SearchDirectionEnum
Visual Basic (Declaration)
Public Enumeration SearchDirectionEnum
Visual C++
public enum class SearchDirectionEnum

Members

Member name | Description
Forward | Specifies search forward direction.
Backward | Specifies search backward direction.

See Also

PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SearchResult Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Class
Members See Also Send Feedback
Represents text search results.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SearchResult
Visual Basic (Declaration)
Public Class SearchResult
Visual C++
public ref class SearchResult

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.SearchResult

See Also

SearchResult Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SearchResult Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Members
SearchResult Class Constructors Methods Properties See Also Send Feedback

The SearchResult type exposes the following members.

Constructors

Name | Description
SearchResult | Initializes a new instance of the SearchResult class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ControlIndex | Gets or sets a report control number on a page.
Direction | Gets or sets search direction.
EndPageIndex | Gets or sets end page index for search.
FindText | Gets or sets a text for search.
FromBegining | Gets or sets value which specifies if the search starts from begining of document.
Height | Gets or sets the height of the fragment which contains required text.
PageIndex | Gets or sets start page index for search.
SearchType | Specifies server search type.
TextFound | Gets or sets values which indicate if required text was found.
Width | Gets or sets the width of the fragment which includes required text.
X | Gets or sets the ordinate of the fragment beginning which includes required text.
Y | Gets or sets the ordinate of the fragment beginning which includes required text.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SearchResult Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Constructor
SearchResult Class See Also Send Feedback
Initializes a new instance of the SearchResult class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchResult()

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SearchResult Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Methods
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SearchResult Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult Properties
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Properties

Name | Description
ControlIndex | Gets or sets a report control number on a page.
Direction | Gets or sets search direction.
EndPageIndex | Gets or sets end page index for search.
FindText | Gets or sets a text for search.
FromBegining | Gets or sets value which specifies if the search starts from begining of document.
Height | Gets or sets the height of the fragment which contains required text.
PageIndex | Gets or sets start page index for search.
SearchType | Specifies server search type.
TextFound | Gets or sets values which indicate if required text was found.
Width | Gets or sets the width of the fragment which includes required text.
X | Gets or sets the ordinate of the fragment beginning which includes required text.
Y | Gets or sets the ordinate of the fragment beginning which includes required text.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ControlIndex Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.ControlIndex Property
SearchResult Class See Also Send Feedback
Gets or sets a report control number on a page.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int ControlIndex { get; set; }
Visual Basic (Declaration)
Public Property ControlIndex As Integer
Visual C++
public:
property int ControlIndex {
    int get ();
    void set (int value);
}

Remarks

Not used for Reporting Services server.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Direction Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.Direction Property
SearchResult Class See Also Send Feedback
Gets or sets search direction.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchDirectionEnum Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As SearchDirectionEnum
Visual C++
public:
property SearchDirectionEnum Direction {
    SearchDirectionEnum get ();
    void set (SearchDirectionEnum value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


EndPageIndex Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.EndPageIndex Property
SearchResult Class See Also Send Feedback
Gets or sets end page index for search.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int EndPageIndex { get; set; }
Visual Basic (Declaration)
Public Property EndPageIndex As Integer
Visual C++
public:
property int EndPageIndex {
    int get ();
    void set (int value);
}

Remarks

If EndPageIndex property is not specify, it will be set to last page of report.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FindText Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.FindText Property
SearchResult Class See Also Send Feedback
Gets or sets a text for search.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FindText { get; set; }
Visual Basic (Declaration)
Public Property FindText As String
Visual C++
public:
property String^ FindText {
    String^ get ();
    void set (String^ value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


FromBegining Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.FromBegining Property
SearchResult Class See Also Send Feedback
Gets or sets value which specifies if the search starts from begining of document.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool FromBegining { get; set; }
Visual Basic (Declaration)
Public Property FromBegining As Boolean
Visual C++
public:
property bool FromBegining {
    bool get ();
    void set (bool value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Height Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.Height Property
SearchResult Class See Also Send Feedback
Gets or sets the height of the fragment which contains required text.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Remarks

Not used for Reporting Services server.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


PageIndex Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.PageIndex Property
SearchResult Class See Also Send Feedback
Gets or sets start page index for search.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int PageIndex { get; set; }
Visual Basic (Declaration)
Public Property PageIndex As Integer
Visual C++
public:
property int PageIndex {
    int get ();
    void set (int value);
}

Remarks

If the SearchResult is the search result, it determines the page index where the text is found.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SearchType Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.SearchType Property
SearchResult Class See Also Send Feedback
Specifies server search type.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchTypeEnum SearchType { get; set; }
Visual Basic (Declaration)
Public Property SearchType As SearchTypeEnum
Visual C++
public:
property SearchTypeEnum SearchType {
    SearchTypeEnum get ();
    void set (SearchTypeEnum value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


TextFound Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.TextFound Property
SearchResult Class See Also Send Feedback
Gets or sets values which indicate if required text was found.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool TextFound { get; set; }
Visual Basic (Declaration)
Public Property TextFound As Boolean
Visual C++
public:
property bool TextFound {
    bool get ();
    void set (bool value);
}

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Width Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.Width Property
SearchResult Class See Also Send Feedback
Gets or sets the width of the fragment which includes required text.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

Not used for Reporting Services server.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


X Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.X Property
SearchResult Class See Also Send Feedback
Gets or sets the ordinate of the fragment beginning which includes required text.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

Remarks

Not used for Reporting Services server.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Y Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchResult..::.Y Property
SearchResult Class See Also Send Feedback
Gets or sets the ordinate of the fragment beginning which includes required text.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

Remarks

Not used for Reporting Services server.

See Also

SearchResult Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SearchTypeEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SearchTypeEnum Enumeration
See Also Send Feedback
Specifies a search type.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum SearchTypeEnum
Visual Basic (Declaration)
Public Enumeration SearchTypeEnum
Visual C++
public enum class SearchTypeEnum

Members

Member name | Description
Reporting | Specifies Microsoft SQL Reporting Services search type.
Shooter | Specifies Perpertuum Software Report Sharp-Shooter for Silverlight search type.

Remarks

This property can't be used directly.

See Also

PerpetuumSoft.ReportingServices.Viewer.Server Namespace


SortDirectionEnum Enumeration

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
SortDirectionEnum Enumeration
See Also Send Feedback
Specifies sorting directions.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum SortDirectionEnum
Visual Basic (Declaration)
Public Enumeration SortDirectionEnum
Visual C++
public enum class SortDirectionEnum

Members

Member name | Description
Ascending | Specifies an ascending sorting direction.
Descending | Specifies a descending sorting direction.
None | No sorting direction specified.

Remarks

Use the SortDirectionEnum enumeration with the Sort method.

See Also

PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ValidValue Class

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Class
Members See Also Send Feedback
Represents a valid value for an extension setting.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ValidValue
Visual Basic (Declaration)
Public Class ValidValue
Visual C++
public ref class ValidValue

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.ReportingServices.Viewer.Server..::.ValidValue
PerpetuumSoft.ReportingServices.Viewer.Server..::.ReportParameterValue

See Also

ValidValue Members
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ValidValue Members

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Members
ValidValue Class Constructors Methods Properties See Also Send Feedback

The ValidValue type exposes the following members.

Constructors

Name | Description
ValidValue | Initializes a new instance of the ValidValue class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Label | Gets or sets the label for the valid value.
Value | Gets or sets a valid value for the setting.

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ValidValue Constructor

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Constructor
ValidValue Class See Also Send Feedback
Initializes a new instance of the ValidValue class

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ValidValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ValidValue()

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ValidValue Methods

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Methods
ValidValue Class See Also Send Feedback

The ValidValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


ValidValue Properties

[image] [image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue Properties
ValidValue Class See Also Send Feedback

The ValidValue type exposes the following members.

Properties

Name | Description
Label | Gets or sets the label for the valid value.
Value | Gets or sets a valid value for the setting.

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Label Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue..::.Label Property
ValidValue Class See Also Send Feedback
Gets or sets the label for the valid value.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Label { get; set; }
Visual Basic (Declaration)
Public Property Label As String
Visual C++
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}

Remarks

The Label property is used in cases where you need to display an alternate name for the setting value to an end user. The Label property might be used in the case where the value of the setting that is displayed to the end user is dependent on culture information.

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace


Value Property

[image]

Silverlight Viewer for Reporting Services 2008 Class Library
ValidValue..::.Value Property
ValidValue Class See Also Send Feedback
Gets or sets a valid value for the setting.

Namespace: PerpetuumSoft.ReportingServices.Viewer.Server
Assembly: PerpetuumSoft.ReportingServices.Viewer.Server (in PerpetuumSoft.ReportingServices.Viewer.Server.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

ValidValue Class
PerpetuumSoft.ReportingServices.Viewer.Server Namespace