PerpetuumSoft.InstrumentationPDA

Instrumentation Widgets for PDA

PerpetuumSoft.InstrumentationPDA Namespace

Namespace hierarchy

Classes

Class | Description
Bevel | Incapsulates bevel painting.
CircularControl | Provides base behaviour for circular controls.
CircularControlBase | Provides geometry methods for circular controls.
ColorSection | Incapsulates information about scale section color.
Dial | Emulates dial look and feel.
DigitalLED | Emulates appearance of seven-segment digital led indicator.
DigitsDisplay | Helper class for painting digits.
Level | Presents value on the multicolor scale.
LinearControl | Provides base behavior for all linear controls.
Meter | Emulates lok and feel of meter.
Slider | Emulates look and feel of slider.
Switch | Emulates look and feeel of switch.
SwitchBase | Provides base behavior for switches and toggles.
Thermometer | Emulates look and feel of thermometer.
Toggle | Emulates toggle look, feel and behavior.
ValuePresenter | Provides basic logic for all controls that presents decimal value.
Widget | Base class for all visual controls in library.

Enumerations

Enumeration | Description
BevelStyle | Enumerates control Bevel's styles.
FaceStyle | Control face appearance style.
ImagePosition | Position of dial image.
Orientation | Control orientation.
PointerType | Type of a dial pointer.
SliderElementsPosition | Position of linear control elements.

(c) 2006 Perpetuum Software. All rights reserved.


Bevel Class

Incapsulates bevel painting.

For a list of all members of this type, see Bevel Members.

System.Object
PerpetuumSoft.InstrumentationPDA.Bevel

[Visual Basic]
Public Class Bevel
[C#]
public class Bevel

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Bevel Members | PerpetuumSoft.InstrumentationPDA Namespace


Bevel Members

Bevel overview

Public Instance Constructors

Bevel Constructor Public constructor.

Public Instance Properties

InnerBorder | Gets or sets whether the inner border should be drawn.
OutterBorder | Gets or sets whether the outter border should be drawn.
Style | Gets or sets style of control's bevel.

Public Instance Methods

Draw | Paints bevel.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMargin | Returns summary bevel width.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Bevel Class | PerpetuumSoft.InstrumentationPDA Namespace


Bevel Constructor

Public constructor.

[Visual Basic]
Public Sub New( _
ByVal style As BevelStyle, _
ByVal outterBorder As Boolean, _
ByVal innerBorder As Boolean _
)
[C#]
public Bevel(
BevelStyle style,
bool outterBorder,
bool innerBorder
);

See Also

Bevel Class | PerpetuumSoft.InstrumentationPDA Namespace


Bevel Properties

The properties of the Bevel class are listed below. For a complete list of Bevel class members, see the Bevel Members topic.

Public Instance Properties

InnerBorder | Gets or sets whether the inner border should be drawn.
OutterBorder | Gets or sets whether the outter border should be drawn.
Style | Gets or sets style of control's bevel.

See Also

Bevel Class | PerpetuumSoft.InstrumentationPDA Namespace


InnerBorder Property

Instrumentation Widgets for PDA

Bevel.InnerBorder Property

Gets or sets whether the inner border should be drawn.

[Visual Basic]
Public Property InnerBorder As Boolean
[C#]
public bool InnerBorder {get; set;}

See Also

Bevel Class | PerpetuumSoft.InstrumentationPDA Namespace


OutterBorder Property

Instrumentation Widgets for PDA

Bevel.OutterBorder Property

Gets or sets whether the outter border should be drawn.

[Visual Basic]
Public Property OutterBorder As Boolean
[C#]
public bool OutterBorder {get; set;}

See Also

Bevel Class | PerpetuumSoft.InstrumentationPDA Namespace


Style Property

Instrumentation Widgets for PDA

Bevel.Style Property

Gets or sets style of control's bevel.

[Visual Basic]
Public Property Style As BevelStyle
[C#]
public BevelStyle Style {get; set;}

See Also

Bevel Class | PerpetuumSoft.InstrumentationPDA Namespace


Bevel Methods

The methods of the Bevel class are listed below. For a complete list of Bevel class members, see the Bevel Members topic.

Public Instance Methods

Draw | Paints bevel.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMargin | Returns summary bevel width.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Bevel Class | PerpetuumSoft.InstrumentationPDA Namespace


Bevel.Draw Method

Paints bevel.

[Visual Basic]
Public Sub Draw( _
ByVal g As Graphics, _
ByVal r As Rectangle _
)
[C#]
public void Draw(
Graphics g,
Rectangle r
);

Parameters

g
Graphics object to paint on.
r
Bevel rectangle.

See Also

Bevel Class | PerpetuumSoft.InstrumentationPDA Namespace


Bevel.GetMargin Method

Returns summary bevel width.

[Visual Basic]
Public Function GetMargin() As Integer
[C#]
public int GetMargin();

Return Value

Width of bevel for current values of style and borders.

See Also

Bevel Class | PerpetuumSoft.InstrumentationPDA Namespace


BevelStyle Enumeration

Enumerates control Bevel's styles.

[Visual Basic]
Public Enum BevelStyle
[C#]
public enum BevelStyle

Members

Member Name | Description
None | No bevel.
Flat | Flat-style bevel appearance.
Single | Single width black bevel.
Double | Double width black bevel.
Raised | 3D Raised style bevel.
Lowered | 3D Lowered style bevel.
DoubleRaised | 3D Raised style bevel with double width.
DoubleLowered | 3D Lowered style bevel with double width.
FrameRaised | Raised Frame.
FrameLowered | Lowered Frame.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

PerpetuumSoft.InstrumentationPDA Namespace


CircularControl Class

Provides base behaviour for circular controls.

For a list of all members of this type, see CircularControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.ValuePresenter
PerpetuumSoft.InstrumentationPDA.CircularControlBase
PerpetuumSoft.InstrumentationPDA.CircularControl
PerpetuumSoft.InstrumentationPDA.Dial
PerpetuumSoft.InstrumentationPDA.Meter

[Visual Basic]
MustInherit Public Class CircularControl
Inherits CircularControlBase
[C#]
public abstract class CircularControl : CircularControlBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

CircularControl Members | PerpetuumSoft.InstrumentationPDA Namespace


CircularControl Members

CircularControl overview

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Center (inherited from CircularControlBase) | Gets or sets displacement between control center and dial center.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAngle (inherited from CircularControlBase) | Gets or sets current control angle.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EndAngle (inherited from CircularControlBase) | Gets or sets end control angle.
ExternalPointerRadius | Gets or sets external radius of the pointer.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InternalPointerRadius | Gets or sets internal radius of the pointer.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels | Gets or sets scale labels.
LabelsCount |
LabelsRadius | Gets or sets radius for the scale labels.
LabelsVisible | Gets or sets whether scale labels should be displayed.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PointerColor | Gets or sets color of the pointer.
PointerSize | Gets or sets size of the pointer.
PointerType | Gets or sets shape of pointer.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from CircularControlBase) | Gets or sets whether scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SectionsColors | Gets or sets colors of the scale.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StartAngle (inherited from CircularControlBase) | Gets or sets start control angle.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksCount |
TicksLenght | Gets or sets the lenght of the scale ticks.
TicksRadius | Gets or sets scale ticks radius.
TicksSubDivisionsCount |
TicksVisible | Gets or sets whether scale ticks should be displayed.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TotalAngle (inherited from CircularControlBase) | Gets or sets full control angle.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from ValuePresenter) | Occurs when Value of the control changed.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Constructors

CircularControl Constructor Initializes a new instance of the CircularControl class.

Protected Instance Properties

CenterPoint (inherited from CircularControlBase) | Gets dial center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Widget) | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AngleToValue (inherited from CircularControlBase) | Converts angle to value.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawPointer | Paints pointer.
DrawScale | Paints scale.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
GetColor | Returns color of the scale element corresponding to the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToAngle (inherited from CircularControlBase) | Converts percent to angle.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from CircularControlBase) | Overloaded. Overrides inherited ToPoint method.
ToValue (inherited from CircularControlBase) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToAngle (inherited from CircularControlBase) | Converts value to angle.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControl Constructor

Initializes a new instance of the CircularControl class.

[Visual Basic]
Protected Sub New()
[C#]
protected CircularControl();

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControl Properties

The properties of the CircularControl class are listed below. For a complete list of CircularControl class members, see the CircularControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Center (inherited from CircularControlBase) | Gets or sets displacement between control center and dial center.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAngle (inherited from CircularControlBase) | Gets or sets current control angle.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EndAngle (inherited from CircularControlBase) | Gets or sets end control angle.
ExternalPointerRadius | Gets or sets external radius of the pointer.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InternalPointerRadius | Gets or sets internal radius of the pointer.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels | Gets or sets scale labels.
LabelsCount |
LabelsRadius | Gets or sets radius for the scale labels.
LabelsVisible | Gets or sets whether scale labels should be displayed.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PointerColor | Gets or sets color of the pointer.
PointerSize | Gets or sets size of the pointer.
PointerType | Gets or sets shape of pointer.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from CircularControlBase) | Gets or sets whether scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SectionsColors | Gets or sets colors of the scale.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StartAngle (inherited from CircularControlBase) | Gets or sets start control angle.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksCount |
TicksLenght | Gets or sets the lenght of the scale ticks.
TicksRadius | Gets or sets scale ticks radius.
TicksSubDivisionsCount |
TicksVisible | Gets or sets whether scale ticks should be displayed.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TotalAngle (inherited from CircularControlBase) | Gets or sets full control angle.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CenterPoint (inherited from CircularControlBase) | Gets dial center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Widget) | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


ExternalPointerRadius Property

Instrumentation Widgets for PDA

CircularControl.ExternalPointerRadius Property

Gets or sets external radius of the pointer.

[Visual Basic]
Public Property ExternalPointerRadius As Integer
[C#]
public int ExternalPointerRadius {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


InternalPointerRadius Property

Instrumentation Widgets for PDA

CircularControl.InternalPointerRadius Property

Gets or sets internal radius of the pointer.

[Visual Basic]
Public Property InternalPointerRadius As Integer
[C#]
public int InternalPointerRadius {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


Labels Property

Instrumentation Widgets for PDA

CircularControl.Labels Property

Gets or sets scale labels.

[Visual Basic]
Public Property Labels As String()
[C#]
public string[] Labels {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LabelsCount Property

Instrumentation Widgets for PDA

CircularControl.LabelsCount Property

[Visual Basic]
Public Property LabelsCount As Integer
[C#]
public int LabelsCount {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LabelsRadius Property

Instrumentation Widgets for PDA

CircularControl.LabelsRadius Property

Gets or sets radius for the scale labels.

[Visual Basic]
Public Property LabelsRadius As Integer
[C#]
public int LabelsRadius {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LabelsVisible Property

Instrumentation Widgets for PDA

CircularControl.LabelsVisible Property

Gets or sets whether scale labels should be displayed.

[Visual Basic]
Public Property LabelsVisible As Boolean
[C#]
public bool LabelsVisible {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


PointerColor Property

Instrumentation Widgets for PDA

CircularControl.PointerColor Property

Gets or sets color of the pointer.

[Visual Basic]
Public Property PointerColor As Color
[C#]
public System.Drawing.Color PointerColor {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


PointerSize Property

Instrumentation Widgets for PDA

CircularControl.PointerSize Property

Gets or sets size of the pointer.

[Visual Basic]
Public Property PointerSize As Decimal
[C#]
public decimal PointerSize {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


PointerType Property

Instrumentation Widgets for PDA

CircularControl.PointerType Property

Gets or sets shape of pointer.

[Visual Basic]
Public Property PointerType As PointerType
[C#]
public PointerType PointerType {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


SectionsColors Property

Instrumentation Widgets for PDA

CircularControl.SectionsColors Property

Gets or sets colors of the scale.

[Visual Basic]
Public Property SectionsColors As ColorSection()
[C#]
public ColorSection[] SectionsColors {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


TicksCount Property

Instrumentation Widgets for PDA

CircularControl.TicksCount Property

[Visual Basic]
Public Property TicksCount As Integer
[C#]
public int TicksCount {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


TicksLenght Property

Instrumentation Widgets for PDA

CircularControl.TicksLenght Property

Gets or sets the lenght of the scale ticks.

[Visual Basic]
Public Property TicksLenght As Integer
[C#]
public int TicksLenght {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


TicksRadius Property

Instrumentation Widgets for PDA

CircularControl.TicksRadius Property

Gets or sets scale ticks radius.

[Visual Basic]
Public Property TicksRadius As Integer
[C#]
public int TicksRadius {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


TicksSubDivisionsCount Property

Instrumentation Widgets for PDA

CircularControl.TicksSubDivisionsCount Property

[Visual Basic]
Public Property TicksSubDivisionsCount As Integer
[C#]
public int TicksSubDivisionsCount {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


TicksVisible Property

Instrumentation Widgets for PDA

CircularControl.TicksVisible Property

Gets or sets whether scale ticks should be displayed.

[Visual Basic]
Public Property TicksVisible As Boolean
[C#]
public bool TicksVisible {get; set;}

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControl Methods

The methods of the CircularControl class are listed below. For a complete list of CircularControl class members, see the CircularControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AngleToValue (inherited from CircularControlBase) | Converts angle to value.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawPointer | Paints pointer.
DrawScale | Paints scale.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
GetColor | Returns color of the scale element corresponding to the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToAngle (inherited from CircularControlBase) | Converts percent to angle.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from CircularControlBase) | Overloaded. Overrides inherited ToPoint method.
ToValue (inherited from CircularControlBase) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToAngle (inherited from CircularControlBase) | Converts value to angle.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControl.DrawDynamic Method

Overrides inherited DrawDynamic method.

[Visual Basic]
Overrides Protected Sub DrawDynamic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawDynamic(
Graphics g
);

Parameters

g

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControl.DrawPointer Method

Paints pointer.

[Visual Basic]
Protected Sub DrawPointer( _
ByVal g As Graphics _
)
[C#]
protected void DrawPointer(
Graphics g
);

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControl.DrawScale Method

Paints scale.

[Visual Basic]
Protected Sub DrawScale( _
ByVal g As Graphics _
)
[C#]
protected void DrawScale(
Graphics g
);

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControl.DrawStatic Method

Overrides inherited DrawStatic method.

[Visual Basic]
Overrides Protected Sub DrawStatic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawStatic(
Graphics g
);

Parameters

g

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControl.GetColor Method

Returns color of the scale element corresponding to the specified value.

[Visual Basic]
Protected Function GetColor( _
ByVal curentValue As Decimal _
) As Color
[C#]
protected Color GetColor(
decimal curentValue
);

Parameters

curentValue

Return Value

See Also

CircularControl Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControlBase Class

Provides geometry methods for circular controls.

For a list of all members of this type, see CircularControlBase Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.ValuePresenter
PerpetuumSoft.InstrumentationPDA.CircularControlBase
PerpetuumSoft.InstrumentationPDA.CircularControl

[Visual Basic]
MustInherit Public Class CircularControlBase
Inherits ValuePresenter
[C#]
public abstract class CircularControlBase : ValuePresenter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

CircularControlBase Members | PerpetuumSoft.InstrumentationPDA Namespace


CircularControlBase Members

CircularControlBase overview

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Center | Gets or sets displacement between control center and dial center.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAngle | Gets or sets current control angle.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EndAngle | Gets or sets end control angle.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale | Gets or sets whether scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StartAngle | Gets or sets start control angle.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TotalAngle | Gets or sets full control angle.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from ValuePresenter) | Occurs when Value of the control changed.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Constructors

CircularControlBase Constructor Initializes a new instance of the CircularControlBase class.

Protected Instance Properties

CenterPoint | Gets dial center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Widget) | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AngleToValue | Converts angle to value.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic (inherited from Widget) | Virtual method that perform actual drawing of dynamic part of the control.
DrawStatic (inherited from Widget) | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToAngle | Converts percent to angle.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint | Overloaded. Overrides inherited ToPoint method.
ToValue | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToAngle | Converts value to angle.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControlBase Constructor

Initializes a new instance of the CircularControlBase class.

[Visual Basic]
Protected Sub New()
[C#]
protected CircularControlBase();

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControlBase Properties

The properties of the CircularControlBase class are listed below. For a complete list of CircularControlBase class members, see the CircularControlBase Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Center | Gets or sets displacement between control center and dial center.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAngle | Gets or sets current control angle.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EndAngle | Gets or sets end control angle.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale | Gets or sets whether scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StartAngle | Gets or sets start control angle.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TotalAngle | Gets or sets full control angle.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CenterPoint | Gets dial center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Widget) | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


Center Property

Instrumentation Widgets for PDA

CircularControlBase.Center Property

Gets or sets displacement between control center and dial center.

[Visual Basic]
Public Property Center As Size
[C#]
public System.Drawing.Size Center {get; set;}

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


CenterPoint Property

Instrumentation Widgets for PDA

CircularControlBase.CenterPoint Property

Gets dial center.

[Visual Basic]
Protected ReadOnly Property CenterPoint As Vector
[C#]
protected Mathematics.Vector CenterPoint {get;}

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


CurrentAngle Property

Instrumentation Widgets for PDA

CircularControlBase.CurrentAngle Property

Gets or sets current control angle.

[Visual Basic]
Public Property CurrentAngle As Integer
[C#]
public int CurrentAngle {get; set;}

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


EndAngle Property

Instrumentation Widgets for PDA

CircularControlBase.EndAngle Property

Gets or sets end control angle.

[Visual Basic]
Public Property EndAngle As Integer
[C#]
public int EndAngle {get; set;}

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


ReverseScale Property

Instrumentation Widgets for PDA

CircularControlBase.ReverseScale Property

Gets or sets whether scale should be reversed.

[Visual Basic]
Public Property ReverseScale As Boolean
[C#]
public bool ReverseScale {get; set;}

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


StartAngle Property

Instrumentation Widgets for PDA

CircularControlBase.StartAngle Property

Gets or sets start control angle.

[Visual Basic]
Public Property StartAngle As Integer
[C#]
public int StartAngle {get; set;}

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


TotalAngle Property

Instrumentation Widgets for PDA

CircularControlBase.TotalAngle Property

Gets or sets full control angle.

[Visual Basic]
Public Property TotalAngle As Integer
[C#]
public int TotalAngle {get; set;}

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControlBase Methods

The methods of the CircularControlBase class are listed below. For a complete list of CircularControlBase class members, see the CircularControlBase Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AngleToValue | Converts angle to value.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic (inherited from Widget) | Virtual method that perform actual drawing of dynamic part of the control.
DrawStatic (inherited from Widget) | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToAngle | Converts percent to angle.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint | Overloaded. Overrides inherited ToPoint method.
ToValue | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToAngle | Converts value to angle.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControlBase.AngleToValue Method

Converts angle to value.

[Visual Basic]
Protected Function AngleToValue( _
ByVal angle As Decimal _
) As Decimal
[C#]
protected decimal AngleToValue(
decimal angle
);

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControlBase.PercentToAngle Method

Converts percent to angle.

[Visual Basic]
Protected Function PercentToAngle( _
ByVal value As Decimal _
) As Decimal
[C#]
protected decimal PercentToAngle(
decimal value
);

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


ToPoint Method

Instrumentation Widgets for PDA

CircularControlBase.ToPoint Method

Overrides inherited ToPoint method.

Overload List

Overrides inherited ToPoint method.

protected override Vector ToPoint(decimal);

Returns point for the specified value and radius.

protected Vector ToPoint(decimal,decimal);

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControlBase.ToPoint Method (Decimal)

Overrides inherited ToPoint method.

[Visual Basic]
Overrides Overloads Protected Function ToPoint( _
ByVal value As Decimal _
) As Vector
[C#]
protected override Vector ToPoint(
decimal value
);

Parameters

value

Return Value

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace | CircularControlBase.ToPoint Overload List


CircularControlBase.ToPoint Method (Decimal, Decimal)

Returns point for the specified value and radius.

[Visual Basic]
Overloads Protected Function ToPoint( _
ByVal value As Decimal, _
ByVal radius As Decimal _
) As Vector
[C#]
protected Vector ToPoint(
decimal value,
decimal radius
);

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace | CircularControlBase.ToPoint Overload List


CircularControlBase.ToValue Method

Overrides inherited ToValue method.

[Visual Basic]
Overrides Protected Function ToValue( _
ByVal v As Vector _
) As Decimal
[C#]
protected override decimal ToValue(
Vector v
);

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


CircularControlBase.ValueToAngle Method

Converts value to angle.

[Visual Basic]
Protected Function ValueToAngle( _
ByVal value As Decimal _
) As Decimal
[C#]
protected decimal ValueToAngle(
decimal value
);

Parameters

value

Return Value

See Also

CircularControlBase Class | PerpetuumSoft.InstrumentationPDA Namespace


ColorSection Class

Incapsulates information about scale section color.

For a list of all members of this type, see ColorSection Members.

System.Object
PerpetuumSoft.InstrumentationPDA.ColorSection

[Visual Basic]
Public Class ColorSection
[C#]
public class ColorSection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

ColorSection Members | PerpetuumSoft.InstrumentationPDA Namespace


ColorSection Members

ColorSection overview

Public Instance Constructors

ColorSection Overloaded. Initializes a new instance of the ColorSection class.

Public Instance Properties

Color | Gets or sets section color.
MaximumPercent | Gets or sets end of section in percents.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Converts object to its string representation.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColorSection Class | PerpetuumSoft.InstrumentationPDA Namespace


ColorSection Constructor

Creates new instance of the ColorSection class.

Overload List

Creates new instance of the ColorSection class.

public ColorSection();

Creates new instance of the ColorSection class.

public ColorSection(Color,decimal);

See Also

ColorSection Class | PerpetuumSoft.InstrumentationPDA Namespace


ColorSection Constructor ()

Creates new instance of the ColorSection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ColorSection();

See Also

ColorSection Class | PerpetuumSoft.InstrumentationPDA Namespace | ColorSection Constructor Overload List


ColorSection Constructor (Color, Decimal)

Creates new instance of the ColorSection class.

[Visual Basic]
Overloads Public Sub New( _
ByVal color As Color, _
ByVal maximumPercent As Decimal _
)
[C#]
public ColorSection(
Color color,
decimal maximumPercent
);

See Also

ColorSection Class | PerpetuumSoft.InstrumentationPDA Namespace | ColorSection Constructor Overload List


ColorSection Properties

The properties of the ColorSection class are listed below. For a complete list of ColorSection class members, see the ColorSection Members topic.

Public Instance Properties

Color | Gets or sets section color.
MaximumPercent | Gets or sets end of section in percents.

See Also

ColorSection Class | PerpetuumSoft.InstrumentationPDA Namespace


Color Property

Instrumentation Widgets for PDA

ColorSection.Color Property

Gets or sets section color.

[Visual Basic]
Public Property Color As Color
[C#]
public System.Drawing.Color Color {get; set;}

See Also

ColorSection Class | PerpetuumSoft.InstrumentationPDA Namespace


MaximumPercent Property

Instrumentation Widgets for PDA

ColorSection.MaximumPercent Property

Gets or sets end of section in percents.

[Visual Basic]
Public Property MaximumPercent As Decimal
[C#]
public decimal MaximumPercent {get; set;}

See Also

ColorSection Class | PerpetuumSoft.InstrumentationPDA Namespace


ColorSection Methods

The methods of the ColorSection class are listed below. For a complete list of ColorSection class members, see the ColorSection Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Converts object to its string representation.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColorSection Class | PerpetuumSoft.InstrumentationPDA Namespace


ColorSection.ToString Method

Converts object to its string representation.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

See Also

ColorSection Class | PerpetuumSoft.InstrumentationPDA Namespace


Dial Class

Emulates dial look and feel.

For a list of all members of this type, see Dial Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.ValuePresenter
PerpetuumSoft.InstrumentationPDA.CircularControlBase
PerpetuumSoft.InstrumentationPDA.CircularControl
PerpetuumSoft.InstrumentationPDA.Dial

[Visual Basic]
Public Class Dial
Inherits CircularControl
[C#]
public class Dial : CircularControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Dial Members | PerpetuumSoft.InstrumentationPDA Namespace


Dial Members

Dial overview

Public Instance Constructors

Dial Constructor Initializes a new instance of the Dial class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Center (inherited from CircularControlBase) | Gets or sets displacement between control center and dial center.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAngle (inherited from CircularControlBase) | Gets or sets current control angle.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialImage | Gets or sets dial image.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EndAngle (inherited from CircularControlBase) | Gets or sets end control angle.
ExternalCircleBorderColor | Gets or sets color of the external circle border.
ExternalCircleColor | Gets or sets color of the external circle.
ExternalCircleRadius | Gets or sets radius of the external circle.
ExternalPointerRadius (inherited from CircularControl) | Gets or sets external radius of the pointer.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImagePosition | Gets or sets dial image position.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InternalCircleBorderColor | Gets or sets color of the internal circle border.
InternalCircleColor | Gets or sets color of the internal circle.
InternalCircleRadius | Gets or sets radius of the internal circle.
InternalPointerRadius (inherited from CircularControl) | Gets or sets internal radius of the pointer.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels (inherited from CircularControl) | Gets or sets scale labels.
LabelsCount (inherited from CircularControl) |
LabelsRadius (inherited from CircularControl) | Gets or sets radius for the scale labels.
LabelsVisible (inherited from CircularControl) | Gets or sets whether scale labels should be displayed.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LightCircleColor | Gets or sets ligthen area color.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
NotchesColor | Gets or sets color of the notches.
NotchesCount | Gets or sets count of deal notches.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PointerColor (inherited from CircularControl) | Gets or sets color of the pointer.
PointerSize (inherited from CircularControl) | Gets or sets size of the pointer.
PointerType (inherited from CircularControl) | Gets or sets shape of pointer.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from CircularControlBase) | Gets or sets whether scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SectionsColors (inherited from CircularControl) | Gets or sets colors of the scale.
ShowNotches | Gets or sets whether dial notches should be displayed.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StartAngle (inherited from CircularControlBase) | Gets or sets start control angle.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksCount (inherited from CircularControl) |
TicksLenght (inherited from CircularControl) | Gets or sets the lenght of the scale ticks.
TicksRadius (inherited from CircularControl) | Gets or sets scale ticks radius.
TicksSubDivisionsCount (inherited from CircularControl) |
TicksVisible (inherited from CircularControl) | Gets or sets whether scale ticks should be displayed.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TotalAngle (inherited from CircularControlBase) | Gets or sets full control angle.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from ValuePresenter) | Occurs when Value of the control changed.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CenterPoint (inherited from CircularControlBase) | Gets dial center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AngleToValue (inherited from CircularControlBase) | Converts angle to value.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic | Overrides inherited draw dynamic method.
DrawPointer (inherited from CircularControl) | Paints pointer.
DrawScale (inherited from CircularControl) | Paints scale.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
GetColor (inherited from CircularControl) | Returns color of the scale element corresponding to the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToAngle (inherited from CircularControlBase) | Converts percent to angle.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from CircularControlBase) | Overloaded. Overrides inherited ToPoint method.
ToValue (inherited from CircularControlBase) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToAngle (inherited from CircularControlBase) | Converts value to angle.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


Dial Constructor

Initializes a new instance of the Dial class.

[Visual Basic]
Public Sub New()
[C#]
public Dial();

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


Dial Properties

The properties of the Dial class are listed below. For a complete list of Dial class members, see the Dial Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Center (inherited from CircularControlBase) | Gets or sets displacement between control center and dial center.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAngle (inherited from CircularControlBase) | Gets or sets current control angle.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DialImage | Gets or sets dial image.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EndAngle (inherited from CircularControlBase) | Gets or sets end control angle.
ExternalCircleBorderColor | Gets or sets color of the external circle border.
ExternalCircleColor | Gets or sets color of the external circle.
ExternalCircleRadius | Gets or sets radius of the external circle.
ExternalPointerRadius (inherited from CircularControl) | Gets or sets external radius of the pointer.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImagePosition | Gets or sets dial image position.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InternalCircleBorderColor | Gets or sets color of the internal circle border.
InternalCircleColor | Gets or sets color of the internal circle.
InternalCircleRadius | Gets or sets radius of the internal circle.
InternalPointerRadius (inherited from CircularControl) | Gets or sets internal radius of the pointer.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels (inherited from CircularControl) | Gets or sets scale labels.
LabelsCount (inherited from CircularControl) |
LabelsRadius (inherited from CircularControl) | Gets or sets radius for the scale labels.
LabelsVisible (inherited from CircularControl) | Gets or sets whether scale labels should be displayed.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LightCircleColor | Gets or sets ligthen area color.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
NotchesColor | Gets or sets color of the notches.
NotchesCount | Gets or sets count of deal notches.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PointerColor (inherited from CircularControl) | Gets or sets color of the pointer.
PointerSize (inherited from CircularControl) | Gets or sets size of the pointer.
PointerType (inherited from CircularControl) | Gets or sets shape of pointer.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from CircularControlBase) | Gets or sets whether scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SectionsColors (inherited from CircularControl) | Gets or sets colors of the scale.
ShowNotches | Gets or sets whether dial notches should be displayed.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StartAngle (inherited from CircularControlBase) | Gets or sets start control angle.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksCount (inherited from CircularControl) |
TicksLenght (inherited from CircularControl) | Gets or sets the lenght of the scale ticks.
TicksRadius (inherited from CircularControl) | Gets or sets scale ticks radius.
TicksSubDivisionsCount (inherited from CircularControl) |
TicksVisible (inherited from CircularControl) | Gets or sets whether scale ticks should be displayed.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TotalAngle (inherited from CircularControlBase) | Gets or sets full control angle.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CenterPoint (inherited from CircularControlBase) | Gets dial center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


DefaultSize Property

Instrumentation Widgets for PDA

Dial.DefaultSize Property

Gets default control size.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override System.Drawing.Size DefaultSize {get;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


DialImage Property

Instrumentation Widgets for PDA

Dial.DialImage Property

Gets or sets dial image.

[Visual Basic]
Public Property DialImage As Image
[C#]
public System.Drawing.Image DialImage {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


ExternalCircleBorderColor Property

Instrumentation Widgets for PDA

Dial.ExternalCircleBorderColor Property

Gets or sets color of the external circle border.

[Visual Basic]
Public Property ExternalCircleBorderColor As Color
[C#]
public System.Drawing.Color ExternalCircleBorderColor {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


ExternalCircleColor Property

Instrumentation Widgets for PDA

Dial.ExternalCircleColor Property

Gets or sets color of the external circle.

[Visual Basic]
Public Property ExternalCircleColor As Color
[C#]
public System.Drawing.Color ExternalCircleColor {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


ExternalCircleRadius Property

Instrumentation Widgets for PDA

Dial.ExternalCircleRadius Property

Gets or sets radius of the external circle.

[Visual Basic]
Public Property ExternalCircleRadius As Integer
[C#]
public int ExternalCircleRadius {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


ImagePosition Property

Instrumentation Widgets for PDA

Dial.ImagePosition Property

Gets or sets dial image position.

[Visual Basic]
Public Property ImagePosition As ImagePosition
[C#]
public ImagePosition ImagePosition {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


InternalCircleBorderColor Property

Instrumentation Widgets for PDA

Dial.InternalCircleBorderColor Property

Gets or sets color of the internal circle border.

[Visual Basic]
Public Property InternalCircleBorderColor As Color
[C#]
public System.Drawing.Color InternalCircleBorderColor {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


InternalCircleColor Property

Instrumentation Widgets for PDA

Dial.InternalCircleColor Property

Gets or sets color of the internal circle.

[Visual Basic]
Public Property InternalCircleColor As Color
[C#]
public System.Drawing.Color InternalCircleColor {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


InternalCircleRadius Property

Instrumentation Widgets for PDA

Dial.InternalCircleRadius Property

Gets or sets radius of the internal circle.

[Visual Basic]
Public Property InternalCircleRadius As Integer
[C#]
public int InternalCircleRadius {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


LightCircleColor Property

Instrumentation Widgets for PDA

Dial.LightCircleColor Property

Gets or sets ligthen area color.

[Visual Basic]
Public Property LightCircleColor As Color
[C#]
public System.Drawing.Color LightCircleColor {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


NotchesColor Property

Instrumentation Widgets for PDA

Dial.NotchesColor Property

Gets or sets color of the notches.

[Visual Basic]
Public Property NotchesColor As Color
[C#]
public System.Drawing.Color NotchesColor {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


NotchesCount Property

Instrumentation Widgets for PDA

Dial.NotchesCount Property

Gets or sets count of deal notches.

[Visual Basic]
Public Property NotchesCount As Integer
[C#]
public int NotchesCount {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


ShowNotches Property

Instrumentation Widgets for PDA

Dial.ShowNotches Property

Gets or sets whether dial notches should be displayed.

[Visual Basic]
Public Property ShowNotches As Boolean
[C#]
public bool ShowNotches {get; set;}

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


Dial Methods

The methods of the Dial class are listed below. For a complete list of Dial class members, see the Dial Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AngleToValue (inherited from CircularControlBase) | Converts angle to value.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic | Overrides inherited draw dynamic method.
DrawPointer (inherited from CircularControl) | Paints pointer.
DrawScale (inherited from CircularControl) | Paints scale.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
GetColor (inherited from CircularControl) | Returns color of the scale element corresponding to the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToAngle (inherited from CircularControlBase) | Converts percent to angle.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from CircularControlBase) | Overloaded. Overrides inherited ToPoint method.
ToValue (inherited from CircularControlBase) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToAngle (inherited from CircularControlBase) | Converts value to angle.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


Dial.DrawDynamic Method

Overrides inherited draw dynamic method.

[Visual Basic]
Overrides Protected Sub DrawDynamic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawDynamic(
Graphics g
);

Parameters

g

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


Dial.DrawStatic Method

Overrides inherited DrawStatic method.

[Visual Basic]
Overrides Protected Sub DrawStatic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawStatic(
Graphics g
);

Parameters

g

See Also

Dial Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitalLED Class

Emulates appearance of seven-segment digital led indicator.

For a list of all members of this type, see DigitalLED Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.DigitalLED

[Visual Basic]
Public Class DigitalLED
Inherits Widget
[C#]
public class DigitalLED : Widget

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

DigitalLED Members | PerpetuumSoft.InstrumentationPDA Namespace


DigitalLED Members

DigitalLED overview

Public Instance Constructors

DigitalLED Constructor Public constructor for DigitalLED

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Digits | Gets or sets underlying DigitsDisplay object.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic | Paints control.
DrawStatic (inherited from Widget) | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged | Raises TextChanged event and performs invalidation logic.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

DigitalLED Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitalLED Constructor

Public constructor for DigitalLED

[Visual Basic]
Public Sub New()
[C#]
public DigitalLED();

See Also

DigitalLED Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitalLED Properties

The properties of the DigitalLED class are listed below. For a complete list of DigitalLED class members, see the DigitalLED Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Digits | Gets or sets underlying DigitsDisplay object.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

DigitalLED Class | PerpetuumSoft.InstrumentationPDA Namespace


DefaultSize Property

Instrumentation Widgets for PDA

DigitalLED.DefaultSize Property

Gets default control size.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override System.Drawing.Size DefaultSize {get;}

See Also

DigitalLED Class | PerpetuumSoft.InstrumentationPDA Namespace


Digits Property

Instrumentation Widgets for PDA

DigitalLED.Digits Property

Gets or sets underlying DigitsDisplay object.

[Visual Basic]
Public Property Digits As DigitsDisplay
[C#]
public DigitsDisplay Digits {get; set;}

See Also

DigitalLED Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitalLED Methods

The methods of the DigitalLED class are listed below. For a complete list of DigitalLED class members, see the DigitalLED Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic | Paints control.
DrawStatic (inherited from Widget) | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged | Raises TextChanged event and performs invalidation logic.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

DigitalLED Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitalLED.DrawDynamic Method

Paints control.

[Visual Basic]
Overrides Protected Sub DrawDynamic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawDynamic(
Graphics g
);

See Also

DigitalLED Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitalLED.OnTextChanged Method

Raises TextChanged event and performs invalidation logic.

[Visual Basic]
Overrides Protected Sub OnTextChanged( _
ByVal e As EventArgs _
)
[C#]
protected override void OnTextChanged(
EventArgs e
);

Parameters

e

See Also

DigitalLED Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitsDisplay Class

Helper class for painting digits.

For a list of all members of this type, see DigitsDisplay Members.

System.Object
PerpetuumSoft.InstrumentationPDA.DigitsDisplay

[Visual Basic]
Public Class DigitsDisplay
[C#]
public class DigitsDisplay

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

DigitsDisplay Members | PerpetuumSoft.InstrumentationPDA Namespace


DigitsDisplay Members

DigitsDisplay overview

Public Instance Constructors

DigitsDisplay Overloaded. Initializes a new instance of the DigitsDisplay class.

Public Instance Properties

ActiveColor | Gets or sets active led color
DigitHeight | Gets or sets height of partial digit.
DigitSpace | Gets or sets space between neightbours digits.
DigitWidth | Gets or sets width of partial digit.
InactiveColor | Gets or sets inactive led color.
SegmentSpace | Gets or sets space between led segments.
SegmentThickness | Gets or sets led segment thickness.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintString | Paints string of Digits at specified location.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitsDisplay Constructor

Creates new instance of the DigitsDisplay class.

Overload List

Creates new instance of the DigitsDisplay class.

public DigitsDisplay();

Creates new instance of the DigitsDisplay class with specified settings.

public DigitsDisplay(Color,int,int,int,Color,int,int);

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitsDisplay Constructor ()

Creates new instance of the DigitsDisplay class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DigitsDisplay();

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace | DigitsDisplay Constructor Overload List


DigitsDisplay Constructor (Color, Int32, Int32, Int32, Color, Int32, Int32)

Creates new instance of the DigitsDisplay class with specified settings.

[Visual Basic]
Overloads Public Sub New( _
ByVal activeColor As Color, _
ByVal digitHeight As Integer, _
ByVal digitSpace As Integer, _
ByVal digitWidth As Integer, _
ByVal inactiveColor As Color, _
ByVal segmentSpace As Integer, _
ByVal segmentThickness As Integer _
)
[C#]
public DigitsDisplay(
Color activeColor,
int digitHeight,
int digitSpace,
int digitWidth,
Color inactiveColor,
int segmentSpace,
int segmentThickness
);

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace | DigitsDisplay Constructor Overload List


DigitsDisplay Properties

The properties of the DigitsDisplay class are listed below. For a complete list of DigitsDisplay class members, see the DigitsDisplay Members topic.

Public Instance Properties

ActiveColor | Gets or sets active led color
DigitHeight | Gets or sets height of partial digit.
DigitSpace | Gets or sets space between neightbours digits.
DigitWidth | Gets or sets width of partial digit.
InactiveColor | Gets or sets inactive led color.
SegmentSpace | Gets or sets space between led segments.
SegmentThickness | Gets or sets led segment thickness.

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


ActiveColor Property

Instrumentation Widgets for PDA

DigitsDisplay.ActiveColor Property

Gets or sets active led color

[Visual Basic]
Public Property ActiveColor As Color
[C#]
public System.Drawing.Color ActiveColor {get; set;}

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitHeight Property

Instrumentation Widgets for PDA

DigitsDisplay.DigitHeight Property

Gets or sets height of partial digit.

[Visual Basic]
Public Property DigitHeight As Integer
[C#]
public int DigitHeight {get; set;}

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitSpace Property

Instrumentation Widgets for PDA

DigitsDisplay.DigitSpace Property

Gets or sets space between neightbours digits.

[Visual Basic]
Public Property DigitSpace As Integer
[C#]
public int DigitSpace {get; set;}

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitWidth Property

Instrumentation Widgets for PDA

DigitsDisplay.DigitWidth Property

Gets or sets width of partial digit.

[Visual Basic]
Public Property DigitWidth As Integer
[C#]
public int DigitWidth {get; set;}

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


InactiveColor Property

Instrumentation Widgets for PDA

DigitsDisplay.InactiveColor Property

Gets or sets inactive led color.

[Visual Basic]
Public Property InactiveColor As Color
[C#]
public System.Drawing.Color InactiveColor {get; set;}

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


SegmentSpace Property

Instrumentation Widgets for PDA

DigitsDisplay.SegmentSpace Property

Gets or sets space between led segments.

[Visual Basic]
Public Property SegmentSpace As Integer
[C#]
public int SegmentSpace {get; set;}

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


SegmentThickness Property

Instrumentation Widgets for PDA

DigitsDisplay.SegmentThickness Property

Gets or sets led segment thickness.

[Visual Basic]
Public Property SegmentThickness As Integer
[C#]
public int SegmentThickness {get; set;}

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitsDisplay Methods

The methods of the DigitsDisplay class are listed below. For a complete list of DigitsDisplay class members, see the DigitsDisplay Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PaintString | Paints string of Digits at specified location.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


DigitsDisplay.PaintString Method

Paints string of Digits at specified location.

[Visual Basic]
Public Sub PaintString( _
ByVal g As Graphics, _
ByVal pos As Vector, _
ByVal text As String _
)
[C#]
public void PaintString(
Graphics g,
Vector pos,
string text
);

Parameters

g
Graphics object to paint on.
pos
Top-Left corner of digits sting.
text
String of digits.

Remarks

  • Decimal numeric symbols - ("0"-"9")
  • Minus sign - "-"
  • Space - " "
  • Semicolon - ":"
  • Digital point - "." or ","
All symbols except mentioned above are ignored

See Also

DigitsDisplay Class | PerpetuumSoft.InstrumentationPDA Namespace


FaceStyle Enumeration

Control face appearance style.

[Visual Basic]
Public Enum FaceStyle
[C#]
public enum FaceStyle

Members

Member Name | Description
Smooth | Smooth face.
RaisedNotch | Face with raised notch.
LoweredNotch | Face with lowered notch.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

PerpetuumSoft.InstrumentationPDA Namespace


ImagePosition Enumeration

Position of dial image.

[Visual Basic]
Public Enum ImagePosition
[C#]
public enum ImagePosition

Members

Member Name | Description
Stretch | Stretch to control content.
Normal | Original size and position at left-top corner.
ControlCenter | Original size and position at the center of control.
DialCenter | Original size and position at the center of dial.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

PerpetuumSoft.InstrumentationPDA Namespace


Level Class

Presents value on the multicolor scale.

For a list of all members of this type, see Level Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.ValuePresenter
PerpetuumSoft.InstrumentationPDA.LinearControl
PerpetuumSoft.InstrumentationPDA.Level

[Visual Basic]
Public Class Level
Inherits LinearControl
[C#]
public class Level : LinearControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Level Members | PerpetuumSoft.InstrumentationPDA Namespace


Level Members

Level overview

Public Instance Constructors

Level Constructor Initializes a new instance of the Level class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveColorSection | Gets or sets colors of the bar in active state.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BarWidth (inherited from LinearControl) | Gets or sets width of the bar.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Divisions | Gets or sets number of divisions of the bar.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InactiveColorSection | Gets or sets colors of the bar in inactive state.
Indent (inherited from LinearControl) | Gets or sets control indents.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels (inherited from LinearControl) | Gets or sets labels texts.
LabelsPosition (inherited from LinearControl) | Gets and sets position of the labels on the scale.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation (inherited from LinearControl) | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from LinearControl) | Gets or sets if the scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScaleDivisions (inherited from LinearControl) | Gets and sets number of divisions on the scale.
ScaleLabelDivisions (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
ScaleSubDivisions (inherited from LinearControl) | Gets and sets number of subdivisions in each division on the scale.
ScaleWidth (inherited from LinearControl) | Gets or sets width of scale.
SectionsColors (inherited from LinearControl) | Gets or sets scale colors.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Space | Gets or sets space between divisions.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksLenght (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
TicksPosition (inherited from LinearControl) | Gets or sets position of the ticks on the scale.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
ValueBackgroundColor (inherited from LinearControl) | Gets or sets background for the current value label.
ValuePosition (inherited from LinearControl) | Gets or sets position of the current value label.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from ValuePresenter) | Occurs when Value of the control changed.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CenterLine (inherited from LinearControl) | Returns coord of the bar center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction (inherited from LinearControl) | Gets control direction.
EndPoint (inherited from LinearControl) | Returns end bar point.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
StartPoint (inherited from LinearControl) | Returns start bar point.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawCurrentValue (inherited from LinearControl) | Paints current value.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawScale (inherited from LinearControl) | Paints scale.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
FromPoint (inherited from LinearControl) | Overrides inherited FromPoint method.
GetColor (inherited from LinearControl) | Returns color for the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from LinearControl) | Overrides inherited ToPoint method.
ToValue (inherited from LinearControl) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


Level Constructor

Initializes a new instance of the Level class.

[Visual Basic]
Public Sub New()
[C#]
public Level();

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


Level Properties

The properties of the Level class are listed below. For a complete list of Level class members, see the Level Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveColorSection | Gets or sets colors of the bar in active state.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BarWidth (inherited from LinearControl) | Gets or sets width of the bar.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Divisions | Gets or sets number of divisions of the bar.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InactiveColorSection | Gets or sets colors of the bar in inactive state.
Indent (inherited from LinearControl) | Gets or sets control indents.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels (inherited from LinearControl) | Gets or sets labels texts.
LabelsPosition (inherited from LinearControl) | Gets and sets position of the labels on the scale.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation (inherited from LinearControl) | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from LinearControl) | Gets or sets if the scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScaleDivisions (inherited from LinearControl) | Gets and sets number of divisions on the scale.
ScaleLabelDivisions (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
ScaleSubDivisions (inherited from LinearControl) | Gets and sets number of subdivisions in each division on the scale.
ScaleWidth (inherited from LinearControl) | Gets or sets width of scale.
SectionsColors (inherited from LinearControl) | Gets or sets scale colors.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Space | Gets or sets space between divisions.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksLenght (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
TicksPosition (inherited from LinearControl) | Gets or sets position of the ticks on the scale.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
ValueBackgroundColor (inherited from LinearControl) | Gets or sets background for the current value label.
ValuePosition (inherited from LinearControl) | Gets or sets position of the current value label.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CenterLine (inherited from LinearControl) | Returns coord of the bar center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction (inherited from LinearControl) | Gets control direction.
EndPoint (inherited from LinearControl) | Returns end bar point.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
StartPoint (inherited from LinearControl) | Returns start bar point.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


ActiveColorSection Property

Instrumentation Widgets for PDA

Level.ActiveColorSection Property

Gets or sets colors of the bar in active state.

[Visual Basic]
Public Property ActiveColorSection As ColorSection()
[C#]
public ColorSection[] ActiveColorSection {get; set;}

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


DefaultSize Property

Instrumentation Widgets for PDA

Level.DefaultSize Property

Gets default control size.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override System.Drawing.Size DefaultSize {get;}

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


Divisions Property

Instrumentation Widgets for PDA

Level.Divisions Property

Gets or sets number of divisions of the bar.

[Visual Basic]
Public Property Divisions As Integer
[C#]
public int Divisions {get; set;}

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


InactiveColorSection Property

Instrumentation Widgets for PDA

Level.InactiveColorSection Property

Gets or sets colors of the bar in inactive state.

[Visual Basic]
Public Property InactiveColorSection As ColorSection()
[C#]
public ColorSection[] InactiveColorSection {get; set;}

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


Space Property

Instrumentation Widgets for PDA

Level.Space Property

Gets or sets space between divisions.

[Visual Basic]
Public Property Space As Integer
[C#]
public int Space {get; set;}

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


Level Methods

The methods of the Level class are listed below. For a complete list of Level class members, see the Level Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawCurrentValue (inherited from LinearControl) | Paints current value.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawScale (inherited from LinearControl) | Paints scale.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
FromPoint (inherited from LinearControl) | Overrides inherited FromPoint method.
GetColor (inherited from LinearControl) | Returns color for the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from LinearControl) | Overrides inherited ToPoint method.
ToValue (inherited from LinearControl) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


Level.DrawDynamic Method

Overrides inherited DrawDynamic method.

[Visual Basic]
Overrides Protected Sub DrawDynamic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawDynamic(
Graphics g
);

Parameters

g

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


Level.DrawStatic Method

Overrides inherited DrawStatic method.

[Visual Basic]
Overrides Protected Sub DrawStatic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawStatic(
Graphics g
);

Parameters

g

See Also

Level Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl Class

Provides base behavior for all linear controls.

For a list of all members of this type, see LinearControl Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.ValuePresenter
PerpetuumSoft.InstrumentationPDA.LinearControl
PerpetuumSoft.InstrumentationPDA.Level
PerpetuumSoft.InstrumentationPDA.Slider
PerpetuumSoft.InstrumentationPDA.Thermometer

[Visual Basic]
MustInherit Public Class LinearControl
Inherits ValuePresenter
[C#]
public abstract class LinearControl : ValuePresenter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

LinearControl Members | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl Members

LinearControl overview

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BarWidth | Gets or sets width of the bar.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Indent | Gets or sets control indents.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels | Gets or sets labels texts.
LabelsPosition | Gets and sets position of the labels on the scale.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale | Gets or sets if the scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScaleDivisions | Gets and sets number of divisions on the scale.
ScaleLabelDivisions | Gets and sets lenght of the scale ticks.
ScaleSubDivisions | Gets and sets number of subdivisions in each division on the scale.
ScaleWidth | Gets or sets width of scale.
SectionsColors | Gets or sets scale colors.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksLenght | Gets and sets lenght of the scale ticks.
TicksPosition | Gets or sets position of the ticks on the scale.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
ValueBackgroundColor | Gets or sets background for the current value label.
ValuePosition | Gets or sets position of the current value label.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from ValuePresenter) | Occurs when Value of the control changed.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Constructors

LinearControl Constructor Initializes a new instance of the LinearControl class.

Protected Instance Properties

CenterLine | Returns coord of the bar center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Widget) | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction | Gets control direction.
EndPoint | Returns end bar point.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
StartPoint | Returns start bar point.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawCurrentValue | Paints current value.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawScale | Paints scale.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
FromPoint | Overrides inherited FromPoint method.
GetColor | Returns color for the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint | Overrides inherited ToPoint method.
ToValue | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl Constructor

Initializes a new instance of the LinearControl class.

[Visual Basic]
Protected Sub New()
[C#]
protected LinearControl();

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl Properties

The properties of the LinearControl class are listed below. For a complete list of LinearControl class members, see the LinearControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BarWidth | Gets or sets width of the bar.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Indent | Gets or sets control indents.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels | Gets or sets labels texts.
LabelsPosition | Gets and sets position of the labels on the scale.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale | Gets or sets if the scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScaleDivisions | Gets and sets number of divisions on the scale.
ScaleLabelDivisions | Gets and sets lenght of the scale ticks.
ScaleSubDivisions | Gets and sets number of subdivisions in each division on the scale.
ScaleWidth | Gets or sets width of scale.
SectionsColors | Gets or sets scale colors.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksLenght | Gets and sets lenght of the scale ticks.
TicksPosition | Gets or sets position of the ticks on the scale.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
ValueBackgroundColor | Gets or sets background for the current value label.
ValuePosition | Gets or sets position of the current value label.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CenterLine | Returns coord of the bar center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Widget) | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction | Gets control direction.
EndPoint | Returns end bar point.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
StartPoint | Returns start bar point.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


BarWidth Property

Instrumentation Widgets for PDA

LinearControl.BarWidth Property

Gets or sets width of the bar.

[Visual Basic]
Public Property BarWidth As Integer
[C#]
public int BarWidth {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


CenterLine Property

Instrumentation Widgets for PDA

LinearControl.CenterLine Property

Returns coord of the bar center.

[Visual Basic]
Protected ReadOnly Property CenterLine As Integer
[C#]
protected int CenterLine {get;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


Direction Property

Instrumentation Widgets for PDA

LinearControl.Direction Property

Gets control direction.

[Visual Basic]
Protected ReadOnly Property Direction As Direction
[C#]
protected Mathematics.Direction Direction {get;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


EndPoint Property

Instrumentation Widgets for PDA

LinearControl.EndPoint Property

Returns end bar point.

[Visual Basic]
Protected ReadOnly Property EndPoint As Vector
[C#]
protected Mathematics.Vector EndPoint {get;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


Indent Property

Instrumentation Widgets for PDA

LinearControl.Indent Property

Gets or sets control indents.

[Visual Basic]
Public Property Indent As Integer
[C#]
public int Indent {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


Labels Property

Instrumentation Widgets for PDA

LinearControl.Labels Property

Gets or sets labels texts.

[Visual Basic]
Public Property Labels As String()
[C#]
public string[] Labels {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LabelsPosition Property

Instrumentation Widgets for PDA

LinearControl.LabelsPosition Property

Gets and sets position of the labels on the scale.

[Visual Basic]
Public Property LabelsPosition As SliderElementsPosition
[C#]
public SliderElementsPosition LabelsPosition {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


Orientation Property

Instrumentation Widgets for PDA

LinearControl.Orientation Property

Gets or sets control orientation.

[Visual Basic]
Public Property Orientation As Orientation
[C#]
public Orientation Orientation {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


ReverseScale Property

Instrumentation Widgets for PDA

LinearControl.ReverseScale Property

Gets or sets if the scale should be reversed.

[Visual Basic]
Public Property ReverseScale As Boolean
[C#]
public bool ReverseScale {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


ScaleDivisions Property

Instrumentation Widgets for PDA

LinearControl.ScaleDivisions Property

Gets and sets number of divisions on the scale.

[Visual Basic]
Public Property ScaleDivisions As Integer
[C#]
public int ScaleDivisions {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


ScaleLabelDivisions Property

Instrumentation Widgets for PDA

LinearControl.ScaleLabelDivisions Property

Gets and sets lenght of the scale ticks.

[Visual Basic]
Public Property ScaleLabelDivisions As Integer
[C#]
public int ScaleLabelDivisions {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


ScaleSubDivisions Property

Instrumentation Widgets for PDA

LinearControl.ScaleSubDivisions Property

Gets and sets number of subdivisions in each division on the scale.

[Visual Basic]
Public Property ScaleSubDivisions As Integer
[C#]
public int ScaleSubDivisions {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


ScaleWidth Property

Instrumentation Widgets for PDA

LinearControl.ScaleWidth Property

Gets or sets width of scale.

[Visual Basic]
Public Property ScaleWidth As Integer
[C#]
public int ScaleWidth {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


SectionsColors Property

Instrumentation Widgets for PDA

LinearControl.SectionsColors Property

Gets or sets scale colors.

[Visual Basic]
Public Property SectionsColors As ColorSection()
[C#]
public ColorSection[] SectionsColors {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


StartPoint Property

Instrumentation Widgets for PDA

LinearControl.StartPoint Property

Returns start bar point.

[Visual Basic]
Protected ReadOnly Property StartPoint As Vector
[C#]
protected Mathematics.Vector StartPoint {get;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


TicksLenght Property

Instrumentation Widgets for PDA

LinearControl.TicksLenght Property

Gets and sets lenght of the scale ticks.

[Visual Basic]
Public Property TicksLenght As Integer
[C#]
public int TicksLenght {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


TicksPosition Property

Instrumentation Widgets for PDA

LinearControl.TicksPosition Property

Gets or sets position of the ticks on the scale.

[Visual Basic]
Public Property TicksPosition As SliderElementsPosition
[C#]
public SliderElementsPosition TicksPosition {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


ValueBackgroundColor Property

Instrumentation Widgets for PDA

LinearControl.ValueBackgroundColor Property

Gets or sets background for the current value label.

[Visual Basic]
Public Property ValueBackgroundColor As Color
[C#]
public System.Drawing.Color ValueBackgroundColor {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePosition Property

Instrumentation Widgets for PDA

LinearControl.ValuePosition Property

Gets or sets position of the current value label.

[Visual Basic]
Public Property ValuePosition As SliderElementsPosition
[C#]
public SliderElementsPosition ValuePosition {get; set;}

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl Methods

The methods of the LinearControl class are listed below. For a complete list of LinearControl class members, see the LinearControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawCurrentValue | Paints current value.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawScale | Paints scale.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
FromPoint | Overrides inherited FromPoint method.
GetColor | Returns color for the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint | Overrides inherited ToPoint method.
ToValue | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl.DrawCurrentValue Method

Paints current value.

[Visual Basic]
Overridable Protected Sub DrawCurrentValue( _
ByVal g As Graphics _
)
[C#]
protected virtual void DrawCurrentValue(
Graphics g
);

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl.DrawDynamic Method

Overrides inherited DrawDynamic method.

[Visual Basic]
Overrides Protected Sub DrawDynamic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawDynamic(
Graphics g
);

Parameters

g

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl.DrawScale Method

Paints scale.

[Visual Basic]
Overridable Protected Sub DrawScale( _
ByVal g As Graphics _
)
[C#]
protected virtual void DrawScale(
Graphics g
);

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl.DrawStatic Method

Overrides inherited DrawStatic method.

[Visual Basic]
Overrides Protected Sub DrawStatic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawStatic(
Graphics g
);

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl.FromPoint Method

Overrides inherited FromPoint method.

[Visual Basic]
Protected Function FromPoint( _
ByVal value As Decimal _
) As Vector
[C#]
protected Vector FromPoint(
decimal value
);

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl.GetColor Method

Returns color for the specified value.

[Visual Basic]
Overridable Protected Function GetColor( _
ByVal curentValue As Decimal _
) As Color
[C#]
protected virtual Color GetColor(
decimal curentValue
);

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl.ToPoint Method

Overrides inherited ToPoint method.

[Visual Basic]
Overrides Protected Function ToPoint( _
ByVal value As Decimal _
) As Vector
[C#]
protected override Vector ToPoint(
decimal value
);

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


LinearControl.ToValue Method

Overrides inherited ToValue method.

[Visual Basic]
Overrides Protected Function ToValue( _
ByVal v As Vector _
) As Decimal
[C#]
protected override decimal ToValue(
Vector v
);

See Also

LinearControl Class | PerpetuumSoft.InstrumentationPDA Namespace


Meter Class

Emulates lok and feel of meter.

For a list of all members of this type, see Meter Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.ValuePresenter
PerpetuumSoft.InstrumentationPDA.CircularControlBase
PerpetuumSoft.InstrumentationPDA.CircularControl
PerpetuumSoft.InstrumentationPDA.Meter

[Visual Basic]
Public Class Meter
Inherits CircularControl
[C#]
public class Meter : CircularControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Meter Members | PerpetuumSoft.InstrumentationPDA Namespace


Meter Members

Meter overview

Public Instance Constructors

Meter Constructor Initializes a new instance of the Meter class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderCircleColor | Gets or sets border color.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Center (inherited from CircularControlBase) | Gets or sets displacement between control center and dial center.
CircleColor | Gets or sets circle color.
CircleRadius | Gets or sets circle radius.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAngle (inherited from CircularControlBase) | Gets or sets current control angle.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EndAngle (inherited from CircularControlBase) | Gets or sets end control angle.
ExternalPointerRadius (inherited from CircularControl) | Gets or sets external radius of the pointer.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InternalPointerRadius (inherited from CircularControl) | Gets or sets internal radius of the pointer.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels (inherited from CircularControl) | Gets or sets scale labels.
LabelsCount (inherited from CircularControl) |
LabelsRadius (inherited from CircularControl) | Gets or sets radius for the scale labels.
LabelsVisible (inherited from CircularControl) | Gets or sets whether scale labels should be displayed.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PointerColor (inherited from CircularControl) | Gets or sets color of the pointer.
PointerSize (inherited from CircularControl) | Gets or sets size of the pointer.
PointerType (inherited from CircularControl) | Gets or sets shape of pointer.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from CircularControlBase) | Gets or sets whether scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SectionsColors (inherited from CircularControl) | Gets or sets colors of the scale.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StartAngle (inherited from CircularControlBase) | Gets or sets start control angle.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksCount (inherited from CircularControl) |
TicksLenght (inherited from CircularControl) | Gets or sets the lenght of the scale ticks.
TicksRadius (inherited from CircularControl) | Gets or sets scale ticks radius.
TicksSubDivisionsCount (inherited from CircularControl) |
TicksVisible (inherited from CircularControl) | Gets or sets whether scale ticks should be displayed.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TotalAngle (inherited from CircularControlBase) | Gets or sets full control angle.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from ValuePresenter) | Occurs when Value of the control changed.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CenterPoint (inherited from CircularControlBase) | Gets dial center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AngleToValue (inherited from CircularControlBase) | Converts angle to value.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic (inherited from CircularControl) | Overrides inherited DrawDynamic method.
DrawPointer (inherited from CircularControl) | Paints pointer.
DrawScale (inherited from CircularControl) | Paints scale.
DrawStatic | Overrides inherited DtrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
GetColor (inherited from CircularControl) | Returns color of the scale element corresponding to the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToAngle (inherited from CircularControlBase) | Converts percent to angle.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from CircularControlBase) | Overloaded. Overrides inherited ToPoint method.
ToValue (inherited from CircularControlBase) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToAngle (inherited from CircularControlBase) | Converts value to angle.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Meter Class | PerpetuumSoft.InstrumentationPDA Namespace


Meter Constructor

Initializes a new instance of the Meter class.

[Visual Basic]
Public Sub New()
[C#]
public Meter();

See Also

Meter Class | PerpetuumSoft.InstrumentationPDA Namespace


Meter Properties

The properties of the Meter class are listed below. For a complete list of Meter class members, see the Meter Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderCircleColor | Gets or sets border color.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Center (inherited from CircularControlBase) | Gets or sets displacement between control center and dial center.
CircleColor | Gets or sets circle color.
CircleRadius | Gets or sets circle radius.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
CurrentAngle (inherited from CircularControlBase) | Gets or sets current control angle.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
EndAngle (inherited from CircularControlBase) | Gets or sets end control angle.
ExternalPointerRadius (inherited from CircularControl) | Gets or sets external radius of the pointer.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InternalPointerRadius (inherited from CircularControl) | Gets or sets internal radius of the pointer.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels (inherited from CircularControl) | Gets or sets scale labels.
LabelsCount (inherited from CircularControl) |
LabelsRadius (inherited from CircularControl) | Gets or sets radius for the scale labels.
LabelsVisible (inherited from CircularControl) | Gets or sets whether scale labels should be displayed.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PointerColor (inherited from CircularControl) | Gets or sets color of the pointer.
PointerSize (inherited from CircularControl) | Gets or sets size of the pointer.
PointerType (inherited from CircularControl) | Gets or sets shape of pointer.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from CircularControlBase) | Gets or sets whether scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
SectionsColors (inherited from CircularControl) | Gets or sets colors of the scale.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
StartAngle (inherited from CircularControlBase) | Gets or sets start control angle.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksCount (inherited from CircularControl) |
TicksLenght (inherited from CircularControl) | Gets or sets the lenght of the scale ticks.
TicksRadius (inherited from CircularControl) | Gets or sets scale ticks radius.
TicksSubDivisionsCount (inherited from CircularControl) |
TicksVisible (inherited from CircularControl) | Gets or sets whether scale ticks should be displayed.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TotalAngle (inherited from CircularControlBase) | Gets or sets full control angle.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CenterPoint (inherited from CircularControlBase) | Gets dial center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

Meter Class | PerpetuumSoft.InstrumentationPDA Namespace


BorderCircleColor Property

Instrumentation Widgets for PDA

Meter.BorderCircleColor Property

Gets or sets border color.

[Visual Basic]
Public Property BorderCircleColor As Color
[C#]
public System.Drawing.Color BorderCircleColor {get; set;}

See Also

Meter Class | PerpetuumSoft.InstrumentationPDA Namespace


CircleColor Property

Instrumentation Widgets for PDA

Meter.CircleColor Property

Gets or sets circle color.

[Visual Basic]
Public Property CircleColor As Color
[C#]
public System.Drawing.Color CircleColor {get; set;}

See Also

Meter Class | PerpetuumSoft.InstrumentationPDA Namespace


CircleRadius Property

Instrumentation Widgets for PDA

Meter.CircleRadius Property

Gets or sets circle radius.

[Visual Basic]
Public Property CircleRadius As Integer
[C#]
public int CircleRadius {get; set;}

See Also

Meter Class | PerpetuumSoft.InstrumentationPDA Namespace


DefaultSize Property

Instrumentation Widgets for PDA

Meter.DefaultSize Property

Gets default control size.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override System.Drawing.Size DefaultSize {get;}

See Also

Meter Class | PerpetuumSoft.InstrumentationPDA Namespace


Meter Methods

The methods of the Meter class are listed below. For a complete list of Meter class members, see the Meter Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AngleToValue (inherited from CircularControlBase) | Converts angle to value.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic (inherited from CircularControl) | Overrides inherited DrawDynamic method.
DrawPointer (inherited from CircularControl) | Paints pointer.
DrawScale (inherited from CircularControl) | Paints scale.
DrawStatic | Overrides inherited DtrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
GetColor (inherited from CircularControl) | Returns color of the scale element corresponding to the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToAngle (inherited from CircularControlBase) | Converts percent to angle.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from CircularControlBase) | Overloaded. Overrides inherited ToPoint method.
ToValue (inherited from CircularControlBase) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToAngle (inherited from CircularControlBase) | Converts value to angle.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Meter Class | PerpetuumSoft.InstrumentationPDA Namespace


Meter.DrawStatic Method

Overrides inherited DtrawStatic method.

[Visual Basic]
Overrides Protected Sub DrawStatic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawStatic(
Graphics g
);

Parameters

g

See Also

Meter Class | PerpetuumSoft.InstrumentationPDA Namespace


Orientation Enumeration

Control orientation.

[Visual Basic]
Public Enum Orientation
[C#]
public enum Orientation

Members

Member Name | Description
Vertical | Vertical orientation.
Horizontal | Horizontal orientation.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

PerpetuumSoft.InstrumentationPDA Namespace


PointerType Enumeration

Type of a dial pointer.

[Visual Basic]
Public Enum PointerType
[C#]
public enum PointerType

Members

Member Name | Description
Circle | Circle shaped pointer.
Line | Line pointer.
Triangle | Triangle pointer.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

PerpetuumSoft.InstrumentationPDA Namespace


Slider Class

Emulates look and feel of slider.

For a list of all members of this type, see Slider Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.ValuePresenter
PerpetuumSoft.InstrumentationPDA.LinearControl
PerpetuumSoft.InstrumentationPDA.Slider

[Visual Basic]
Public Class Slider
Inherits LinearControl
[C#]
public class Slider : LinearControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Slider Members | PerpetuumSoft.InstrumentationPDA Namespace


Slider Members

Slider overview

Public Instance Constructors

Slider Constructor Initializes a new instance of the Slider class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveBarColor | Gets and sets color of the active part of bar.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BarWidth (inherited from LinearControl) | Gets or sets width of the bar.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InactiveBarColor | Gets and sets color of the inactive part of bar.
Indent (inherited from LinearControl) | Gets or sets control indents.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels (inherited from LinearControl) | Gets or sets labels texts.
LabelsPosition (inherited from LinearControl) | Gets and sets position of the labels on the scale.
LedColor | Gets and sets color of the led.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation (inherited from LinearControl) | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from LinearControl) | Gets or sets if the scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScaleDivisions (inherited from LinearControl) | Gets and sets number of divisions on the scale.
ScaleLabelDivisions (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
ScaleSubDivisions (inherited from LinearControl) | Gets and sets number of subdivisions in each division on the scale.
ScaleWidth (inherited from LinearControl) | Gets or sets width of scale.
SectionsColors (inherited from LinearControl) | Gets or sets scale colors.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SliderBarColor | Gets and sets color of the bar.
SliderImage | Gets and sets image for slider.
SliderSize | Gets or sets size of the slider.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksLenght (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
TicksPosition (inherited from LinearControl) | Gets or sets position of the ticks on the scale.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
ValueBackgroundColor (inherited from LinearControl) | Gets or sets background for the current value label.
ValuePosition (inherited from LinearControl) | Gets or sets position of the current value label.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from ValuePresenter) | Occurs when Value of the control changed.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CenterLine (inherited from LinearControl) | Returns coord of the bar center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction (inherited from LinearControl) | Gets control direction.
EndPoint (inherited from LinearControl) | Returns end bar point.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
StartPoint (inherited from LinearControl) | Returns start bar point.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawActiveBar |
DrawBevel (inherited from Widget) | Paints control bevel.
DrawCurrentValue (inherited from LinearControl) | Paints current value.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawInactiveBar |
DrawScale (inherited from LinearControl) | Paints scale.
DrawSlider |
DrawStatic | Overrides inherited DrawStaic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
FromPoint (inherited from LinearControl) | Overrides inherited FromPoint method.
GetColor (inherited from LinearControl) | Returns color for the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from LinearControl) | Overrides inherited ToPoint method.
ToValue (inherited from LinearControl) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


Slider Constructor

Initializes a new instance of the Slider class.

[Visual Basic]
Public Sub New()
[C#]
public Slider();

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


Slider Properties

The properties of the Slider class are listed below. For a complete list of Slider class members, see the Slider Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveBarColor | Gets and sets color of the active part of bar.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BarWidth (inherited from LinearControl) | Gets or sets width of the bar.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InactiveBarColor | Gets and sets color of the inactive part of bar.
Indent (inherited from LinearControl) | Gets or sets control indents.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels (inherited from LinearControl) | Gets or sets labels texts.
LabelsPosition (inherited from LinearControl) | Gets and sets position of the labels on the scale.
LedColor | Gets and sets color of the led.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation (inherited from LinearControl) | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from LinearControl) | Gets or sets if the scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScaleDivisions (inherited from LinearControl) | Gets and sets number of divisions on the scale.
ScaleLabelDivisions (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
ScaleSubDivisions (inherited from LinearControl) | Gets and sets number of subdivisions in each division on the scale.
ScaleWidth (inherited from LinearControl) | Gets or sets width of scale.
SectionsColors (inherited from LinearControl) | Gets or sets scale colors.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SliderBarColor | Gets and sets color of the bar.
SliderImage | Gets and sets image for slider.
SliderSize | Gets or sets size of the slider.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksLenght (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
TicksPosition (inherited from LinearControl) | Gets or sets position of the ticks on the scale.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
ValueBackgroundColor (inherited from LinearControl) | Gets or sets background for the current value label.
ValuePosition (inherited from LinearControl) | Gets or sets position of the current value label.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CenterLine (inherited from LinearControl) | Returns coord of the bar center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction (inherited from LinearControl) | Gets control direction.
EndPoint (inherited from LinearControl) | Returns end bar point.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
StartPoint (inherited from LinearControl) | Returns start bar point.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


ActiveBarColor Property

Instrumentation Widgets for PDA

Slider.ActiveBarColor Property

Gets and sets color of the active part of bar.

[Visual Basic]
Public Property ActiveBarColor As Color
[C#]
public System.Drawing.Color ActiveBarColor {get; set;}

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


DefaultSize Property

Instrumentation Widgets for PDA

Slider.DefaultSize Property

Gets default control size.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override System.Drawing.Size DefaultSize {get;}

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


InactiveBarColor Property

Instrumentation Widgets for PDA

Slider.InactiveBarColor Property

Gets and sets color of the inactive part of bar.

[Visual Basic]
Public Property InactiveBarColor As Color
[C#]
public System.Drawing.Color InactiveBarColor {get; set;}

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


LedColor Property

Instrumentation Widgets for PDA

Slider.LedColor Property

Gets and sets color of the led.

[Visual Basic]
Public Property LedColor As Color
[C#]
public System.Drawing.Color LedColor {get; set;}

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


SliderBarColor Property

Instrumentation Widgets for PDA

Slider.SliderBarColor Property

Gets and sets color of the bar.

[Visual Basic]
Public Property SliderBarColor As Color
[C#]
public System.Drawing.Color SliderBarColor {get; set;}

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


SliderImage Property

Instrumentation Widgets for PDA

Slider.SliderImage Property

Gets and sets image for slider.

[Visual Basic]
Public Property SliderImage As Image
[C#]
public System.Drawing.Image SliderImage {get; set;}

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


SliderSize Property

Instrumentation Widgets for PDA

Slider.SliderSize Property

Gets or sets size of the slider.

[Visual Basic]
Public Property SliderSize As Size
[C#]
public System.Drawing.Size SliderSize {get; set;}

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


Slider Methods

The methods of the Slider class are listed below. For a complete list of Slider class members, see the Slider Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawActiveBar |
DrawBevel (inherited from Widget) | Paints control bevel.
DrawCurrentValue (inherited from LinearControl) | Paints current value.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawInactiveBar |
DrawScale (inherited from LinearControl) | Paints scale.
DrawSlider |
DrawStatic | Overrides inherited DrawStaic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
FromPoint (inherited from LinearControl) | Overrides inherited FromPoint method.
GetColor (inherited from LinearControl) | Returns color for the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from LinearControl) | Overrides inherited ToPoint method.
ToValue (inherited from LinearControl) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


Slider.DrawActiveBar Method

[Visual Basic]
Overridable Protected Sub DrawActiveBar( _
ByVal g As Graphics _
)
[C#]
protected virtual void DrawActiveBar(
Graphics g
);

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


Slider.DrawDynamic Method

Overrides inherited DrawDynamic method.

[Visual Basic]
Overrides Protected Sub DrawDynamic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawDynamic(
Graphics g
);

Parameters

g

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


Slider.DrawInactiveBar Method

[Visual Basic]
Overridable Protected Sub DrawInactiveBar( _
ByVal g As Graphics _
)
[C#]
protected virtual void DrawInactiveBar(
Graphics g
);

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


Slider.DrawSlider Method

[Visual Basic]
Overridable Protected Sub DrawSlider( _
ByVal g As Graphics _
)
[C#]
protected virtual void DrawSlider(
Graphics g
);

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


Slider.DrawStatic Method

Overrides inherited DrawStaic method.

[Visual Basic]
Overrides Protected Sub DrawStatic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawStatic(
Graphics g
);

Parameters

g

See Also

Slider Class | PerpetuumSoft.InstrumentationPDA Namespace


SliderElementsPosition Enumeration

Position of linear control elements.

[Visual Basic]
Public Enum SliderElementsPosition
[C#]
public enum SliderElementsPosition

Members

Member Name | Description
None | Invisible.
TopLeft | At top or left.
BottomRight | At bottom or rigth.
Both | At both sides.
Internal | Internal.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

PerpetuumSoft.InstrumentationPDA Namespace


Switch Class

Emulates look and feeel of switch.

For a list of all members of this type, see Switch Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.SwitchBase
PerpetuumSoft.InstrumentationPDA.Switch

[Visual Basic]
Public Class Switch
Inherits SwitchBase
[C#]
public class Switch : SwitchBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Switch Members | PerpetuumSoft.InstrumentationPDA Namespace


Switch Members

Switch overview

Public Instance Constructors

Switch Constructor Initializes a new instance of the Switch class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveLedColor | Gets or sets color of the led in pressed state.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Checked (inherited from SwitchBase) | Gets and sets if the switch is on.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DarkColor | Gets or sets dark control part color.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Depth | Gets or sets press depth.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FaceStyle | Gets or sets control face appearance.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InactiveLedColor | Gets or sets color of the led in unpressed state.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
LedSize | Gets or sets size of the led.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LightColor | Gets or sets light control part color.
LightLightColor | Gets or sets lightest control part color.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MiddleColor | Gets or sets middle control part color.
Name (inherited from Control) | Gets or sets the name of the control.
NotchDarkColor | Gets or sets dark color of notches.
NotchLightColor | Gets or sets light color of notches.
Orientation (inherited from SwitchBase) | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Reverse (inherited from SwitchBase) | Gets or sets if scale is reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
CheckedChanged (inherited from SwitchBase) | Occurs when Checked of the control changed.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction (inherited from SwitchBase) | Gets control direction.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawStatic (inherited from Widget) | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsCheckedPoint (inherited from SwitchBase) | Returns if specified point corresponeds checked state.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged (inherited from SwitchBase) | Raises CheckedChanged event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from SwitchBase) | Raises the MouseDown event and set Checked property corresponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from SwitchBase) | Raises the MouseMove event and set Checked property corrsponding to current mouse position.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


Switch Constructor

Initializes a new instance of the Switch class.

[Visual Basic]
Public Sub New()
[C#]
public Switch();

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


Switch Properties

The properties of the Switch class are listed below. For a complete list of Switch class members, see the Switch Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveLedColor | Gets or sets color of the led in pressed state.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Checked (inherited from SwitchBase) | Gets and sets if the switch is on.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DarkColor | Gets or sets dark control part color.
DataBindings (inherited from Control) | Gets the data bindings for the control.
Depth | Gets or sets press depth.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FaceStyle | Gets or sets control face appearance.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InactiveLedColor | Gets or sets color of the led in unpressed state.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
LedSize | Gets or sets size of the led.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LightColor | Gets or sets light control part color.
LightLightColor | Gets or sets lightest control part color.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MiddleColor | Gets or sets middle control part color.
Name (inherited from Control) | Gets or sets the name of the control.
NotchDarkColor | Gets or sets dark color of notches.
NotchLightColor | Gets or sets light color of notches.
Orientation (inherited from SwitchBase) | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Reverse (inherited from SwitchBase) | Gets or sets if scale is reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction (inherited from SwitchBase) | Gets control direction.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


ActiveLedColor Property

Instrumentation Widgets for PDA

Switch.ActiveLedColor Property

Gets or sets color of the led in pressed state.

[Visual Basic]
Public Property ActiveLedColor As Color
[C#]
public System.Drawing.Color ActiveLedColor {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


DarkColor Property

Instrumentation Widgets for PDA

Switch.DarkColor Property

Gets or sets dark control part color.

[Visual Basic]
Public Property DarkColor As Color
[C#]
public System.Drawing.Color DarkColor {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


DefaultSize Property

Instrumentation Widgets for PDA

Switch.DefaultSize Property

Gets default control size.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override System.Drawing.Size DefaultSize {get;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


Depth Property

Instrumentation Widgets for PDA

Switch.Depth Property

Gets or sets press depth.

[Visual Basic]
Public Property Depth As Integer
[C#]
public int Depth {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


FaceStyle Property

Instrumentation Widgets for PDA

Switch.FaceStyle Property

Gets or sets control face appearance.

[Visual Basic]
Public Property FaceStyle As FaceStyle
[C#]
public FaceStyle FaceStyle {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


InactiveLedColor Property

Instrumentation Widgets for PDA

Switch.InactiveLedColor Property

Gets or sets color of the led in unpressed state.

[Visual Basic]
Public Property InactiveLedColor As Color
[C#]
public System.Drawing.Color InactiveLedColor {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


LedSize Property

Instrumentation Widgets for PDA

Switch.LedSize Property

Gets or sets size of the led.

[Visual Basic]
Public Property LedSize As Size
[C#]
public System.Drawing.Size LedSize {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


LightColor Property

Instrumentation Widgets for PDA

Switch.LightColor Property

Gets or sets light control part color.

[Visual Basic]
Public Property LightColor As Color
[C#]
public System.Drawing.Color LightColor {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


LightLightColor Property

Instrumentation Widgets for PDA

Switch.LightLightColor Property

Gets or sets lightest control part color.

[Visual Basic]
Public Property LightLightColor As Color
[C#]
public System.Drawing.Color LightLightColor {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


MiddleColor Property

Instrumentation Widgets for PDA

Switch.MiddleColor Property

Gets or sets middle control part color.

[Visual Basic]
Public Property MiddleColor As Color
[C#]
public System.Drawing.Color MiddleColor {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


NotchDarkColor Property

Instrumentation Widgets for PDA

Switch.NotchDarkColor Property

Gets or sets dark color of notches.

[Visual Basic]
Public Property NotchDarkColor As Color
[C#]
public System.Drawing.Color NotchDarkColor {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


NotchLightColor Property

Instrumentation Widgets for PDA

Switch.NotchLightColor Property

Gets or sets light color of notches.

[Visual Basic]
Public Property NotchLightColor As Color
[C#]
public System.Drawing.Color NotchLightColor {get; set;}

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


Switch Methods

The methods of the Switch class are listed below. For a complete list of Switch class members, see the Switch Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawStatic (inherited from Widget) | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsCheckedPoint (inherited from SwitchBase) | Returns if specified point corresponeds checked state.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged (inherited from SwitchBase) | Raises CheckedChanged event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from SwitchBase) | Raises the MouseDown event and set Checked property corresponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from SwitchBase) | Raises the MouseMove event and set Checked property corrsponding to current mouse position.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


Switch.DrawDynamic Method

Overrides inherited DrawDynamic method.

[Visual Basic]
Overrides Protected Sub DrawDynamic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawDynamic(
Graphics g
);

Parameters

g

See Also

Switch Class | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase Class

Provides base behavior for switches and toggles.

For a list of all members of this type, see SwitchBase Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.SwitchBase
PerpetuumSoft.InstrumentationPDA.Switch
PerpetuumSoft.InstrumentationPDA.Toggle

[Visual Basic]
MustInherit Public Class SwitchBase
Inherits Widget
[C#]
public abstract class SwitchBase : Widget

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

SwitchBase Members | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase Members

SwitchBase overview

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Checked | Gets and sets if the switch is on.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Reverse | Gets or sets if scale is reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
CheckedChanged | Occurs when Checked of the control changed.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Constructors

SwitchBase Constructor Initializes a new instance of the SwitchBase class.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Widget) | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction | Gets control direction.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic (inherited from Widget) | Virtual method that perform actual drawing of dynamic part of the control.
DrawStatic (inherited from Widget) | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsCheckedPoint | Returns if specified point corresponeds checked state.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged | Raises CheckedChanged event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown | Raises the MouseDown event and set Checked property corresponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove | Raises the MouseMove event and set Checked property corrsponding to current mouse position.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase Constructor

Initializes a new instance of the SwitchBase class.

[Visual Basic]
Protected Sub New()
[C#]
protected SwitchBase();

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase Properties

The properties of the SwitchBase class are listed below. For a complete list of SwitchBase class members, see the SwitchBase Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Checked | Gets and sets if the switch is on.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Reverse | Gets or sets if scale is reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Widget) | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction | Gets control direction.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


Checked Property

Instrumentation Widgets for PDA

SwitchBase.Checked Property

Gets and sets if the switch is on.

[Visual Basic]
Public Property Checked As Boolean
[C#]
public bool Checked {get; set;}

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


Direction Property

Instrumentation Widgets for PDA

SwitchBase.Direction Property

Gets control direction.

[Visual Basic]
Protected ReadOnly Property Direction As Direction
[C#]
protected Mathematics.Direction Direction {get;}

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


Orientation Property

Instrumentation Widgets for PDA

SwitchBase.Orientation Property

Gets or sets control orientation.

[Visual Basic]
Public Property Orientation As Orientation
[C#]
public Orientation Orientation {get; set;}

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


Reverse Property

Instrumentation Widgets for PDA

SwitchBase.Reverse Property

Gets or sets if scale is reversed.

[Visual Basic]
Public Property Reverse As Boolean
[C#]
public bool Reverse {get; set;}

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase Methods

The methods of the SwitchBase class are listed below. For a complete list of SwitchBase class members, see the SwitchBase Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic (inherited from Widget) | Virtual method that perform actual drawing of dynamic part of the control.
DrawStatic (inherited from Widget) | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsCheckedPoint | Returns if specified point corresponeds checked state.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged | Raises CheckedChanged event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown | Raises the MouseDown event and set Checked property corresponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove | Raises the MouseMove event and set Checked property corrsponding to current mouse position.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase.IsCheckedPoint Method

Returns if specified point corresponeds checked state.

[Visual Basic]
Overridable Protected Function IsCheckedPoint( _
ByVal x As Integer, _
ByVal y As Integer _
) As Boolean
[C#]
protected virtual bool IsCheckedPoint(
int x,
int y
);

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase.OnCheckedChanged Method

Raises CheckedChanged event.

[Visual Basic]
Overridable Protected Sub OnCheckedChanged( _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnCheckedChanged(
EventArgs e
);

Parameters

e

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase.OnMouseDown Method

Raises the MouseDown event and set Checked property corresponding to current mouse position.

[Visual Basic]
Overrides Protected Sub OnMouseDown( _
ByVal mevent As MouseEventArgs _
)
[C#]
protected override void OnMouseDown(
MouseEventArgs mevent
);

Parameters

mevent

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase.OnMouseMove Method

Raises the MouseMove event and set Checked property corrsponding to current mouse position.

[Visual Basic]
Overrides Protected Sub OnMouseMove( _
ByVal e As MouseEventArgs _
)
[C#]
protected override void OnMouseMove(
MouseEventArgs e
);

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase Events

The events of the SwitchBase class are listed below. For a complete list of SwitchBase class members, see the SwitchBase Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
CheckedChanged | Occurs when Checked of the control changed.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


SwitchBase.CheckedChanged Event

Occurs when Checked of the control changed.

[Visual Basic]
Public Event CheckedChanged As EventHandler
[C#]
public event EventHandler CheckedChanged;

See Also

SwitchBase Class | PerpetuumSoft.InstrumentationPDA Namespace


Thermometer Class

Emulates look and feel of thermometer.

For a list of all members of this type, see Thermometer Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.ValuePresenter
PerpetuumSoft.InstrumentationPDA.LinearControl
PerpetuumSoft.InstrumentationPDA.Thermometer

[Visual Basic]
Public Class Thermometer
Inherits LinearControl
[C#]
public class Thermometer : LinearControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Thermometer Members | PerpetuumSoft.InstrumentationPDA Namespace


Thermometer Members

Thermometer overview

Public Instance Constructors

Thermometer Constructor Initializes a new instance of the Thermometer class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BarWidth (inherited from LinearControl) | Gets or sets width of the bar.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Indent (inherited from LinearControl) | Gets or sets control indents.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels (inherited from LinearControl) | Gets or sets labels texts.
LabelsPosition (inherited from LinearControl) | Gets and sets position of the labels on the scale.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LiquidColor | Gets or sets color of liquid.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation (inherited from LinearControl) | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from LinearControl) | Gets or sets if the scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScaleDivisions (inherited from LinearControl) | Gets and sets number of divisions on the scale.
ScaleLabelDivisions (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
ScaleSubDivisions (inherited from LinearControl) | Gets and sets number of subdivisions in each division on the scale.
ScaleWidth (inherited from LinearControl) | Gets or sets width of scale.
SectionsColors (inherited from LinearControl) | Gets or sets scale colors.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
TankColor | Gets or sets color of tank.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksLenght (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
TicksPosition (inherited from LinearControl) | Gets or sets position of the ticks on the scale.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
ValueBackgroundColor (inherited from LinearControl) | Gets or sets background for the current value label.
ValuePosition (inherited from LinearControl) | Gets or sets position of the current value label.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged (inherited from ValuePresenter) | Occurs when Value of the control changed.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CenterLine (inherited from LinearControl) | Returns coord of the bar center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction (inherited from LinearControl) | Gets control direction.
EndPoint (inherited from LinearControl) | Returns end bar point.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
StartPoint (inherited from LinearControl) | Returns start bar point.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawCurrentValue (inherited from LinearControl) | Paints current value.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawScale (inherited from LinearControl) | Paints scale.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
FromPoint (inherited from LinearControl) | Overrides inherited FromPoint method.
GetColor (inherited from LinearControl) | Returns color for the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from LinearControl) | Overrides inherited ToPoint method.
ToValue (inherited from LinearControl) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Thermometer Class | PerpetuumSoft.InstrumentationPDA Namespace


Thermometer Constructor

Initializes a new instance of the Thermometer class.

[Visual Basic]
Public Sub New()
[C#]
public Thermometer();

See Also

Thermometer Class | PerpetuumSoft.InstrumentationPDA Namespace


Thermometer Properties

The properties of the Thermometer class are listed below. For a complete list of Thermometer class members, see the Thermometer Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BarWidth (inherited from LinearControl) | Gets or sets width of the bar.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format (inherited from ValuePresenter) | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Indent (inherited from LinearControl) | Gets or sets control indents.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly (inherited from ValuePresenter) | Gets or sets whether control will act only as indicator.
Labels (inherited from LinearControl) | Gets or sets labels texts.
LabelsPosition (inherited from LinearControl) | Gets and sets position of the labels on the scale.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LiquidColor | Gets or sets color of liquid.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum (inherited from ValuePresenter) | Gets or sets the upper bound for the value property.
Minimum (inherited from ValuePresenter) | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Orientation (inherited from LinearControl) | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReverseScale (inherited from LinearControl) | Gets or sets if the scale should be reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ScaleDivisions (inherited from LinearControl) | Gets and sets number of divisions on the scale.
ScaleLabelDivisions (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
ScaleSubDivisions (inherited from LinearControl) | Gets and sets number of subdivisions in each division on the scale.
ScaleWidth (inherited from LinearControl) | Gets or sets width of scale.
SectionsColors (inherited from LinearControl) | Gets or sets scale colors.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Step (inherited from ValuePresenter) | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
TankColor | Gets or sets color of tank.
Text (inherited from Control) | Gets or sets the text associated with this control.
TicksLenght (inherited from LinearControl) | Gets and sets lenght of the scale ticks.
TicksPosition (inherited from LinearControl) | Gets or sets position of the ticks on the scale.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Value (inherited from ValuePresenter) | Gets or sets current value associated with the control.
ValueBackgroundColor (inherited from LinearControl) | Gets or sets background for the current value label.
ValuePosition (inherited from LinearControl) | Gets or sets position of the current value label.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CenterLine (inherited from LinearControl) | Returns coord of the bar center.
CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction (inherited from LinearControl) | Gets control direction.
EndPoint (inherited from LinearControl) | Returns end bar point.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
StartPoint (inherited from LinearControl) | Returns start bar point.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

Thermometer Class | PerpetuumSoft.InstrumentationPDA Namespace


DefaultSize Property

Instrumentation Widgets for PDA

Thermometer.DefaultSize Property

Gets default control size.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override System.Drawing.Size DefaultSize {get;}

See Also

Thermometer Class | PerpetuumSoft.InstrumentationPDA Namespace


LiquidColor Property

Instrumentation Widgets for PDA

Thermometer.LiquidColor Property

Gets or sets color of liquid.

[Visual Basic]
Public Property LiquidColor As Color
[C#]
public System.Drawing.Color LiquidColor {get; set;}

See Also

Thermometer Class | PerpetuumSoft.InstrumentationPDA Namespace


TankColor Property

Instrumentation Widgets for PDA

Thermometer.TankColor Property

Gets or sets color of tank.

[Visual Basic]
Public Property TankColor As Color
[C#]
public System.Drawing.Color TankColor {get; set;}

See Also

Thermometer Class | PerpetuumSoft.InstrumentationPDA Namespace


Thermometer Methods

The methods of the Thermometer class are listed below. For a complete list of Thermometer class members, see the Thermometer Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawCurrentValue (inherited from LinearControl) | Paints current value.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawScale (inherited from LinearControl) | Paints scale.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue (inherited from ValuePresenter) | Formats number with current settings.
FromPoint (inherited from LinearControl) | Overrides inherited FromPoint method.
GetColor (inherited from LinearControl) | Returns color for the specified value.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from ValuePresenter) | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from ValuePresenter) | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp (inherited from ValuePresenter) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged (inherited from ValuePresenter) | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToValue (inherited from ValuePresenter) | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint (inherited from LinearControl) | Overrides inherited ToPoint method.
ToValue (inherited from LinearControl) | Overrides inherited ToValue method.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToPercent (inherited from ValuePresenter) | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Thermometer Class | PerpetuumSoft.InstrumentationPDA Namespace


Thermometer.DrawDynamic Method

Overrides inherited DrawDynamic method.

[Visual Basic]
Overrides Protected Sub DrawDynamic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawDynamic(
Graphics g
);

See Also

Thermometer Class | PerpetuumSoft.InstrumentationPDA Namespace


Thermometer.DrawStatic Method

Overrides inherited DrawStatic method.

[Visual Basic]
Overrides Protected Sub DrawStatic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawStatic(
Graphics g
);

Parameters

g

See Also

Thermometer Class | PerpetuumSoft.InstrumentationPDA Namespace


Toggle Class

Emulates toggle look, feel and behavior.

For a list of all members of this type, see Toggle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.SwitchBase
PerpetuumSoft.InstrumentationPDA.Toggle

[Visual Basic]
Public Class Toggle
Inherits SwitchBase
[C#]
public class Toggle : SwitchBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Toggle Members | PerpetuumSoft.InstrumentationPDA Namespace


Toggle Members

Toggle overview

Public Instance Constructors

Toggle Constructor Creates new instance of the Toggle class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveLedColor | Gets or sets color of the led in pressed state.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Checked (inherited from SwitchBase) | Gets and sets if the switch is on.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FaceColor | Gets or sets middle part color.
FaceStyle | Gets or sets face style.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InactiveLedColor | Gets or sets color of the led in unpressed state.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
LedSize | Gets or sets the size of the led.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
NotchDarkColor | Gets or sets dark color of notches.
NotchLightColor | Gets or sets light color of notches.
Orientation (inherited from SwitchBase) | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Reverse (inherited from SwitchBase) | Gets or sets if scale is reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
CheckedChanged (inherited from SwitchBase) | Occurs when Checked of the control changed.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction (inherited from SwitchBase) | Gets control direction.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsCheckedPoint (inherited from SwitchBase) | Returns if specified point corresponeds checked state.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged (inherited from SwitchBase) | Raises CheckedChanged event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from SwitchBase) | Raises the MouseDown event and set Checked property corresponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from SwitchBase) | Raises the MouseMove event and set Checked property corrsponding to current mouse position.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


Toggle Constructor

Creates new instance of the Toggle class.

[Visual Basic]
Public Sub New()
[C#]
public Toggle();

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


Toggle Properties

The properties of the Toggle class are listed below. For a complete list of Toggle class members, see the Toggle Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveLedColor | Gets or sets color of the led in pressed state.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Checked (inherited from SwitchBase) | Gets and sets if the switch is on.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
FaceColor | Gets or sets middle part color.
FaceStyle | Gets or sets face style.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InactiveLedColor | Gets or sets color of the led in unpressed state.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
LedSize | Gets or sets the size of the led.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
NotchDarkColor | Gets or sets dark color of notches.
NotchLightColor | Gets or sets light color of notches.
Orientation (inherited from SwitchBase) | Gets or sets control orientation.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Reverse (inherited from SwitchBase) | Gets or sets if scale is reversed.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Direction (inherited from SwitchBase) | Gets control direction.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


ActiveLedColor Property

Instrumentation Widgets for PDA

Toggle.ActiveLedColor Property

Gets or sets color of the led in pressed state.

[Visual Basic]
Public Property ActiveLedColor As Color
[C#]
public System.Drawing.Color ActiveLedColor {get; set;}

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


DefaultSize Property

Instrumentation Widgets for PDA

Toggle.DefaultSize Property

Gets default control size.

[Visual Basic]
Overrides Protected ReadOnly Property DefaultSize As Size
[C#]
protected override System.Drawing.Size DefaultSize {get;}

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


FaceColor Property

Instrumentation Widgets for PDA

Toggle.FaceColor Property

Gets or sets middle part color.

[Visual Basic]
Public Property FaceColor As Color
[C#]
public System.Drawing.Color FaceColor {get; set;}

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


FaceStyle Property

Instrumentation Widgets for PDA

Toggle.FaceStyle Property

Gets or sets face style.

[Visual Basic]
Public Property FaceStyle As FaceStyle
[C#]
public FaceStyle FaceStyle {get; set;}

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


InactiveLedColor Property

Instrumentation Widgets for PDA

Toggle.InactiveLedColor Property

Gets or sets color of the led in unpressed state.

[Visual Basic]
Public Property InactiveLedColor As Color
[C#]
public System.Drawing.Color InactiveLedColor {get; set;}

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


LedSize Property

Instrumentation Widgets for PDA

Toggle.LedSize Property

Gets or sets the size of the led.

[Visual Basic]
Public Property LedSize As Size
[C#]
public System.Drawing.Size LedSize {get; set;}

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


NotchDarkColor Property

Instrumentation Widgets for PDA

Toggle.NotchDarkColor Property

Gets or sets dark color of notches.

[Visual Basic]
Public Property NotchDarkColor As Color
[C#]
public System.Drawing.Color NotchDarkColor {get; set;}

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


NotchLightColor Property

Instrumentation Widgets for PDA

Toggle.NotchLightColor Property

Gets or sets light color of notches.

[Visual Basic]
Public Property NotchLightColor As Color
[C#]
public System.Drawing.Color NotchLightColor {get; set;}

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


Toggle Methods

The methods of the Toggle class are listed below. For a complete list of Toggle class members, see the Toggle Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic | Overrides inherited DrawDynamic method.
DrawStatic | Overrides inherited DrawStatic method.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsCheckedPoint (inherited from SwitchBase) | Returns if specified point corresponeds checked state.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnCheckedChanged (inherited from SwitchBase) | Raises CheckedChanged event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from SwitchBase) | Raises the MouseDown event and set Checked property corresponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from SwitchBase) | Raises the MouseMove event and set Checked property corrsponding to current mouse position.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


Toggle.DrawDynamic Method

Overrides inherited DrawDynamic method.

[Visual Basic]
Overrides Protected Sub DrawDynamic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawDynamic(
Graphics g
);

Parameters

g

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


Toggle.DrawStatic Method

Overrides inherited DrawStatic method.

[Visual Basic]
Overrides Protected Sub DrawStatic( _
ByVal g As Graphics _
)
[C#]
protected override void DrawStatic(
Graphics g
);

See Also

Toggle Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter Class

Provides basic logic for all controls that presents decimal value.

For a list of all members of this type, see ValuePresenter Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.ValuePresenter
PerpetuumSoft.InstrumentationPDA.CircularControlBase
PerpetuumSoft.InstrumentationPDA.LinearControl

[Visual Basic]
MustInherit Public Class ValuePresenter
Inherits Widget
[C#]
public abstract class ValuePresenter : Widget

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

ValuePresenter Members | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter Members

ValuePresenter overview

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly | Gets or sets whether control will act only as indicator.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum | Gets or sets the upper bound for the value property.
Minimum | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Step | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Value | Gets or sets current value associated with the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged | Occurs when Value of the control changed.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Constructors

ValuePresenter Constructor Initializes a new instance of the ValuePresenter class.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Widget) | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic (inherited from Widget) | Virtual method that perform actual drawing of dynamic part of the control.
DrawStatic (inherited from Widget) | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue | Formats number with current settings.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToValue | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint | Returns the point that corresponds specified value.
ToValue | Returns value that corresponds the selected screen point.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToPercent | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter Constructor

Initializes a new instance of the ValuePresenter class.

[Visual Basic]
Protected Sub New()
[C#]
protected ValuePresenter();

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter Properties

The properties of the ValuePresenter class are listed below. For a complete list of ValuePresenter class members, see the ValuePresenter Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Widget) | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel (inherited from Widget) | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Format | Gets or sets numbers format string.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsIndicatorOnly | Gets or sets whether control will act only as indicator.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Maximum | Gets or sets the upper bound for the value property.
Minimum | Gets or sets the lower bound for the value property.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
Step | Gets or sets step for value property.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Value | Gets or sets current value associated with the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Widget) | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle (inherited from Widget) | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


Format Property

Instrumentation Widgets for PDA

ValuePresenter.Format Property

Gets or sets numbers format string.

[Visual Basic]
Public Property Format As String
[C#]
public string Format {get; set;}

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


IsIndicatorOnly Property

Instrumentation Widgets for PDA

ValuePresenter.IsIndicatorOnly Property

Gets or sets whether control will act only as indicator.

[Visual Basic]
Public Property IsIndicatorOnly As Boolean
[C#]
public bool IsIndicatorOnly {get; set;}

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


Maximum Property

Instrumentation Widgets for PDA

ValuePresenter.Maximum Property

Gets or sets the upper bound for the value property.

[Visual Basic]
Public Property Maximum As Decimal
[C#]
public decimal Maximum {get; set;}

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


Minimum Property

Instrumentation Widgets for PDA

ValuePresenter.Minimum Property

Gets or sets the lower bound for the value property.

[Visual Basic]
Public Property Minimum As Decimal
[C#]
public decimal Minimum {get; set;}

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


Step Property

Instrumentation Widgets for PDA

ValuePresenter.Step Property

Gets or sets step for value property.

[Visual Basic]
Public Property Step As Decimal
[C#]
public decimal Step {get; set;}

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


Value Property

Instrumentation Widgets for PDA

ValuePresenter.Value Property

Gets or sets current value associated with the control.

[Visual Basic]
Public Property Value As Decimal
[C#]
public decimal Value {get; set;}

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter Methods

The methods of the ValuePresenter class are listed below. For a complete list of ValuePresenter class members, see the ValuePresenter Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel (inherited from Widget) | Paints control bevel.
DrawDynamic (inherited from Widget) | Virtual method that perform actual drawing of dynamic part of the control.
DrawStatic (inherited from Widget) | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
FormatValue | Formats number with current settings.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic (inherited from Widget) | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown | Raises the MouseDown event and set Value property corrsponding to current mouse position.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove | Raises the MouseMove event and set Value property corrsponding to current mouse position.
OnMouseUp | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Widget) | Overriden method to provide custom painting.
OnPaintBackground (inherited from Widget) | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Widget) | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnValueChanged | Raises ValueChange event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
PercentToValue | Converts precent to value.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round (inherited from Widget) | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
ToPoint | Returns the point that corresponds specified value.
ToValue | Returns value that corresponds the selected screen point.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
ValueToPercent | Converts value to percent.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter.FormatValue Method

Formats number with current settings.

[Visual Basic]
Protected Function FormatValue( _
ByVal value As Decimal _
) As String
[C#]
protected string FormatValue(
decimal value
);

Parameters

value

Return Value

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter.OnMouseDown Method

Raises the MouseDown event and set Value property corrsponding to current mouse position.

[Visual Basic]
Overrides Protected Sub OnMouseDown( _
ByVal e As MouseEventArgs _
)
[C#]
protected override void OnMouseDown(
MouseEventArgs e
);

Parameters

e

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter.OnMouseMove Method

Raises the MouseMove event and set Value property corrsponding to current mouse position.

[Visual Basic]
Overrides Protected Sub OnMouseMove( _
ByVal e As MouseEventArgs _
)
[C#]
protected override void OnMouseMove(
MouseEventArgs e
);

Parameters

e

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter.OnMouseUp Method

Raises the MouseUp event.

[Visual Basic]
Overrides Protected Sub OnMouseUp( _
ByVal e As MouseEventArgs _
)
[C#]
protected override void OnMouseUp(
MouseEventArgs e
);

Parameters

e

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter.OnValueChanged Method

Raises ValueChange event.

[Visual Basic]
Overridable Protected Sub OnValueChanged( _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnValueChanged(
EventArgs e
);

Parameters

e

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter.PercentToValue Method

Converts precent to value.

[Visual Basic]
Protected Function PercentToValue( _
ByVal value As Decimal _
) As Decimal
[C#]
protected decimal PercentToValue(
decimal value
);

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter.ToPoint Method

Returns the point that corresponds specified value.

[Visual Basic]
MustOverride Protected Function ToPoint( _
ByVal value As Decimal _
) As Vector
[C#]
protected abstract Vector ToPoint(
decimal value
);

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter.ToValue Method

Returns value that corresponds the selected screen point.

[Visual Basic]
MustOverride Protected Function ToValue( _
ByVal v As Vector _
) As Decimal
[C#]
protected abstract decimal ToValue(
Vector v
);

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter.ValueToPercent Method

Converts value to percent.

[Visual Basic]
Protected Function ValueToPercent( _
ByVal value As Decimal _
) As Decimal
[C#]
protected decimal ValueToPercent(
decimal value
);

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter Events

The events of the ValuePresenter class are listed below. For a complete list of ValuePresenter class members, see the ValuePresenter Members topic.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
ValueChanged | Occurs when Value of the control changed.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


ValuePresenter.ValueChanged Event

Occurs when Value of the control changed.

[Visual Basic]
Public Event ValueChanged As EventHandler
[C#]
public event EventHandler ValueChanged;

See Also

ValuePresenter Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget Class

Base class for all visual controls in library.

For a list of all members of this type, see Widget Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.DigitalLED
PerpetuumSoft.InstrumentationPDA.SwitchBase
PerpetuumSoft.InstrumentationPDA.ValuePresenter

[Visual Basic]
MustInherit Public Class Widget
Inherits Control
[C#]
public abstract class Widget : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Widget Members | PerpetuumSoft.InstrumentationPDA Namespace


Widget Members

Widget overview

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Constructors

Widget Constructor Creates new instance of the Widget class.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel | Paints control bevel.
DrawDynamic | Virtual method that perform actual drawing of dynamic part of the control.
DrawStatic | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Overriden method to provide custom painting.
OnPaintBackground | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget Constructor

Creates new instance of the Widget class.

[Visual Basic]
Protected Sub New()
[C#]
protected Widget();

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget Properties

The properties of the Widget class are listed below. For a complete list of Widget class members, see the Widget Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor | Overides BackColor and provides invalidation logic.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
Bevel | Gets or sets bevel for the widget.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize | Gets default control size.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
WorkRectangle | Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


BackColor Property

Instrumentation Widgets for PDA

Widget.BackColor Property

Overides BackColor and provides invalidation logic.

[Visual Basic]
Overrides Public Property BackColor As Color
[C#]
public override System.Drawing.Color BackColor {get; set;}

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Bevel Property

Instrumentation Widgets for PDA

Widget.Bevel Property

Gets or sets bevel for the widget.

[Visual Basic]
Public Property Bevel As Bevel
[C#]
public Bevel Bevel {get; set;}

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


DefaultSize Property

Instrumentation Widgets for PDA

Widget.DefaultSize Property

Gets default control size.

[Visual Basic]
Overridable Protected ReadOnly Property DefaultSize As Size
[C#]
new protected virtual System.Drawing.Size DefaultSize {get;}

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


WorkRectangle Property

Instrumentation Widgets for PDA

Widget.WorkRectangle Property

Gets internal rectangle to paint. Work rectangle excludes area occupied by control's bevel.

[Visual Basic]
Overridable Protected ReadOnly Property WorkRectangle As Rectangle
[C#]
protected virtual System.Drawing.Rectangle WorkRectangle {get;}

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget Methods

The methods of the Widget class are listed below. For a complete list of Widget class members, see the Widget Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
DrawBevel | Paints control bevel.
DrawDynamic | Virtual method that perform actual drawing of dynamic part of the control.
DrawStatic | Virtual method that perform actual drawing of static part of the control.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvalidateStatic | Invalidates all parts of the control.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint | Overriden method to provide custom painting.
OnPaintBackground | Overrides standard OnPaintBackground to avoid flicking.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize | Provides invalidation logic.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
Round | Rounds decimal value and convert it to int.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget.DrawBevel Method

Paints control bevel.

[Visual Basic]
Overridable Protected Sub DrawBevel( _
ByVal g As Graphics _
)
[C#]
protected virtual void DrawBevel(
Graphics g
);

Parameters

g
Graphics object to paint on.

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget.DrawDynamic Method

Virtual method that perform actual drawing of dynamic part of the control.

[Visual Basic]
Overridable Protected Sub DrawDynamic( _
ByVal g As Graphics _
)
[C#]
protected virtual void DrawDynamic(
Graphics g
);

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget.DrawStatic Method

Virtual method that perform actual drawing of static part of the control.

[Visual Basic]
Overridable Protected Sub DrawStatic( _
ByVal g As Graphics _
)
[C#]
protected virtual void DrawStatic(
Graphics g
);

Parameters

g

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget.InvalidateStatic Method

Invalidates all parts of the control.

[Visual Basic]
Protected Sub InvalidateStatic()
[C#]
protected void InvalidateStatic();

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget.OnPaint Method

Overriden method to provide custom painting.

[Visual Basic]
Overrides Protected Sub OnPaint( _
ByVal e As PaintEventArgs _
)
[C#]
protected override void OnPaint(
PaintEventArgs e
);

Remarks

Do not override this method when derive from control. Use Draw() method instead.

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget.OnPaintBackground Method

Overrides standard OnPaintBackground to avoid flicking.

[Visual Basic]
Overrides Protected Sub OnPaintBackground( _
ByVal e As PaintEventArgs _
)
[C#]
protected override void OnPaintBackground(
PaintEventArgs e
);

Parameters

e

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget.OnResize Method

Provides invalidation logic.

[Visual Basic]
Overrides Protected Sub OnResize( _
ByVal e As EventArgs _
)
[C#]
protected override void OnResize(
EventArgs e
);

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


Widget.Round Method

Rounds decimal value and convert it to int.

[Visual Basic]
Protected Function Round( _
ByVal value As Decimal _
) As Integer
[C#]
protected int Round(
decimal value
);

Parameters

value

Return Value

See Also

Widget Class | PerpetuumSoft.InstrumentationPDA Namespace


PerpetuumSoft.InstrumentationPDA.Mathematics

Instrumentation Widgets for PDA

PerpetuumSoft.InstrumentationPDA.Mathematics Namespace

Namespace hierarchy

Classes

Class | Description
Math2 | Provides additional Math functions.

Structures

Structure | Description
Vector | Defines properties of vectors on a plane and operations on these vectors.
VectorRectangle | Defines location and size of a rectangle on a surface.

Enumerations

Enumeration | Description
Direction | Vector directions.


Direction Enumeration

Vector directions.

[Visual Basic]
Public Enum Direction
[C#]
public enum Direction

Members

Member Name | Description
X | X - axis.
Y | Y - axis.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA.Mathematics

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Math2 Class

Provides additional Math functions.

For a list of all members of this type, see Math2 Members.

System.Object
PerpetuumSoft.InstrumentationPDA.Mathematics.Math2

[Visual Basic]
Public Class Math2
[C#]
public class Math2

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA.Mathematics

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Math2 Members | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Math2 Members

Math2 overview

Public Static (Shared) Fields

Degrees Allows to convert degrees to radians.

Public Instance Constructors

Math2 Constructor Initializes a new instance of the Math2 class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Math2 Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Math2 Constructor

Initializes a new instance of the Math2 class.

[Visual Basic]
Public Sub New()
[C#]
public Math2();

See Also

Math2 Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Math2 Fields

The fields of the Math2 class are listed below. For a complete list of Math2 class members, see the Math2 Members topic.

Public Static (Shared) Fields

Degrees Allows to convert degrees to radians.

See Also

Math2 Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Math2.Degrees Field

Allows to convert degrees to radians.

[Visual Basic]
Public Shared ReadOnly Degrees As Decimal
[C#]
public static readonly decimal Degrees;

See Also

Math2 Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Structure

Defines properties of vectors on a plane and operations on these vectors.

For a list of all members of this type, see Vector Members.

System.Object
System.ValueType
PerpetuumSoft.InstrumentationPDA.Mathematics.Vector

[Visual Basic]
Public Structure Vector
[C#]
public struct Vector

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This structure is similar to the .NET Framework structures SizeF and PointF, however, it implements a set of additional methods facilitating the work with coordinates of objects on a plane.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA.Mathematics

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

Vector Members | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Members

Vector overview

Public Static (Shared) Fields

Empty Defines a "null"-vector.

Public Static (Shared) Methods

FromPolar Converts plar coords to Vector.

Public Static (Shared) Operators and Type Conversions

Addition Operator | Implements addition of the two given vectors.
Division Operator | Implements division of the given vector by the specified scalar value.
Equality Operator | Returns true if two given vectors are identical.
Inequality Operator | Returns true if two given vectors are not identical.
Multiplication Operator | Overloaded. Implements multiplication of the two given vectors.
Subtraction Operator | Implements subtraction of the two given vectors.
Unary Negation Operator | Defines unary operator -.
Unary Plus Operator | Defines unary operator +.
Explicit Vector to Point Conversion | Converts the given Vector to an integer Point with truncation.
Explicit Vector to Size Conversion | Converts the given Vector to an integer Size with truncation.
Implicit Vector to SizeF Conversion | Converts the given Vector to a SizeF
Implicit Point to Vector Conversion | Converts the given integer Point to a Vector
Implicit Size to Vector Conversion | Converts the given integer Size to a Vector
Implicit SizeF to Vector Conversion | Converts the given SizeF to a Vector

Public Instance Constructors

Vector Overloaded. Initializes a new instance of the Vector class.

Public Instance Properties

Height | Gets or sets the "height" duplicates the Y-value.
IsEmpty | Returns true if this is a "null"-vector.
Item | Gets or sets vector coord in specified direction.
Lenght | Gets vector lenght.
Rotation | Gets vector rotation.
Width | Gets or sets the "width" duplicates the X-value.
X | Gets or sets X-component of the vector
Y | Gets or sets Y-component of the vector.

Public Instance Methods

Abs | Returns the modulus of the vector
Equals | Determines whether two Vector instances are equal.
GetHashCode | Serves as a hash function for Vector, suitable for use in hashing algorithms and data structures like a hash table.
GetSecondaryValue | Gets secondary direction coord.
GetType (inherited from Object) | Gets the Type of the current instance.
Quant | Snaps the vector to a grid with the specifed cell size.
QuantX | Snaps the X-component to a grid with the specified x-size of a cell
QuantY | Snaps the Y-component to a grid with the specified y-size of a cell
ToString | Returns a String that represents the current Vector object.
Truncate | Truncates the current Vector object to an integer Point.
TruncateSize | Truncates the current Vector object to an integer Size.

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Constructor

Constructs a vector using the specified coordinate values.

Overload List

Constructs a vector for the specified dicrection and coords.

public Vector(Direction,decimal,decimal);

Constructs a vector for the specified dicrection and point.

public Vector(Direction,Point);

Constructs a vector using the specified coordinate values.

public Vector(decimal,decimal);

Constructs a vector for the point that is specified as a pair of integer coordinates.

public Vector(Point);

Constructs a vector for the specified integer size.

public Vector(Size);

Constructs a vector for the specified size.

public Vector(SizeF);

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Constructor (Decimal, Decimal)

Constructs a vector using the specified coordinate values.

[Visual Basic]
Overloads Public Sub New( _
ByVal x As Decimal, _
ByVal y As Decimal _
)
[C#]
public Vector(
decimal x,
decimal y
);

Parameters

x
y

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | Vector Constructor Overload List


Vector Constructor (Point)

Constructs a vector for the point that is specified as a pair of integer coordinates.

[Visual Basic]
Overloads Public Sub New( _
ByVal point As Point _
)
[C#]
public Vector(
Point point
);

Parameters

point

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | Vector Constructor Overload List


Vector Constructor (Size)

Constructs a vector for the specified integer size.

[Visual Basic]
Overloads Public Sub New( _
ByVal size As Size _
)
[C#]
public Vector(
Size size
);

Parameters

size

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | Vector Constructor Overload List


Vector Constructor (SizeF)

Constructs a vector for the specified size.

[Visual Basic]
Overloads Public Sub New( _
ByVal size As SizeF _
)
[C#]
public Vector(
SizeF size
);

Parameters

size

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | Vector Constructor Overload List


Vector Constructor (Direction, Decimal, Decimal)

Constructs a vector for the specified dicrection and coords.

[Visual Basic]
Overloads Public Sub New( _
ByVal direction As Direction, _
ByVal primary As Decimal, _
ByVal secodary As Decimal _
)
[C#]
public Vector(
Direction direction,
decimal primary,
decimal secodary
);

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | Vector Constructor Overload List


Vector Constructor (Direction, Point)

Constructs a vector for the specified dicrection and point.

[Visual Basic]
Overloads Public Sub New( _
ByVal direction As Direction, _
ByVal point As Point _
)
[C#]
public Vector(
Direction direction,
Point point
);

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | Vector Constructor Overload List


Vector Fields

The fields of the Vector structure are listed below. For a complete list of Vector structure members, see the Vector Members topic.

Public Static (Shared) Fields

Empty Defines a "null"-vector.

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.Empty Field

Defines a "null"-vector.

[Visual Basic]
Public Shared ReadOnly Empty As Vector
[C#]
public static readonly Vector Empty;

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Properties

The properties of the Vector structure are listed below. For a complete list of Vector structure members, see the Vector Members topic.

Public Instance Properties

Height | Gets or sets the "height" duplicates the Y-value.
IsEmpty | Returns true if this is a "null"-vector.
Item | Gets or sets vector coord in specified direction.
Lenght | Gets vector lenght.
Rotation | Gets vector rotation.
Width | Gets or sets the "width" duplicates the X-value.
X | Gets or sets X-component of the vector
Y | Gets or sets Y-component of the vector.

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Height Property

Instrumentation Widgets for PDA

Vector.Height Property

Gets or sets the "height" duplicates the Y-value.

[Visual Basic]
Public Property Height As Decimal
[C#]
public decimal Height {get; set;}

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


IsEmpty Property

Instrumentation Widgets for PDA

Vector.IsEmpty Property

Returns true if this is a "null"-vector.

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Item Property

Instrumentation Widgets for PDA

Vector.Item Property

Gets or sets vector coord in specified direction.

[Visual Basic]
Public Default Property Item( _
ByVal direction As Direction _
) As Decimal
[C#]
public decimal this[
PerpetuumSoft.InstrumentationPDA.Mathematics.Direction direction
] {get; set;}

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Lenght Property

Instrumentation Widgets for PDA

Vector.Lenght Property

Gets vector lenght.

[Visual Basic]
Public Property Lenght As Decimal
[C#]
public decimal Lenght {get; set;}

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Rotation Property

Instrumentation Widgets for PDA

Vector.Rotation Property

Gets vector rotation.

[Visual Basic]
Public Property Rotation As Decimal
[C#]
public decimal Rotation {get; set;}

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Width Property

Instrumentation Widgets for PDA

Vector.Width Property

Gets or sets the "width" duplicates the X-value.

[Visual Basic]
Public Property Width As Decimal
[C#]
public decimal Width {get; set;}

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


X Property

Instrumentation Widgets for PDA

Vector.X Property

Gets or sets X-component of the vector

[Visual Basic]
Public Property X As Decimal
[C#]
public decimal X {get; set;}

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Y Property

Instrumentation Widgets for PDA

Vector.Y Property

Gets or sets Y-component of the vector.

[Visual Basic]
Public Property Y As Decimal
[C#]
public decimal Y {get; set;}

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Methods

The methods of the Vector structure are listed below. For a complete list of Vector structure members, see the Vector Members topic.

Public Static (Shared) Methods

FromPolar Converts plar coords to Vector.

Public Instance Methods

Abs | Returns the modulus of the vector
Equals | Determines whether two Vector instances are equal.
GetHashCode | Serves as a hash function for Vector, suitable for use in hashing algorithms and data structures like a hash table.
GetSecondaryValue | Gets secondary direction coord.
GetType (inherited from Object) | Gets the Type of the current instance.
Quant | Snaps the vector to a grid with the specifed cell size.
QuantX | Snaps the X-component to a grid with the specified x-size of a cell
QuantY | Snaps the Y-component to a grid with the specified y-size of a cell
ToString | Returns a String that represents the current Vector object.
Truncate | Truncates the current Vector object to an integer Point.
TruncateSize | Truncates the current Vector object to an integer Size.

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.Abs Method

Returns the modulus of the vector

[Visual Basic]
Public Function Abs() As Decimal
[C#]
public decimal Abs();

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.Equals Method

Determines whether two Vector instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal o As Object _
) As Boolean
[C#]
public override bool Equals(
object o
);

Parameters

o

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.FromPolar Method

Converts plar coords to Vector.

[Visual Basic]
Public Shared Function FromPolar( _
ByVal Lenght As Decimal, _
ByVal angle As Decimal _
) As Vector
[C#]
public static Vector FromPolar(
decimal Lenght,
decimal angle
);

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.GetHashCode Method

Serves as a hash function for Vector, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.GetSecondaryValue Method

Gets secondary direction coord.

[Visual Basic]
Public Function GetSecondaryValue( _
ByVal direction As Direction _
) As Decimal
[C#]
public decimal GetSecondaryValue(
Direction direction
);

Parameters

direction

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.Quant Method

Snaps the vector to a grid with the specifed cell size.

[Visual Basic]
Public Function Quant( _
ByVal xGrid As Decimal, _
ByVal yGrid As Decimal _
) As Vector
[C#]
public Vector Quant(
decimal xGrid,
decimal yGrid
);

Parameters

xGrid
yGrid

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.QuantX Method

Snaps the X-component to a grid with the specified x-size of a cell

[Visual Basic]
Public Function QuantX( _
ByVal xGrid As Decimal _
) As Vector
[C#]
public Vector QuantX(
decimal xGrid
);

Parameters

xGrid

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.QuantY Method

Snaps the Y-component to a grid with the specified y-size of a cell

[Visual Basic]
Public Function QuantY( _
ByVal yGrid As Decimal _
) As Vector
[C#]
public Vector QuantY(
decimal yGrid
);

Parameters

yGrid

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.ToString Method

Returns a String that represents the current Vector object.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.Truncate Method

Truncates the current Vector object to an integer Point.

[Visual Basic]
Public Function Truncate() As Point
[C#]
public Point Truncate();

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector.TruncateSize Method

Truncates the current Vector object to an integer Size.

[Visual Basic]
Public Function TruncateSize() As Size
[C#]
public Size TruncateSize();

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Operators and Type Conversions

The operators and type conversions of the Vector structure are listed below. For a complete list of Vector structure members, see the Vector Members topic.

Public Static (Shared) Operators and Type Conversions

Addition Operator | Implements addition of the two given vectors.
Division Operator | Implements division of the given vector by the specified scalar value.
Equality Operator | Returns true if two given vectors are identical.
Inequality Operator | Returns true if two given vectors are not identical.
Multiplication Operator | Overloaded. Implements multiplication of the two given vectors.
Subtraction Operator | Implements subtraction of the two given vectors.
Unary Negation Operator | Defines unary operator -.
Unary Plus Operator | Defines unary operator +.
Explicit Vector to Point Conversion | Converts the given Vector to an integer Point with truncation.
Explicit Vector to Size Conversion | Converts the given Vector to an integer Size with truncation.
Implicit Vector to SizeF Conversion | Converts the given Vector to a SizeF
Implicit Point to Vector Conversion | Converts the given integer Point to a Vector
Implicit Size to Vector Conversion | Converts the given integer Size to a Vector
Implicit SizeF to Vector Conversion | Converts the given SizeF to a Vector

See Also

Vector Class | Vector Members | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Addition Operator

Implements addition of the two given vectors.

[Visual Basic]
returnValue = Vector.op_Addition(a, b)
[C#]
public static Vector operator +(
Vector a,
Vector b
);

Parameters

a
b

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Division Operator

Implements division of the given vector by the specified scalar value.

[Visual Basic]
returnValue = Vector.op_Division(v, a)
[C#]
public static Vector operator /(
Vector v,
decimal a
);

Parameters

v
a

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Equality Operator

Returns true if two given vectors are identical.

[Visual Basic]
returnValue = Vector.op_Equality(v1, v2)
[C#]
public static bool operator ==(
Vector v1,
Vector v2
);

Parameters

v1
v2

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Inequality Operator

Returns true if two given vectors are not identical.

[Visual Basic]
returnValue = Vector.op_Inequality(v1, v2)
[C#]
public static bool operator !=(
Vector v1,
Vector v2
);

Parameters

v1
v2

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Multiplication Operator

Implements multiplication of the two given vectors.

Overload List

Implements multiplication of the two given vectors.

public static Vector Multiplication Operator(Vector,Vector);

Implements multiplication of the given vector by the specified scalar value.

public static Vector Multiplication Operator(Vector,decimal);

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Multiplication Operator

Implements multiplication of the two given vectors.

[Visual Basic]
returnValue = Vector.op_Multiply(a, b)
[C#]
public static Vector operator *(
Vector a,
Vector b
);

Parameters

a
b

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | VectorMultiplication Operator Overload List


Vector Multiplication Operator

Implements multiplication of the given vector by the specified scalar value.

[Visual Basic]
returnValue = Vector.op_Multiply(v, a)
[C#]
public static Vector operator *(
Vector v,
decimal a
);

Parameters

v
a

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | VectorMultiplication Operator Overload List


Vector Subtraction Operator

Implements subtraction of the two given vectors.

[Visual Basic]
returnValue = Vector.op_Subtraction(a, b)
[C#]
public static Vector operator -(
Vector a,
Vector b
);

Parameters

a
b

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Unary Negation Operator

Defines unary operator -.

[Visual Basic]
returnValue = Vector.op_UnaryNegation(v)
[C#]
public static Vector operator -(
Vector v
);

Parameters

v

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Unary Plus Operator

Defines unary operator +.

[Visual Basic]
returnValue = Vector.op_UnaryPlus(v)
[C#]
public static Vector operator +(
Vector v
);

Parameters

v

Return Value

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Explicit Vector to Point Conversion

Converts the given Vector to an integer Point with truncation.

[Visual Basic]
returnValue = Vector.op_Explicit(vector)
[C#]
public static explicit operator Point(
Vector vector
);

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Explicit Vector to Size Conversion

Converts the given Vector to an integer Size with truncation.

[Visual Basic]
returnValue = Vector.op_Explicit(vector)
[C#]
public static explicit operator Size(
Vector vector
);

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Implicit Vector to SizeF Conversion

Converts the given Vector to a SizeF

[Visual Basic]
returnValue = Vector.op_Implicit(vector)
[C#]
public static implicit operator SizeF(
Vector vector
);

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Implicit Point to Vector Conversion

Converts the given integer Point to a Vector

[Visual Basic]
returnValue = Vector.op_Implicit(point)
[C#]
public static implicit operator Vector(
Point point
);

Parameters

point

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Implicit Size to Vector Conversion

Converts the given integer Size to a Vector

[Visual Basic]
returnValue = Vector.op_Implicit(size)
[C#]
public static implicit operator Vector(
Size size
);

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Vector Implicit SizeF to Vector Conversion

Converts the given SizeF to a Vector

[Visual Basic]
returnValue = Vector.op_Implicit(size)
[C#]
public static implicit operator Vector(
SizeF size
);

See Also

Vector Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Structure

Defines location and size of a rectangle on a surface.

For a list of all members of this type, see VectorRectangle Members.

System.Object
System.ValueType
PerpetuumSoft.InstrumentationPDA.Mathematics.VectorRectangle

[Visual Basic]
Public Structure VectorRectangle
[C#]
public struct VectorRectangle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This structure is similar to the .NET Framework structure RectangleF, however, it offers a set of additional methods and properties facilitating the work with shapes on a plane.

Requirements

Namespace: PerpetuumSoft.InstrumentationPDA.Mathematics

Assembly: PerpetuumSoft.InstrumentationPDA (in PerpetuumSoft.InstrumentationPDA.dll)

See Also

VectorRectangle Members | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Members

VectorRectangle overview

Public Static (Shared) Operators and Type Conversions

Equality Operator | Equality operator for the two specified VectorRectangle instances.
Inequality Operator | Non-equality operator for the two specified VectorRectangle instances.
Explicit VectorRectangle to Rectangle Conversion | Converts the specified VectorRectangle to an integer Rectangle with truncation.
Implicit VectorRectangle to RectangleF Conversion | Converts the specified VectorRectangle to a RectangleF
Implicit Rectangle to VectorRectangle Conversion | Converts the specified Rectangle to a VectorRectangle
Implicit RectangleF to VectorRectangle Conversion | Converts the specified RectangleF to a VectorRectangle

Public Instance Constructors

VectorRectangle Overloaded. Initializes a new instance of the VectorRectangle class.

Public Instance Properties

Bottom | Gets Y coordinate of the bottom side of the rectangle.
BottomCenter | Gets location of the center of the bottom side of the rectangle.
BottomLeft | Gets location of the bottom left corner of the rectangle.
BottomRight | Gets location of the bottom right corner of the rectangle.
Center | Gets location of the center of the rectangle.
CenterX | Gets X coordinate of the center of the rectangle.
CenterY | Gets Y coordinate of the center of the rectangle.
Height | Gets or sets height of the rectangle.
IsEmpty | Gets if width and height of the current VectorRectangle are zeros.
Left | Gets X coordinate of the left side of the rectangle.
LeftCenter | Gets location of the center of the left side of the rectangle.
Location | Gets or sets location of the rectangle (the top left corner).
Right | Gets X coordinate of the right side of the rectangle.
RightCenter | Gets location of the center of the right side of the rectangle.
Size | Gets or sets size of the rectangle.
Top | Gets Y coordinate of the top side of the rectangle.
TopCenter | Gets location of the center of the top side of the rectangle.
TopLeft | Gets location of the top left corner of the rectangle.
TopRight | Gets location of the top right corner of the rectangle.
Width | Gets or sets width of the rectangle
X | Gets or sets X coordinate of the top left corner of the rectangle
Y | Gets or sets Y coordinate of the top left corner of the rectangle

Public Instance Methods

Area | Returns the area of the current VectorRectangle object.
Contains | Returns whether the current VectorRectangle contains the specified point.
Equals | Determines whether two VectorRectangle instances are equal.
GetHashCode | Serves as a hash function for VectorRectangle, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PositiveRectangle | Returns a new VectorRectangle instance with the geometry identical to the current instance and with positive width and height values.
Quant | Aligns the current VectorRectangle instance using the specified grid steps.
QuantX | Aligns the current VectorRectangle instance horizontally using the specified grid x-step.
QuantY | Aligns the current VectorRectangle instance vertically using the specified grid y-step.
Round | Rounds rectangle coords.
ToString | Returns a String that represents the current VectorRectangle object.
Truncate | Truncates the current instance of VectorRectangle to integer Rectangle.

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Constructor

Creates a new VectorRectangle instance given the top left coordinates, width, and height.

Overload List

Creates a new VectorRectangle instance given the top left location and size.

public VectorRectangle(Vector,Vector);

Creates a new VectorRectangle instance given the top left coordinates, width, and height.

public VectorRectangle(decimal,decimal,decimal,decimal);

Creates a new VectorRectangle instance given an exisitng instance of Rectangle.

public VectorRectangle(Rectangle);

Creates a new VectorRectangle instance given an exisitng instance of RectangleF.

public VectorRectangle(RectangleF);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Constructor (Decimal, Decimal, Decimal, Decimal)

Creates a new VectorRectangle instance given the top left coordinates, width, and height.

[Visual Basic]
Overloads Public Sub New( _
ByVal x As Decimal, _
ByVal y As Decimal, _
ByVal width As Decimal, _
ByVal height As Decimal _
)
[C#]
public VectorRectangle(
decimal x,
decimal y,
decimal width,
decimal height
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | VectorRectangle Constructor Overload List


VectorRectangle Constructor (Vector, Vector)

Creates a new VectorRectangle instance given the top left location and size.

[Visual Basic]
Overloads Public Sub New( _
ByVal location As Vector, _
ByVal size As Vector _
)
[C#]
public VectorRectangle(
Vector location,
Vector size
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | VectorRectangle Constructor Overload List


VectorRectangle Constructor (Rectangle)

Creates a new VectorRectangle instance given an exisitng instance of Rectangle.

[Visual Basic]
Overloads Public Sub New( _
ByVal rect As Rectangle _
)
[C#]
public VectorRectangle(
Rectangle rect
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | VectorRectangle Constructor Overload List


VectorRectangle Constructor (RectangleF)

Creates a new VectorRectangle instance given an exisitng instance of RectangleF.

[Visual Basic]
Overloads Public Sub New( _
ByVal rect As RectangleF _
)
[C#]
public VectorRectangle(
RectangleF rect
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace | VectorRectangle Constructor Overload List


VectorRectangle Properties

The properties of the VectorRectangle structure are listed below. For a complete list of VectorRectangle structure members, see the VectorRectangle Members topic.

Public Instance Properties

Bottom | Gets Y coordinate of the bottom side of the rectangle.
BottomCenter | Gets location of the center of the bottom side of the rectangle.
BottomLeft | Gets location of the bottom left corner of the rectangle.
BottomRight | Gets location of the bottom right corner of the rectangle.
Center | Gets location of the center of the rectangle.
CenterX | Gets X coordinate of the center of the rectangle.
CenterY | Gets Y coordinate of the center of the rectangle.
Height | Gets or sets height of the rectangle.
IsEmpty | Gets if width and height of the current VectorRectangle are zeros.
Left | Gets X coordinate of the left side of the rectangle.
LeftCenter | Gets location of the center of the left side of the rectangle.
Location | Gets or sets location of the rectangle (the top left corner).
Right | Gets X coordinate of the right side of the rectangle.
RightCenter | Gets location of the center of the right side of the rectangle.
Size | Gets or sets size of the rectangle.
Top | Gets Y coordinate of the top side of the rectangle.
TopCenter | Gets location of the center of the top side of the rectangle.
TopLeft | Gets location of the top left corner of the rectangle.
TopRight | Gets location of the top right corner of the rectangle.
Width | Gets or sets width of the rectangle
X | Gets or sets X coordinate of the top left corner of the rectangle
Y | Gets or sets Y coordinate of the top left corner of the rectangle

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Bottom Property

Instrumentation Widgets for PDA

VectorRectangle.Bottom Property

Gets Y coordinate of the bottom side of the rectangle.

[Visual Basic]
Public ReadOnly Property Bottom As Decimal
[C#]
public decimal Bottom {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


BottomCenter Property

Instrumentation Widgets for PDA

VectorRectangle.BottomCenter Property

Gets location of the center of the bottom side of the rectangle.

[Visual Basic]
Public ReadOnly Property BottomCenter As Vector
[C#]
public Vector BottomCenter {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


BottomLeft Property

Instrumentation Widgets for PDA

VectorRectangle.BottomLeft Property

Gets location of the bottom left corner of the rectangle.

[Visual Basic]
Public ReadOnly Property BottomLeft As Vector
[C#]
public Vector BottomLeft {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


BottomRight Property

Instrumentation Widgets for PDA

VectorRectangle.BottomRight Property

Gets location of the bottom right corner of the rectangle.

[Visual Basic]
Public ReadOnly Property BottomRight As Vector
[C#]
public Vector BottomRight {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Center Property

Instrumentation Widgets for PDA

VectorRectangle.Center Property

Gets location of the center of the rectangle.

[Visual Basic]
Public ReadOnly Property Center As Vector
[C#]
public Vector Center {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


CenterX Property

Instrumentation Widgets for PDA

VectorRectangle.CenterX Property

Gets X coordinate of the center of the rectangle.

[Visual Basic]
Public ReadOnly Property CenterX As Decimal
[C#]
public decimal CenterX {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


CenterY Property

Instrumentation Widgets for PDA

VectorRectangle.CenterY Property

Gets Y coordinate of the center of the rectangle.

[Visual Basic]
Public ReadOnly Property CenterY As Decimal
[C#]
public decimal CenterY {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Height Property

Instrumentation Widgets for PDA

VectorRectangle.Height Property

Gets or sets height of the rectangle.

[Visual Basic]
Public Property Height As Decimal
[C#]
public decimal Height {get; set;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


IsEmpty Property

Instrumentation Widgets for PDA

VectorRectangle.IsEmpty Property

Gets if width and height of the current VectorRectangle are zeros.

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Left Property

Instrumentation Widgets for PDA

VectorRectangle.Left Property

Gets X coordinate of the left side of the rectangle.

[Visual Basic]
Public ReadOnly Property Left As Decimal
[C#]
public decimal Left {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


LeftCenter Property

Instrumentation Widgets for PDA

VectorRectangle.LeftCenter Property

Gets location of the center of the left side of the rectangle.

[Visual Basic]
Public ReadOnly Property LeftCenter As Vector
[C#]
public Vector LeftCenter {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Location Property

Instrumentation Widgets for PDA

VectorRectangle.Location Property

Gets or sets location of the rectangle (the top left corner).

[Visual Basic]
Public Property Location As Vector
[C#]
public Vector Location {get; set;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Right Property

Instrumentation Widgets for PDA

VectorRectangle.Right Property

Gets X coordinate of the right side of the rectangle.

[Visual Basic]
Public ReadOnly Property Right As Decimal
[C#]
public decimal Right {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


RightCenter Property

Instrumentation Widgets for PDA

VectorRectangle.RightCenter Property

Gets location of the center of the right side of the rectangle.

[Visual Basic]
Public ReadOnly Property RightCenter As Vector
[C#]
public Vector RightCenter {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Size Property

Instrumentation Widgets for PDA

VectorRectangle.Size Property

Gets or sets size of the rectangle.

[Visual Basic]
Public Property Size As Vector
[C#]
public Vector Size {get; set;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Top Property

Instrumentation Widgets for PDA

VectorRectangle.Top Property

Gets Y coordinate of the top side of the rectangle.

[Visual Basic]
Public ReadOnly Property Top As Decimal
[C#]
public decimal Top {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


TopCenter Property

Instrumentation Widgets for PDA

VectorRectangle.TopCenter Property

Gets location of the center of the top side of the rectangle.

[Visual Basic]
Public ReadOnly Property TopCenter As Vector
[C#]
public Vector TopCenter {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


TopLeft Property

Instrumentation Widgets for PDA

VectorRectangle.TopLeft Property

Gets location of the top left corner of the rectangle.

[Visual Basic]
Public ReadOnly Property TopLeft As Vector
[C#]
public Vector TopLeft {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


TopRight Property

Instrumentation Widgets for PDA

VectorRectangle.TopRight Property

Gets location of the top right corner of the rectangle.

[Visual Basic]
Public ReadOnly Property TopRight As Vector
[C#]
public Vector TopRight {get;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Width Property

Instrumentation Widgets for PDA

VectorRectangle.Width Property

Gets or sets width of the rectangle

[Visual Basic]
Public Property Width As Decimal
[C#]
public decimal Width {get; set;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


X Property

Instrumentation Widgets for PDA

VectorRectangle.X Property

Gets or sets X coordinate of the top left corner of the rectangle

[Visual Basic]
Public Property X As Decimal
[C#]
public decimal X {get; set;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


Y Property

Instrumentation Widgets for PDA

VectorRectangle.Y Property

Gets or sets Y coordinate of the top left corner of the rectangle

[Visual Basic]
Public Property Y As Decimal
[C#]
public decimal Y {get; set;}

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Methods

The methods of the VectorRectangle structure are listed below. For a complete list of VectorRectangle structure members, see the VectorRectangle Members topic.

Public Instance Methods

Area | Returns the area of the current VectorRectangle object.
Contains | Returns whether the current VectorRectangle contains the specified point.
Equals | Determines whether two VectorRectangle instances are equal.
GetHashCode | Serves as a hash function for VectorRectangle, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PositiveRectangle | Returns a new VectorRectangle instance with the geometry identical to the current instance and with positive width and height values.
Quant | Aligns the current VectorRectangle instance using the specified grid steps.
QuantX | Aligns the current VectorRectangle instance horizontally using the specified grid x-step.
QuantY | Aligns the current VectorRectangle instance vertically using the specified grid y-step.
Round | Rounds rectangle coords.
ToString | Returns a String that represents the current VectorRectangle object.
Truncate | Truncates the current instance of VectorRectangle to integer Rectangle.

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.Area Method

Returns the area of the current VectorRectangle object.

[Visual Basic]
Public Function Area() As Decimal
[C#]
public decimal Area();

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.Contains Method

Returns whether the current VectorRectangle contains the specified point.

[Visual Basic]
Public Function Contains( _
ByVal v As Vector _
) As Boolean
[C#]
public bool Contains(
Vector v
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.Equals Method

Determines whether two VectorRectangle instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
ByVal o As Object _
) As Boolean
[C#]
public override bool Equals(
object o
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.GetHashCode Method

Serves as a hash function for VectorRectangle, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.PositiveRectangle Method

Returns a new VectorRectangle instance with the geometry identical to the current instance and with positive width and height values.

[Visual Basic]
Public Function PositiveRectangle() As VectorRectangle
[C#]
public VectorRectangle PositiveRectangle();

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.Quant Method

Aligns the current VectorRectangle instance using the specified grid steps.

[Visual Basic]
Public Function Quant( _
ByVal xGrid As Decimal, _
ByVal yGrid As Decimal _
) As VectorRectangle
[C#]
public VectorRectangle Quant(
decimal xGrid,
decimal yGrid
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.QuantX Method

Aligns the current VectorRectangle instance horizontally using the specified grid x-step.

[Visual Basic]
Public Function QuantX( _
ByVal xGrid As Decimal _
) As VectorRectangle
[C#]
public VectorRectangle QuantX(
decimal xGrid
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.QuantY Method

Aligns the current VectorRectangle instance vertically using the specified grid y-step.

[Visual Basic]
Public Function QuantY( _
ByVal yGrid As Decimal _
) As VectorRectangle
[C#]
public VectorRectangle QuantY(
decimal yGrid
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.Round Method

Rounds rectangle coords.

[Visual Basic]
Public Function Round() As Rectangle
[C#]
public Rectangle Round();

Return Value

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.ToString Method

Returns a String that represents the current VectorRectangle object.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle.Truncate Method

Truncates the current instance of VectorRectangle to integer Rectangle.

[Visual Basic]
Public Function Truncate() As Rectangle
[C#]
public Rectangle Truncate();

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Operators and Type Conversions

The operators and type conversions of the VectorRectangle structure are listed below. For a complete list of VectorRectangle structure members, see the VectorRectangle Members topic.

Public Static (Shared) Operators and Type Conversions

Equality Operator | Equality operator for the two specified VectorRectangle instances.
Inequality Operator | Non-equality operator for the two specified VectorRectangle instances.
Explicit VectorRectangle to Rectangle Conversion | Converts the specified VectorRectangle to an integer Rectangle with truncation.
Implicit VectorRectangle to RectangleF Conversion | Converts the specified VectorRectangle to a RectangleF
Implicit Rectangle to VectorRectangle Conversion | Converts the specified Rectangle to a VectorRectangle
Implicit RectangleF to VectorRectangle Conversion | Converts the specified RectangleF to a VectorRectangle

See Also

VectorRectangle Class | VectorRectangle Members | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Equality Operator

Equality operator for the two specified VectorRectangle instances.

[Visual Basic]
returnValue = VectorRectangle.op_Equality(v1, v2)
[C#]
public static bool operator ==(
VectorRectangle v1,
VectorRectangle v2
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Inequality Operator

Non-equality operator for the two specified VectorRectangle instances.

[Visual Basic]
returnValue = VectorRectangle.op_Inequality(v1, v2)
[C#]
public static bool operator !=(
VectorRectangle v1,
VectorRectangle v2
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Explicit VectorRectangle to Rectangle Conversion

Converts the specified VectorRectangle to an integer Rectangle with truncation.

[Visual Basic]
returnValue = VectorRectangle.op_Explicit(rect)
[C#]
public static explicit operator Rectangle(
VectorRectangle rect
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Implicit VectorRectangle to RectangleF Conversion

Converts the specified VectorRectangle to a RectangleF

[Visual Basic]
returnValue = VectorRectangle.op_Implicit(rect)
[C#]
public static implicit operator RectangleF(
VectorRectangle rect
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Implicit Rectangle to VectorRectangle Conversion

Converts the specified Rectangle to a VectorRectangle

[Visual Basic]
returnValue = VectorRectangle.op_Implicit(rect)
[C#]
public static implicit operator VectorRectangle(
Rectangle rect
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


VectorRectangle Implicit RectangleF to VectorRectangle Conversion

Converts the specified RectangleF to a VectorRectangle

[Visual Basic]
returnValue = VectorRectangle.op_Implicit(rect)
[C#]
public static implicit operator VectorRectangle(
RectangleF rect
);

See Also

VectorRectangle Class | PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


PerpetuumSoft.InstrumentationPDA.MathematicsHierarchy

Instrumentation Widgets for PDA

PerpetuumSoft.InstrumentationPDA.Mathematics Hierarchy

System.Object
PerpetuumSoft.InstrumentationPDA.Mathematics.Math2
System.ValueType
PerpetuumSoft.InstrumentationPDA.Mathematics.Vector
PerpetuumSoft.InstrumentationPDA.Mathematics.VectorRectangle
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
PerpetuumSoft.InstrumentationPDA.Mathematics.Direction

See Also

PerpetuumSoft.InstrumentationPDA.Mathematics Namespace


PerpetuumSoft.InstrumentationPDAHierarchy

Instrumentation Widgets for PDA

PerpetuumSoft.InstrumentationPDA Hierarchy

System.Object
PerpetuumSoft.InstrumentationPDA.Bevel
PerpetuumSoft.InstrumentationPDA.ColorSection
PerpetuumSoft.InstrumentationPDA.DigitsDisplay
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IWin32Window
PerpetuumSoft.InstrumentationPDA.Widget
PerpetuumSoft.InstrumentationPDA.DigitalLED
PerpetuumSoft.InstrumentationPDA.SwitchBase
PerpetuumSoft.InstrumentationPDA.Switch
PerpetuumSoft.InstrumentationPDA.Toggle
PerpetuumSoft.InstrumentationPDA.ValuePresenter
PerpetuumSoft.InstrumentationPDA.CircularControlBase
PerpetuumSoft.InstrumentationPDA.CircularControl
PerpetuumSoft.InstrumentationPDA.Dial
PerpetuumSoft.InstrumentationPDA.Meter
PerpetuumSoft.InstrumentationPDA.LinearControl
PerpetuumSoft.InstrumentationPDA.Level
PerpetuumSoft.InstrumentationPDA.Slider
PerpetuumSoft.InstrumentationPDA.Thermometer
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
PerpetuumSoft.InstrumentationPDA.BevelStyle
PerpetuumSoft.InstrumentationPDA.FaceStyle
PerpetuumSoft.InstrumentationPDA.ImagePosition
PerpetuumSoft.InstrumentationPDA.Orientation
PerpetuumSoft.InstrumentationPDA.PointerType
PerpetuumSoft.InstrumentationPDA.SliderElementsPosition

See Also

PerpetuumSoft.InstrumentationPDA Namespace