PerpetuumSoft.DataModel Namespace

[image]

SQL Schema Sync API Class reference
PerpetuumSoft.DataModel Namespace
Send Feedback
Namespace PerpetuumSoft.DataModel contains the DatabaseSync component and additional classes to manage this component

Classes

Class | Description
AbortUpdateException | Represents exception appearing if the user aborts synchronization.
DatabaseSync | Performs database updates and comparisions.
DatabaseSyncOptions | Represents options of databases synchronization.
DatabaseUpdatingEventArgs | Represents parameters of the DatabaseUpdating event.
FunctionRequareEventArgs | Represents arguments of the FunctionRequire event.
ProgressEventArgs | Represents the Progress event arguments.
ScriptExecuteEventArgs | Represents ScriptExecuted event arguments.
SkipSynchronizingEventArgs | Represents arguments for the SkipSynchronizing event.

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


AbortUpdateException Class

[image]

SQL Schema Sync API Class reference
AbortUpdateException Class
Members See Also Send Feedback
Represents exception appearing if the user aborts synchronization.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class AbortUpdateException : Exception
Visual Basic (Declaration)
Public Class AbortUpdateException _
    Inherits Exception
Visual C++
public ref class AbortUpdateException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.DataModel..::.AbortUpdateException

See Also

AbortUpdateException Members
PerpetuumSoft.DataModel Namespace


AbortUpdateException Members

[image] [image]

SQL Schema Sync API Class reference
AbortUpdateException Members
AbortUpdateException Class Constructors Methods Properties See Also Send Feedback

The AbortUpdateException type exposes the following members.

Constructors

Name | Description
AbortUpdateException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AbortUpdateException Class
PerpetuumSoft.DataModel Namespace


AbortUpdateException Constructor

[image] [image]

SQL Schema Sync API Class reference
AbortUpdateException Constructor
AbortUpdateException Class See Also Send Feedback

Overload List

Name | Description
AbortUpdateException()()() | Initializes a new instance of the AbortUpdateException class.
AbortUpdateException(String) | Initializes a new instance of the AbortUpdateException class.
AbortUpdateException(String, Exception) | Initializes a new instance of the AbortUpdateException class.

See Also

AbortUpdateException Class
AbortUpdateException Members
PerpetuumSoft.DataModel Namespace


AbortUpdateException Constructor

[image]

SQL Schema Sync API Class reference
AbortUpdateException Constructor
AbortUpdateException Class See Also Send Feedback
Initializes a new instance of the AbortUpdateException class.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public AbortUpdateException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AbortUpdateException()

See Also

AbortUpdateException Class
AbortUpdateException Overload
PerpetuumSoft.DataModel Namespace


AbortUpdateException Constructor (String)

[image]

SQL Schema Sync API Class reference
AbortUpdateException Constructor (String)
AbortUpdateException Class See Also Send Feedback
Initializes a new instance of the AbortUpdateException class.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public AbortUpdateException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
AbortUpdateException(
    String^ message
)

Parameters

message
Type: System..::.String

See Also

AbortUpdateException Class
AbortUpdateException Overload
PerpetuumSoft.DataModel Namespace


AbortUpdateException Constructor (String, Exception)

[image]

SQL Schema Sync API Class reference
AbortUpdateException Constructor (String, Exception)
AbortUpdateException Class See Also Send Feedback
Initializes a new instance of the AbortUpdateException class.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public AbortUpdateException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
AbortUpdateException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
innerException
Type: System..::.Exception

See Also

AbortUpdateException Class
AbortUpdateException Overload
PerpetuumSoft.DataModel Namespace


AbortUpdateException Methods

[image] [image]

SQL Schema Sync API Class reference
AbortUpdateException Methods
AbortUpdateException Class See Also Send Feedback

The AbortUpdateException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AbortUpdateException Class
PerpetuumSoft.DataModel Namespace


AbortUpdateException Properties

[image] [image]

SQL Schema Sync API Class reference
AbortUpdateException Properties
AbortUpdateException Class See Also Send Feedback

The AbortUpdateException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AbortUpdateException Class
PerpetuumSoft.DataModel Namespace


DatabaseSync Class

[image]

SQL Schema Sync API Class reference
DatabaseSync Class
Members See Also Send Feedback
Performs database updates and comparisions.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class DatabaseSync : Component
Visual Basic (Declaration)
Public Class DatabaseSync _
    Inherits Component
Visual C++
public ref class DatabaseSync : public Component

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.DataModel..::.DatabaseSync

See Also

DatabaseSync Members
PerpetuumSoft.DataModel Namespace


DatabaseSync Members

[image] [image]

SQL Schema Sync API Class reference
DatabaseSync Members
DatabaseSync Class Constructors Methods Properties Events See Also Send Feedback

The DatabaseSync type exposes the following members.

Constructors

Name | Description
DatabaseSync | Overloaded.

Methods

Name | Description
Compare | Compares database structures.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
OnDatabaseUpdated | Raises the DatabaseUpdated event.
OnDatabaseUpdating | Raises the DatabaseUpdating event.
OnProgress | Raises the Progress event.
OnScriptExecuted | Raises the ScriptExecuted event.
OnScriptExecuting | Raises the ScriptExecuting event.
OnSkipSynchronizing | Raises the SkipSynchronizing event.
ReverseDatabase | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateDatabase | Overloaded.

Properties

Name | Description
About | Gets copyright string.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Options | Gets or sets the DatabaseSyncOptions option of databases synchronization.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
DatabaseUpdated | Occurs when database structure is changed.
DatabaseUpdating | Occurs when database structure starts changing.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
Progress | Occurs when progress information on the current operation changes.
ScriptExecuted | Occurs when script section synchronization is executed.
ScriptExecuting | Occurs before a script is executed.
SkipSynchronizing | Occurs during the scripts building. Used to skip separate objects synchronization.

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


DatabaseSync Constructor

[image] [image]

SQL Schema Sync API Class reference
DatabaseSync Constructor
DatabaseSync Class See Also Send Feedback

Overload List

Name | Description
DatabaseSync()()() | Initializes a new instance of the DatabaseSync class.
DatabaseSync(IContainer) | Initializes a new instance of the DatabaseSync class.

See Also

DatabaseSync Class
DatabaseSync Members
PerpetuumSoft.DataModel Namespace


DatabaseSync Constructor

[image]

SQL Schema Sync API Class reference
DatabaseSync Constructor
DatabaseSync Class See Also Send Feedback
Initializes a new instance of the DatabaseSync class.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseSync()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DatabaseSync()

See Also

DatabaseSync Class
DatabaseSync Overload
PerpetuumSoft.DataModel Namespace


DatabaseSync Constructor (IContainer)

[image]

SQL Schema Sync API Class reference
DatabaseSync Constructor (IContainer)
DatabaseSync Class See Also Send Feedback
Initializes a new instance of the DatabaseSync class.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseSync(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
DatabaseSync(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

DatabaseSync Class
DatabaseSync Overload
PerpetuumSoft.DataModel Namespace


DatabaseSync Methods

[image] [image]

SQL Schema Sync API Class reference
DatabaseSync Methods
DatabaseSync Class See Also Send Feedback

The DatabaseSync type exposes the following members.

Methods

Name | Description
Compare | Compares database structures.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
OnDatabaseUpdated | Raises the DatabaseUpdated event.
OnDatabaseUpdating | Raises the DatabaseUpdating event.
OnProgress | Raises the Progress event.
OnScriptExecuted | Raises the ScriptExecuted event.
OnScriptExecuting | Raises the ScriptExecuting event.
OnSkipSynchronizing | Raises the SkipSynchronizing event.
ReverseDatabase | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateDatabase | Overloaded.

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


Compare Method

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.Compare Method
DatabaseSync Class See Also Send Feedback
Compares database structures.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseSynchronizer Compare(
    Database sourceDatabase,
    Database targetDatabase
)
Visual Basic (Declaration)
Public Function Compare ( _
    sourceDatabase As Database, _
    targetDatabase As Database _
) As DatabaseSynchronizer
Visual C++
public:
DatabaseSynchronizer^ Compare(
    Database^ sourceDatabase,
    Database^ targetDatabase
)

Parameters

sourceDatabase
Type: PerpetuumSoft.DataModel.MsSql..::.Database
targetDatabase
Type: PerpetuumSoft.DataModel.MsSql..::.Database

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


Dispose Method

[image] [image]

SQL Schema Sync API Class reference
DatabaseSync..::.Dispose Method
DatabaseSync Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the captured resources. (Overrides Component..::.Dispose(Boolean).)

See Also

DatabaseSync Class
DatabaseSync Members
PerpetuumSoft.DataModel Namespace


Dispose Method (Boolean)

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.Dispose Method (Boolean)
DatabaseSync Class See Also Send Feedback
Releases the captured resources.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

DatabaseSync Class
Dispose Overload
PerpetuumSoft.DataModel Namespace


MemberwiseClone Method

[image] [image]

SQL Schema Sync API Class reference
DatabaseSync..::.MemberwiseClone Method
DatabaseSync Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DatabaseSync Class
DatabaseSync Members
PerpetuumSoft.DataModel Namespace


OnDatabaseUpdated Method

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.OnDatabaseUpdated Method
DatabaseSync Class See Also Send Feedback
Raises the DatabaseUpdated event.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void OnDatabaseUpdated(
    EventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnDatabaseUpdated ( _
    args As EventArgs _
)
Visual C++
protected:
virtual void OnDatabaseUpdated(
    EventArgs^ args
)

Parameters

args
Type: System..::.EventArgs

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


OnDatabaseUpdating Method

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.OnDatabaseUpdating Method
DatabaseSync Class See Also Send Feedback
Raises the DatabaseUpdating event.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void OnDatabaseUpdating(
    DatabaseUpdatingEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnDatabaseUpdating ( _
    args As DatabaseUpdatingEventArgs _
)
Visual C++
protected:
virtual void OnDatabaseUpdating(
    DatabaseUpdatingEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.DataModel..::.DatabaseUpdatingEventArgs

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


OnProgress Method

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.OnProgress Method
DatabaseSync Class See Also Send Feedback
Raises the Progress event.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void OnProgress(
    ProgressEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnProgress ( _
    args As ProgressEventArgs _
)
Visual C++
protected:
virtual void OnProgress(
    ProgressEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.DataModel..::.ProgressEventArgs

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


OnScriptExecuted Method

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.OnScriptExecuted Method
DatabaseSync Class See Also Send Feedback
Raises the ScriptExecuted event.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void OnScriptExecuted(
    ScriptExecuteEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnScriptExecuted ( _
    args As ScriptExecuteEventArgs _
)
Visual C++
protected:
virtual void OnScriptExecuted(
    ScriptExecuteEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.DataModel..::.ScriptExecuteEventArgs

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


OnScriptExecuting Method

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.OnScriptExecuting Method
DatabaseSync Class See Also Send Feedback
Raises the ScriptExecuting event.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void OnScriptExecuting(
    ScriptExecuteEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnScriptExecuting ( _
    args As ScriptExecuteEventArgs _
)
Visual C++
protected:
virtual void OnScriptExecuting(
    ScriptExecuteEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.DataModel..::.ScriptExecuteEventArgs

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


OnSkipSynchronizing Method

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.OnSkipSynchronizing Method
DatabaseSync Class See Also Send Feedback
Raises the SkipSynchronizing event.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void OnSkipSynchronizing(
    SkipSynchronizingEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnSkipSynchronizing ( _
    args As SkipSynchronizingEventArgs _
)
Visual C++
protected:
virtual void OnSkipSynchronizing(
    SkipSynchronizingEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.DataModel..::.SkipSynchronizingEventArgs

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


ReverseDatabase Method

[image] [image]

SQL Schema Sync API Class reference
DatabaseSync..::.ReverseDatabase Method
DatabaseSync Class See Also Send Feedback

Overload List

Name | Description
ReverseDatabase(String) | Returns the database structure in the form of object graph.
ReverseDatabase(SqlConnection, SqlTransaction) | Returns the database structure in the form of object graph.

See Also

DatabaseSync Class
DatabaseSync Members
PerpetuumSoft.DataModel Namespace


ReverseDatabase Method (String)

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.ReverseDatabase Method (String)
DatabaseSync Class See Also Send Feedback
Returns the database structure in the form of object graph.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Database ReverseDatabase(
    string connectionString
)
Visual Basic (Declaration)
Public Function ReverseDatabase ( _
    connectionString As String _
) As Database
Visual C++
public:
Database^ ReverseDatabase(
    String^ connectionString
)

Parameters

connectionString
Type: System..::.String

See Also

DatabaseSync Class
ReverseDatabase Overload
PerpetuumSoft.DataModel Namespace


ReverseDatabase Method (SqlConnection, SqlTransaction)

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.ReverseDatabase Method (SqlConnection, SqlTransaction)
DatabaseSync Class See Also Send Feedback
Returns the database structure in the form of object graph.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Database ReverseDatabase(
    SqlConnection connection,
    SqlTransaction transaction
)
Visual Basic (Declaration)
Public Function ReverseDatabase ( _
    connection As SqlConnection, _
    transaction As SqlTransaction _
) As Database
Visual C++
public:
Database^ ReverseDatabase(
    SqlConnection^ connection,
    SqlTransaction^ transaction
)

Parameters

connection
Type: System.Data.SqlClient..::.SqlConnection
transaction
Type: System.Data.SqlClient..::.SqlTransaction

See Also

DatabaseSync Class
ReverseDatabase Overload
PerpetuumSoft.DataModel Namespace


UpdateDatabase Method

[image] [image]

SQL Schema Sync API Class reference
DatabaseSync..::.UpdateDatabase Method
DatabaseSync Class See Also Send Feedback

Overload List

Name | Description
UpdateDatabase(Database, String) | Updates the existing database stucture.
UpdateDatabase(String, String) | Updates the existing database stucture.
UpdateDatabase(Database, SqlConnection, SqlTransaction) | Updates the existing database stucture.

See Also

DatabaseSync Class
DatabaseSync Members
PerpetuumSoft.DataModel Namespace


UpdateDatabase Method (Database, String)

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.UpdateDatabase Method (Database, String)
DatabaseSync Class See Also Send Feedback
Updates the existing database stucture.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void UpdateDatabase(
    Database sourceDatabase,
    string targetConnectionString
)
Visual Basic (Declaration)
Public Sub UpdateDatabase ( _
    sourceDatabase As Database, _
    targetConnectionString As String _
)
Visual C++
public:
void UpdateDatabase(
    Database^ sourceDatabase,
    String^ targetConnectionString
)

Parameters

sourceDatabase
Type: PerpetuumSoft.DataModel.MsSql..::.Database
targetConnectionString
Type: System..::.String

See Also

DatabaseSync Class
UpdateDatabase Overload
PerpetuumSoft.DataModel Namespace


UpdateDatabase Method (String, String)

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.UpdateDatabase Method (String, String)
DatabaseSync Class See Also Send Feedback
Updates the existing database stucture.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void UpdateDatabase(
    string sourceConnectionString,
    string targetConnectionString
)
Visual Basic (Declaration)
Public Sub UpdateDatabase ( _
    sourceConnectionString As String, _
    targetConnectionString As String _
)
Visual C++
public:
void UpdateDatabase(
    String^ sourceConnectionString,
    String^ targetConnectionString
)

Parameters

sourceConnectionString
Type: System..::.String
targetConnectionString
Type: System..::.String

See Also

DatabaseSync Class
UpdateDatabase Overload
PerpetuumSoft.DataModel Namespace


UpdateDatabase Method (Database, SqlConnection, SqlTransaction)

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.UpdateDatabase Method (Database, SqlConnection, SqlTransaction)
DatabaseSync Class See Also Send Feedback
Updates the existing database stucture.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void UpdateDatabase(
    Database sourceDatabase,
    SqlConnection targetDatabaseConnection,
    SqlTransaction targetDatabaseTransaction
)
Visual Basic (Declaration)
Public Sub UpdateDatabase ( _
    sourceDatabase As Database, _
    targetDatabaseConnection As SqlConnection, _
    targetDatabaseTransaction As SqlTransaction _
)
Visual C++
public:
void UpdateDatabase(
    Database^ sourceDatabase,
    SqlConnection^ targetDatabaseConnection,
    SqlTransaction^ targetDatabaseTransaction
)

Parameters

sourceDatabase
Type: PerpetuumSoft.DataModel.MsSql..::.Database
targetDatabaseConnection
Type: System.Data.SqlClient..::.SqlConnection
targetDatabaseTransaction
Type: System.Data.SqlClient..::.SqlTransaction

See Also

DatabaseSync Class
UpdateDatabase Overload
PerpetuumSoft.DataModel Namespace


DatabaseSync Properties

[image] [image]

SQL Schema Sync API Class reference
DatabaseSync Properties
DatabaseSync Class See Also Send Feedback

The DatabaseSync type exposes the following members.

Properties

Name | Description
About | Gets copyright string.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Options | Gets or sets the DatabaseSyncOptions option of databases synchronization.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


About Property

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.About Property
DatabaseSync Class See Also Send Feedback
Gets copyright string.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string About { get; }
Visual Basic (Declaration)
Public ReadOnly Property About As String
Visual C++
public:
property String^ About {
    String^ get ();
}

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


Options Property

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.Options Property
DatabaseSync Class See Also Send Feedback
Gets or sets the DatabaseSyncOptions option of databases synchronization.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseSyncOptions Options { get; set; }
Visual Basic (Declaration)
Public Property Options As DatabaseSyncOptions
Visual C++
public:
property DatabaseSyncOptions^ Options {
    DatabaseSyncOptions^ get ();
    void set (DatabaseSyncOptions^ value);
}

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


DatabaseSync Events

[image] [image]

SQL Schema Sync API Class reference
DatabaseSync Events
DatabaseSync Class See Also Send Feedback

The DatabaseSync type exposes the following members.

Events

Name | Description
DatabaseUpdated | Occurs when database structure is changed.
DatabaseUpdating | Occurs when database structure starts changing.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
Progress | Occurs when progress information on the current operation changes.
ScriptExecuted | Occurs when script section synchronization is executed.
ScriptExecuting | Occurs before a script is executed.
SkipSynchronizing | Occurs during the scripts building. Used to skip separate objects synchronization.

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


DatabaseUpdated Event

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.DatabaseUpdated Event
DatabaseSync Class See Also Send Feedback
Occurs when database structure is changed.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<EventArgs> DatabaseUpdated
Visual Basic (Declaration)
Public Event DatabaseUpdated As EventHandler(Of EventArgs)
Visual C++
public:
 event EventHandler<EventArgs^>^ DatabaseUpdated {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


DatabaseUpdating Event

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.DatabaseUpdating Event
DatabaseSync Class See Also Send Feedback
Occurs when database structure starts changing.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<DatabaseUpdatingEventArgs> DatabaseUpdating
Visual Basic (Declaration)
Public Event DatabaseUpdating As EventHandler(Of DatabaseUpdatingEventArgs)
Visual C++
public:
 event EventHandler<DatabaseUpdatingEventArgs^>^ DatabaseUpdating {
    void add (EventHandler<DatabaseUpdatingEventArgs^>^ value);
    void remove (EventHandler<DatabaseUpdatingEventArgs^>^ value);
}

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


Progress Event

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.Progress Event
DatabaseSync Class See Also Send Feedback
Occurs when progress information on the current operation changes.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<ProgressEventArgs> Progress
Visual Basic (Declaration)
Public Event Progress As EventHandler(Of ProgressEventArgs)
Visual C++
public:
 event EventHandler<ProgressEventArgs^>^ Progress {
    void add (EventHandler<ProgressEventArgs^>^ value);
    void remove (EventHandler<ProgressEventArgs^>^ value);
}

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


ScriptExecuted Event

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.ScriptExecuted Event
DatabaseSync Class See Also Send Feedback
Occurs when script section synchronization is executed.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<ScriptExecuteEventArgs> ScriptExecuted
Visual Basic (Declaration)
Public Event ScriptExecuted As EventHandler(Of ScriptExecuteEventArgs)
Visual C++
public:
 event EventHandler<ScriptExecuteEventArgs^>^ ScriptExecuted {
    void add (EventHandler<ScriptExecuteEventArgs^>^ value);
    void remove (EventHandler<ScriptExecuteEventArgs^>^ value);
}

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


ScriptExecuting Event

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.ScriptExecuting Event
DatabaseSync Class See Also Send Feedback
Occurs before a script is executed.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<ScriptExecuteEventArgs> ScriptExecuting
Visual Basic (Declaration)
Public Event ScriptExecuting As EventHandler(Of ScriptExecuteEventArgs)
Visual C++
public:
 event EventHandler<ScriptExecuteEventArgs^>^ ScriptExecuting {
    void add (EventHandler<ScriptExecuteEventArgs^>^ value);
    void remove (EventHandler<ScriptExecuteEventArgs^>^ value);
}

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


SkipSynchronizing Event

[image]

SQL Schema Sync API Class reference
DatabaseSync..::.SkipSynchronizing Event
DatabaseSync Class See Also Send Feedback
Occurs during the scripts building. Used to skip separate objects synchronization.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<SkipSynchronizingEventArgs> SkipSynchronizing
Visual Basic (Declaration)
Public Event SkipSynchronizing As EventHandler(Of SkipSynchronizingEventArgs)
Visual C++
public:
 event EventHandler<SkipSynchronizingEventArgs^>^ SkipSynchronizing {
    void add (EventHandler<SkipSynchronizingEventArgs^>^ value);
    void remove (EventHandler<SkipSynchronizingEventArgs^>^ value);
}

See Also

DatabaseSync Class
PerpetuumSoft.DataModel Namespace


DatabaseSyncOptions Class

[image]

SQL Schema Sync API Class reference
DatabaseSyncOptions Class
Members See Also Send Feedback
Represents options of databases synchronization.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class DatabaseSyncOptions
Visual Basic (Declaration)
Public Class DatabaseSyncOptions
Visual C++
public ref class DatabaseSyncOptions

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel..::.DatabaseSyncOptions

See Also

DatabaseSyncOptions Members
PerpetuumSoft.DataModel Namespace


DatabaseSyncOptions Members

[image] [image]

SQL Schema Sync API Class reference
DatabaseSyncOptions Members
DatabaseSyncOptions Class Constructors Methods Properties See Also Send Feedback

The DatabaseSyncOptions type exposes the following members.

Constructors

Name | Description
DatabaseSyncOptions | Creates new instance of the DatabaseSyncOptions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CommandTimeout |
ConstraintsWithCheck | If the property value is true, then Constrains will be created with the enabled WithCheck option during the synchronization.
DisableDdlTriggers | If the property value is true, then DLL triggers will be disabled during synchronization.
SynchronizeCollation | If the property value is true, then synchronization of Collation occurs.
SynchronizeDatabaseOptions | If the property value is set to true, synchronization of database Properties is executed.
SynchronizeExtendedProperties | If the property value is true then the synchronization of the extended property occurs.
SynchronizePermissions | If the property value is true, then synchronization of permissions occurs.
SynchronizePrincipals | If the property value is true, then synchronization of principals occurs.

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


DatabaseSyncOptions Constructor

[image]

SQL Schema Sync API Class reference
DatabaseSyncOptions Constructor
DatabaseSyncOptions Class See Also Send Feedback
Creates new instance of the DatabaseSyncOptions class.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseSyncOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DatabaseSyncOptions()

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


DatabaseSyncOptions Methods

[image] [image]

SQL Schema Sync API Class reference
DatabaseSyncOptions Methods
DatabaseSyncOptions Class See Also Send Feedback

The DatabaseSyncOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


DatabaseSyncOptions Properties

[image] [image]

SQL Schema Sync API Class reference
DatabaseSyncOptions Properties
DatabaseSyncOptions Class See Also Send Feedback

The DatabaseSyncOptions type exposes the following members.

Properties

Name | Description
CommandTimeout |
ConstraintsWithCheck | If the property value is true, then Constrains will be created with the enabled WithCheck option during the synchronization.
DisableDdlTriggers | If the property value is true, then DLL triggers will be disabled during synchronization.
SynchronizeCollation | If the property value is true, then synchronization of Collation occurs.
SynchronizeDatabaseOptions | If the property value is set to true, synchronization of database Properties is executed.
SynchronizeExtendedProperties | If the property value is true then the synchronization of the extended property occurs.
SynchronizePermissions | If the property value is true, then synchronization of permissions occurs.
SynchronizePrincipals | If the property value is true, then synchronization of principals occurs.

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


CommandTimeout Property

[image]

SQL Schema Sync API Class reference
DatabaseSyncOptions..::.CommandTimeout Property
DatabaseSyncOptions Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.DatabaseSyncOptions.CommandTimeout"]

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int CommandTimeout { get; set; }
Visual Basic (Declaration)
Public Property CommandTimeout As Integer
Visual C++
public:
property int CommandTimeout {
    int get ();
    void set (int value);
}

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


ConstraintsWithCheck Property

[image]

SQL Schema Sync API Class reference
DatabaseSyncOptions..::.ConstraintsWithCheck Property
DatabaseSyncOptions Class See Also Send Feedback
If the property value is true, then Constrains will be created with the enabled WithCheck option during the synchronization.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool ConstraintsWithCheck { get; set; }
Visual Basic (Declaration)
Public Property ConstraintsWithCheck As Boolean
Visual C++
public:
property bool ConstraintsWithCheck {
    bool get ();
    void set (bool value);
}

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


DisableDdlTriggers Property

[image]

SQL Schema Sync API Class reference
DatabaseSyncOptions..::.DisableDdlTriggers Property
DatabaseSyncOptions Class See Also Send Feedback
If the property value is true, then DLL triggers will be disabled during synchronization.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool DisableDdlTriggers { get; set; }
Visual Basic (Declaration)
Public Property DisableDdlTriggers As Boolean
Visual C++
public:
property bool DisableDdlTriggers {
    bool get ();
    void set (bool value);
}

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


SynchronizeCollation Property

[image]

SQL Schema Sync API Class reference
DatabaseSyncOptions..::.SynchronizeCollation Property
DatabaseSyncOptions Class See Also Send Feedback
If the property value is true, then synchronization of Collation occurs.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool SynchronizeCollation { get; set; }
Visual Basic (Declaration)
Public Property SynchronizeCollation As Boolean
Visual C++
public:
property bool SynchronizeCollation {
    bool get ();
    void set (bool value);
}

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


SynchronizeDatabaseOptions Property

[image]

SQL Schema Sync API Class reference
DatabaseSyncOptions..::.SynchronizeDatabaseOptions Property
DatabaseSyncOptions Class See Also Send Feedback
If the property value is set to true, synchronization of database Properties is executed.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool SynchronizeDatabaseOptions { get; set; }
Visual Basic (Declaration)
Public Property SynchronizeDatabaseOptions As Boolean
Visual C++
public:
property bool SynchronizeDatabaseOptions {
    bool get ();
    void set (bool value);
}

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


SynchronizeExtendedProperties Property

[image]

SQL Schema Sync API Class reference
DatabaseSyncOptions..::.SynchronizeExtendedProperties Property
DatabaseSyncOptions Class See Also Send Feedback
If the property value is true then the synchronization of the extended property occurs.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool SynchronizeExtendedProperties { get; set; }
Visual Basic (Declaration)
Public Property SynchronizeExtendedProperties As Boolean
Visual C++
public:
property bool SynchronizeExtendedProperties {
    bool get ();
    void set (bool value);
}

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


SynchronizePermissions Property

[image]

SQL Schema Sync API Class reference
DatabaseSyncOptions..::.SynchronizePermissions Property
DatabaseSyncOptions Class See Also Send Feedback
If the property value is true, then synchronization of permissions occurs.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool SynchronizePermissions { get; set; }
Visual Basic (Declaration)
Public Property SynchronizePermissions As Boolean
Visual C++
public:
property bool SynchronizePermissions {
    bool get ();
    void set (bool value);
}

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


SynchronizePrincipals Property

[image]

SQL Schema Sync API Class reference
DatabaseSyncOptions..::.SynchronizePrincipals Property
DatabaseSyncOptions Class See Also Send Feedback
If the property value is true, then synchronization of principals occurs.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool SynchronizePrincipals { get; set; }
Visual Basic (Declaration)
Public Property SynchronizePrincipals As Boolean
Visual C++
public:
property bool SynchronizePrincipals {
    bool get ();
    void set (bool value);
}

See Also

DatabaseSyncOptions Class
PerpetuumSoft.DataModel Namespace


DatabaseUpdatingEventArgs Class

[image]

SQL Schema Sync API Class reference
DatabaseUpdatingEventArgs Class
Members See Also Send Feedback
Represents parameters of the DatabaseUpdating event.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class DatabaseUpdatingEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DatabaseUpdatingEventArgs _
    Inherits EventArgs
Visual C++
public ref class DatabaseUpdatingEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.DataModel..::.DatabaseUpdatingEventArgs

See Also

DatabaseUpdatingEventArgs Members
PerpetuumSoft.DataModel Namespace


DatabaseUpdatingEventArgs Members

[image] [image]

SQL Schema Sync API Class reference
DatabaseUpdatingEventArgs Members
DatabaseUpdatingEventArgs Class Constructors Methods Properties See Also Send Feedback

The DatabaseUpdatingEventArgs type exposes the following members.

Constructors

Name | Description
DatabaseUpdatingEventArgs | Creates new instance of the DatabaseUpdatingEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseSynchronizer | Gets DatabaseSynchronizer which will synchronize databases.

See Also

DatabaseUpdatingEventArgs Class
PerpetuumSoft.DataModel Namespace


DatabaseUpdatingEventArgs Constructor

[image]

SQL Schema Sync API Class reference
DatabaseUpdatingEventArgs Constructor
DatabaseUpdatingEventArgs Class See Also Send Feedback
Creates new instance of the DatabaseUpdatingEventArgs class.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseUpdatingEventArgs(
    DatabaseSynchronizer databaseSynchronizer
)
Visual Basic (Declaration)
Public Sub New ( _
    databaseSynchronizer As DatabaseSynchronizer _
)
Visual C++
public:
DatabaseUpdatingEventArgs(
    DatabaseSynchronizer^ databaseSynchronizer
)

Parameters

databaseSynchronizer
Type: PerpetuumSoft.DataModel.MsSql.Synchronizers..::.DatabaseSynchronizer

See Also

DatabaseUpdatingEventArgs Class
PerpetuumSoft.DataModel Namespace


DatabaseUpdatingEventArgs Methods

[image] [image]

SQL Schema Sync API Class reference
DatabaseUpdatingEventArgs Methods
DatabaseUpdatingEventArgs Class See Also Send Feedback

The DatabaseUpdatingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseUpdatingEventArgs Class
PerpetuumSoft.DataModel Namespace


DatabaseUpdatingEventArgs Properties

[image] [image]

SQL Schema Sync API Class reference
DatabaseUpdatingEventArgs Properties
DatabaseUpdatingEventArgs Class See Also Send Feedback

The DatabaseUpdatingEventArgs type exposes the following members.

Properties

Name | Description
DatabaseSynchronizer | Gets DatabaseSynchronizer which will synchronize databases.

See Also

DatabaseUpdatingEventArgs Class
PerpetuumSoft.DataModel Namespace


DatabaseSynchronizer Property

[image]

SQL Schema Sync API Class reference
DatabaseUpdatingEventArgs..::.DatabaseSynchronizer Property
DatabaseUpdatingEventArgs Class See Also Send Feedback
Gets DatabaseSynchronizer which will synchronize databases.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseSynchronizer DatabaseSynchronizer { get; }
Visual Basic (Declaration)
Public ReadOnly Property DatabaseSynchronizer As DatabaseSynchronizer
Visual C++
public:
property DatabaseSynchronizer^ DatabaseSynchronizer {
    DatabaseSynchronizer^ get ();
}

See Also

DatabaseUpdatingEventArgs Class
PerpetuumSoft.DataModel Namespace


FunctionRequareEventArgs Class

[image]

SQL Schema Sync API Class reference
FunctionRequareEventArgs Class
Members See Also Send Feedback
Represents arguments of the FunctionRequire event.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public class FunctionRequareEventArgs : EventArgs
Visual Basic (Declaration)
Public Class FunctionRequareEventArgs _
    Inherits EventArgs
Visual C++
public ref class FunctionRequareEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.DataModel..::.FunctionRequareEventArgs

See Also

FunctionRequareEventArgs Members
PerpetuumSoft.DataModel Namespace


FunctionRequareEventArgs Members

[image] [image]

SQL Schema Sync API Class reference
FunctionRequareEventArgs Members
FunctionRequareEventArgs Class Constructors Methods Properties See Also Send Feedback

The FunctionRequareEventArgs type exposes the following members.

Constructors

Name | Description
FunctionRequareEventArgs | Creates new instance of the FunctionRequareEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Function | Function object that should be initialized in the event handler.
FunctionName | Function name.
SchemaName | Name of the schema containing function.

See Also

FunctionRequareEventArgs Class
PerpetuumSoft.DataModel Namespace


FunctionRequareEventArgs Constructor

[image]

SQL Schema Sync API Class reference
FunctionRequareEventArgs Constructor
FunctionRequareEventArgs Class See Also Send Feedback
Creates new instance of the FunctionRequareEventArgs class.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public FunctionRequareEventArgs(
    string schemaName,
    string functionName
)
Visual Basic (Declaration)
Public Sub New ( _
    schemaName As String, _
    functionName As String _
)
Visual C++
public:
FunctionRequareEventArgs(
    String^ schemaName,
    String^ functionName
)

Parameters

schemaName
Type: System..::.String
functionName
Type: System..::.String

See Also

FunctionRequareEventArgs Class
PerpetuumSoft.DataModel Namespace


FunctionRequareEventArgs Methods

[image] [image]

SQL Schema Sync API Class reference
FunctionRequareEventArgs Methods
FunctionRequareEventArgs Class See Also Send Feedback

The FunctionRequareEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FunctionRequareEventArgs Class
PerpetuumSoft.DataModel Namespace


FunctionRequareEventArgs Properties

[image] [image]

SQL Schema Sync API Class reference
FunctionRequareEventArgs Properties
FunctionRequareEventArgs Class See Also Send Feedback

The FunctionRequareEventArgs type exposes the following members.

Properties

Name | Description
Function | Function object that should be initialized in the event handler.
FunctionName | Function name.
SchemaName | Name of the schema containing function.

See Also

FunctionRequareEventArgs Class
PerpetuumSoft.DataModel Namespace


Function Property

[image]

SQL Schema Sync API Class reference
FunctionRequareEventArgs..::.Function Property
FunctionRequareEventArgs Class See Also Send Feedback
Function object that should be initialized in the event handler.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public FunctionBase Function { get; set; }
Visual Basic (Declaration)
Public Property Function As FunctionBase
Visual C++
public:
property FunctionBase^ Function {
    FunctionBase^ get ();
    void set (FunctionBase^ value);
}

See Also

FunctionRequareEventArgs Class
PerpetuumSoft.DataModel Namespace


FunctionName Property

[image]

SQL Schema Sync API Class reference
FunctionRequareEventArgs..::.FunctionName Property
FunctionRequareEventArgs Class See Also Send Feedback
Function name.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public string FunctionName { get; set; }
Visual Basic (Declaration)
Public Property FunctionName As String
Visual C++
public:
property String^ FunctionName {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionRequareEventArgs Class
PerpetuumSoft.DataModel Namespace


SchemaName Property

[image]

SQL Schema Sync API Class reference
FunctionRequareEventArgs..::.SchemaName Property
FunctionRequareEventArgs Class See Also Send Feedback
Name of the schema containing function.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public string SchemaName { get; set; }
Visual Basic (Declaration)
Public Property SchemaName As String
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionRequareEventArgs Class
PerpetuumSoft.DataModel Namespace


ProgressEventArgs Class

[image]

SQL Schema Sync API Class reference
ProgressEventArgs Class
Members See Also Send Feedback
Represents the Progress event arguments.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class ProgressEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ProgressEventArgs _
    Inherits EventArgs
Visual C++
public ref class ProgressEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.DataModel..::.ProgressEventArgs

See Also

ProgressEventArgs Members
PerpetuumSoft.DataModel Namespace


ProgressEventArgs Members

[image] [image]

SQL Schema Sync API Class reference
ProgressEventArgs Members
ProgressEventArgs Class Constructors Methods Properties See Also Send Feedback

The ProgressEventArgs type exposes the following members.

Constructors

Name | Description
ProgressEventArgs | Initializes a new instance of the ProgressEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AbortUpdate | Gets or sets
Action | Gets an executed action name.
Percent | Gets progress as percentage.

See Also

ProgressEventArgs Class
PerpetuumSoft.DataModel Namespace


ProgressEventArgs Constructor

[image]

SQL Schema Sync API Class reference
ProgressEventArgs Constructor
ProgressEventArgs Class See Also Send Feedback
Initializes a new instance of the ProgressEventArgs class.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ProgressEventArgs(
    string action,
    int percent
)
Visual Basic (Declaration)
Public Sub New ( _
    action As String, _
    percent As Integer _
)
Visual C++
public:
ProgressEventArgs(
    String^ action,
    int percent
)

Parameters

action
Type: System..::.String
percent
Type: System..::.Int32

See Also

ProgressEventArgs Class
PerpetuumSoft.DataModel Namespace


ProgressEventArgs Methods

[image] [image]

SQL Schema Sync API Class reference
ProgressEventArgs Methods
ProgressEventArgs Class See Also Send Feedback

The ProgressEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProgressEventArgs Class
PerpetuumSoft.DataModel Namespace


ProgressEventArgs Properties

[image] [image]

SQL Schema Sync API Class reference
ProgressEventArgs Properties
ProgressEventArgs Class See Also Send Feedback

The ProgressEventArgs type exposes the following members.

Properties

Name | Description
AbortUpdate | Gets or sets
Action | Gets an executed action name.
Percent | Gets progress as percentage.

See Also

ProgressEventArgs Class
PerpetuumSoft.DataModel Namespace


AbortUpdate Property

[image]

SQL Schema Sync API Class reference
ProgressEventArgs..::.AbortUpdate Property
ProgressEventArgs Class See Also Send Feedback
Gets or sets

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AbortUpdate { get; set; }
Visual Basic (Declaration)
Public Property AbortUpdate As Boolean
Visual C++
public:
property bool AbortUpdate {
    bool get ();
    void set (bool value);
}

See Also

ProgressEventArgs Class
PerpetuumSoft.DataModel Namespace


Action Property

[image]

SQL Schema Sync API Class reference
ProgressEventArgs..::.Action Property
ProgressEventArgs Class See Also Send Feedback
Gets an executed action name.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Action { get; }
Visual Basic (Declaration)
Public ReadOnly Property Action As String
Visual C++
public:
property String^ Action {
    String^ get ();
}

See Also

ProgressEventArgs Class
PerpetuumSoft.DataModel Namespace


Percent Property

[image]

SQL Schema Sync API Class reference
ProgressEventArgs..::.Percent Property
ProgressEventArgs Class See Also Send Feedback
Gets progress as percentage.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int Percent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Percent As Integer
Visual C++
public:
property int Percent {
    int get ();
}

See Also

ProgressEventArgs Class
PerpetuumSoft.DataModel Namespace


ScriptExecuteEventArgs Class

[image]

SQL Schema Sync API Class reference
ScriptExecuteEventArgs Class
Members See Also Send Feedback
Represents ScriptExecuted event arguments.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class ScriptExecuteEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ScriptExecuteEventArgs _
    Inherits EventArgs
Visual C++
public ref class ScriptExecuteEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.DataModel..::.ScriptExecuteEventArgs

See Also

ScriptExecuteEventArgs Members
PerpetuumSoft.DataModel Namespace


ScriptExecuteEventArgs Members

[image] [image]

SQL Schema Sync API Class reference
ScriptExecuteEventArgs Members
ScriptExecuteEventArgs Class Constructors Methods Properties See Also Send Feedback

The ScriptExecuteEventArgs type exposes the following members.

Constructors

Name | Description
ScriptExecuteEventArgs | Initializes a new instance of the ScriptExecuteEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Text | Gets script text.

See Also

ScriptExecuteEventArgs Class
PerpetuumSoft.DataModel Namespace


ScriptExecuteEventArgs Constructor

[image]

SQL Schema Sync API Class reference
ScriptExecuteEventArgs Constructor
ScriptExecuteEventArgs Class See Also Send Feedback
Initializes a new instance of the ScriptExecuteEventArgs class.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ScriptExecuteEventArgs(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)
Visual C++
public:
ScriptExecuteEventArgs(
    String^ text
)

Parameters

text
Type: System..::.String

See Also

ScriptExecuteEventArgs Class
PerpetuumSoft.DataModel Namespace


ScriptExecuteEventArgs Methods

[image] [image]

SQL Schema Sync API Class reference
ScriptExecuteEventArgs Methods
ScriptExecuteEventArgs Class See Also Send Feedback

The ScriptExecuteEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptExecuteEventArgs Class
PerpetuumSoft.DataModel Namespace


ScriptExecuteEventArgs Properties

[image] [image]

SQL Schema Sync API Class reference
ScriptExecuteEventArgs Properties
ScriptExecuteEventArgs Class See Also Send Feedback

The ScriptExecuteEventArgs type exposes the following members.

Properties

Name | Description
Text | Gets script text.

See Also

ScriptExecuteEventArgs Class
PerpetuumSoft.DataModel Namespace


Text Property

[image]

SQL Schema Sync API Class reference
ScriptExecuteEventArgs..::.Text Property
ScriptExecuteEventArgs Class See Also Send Feedback
Gets script text.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ScriptExecuteEventArgs Class
PerpetuumSoft.DataModel Namespace


SkipSynchronizingEventArgs Class

[image]

SQL Schema Sync API Class reference
SkipSynchronizingEventArgs Class
Members See Also Send Feedback
Represents arguments for the SkipSynchronizing event.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class SkipSynchronizingEventArgs : EventArgs
Visual Basic (Declaration)
Public Class SkipSynchronizingEventArgs _
    Inherits EventArgs
Visual C++
public ref class SkipSynchronizingEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.DataModel..::.SkipSynchronizingEventArgs

See Also

SkipSynchronizingEventArgs Members
PerpetuumSoft.DataModel Namespace


SkipSynchronizingEventArgs Members

[image] [image]

SQL Schema Sync API Class reference
SkipSynchronizingEventArgs Members
SkipSynchronizingEventArgs Class Constructors Methods Properties See Also Send Feedback

The SkipSynchronizingEventArgs type exposes the following members.

Constructors

Name | Description
SkipSynchronizingEventArgs | Initializes a new instance of the SkipSynchronizingEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NeedSynchronizing | Gets or sets true value if the object is synchronized.
NewObject | Gets a new database object.
OldObject | Gets database old object.

See Also

SkipSynchronizingEventArgs Class
PerpetuumSoft.DataModel Namespace


SkipSynchronizingEventArgs Constructor

[image]

SQL Schema Sync API Class reference
SkipSynchronizingEventArgs Constructor
SkipSynchronizingEventArgs Class See Also Send Feedback
Initializes a new instance of the SkipSynchronizingEventArgs class

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SkipSynchronizingEventArgs(
    Element newObject,
    Element oldObject,
    ref bool needSynchronizing
)
Visual Basic (Declaration)
Public Sub New ( _
    newObject As Element, _
    oldObject As Element, _
    ByRef needSynchronizing As Boolean _
)
Visual C++
public:
SkipSynchronizingEventArgs(
    Element^ newObject,
    Element^ oldObject,
    bool% needSynchronizing
)

Parameters

newObject
Type: PerpetuumSoft.DataModel.MsSql..::.Element
oldObject
Type: PerpetuumSoft.DataModel.MsSql..::.Element
needSynchronizing
Type: System..::.Boolean %

See Also

SkipSynchronizingEventArgs Class
PerpetuumSoft.DataModel Namespace


SkipSynchronizingEventArgs Methods

[image] [image]

SQL Schema Sync API Class reference
SkipSynchronizingEventArgs Methods
SkipSynchronizingEventArgs Class See Also Send Feedback

The SkipSynchronizingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SkipSynchronizingEventArgs Class
PerpetuumSoft.DataModel Namespace


SkipSynchronizingEventArgs Properties

[image] [image]

SQL Schema Sync API Class reference
SkipSynchronizingEventArgs Properties
SkipSynchronizingEventArgs Class See Also Send Feedback

The SkipSynchronizingEventArgs type exposes the following members.

Properties

Name | Description
NeedSynchronizing | Gets or sets true value if the object is synchronized.
NewObject | Gets a new database object.
OldObject | Gets database old object.

See Also

SkipSynchronizingEventArgs Class
PerpetuumSoft.DataModel Namespace


NeedSynchronizing Property

[image]

SQL Schema Sync API Class reference
SkipSynchronizingEventArgs..::.NeedSynchronizing Property
SkipSynchronizingEventArgs Class See Also Send Feedback
Gets or sets true value if the object is synchronized.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool NeedSynchronizing { get; set; }
Visual Basic (Declaration)
Public Property NeedSynchronizing As Boolean
Visual C++
public:
property bool NeedSynchronizing {
    bool get ();
    void set (bool value);
}

See Also

SkipSynchronizingEventArgs Class
PerpetuumSoft.DataModel Namespace


NewObject Property

[image]

SQL Schema Sync API Class reference
SkipSynchronizingEventArgs..::.NewObject Property
SkipSynchronizingEventArgs Class See Also Send Feedback
Gets a new database object.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Element NewObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewObject As Element
Visual C++
public:
property Element^ NewObject {
    Element^ get ();
}

See Also

SkipSynchronizingEventArgs Class
PerpetuumSoft.DataModel Namespace


OldObject Property

[image]

SQL Schema Sync API Class reference
SkipSynchronizingEventArgs..::.OldObject Property
SkipSynchronizingEventArgs Class See Also Send Feedback
Gets database old object.

Namespace: PerpetuumSoft.DataModel
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Element OldObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property OldObject As Element
Visual C++
public:
property Element^ OldObject {
    Element^ get ();
}

See Also

SkipSynchronizingEventArgs Class
PerpetuumSoft.DataModel Namespace


PerpetuumSoft.DataModel.LinqToSql Namespace

[image]

SQL Schema Sync API Class reference
PerpetuumSoft.DataModel.LinqToSql Namespace
Send Feedback
PerpetuumSoft.DataModel.LinqToSql Namespace contains classes used for the creation of Database by LINQ to SQL Classes.

Classes

Class | Description
LinqDatabaseBuilder | Represents builder of database object model by LINQ conceptual model.

Structures

Structure | Description
FullName | Represents full name of database object. It allows you to split full name into constituents: schema name and object name.


FullName Structure

[image]

SQL Schema Sync API Class reference
FullName Structure
Members See Also Send Feedback
Represents full name of database object. It allows you to split full name into constituents: schema name and object name.

Namespace: PerpetuumSoft.DataModel.LinqToSql
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public struct FullName
Visual Basic (Declaration)
Public Structure FullName
Visual C++
public value class FullName

See Also

FullName Members
PerpetuumSoft.DataModel.LinqToSql Namespace


FullName Members

[image] [image]

SQL Schema Sync API Class reference
FullName Members
FullName Structure Constructors Methods Properties See Also Send Feedback

The FullName type exposes the following members.

Constructors

Name | Description
FullName | Initializes a new instance of the FullName class.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
ObjectName | Gets object name
SchemaName | Gets schema name

See Also

FullName Structure
PerpetuumSoft.DataModel.LinqToSql Namespace


FullName Constructor

[image]

SQL Schema Sync API Class reference
FullName Constructor
FullName Structure See Also Send Feedback
Initializes a new instance of the FullName class.

Namespace: PerpetuumSoft.DataModel.LinqToSql
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public FullName(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
FullName(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

FullName Structure
PerpetuumSoft.DataModel.LinqToSql Namespace


FullName Methods

[image] [image]

SQL Schema Sync API Class reference
FullName Methods
FullName Structure See Also Send Feedback

The FullName type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

FullName Structure
PerpetuumSoft.DataModel.LinqToSql Namespace


FullName Properties

[image] [image]

SQL Schema Sync API Class reference
FullName Properties
FullName Structure See Also Send Feedback

The FullName type exposes the following members.

Properties

Name | Description
ObjectName | Gets object name
SchemaName | Gets schema name

See Also

FullName Structure
PerpetuumSoft.DataModel.LinqToSql Namespace


ObjectName Property

[image]

SQL Schema Sync API Class reference
FullName..::.ObjectName Property
FullName Structure See Also Send Feedback
Gets object name

Namespace: PerpetuumSoft.DataModel.LinqToSql
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public string ObjectName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectName As String
Visual C++
public:
property String^ ObjectName {
    String^ get ();
}

See Also

FullName Structure
PerpetuumSoft.DataModel.LinqToSql Namespace


SchemaName Property

[image]

SQL Schema Sync API Class reference
FullName..::.SchemaName Property
FullName Structure See Also Send Feedback
Gets schema name

Namespace: PerpetuumSoft.DataModel.LinqToSql
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public string SchemaName { get; }
Visual Basic (Declaration)
Public ReadOnly Property SchemaName As String
Visual C++
public:
property String^ SchemaName {
    String^ get ();
}

See Also

FullName Structure
PerpetuumSoft.DataModel.LinqToSql Namespace


LinqDatabaseBuilder Class

[image]

SQL Schema Sync API Class reference
LinqDatabaseBuilder Class
Members See Also Send Feedback
Represents builder of database object model by LINQ conceptual model.

Namespace: PerpetuumSoft.DataModel.LinqToSql
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public sealed class LinqDatabaseBuilder
Visual Basic (Declaration)
Public NotInheritable Class LinqDatabaseBuilder
Visual C++
public ref class LinqDatabaseBuilder sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.LinqToSql..::.LinqDatabaseBuilder

See Also

LinqDatabaseBuilder Members
PerpetuumSoft.DataModel.LinqToSql Namespace


LinqDatabaseBuilder Members

[image] [image]

SQL Schema Sync API Class reference
LinqDatabaseBuilder Members
LinqDatabaseBuilder Class Constructors Methods Properties Events See Also Send Feedback

The LinqDatabaseBuilder type exposes the following members.

Constructors

Name | Description
LinqDatabaseBuilder | Creates new instance of the LinqDatabaseBuilder class.

Methods

Name | Description
CreateDatabase | Returns object of database model based on metamodel.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CreateFunctions | If property value is set to true, the FunctionRequire event will fire.

Events

Name | Description
FunctionRequire | Event which handler should initialize function which name is passed in the event arguments.

See Also

LinqDatabaseBuilder Class
PerpetuumSoft.DataModel.LinqToSql Namespace


LinqDatabaseBuilder Constructor

[image]

SQL Schema Sync API Class reference
LinqDatabaseBuilder Constructor
LinqDatabaseBuilder Class See Also Send Feedback
Creates new instance of the LinqDatabaseBuilder class.

Namespace: PerpetuumSoft.DataModel.LinqToSql
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public LinqDatabaseBuilder()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinqDatabaseBuilder()

See Also

LinqDatabaseBuilder Class
PerpetuumSoft.DataModel.LinqToSql Namespace


LinqDatabaseBuilder Methods

[image] [image]

SQL Schema Sync API Class reference
LinqDatabaseBuilder Methods
LinqDatabaseBuilder Class See Also Send Feedback

The LinqDatabaseBuilder type exposes the following members.

Methods

Name | Description
CreateDatabase | Returns object of database model based on metamodel.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinqDatabaseBuilder Class
PerpetuumSoft.DataModel.LinqToSql Namespace


CreateDatabase Method

[image]

SQL Schema Sync API Class reference
LinqDatabaseBuilder..::.CreateDatabase Method
LinqDatabaseBuilder Class See Also Send Feedback
Returns object of database model based on metamodel.

Namespace: PerpetuumSoft.DataModel.LinqToSql
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public Database CreateDatabase(
    MetaModel metaModel
)
Visual Basic (Declaration)
Public Function CreateDatabase ( _
    metaModel As MetaModel _
) As Database
Visual C++
public:
Database^ CreateDatabase(
    MetaModel^ metaModel
)

Parameters

metaModel
Type: System.Data.Linq.Mapping..::.MetaModel

See Also

LinqDatabaseBuilder Class
PerpetuumSoft.DataModel.LinqToSql Namespace


LinqDatabaseBuilder Properties

[image] [image]

SQL Schema Sync API Class reference
LinqDatabaseBuilder Properties
LinqDatabaseBuilder Class See Also Send Feedback

The LinqDatabaseBuilder type exposes the following members.

Properties

Name | Description
CreateFunctions | If property value is set to true, the FunctionRequire event will fire.

See Also

LinqDatabaseBuilder Class
PerpetuumSoft.DataModel.LinqToSql Namespace


CreateFunctions Property

[image]

SQL Schema Sync API Class reference
LinqDatabaseBuilder..::.CreateFunctions Property
LinqDatabaseBuilder Class See Also Send Feedback
If property value is set to true, the FunctionRequire event will fire.

Namespace: PerpetuumSoft.DataModel.LinqToSql
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public bool CreateFunctions { get; set; }
Visual Basic (Declaration)
Public Property CreateFunctions As Boolean
Visual C++
public:
property bool CreateFunctions {
    bool get ();
    void set (bool value);
}

See Also

LinqDatabaseBuilder Class
PerpetuumSoft.DataModel.LinqToSql Namespace


LinqDatabaseBuilder Events

[image] [image]

SQL Schema Sync API Class reference
LinqDatabaseBuilder Events
LinqDatabaseBuilder Class See Also Send Feedback

The LinqDatabaseBuilder type exposes the following members.

Events

Name | Description
FunctionRequire | Event which handler should initialize function which name is passed in the event arguments.

See Also

LinqDatabaseBuilder Class
PerpetuumSoft.DataModel.LinqToSql Namespace


FunctionRequire Event

[image]

SQL Schema Sync API Class reference
LinqDatabaseBuilder..::.FunctionRequire Event
LinqDatabaseBuilder Class See Also Send Feedback
Event which handler should initialize function which name is passed in the event arguments.

Namespace: PerpetuumSoft.DataModel.LinqToSql
Assembly: PerpetuumSoft.DataModel.LinqToSql (in PerpetuumSoft.DataModel.LinqToSql.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler<FunctionRequareEventArgs> FunctionRequire
Visual Basic (Declaration)
Public Event FunctionRequire As EventHandler(Of FunctionRequareEventArgs)
Visual C++
public:
 event EventHandler<FunctionRequareEventArgs^>^ FunctionRequire {
    void add (EventHandler<FunctionRequareEventArgs^>^ value);
    void remove (EventHandler<FunctionRequareEventArgs^>^ value);
}

See Also

LinqDatabaseBuilder Class
PerpetuumSoft.DataModel.LinqToSql Namespace


PerpetuumSoft.DataModel.MsSql Namespace

[image]

SQL Schema Sync API Class reference
PerpetuumSoft.DataModel.MsSql Namespace
Send Feedback
Namespace PerpetuumSoft.DataModel.MsSql contains classes representing database object model.

Classes

Class | Description
Assembly | Represents Assembly in the database structure.
BoundingBox |
CheckConstraint | Represents the check constaint in the database structure.
CLRFunctionBase | Basic class for CLR functions.
CLRType | Represents CLR type in the database structure.
ColumnBase | Abstract base class for all column classes.
ColumnBaseCollection | Basic class for table columns, views and computable columns.
ColumnRef | Represents reference to a column.
ColumnRefCollection | Represents a collection of ColumnRef.
ComputedColumn | Represents the computed column in a table.
Constraint | Abstract base class for all constraint classes.
Database | Represents the database structure.
DatabaseObject | Abstract base class for all database entities.
DatabaseObjectCollection | Represents a collection of DatabaseObject.
DatabaseOptions | Represents Database options.
DataColumn | Represents a data column in a database table.
DataColumnSql10 |
DataType | Abstract base class for all column types.
DataType..::.BigInt | Represents the bigint data type.
DataType..::.Binary | Represents the binary data type.
DataType..::.Bit | Represents the bit data type.
DataType..::.Char | Represents the char data type.
DataType..::.Date |
DataType..::.DateSizedType |
DataType..::.DateTime | Represents the datetime data type.
DataType..::.DateTime2 |
DataType..::.DateTimeOffset |
DataType..::.Decimal | Represents the decimal data type.
DataType..::.Float | Represents the float data type.
DataType..::.Geography |
DataType..::.Geometry |
DataType..::.Hierarchyid |
DataType..::.Image | Represents the image data type.
DataType..::.Int | Represents the int data type.
DataType..::.Money | Represents the moey data type.
DataType..::.NChar | Represents the nchar data type.
DataType..::.NText | Represents the ntext data type.
DataType..::.Numeric | Represents the numeric data type.
DataType..::.NVarChar | Represents the nvarchar data type.
DataType..::.Real | Represents the real data type.
DataType..::.SizedType | Abstract base class for the types defined by size.
DataType..::.SmallDateTime | Represents the smalldatetime data type.
DataType..::.SmallInt | Represents the smallint data type.
DataType..::.SmallMoney | Represents the smallmoney data type.
DataType..::.SqlVariant | Represents the sqlvariant data type.
DataType..::.Text | Represents the text data type.
DataType..::.Time |
DataType..::.TimeStamp | Represents the timestamp data type.
DataType..::.TinyInt | Represents the tinyint data type.
DataType..::.TypeWithPrecision | Base class for the types defined by scale and precision.
DataType..::.UniqueIdentifier | Represents the uniqueidentifier data type.
DataType..::.UserCLRType | Represents user CLR type in hte database structure.
DataType..::.UserTableType |
DataType..::.UserType | Represents the user defined data type.
DataType..::.VarBinary | Represents the varbinary data type.
DataType..::.VarChar | Represents the var char data type.
DataType..::.Xml | Represents the xml data type.
DdlTrigger | Represents DLL trigger in the database structure.
Default | Represents default value.
DefaultConstraint | Represents default constraint in the database structure.
Dependency | Represents dependency beetween sql objects.
DependencyCollection | Represents a collection of Dependency .
Element | Abstract base class for all definition cleaases of the database structure.
ExtendedProperty | Represents extended properties in the database structure.
ExtendedPropertyCollection | Represents the extended properties collection.
ForeignKey | Represents a foreign key in the database structure.
FunctionBase | Basic class for all functions in the data base structure.
Grant | Represents grant of permission on the securable object in the database structure.
GrantCollection | Represents collection of permission grants in the database structure.
GridDestiny |
Identity | Stores identity settings of a table column.
Index | Represents an index in the database structure.
IndexBase | Abstract base class for the index objects.
IndexColumn | Represents a column in the index.
IndexColumnCollection | Represents a collection of IndexColumn .
IndexFilter |
IndexSql10 |
InlineTableValuedFunction | Represents the inline table valued function in the database structure.
InParameter | Represents input parameter for the function and stored procedure in a data base structure.
KeyConstraint | Abtsract base class for the primary key and unique key objects.
MultistatementTableValuedFunction | Represents the multistatement table valued function in the database structure.
OutParameter | Represents the function output parameter in the database structure.
ParameterBase | Basic class for function parameters.
ParameterBaseCollection | Represents collection of function parameters in the database structure.
ParameterOrderRef |
Permission | Represents permission in the database structure.
PermissionCollection | Represents collection of permissions in the database structure.
PrimaryKey | Represents a primary key in the database structure.
Principal | Represents principal in the database structure. Base class for users and roles.
Role | Represents role in the database structure.
RoleMember | Represents role member in the database structure.
RoleMemberCollection | Represents collection of the role members.
Rule | Represents rule in database structure.
RuleDefaultObject | Represents object containing reference to ISupportRulesDefaults
RuleDefaultObjectCollection | Represents collection of objects of the RuleDefaultObject type.
ScalarCLRFunction | Represents scalar CLR functions in the database structure.
ScalarFunction | Represents scalar function in the database structure.
Schema | Represent the schema in the database structure.
SchemaObject | Base class for the schema-aware objects.
SpatialIndexSql10 |
StoredProcedure | Represents the stored procedure in the database structure.
Synonym | Represents synonym in the database structure.
Table | Represents a table in the database structure.
TableBase | Abstract superclass for the table and view objects.
TableColumn | Represents table column in the database structure.
TableTypeSql10 |
TableValuedCLRFunction | Represents the table valued CLR function in the database structure.
TableValuedCLRFunctionSql10 |
TableValuedFunction | Represents the table valued function in the database structure.
TextFunction | Basic class for functions and stored procedures.
Trigger | Represents trigger in the database structure.
UniqueConstraint | Represents an unique constraint.
User | Represents user in the database structure.
UserDefinedType | Represents a user defined type in the database structure.
View | Represents a view in the database structure.
ViewColumn | Represents a column in a view.
XmlIndex | Represents xml index in the database structure.
XmlSchemaCollection | Represents collection of xml schemas in the database structure.

Interfaces

Interface | Description
ISchemaObject | Unites all schema-related objects.
ISecurable | Unites all securable objects.
ISupportRulesDefaults | Unites all objects supporting default values and rules.

Enumerations

Enumeration | Description
DefaultCursor | DefaultCursor.
DestinyEnum |
ExecuteAsClause | Represents possible values of the function security context.
ForeignKeyAction | Enumerates foreign key action types.
GrantAction | Represents action on granting permission on the securable object.
GrantMode | Represents mode to grant permission on the securable object .
IndexColumnOrder | Represents an order of the index elements.
NullInputOption | Represents options of function execution subject to the input values.
PageVerify | PageVerify.
Parameterization | Parameterization.
PermissionSet | Represents set of assembly permissions in the database structure.
RoleType | Represents role type in the database structure.
SqlVersionEnum |
TessellationSchema |
UserType | Represents user type in the database structure.
XmlIndexType | Represents xml index type.


Assembly Class

[image]

SQL Schema Sync API Class reference
Assembly Class
Members See Also Send Feedback
Represents Assembly in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Assembly : DatabaseObject,
    ISecurable
Visual Basic (Declaration)
Public NotInheritable Class Assembly _
    Inherits DatabaseObject _
    Implements ISecurable
Visual C++
public ref class Assembly sealed : public DatabaseObject,
    ISecurable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Assembly

See Also

Assembly Members
PerpetuumSoft.DataModel.MsSql Namespace


Assembly Members

[image] [image]

SQL Schema Sync API Class reference
Assembly Members
Assembly Class Constructors Methods Properties See Also Send Feedback

The Assembly type exposes the following members.

Constructors

Name | Description
Assembly | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualTo | Gets true value if two assemblies are equal, otherwise gets false value.
LoadContent | Loads the binary content by the file name.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Content | Gets or sets String which is the binary content of assembly represented as a string.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for the assembly.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets Principal which is the assembly owner.
PermissionSet | Gets or sets PermissionSet which is a set of access permissions to the assembly code.

See Also

Assembly Class


Assembly Constructor

[image] [image]

SQL Schema Sync API Class reference
Assembly Constructor
Assembly Class See Also Send Feedback

Overload List

Name | Description
Assembly()()() | Creates new instance of the Assembly class.
Assembly(String) | Creates new instance of the Assembly class.

See Also

Assembly Class
Assembly Members


Assembly Constructor

[image]

SQL Schema Sync API Class reference
Assembly Constructor
Assembly Class See Also Send Feedback
Creates new instance of the Assembly class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Assembly()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Assembly()

See Also

Assembly Class
Assembly Overload


Assembly Constructor (String)

[image]

SQL Schema Sync API Class reference
Assembly Constructor (String)
Assembly Class See Also Send Feedback
Creates new instance of the Assembly class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Assembly(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
Assembly(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Assembly Class
Assembly Overload


Assembly Methods

[image] [image]

SQL Schema Sync API Class reference
Assembly Methods
Assembly Class See Also Send Feedback

The Assembly type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualTo | Gets true value if two assemblies are equal, otherwise gets false value.
LoadContent | Loads the binary content by the file name.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Assembly Class


IsEqualTo Method

[image]

SQL Schema Sync API Class reference
Assembly..::.IsEqualTo Method
Assembly Class See Also Send Feedback
Gets true value if two assemblies are equal, otherwise gets false value.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEqualTo(
    Assembly assembly
)
Visual Basic (Declaration)
Public Function IsEqualTo ( _
    assembly As Assembly _
) As Boolean
Visual C++
public:
bool IsEqualTo(
    Assembly^ assembly
)

Parameters

assembly
Type: PerpetuumSoft.DataModel.MsSql..::.Assembly

See Also

Assembly Class


LoadContent Method

[image]

SQL Schema Sync API Class reference
Assembly..::.LoadContent Method
Assembly Class See Also Send Feedback
Loads the binary content by the file name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void LoadContent(
    string path
)
Visual Basic (Declaration)
Public Sub LoadContent ( _
    path As String _
)
Visual C++
public:
void LoadContent(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

Assembly Class


Assembly Properties

[image] [image]

SQL Schema Sync API Class reference
Assembly Properties
Assembly Class See Also Send Feedback

The Assembly type exposes the following members.

Properties

Name | Description
Content | Gets or sets String which is the binary content of assembly represented as a string.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for the assembly.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets Principal which is the assembly owner.
PermissionSet | Gets or sets PermissionSet which is a set of access permissions to the assembly code.

See Also

Assembly Class


Content Property

[image]

SQL Schema Sync API Class reference
Assembly..::.Content Property
Assembly Class See Also Send Feedback
Gets or sets String which is the binary content of assembly represented as a string.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Content { get; set; }
Visual Basic (Declaration)
Public Property Content As String
Visual C++
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

See Also

Assembly Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
Assembly..::.ExtendedProperties Property
Assembly Class See Also Send Feedback
Gets ExtendedProperties for the assembly.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

Assembly Class


Owner Property

[image]

SQL Schema Sync API Class reference
Assembly..::.Owner Property
Assembly Class See Also Send Feedback
Gets or sets Principal which is the assembly owner.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Principal Owner { get; set; }
Visual Basic (Declaration)
Public Property Owner As Principal
Visual C++
public:
property Principal^ Owner {
    Principal^ get ();
    void set (Principal^ value);
}

See Also

Assembly Class


PermissionSet Property

[image]

SQL Schema Sync API Class reference
Assembly..::.PermissionSet Property
Assembly Class See Also Send Feedback
Gets or sets PermissionSet which is a set of access permissions to the assembly code.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public PermissionSet PermissionSet { get; set; }
Visual Basic (Declaration)
Public Property PermissionSet As PermissionSet
Visual C++
public:
property PermissionSet PermissionSet {
    PermissionSet get ();
    void set (PermissionSet value);
}

See Also

Assembly Class


BoundingBox Class

[image]

SQL Schema Sync API Class reference
BoundingBox Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.BoundingBox"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class BoundingBox
Visual Basic (Declaration)
Public Class BoundingBox
Visual C++
public ref class BoundingBox

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.BoundingBox

See Also

BoundingBox Members


BoundingBox Members

[image] [image]

SQL Schema Sync API Class reference
BoundingBox Members
BoundingBox Class Constructors Methods Properties See Also Send Feedback

The BoundingBox type exposes the following members.

Constructors

Name | Description
BoundingBox | Initializes a new instance of the BoundingBox class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEquals |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
XMax |
XMin |
YMax |
YMin |

See Also

BoundingBox Class


BoundingBox Constructor

[image]

SQL Schema Sync API Class reference
BoundingBox Constructor
BoundingBox Class See Also Send Feedback
Initializes a new instance of the BoundingBox class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public BoundingBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoundingBox()

See Also

BoundingBox Class


BoundingBox Methods

[image] [image]

SQL Schema Sync API Class reference
BoundingBox Methods
BoundingBox Class See Also Send Feedback

The BoundingBox type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEquals |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBox Class


IsEquals Method

[image]

SQL Schema Sync API Class reference
BoundingBox..::.IsEquals Method
BoundingBox Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.BoundingBox.IsEquals(PerpetuumSoft.DataModel.MsSql.BoundingBox)"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEquals(
    BoundingBox otherBoundingBox
)
Visual Basic (Declaration)
Public Function IsEquals ( _
    otherBoundingBox As BoundingBox _
) As Boolean
Visual C++
public:
bool IsEquals(
    BoundingBox^ otherBoundingBox
)

Parameters

otherBoundingBox
Type: PerpetuumSoft.DataModel.MsSql..::.BoundingBox

See Also

BoundingBox Class


BoundingBox Properties

[image] [image]

SQL Schema Sync API Class reference
BoundingBox Properties
BoundingBox Class See Also Send Feedback

The BoundingBox type exposes the following members.

Properties

Name | Description
XMax |
XMin |
YMax |
YMin |

See Also

BoundingBox Class


XMax Property

[image]

SQL Schema Sync API Class reference
BoundingBox..::.XMax Property
BoundingBox Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.BoundingBox.XMax"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public double XMax { get; set; }
Visual Basic (Declaration)
Public Property XMax As Double
Visual C++
public:
property double XMax {
    double get ();
    void set (double value);
}

See Also

BoundingBox Class


XMin Property

[image]

SQL Schema Sync API Class reference
BoundingBox..::.XMin Property
BoundingBox Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.BoundingBox.XMin"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public double XMin { get; set; }
Visual Basic (Declaration)
Public Property XMin As Double
Visual C++
public:
property double XMin {
    double get ();
    void set (double value);
}

See Also

BoundingBox Class


YMax Property

[image]

SQL Schema Sync API Class reference
BoundingBox..::.YMax Property
BoundingBox Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.BoundingBox.YMax"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public double YMax { get; set; }
Visual Basic (Declaration)
Public Property YMax As Double
Visual C++
public:
property double YMax {
    double get ();
    void set (double value);
}

See Also

BoundingBox Class


YMin Property

[image]

SQL Schema Sync API Class reference
BoundingBox..::.YMin Property
BoundingBox Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.BoundingBox.YMin"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public double YMin { get; set; }
Visual Basic (Declaration)
Public Property YMin As Double
Visual C++
public:
property double YMin {
    double get ();
    void set (double value);
}

See Also

BoundingBox Class


CheckConstraint Class

[image]

SQL Schema Sync API Class reference
CheckConstraint Class
Members See Also Send Feedback
Represents the check constaint in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class CheckConstraint : Constraint
Visual Basic (Declaration)
Public NotInheritable Class CheckConstraint _
    Inherits Constraint
Visual C++
public ref class CheckConstraint sealed : public Constraint

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Constraint
PerpetuumSoft.DataModel.MsSql..::.CheckConstraint

See Also

CheckConstraint Members


CheckConstraint Members

[image] [image]

SQL Schema Sync API Class reference
CheckConstraint Members
CheckConstraint Class Constructors Methods Properties See Also Send Feedback

The CheckConstraint type exposes the following members.

Constructors

Name | Description
CheckConstraint | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
Expression | Gets or sets the checked expression.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)

See Also

CheckConstraint Class


CheckConstraint Constructor

[image] [image]

SQL Schema Sync API Class reference
CheckConstraint Constructor
CheckConstraint Class See Also Send Feedback

Overload List

Name | Description
CheckConstraint()()() | Initializes a new instance of the CheckConstraint class.
CheckConstraint(String, Table, String) | Initializes a new instance of the CheckConstraint class.

See Also

CheckConstraint Class
CheckConstraint Members


CheckConstraint Constructor

[image]

SQL Schema Sync API Class reference
CheckConstraint Constructor
CheckConstraint Class See Also Send Feedback
Initializes a new instance of the CheckConstraint class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public CheckConstraint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CheckConstraint()

See Also

CheckConstraint Class
CheckConstraint Overload


CheckConstraint Constructor (String, Table, String)

[image]

SQL Schema Sync API Class reference
CheckConstraint Constructor (String, Table, String)
CheckConstraint Class See Also Send Feedback
Initializes a new instance of the CheckConstraint class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public CheckConstraint(
    string name,
    Table table,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    table As Table, _
    expression As String _
)
Visual C++
public:
CheckConstraint(
    String^ name,
    Table^ table,
    String^ expression
)

Parameters

name
Type: System..::.String
table
Type: PerpetuumSoft.DataModel.MsSql..::.Table
expression
Type: System..::.String

See Also

CheckConstraint Class
CheckConstraint Overload


CheckConstraint Methods

[image] [image]

SQL Schema Sync API Class reference
CheckConstraint Methods
CheckConstraint Class See Also Send Feedback

The CheckConstraint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

CheckConstraint Class


CheckConstraint Properties

[image] [image]

SQL Schema Sync API Class reference
CheckConstraint Properties
CheckConstraint Class See Also Send Feedback

The CheckConstraint type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
Expression | Gets or sets the checked expression.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)

See Also

CheckConstraint Class


Expression Property

[image]

SQL Schema Sync API Class reference
CheckConstraint..::.Expression Property
CheckConstraint Class See Also Send Feedback
Gets or sets the checked expression.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

CheckConstraint Class


CLRFunctionBase Class

[image]

SQL Schema Sync API Class reference
CLRFunctionBase Class
Members See Also Send Feedback
Basic class for CLR functions.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class CLRFunctionBase : FunctionBase
Visual Basic (Declaration)
Public MustInherit Class CLRFunctionBase _
    Inherits FunctionBase
Visual C++
public ref class CLRFunctionBase abstract : public FunctionBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.CLRFunctionBase
PerpetuumSoft.DataModel.MsSql..::.ScalarCLRFunction
PerpetuumSoft.DataModel.MsSql..::.TableValuedCLRFunction

See Also

CLRFunctionBase Members


CLRFunctionBase Members

[image] [image]

SQL Schema Sync API Class reference
CLRFunctionBase Members
CLRFunctionBase Class Methods Properties See Also Send Feedback

The CLRFunctionBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Assembly | Gets or sets Assembly which contains this function.
ClassName | Gets or sets name of the class which contains this function.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MethodName | Gets or sets name of the method which defines this method in the assembly.
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

CLRFunctionBase Class


CLRFunctionBase Methods

[image] [image]

SQL Schema Sync API Class reference
CLRFunctionBase Methods
CLRFunctionBase Class See Also Send Feedback

The CLRFunctionBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

CLRFunctionBase Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
CLRFunctionBase..::.SetExecuteAsClause Method
CLRFunctionBase Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context. (Inherited from FunctionBase.)
SetExecuteAsClause(String) | Sets the function security context. (Inherited from FunctionBase.)

See Also

CLRFunctionBase Class
CLRFunctionBase Members


CLRFunctionBase Properties

[image] [image]

SQL Schema Sync API Class reference
CLRFunctionBase Properties
CLRFunctionBase Class See Also Send Feedback

The CLRFunctionBase type exposes the following members.

Properties

Name | Description
Assembly | Gets or sets Assembly which contains this function.
ClassName | Gets or sets name of the class which contains this function.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MethodName | Gets or sets name of the method which defines this method in the assembly.
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

CLRFunctionBase Class


Assembly Property

[image]

SQL Schema Sync API Class reference
CLRFunctionBase..::.Assembly Property
CLRFunctionBase Class See Also Send Feedback
Gets or sets Assembly which contains this function.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Assembly Assembly { get; set; }
Visual Basic (Declaration)
Public Property Assembly As Assembly
Visual C++
public:
property Assembly^ Assembly {
    Assembly^ get ();
    void set (Assembly^ value);
}

See Also

CLRFunctionBase Class


ClassName Property

[image]

SQL Schema Sync API Class reference
CLRFunctionBase..::.ClassName Property
CLRFunctionBase Class See Also Send Feedback
Gets or sets name of the class which contains this function.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string ClassName { get; set; }
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

See Also

CLRFunctionBase Class


MethodName Property

[image]

SQL Schema Sync API Class reference
CLRFunctionBase..::.MethodName Property
CLRFunctionBase Class See Also Send Feedback
Gets or sets name of the method which defines this method in the assembly.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string MethodName { get; set; }
Visual Basic (Declaration)
Public Property MethodName As String
Visual C++
public:
property String^ MethodName {
    String^ get ();
    void set (String^ value);
}

See Also

CLRFunctionBase Class


CLRType Class

[image]

SQL Schema Sync API Class reference
CLRType Class
Members See Also Send Feedback
Represents CLR type in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class CLRType : SchemaObject
Visual Basic (Declaration)
Public NotInheritable Class CLRType _
    Inherits SchemaObject
Visual C++
public ref class CLRType sealed : public SchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.CLRType

See Also

CLRType Members


CLRType Members

[image] [image]

SQL Schema Sync API Class reference
CLRType Members
CLRType Class Constructors Methods Properties See Also Send Feedback

The CLRType type exposes the following members.

Constructors

Name | Description
CLRType | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Assembly | Gets or sets Assembly which contains this type.
ClassName | Gets or sets name of the class which defines this type.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

CLRType Class


CLRType Constructor

[image] [image]

SQL Schema Sync API Class reference
CLRType Constructor
CLRType Class See Also Send Feedback

Overload List

Name | Description
CLRType()()() | Creates new instance of theCLRType class.
CLRType(String, String, Schema, Assembly) | Creates new instance of the CLRType class.

See Also

CLRType Class
CLRType Members


CLRType Constructor

[image]

SQL Schema Sync API Class reference
CLRType Constructor
CLRType Class See Also Send Feedback
Creates new instance of theCLRType class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public CLRType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CLRType()

See Also

CLRType Class
CLRType Overload


CLRType Constructor (String, String, Schema, Assembly)

[image]

SQL Schema Sync API Class reference
CLRType Constructor (String, String, Schema, Assembly)
CLRType Class See Also Send Feedback
Creates new instance of the CLRType class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public CLRType(
    string name,
    string className,
    Schema schema,
    Assembly assembly
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    className As String, _
    schema As Schema, _
    assembly As Assembly _
)
Visual C++
public:
CLRType(
    String^ name,
    String^ className,
    Schema^ schema,
    Assembly^ assembly
)

Parameters

name
Type: System..::.String
className
Type: System..::.String
schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema
assembly
Type: PerpetuumSoft.DataModel.MsSql..::.Assembly

See Also

CLRType Class
CLRType Overload


CLRType Methods

[image] [image]

SQL Schema Sync API Class reference
CLRType Methods
CLRType Class See Also Send Feedback

The CLRType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

CLRType Class


CLRType Properties

[image] [image]

SQL Schema Sync API Class reference
CLRType Properties
CLRType Class See Also Send Feedback

The CLRType type exposes the following members.

Properties

Name | Description
Assembly | Gets or sets Assembly which contains this type.
ClassName | Gets or sets name of the class which defines this type.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

CLRType Class


Assembly Property

[image]

SQL Schema Sync API Class reference
CLRType..::.Assembly Property
CLRType Class See Also Send Feedback
Gets or sets Assembly which contains this type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Assembly Assembly { get; set; }
Visual Basic (Declaration)
Public Property Assembly As Assembly
Visual C++
public:
property Assembly^ Assembly {
    Assembly^ get ();
    void set (Assembly^ value);
}

See Also

CLRType Class


ClassName Property

[image]

SQL Schema Sync API Class reference
CLRType..::.ClassName Property
CLRType Class See Also Send Feedback
Gets or sets name of the class which defines this type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string ClassName { get; set; }
Visual Basic (Declaration)
Public Property ClassName As String
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

See Also

CLRType Class


ColumnBase Class

[image]

SQL Schema Sync API Class reference
ColumnBase Class
Members See Also Send Feedback
Abstract base class for all column classes.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class ColumnBase : Element
Visual Basic (Declaration)
Public MustInherit Class ColumnBase _
    Inherits Element
Visual C++
public ref class ColumnBase abstract : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.ColumnBase
PerpetuumSoft.DataModel.MsSql..::.TableColumn
PerpetuumSoft.DataModel.MsSql..::.ViewColumn

See Also

ColumnBase Members


ColumnBase Members

[image] [image]

SQL Schema Sync API Class reference
ColumnBase Members
ColumnBase Class Constructors Methods Properties See Also Send Feedback

The ColumnBase type exposes the following members.

Constructors

Name | Description
ColumnBase | Initializes a new instance of the ColumnBase class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). (Overrides Element..::.ToString()()().)
TypeEquals | Gets true value if columns types are equal.

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values.
DataType | Gets or sets DataType of a column.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for a column.
FullName | Gets full name of the column. (Overrides Element..::.FullName.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets TableBase which contains a column.

See Also

ColumnBase Class


ColumnBase Constructor

[image]

SQL Schema Sync API Class reference
ColumnBase Constructor
ColumnBase Class See Also Send Feedback
Initializes a new instance of the ColumnBase class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected ColumnBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ColumnBase()

See Also

ColumnBase Class


ColumnBase Methods

[image] [image]

SQL Schema Sync API Class reference
ColumnBase Methods
ColumnBase Class See Also Send Feedback

The ColumnBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). (Overrides Element..::.ToString()()().)
TypeEquals | Gets true value if columns types are equal.

See Also

ColumnBase Class


ToString Method

[image]

SQL Schema Sync API Class reference
ColumnBase..::.ToString Method
ColumnBase Class See Also Send Feedback
Override. See ToString()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ColumnBase Class


TypeEquals Method

[image]

SQL Schema Sync API Class reference
ColumnBase..::.TypeEquals Method
ColumnBase Class See Also Send Feedback
Gets true value if columns types are equal.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract bool TypeEquals(
    ColumnBase other
)
Visual Basic (Declaration)
Public MustOverride Function TypeEquals ( _
    other As ColumnBase _
) As Boolean
Visual C++
public:
virtual bool TypeEquals(
    ColumnBase^ other
) abstract

Parameters

other
Type: PerpetuumSoft.DataModel.MsSql..::.ColumnBase

See Also

ColumnBase Class


ColumnBase Properties

[image] [image]

SQL Schema Sync API Class reference
ColumnBase Properties
ColumnBase Class See Also Send Feedback

The ColumnBase type exposes the following members.

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values.
DataType | Gets or sets DataType of a column.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for a column.
FullName | Gets full name of the column. (Overrides Element..::.FullName.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets TableBase which contains a column.

See Also

ColumnBase Class


AllowNulls Property

[image]

SQL Schema Sync API Class reference
ColumnBase..::.AllowNulls Property
ColumnBase Class See Also Send Feedback
If the property value is true, then the column can contain Null values.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowNulls { get; set; }
Visual Basic (Declaration)
Public Property AllowNulls As Boolean
Visual C++
public:
property bool AllowNulls {
    bool get ();
    void set (bool value);
}

See Also

ColumnBase Class


DataType Property

[image]

SQL Schema Sync API Class reference
ColumnBase..::.DataType Property
ColumnBase Class See Also Send Feedback
Gets or sets DataType of a column.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DataType DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As DataType
Visual C++
public:
property DataType^ DataType {
    DataType^ get ();
    void set (DataType^ value);
}

See Also

ColumnBase Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
ColumnBase..::.ExtendedProperties Property
ColumnBase Class See Also Send Feedback
Gets ExtendedProperties for a column.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

ColumnBase Class


FullName Property

[image]

SQL Schema Sync API Class reference
ColumnBase..::.FullName Property
ColumnBase Class See Also Send Feedback
Gets full name of the column.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string FullName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property FullName As String
Visual C++
public:
virtual property String^ FullName {
    String^ get () override;
}

See Also

ColumnBase Class


Owner Property

[image]

SQL Schema Sync API Class reference
ColumnBase..::.Owner Property
ColumnBase Class See Also Send Feedback
Gets TableBase which contains a column.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableBase Owner { get; internal set; }
Visual Basic (Declaration)
Public Property Owner As TableBase
Visual C++
public:
property TableBase^ Owner {
    TableBase^ get ();
    void set (TableBase^ value);
}

See Also

ColumnBase Class


ColumnBaseCollection Class

[image]

SQL Schema Sync API Class reference
ColumnBaseCollection Class
Members See Also Send Feedback
Basic class for table columns, views and computable columns.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ColumnBaseCollection : Collection<ColumnBase>
Visual Basic (Declaration)
Public NotInheritable Class ColumnBaseCollection _
    Inherits Collection(Of ColumnBase)
Visual C++
public ref class ColumnBaseCollection sealed : public Collection<ColumnBase^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( ColumnBase >)>)
PerpetuumSoft.DataModel.MsSql..::.ColumnBaseCollection

See Also

ColumnBaseCollection Members


ColumnBaseCollection Members

[image] [image]

SQL Schema Sync API Class reference
ColumnBaseCollection Members
ColumnBaseCollection Class Methods Properties See Also Send Feedback

The ColumnBaseCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( ColumnBase >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ColumnBase >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ColumnBase >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( ColumnBase >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
Owner | Gets TableBase which contains this column.

See Also

ColumnBaseCollection Class


ColumnBaseCollection Methods

[image] [image]

SQL Schema Sync API Class reference
ColumnBaseCollection Methods
ColumnBaseCollection Class See Also Send Feedback

The ColumnBaseCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( ColumnBase >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ColumnBase >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ColumnBase >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( ColumnBase >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColumnBaseCollection Class


ColumnBaseCollection Properties

[image] [image]

SQL Schema Sync API Class reference
ColumnBaseCollection Properties
ColumnBaseCollection Class See Also Send Feedback

The ColumnBaseCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnBase >)>).)
Owner | Gets TableBase which contains this column.

See Also

ColumnBaseCollection Class


Item Property

[image] [image]

SQL Schema Sync API Class reference
ColumnBaseCollection..::.Item Property
ColumnBaseCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( ColumnBase >)>).)
Item[([(String])]) | Gets ColumnBase by name.

See Also

ColumnBaseCollection Class
ColumnBaseCollection Members


Item Property (String)

[image]

SQL Schema Sync API Class reference
ColumnBaseCollection..::.Item Property (String)
ColumnBaseCollection Class See Also Send Feedback
Gets ColumnBase by name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ColumnBase this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As ColumnBase
Visual C++
public:
property ColumnBase^ default[String^ name] {
    ColumnBase^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

ColumnBaseCollection Class
Item Overload


Owner Property

[image]

SQL Schema Sync API Class reference
ColumnBaseCollection..::.Owner Property
ColumnBaseCollection Class See Also Send Feedback
Gets TableBase which contains this column.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableBase Owner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Owner As TableBase
Visual C++
public:
property TableBase^ Owner {
    TableBase^ get ();
}

See Also

ColumnBaseCollection Class


ColumnRef Class

[image]

SQL Schema Sync API Class reference
ColumnRef Class
Members See Also Send Feedback
Represents reference to a column.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ColumnRef
Visual Basic (Declaration)
Public NotInheritable Class ColumnRef
Visual C++
public ref class ColumnRef sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.ColumnRef

See Also

ColumnRef Members


ColumnRef Members

[image] [image]

SQL Schema Sync API Class reference
ColumnRef Members
ColumnRef Class Constructors Methods Properties See Also Send Feedback

The ColumnRef type exposes the following members.

Constructors

Name | Description
ColumnRef | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Column | Gets or sets ColumnBase associated with an object.

See Also

ColumnRef Class


ColumnRef Constructor

[image] [image]

SQL Schema Sync API Class reference
ColumnRef Constructor
ColumnRef Class See Also Send Feedback

Overload List

Name | Description
ColumnRef()()() | Initializes a new instance of the ColumnRef class.
ColumnRef(ColumnBase) | Initializes a new instance of the ColumnRef class.

See Also

ColumnRef Class
ColumnRef Members


ColumnRef Constructor

[image]

SQL Schema Sync API Class reference
ColumnRef Constructor
ColumnRef Class See Also Send Feedback
Initializes a new instance of the ColumnRef class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ColumnRef()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColumnRef()

See Also

ColumnRef Class
ColumnRef Overload


ColumnRef Constructor (ColumnBase)

[image]

SQL Schema Sync API Class reference
ColumnRef Constructor (ColumnBase)
ColumnRef Class See Also Send Feedback
Initializes a new instance of the ColumnRef class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ColumnRef(
    ColumnBase column
)
Visual Basic (Declaration)
Public Sub New ( _
    column As ColumnBase _
)
Visual C++
public:
ColumnRef(
    ColumnBase^ column
)

Parameters

column
Type: PerpetuumSoft.DataModel.MsSql..::.ColumnBase

See Also

ColumnRef Class
ColumnRef Overload


ColumnRef Methods

[image] [image]

SQL Schema Sync API Class reference
ColumnRef Methods
ColumnRef Class See Also Send Feedback

The ColumnRef type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

ColumnRef Class


ToString Method

[image]

SQL Schema Sync API Class reference
ColumnRef..::.ToString Method
ColumnRef Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ColumnRef Class


ColumnRef Properties

[image] [image]

SQL Schema Sync API Class reference
ColumnRef Properties
ColumnRef Class See Also Send Feedback

The ColumnRef type exposes the following members.

Properties

Name | Description
Column | Gets or sets ColumnBase associated with an object.

See Also

ColumnRef Class


Column Property

[image]

SQL Schema Sync API Class reference
ColumnRef..::.Column Property
ColumnRef Class See Also Send Feedback
Gets or sets ColumnBase associated with an object.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ColumnBase Column { get; set; }
Visual Basic (Declaration)
Public Property Column As ColumnBase
Visual C++
public:
property ColumnBase^ Column {
    ColumnBase^ get ();
    void set (ColumnBase^ value);
}

See Also

ColumnRef Class


ColumnRefCollection Class

[image]

SQL Schema Sync API Class reference
ColumnRefCollection Class
Members See Also Send Feedback
Represents a collection of ColumnRef.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ColumnRefCollection : Collection<ColumnRef>
Visual Basic (Declaration)
Public NotInheritable Class ColumnRefCollection _
    Inherits Collection(Of ColumnRef)
Visual C++
public ref class ColumnRefCollection sealed : public Collection<ColumnRef^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( ColumnRef >)>)
PerpetuumSoft.DataModel.MsSql..::.ColumnRefCollection

See Also

ColumnRefCollection Members


ColumnRefCollection Members

[image] [image]

SQL Schema Sync API Class reference
ColumnRefCollection Members
ColumnRefCollection Class Methods Properties See Also Send Feedback

The ColumnRefCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( ColumnRef >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ColumnRef >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ColumnRef >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( ColumnRef >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( ColumnRef >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)

See Also

ColumnRefCollection Class


ColumnRefCollection Methods

[image] [image]

SQL Schema Sync API Class reference
ColumnRefCollection Methods
ColumnRefCollection Class See Also Send Feedback

The ColumnRefCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( ColumnRef >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ColumnRef >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ColumnRef >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( ColumnRef >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColumnRefCollection Class


ColumnRefCollection Properties

[image] [image]

SQL Schema Sync API Class reference
ColumnRefCollection Properties
ColumnRefCollection Class See Also Send Feedback

The ColumnRefCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( ColumnRef >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ColumnRef >)>).)

See Also

ColumnRefCollection Class


ComputedColumn Class

[image]

SQL Schema Sync API Class reference
ComputedColumn Class
Members See Also Send Feedback
Represents the computed column in a table.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ComputedColumn : TableColumn
Visual Basic (Declaration)
Public NotInheritable Class ComputedColumn _
    Inherits TableColumn
Visual C++
public ref class ComputedColumn sealed : public TableColumn

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.ColumnBase
PerpetuumSoft.DataModel.MsSql..::.TableColumn
PerpetuumSoft.DataModel.MsSql..::.ComputedColumn

See Also

ComputedColumn Members


ComputedColumn Members

[image] [image]

SQL Schema Sync API Class reference
ComputedColumn Members
ComputedColumn Class Constructors Methods Properties See Also Send Feedback

The ComputedColumn type exposes the following members.

Constructors

Name | Description
ComputedColumn | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). (Inherited from ColumnBase.)
TypeEquals | Override. See TypeEquals(ColumnBase). (Overrides ColumnBase..::.TypeEquals(ColumnBase).)

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values. (Inherited from ColumnBase.)
DataType | Gets or sets DataType of a column. (Inherited from ColumnBase.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
Expression | Gets or sets the column expression.
ExtendedProperties | Gets ExtendedProperties for a column. (Inherited from ColumnBase.)
FullName | Gets full name of the column. (Inherited from ColumnBase.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets TableBase which contains a column. (Inherited from ColumnBase.)
Persisted | Gets or sets if a column is persisted.

See Also

ComputedColumn Class


ComputedColumn Constructor

[image] [image]

SQL Schema Sync API Class reference
ComputedColumn Constructor
ComputedColumn Class See Also Send Feedback

Overload List

Name | Description
ComputedColumn()()() | Initializes a new instance of the ComputedColumn class.
ComputedColumn(String, String) | Creates new instance of the ComputedColumn class.

See Also

ComputedColumn Class
ComputedColumn Members


ComputedColumn Constructor

[image]

SQL Schema Sync API Class reference
ComputedColumn Constructor
ComputedColumn Class See Also Send Feedback
Initializes a new instance of the ComputedColumn class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ComputedColumn()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ComputedColumn()

See Also

ComputedColumn Class
ComputedColumn Overload


ComputedColumn Constructor (String, String)

[image]

SQL Schema Sync API Class reference
ComputedColumn Constructor (String, String)
ComputedColumn Class See Also Send Feedback
Creates new instance of the ComputedColumn class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ComputedColumn(
    string name,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    expression As String _
)
Visual C++
public:
ComputedColumn(
    String^ name,
    String^ expression
)

Parameters

name
Type: System..::.String
expression
Type: System..::.String

See Also

ComputedColumn Class
ComputedColumn Overload


ComputedColumn Methods

[image] [image]

SQL Schema Sync API Class reference
ComputedColumn Methods
ComputedColumn Class See Also Send Feedback

The ComputedColumn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). (Inherited from ColumnBase.)
TypeEquals | Override. See TypeEquals(ColumnBase). (Overrides ColumnBase..::.TypeEquals(ColumnBase).)

See Also

ComputedColumn Class


TypeEquals Method

[image]

SQL Schema Sync API Class reference
ComputedColumn..::.TypeEquals Method
ComputedColumn Class See Also Send Feedback
Override. See TypeEquals(ColumnBase).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool TypeEquals(
    ColumnBase other
)
Visual Basic (Declaration)
Public Overrides Function TypeEquals ( _
    other As ColumnBase _
) As Boolean
Visual C++
public:
virtual bool TypeEquals(
    ColumnBase^ other
) override

Parameters

other
Type: PerpetuumSoft.DataModel.MsSql..::.ColumnBase

See Also

ComputedColumn Class


ComputedColumn Properties

[image] [image]

SQL Schema Sync API Class reference
ComputedColumn Properties
ComputedColumn Class See Also Send Feedback

The ComputedColumn type exposes the following members.

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values. (Inherited from ColumnBase.)
DataType | Gets or sets DataType of a column. (Inherited from ColumnBase.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
Expression | Gets or sets the column expression.
ExtendedProperties | Gets ExtendedProperties for a column. (Inherited from ColumnBase.)
FullName | Gets full name of the column. (Inherited from ColumnBase.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets TableBase which contains a column. (Inherited from ColumnBase.)
Persisted | Gets or sets if a column is persisted.

See Also

ComputedColumn Class


Expression Property

[image]

SQL Schema Sync API Class reference
ComputedColumn..::.Expression Property
ComputedColumn Class See Also Send Feedback
Gets or sets the column expression.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

ComputedColumn Class


Persisted Property

[image]

SQL Schema Sync API Class reference
ComputedColumn..::.Persisted Property
ComputedColumn Class See Also Send Feedback
Gets or sets if a column is persisted.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Persisted { get; set; }
Visual Basic (Declaration)
Public Property Persisted As Boolean
Visual C++
public:
property bool Persisted {
    bool get ();
    void set (bool value);
}

See Also

ComputedColumn Class


Constraint Class

[image]

SQL Schema Sync API Class reference
Constraint Class
Members See Also Send Feedback
Abstract base class for all constraint classes.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class Constraint : DatabaseObject,
    ISchemaObject
Visual Basic (Declaration)
Public MustInherit Class Constraint _
    Inherits DatabaseObject _
    Implements ISchemaObject
Visual C++
public ref class Constraint abstract : public DatabaseObject,
    ISchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Constraint
PerpetuumSoft.DataModel.MsSql..::.CheckConstraint
PerpetuumSoft.DataModel.MsSql..::.DefaultConstraint
PerpetuumSoft.DataModel.MsSql..::.ForeignKey
PerpetuumSoft.DataModel.MsSql..::.KeyConstraint

See Also

Constraint Members


Constraint Members

[image] [image]

SQL Schema Sync API Class reference
Constraint Members
Constraint Class Methods Properties See Also Send Feedback

The Constraint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Overrides Element..::.RelatesTo(Element).)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. Returns schema object associated with Constraint.
Table | Gets or sets Table associated with constraint.

See Also

Constraint Class


Constraint Methods

[image] [image]

SQL Schema Sync API Class reference
Constraint Methods
Constraint Class See Also Send Feedback

The Constraint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Overrides Element..::.RelatesTo(Element).)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Constraint Class


RelatesTo Method

[image]

SQL Schema Sync API Class reference
Constraint..::.RelatesTo Method
Constraint Class See Also Send Feedback
Overridden. See RelatesTo(Element).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool RelatesTo(
    Element element
)
Visual Basic (Declaration)
Public Overrides Function RelatesTo ( _
    element As Element _
) As Boolean
Visual C++
public:
virtual bool RelatesTo(
    Element^ element
) override

Parameters

element
Type: PerpetuumSoft.DataModel.MsSql..::.Element

See Also

Constraint Class


Constraint Properties

[image] [image]

SQL Schema Sync API Class reference
Constraint Properties
Constraint Class See Also Send Feedback

The Constraint type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. Returns schema object associated with Constraint.
Table | Gets or sets Table associated with constraint.

See Also

Constraint Class


Schema Property

[image]

SQL Schema Sync API Class reference
Constraint..::.Schema Property
Constraint Class See Also Send Feedback
Implements Schema. Returns schema object associated with Constraint.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Schema Schema { get; }
Visual Basic (Declaration)
Public ReadOnly Property Schema As Schema
Visual C++
public:
virtual property Schema^ Schema {
    Schema^ get () sealed;
}

Implements

ISchemaObject..::.Schema

See Also

Constraint Class


Table Property

[image]

SQL Schema Sync API Class reference
Constraint..::.Table Property
Constraint Class See Also Send Feedback
Gets or sets Table associated with constraint.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Table Table { get; set; }
Visual Basic (Declaration)
Public Property Table As Table
Visual C++
public:
property Table^ Table {
    Table^ get ();
    void set (Table^ value);
}

See Also

Constraint Class


Database Class

[image]

SQL Schema Sync API Class reference
Database Class
Members See Also Send Feedback
Represents the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Database : ISecurable
Visual Basic (Declaration)
Public NotInheritable Class Database _
    Implements ISecurable
Visual C++
public ref class Database sealed : ISecurable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Database

See Also

Database Members


Database Members

[image] [image]

SQL Schema Sync API Class reference
Database Members
Database Class Constructors Methods Properties See Also Send Feedback

The Database type exposes the following members.

Constructors

Name | Description
Database | Overloaded.

Methods

Name | Description
CreateDatabaseWithSystemObjects | Creates database with system objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.

Properties

Name | Description
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the Database .
FullName |
Name | Gets or sets database name.
Objects | Gets DatabaseObjectCollection
Options | Gets or sets DatabaseOptions.
SqlVersion |

See Also

Database Class


Database Constructor

[image] [image]

SQL Schema Sync API Class reference
Database Constructor
Database Class See Also Send Feedback

Overload List

Name | Description
Database()()() | Initializes a new instance of the Database class.
Database(SqlVersionEnum) | Initializes a new instance of the Database class

See Also

Database Class
Database Members


Database Constructor

[image]

SQL Schema Sync API Class reference
Database Constructor
Database Class See Also Send Feedback
Initializes a new instance of the Database class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Database()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Database()

See Also

Database Class
Database Overload


Database Constructor (SqlVersionEnum)

[image]

SQL Schema Sync API Class reference
Database Constructor (SqlVersionEnum)
Database Class See Also Send Feedback
Initializes a new instance of the Database class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Database(
    SqlVersionEnum sqlVersion
)
Visual Basic (Declaration)
Public Sub New ( _
    sqlVersion As SqlVersionEnum _
)
Visual C++
public:
Database(
    SqlVersionEnum sqlVersion
)

Parameters

sqlVersion
Type: PerpetuumSoft.DataModel.MsSql..::.SqlVersionEnum

See Also

Database Class
Database Overload


Database Methods

[image] [image]

SQL Schema Sync API Class reference
Database Methods
Database Class See Also Send Feedback

The Database type exposes the following members.

Methods

Name | Description
CreateDatabaseWithSystemObjects | Creates database with system objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.

See Also

Database Class


CreateDatabaseWithSystemObjects Method

[image]

SQL Schema Sync API Class reference
Database..::.CreateDatabaseWithSystemObjects Method
Database Class See Also Send Feedback
Creates database with system objects.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static Database CreateDatabaseWithSystemObjects()
Visual Basic (Declaration)
Public Shared Function CreateDatabaseWithSystemObjects As Database
Visual C++
public:
static Database^ CreateDatabaseWithSystemObjects()

See Also

Database Class


Read Method

[image] [image]

SQL Schema Sync API Class reference
Database..::.Read Method
Database Class See Also Send Feedback

Overload List

Name | Description
Read(Stream) | Reads the database structure from a stream.
Read(TextReader) | Reads the database structure from the TextWriter.
Read(String) | Reads the database structure from a file.
Read(Stream, SerializationMode) | Reads database srtucture from a file with the selected serialization mode.
Read(String, SerializationMode) | Reads database structure from a file with the selected serialization mode.

See Also

Database Class
Database Members


Read Method (Stream)

[image]

SQL Schema Sync API Class reference
Database..::.Read Method (Stream)
Database Class See Also Send Feedback
Reads the database structure from a stream.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static Database Read(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    stream As Stream _
) As Database
Visual C++
public:
static Database^ Read(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

Database Class
Read Overload


Read Method (TextReader)

[image]

SQL Schema Sync API Class reference
Database..::.Read Method (TextReader)
Database Class See Also Send Feedback
Reads the database structure from the TextWriter.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static Database Read(
    TextReader reader
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    reader As TextReader _
) As Database
Visual C++
public:
static Database^ Read(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::.TextReader

See Also

Database Class
Read Overload


Read Method (String)

[image]

SQL Schema Sync API Class reference
Database..::.Read Method (String)
Database Class See Also Send Feedback
Reads the database structure from a file.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static Database Read(
    string fileName
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    fileName As String _
) As Database
Visual C++
public:
static Database^ Read(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

Database Class
Read Overload


Read Method (Stream, )

[image]

SQL Schema Sync API Class reference
Database..::.Read Method (Stream, )
Database Class See Also Send Feedback
Reads database srtucture from a file with the selected serialization mode.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static Database Read(
    Stream stream,
    SerializationMode mode
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    stream As Stream, _
    mode As SerializationMode _
) As Database
Visual C++
public:
static Database^ Read(
    Stream^ stream,
    SerializationMode mode
)

Parameters

stream
Type: System.IO..::.Stream
mode
Type: SerializationMode

See Also

Database Class
Read Overload


Read Method (String, )

[image]

SQL Schema Sync API Class reference
Database..::.Read Method (String, )
Database Class See Also Send Feedback
Reads database structure from a file with the selected serialization mode.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static Database Read(
    string fileName,
    SerializationMode mode
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    fileName As String, _
    mode As SerializationMode _
) As Database
Visual C++
public:
static Database^ Read(
    String^ fileName,
    SerializationMode mode
)

Parameters

fileName
Type: System..::.String
mode
Type: SerializationMode

See Also

Database Class
Read Overload


Write Method

[image] [image]

SQL Schema Sync API Class reference
Database..::.Write Method
Database Class See Also Send Feedback

Overload List

Name | Description
Write(Stream) | Writes the database structure to a stream.
Write(TextWriter) | Writes the database structure to the TextWriter.
Write(String) | Writes the database structure to a file.
Write(Stream, SerializationMode) | Writes database structure to a stream with the selected serialization mode.
Write(String, SerializationMode) | Writes database structure to a file with the selected serialization mode.

See Also

Database Class
Database Members


Write Method (Stream)

[image]

SQL Schema Sync API Class reference
Database..::.Write Method (Stream)
Database Class See Also Send Feedback
Writes the database structure to a stream.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void Write(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Write ( _
    stream As Stream _
)
Visual C++
public:
void Write(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

Database Class
Write Overload


Write Method (TextWriter)

[image]

SQL Schema Sync API Class reference
Database..::.Write Method (TextWriter)
Database Class See Also Send Feedback
Writes the database structure to the TextWriter.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void Write(
    TextWriter writer
)
Visual Basic (Declaration)
Public Sub Write ( _
    writer As TextWriter _
)
Visual C++
public:
void Write(
    TextWriter^ writer
)

Parameters

writer
Type: System.IO..::.TextWriter

See Also

Database Class
Write Overload


Write Method (String)

[image]

SQL Schema Sync API Class reference
Database..::.Write Method (String)
Database Class See Also Send Feedback
Writes the database structure to a file.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void Write(
    string fileName
)
Visual Basic (Declaration)
Public Sub Write ( _
    fileName As String _
)
Visual C++
public:
void Write(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

Database Class
Write Overload


Write Method (Stream, )

[image]

SQL Schema Sync API Class reference
Database..::.Write Method (Stream, )
Database Class See Also Send Feedback
Writes database structure to a stream with the selected serialization mode.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void Write(
    Stream stream,
    SerializationMode mode
)
Visual Basic (Declaration)
Public Sub Write ( _
    stream As Stream, _
    mode As SerializationMode _
)
Visual C++
public:
void Write(
    Stream^ stream,
    SerializationMode mode
)

Parameters

stream
Type: System.IO..::.Stream
mode
Type: SerializationMode

See Also

Database Class
Write Overload


Write Method (String, )

[image]

SQL Schema Sync API Class reference
Database..::.Write Method (String, )
Database Class See Also Send Feedback
Writes database structure to a file with the selected serialization mode.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void Write(
    string fileName,
    SerializationMode mode
)
Visual Basic (Declaration)
Public Sub Write ( _
    fileName As String, _
    mode As SerializationMode _
)
Visual C++
public:
void Write(
    String^ fileName,
    SerializationMode mode
)

Parameters

fileName
Type: System..::.String
mode
Type: SerializationMode

See Also

Database Class
Write Overload


Database Properties

[image] [image]

SQL Schema Sync API Class reference
Database Properties
Database Class See Also Send Feedback

The Database type exposes the following members.

Properties

Name | Description
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the Database .
FullName |
Name | Gets or sets database name.
Objects | Gets DatabaseObjectCollection
Options | Gets or sets DatabaseOptions.
SqlVersion |

See Also

Database Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
Database..::.ExtendedProperties Property
Database Class See Also Send Feedback
Implements ExtendedProperties()()(). Gets extended properties for the Database .

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

Database Class


FullName Property

[image]

SQL Schema Sync API Class reference
Database..::.FullName Property
Database Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.Database.FullName"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string FullName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullName As String
Visual C++
public:
virtual property String^ FullName {
    String^ get () sealed;
}

Implements

ISecurable..::.FullName

See Also

Database Class


Name Property

[image]

SQL Schema Sync API Class reference
Database..::.Name Property
Database Class See Also Send Feedback
Gets or sets database name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Database Class


Objects Property

[image]

SQL Schema Sync API Class reference
Database..::.Objects Property
Database Class See Also Send Feedback
Gets DatabaseObjectCollection

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseObjectCollection Objects { get; }
Visual Basic (Declaration)
Public ReadOnly Property Objects As DatabaseObjectCollection
Visual C++
public:
property DatabaseObjectCollection^ Objects {
    DatabaseObjectCollection^ get ();
}

See Also

Database Class


Options Property

[image]

SQL Schema Sync API Class reference
Database..::.Options Property
Database Class See Also Send Feedback
Gets or sets DatabaseOptions.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseOptions Options { get; set; }
Visual Basic (Declaration)
Public Property Options As DatabaseOptions
Visual C++
public:
property DatabaseOptions^ Options {
    DatabaseOptions^ get ();
    void set (DatabaseOptions^ value);
}

See Also

Database Class


SqlVersion Property

[image]

SQL Schema Sync API Class reference
Database..::.SqlVersion Property
Database Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.Database.SqlVersion"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SqlVersionEnum SqlVersion { get; set; }
Visual Basic (Declaration)
Public Property SqlVersion As SqlVersionEnum
Visual C++
public:
property SqlVersionEnum SqlVersion {
    SqlVersionEnum get ();
    void set (SqlVersionEnum value);
}

See Also

Database Class


DatabaseObject Class

[image]

SQL Schema Sync API Class reference
DatabaseObject Class
Members See Also Send Feedback
Abstract base class for all database entities.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class DatabaseObject : Element
Visual Basic (Declaration)
Public MustInherit Class DatabaseObject _
    Inherits Element
Visual C++
public ref class DatabaseObject abstract : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Assembly
PerpetuumSoft.DataModel.MsSql..::.Constraint
PerpetuumSoft.DataModel.MsSql..::.DdlTrigger
PerpetuumSoft.DataModel.MsSql..::.IndexBase
PerpetuumSoft.DataModel.MsSql..::.Principal
PerpetuumSoft.DataModel.MsSql..::.Schema
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.Trigger

See Also

DatabaseObject Members


DatabaseObject Members

[image] [image]

SQL Schema Sync API Class reference
DatabaseObject Members
DatabaseObject Class Constructors Methods Properties See Also Send Feedback

The DatabaseObject type exposes the following members.

Constructors

Name | Description
DatabaseObject | Initializes a new instance of the DatabaseObject class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)

See Also

DatabaseObject Class


DatabaseObject Constructor

[image]

SQL Schema Sync API Class reference
DatabaseObject Constructor
DatabaseObject Class See Also Send Feedback
Initializes a new instance of the DatabaseObject class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected DatabaseObject()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
DatabaseObject()

See Also

DatabaseObject Class


DatabaseObject Methods

[image] [image]

SQL Schema Sync API Class reference
DatabaseObject Methods
DatabaseObject Class See Also Send Feedback

The DatabaseObject type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

DatabaseObject Class


DatabaseObject Properties

[image] [image]

SQL Schema Sync API Class reference
DatabaseObject Properties
DatabaseObject Class See Also Send Feedback

The DatabaseObject type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)

See Also

DatabaseObject Class


Database Property

[image]

SQL Schema Sync API Class reference
DatabaseObject..::.Database Property
DatabaseObject Class See Also Send Feedback
Gets the Database owner.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Database Database { get; internal set; }
Visual Basic (Declaration)
Public Property Database As Database
Visual C++
public:
property Database^ Database {
    Database^ get ();
    void set (Database^ value);
}

See Also

DatabaseObject Class


DatabaseObjectCollection Class

[image]

SQL Schema Sync API Class reference
DatabaseObjectCollection Class
Members See Also Send Feedback
Represents a collection of DatabaseObject.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class DatabaseObjectCollection : Collection<DatabaseObject>
Visual Basic (Declaration)
Public NotInheritable Class DatabaseObjectCollection _
    Inherits Collection(Of DatabaseObject)
Visual C++
public ref class DatabaseObjectCollection sealed : public Collection<DatabaseObject^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( DatabaseObject >)>)
PerpetuumSoft.DataModel.MsSql..::.DatabaseObjectCollection

See Also

DatabaseObjectCollection Members


DatabaseObjectCollection Members

[image] [image]

SQL Schema Sync API Class reference
DatabaseObjectCollection Members
DatabaseObjectCollection Class Methods Properties See Also Send Feedback

The DatabaseObjectCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( DatabaseObject >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetElement<(Of <(T>)>) |
GetElements<(Of <(T>)>) |
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObject<(Of <(T>)>) |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( DatabaseObject >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( DatabaseObject >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( DatabaseObject >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
Parent | Gets a collection owner Database.

See Also

DatabaseObjectCollection Class


DatabaseObjectCollection Methods

[image] [image]

SQL Schema Sync API Class reference
DatabaseObjectCollection Methods
DatabaseObjectCollection Class See Also Send Feedback

The DatabaseObjectCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( DatabaseObject >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetElement<(Of <(T>)>) |
GetElements<(Of <(T>)>) |
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObject<(Of <(T>)>) |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( DatabaseObject >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( DatabaseObject >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( DatabaseObject >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseObjectCollection Class


GetElement(T) Method

[image]

SQL Schema Sync API Class reference
DatabaseObjectCollection..::.GetElement<(Of <(T>)>) Method
DatabaseObjectCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DatabaseObjectCollection.GetElement``1(System.String)"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public T GetElement<T>(
    string name
)
where T : DatabaseObject
Visual Basic (Declaration)
Public Function GetElement(Of T As DatabaseObject) ( _
    name As String _
) As T
Visual C++
public:
generic<typename T>
where T : DatabaseObject
T GetElement(
    String^ name
)

Parameters

name
Type: System..::.String

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:PerpetuumSoft.DataModel.MsSql.DatabaseObjectCollection.GetElement``1(System.String)"]

See Also

DatabaseObjectCollection Class


GetElements(T) Method

[image]

SQL Schema Sync API Class reference
DatabaseObjectCollection..::.GetElements<(Of <(T>)>) Method
DatabaseObjectCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DatabaseObjectCollection.GetElements``1"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IEnumerable<T> GetElements<T>()
where T : DatabaseObject
Visual Basic (Declaration)
Public Function GetElements(Of T As DatabaseObject) As IEnumerable(Of T)
Visual C++
public:
generic<typename T>
where T : DatabaseObject
IEnumerable<T>^ GetElements()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:PerpetuumSoft.DataModel.MsSql.DatabaseObjectCollection.GetElements``1"]

See Also

DatabaseObjectCollection Class


GetObject(T) Method

[image]

SQL Schema Sync API Class reference
DatabaseObjectCollection..::.GetObject<(Of <(T>)>) Method
DatabaseObjectCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DatabaseObjectCollection.GetObject``1(System.String,System.String)"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public T GetObject<T>(
    string schemaName,
    string objectName
)
where T : SchemaObject
Visual Basic (Declaration)
Public Function GetObject(Of T As SchemaObject) ( _
    schemaName As String, _
    objectName As String _
) As T
Visual C++
public:
generic<typename T>
where T : SchemaObject
T GetObject(
    String^ schemaName,
    String^ objectName
)

Parameters

schemaName
Type: System..::.String
objectName
Type: System..::.String

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:PerpetuumSoft.DataModel.MsSql.DatabaseObjectCollection.GetObject``1(System.String,System.String)"]

See Also

DatabaseObjectCollection Class


DatabaseObjectCollection Properties

[image] [image]

SQL Schema Sync API Class reference
DatabaseObjectCollection Properties
DatabaseObjectCollection Class See Also Send Feedback

The DatabaseObjectCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( DatabaseObject >)>).)
Parent | Gets a collection owner Database.

See Also

DatabaseObjectCollection Class


Item Property

[image] [image]

SQL Schema Sync API Class reference
DatabaseObjectCollection..::.Item Property
DatabaseObjectCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( DatabaseObject >)>).)
Item[([(String])]) | Gets DatabaseObject at specified index.

See Also

DatabaseObjectCollection Class
DatabaseObjectCollection Members


Item Property (String)

[image]

SQL Schema Sync API Class reference
DatabaseObjectCollection..::.Item Property (String)
DatabaseObjectCollection Class See Also Send Feedback
Gets DatabaseObject at specified index.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseObject this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As DatabaseObject
Visual C++
public:
property DatabaseObject^ default[String^ name] {
    DatabaseObject^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

DatabaseObjectCollection Class
Item Overload


Parent Property

[image]

SQL Schema Sync API Class reference
DatabaseObjectCollection..::.Parent Property
DatabaseObjectCollection Class See Also Send Feedback
Gets a collection owner Database.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Database Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As Database
Visual C++
public:
property Database^ Parent {
    Database^ get ();
}

See Also

DatabaseObjectCollection Class


DatabaseOptions Class

[image]

SQL Schema Sync API Class reference
DatabaseOptions Class
Members See Also Send Feedback
Represents Database options.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class DatabaseOptions
Visual Basic (Declaration)
Public Class DatabaseOptions
Visual C++
public ref class DatabaseOptions

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DatabaseOptions

See Also

DatabaseOptions Members


DatabaseOptions Members

[image] [image]

SQL Schema Sync API Class reference
DatabaseOptions Members
DatabaseOptions Class Constructors Methods Properties See Also Send Feedback

The DatabaseOptions type exposes the following members.

Constructors

Name | Description
DatabaseOptions | Creates new instance of the DatabaseOptions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnsiNullDefault | Gets or sets Ansi Null Default option.
AnsiNullsEnabled | Gets or sets Ansi Nulls Enabled option.
AnsiPaddingEnabled | 'Gets or sets Ansi Padding Enabled option.
AnsiWarningsEnabled | 'Gets or sets Ansi Warnings Enabled option.
ArithmeticAbortEnabled | Gets or sets Arithmetic Abort Enabled option.
AutoClose | Gets or sets Auto Close option.
AutoCreateStatistic | Gets or sets Auto Create Statistic option.
AutoShrink | Gets or sets Auto Shrink option.
AutoUpdateStatistic | Gets or sets Auto Update Statistic option.
AutoUpdateStatisticAsync | Gets or sets Auto Update Statistic Async option.
CloseCursorsOnCommitEnables | Gets or sets Close Cursors On Commit Enables option.
ConcatenateNullYieldsNull | Gets or sets Concatenate Null Yields Null option.
DatabaseOwnershipChaining | Gets or sets Database Ownership Chaining option.
DefaultCursor | Gets or sets DefaultCursor option
NumericRoundAbortEnabled | Gets or sets Numeric Round Abort Enabled option.
PageVerify | Gets or sets PageVerify option
Parametrization | Gets or sets Parameterization option.
QuotedIdentifiersEnabled | Gets or sets Quoted Identifiers Enabled option.
RecursiveTriggersEnabled | Gets or sets Recursive Triggers Enabled option.
Trustworthy | Gets or sets Trustworthy option.

See Also

DatabaseOptions Class


DatabaseOptions Constructor

[image]

SQL Schema Sync API Class reference
DatabaseOptions Constructor
DatabaseOptions Class See Also Send Feedback
Creates new instance of the DatabaseOptions class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DatabaseOptions()

See Also

DatabaseOptions Class


DatabaseOptions Methods

[image] [image]

SQL Schema Sync API Class reference
DatabaseOptions Methods
DatabaseOptions Class See Also Send Feedback

The DatabaseOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseOptions Class


DatabaseOptions Properties

[image] [image]

SQL Schema Sync API Class reference
DatabaseOptions Properties
DatabaseOptions Class See Also Send Feedback

The DatabaseOptions type exposes the following members.

Properties

Name | Description
AnsiNullDefault | Gets or sets Ansi Null Default option.
AnsiNullsEnabled | Gets or sets Ansi Nulls Enabled option.
AnsiPaddingEnabled | 'Gets or sets Ansi Padding Enabled option.
AnsiWarningsEnabled | 'Gets or sets Ansi Warnings Enabled option.
ArithmeticAbortEnabled | Gets or sets Arithmetic Abort Enabled option.
AutoClose | Gets or sets Auto Close option.
AutoCreateStatistic | Gets or sets Auto Create Statistic option.
AutoShrink | Gets or sets Auto Shrink option.
AutoUpdateStatistic | Gets or sets Auto Update Statistic option.
AutoUpdateStatisticAsync | Gets or sets Auto Update Statistic Async option.
CloseCursorsOnCommitEnables | Gets or sets Close Cursors On Commit Enables option.
ConcatenateNullYieldsNull | Gets or sets Concatenate Null Yields Null option.
DatabaseOwnershipChaining | Gets or sets Database Ownership Chaining option.
DefaultCursor | Gets or sets DefaultCursor option
NumericRoundAbortEnabled | Gets or sets Numeric Round Abort Enabled option.
PageVerify | Gets or sets PageVerify option
Parametrization | Gets or sets Parameterization option.
QuotedIdentifiersEnabled | Gets or sets Quoted Identifiers Enabled option.
RecursiveTriggersEnabled | Gets or sets Recursive Triggers Enabled option.
Trustworthy | Gets or sets Trustworthy option.

See Also

DatabaseOptions Class


AnsiNullDefault Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.AnsiNullDefault Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Ansi Null Default option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AnsiNullDefault { get; set; }
Visual Basic (Declaration)
Public Property AnsiNullDefault As Boolean
Visual C++
public:
property bool AnsiNullDefault {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


AnsiNullsEnabled Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.AnsiNullsEnabled Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Ansi Nulls Enabled option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AnsiNullsEnabled { get; set; }
Visual Basic (Declaration)
Public Property AnsiNullsEnabled As Boolean
Visual C++
public:
property bool AnsiNullsEnabled {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


AnsiPaddingEnabled Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.AnsiPaddingEnabled Property
DatabaseOptions Class See Also Send Feedback
'Gets or sets Ansi Padding Enabled option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AnsiPaddingEnabled { get; set; }
Visual Basic (Declaration)
Public Property AnsiPaddingEnabled As Boolean
Visual C++
public:
property bool AnsiPaddingEnabled {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


AnsiWarningsEnabled Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.AnsiWarningsEnabled Property
DatabaseOptions Class See Also Send Feedback
'Gets or sets Ansi Warnings Enabled option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AnsiWarningsEnabled { get; set; }
Visual Basic (Declaration)
Public Property AnsiWarningsEnabled As Boolean
Visual C++
public:
property bool AnsiWarningsEnabled {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


ArithmeticAbortEnabled Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.ArithmeticAbortEnabled Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Arithmetic Abort Enabled option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool ArithmeticAbortEnabled { get; set; }
Visual Basic (Declaration)
Public Property ArithmeticAbortEnabled As Boolean
Visual C++
public:
property bool ArithmeticAbortEnabled {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


AutoClose Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.AutoClose Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Auto Close option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AutoClose { get; set; }
Visual Basic (Declaration)
Public Property AutoClose As Boolean
Visual C++
public:
property bool AutoClose {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


AutoCreateStatistic Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.AutoCreateStatistic Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Auto Create Statistic option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AutoCreateStatistic { get; set; }
Visual Basic (Declaration)
Public Property AutoCreateStatistic As Boolean
Visual C++
public:
property bool AutoCreateStatistic {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


AutoShrink Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.AutoShrink Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Auto Shrink option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AutoShrink { get; set; }
Visual Basic (Declaration)
Public Property AutoShrink As Boolean
Visual C++
public:
property bool AutoShrink {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


AutoUpdateStatistic Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.AutoUpdateStatistic Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Auto Update Statistic option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AutoUpdateStatistic { get; set; }
Visual Basic (Declaration)
Public Property AutoUpdateStatistic As Boolean
Visual C++
public:
property bool AutoUpdateStatistic {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


AutoUpdateStatisticAsync Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.AutoUpdateStatisticAsync Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Auto Update Statistic Async option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AutoUpdateStatisticAsync { get; set; }
Visual Basic (Declaration)
Public Property AutoUpdateStatisticAsync As Boolean
Visual C++
public:
property bool AutoUpdateStatisticAsync {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


CloseCursorsOnCommitEnables Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.CloseCursorsOnCommitEnables Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Close Cursors On Commit Enables option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool CloseCursorsOnCommitEnables { get; set; }
Visual Basic (Declaration)
Public Property CloseCursorsOnCommitEnables As Boolean
Visual C++
public:
property bool CloseCursorsOnCommitEnables {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


ConcatenateNullYieldsNull Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.ConcatenateNullYieldsNull Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Concatenate Null Yields Null option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool ConcatenateNullYieldsNull { get; set; }
Visual Basic (Declaration)
Public Property ConcatenateNullYieldsNull As Boolean
Visual C++
public:
property bool ConcatenateNullYieldsNull {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


DatabaseOwnershipChaining Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.DatabaseOwnershipChaining Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Database Ownership Chaining option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool DatabaseOwnershipChaining { get; set; }
Visual Basic (Declaration)
Public Property DatabaseOwnershipChaining As Boolean
Visual C++
public:
property bool DatabaseOwnershipChaining {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


DefaultCursor Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.DefaultCursor Property
DatabaseOptions Class See Also Send Feedback
Gets or sets DefaultCursor option

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DefaultCursor DefaultCursor { get; set; }
Visual Basic (Declaration)
Public Property DefaultCursor As DefaultCursor
Visual C++
public:
property DefaultCursor DefaultCursor {
    DefaultCursor get ();
    void set (DefaultCursor value);
}

See Also

DatabaseOptions Class


NumericRoundAbortEnabled Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.NumericRoundAbortEnabled Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Numeric Round Abort Enabled option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool NumericRoundAbortEnabled { get; set; }
Visual Basic (Declaration)
Public Property NumericRoundAbortEnabled As Boolean
Visual C++
public:
property bool NumericRoundAbortEnabled {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


PageVerify Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.PageVerify Property
DatabaseOptions Class See Also Send Feedback
Gets or sets PageVerify option

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public PageVerify PageVerify { get; set; }
Visual Basic (Declaration)
Public Property PageVerify As PageVerify
Visual C++
public:
property PageVerify PageVerify {
    PageVerify get ();
    void set (PageVerify value);
}

See Also

DatabaseOptions Class


Parametrization Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.Parametrization Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Parameterization option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Parameterization Parametrization { get; set; }
Visual Basic (Declaration)
Public Property Parametrization As Parameterization
Visual C++
public:
property Parameterization Parametrization {
    Parameterization get ();
    void set (Parameterization value);
}

See Also

DatabaseOptions Class


QuotedIdentifiersEnabled Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.QuotedIdentifiersEnabled Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Quoted Identifiers Enabled option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool QuotedIdentifiersEnabled { get; set; }
Visual Basic (Declaration)
Public Property QuotedIdentifiersEnabled As Boolean
Visual C++
public:
property bool QuotedIdentifiersEnabled {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


RecursiveTriggersEnabled Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.RecursiveTriggersEnabled Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Recursive Triggers Enabled option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool RecursiveTriggersEnabled { get; set; }
Visual Basic (Declaration)
Public Property RecursiveTriggersEnabled As Boolean
Visual C++
public:
property bool RecursiveTriggersEnabled {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


Trustworthy Property

[image]

SQL Schema Sync API Class reference
DatabaseOptions..::.Trustworthy Property
DatabaseOptions Class See Also Send Feedback
Gets or sets Trustworthy option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Trustworthy { get; set; }
Visual Basic (Declaration)
Public Property Trustworthy As Boolean
Visual C++
public:
property bool Trustworthy {
    bool get ();
    void set (bool value);
}

See Also

DatabaseOptions Class


DataColumn Class

[image]

SQL Schema Sync API Class reference
DataColumn Class
Members See Also Send Feedback
Represents a data column in a database table.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class DataColumn : TableColumn, ISupportRulesDefaults
Visual Basic (Declaration)
Public Class DataColumn _
    Inherits TableColumn _
    Implements ISupportRulesDefaults
Visual C++
public ref class DataColumn : public TableColumn,
    ISupportRulesDefaults

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.ColumnBase
PerpetuumSoft.DataModel.MsSql..::.TableColumn
PerpetuumSoft.DataModel.MsSql..::.DataColumn
PerpetuumSoft.DataModel.MsSql..::.DataColumnSql10

See Also

DataColumn Members


DataColumn Members

[image] [image]

SQL Schema Sync API Class reference
DataColumn Members
DataColumn Class Constructors Methods Properties See Also Send Feedback

The DataColumn type exposes the following members.

Constructors

Name | Description
DataColumn | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). (Inherited from ColumnBase.)
TypeEquals | Override. See TypeEquals(ColumnBase). (Overrides ColumnBase..::.TypeEquals(ColumnBase).)

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values. (Inherited from ColumnBase.)
Collation | Gets or sets the column collation.
DataType | Gets or sets DataType of a column. (Inherited from ColumnBase.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for a column. (Inherited from ColumnBase.)
FullName | Gets full name of the column. (Inherited from ColumnBase.)
Identity | Gets or sets column identity settings.
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
NotForReplication | Gets or sets if a column is not for replication.
Owner | Gets TableBase which contains a column. (Inherited from ColumnBase.)
RowGuidColumn | Gets or sets if a column is a row guid column.

See Also

DataColumn Class


DataColumn Constructor

[image] [image]

SQL Schema Sync API Class reference
DataColumn Constructor
DataColumn Class See Also Send Feedback

Overload List

Name | Description
DataColumn()()() | Initializes a new instance of the DataColumn class.
DataColumn(String, DataType, Boolean) | Creates new instance of the DataColumn class.

See Also

DataColumn Class
DataColumn Members


DataColumn Constructor

[image]

SQL Schema Sync API Class reference
DataColumn Constructor
DataColumn Class See Also Send Feedback
Initializes a new instance of the DataColumn class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DataColumn()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataColumn()

See Also

DataColumn Class
DataColumn Overload


DataColumn Constructor (String, DataType, Boolean)

[image]

SQL Schema Sync API Class reference
DataColumn Constructor (String, DataType, Boolean)
DataColumn Class See Also Send Feedback
Creates new instance of the DataColumn class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DataColumn(
    string name,
    DataType dataType,
    bool allowNulls
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    dataType As DataType, _
    allowNulls As Boolean _
)
Visual C++
public:
DataColumn(
    String^ name,
    DataType^ dataType,
    bool allowNulls
)

Parameters

name
Type: System..::.String
dataType
Type: PerpetuumSoft.DataModel.MsSql..::.DataType
allowNulls
Type: System..::.Boolean

See Also

DataColumn Class
DataColumn Overload


DataColumn Methods

[image] [image]

SQL Schema Sync API Class reference
DataColumn Methods
DataColumn Class See Also Send Feedback

The DataColumn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). (Inherited from ColumnBase.)
TypeEquals | Override. See TypeEquals(ColumnBase). (Overrides ColumnBase..::.TypeEquals(ColumnBase).)

See Also

DataColumn Class


TypeEquals Method

[image]

SQL Schema Sync API Class reference
DataColumn..::.TypeEquals Method
DataColumn Class See Also Send Feedback
Override. See TypeEquals(ColumnBase).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool TypeEquals(
    ColumnBase other
)
Visual Basic (Declaration)
Public Overrides Function TypeEquals ( _
    other As ColumnBase _
) As Boolean
Visual C++
public:
virtual bool TypeEquals(
    ColumnBase^ other
) override

Parameters

other
Type: PerpetuumSoft.DataModel.MsSql..::.ColumnBase

See Also

DataColumn Class


DataColumn Properties

[image] [image]

SQL Schema Sync API Class reference
DataColumn Properties
DataColumn Class See Also Send Feedback

The DataColumn type exposes the following members.

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values. (Inherited from ColumnBase.)
Collation | Gets or sets the column collation.
DataType | Gets or sets DataType of a column. (Inherited from ColumnBase.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for a column. (Inherited from ColumnBase.)
FullName | Gets full name of the column. (Inherited from ColumnBase.)
Identity | Gets or sets column identity settings.
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
NotForReplication | Gets or sets if a column is not for replication.
Owner | Gets TableBase which contains a column. (Inherited from ColumnBase.)
RowGuidColumn | Gets or sets if a column is a row guid column.

See Also

DataColumn Class


Collation Property

[image]

SQL Schema Sync API Class reference
DataColumn..::.Collation Property
DataColumn Class See Also Send Feedback
Gets or sets the column collation.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Collation { get; set; }
Visual Basic (Declaration)
Public Property Collation As String
Visual C++
public:
property String^ Collation {
    String^ get ();
    void set (String^ value);
}

See Also

DataColumn Class


Identity Property

[image]

SQL Schema Sync API Class reference
DataColumn..::.Identity Property
DataColumn Class See Also Send Feedback
Gets or sets column identity settings.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Identity Identity { get; set; }
Visual Basic (Declaration)
Public Property Identity As Identity
Visual C++
public:
property Identity^ Identity {
    Identity^ get ();
    void set (Identity^ value);
}

See Also

DataColumn Class


NotForReplication Property

[image]

SQL Schema Sync API Class reference
DataColumn..::.NotForReplication Property
DataColumn Class See Also Send Feedback
Gets or sets if a column is not for replication.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool NotForReplication { get; set; }
Visual Basic (Declaration)
Public Property NotForReplication As Boolean
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

DataColumn Class


RowGuidColumn Property

[image]

SQL Schema Sync API Class reference
DataColumn..::.RowGuidColumn Property
DataColumn Class See Also Send Feedback
Gets or sets if a column is a row guid column.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool RowGuidColumn { get; set; }
Visual Basic (Declaration)
Public Property RowGuidColumn As Boolean
Visual C++
public:
property bool RowGuidColumn {
    bool get ();
    void set (bool value);
}

See Also

DataColumn Class


DataColumnSql10 Class

[image]

SQL Schema Sync API Class reference
DataColumnSql10 Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DataColumnSql10"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class DataColumnSql10 : DataColumn
Visual Basic (Declaration)
Public Class DataColumnSql10 _
    Inherits DataColumn
Visual C++
public ref class DataColumnSql10 : public DataColumn

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.ColumnBase
PerpetuumSoft.DataModel.MsSql..::.TableColumn
PerpetuumSoft.DataModel.MsSql..::.DataColumn
PerpetuumSoft.DataModel.MsSql..::.DataColumnSql10

See Also

DataColumnSql10 Members


DataColumnSql10 Members

[image] [image]

SQL Schema Sync API Class reference
DataColumnSql10 Members
DataColumnSql10 Class Constructors Methods Properties See Also Send Feedback

The DataColumnSql10 type exposes the following members.

Constructors

Name | Description
DataColumnSql10 | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). (Inherited from ColumnBase.)
TypeEquals | (Overrides DataColumn..::.TypeEquals(ColumnBase).)

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values. (Inherited from ColumnBase.)
Collation | Gets or sets the column collation. (Inherited from DataColumn.)
DataType | Gets or sets DataType of a column. (Inherited from ColumnBase.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for a column. (Inherited from ColumnBase.)
FullName | Gets full name of the column. (Inherited from ColumnBase.)
Identity | Gets or sets column identity settings. (Inherited from DataColumn.)
IsColumnset |
IsFilestream |
IsSparse |
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
NotForReplication | Gets or sets if a column is not for replication. (Inherited from DataColumn.)
Owner | Gets TableBase which contains a column. (Inherited from ColumnBase.)
RowGuidColumn | Gets or sets if a column is a row guid column. (Inherited from DataColumn.)

See Also

DataColumnSql10 Class


DataColumnSql10 Constructor

[image] [image]

SQL Schema Sync API Class reference
DataColumnSql10 Constructor
DataColumnSql10 Class See Also Send Feedback

Overload List

Name | Description
DataColumnSql10()()() | Initializes a new instance of the DataColumnSql10 class
DataColumnSql10(String, DataType, Boolean) | Initializes a new instance of the DataColumnSql10 class

See Also

DataColumnSql10 Class
DataColumnSql10 Members


DataColumnSql10 Constructor

[image]

SQL Schema Sync API Class reference
DataColumnSql10 Constructor
DataColumnSql10 Class See Also Send Feedback
Initializes a new instance of the DataColumnSql10 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DataColumnSql10()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataColumnSql10()

See Also

DataColumnSql10 Class
DataColumnSql10 Overload


DataColumnSql10 Constructor (String, DataType, Boolean)

[image]

SQL Schema Sync API Class reference
DataColumnSql10 Constructor (String, DataType, Boolean)
DataColumnSql10 Class See Also Send Feedback
Initializes a new instance of the DataColumnSql10 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DataColumnSql10(
    string name,
    DataType dataType,
    bool allowNulls
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    dataType As DataType, _
    allowNulls As Boolean _
)
Visual C++
public:
DataColumnSql10(
    String^ name,
    DataType^ dataType,
    bool allowNulls
)

Parameters

name
Type: System..::.String
dataType
Type: PerpetuumSoft.DataModel.MsSql..::.DataType
allowNulls
Type: System..::.Boolean

See Also

DataColumnSql10 Class
DataColumnSql10 Overload


DataColumnSql10 Methods

[image] [image]

SQL Schema Sync API Class reference
DataColumnSql10 Methods
DataColumnSql10 Class See Also Send Feedback

The DataColumnSql10 type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). (Inherited from ColumnBase.)
TypeEquals | (Overrides DataColumn..::.TypeEquals(ColumnBase).)

See Also

DataColumnSql10 Class


TypeEquals Method

[image]

SQL Schema Sync API Class reference
DataColumnSql10..::.TypeEquals Method
DataColumnSql10 Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DataColumnSql10.TypeEquals(PerpetuumSoft.DataModel.MsSql.ColumnBase)"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool TypeEquals(
    ColumnBase other
)
Visual Basic (Declaration)
Public Overrides Function TypeEquals ( _
    other As ColumnBase _
) As Boolean
Visual C++
public:
virtual bool TypeEquals(
    ColumnBase^ other
) override

Parameters

other
Type: PerpetuumSoft.DataModel.MsSql..::.ColumnBase

See Also

DataColumnSql10 Class


DataColumnSql10 Properties

[image] [image]

SQL Schema Sync API Class reference
DataColumnSql10 Properties
DataColumnSql10 Class See Also Send Feedback

The DataColumnSql10 type exposes the following members.

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values. (Inherited from ColumnBase.)
Collation | Gets or sets the column collation. (Inherited from DataColumn.)
DataType | Gets or sets DataType of a column. (Inherited from ColumnBase.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for a column. (Inherited from ColumnBase.)
FullName | Gets full name of the column. (Inherited from ColumnBase.)
Identity | Gets or sets column identity settings. (Inherited from DataColumn.)
IsColumnset |
IsFilestream |
IsSparse |
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
NotForReplication | Gets or sets if a column is not for replication. (Inherited from DataColumn.)
Owner | Gets TableBase which contains a column. (Inherited from ColumnBase.)
RowGuidColumn | Gets or sets if a column is a row guid column. (Inherited from DataColumn.)

See Also

DataColumnSql10 Class


IsColumnset Property

[image]

SQL Schema Sync API Class reference
DataColumnSql10..::.IsColumnset Property
DataColumnSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataColumnSql10.IsColumnset"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsColumnset { get; set; }
Visual Basic (Declaration)
Public Property IsColumnset As Boolean
Visual C++
public:
property bool IsColumnset {
    bool get ();
    void set (bool value);
}

See Also

DataColumnSql10 Class


IsFilestream Property

[image]

SQL Schema Sync API Class reference
DataColumnSql10..::.IsFilestream Property
DataColumnSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataColumnSql10.IsFilestream"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsFilestream { get; set; }
Visual Basic (Declaration)
Public Property IsFilestream As Boolean
Visual C++
public:
property bool IsFilestream {
    bool get ();
    void set (bool value);
}

See Also

DataColumnSql10 Class


IsSparse Property

[image]

SQL Schema Sync API Class reference
DataColumnSql10..::.IsSparse Property
DataColumnSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataColumnSql10.IsSparse"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsSparse { get; set; }
Visual Basic (Declaration)
Public Property IsSparse As Boolean
Visual C++
public:
property bool IsSparse {
    bool get ();
    void set (bool value);
}

See Also

DataColumnSql10 Class


DataType Class

[image]

SQL Schema Sync API Class reference
DataType Class
Members See Also Send Feedback
Abstract base class for all column types.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class DataType
Visual Basic (Declaration)
Public MustInherit Class DataType
Visual C++
public ref class DataType abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.BigInt
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Bit
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Date
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateSizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateTime
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Float
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Geography
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Geometry
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Hierarchyid
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Image
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Int
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Money
PerpetuumSoft.DataModel.MsSql..::.DataType..::.NText
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Real
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SmallDateTime
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SmallInt
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SmallMoney
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SqlVariant
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Text
PerpetuumSoft.DataModel.MsSql..::.DataType..::.TimeStamp
PerpetuumSoft.DataModel.MsSql..::.DataType..::.TinyInt
PerpetuumSoft.DataModel.MsSql..::.DataType..::.TypeWithPrecision
PerpetuumSoft.DataModel.MsSql..::.DataType..::.UniqueIdentifier
PerpetuumSoft.DataModel.MsSql..::.DataType..::.UserCLRType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.UserTableType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.UserType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Xml

See Also

DataType Members


DataType Members

[image] [image]

SQL Schema Sync API Class reference
DataType Members
DataType Class Constructors Methods Properties See Also Send Feedback

The DataType type exposes the following members.

Constructors

Name | Description
DataType | Initializes a new instance of the DataType class

Methods

Name | Description
DataTypeEquals | Returns if data types are equal.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Returns the sql type definition.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
BaseType | Gets DataType
DefaultValue | Gets default value for a type.
IsUserDefinedType | Gets if a type is declared as a user defined one.
SupportCollation | Gets true value if a type supports collation.

See Also

DataType Class


DataType Constructor

[image]

SQL Schema Sync API Class reference
DataType Constructor
DataType Class See Also Send Feedback
Initializes a new instance of the DataType class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected DataType()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
DataType()

See Also

DataType Class


DataType Methods

[image] [image]

SQL Schema Sync API Class reference
DataType Methods
DataType Class See Also Send Feedback

The DataType type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Returns the sql type definition.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

DataType Class


DataTypeEquals Method

[image]

SQL Schema Sync API Class reference
DataType..::.DataTypeEquals Method
DataType Class See Also Send Feedback
Returns if data types are equal.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool DataTypeEquals(
    DataType dt
)
Visual Basic (Declaration)
Public Overridable Function DataTypeEquals ( _
    dt As DataType _
) As Boolean
Visual C++
public:
virtual bool DataTypeEquals(
    DataType^ dt
)

Parameters

dt
Type: PerpetuumSoft.DataModel.MsSql..::.DataType

See Also

DataType Class


Equals Method

[image]

SQL Schema Sync API Class reference
DataType..::.Equals Method
DataType Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

DataType Class


GetHashCode Method

[image]

SQL Schema Sync API Class reference
DataType..::.GetHashCode Method
DataType Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

DataType Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.GetTypeDefinition Method
DataType Class See Also Send Feedback
Returns the sql type definition.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract string GetTypeDefinition()
Visual Basic (Declaration)
Public MustOverride Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() abstract

See Also

DataType Class


ToString Method

[image]

SQL Schema Sync API Class reference
DataType..::.ToString Method
DataType Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

DataType Class


DataType Properties

[image] [image]

SQL Schema Sync API Class reference
DataType Properties
DataType Class See Also Send Feedback

The DataType type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType
DefaultValue | Gets default value for a type.
IsUserDefinedType | Gets if a type is declared as a user defined one.
SupportCollation | Gets true value if a type supports collation.

See Also

DataType Class


BaseType Property

[image]

SQL Schema Sync API Class reference
DataType..::.BaseType Property
DataType Class See Also Send Feedback
Gets DataType

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public virtual DataType BaseType { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property BaseType As DataType
Visual C++
public:
virtual property DataType^ BaseType {
    DataType^ get ();
}

See Also

DataType Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.DefaultValue Property
DataType Class See Also Send Feedback
Gets default value for a type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract string DefaultValue { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () abstract;
}

See Also

DataType Class


IsUserDefinedType Property

[image]

SQL Schema Sync API Class reference
DataType..::.IsUserDefinedType Property
DataType Class See Also Send Feedback
Gets if a type is declared as a user defined one.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool IsUserDefinedType { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsUserDefinedType As Boolean
Visual C++
public:
virtual property bool IsUserDefinedType {
    bool get ();
}

See Also

DataType Class


SupportCollation Property

[image]

SQL Schema Sync API Class reference
DataType..::.SupportCollation Property
DataType Class See Also Send Feedback
Gets true value if a type supports collation.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool SupportCollation { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property SupportCollation As Boolean
Visual C++
public:
virtual property bool SupportCollation {
    bool get ();
}

See Also

DataType Class


DataType.BigInt Class

[image]

SQL Schema Sync API Class reference
DataType..::.BigInt Class
DataType Class Members See Also Send Feedback
Represents the bigint data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class BigInt : DataType
Visual Basic (Declaration)
Public NotInheritable Class BigInt _
    Inherits DataType
Visual C++
public ref class BigInt sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.BigInt

See Also

DataType..::.BigInt Members


DataType.BigInt Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.BigInt Members
DataType..::.BigInt Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.BigInt type exposes the following members.

Constructors

Name | Description
DataType..::.BigInt | Initializes a new instance of the DataType..::.BigInt class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.BigInt Class


DataType.BigInt Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.BigInt Constructor
DataType..::.BigInt Class See Also Send Feedback
Initializes a new instance of the DataType..::.BigInt class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public BigInt()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BigInt()

See Also

DataType..::.BigInt Class


DataType.BigInt Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.BigInt Methods
DataType..::.BigInt Class See Also Send Feedback

The DataType..::.BigInt type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.BigInt Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.BigInt..::.GetTypeDefinition Method
DataType..::.BigInt Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.BigInt Class


DataType.BigInt Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.BigInt Properties
DataType..::.BigInt Class See Also Send Feedback

The DataType..::.BigInt type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.BigInt Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.BigInt..::.DefaultValue Property
DataType..::.BigInt Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.BigInt Class


DataType.Binary Class

[image]

SQL Schema Sync API Class reference
DataType..::.Binary Class
DataType Class Members See Also Send Feedback
Represents the binary data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Binary : DataType..::.SizedType
Visual Basic (Declaration)
Public NotInheritable Class Binary _
    Inherits DataType..::.SizedType
Visual C++
public ref class Binary sealed : public DataType..::.SizedType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Binary

See Also

DataType..::.Binary Members


DataType.Binary Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Binary Members
DataType..::.Binary Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Binary type exposes the following members.

Constructors

Name | Description
DataType..::.Binary | Overloaded.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Binary Class


DataType.Binary Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Binary Constructor
DataType..::.Binary Class See Also Send Feedback

Overload List

Name | Description
DataType..::.Binary()()() | Initializes a new instance of the DataType..::.Binary class.
DataType..::.Binary(Int32) | Creates new instance of the DataType..::.Binary class.

See Also

DataType..::.Binary Class
DataType..::.Binary Members


DataType.Binary Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Binary Constructor
DataType..::.Binary Class See Also Send Feedback
Initializes a new instance of the DataType..::.Binary class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Binary()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Binary()

See Also

DataType..::.Binary Class
DataType..::.Binary Overload


DataType.Binary Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.Binary Constructor (Int32)
DataType..::.Binary Class See Also Send Feedback
Creates new instance of the DataType..::.Binary class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Binary(
    int maxsize
)
Visual Basic (Declaration)
Public Sub New ( _
    maxsize As Integer _
)
Visual C++
public:
Binary(
    int maxsize
)

Parameters

maxsize
Type: System..::.Int32

See Also

DataType..::.Binary Class
DataType..::.Binary Overload


DataType.Binary Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Binary Methods
DataType..::.Binary Class See Also Send Feedback

The DataType..::.Binary type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Binary Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Binary..::.GetTypeDefinition Method
DataType..::.Binary Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Binary Class


DataType.Binary Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Binary Properties
DataType..::.Binary Class See Also Send Feedback

The DataType..::.Binary type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Binary Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Binary..::.DefaultValue Property
DataType..::.Binary Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Binary Class


DataType.Bit Class

[image]

SQL Schema Sync API Class reference
DataType..::.Bit Class
DataType Class Members See Also Send Feedback
Represents the bit data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Bit : DataType
Visual Basic (Declaration)
Public NotInheritable Class Bit _
    Inherits DataType
Visual C++
public ref class Bit sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Bit

See Also

DataType..::.Bit Members


DataType.Bit Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Bit Members
DataType..::.Bit Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Bit type exposes the following members.

Constructors

Name | Description
DataType..::.Bit | Initializes a new instance of the DataType..::.Bit class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Bit Class


DataType.Bit Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Bit Constructor
DataType..::.Bit Class See Also Send Feedback
Initializes a new instance of the DataType..::.Bit class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Bit()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Bit()

See Also

DataType..::.Bit Class


DataType.Bit Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Bit Methods
DataType..::.Bit Class See Also Send Feedback

The DataType..::.Bit type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Bit Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Bit..::.GetTypeDefinition Method
DataType..::.Bit Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Bit Class


DataType.Bit Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Bit Properties
DataType..::.Bit Class See Also Send Feedback

The DataType..::.Bit type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Bit Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Bit..::.DefaultValue Property
DataType..::.Bit Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Bit Class


DataType.Char Class

[image]

SQL Schema Sync API Class reference
DataType..::.Char Class
DataType Class Members See Also Send Feedback
Represents the char data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Char : DataType..::.SizedType
Visual Basic (Declaration)
Public NotInheritable Class Char _
    Inherits DataType..::.SizedType
Visual C++
public ref class Char sealed : public DataType..::.SizedType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Char

See Also

DataType..::.Char Members


DataType.Char Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Char Members
DataType..::.Char Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Char type exposes the following members.

Constructors

Name | Description
DataType..::.Char | Overloaded.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.Char Class


DataType.Char Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Char Constructor
DataType..::.Char Class See Also Send Feedback

Overload List

Name | Description
DataType..::.Char()()() | Initializes a new instance of the DataType..::.Char class.
DataType..::.Char(Int32) | Creates new instance of the DataType..::.Char class.

See Also

DataType..::.Char Class
DataType..::.Char Members


DataType.Char Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Char Constructor
DataType..::.Char Class See Also Send Feedback
Initializes a new instance of the DataType..::.Char class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Char()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Char()

See Also

DataType..::.Char Class
DataType..::.Char Overload


DataType.Char Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.Char Constructor (Int32)
DataType..::.Char Class See Also Send Feedback
Creates new instance of the DataType..::.Char class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Char(
    int maxsize
)
Visual Basic (Declaration)
Public Sub New ( _
    maxsize As Integer _
)
Visual C++
public:
Char(
    int maxsize
)

Parameters

maxsize
Type: System..::.Int32

See Also

DataType..::.Char Class
DataType..::.Char Overload


DataType.Char Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Char Methods
DataType..::.Char Class See Also Send Feedback

The DataType..::.Char type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Char Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Char..::.GetTypeDefinition Method
DataType..::.Char Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Char Class


DataType.Char Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Char Properties
DataType..::.Char Class See Also Send Feedback

The DataType..::.Char type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.Char Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Char..::.DefaultValue Property
DataType..::.Char Class See Also Send Feedback
Override. See DefaultValue. Gets ".

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Char Class


SupportCollation Property

[image]

SQL Schema Sync API Class reference
DataType..::.Char..::.SupportCollation Property
DataType..::.Char Class See Also Send Feedback
Override. See SupportCollation.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool SupportCollation { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SupportCollation As Boolean
Visual C++
public:
virtual property bool SupportCollation {
    bool get () override;
}

See Also

DataType..::.Char Class


DataType.Date Class

[image]

SQL Schema Sync API Class reference
DataType..::.Date Class
DataType Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DataType.Date"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Date : DataType
Visual Basic (Declaration)
Public NotInheritable Class Date _
    Inherits DataType
Visual C++
public ref class Date sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Date

See Also

DataType..::.Date Members


DataType.Date Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Date Members
DataType..::.Date Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Date type exposes the following members.

Constructors

Name | Description
DataType..::.Date | Initializes a new instance of the DataType..::.Date class

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Date Class


DataType.Date Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Date Constructor
DataType..::.Date Class See Also Send Feedback
Initializes a new instance of the DataType..::.Date class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Date()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Date()

See Also

DataType..::.Date Class


DataType.Date Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Date Methods
DataType..::.Date Class See Also Send Feedback

The DataType..::.Date type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Date Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Date..::.GetTypeDefinition Method
DataType..::.Date Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DataType.Date.GetTypeDefinition"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Date Class


DataType.Date Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Date Properties
DataType..::.Date Class See Also Send Feedback

The DataType..::.Date type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Date Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Date..::.DefaultValue Property
DataType..::.Date Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.Date.DefaultValue"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Date Class


DataType.DateSizedType Class

[image]

SQL Schema Sync API Class reference
DataType..::.DateSizedType Class
DataType Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DataType.DateSizedType"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class DateSizedType : DataType
Visual Basic (Declaration)
Public MustInherit Class DateSizedType _
    Inherits DataType
Visual C++
public ref class DateSizedType abstract : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateSizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateTime2
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateTimeOffset
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Time

See Also

DataType..::.DateSizedType Members


DataType.DateSizedType Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateSizedType Members
DataType..::.DateSizedType Class Constructors Methods Fields Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.DateSizedType type exposes the following members.

Constructors

Name | Description
DataType..::.DateSizedType | Overloaded.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Returns the sql type definition. (Inherited from DataType.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Fields

Name | Description
_maxSize |

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Gets default value for a type. (Inherited from DataType.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize |
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.DateSizedType Class


DataType.DateSizedType Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateSizedType Constructor
DataType..::.DateSizedType Class See Also Send Feedback

Overload List

Name | Description
DataType..::.DateSizedType()()() | Initializes a new instance of the DataType..::.DateSizedType class
DataType..::.DateSizedType(Int32) | Initializes a new instance of the DataType..::.DateSizedType class

See Also

DataType..::.DateSizedType Class
DataType..::.DateSizedType Members


DataType.DateSizedType Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.DateSizedType Constructor
DataType..::.DateSizedType Class See Also Send Feedback
Initializes a new instance of the DataType..::.DateSizedType class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected DateSizedType()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
DateSizedType()

See Also

DataType..::.DateSizedType Class
DataType..::.DateSizedType Overload


DataType.DateSizedType Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.DateSizedType Constructor (Int32)
DataType..::.DateSizedType Class See Also Send Feedback
Initializes a new instance of the DataType..::.DateSizedType class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected DateSizedType(
    int maxSize
)
Visual Basic (Declaration)
Protected Sub New ( _
    maxSize As Integer _
)
Visual C++
protected:
DateSizedType(
    int maxSize
)

Parameters

maxSize
Type: System..::.Int32

See Also

DataType..::.DateSizedType Class
DataType..::.DateSizedType Overload


DataType.DateSizedType Fields

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateSizedType Fields
DataType..::.DateSizedType Class See Also Send Feedback

The DataType..::.DateSizedType type exposes the following members.

Fields

Name | Description
_maxSize |

See Also

DataType..::.DateSizedType Class


_maxSize Field

[image]

SQL Schema Sync API Class reference
DataType..::.DateSizedType..::._maxSize Field
DataType..::.DateSizedType Class See Also Send Feedback

[Missing <summary> documentation for "F:PerpetuumSoft.DataModel.MsSql.DataType.DateSizedType._maxSize"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected int _maxSize
Visual Basic (Declaration)
Protected _maxSize As Integer
Visual C++
protected:
int _maxSize

See Also

DataType..::.DateSizedType Class


DataType.DateSizedType Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateSizedType Methods
DataType..::.DateSizedType Class See Also Send Feedback

The DataType..::.DateSizedType type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Returns the sql type definition. (Inherited from DataType.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.DateSizedType Class


DataType.DateSizedType Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateSizedType Properties
DataType..::.DateSizedType Class See Also Send Feedback

The DataType..::.DateSizedType type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Gets default value for a type. (Inherited from DataType.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize |
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.DateSizedType Class


MaxSize Property

[image]

SQL Schema Sync API Class reference
DataType..::.DateSizedType..::.MaxSize Property
DataType..::.DateSizedType Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.DateSizedType.MaxSize"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int MaxSize { get; set; }
Visual Basic (Declaration)
Public Property MaxSize As Integer
Visual C++
public:
property int MaxSize {
    int get ();
    void set (int value);
}

See Also

DataType..::.DateSizedType Class


DataType.DateTime Class

[image]

SQL Schema Sync API Class reference
DataType..::.DateTime Class
DataType Class Members See Also Send Feedback
Represents the datetime data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class DateTime : DataType
Visual Basic (Declaration)
Public NotInheritable Class DateTime _
    Inherits DataType
Visual C++
public ref class DateTime sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateTime

See Also

DataType..::.DateTime Members


DataType.DateTime Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTime Members
DataType..::.DateTime Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.DateTime type exposes the following members.

Constructors

Name | Description
DataType..::.DateTime | Initializes a new instance of the DataType..::.DateTime class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.DateTime Class


DataType.DateTime Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.DateTime Constructor
DataType..::.DateTime Class See Also Send Feedback
Initializes a new instance of the DataType..::.DateTime class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DateTime()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateTime()

See Also

DataType..::.DateTime Class


DataType.DateTime Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTime Methods
DataType..::.DateTime Class See Also Send Feedback

The DataType..::.DateTime type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.DateTime Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.DateTime..::.GetTypeDefinition Method
DataType..::.DateTime Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.DateTime Class


DataType.DateTime Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTime Properties
DataType..::.DateTime Class See Also Send Feedback

The DataType..::.DateTime type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.DateTime Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.DateTime..::.DefaultValue Property
DataType..::.DateTime Class See Also Send Feedback
Override. See DefaultValue. Gets ".

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.DateTime Class


DataType.DateTime2 Class

[image]

SQL Schema Sync API Class reference
DataType..::.DateTime2 Class
DataType Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DataType.DateTime2"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class DateTime2 : DataType..::.DateSizedType
Visual Basic (Declaration)
Public NotInheritable Class DateTime2 _
    Inherits DataType..::.DateSizedType
Visual C++
public ref class DateTime2 sealed : public DataType..::.DateSizedType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateSizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateTime2

See Also

DataType..::.DateTime2 Members


DataType.DateTime2 Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTime2 Members
DataType..::.DateTime2 Class Constructors Methods Fields Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.DateTime2 type exposes the following members.

Constructors

Name | Description
DataType..::.DateTime2 | Overloaded.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Fields

Name | Description
_maxSize | (Inherited from DataType..::.DateSizedType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | (Inherited from DataType..::.DateSizedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.DateTime2 Class


DataType.DateTime2 Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTime2 Constructor
DataType..::.DateTime2 Class See Also Send Feedback

Overload List

Name | Description
DataType..::.DateTime2()()() | Initializes a new instance of the DataType..::.DateTime2 class
DataType..::.DateTime2(Int32) | Initializes a new instance of the DataType..::.DateTime2 class

See Also

DataType..::.DateTime2 Class
DataType..::.DateTime2 Members


DataType.DateTime2 Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.DateTime2 Constructor
DataType..::.DateTime2 Class See Also Send Feedback
Initializes a new instance of the DataType..::.DateTime2 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DateTime2()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateTime2()

See Also

DataType..::.DateTime2 Class
DataType..::.DateTime2 Overload


DataType.DateTime2 Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.DateTime2 Constructor (Int32)
DataType..::.DateTime2 Class See Also Send Feedback
Initializes a new instance of the DataType..::.DateTime2 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DateTime2(
    int maxSize
)
Visual Basic (Declaration)
Public Sub New ( _
    maxSize As Integer _
)
Visual C++
public:
DateTime2(
    int maxSize
)

Parameters

maxSize
Type: System..::.Int32

See Also

DataType..::.DateTime2 Class
DataType..::.DateTime2 Overload


DataType.DateTime2 Fields

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTime2 Fields
DataType..::.DateTime2 Class See Also Send Feedback

The DataType..::.DateTime2 type exposes the following members.

Fields

Name | Description
_maxSize | (Inherited from DataType..::.DateSizedType.)

See Also

DataType..::.DateTime2 Class


DataType.DateTime2 Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTime2 Methods
DataType..::.DateTime2 Class See Also Send Feedback

The DataType..::.DateTime2 type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.DateTime2 Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.DateTime2..::.GetTypeDefinition Method
DataType..::.DateTime2 Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DataType.DateTime2.GetTypeDefinition"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.DateTime2 Class


DataType.DateTime2 Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTime2 Properties
DataType..::.DateTime2 Class See Also Send Feedback

The DataType..::.DateTime2 type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | (Inherited from DataType..::.DateSizedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.DateTime2 Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.DateTime2..::.DefaultValue Property
DataType..::.DateTime2 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.DateTime2.DefaultValue"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.DateTime2 Class


DataType.DateTimeOffset Class

[image]

SQL Schema Sync API Class reference
DataType..::.DateTimeOffset Class
DataType Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DataType.DateTimeOffset"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class DateTimeOffset : DataType..::.DateSizedType
Visual Basic (Declaration)
Public NotInheritable Class DateTimeOffset _
    Inherits DataType..::.DateSizedType
Visual C++
public ref class DateTimeOffset sealed : public DataType..::.DateSizedType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateSizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateTimeOffset

See Also

DataType..::.DateTimeOffset Members


DataType.DateTimeOffset Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTimeOffset Members
DataType..::.DateTimeOffset Class Constructors Methods Fields Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.DateTimeOffset type exposes the following members.

Constructors

Name | Description
DataType..::.DateTimeOffset | Overloaded.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Fields

Name | Description
_maxSize | (Inherited from DataType..::.DateSizedType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | (Inherited from DataType..::.DateSizedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.DateTimeOffset Class


DataType.DateTimeOffset Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTimeOffset Constructor
DataType..::.DateTimeOffset Class See Also Send Feedback

Overload List

Name | Description
DataType..::.DateTimeOffset()()() | Initializes a new instance of the DataType..::.DateTimeOffset class
DataType..::.DateTimeOffset(Int32) | Initializes a new instance of the DataType..::.DateTimeOffset class

See Also

DataType..::.DateTimeOffset Class
DataType..::.DateTimeOffset Members


DataType.DateTimeOffset Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.DateTimeOffset Constructor
DataType..::.DateTimeOffset Class See Also Send Feedback
Initializes a new instance of the DataType..::.DateTimeOffset class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DateTimeOffset()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateTimeOffset()

See Also

DataType..::.DateTimeOffset Class
DataType..::.DateTimeOffset Overload


DataType.DateTimeOffset Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.DateTimeOffset Constructor (Int32)
DataType..::.DateTimeOffset Class See Also Send Feedback
Initializes a new instance of the DataType..::.DateTimeOffset class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DateTimeOffset(
    int maxSize
)
Visual Basic (Declaration)
Public Sub New ( _
    maxSize As Integer _
)
Visual C++
public:
DateTimeOffset(
    int maxSize
)

Parameters

maxSize
Type: System..::.Int32

See Also

DataType..::.DateTimeOffset Class
DataType..::.DateTimeOffset Overload


DataType.DateTimeOffset Fields

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTimeOffset Fields
DataType..::.DateTimeOffset Class See Also Send Feedback

The DataType..::.DateTimeOffset type exposes the following members.

Fields

Name | Description
_maxSize | (Inherited from DataType..::.DateSizedType.)

See Also

DataType..::.DateTimeOffset Class


DataType.DateTimeOffset Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTimeOffset Methods
DataType..::.DateTimeOffset Class See Also Send Feedback

The DataType..::.DateTimeOffset type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.DateTimeOffset Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.DateTimeOffset..::.GetTypeDefinition Method
DataType..::.DateTimeOffset Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DataType.DateTimeOffset.GetTypeDefinition"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.DateTimeOffset Class


DataType.DateTimeOffset Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.DateTimeOffset Properties
DataType..::.DateTimeOffset Class See Also Send Feedback

The DataType..::.DateTimeOffset type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | (Inherited from DataType..::.DateSizedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.DateTimeOffset Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.DateTimeOffset..::.DefaultValue Property
DataType..::.DateTimeOffset Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.DateTimeOffset.DefaultValue"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.DateTimeOffset Class


DataType.Decimal Class

[image]

SQL Schema Sync API Class reference
DataType..::.Decimal Class
DataType Class Members See Also Send Feedback
Represents the decimal data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Decimal : DataType..::.TypeWithPrecision
Visual Basic (Declaration)
Public NotInheritable Class Decimal _
    Inherits DataType..::.TypeWithPrecision
Visual C++
public ref class Decimal sealed : public DataType..::.TypeWithPrecision

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.TypeWithPrecision
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Decimal

See Also

DataType..::.Decimal Members


DataType.Decimal Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Decimal Members
DataType..::.Decimal Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Decimal type exposes the following members.

Constructors

Name | Description
DataType..::.Decimal | Overloaded.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.TypeWithPrecision.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
Precision | Gets or sets the type precision. (Inherited from DataType..::.TypeWithPrecision.)
Scale | Gets or sets the type scale. (Inherited from DataType..::.TypeWithPrecision.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Decimal Class


DataType.Decimal Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Decimal Constructor
DataType..::.Decimal Class See Also Send Feedback

Overload List

Name | Description
DataType..::.Decimal()()() | Initializes a new instance of the DataType..::.Decimal class.
DataType..::.Decimal(Int32, Int32) | Creates new instance of the DataType..::.Decimal class.

See Also

DataType..::.Decimal Class
DataType..::.Decimal Members


DataType.Decimal Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Decimal Constructor
DataType..::.Decimal Class See Also Send Feedback
Initializes a new instance of the DataType..::.Decimal class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Decimal()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Decimal()

See Also

DataType..::.Decimal Class
DataType..::.Decimal Overload


DataType.Decimal Constructor (Int32, Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.Decimal Constructor (Int32, Int32)
DataType..::.Decimal Class See Also Send Feedback
Creates new instance of the DataType..::.Decimal class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Decimal(
    int precision,
    int scale
)
Visual Basic (Declaration)
Public Sub New ( _
    precision As Integer, _
    scale As Integer _
)
Visual C++
public:
Decimal(
    int precision,
    int scale
)

Parameters

precision
Type: System..::.Int32
scale
Type: System..::.Int32

See Also

DataType..::.Decimal Class
DataType..::.Decimal Overload


DataType.Decimal Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Decimal Methods
DataType..::.Decimal Class See Also Send Feedback

The DataType..::.Decimal type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.TypeWithPrecision.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Decimal Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Decimal..::.GetTypeDefinition Method
DataType..::.Decimal Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Decimal Class


DataType.Decimal Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Decimal Properties
DataType..::.Decimal Class See Also Send Feedback

The DataType..::.Decimal type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
Precision | Gets or sets the type precision. (Inherited from DataType..::.TypeWithPrecision.)
Scale | Gets or sets the type scale. (Inherited from DataType..::.TypeWithPrecision.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Decimal Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Decimal..::.DefaultValue Property
DataType..::.Decimal Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Decimal Class


DataType.Float Class

[image]

SQL Schema Sync API Class reference
DataType..::.Float Class
DataType Class Members See Also Send Feedback
Represents the float data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Float : DataType
Visual Basic (Declaration)
Public NotInheritable Class Float _
    Inherits DataType
Visual C++
public ref class Float sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Float

See Also

DataType..::.Float Members


DataType.Float Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Float Members
DataType..::.Float Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Float type exposes the following members.

Constructors

Name | Description
DataType..::.Float | Initializes a new instance of the DataType..::.Float class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Float Class


DataType.Float Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Float Constructor
DataType..::.Float Class See Also Send Feedback
Initializes a new instance of the DataType..::.Float class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Float()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Float()

See Also

DataType..::.Float Class


DataType.Float Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Float Methods
DataType..::.Float Class See Also Send Feedback

The DataType..::.Float type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Float Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Float..::.GetTypeDefinition Method
DataType..::.Float Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Float Class


DataType.Float Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Float Properties
DataType..::.Float Class See Also Send Feedback

The DataType..::.Float type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Float Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Float..::.DefaultValue Property
DataType..::.Float Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Float Class


DataType.Geography Class

[image]

SQL Schema Sync API Class reference
DataType..::.Geography Class
DataType Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DataType.Geography"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Geography : DataType
Visual Basic (Declaration)
Public NotInheritable Class Geography _
    Inherits DataType
Visual C++
public ref class Geography sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Geography

See Also

DataType..::.Geography Members


DataType.Geography Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Geography Members
DataType..::.Geography Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Geography type exposes the following members.

Constructors

Name | Description
DataType..::.Geography | Initializes a new instance of the DataType..::.Geography class

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Geography Class


DataType.Geography Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Geography Constructor
DataType..::.Geography Class See Also Send Feedback
Initializes a new instance of the DataType..::.Geography class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Geography()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Geography()

See Also

DataType..::.Geography Class


DataType.Geography Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Geography Methods
DataType..::.Geography Class See Also Send Feedback

The DataType..::.Geography type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Geography Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Geography..::.GetTypeDefinition Method
DataType..::.Geography Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DataType.Geography.GetTypeDefinition"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Geography Class


DataType.Geography Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Geography Properties
DataType..::.Geography Class See Also Send Feedback

The DataType..::.Geography type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Geography Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Geography..::.DefaultValue Property
DataType..::.Geography Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.Geography.DefaultValue"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Geography Class


DataType.Geometry Class

[image]

SQL Schema Sync API Class reference
DataType..::.Geometry Class
DataType Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DataType.Geometry"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Geometry : DataType
Visual Basic (Declaration)
Public NotInheritable Class Geometry _
    Inherits DataType
Visual C++
public ref class Geometry sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Geometry

See Also

DataType..::.Geometry Members


DataType.Geometry Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Geometry Members
DataType..::.Geometry Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Geometry type exposes the following members.

Constructors

Name | Description
DataType..::.Geometry | Initializes a new instance of the DataType..::.Geometry class

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Geometry Class


DataType.Geometry Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Geometry Constructor
DataType..::.Geometry Class See Also Send Feedback
Initializes a new instance of the DataType..::.Geometry class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Geometry()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Geometry()

See Also

DataType..::.Geometry Class


DataType.Geometry Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Geometry Methods
DataType..::.Geometry Class See Also Send Feedback

The DataType..::.Geometry type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Geometry Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Geometry..::.GetTypeDefinition Method
DataType..::.Geometry Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DataType.Geometry.GetTypeDefinition"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Geometry Class


DataType.Geometry Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Geometry Properties
DataType..::.Geometry Class See Also Send Feedback

The DataType..::.Geometry type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Geometry Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Geometry..::.DefaultValue Property
DataType..::.Geometry Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.Geometry.DefaultValue"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Geometry Class


DataType.Hierarchyid Class

[image]

SQL Schema Sync API Class reference
DataType..::.Hierarchyid Class
DataType Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DataType.Hierarchyid"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Hierarchyid : DataType
Visual Basic (Declaration)
Public NotInheritable Class Hierarchyid _
    Inherits DataType
Visual C++
public ref class Hierarchyid sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Hierarchyid

See Also

DataType..::.Hierarchyid Members


DataType.Hierarchyid Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Hierarchyid Members
DataType..::.Hierarchyid Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Hierarchyid type exposes the following members.

Constructors

Name | Description
DataType..::.Hierarchyid | Initializes a new instance of the DataType..::.Hierarchyid class

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Hierarchyid Class


DataType.Hierarchyid Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Hierarchyid Constructor
DataType..::.Hierarchyid Class See Also Send Feedback
Initializes a new instance of the DataType..::.Hierarchyid class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Hierarchyid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Hierarchyid()

See Also

DataType..::.Hierarchyid Class


DataType.Hierarchyid Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Hierarchyid Methods
DataType..::.Hierarchyid Class See Also Send Feedback

The DataType..::.Hierarchyid type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Hierarchyid Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Hierarchyid..::.GetTypeDefinition Method
DataType..::.Hierarchyid Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DataType.Hierarchyid.GetTypeDefinition"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Hierarchyid Class


DataType.Hierarchyid Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Hierarchyid Properties
DataType..::.Hierarchyid Class See Also Send Feedback

The DataType..::.Hierarchyid type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Hierarchyid Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Hierarchyid..::.DefaultValue Property
DataType..::.Hierarchyid Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.Hierarchyid.DefaultValue"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Hierarchyid Class


DataType.Image Class

[image]

SQL Schema Sync API Class reference
DataType..::.Image Class
DataType Class Members See Also Send Feedback
Represents the image data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Image : DataType
Visual Basic (Declaration)
Public NotInheritable Class Image _
    Inherits DataType
Visual C++
public ref class Image sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Image

See Also

DataType..::.Image Members


DataType.Image Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Image Members
DataType..::.Image Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Image type exposes the following members.

Constructors

Name | Description
DataType..::.Image | Initializes a new instance of the DataType..::.Image class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Image Class


DataType.Image Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Image Constructor
DataType..::.Image Class See Also Send Feedback
Initializes a new instance of the DataType..::.Image class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Image()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Image()

See Also

DataType..::.Image Class


DataType.Image Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Image Methods
DataType..::.Image Class See Also Send Feedback

The DataType..::.Image type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Image Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Image..::.GetTypeDefinition Method
DataType..::.Image Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Image Class


DataType.Image Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Image Properties
DataType..::.Image Class See Also Send Feedback

The DataType..::.Image type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Image Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Image..::.DefaultValue Property
DataType..::.Image Class See Also Send Feedback
Override. See DefaultValue. Gets ".

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Image Class


DataType.Int Class

[image]

SQL Schema Sync API Class reference
DataType..::.Int Class
DataType Class Members See Also Send Feedback
Represents the int data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Int : DataType
Visual Basic (Declaration)
Public NotInheritable Class Int _
    Inherits DataType
Visual C++
public ref class Int sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Int

See Also

DataType..::.Int Members


DataType.Int Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Int Members
DataType..::.Int Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Int type exposes the following members.

Constructors

Name | Description
DataType..::.Int | Initializes a new instance of the DataType..::.Int class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Int Class


DataType.Int Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Int Constructor
DataType..::.Int Class See Also Send Feedback
Initializes a new instance of the DataType..::.Int class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Int()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Int()

See Also

DataType..::.Int Class


DataType.Int Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Int Methods
DataType..::.Int Class See Also Send Feedback

The DataType..::.Int type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Int Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Int..::.GetTypeDefinition Method
DataType..::.Int Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Int Class


DataType.Int Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Int Properties
DataType..::.Int Class See Also Send Feedback

The DataType..::.Int type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Int Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Int..::.DefaultValue Property
DataType..::.Int Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Int Class


DataType.Money Class

[image]

SQL Schema Sync API Class reference
DataType..::.Money Class
DataType Class Members See Also Send Feedback
Represents the moey data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Money : DataType
Visual Basic (Declaration)
Public NotInheritable Class Money _
    Inherits DataType
Visual C++
public ref class Money sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Money

See Also

DataType..::.Money Members


DataType.Money Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Money Members
DataType..::.Money Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Money type exposes the following members.

Constructors

Name | Description
DataType..::.Money | Initializes a new instance of the DataType..::.Money class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Money Class


DataType.Money Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Money Constructor
DataType..::.Money Class See Also Send Feedback
Initializes a new instance of the DataType..::.Money class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Money()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Money()

See Also

DataType..::.Money Class


DataType.Money Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Money Methods
DataType..::.Money Class See Also Send Feedback

The DataType..::.Money type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Money Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Money..::.GetTypeDefinition Method
DataType..::.Money Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Money Class


DataType.Money Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Money Properties
DataType..::.Money Class See Also Send Feedback

The DataType..::.Money type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Money Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Money..::.DefaultValue Property
DataType..::.Money Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Money Class


DataType.NChar Class

[image]

SQL Schema Sync API Class reference
DataType..::.NChar Class
DataType Class Members See Also Send Feedback
Represents the nchar data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class NChar : DataType..::.SizedType
Visual Basic (Declaration)
Public NotInheritable Class NChar _
    Inherits DataType..::.SizedType
Visual C++
public ref class NChar sealed : public DataType..::.SizedType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.NChar

See Also

DataType..::.NChar Members


DataType.NChar Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NChar Members
DataType..::.NChar Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.NChar type exposes the following members.

Constructors

Name | Description
DataType..::.NChar | Overloaded.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.NChar Class


DataType.NChar Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NChar Constructor
DataType..::.NChar Class See Also Send Feedback

Overload List

Name | Description
DataType..::.NChar()()() | Initializes a new instance of the DataType..::.NChar class.
DataType..::.NChar(Int32) | Creates new instance of the DataType..::.NChar class.

See Also

DataType..::.NChar Class
DataType..::.NChar Members


DataType.NChar Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.NChar Constructor
DataType..::.NChar Class See Also Send Feedback
Initializes a new instance of the DataType..::.NChar class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public NChar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NChar()

See Also

DataType..::.NChar Class
DataType..::.NChar Overload


DataType.NChar Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.NChar Constructor (Int32)
DataType..::.NChar Class See Also Send Feedback
Creates new instance of the DataType..::.NChar class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public NChar(
    int maxsize
)
Visual Basic (Declaration)
Public Sub New ( _
    maxsize As Integer _
)
Visual C++
public:
NChar(
    int maxsize
)

Parameters

maxsize
Type: System..::.Int32

See Also

DataType..::.NChar Class
DataType..::.NChar Overload


DataType.NChar Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NChar Methods
DataType..::.NChar Class See Also Send Feedback

The DataType..::.NChar type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.NChar Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.NChar..::.GetTypeDefinition Method
DataType..::.NChar Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.NChar Class


DataType.NChar Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NChar Properties
DataType..::.NChar Class See Also Send Feedback

The DataType..::.NChar type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.NChar Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.NChar..::.DefaultValue Property
DataType..::.NChar Class See Also Send Feedback
Override. See DefaultValue. Gets ".

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.NChar Class


SupportCollation Property

[image]

SQL Schema Sync API Class reference
DataType..::.NChar..::.SupportCollation Property
DataType..::.NChar Class See Also Send Feedback
Override. See SupportCollation.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool SupportCollation { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SupportCollation As Boolean
Visual C++
public:
virtual property bool SupportCollation {
    bool get () override;
}

See Also

DataType..::.NChar Class


DataType.NText Class

[image]

SQL Schema Sync API Class reference
DataType..::.NText Class
DataType Class Members See Also Send Feedback
Represents the ntext data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class NText : DataType
Visual Basic (Declaration)
Public NotInheritable Class NText _
    Inherits DataType
Visual C++
public ref class NText sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.NText

See Also

DataType..::.NText Members


DataType.NText Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NText Members
DataType..::.NText Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.NText type exposes the following members.

Constructors

Name | Description
DataType..::.NText | Initializes a new instance of the DataType..::.NText class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.NText Class


DataType.NText Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.NText Constructor
DataType..::.NText Class See Also Send Feedback
Initializes a new instance of the DataType..::.NText class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public NText()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NText()

See Also

DataType..::.NText Class


DataType.NText Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NText Methods
DataType..::.NText Class See Also Send Feedback

The DataType..::.NText type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.NText Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.NText..::.GetTypeDefinition Method
DataType..::.NText Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.NText Class


DataType.NText Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NText Properties
DataType..::.NText Class See Also Send Feedback

The DataType..::.NText type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.NText Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.NText..::.DefaultValue Property
DataType..::.NText Class See Also Send Feedback
Override. See DefaultValue. Gets ".

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.NText Class


SupportCollation Property

[image]

SQL Schema Sync API Class reference
DataType..::.NText..::.SupportCollation Property
DataType..::.NText Class See Also Send Feedback
Override. See SupportCollation.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool SupportCollation { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SupportCollation As Boolean
Visual C++
public:
virtual property bool SupportCollation {
    bool get () override;
}

See Also

DataType..::.NText Class


DataType.Numeric Class

[image]

SQL Schema Sync API Class reference
DataType..::.Numeric Class
DataType Class Members See Also Send Feedback
Represents the numeric data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Numeric : DataType..::.TypeWithPrecision
Visual Basic (Declaration)
Public NotInheritable Class Numeric _
    Inherits DataType..::.TypeWithPrecision
Visual C++
public ref class Numeric sealed : public DataType..::.TypeWithPrecision

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.TypeWithPrecision
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Numeric

See Also

DataType..::.Numeric Members


DataType.Numeric Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Numeric Members
DataType..::.Numeric Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Numeric type exposes the following members.

Constructors

Name | Description
DataType..::.Numeric | Overloaded.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.TypeWithPrecision.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
Precision | Gets or sets the type precision. (Inherited from DataType..::.TypeWithPrecision.)
Scale | Gets or sets the type scale. (Inherited from DataType..::.TypeWithPrecision.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Numeric Class


DataType.Numeric Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Numeric Constructor
DataType..::.Numeric Class See Also Send Feedback

Overload List

Name | Description
DataType..::.Numeric()()() | Initializes a new instance of the DataType..::.Numeric class.
DataType..::.Numeric(Int32, Int32) | Creates new instance of the DataType..::.Numeric class.

See Also

DataType..::.Numeric Class
DataType..::.Numeric Members


DataType.Numeric Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Numeric Constructor
DataType..::.Numeric Class See Also Send Feedback
Initializes a new instance of the DataType..::.Numeric class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Numeric()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Numeric()

See Also

DataType..::.Numeric Class
DataType..::.Numeric Overload


DataType.Numeric Constructor (Int32, Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.Numeric Constructor (Int32, Int32)
DataType..::.Numeric Class See Also Send Feedback
Creates new instance of the DataType..::.Numeric class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Numeric(
    int precision,
    int scale
)
Visual Basic (Declaration)
Public Sub New ( _
    precision As Integer, _
    scale As Integer _
)
Visual C++
public:
Numeric(
    int precision,
    int scale
)

Parameters

precision
Type: System..::.Int32
scale
Type: System..::.Int32

See Also

DataType..::.Numeric Class
DataType..::.Numeric Overload


DataType.Numeric Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Numeric Methods
DataType..::.Numeric Class See Also Send Feedback

The DataType..::.Numeric type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.TypeWithPrecision.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Numeric Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Numeric..::.GetTypeDefinition Method
DataType..::.Numeric Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Numeric Class


DataType.Numeric Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Numeric Properties
DataType..::.Numeric Class See Also Send Feedback

The DataType..::.Numeric type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
Precision | Gets or sets the type precision. (Inherited from DataType..::.TypeWithPrecision.)
Scale | Gets or sets the type scale. (Inherited from DataType..::.TypeWithPrecision.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Numeric Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Numeric..::.DefaultValue Property
DataType..::.Numeric Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Numeric Class


DataType.NVarChar Class

[image]

SQL Schema Sync API Class reference
DataType..::.NVarChar Class
DataType Class Members See Also Send Feedback
Represents the nvarchar data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class NVarChar : DataType..::.SizedType
Visual Basic (Declaration)
Public NotInheritable Class NVarChar _
    Inherits DataType..::.SizedType
Visual C++
public ref class NVarChar sealed : public DataType..::.SizedType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.NVarChar

See Also

DataType..::.NVarChar Members


DataType.NVarChar Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NVarChar Members
DataType..::.NVarChar Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.NVarChar type exposes the following members.

Constructors

Name | Description
DataType..::.NVarChar | Overloaded.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.NVarChar Class


DataType.NVarChar Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NVarChar Constructor
DataType..::.NVarChar Class See Also Send Feedback

Overload List

Name | Description
DataType..::.NVarChar()()() | Initializes a new instance of the DataType..::.NVarChar class.
DataType..::.NVarChar(Int32) | Creates new instance of the DataType..::.NVarChar class.

See Also

DataType..::.NVarChar Class
DataType..::.NVarChar Members


DataType.NVarChar Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.NVarChar Constructor
DataType..::.NVarChar Class See Also Send Feedback
Initializes a new instance of the DataType..::.NVarChar class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public NVarChar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NVarChar()

See Also

DataType..::.NVarChar Class
DataType..::.NVarChar Overload


DataType.NVarChar Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.NVarChar Constructor (Int32)
DataType..::.NVarChar Class See Also Send Feedback
Creates new instance of the DataType..::.NVarChar class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public NVarChar(
    int maxsize
)
Visual Basic (Declaration)
Public Sub New ( _
    maxsize As Integer _
)
Visual C++
public:
NVarChar(
    int maxsize
)

Parameters

maxsize
Type: System..::.Int32

See Also

DataType..::.NVarChar Class
DataType..::.NVarChar Overload


DataType.NVarChar Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NVarChar Methods
DataType..::.NVarChar Class See Also Send Feedback

The DataType..::.NVarChar type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.NVarChar Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.NVarChar..::.GetTypeDefinition Method
DataType..::.NVarChar Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.NVarChar Class


DataType.NVarChar Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.NVarChar Properties
DataType..::.NVarChar Class See Also Send Feedback

The DataType..::.NVarChar type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.NVarChar Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.NVarChar..::.DefaultValue Property
DataType..::.NVarChar Class See Also Send Feedback
Override. See DefaultValue. Gets ".

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.NVarChar Class


SupportCollation Property

[image]

SQL Schema Sync API Class reference
DataType..::.NVarChar..::.SupportCollation Property
DataType..::.NVarChar Class See Also Send Feedback
Override. See SupportCollation.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool SupportCollation { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SupportCollation As Boolean
Visual C++
public:
virtual property bool SupportCollation {
    bool get () override;
}

See Also

DataType..::.NVarChar Class


DataType.Real Class

[image]

SQL Schema Sync API Class reference
DataType..::.Real Class
DataType Class Members See Also Send Feedback
Represents the real data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Real : DataType
Visual Basic (Declaration)
Public NotInheritable Class Real _
    Inherits DataType
Visual C++
public ref class Real sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Real

See Also

DataType..::.Real Members


DataType.Real Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Real Members
DataType..::.Real Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Real type exposes the following members.

Constructors

Name | Description
DataType..::.Real | Initializes a new instance of the DataType..::.Real class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Real Class


DataType.Real Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Real Constructor
DataType..::.Real Class See Also Send Feedback
Initializes a new instance of the DataType..::.Real class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Real()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Real()

See Also

DataType..::.Real Class


DataType.Real Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Real Methods
DataType..::.Real Class See Also Send Feedback

The DataType..::.Real type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Real Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Real..::.GetTypeDefinition Method
DataType..::.Real Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Real Class


DataType.Real Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Real Properties
DataType..::.Real Class See Also Send Feedback

The DataType..::.Real type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Real Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Real..::.DefaultValue Property
DataType..::.Real Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Real Class


DataType.SizedType Class

[image]

SQL Schema Sync API Class reference
DataType..::.SizedType Class
DataType Class Members See Also Send Feedback
Abstract base class for the types defined by size.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class SizedType : DataType
Visual Basic (Declaration)
Public MustInherit Class SizedType _
    Inherits DataType
Visual C++
public ref class SizedType abstract : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Binary
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Char
PerpetuumSoft.DataModel.MsSql..::.DataType..::.NChar
PerpetuumSoft.DataModel.MsSql..::.DataType..::.NVarChar
PerpetuumSoft.DataModel.MsSql..::.DataType..::.VarBinary
PerpetuumSoft.DataModel.MsSql..::.DataType..::.VarChar

See Also

DataType..::.SizedType Members


DataType.SizedType Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SizedType Members
DataType..::.SizedType Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.SizedType type exposes the following members.

Constructors

Name | Description
DataType..::.SizedType | Overloaded.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Overrides DataType..::.DataTypeEquals(DataType).)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Returns the sql type definition. (Inherited from DataType.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Gets default value for a type. (Inherited from DataType.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types.
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.SizedType Class


DataType.SizedType Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SizedType Constructor
DataType..::.SizedType Class See Also Send Feedback

Overload List

Name | Description
DataType..::.SizedType()()() | Initializes a new instance of the DataType..::.SizedType class.
DataType..::.SizedType(Int32) | Creates a new instance of the DataType..::.SizedType class.

See Also

DataType..::.SizedType Class
DataType..::.SizedType Members


DataType.SizedType Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.SizedType Constructor
DataType..::.SizedType Class See Also Send Feedback
Initializes a new instance of the DataType..::.SizedType class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SizedType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SizedType()

See Also

DataType..::.SizedType Class
DataType..::.SizedType Overload


DataType.SizedType Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.SizedType Constructor (Int32)
DataType..::.SizedType Class See Also Send Feedback
Creates a new instance of the DataType..::.SizedType class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SizedType(
    int maxSize
)
Visual Basic (Declaration)
Public Sub New ( _
    maxSize As Integer _
)
Visual C++
public:
SizedType(
    int maxSize
)

Parameters

maxSize
Type: System..::.Int32

See Also

DataType..::.SizedType Class
DataType..::.SizedType Overload


DataType.SizedType Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SizedType Methods
DataType..::.SizedType Class See Also Send Feedback

The DataType..::.SizedType type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Overrides DataType..::.DataTypeEquals(DataType).)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Returns the sql type definition. (Inherited from DataType.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.SizedType Class


DataTypeEquals Method

[image]

SQL Schema Sync API Class reference
DataType..::.SizedType..::.DataTypeEquals Method
DataType..::.SizedType Class See Also Send Feedback
Overridden. See DataTypeEquals(DataType).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool DataTypeEquals(
    DataType dt
)
Visual Basic (Declaration)
Public Overrides Function DataTypeEquals ( _
    dt As DataType _
) As Boolean
Visual C++
public:
virtual bool DataTypeEquals(
    DataType^ dt
) override

Parameters

dt
Type: PerpetuumSoft.DataModel.MsSql..::.DataType

See Also

DataType..::.SizedType Class


GetSizePresentation Method

[image]

SQL Schema Sync API Class reference
DataType..::.SizedType..::.GetSizePresentation Method
DataType..::.SizedType Class See Also Send Feedback
Returns string presentation of the type size.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected string GetSizePresentation()
Visual Basic (Declaration)
Protected Function GetSizePresentation As String
Visual C++
protected:
String^ GetSizePresentation()

See Also

DataType..::.SizedType Class


DataType.SizedType Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SizedType Properties
DataType..::.SizedType Class See Also Send Feedback

The DataType..::.SizedType type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Gets default value for a type. (Inherited from DataType.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types.
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.SizedType Class


MaxSize Property

[image]

SQL Schema Sync API Class reference
DataType..::.SizedType..::.MaxSize Property
DataType..::.SizedType Class See Also Send Feedback
Gets or sets maximum size for the sizing types.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int MaxSize { get; set; }
Visual Basic (Declaration)
Public Property MaxSize As Integer
Visual C++
public:
property int MaxSize {
    int get ();
    void set (int value);
}

See Also

DataType..::.SizedType Class


DataType.SmallDateTime Class

[image]

SQL Schema Sync API Class reference
DataType..::.SmallDateTime Class
DataType Class Members See Also Send Feedback
Represents the smalldatetime data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class SmallDateTime : DataType
Visual Basic (Declaration)
Public NotInheritable Class SmallDateTime _
    Inherits DataType
Visual C++
public ref class SmallDateTime sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SmallDateTime

See Also

DataType..::.SmallDateTime Members


DataType.SmallDateTime Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SmallDateTime Members
DataType..::.SmallDateTime Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.SmallDateTime type exposes the following members.

Constructors

Name | Description
DataType..::.SmallDateTime | Initializes a new instance of the DataType..::.SmallDateTime class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.SmallDateTime Class


DataType.SmallDateTime Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.SmallDateTime Constructor
DataType..::.SmallDateTime Class See Also Send Feedback
Initializes a new instance of the DataType..::.SmallDateTime class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SmallDateTime()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SmallDateTime()

See Also

DataType..::.SmallDateTime Class


DataType.SmallDateTime Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SmallDateTime Methods
DataType..::.SmallDateTime Class See Also Send Feedback

The DataType..::.SmallDateTime type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.SmallDateTime Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.SmallDateTime..::.GetTypeDefinition Method
DataType..::.SmallDateTime Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.SmallDateTime Class


DataType.SmallDateTime Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SmallDateTime Properties
DataType..::.SmallDateTime Class See Also Send Feedback

The DataType..::.SmallDateTime type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.SmallDateTime Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.SmallDateTime..::.DefaultValue Property
DataType..::.SmallDateTime Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.SmallDateTime Class


DataType.SmallInt Class

[image]

SQL Schema Sync API Class reference
DataType..::.SmallInt Class
DataType Class Members See Also Send Feedback
Represents the smallint data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class SmallInt : DataType
Visual Basic (Declaration)
Public NotInheritable Class SmallInt _
    Inherits DataType
Visual C++
public ref class SmallInt sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SmallInt

See Also

DataType..::.SmallInt Members


DataType.SmallInt Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SmallInt Members
DataType..::.SmallInt Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.SmallInt type exposes the following members.

Constructors

Name | Description
DataType..::.SmallInt | Initializes a new instance of the DataType..::.SmallInt class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.SmallInt Class


DataType.SmallInt Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.SmallInt Constructor
DataType..::.SmallInt Class See Also Send Feedback
Initializes a new instance of the DataType..::.SmallInt class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SmallInt()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SmallInt()

See Also

DataType..::.SmallInt Class


DataType.SmallInt Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SmallInt Methods
DataType..::.SmallInt Class See Also Send Feedback

The DataType..::.SmallInt type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.SmallInt Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.SmallInt..::.GetTypeDefinition Method
DataType..::.SmallInt Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.SmallInt Class


DataType.SmallInt Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SmallInt Properties
DataType..::.SmallInt Class See Also Send Feedback

The DataType..::.SmallInt type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.SmallInt Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.SmallInt..::.DefaultValue Property
DataType..::.SmallInt Class See Also Send Feedback
Override. See DefaultValue.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.SmallInt Class


DataType.SmallMoney Class

[image]

SQL Schema Sync API Class reference
DataType..::.SmallMoney Class
DataType Class Members See Also Send Feedback
Represents the smallmoney data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class SmallMoney : DataType
Visual Basic (Declaration)
Public NotInheritable Class SmallMoney _
    Inherits DataType
Visual C++
public ref class SmallMoney sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SmallMoney

See Also

DataType..::.SmallMoney Members


DataType.SmallMoney Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SmallMoney Members
DataType..::.SmallMoney Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.SmallMoney type exposes the following members.

Constructors

Name | Description
DataType..::.SmallMoney | Initializes a new instance of the DataType..::.SmallMoney class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.SmallMoney Class


DataType.SmallMoney Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.SmallMoney Constructor
DataType..::.SmallMoney Class See Also Send Feedback
Initializes a new instance of the DataType..::.SmallMoney class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SmallMoney()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SmallMoney()

See Also

DataType..::.SmallMoney Class


DataType.SmallMoney Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SmallMoney Methods
DataType..::.SmallMoney Class See Also Send Feedback

The DataType..::.SmallMoney type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.SmallMoney Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.SmallMoney..::.GetTypeDefinition Method
DataType..::.SmallMoney Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.SmallMoney Class


DataType.SmallMoney Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SmallMoney Properties
DataType..::.SmallMoney Class See Also Send Feedback

The DataType..::.SmallMoney type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.SmallMoney Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.SmallMoney..::.DefaultValue Property
DataType..::.SmallMoney Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.SmallMoney Class


DataType.SqlVariant Class

[image]

SQL Schema Sync API Class reference
DataType..::.SqlVariant Class
DataType Class Members See Also Send Feedback
Represents the sqlvariant data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class SqlVariant : DataType
Visual Basic (Declaration)
Public NotInheritable Class SqlVariant _
    Inherits DataType
Visual C++
public ref class SqlVariant sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SqlVariant

See Also

DataType..::.SqlVariant Members


DataType.SqlVariant Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SqlVariant Members
DataType..::.SqlVariant Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.SqlVariant type exposes the following members.

Constructors

Name | Description
DataType..::.SqlVariant | Initializes a new instance of the DataType..::.SqlVariant class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.SqlVariant Class


DataType.SqlVariant Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.SqlVariant Constructor
DataType..::.SqlVariant Class See Also Send Feedback
Initializes a new instance of the DataType..::.SqlVariant class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SqlVariant()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SqlVariant()

See Also

DataType..::.SqlVariant Class


DataType.SqlVariant Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SqlVariant Methods
DataType..::.SqlVariant Class See Also Send Feedback

The DataType..::.SqlVariant type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.SqlVariant Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.SqlVariant..::.GetTypeDefinition Method
DataType..::.SqlVariant Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.SqlVariant Class


DataType.SqlVariant Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.SqlVariant Properties
DataType..::.SqlVariant Class See Also Send Feedback

The DataType..::.SqlVariant type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.SqlVariant Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.SqlVariant..::.DefaultValue Property
DataType..::.SqlVariant Class See Also Send Feedback
Override. See DefaultValue. Gets ".

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.SqlVariant Class


DataType.Text Class

[image]

SQL Schema Sync API Class reference
DataType..::.Text Class
DataType Class Members See Also Send Feedback
Represents the text data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Text : DataType
Visual Basic (Declaration)
Public NotInheritable Class Text _
    Inherits DataType
Visual C++
public ref class Text sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Text

See Also

DataType..::.Text Members


DataType.Text Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Text Members
DataType..::.Text Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Text type exposes the following members.

Constructors

Name | Description
DataType..::.Text | Initializes a new instance of the DataType..::.Text class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.Text Class


DataType.Text Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Text Constructor
DataType..::.Text Class See Also Send Feedback
Initializes a new instance of the DataType..::.Text class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Text()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Text()

See Also

DataType..::.Text Class


DataType.Text Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Text Methods
DataType..::.Text Class See Also Send Feedback

The DataType..::.Text type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Text Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Text..::.GetTypeDefinition Method
DataType..::.Text Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Text Class


DataType.Text Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Text Properties
DataType..::.Text Class See Also Send Feedback

The DataType..::.Text type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.Text Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Text..::.DefaultValue Property
DataType..::.Text Class See Also Send Feedback
Override. See DefaultValue. Gets ".

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Text Class


SupportCollation Property

[image]

SQL Schema Sync API Class reference
DataType..::.Text..::.SupportCollation Property
DataType..::.Text Class See Also Send Feedback
Override. See SupportCollation.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool SupportCollation { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SupportCollation As Boolean
Visual C++
public:
virtual property bool SupportCollation {
    bool get () override;
}

See Also

DataType..::.Text Class


DataType.Time Class

[image]

SQL Schema Sync API Class reference
DataType..::.Time Class
DataType Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DataType.Time"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Time : DataType..::.DateSizedType
Visual Basic (Declaration)
Public NotInheritable Class Time _
    Inherits DataType..::.DateSizedType
Visual C++
public ref class Time sealed : public DataType..::.DateSizedType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.DateSizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Time

See Also

DataType..::.Time Members


DataType.Time Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Time Members
DataType..::.Time Class Constructors Methods Fields Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Time type exposes the following members.

Constructors

Name | Description
DataType..::.Time | Overloaded.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Fields

Name | Description
_maxSize | (Inherited from DataType..::.DateSizedType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | (Inherited from DataType..::.DateSizedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Time Class


DataType.Time Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Time Constructor
DataType..::.Time Class See Also Send Feedback

Overload List

Name | Description
DataType..::.Time()()() | Initializes a new instance of the DataType..::.Time class
DataType..::.Time(Int32) | Initializes a new instance of the DataType..::.Time class

See Also

DataType..::.Time Class
DataType..::.Time Members


DataType.Time Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Time Constructor
DataType..::.Time Class See Also Send Feedback
Initializes a new instance of the DataType..::.Time class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Time()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Time()

See Also

DataType..::.Time Class
DataType..::.Time Overload


DataType.Time Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.Time Constructor (Int32)
DataType..::.Time Class See Also Send Feedback
Initializes a new instance of the DataType..::.Time class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Time(
    int maxSize
)
Visual Basic (Declaration)
Public Sub New ( _
    maxSize As Integer _
)
Visual C++
public:
Time(
    int maxSize
)

Parameters

maxSize
Type: System..::.Int32

See Also

DataType..::.Time Class
DataType..::.Time Overload


DataType.Time Fields

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Time Fields
DataType..::.Time Class See Also Send Feedback

The DataType..::.Time type exposes the following members.

Fields

Name | Description
_maxSize | (Inherited from DataType..::.DateSizedType.)

See Also

DataType..::.Time Class


DataType.Time Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Time Methods
DataType..::.Time Class See Also Send Feedback

The DataType..::.Time type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Time Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Time..::.GetTypeDefinition Method
DataType..::.Time Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DataType.Time.GetTypeDefinition"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Time Class


DataType.Time Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Time Properties
DataType..::.Time Class See Also Send Feedback

The DataType..::.Time type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | (Inherited from DataType..::.DateSizedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.Time Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Time..::.DefaultValue Property
DataType..::.Time Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.Time.DefaultValue"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Time Class


DataType.TimeStamp Class

[image]

SQL Schema Sync API Class reference
DataType..::.TimeStamp Class
DataType Class Members See Also Send Feedback
Represents the timestamp data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class TimeStamp : DataType
Visual Basic (Declaration)
Public NotInheritable Class TimeStamp _
    Inherits DataType
Visual C++
public ref class TimeStamp sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.TimeStamp

See Also

DataType..::.TimeStamp Members


DataType.TimeStamp Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.TimeStamp Members
DataType..::.TimeStamp Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.TimeStamp type exposes the following members.

Constructors

Name | Description
DataType..::.TimeStamp | Initializes a new instance of the DataType..::.TimeStamp class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. This type doesn't support the default value. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.TimeStamp Class


DataType.TimeStamp Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.TimeStamp Constructor
DataType..::.TimeStamp Class See Also Send Feedback
Initializes a new instance of the DataType..::.TimeStamp class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TimeStamp()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeStamp()

See Also

DataType..::.TimeStamp Class


DataType.TimeStamp Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.TimeStamp Methods
DataType..::.TimeStamp Class See Also Send Feedback

The DataType..::.TimeStamp type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.TimeStamp Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.TimeStamp..::.GetTypeDefinition Method
DataType..::.TimeStamp Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.TimeStamp Class


DataType.TimeStamp Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.TimeStamp Properties
DataType..::.TimeStamp Class See Also Send Feedback

The DataType..::.TimeStamp type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. This type doesn't support the default value. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.TimeStamp Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.TimeStamp..::.DefaultValue Property
DataType..::.TimeStamp Class See Also Send Feedback
Override. See DefaultValue. This type doesn't support the default value.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.TimeStamp Class


DataType.TinyInt Class

[image]

SQL Schema Sync API Class reference
DataType..::.TinyInt Class
DataType Class Members See Also Send Feedback
Represents the tinyint data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class TinyInt : DataType
Visual Basic (Declaration)
Public NotInheritable Class TinyInt _
    Inherits DataType
Visual C++
public ref class TinyInt sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.TinyInt

See Also

DataType..::.TinyInt Members


DataType.TinyInt Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.TinyInt Members
DataType..::.TinyInt Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.TinyInt type exposes the following members.

Constructors

Name | Description
DataType..::.TinyInt | Initializes a new instance of the DataType..::.TinyInt class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.TinyInt Class


DataType.TinyInt Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.TinyInt Constructor
DataType..::.TinyInt Class See Also Send Feedback
Initializes a new instance of the DataType..::.TinyInt class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TinyInt()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TinyInt()

See Also

DataType..::.TinyInt Class


DataType.TinyInt Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.TinyInt Methods
DataType..::.TinyInt Class See Also Send Feedback

The DataType..::.TinyInt type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.TinyInt Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.TinyInt..::.GetTypeDefinition Method
DataType..::.TinyInt Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.TinyInt Class


DataType.TinyInt Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.TinyInt Properties
DataType..::.TinyInt Class See Also Send Feedback

The DataType..::.TinyInt type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.TinyInt Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.TinyInt..::.DefaultValue Property
DataType..::.TinyInt Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.TinyInt Class


DataType.TypeWithPrecision Class

[image]

SQL Schema Sync API Class reference
DataType..::.TypeWithPrecision Class
DataType Class Members See Also Send Feedback
Base class for the types defined by scale and precision.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class TypeWithPrecision : DataType
Visual Basic (Declaration)
Public MustInherit Class TypeWithPrecision _
    Inherits DataType
Visual C++
public ref class TypeWithPrecision abstract : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.TypeWithPrecision
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Decimal
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Numeric

See Also

DataType..::.TypeWithPrecision Members


DataType.TypeWithPrecision Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.TypeWithPrecision Members
DataType..::.TypeWithPrecision Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.TypeWithPrecision type exposes the following members.

Constructors

Name | Description
DataType..::.TypeWithPrecision | Initializes a new instance of the DataType..::.TypeWithPrecision class

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Overrides DataType..::.DataTypeEquals(DataType).)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Returns the sql type definition. (Inherited from DataType.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Gets default value for a type. (Inherited from DataType.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
Precision | Gets or sets the type precision.
Scale | Gets or sets the type scale.
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.TypeWithPrecision Class


DataType.TypeWithPrecision Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.TypeWithPrecision Constructor
DataType..::.TypeWithPrecision Class See Also Send Feedback
Initializes a new instance of the DataType..::.TypeWithPrecision class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected TypeWithPrecision()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
TypeWithPrecision()

See Also

DataType..::.TypeWithPrecision Class


DataType.TypeWithPrecision Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.TypeWithPrecision Methods
DataType..::.TypeWithPrecision Class See Also Send Feedback

The DataType..::.TypeWithPrecision type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Overrides DataType..::.DataTypeEquals(DataType).)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Returns the sql type definition. (Inherited from DataType.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.TypeWithPrecision Class


DataTypeEquals Method

[image]

SQL Schema Sync API Class reference
DataType..::.TypeWithPrecision..::.DataTypeEquals Method
DataType..::.TypeWithPrecision Class See Also Send Feedback
Overridden. See DataTypeEquals(DataType).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool DataTypeEquals(
    DataType dt
)
Visual Basic (Declaration)
Public Overrides Function DataTypeEquals ( _
    dt As DataType _
) As Boolean
Visual C++
public:
virtual bool DataTypeEquals(
    DataType^ dt
) override

Parameters

dt
Type: PerpetuumSoft.DataModel.MsSql..::.DataType

See Also

DataType..::.TypeWithPrecision Class


DataType.TypeWithPrecision Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.TypeWithPrecision Properties
DataType..::.TypeWithPrecision Class See Also Send Feedback

The DataType..::.TypeWithPrecision type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Gets default value for a type. (Inherited from DataType.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
Precision | Gets or sets the type precision.
Scale | Gets or sets the type scale.
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.TypeWithPrecision Class


Precision Property

[image]

SQL Schema Sync API Class reference
DataType..::.TypeWithPrecision..::.Precision Property
DataType..::.TypeWithPrecision Class See Also Send Feedback
Gets or sets the type precision.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int Precision { get; set; }
Visual Basic (Declaration)
Public Property Precision As Integer
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

DataType..::.TypeWithPrecision Class


Scale Property

[image]

SQL Schema Sync API Class reference
DataType..::.TypeWithPrecision..::.Scale Property
DataType..::.TypeWithPrecision Class See Also Send Feedback
Gets or sets the type scale.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int Scale { get; set; }
Visual Basic (Declaration)
Public Property Scale As Integer
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

See Also

DataType..::.TypeWithPrecision Class


DataType.UniqueIdentifier Class

[image]

SQL Schema Sync API Class reference
DataType..::.UniqueIdentifier Class
DataType Class Members See Also Send Feedback
Represents the uniqueidentifier data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class UniqueIdentifier : DataType
Visual Basic (Declaration)
Public NotInheritable Class UniqueIdentifier _
    Inherits DataType
Visual C++
public ref class UniqueIdentifier sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.UniqueIdentifier

See Also

DataType..::.UniqueIdentifier Members


DataType.UniqueIdentifier Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UniqueIdentifier Members
DataType..::.UniqueIdentifier Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.UniqueIdentifier type exposes the following members.

Constructors

Name | Description
DataType..::.UniqueIdentifier | Initializes a new instance of the DataType..::.UniqueIdentifier class.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets '00000000-0000-0000-0000-000000000000'. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.UniqueIdentifier Class


DataType.UniqueIdentifier Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.UniqueIdentifier Constructor
DataType..::.UniqueIdentifier Class See Also Send Feedback
Initializes a new instance of the DataType..::.UniqueIdentifier class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UniqueIdentifier()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UniqueIdentifier()

See Also

DataType..::.UniqueIdentifier Class


DataType.UniqueIdentifier Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UniqueIdentifier Methods
DataType..::.UniqueIdentifier Class See Also Send Feedback

The DataType..::.UniqueIdentifier type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.UniqueIdentifier Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.UniqueIdentifier..::.GetTypeDefinition Method
DataType..::.UniqueIdentifier Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.UniqueIdentifier Class


DataType.UniqueIdentifier Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UniqueIdentifier Properties
DataType..::.UniqueIdentifier Class See Also Send Feedback

The DataType..::.UniqueIdentifier type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets '00000000-0000-0000-0000-000000000000'. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.UniqueIdentifier Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.UniqueIdentifier..::.DefaultValue Property
DataType..::.UniqueIdentifier Class See Also Send Feedback
Override. See DefaultValue. Gets '00000000-0000-0000-0000-000000000000'.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.UniqueIdentifier Class


DataType.UserCLRType Class

[image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType Class
DataType Class Members See Also Send Feedback
Represents user CLR type in hte database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class UserCLRType : DataType
Visual Basic (Declaration)
Public NotInheritable Class UserCLRType _
    Inherits DataType
Visual C++
public ref class UserCLRType sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.UserCLRType

See Also

DataType..::.UserCLRType Members


DataType.UserCLRType Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType Members
DataType..::.UserCLRType Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.UserCLRType type exposes the following members.

Constructors

Name | Description
DataType..::.UserCLRType | Overloaded.

Methods

Name | Description
DataTypeEquals | Override. See DataTypeEquals(DataType). (Overrides DataType..::.DataTypeEquals(DataType).)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Override. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. This type doesn't support the default value. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Override. See IsUserDefinedType. (Overrides DataType..::.IsUserDefinedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)
TypeReference | Gets or sets reference to the corresponding CLRType type.

See Also

DataType..::.UserCLRType Class


DataType.UserCLRType Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType Constructor
DataType..::.UserCLRType Class See Also Send Feedback

Overload List

Name | Description
DataType..::.UserCLRType()()() | Creates new instance of the DataType..::.UserCLRType class.
DataType..::.UserCLRType(CLRType) | Creates new instance of the DataType..::.UserCLRType class.

See Also

DataType..::.UserCLRType Class
DataType..::.UserCLRType Members


DataType.UserCLRType Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType Constructor
DataType..::.UserCLRType Class See Also Send Feedback
Creates new instance of the DataType..::.UserCLRType class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UserCLRType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserCLRType()

See Also

DataType..::.UserCLRType Class
DataType..::.UserCLRType Overload


DataType.UserCLRType Constructor (CLRType)

[image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType Constructor (CLRType)
DataType..::.UserCLRType Class See Also Send Feedback
Creates new instance of the DataType..::.UserCLRType class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UserCLRType(
    CLRType typeReference
)
Visual Basic (Declaration)
Public Sub New ( _
    typeReference As CLRType _
)
Visual C++
public:
UserCLRType(
    CLRType^ typeReference
)

Parameters

typeReference
Type: PerpetuumSoft.DataModel.MsSql..::.CLRType

See Also

DataType..::.UserCLRType Class
DataType..::.UserCLRType Overload


DataType.UserCLRType Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType Methods
DataType..::.UserCLRType Class See Also Send Feedback

The DataType..::.UserCLRType type exposes the following members.

Methods

Name | Description
DataTypeEquals | Override. See DataTypeEquals(DataType). (Overrides DataType..::.DataTypeEquals(DataType).)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Override. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.UserCLRType Class


DataTypeEquals Method

[image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType..::.DataTypeEquals Method
DataType..::.UserCLRType Class See Also Send Feedback
Override. See DataTypeEquals(DataType).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool DataTypeEquals(
    DataType dt
)
Visual Basic (Declaration)
Public Overrides Function DataTypeEquals ( _
    dt As DataType _
) As Boolean
Visual C++
public:
virtual bool DataTypeEquals(
    DataType^ dt
) override

Parameters

dt
Type: PerpetuumSoft.DataModel.MsSql..::.DataType

See Also

DataType..::.UserCLRType Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType..::.GetTypeDefinition Method
DataType..::.UserCLRType Class See Also Send Feedback
Override. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.UserCLRType Class


DataType.UserCLRType Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType Properties
DataType..::.UserCLRType Class See Also Send Feedback

The DataType..::.UserCLRType type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. This type doesn't support the default value. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Override. See IsUserDefinedType. (Overrides DataType..::.IsUserDefinedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)
TypeReference | Gets or sets reference to the corresponding CLRType type.

See Also

DataType..::.UserCLRType Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType..::.DefaultValue Property
DataType..::.UserCLRType Class See Also Send Feedback
Override. See DefaultValue. This type doesn't support the default value.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.UserCLRType Class


IsUserDefinedType Property

[image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType..::.IsUserDefinedType Property
DataType..::.UserCLRType Class See Also Send Feedback
Override. See IsUserDefinedType.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool IsUserDefinedType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsUserDefinedType As Boolean
Visual C++
public:
virtual property bool IsUserDefinedType {
    bool get () override;
}

See Also

DataType..::.UserCLRType Class


TypeReference Property

[image]

SQL Schema Sync API Class reference
DataType..::.UserCLRType..::.TypeReference Property
DataType..::.UserCLRType Class See Also Send Feedback
Gets or sets reference to the corresponding CLRType type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public CLRType TypeReference { get; set; }
Visual Basic (Declaration)
Public Property TypeReference As CLRType
Visual C++
public:
property CLRType^ TypeReference {
    CLRType^ get ();
    void set (CLRType^ value);
}

See Also

DataType..::.UserCLRType Class


DataType.UserTableType Class

[image]

SQL Schema Sync API Class reference
DataType..::.UserTableType Class
DataType Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DataType.UserTableType"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class UserTableType : DataType
Visual Basic (Declaration)
Public NotInheritable Class UserTableType _
    Inherits DataType
Visual C++
public ref class UserTableType sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.UserTableType

See Also

DataType..::.UserTableType Members


DataType.UserTableType Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserTableType Members
DataType..::.UserTableType Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.UserTableType type exposes the following members.

Constructors

Name | Description
DataType..::.UserTableType | Overloaded.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | (Overrides DataType..::.IsUserDefinedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)
TypeReference |

See Also

DataType..::.UserTableType Class


DataType.UserTableType Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserTableType Constructor
DataType..::.UserTableType Class See Also Send Feedback

Overload List

Name | Description
DataType..::.UserTableType()()() | Initializes a new instance of the DataType..::.UserTableType class
DataType..::.UserTableType(TableTypeSql10) | Initializes a new instance of the DataType..::.UserTableType class

See Also

DataType..::.UserTableType Class
DataType..::.UserTableType Members


DataType.UserTableType Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.UserTableType Constructor
DataType..::.UserTableType Class See Also Send Feedback
Initializes a new instance of the DataType..::.UserTableType class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UserTableType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserTableType()

See Also

DataType..::.UserTableType Class
DataType..::.UserTableType Overload


DataType.UserTableType Constructor (TableTypeSql10)

[image]

SQL Schema Sync API Class reference
DataType..::.UserTableType Constructor (TableTypeSql10)
DataType..::.UserTableType Class See Also Send Feedback
Initializes a new instance of the DataType..::.UserTableType class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UserTableType(
    TableTypeSql10 typeReference
)
Visual Basic (Declaration)
Public Sub New ( _
    typeReference As TableTypeSql10 _
)
Visual C++
public:
UserTableType(
    TableTypeSql10^ typeReference
)

Parameters

typeReference
Type: PerpetuumSoft.DataModel.MsSql..::.TableTypeSql10

See Also

DataType..::.UserTableType Class
DataType..::.UserTableType Overload


DataType.UserTableType Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserTableType Methods
DataType..::.UserTableType Class See Also Send Feedback

The DataType..::.UserTableType type exposes the following members.

Methods

Name | Description
DataTypeEquals | Returns if data types are equal. (Inherited from DataType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.UserTableType Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.UserTableType..::.GetTypeDefinition Method
DataType..::.UserTableType Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.DataType.UserTableType.GetTypeDefinition"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.UserTableType Class


DataType.UserTableType Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserTableType Properties
DataType..::.UserTableType Class See Also Send Feedback

The DataType..::.UserTableType type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | (Overrides DataType..::.IsUserDefinedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)
TypeReference |

See Also

DataType..::.UserTableType Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.UserTableType..::.DefaultValue Property
DataType..::.UserTableType Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.UserTableType.DefaultValue"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.UserTableType Class


IsUserDefinedType Property

[image]

SQL Schema Sync API Class reference
DataType..::.UserTableType..::.IsUserDefinedType Property
DataType..::.UserTableType Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.UserTableType.IsUserDefinedType"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool IsUserDefinedType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsUserDefinedType As Boolean
Visual C++
public:
virtual property bool IsUserDefinedType {
    bool get () override;
}

See Also

DataType..::.UserTableType Class


TypeReference Property

[image]

SQL Schema Sync API Class reference
DataType..::.UserTableType..::.TypeReference Property
DataType..::.UserTableType Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.DataType.UserTableType.TypeReference"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableTypeSql10 TypeReference { get; set; }
Visual Basic (Declaration)
Public Property TypeReference As TableTypeSql10
Visual C++
public:
property TableTypeSql10^ TypeReference {
    TableTypeSql10^ get ();
    void set (TableTypeSql10^ value);
}

See Also

DataType..::.UserTableType Class


DataType.UserType Class

[image]

SQL Schema Sync API Class reference
DataType..::.UserType Class
DataType Class Members See Also Send Feedback
Represents the user defined data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class UserType : DataType
Visual Basic (Declaration)
Public NotInheritable Class UserType _
    Inherits DataType
Visual C++
public ref class UserType sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.UserType

See Also

DataType..::.UserType Members


DataType.UserType Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserType Members
DataType..::.UserType Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.UserType type exposes the following members.

Constructors

Name | Description
DataType..::.UserType | Overloaded.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Overrides DataType..::.DataTypeEquals(DataType).)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Overridden. See BaseType. (Overrides DataType..::.BaseType.)
DefaultValue | Override. See DefaultValue. The default value corresponds the basic type default value. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Overridden. See IsUserDefinedType. (Overrides DataType..::.IsUserDefinedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)
TypeReference | Gets or sets UserDefinedType associated with this UserType.

See Also

DataType..::.UserType Class


DataType.UserType Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserType Constructor
DataType..::.UserType Class See Also Send Feedback

Overload List

Name | Description
DataType..::.UserType()()() | Initializes a new instance of the DataType..::.UserType class.
DataType..::.UserType(UserDefinedType) | Initializes a new instance of the DataType..::.UserType class.

See Also

DataType..::.UserType Class
DataType..::.UserType Members


DataType.UserType Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.UserType Constructor
DataType..::.UserType Class See Also Send Feedback
Initializes a new instance of the DataType..::.UserType class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UserType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserType()

See Also

DataType..::.UserType Class
DataType..::.UserType Overload


DataType.UserType Constructor (UserDefinedType)

[image]

SQL Schema Sync API Class reference
DataType..::.UserType Constructor (UserDefinedType)
DataType..::.UserType Class See Also Send Feedback
Initializes a new instance of the DataType..::.UserType class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UserType(
    UserDefinedType typeReference
)
Visual Basic (Declaration)
Public Sub New ( _
    typeReference As UserDefinedType _
)
Visual C++
public:
UserType(
    UserDefinedType^ typeReference
)

Parameters

typeReference
Type: PerpetuumSoft.DataModel.MsSql..::.UserDefinedType

See Also

DataType..::.UserType Class
DataType..::.UserType Overload


DataType.UserType Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserType Methods
DataType..::.UserType Class See Also Send Feedback

The DataType..::.UserType type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Overrides DataType..::.DataTypeEquals(DataType).)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.UserType Class


DataTypeEquals Method

[image]

SQL Schema Sync API Class reference
DataType..::.UserType..::.DataTypeEquals Method
DataType..::.UserType Class See Also Send Feedback
Overridden. See DataTypeEquals(DataType).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool DataTypeEquals(
    DataType dt
)
Visual Basic (Declaration)
Public Overrides Function DataTypeEquals ( _
    dt As DataType _
) As Boolean
Visual C++
public:
virtual bool DataTypeEquals(
    DataType^ dt
) override

Parameters

dt
Type: PerpetuumSoft.DataModel.MsSql..::.DataType

See Also

DataType..::.UserType Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.UserType..::.GetTypeDefinition Method
DataType..::.UserType Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.UserType Class


DataType.UserType Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.UserType Properties
DataType..::.UserType Class See Also Send Feedback

The DataType..::.UserType type exposes the following members.

Properties

Name | Description
BaseType | Overridden. See BaseType. (Overrides DataType..::.BaseType.)
DefaultValue | Override. See DefaultValue. The default value corresponds the basic type default value. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Overridden. See IsUserDefinedType. (Overrides DataType..::.IsUserDefinedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)
TypeReference | Gets or sets UserDefinedType associated with this UserType.

See Also

DataType..::.UserType Class


BaseType Property

[image]

SQL Schema Sync API Class reference
DataType..::.UserType..::.BaseType Property
DataType..::.UserType Class See Also Send Feedback
Overridden. See BaseType.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override DataType BaseType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property BaseType As DataType
Visual C++
public:
virtual property DataType^ BaseType {
    DataType^ get () override;
}

See Also

DataType..::.UserType Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.UserType..::.DefaultValue Property
DataType..::.UserType Class See Also Send Feedback
Override. See DefaultValue. The default value corresponds the basic type default value.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.UserType Class


IsUserDefinedType Property

[image]

SQL Schema Sync API Class reference
DataType..::.UserType..::.IsUserDefinedType Property
DataType..::.UserType Class See Also Send Feedback
Overridden. See IsUserDefinedType.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool IsUserDefinedType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsUserDefinedType As Boolean
Visual C++
public:
virtual property bool IsUserDefinedType {
    bool get () override;
}

See Also

DataType..::.UserType Class


TypeReference Property

[image]

SQL Schema Sync API Class reference
DataType..::.UserType..::.TypeReference Property
DataType..::.UserType Class See Also Send Feedback
Gets or sets UserDefinedType associated with this UserType.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UserDefinedType TypeReference { get; set; }
Visual Basic (Declaration)
Public Property TypeReference As UserDefinedType
Visual C++
public:
property UserDefinedType^ TypeReference {
    UserDefinedType^ get ();
    void set (UserDefinedType^ value);
}

See Also

DataType..::.UserType Class


DataType.VarBinary Class

[image]

SQL Schema Sync API Class reference
DataType..::.VarBinary Class
DataType Class Members See Also Send Feedback
Represents the varbinary data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class VarBinary : DataType..::.SizedType
Visual Basic (Declaration)
Public NotInheritable Class VarBinary _
    Inherits DataType..::.SizedType
Visual C++
public ref class VarBinary sealed : public DataType..::.SizedType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.VarBinary

See Also

DataType..::.VarBinary Members


DataType.VarBinary Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.VarBinary Members
DataType..::.VarBinary Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.VarBinary type exposes the following members.

Constructors

Name | Description
DataType..::.VarBinary | Overloaded.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.VarBinary Class


DataType.VarBinary Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.VarBinary Constructor
DataType..::.VarBinary Class See Also Send Feedback

Overload List

Name | Description
DataType..::.VarBinary()()() | Initializes a new instance of the DataType..::.VarBinary class.
DataType..::.VarBinary(Int32) | Creates new instance of the DataType..::.VarBinary class.

See Also

DataType..::.VarBinary Class
DataType..::.VarBinary Members


DataType.VarBinary Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.VarBinary Constructor
DataType..::.VarBinary Class See Also Send Feedback
Initializes a new instance of the DataType..::.VarBinary class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public VarBinary()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VarBinary()

See Also

DataType..::.VarBinary Class
DataType..::.VarBinary Overload


DataType.VarBinary Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.VarBinary Constructor (Int32)
DataType..::.VarBinary Class See Also Send Feedback
Creates new instance of the DataType..::.VarBinary class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public VarBinary(
    int maxsize
)
Visual Basic (Declaration)
Public Sub New ( _
    maxsize As Integer _
)
Visual C++
public:
VarBinary(
    int maxsize
)

Parameters

maxsize
Type: System..::.Int32

See Also

DataType..::.VarBinary Class
DataType..::.VarBinary Overload


DataType.VarBinary Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.VarBinary Methods
DataType..::.VarBinary Class See Also Send Feedback

The DataType..::.VarBinary type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.VarBinary Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.VarBinary..::.GetTypeDefinition Method
DataType..::.VarBinary Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.VarBinary Class


DataType.VarBinary Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.VarBinary Properties
DataType..::.VarBinary Class See Also Send Feedback

The DataType..::.VarBinary type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets 0. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)

See Also

DataType..::.VarBinary Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.VarBinary..::.DefaultValue Property
DataType..::.VarBinary Class See Also Send Feedback
Override. See DefaultValue. Gets 0.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.VarBinary Class


DataType.VarChar Class

[image]

SQL Schema Sync API Class reference
DataType..::.VarChar Class
DataType Class Members See Also Send Feedback
Represents the var char data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class VarChar : DataType..::.SizedType
Visual Basic (Declaration)
Public NotInheritable Class VarChar _
    Inherits DataType..::.SizedType
Visual C++
public ref class VarChar sealed : public DataType..::.SizedType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.SizedType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.VarChar

See Also

DataType..::.VarChar Members


DataType.VarChar Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.VarChar Members
DataType..::.VarChar Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.VarChar type exposes the following members.

Constructors

Name | Description
DataType..::.VarChar | Overloaded.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.VarChar Class


DataType.VarChar Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.VarChar Constructor
DataType..::.VarChar Class See Also Send Feedback

Overload List

Name | Description
DataType..::.VarChar()()() | Initializes a new instance of the DataType..::.VarChar class.
DataType..::.VarChar(Int32) | Creates new instance of the DataType..::.VarChar class.

See Also

DataType..::.VarChar Class
DataType..::.VarChar Members


DataType.VarChar Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.VarChar Constructor
DataType..::.VarChar Class See Also Send Feedback
Initializes a new instance of the DataType..::.VarChar class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public VarChar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VarChar()

See Also

DataType..::.VarChar Class
DataType..::.VarChar Overload


DataType.VarChar Constructor (Int32)

[image]

SQL Schema Sync API Class reference
DataType..::.VarChar Constructor (Int32)
DataType..::.VarChar Class See Also Send Feedback
Creates new instance of the DataType..::.VarChar class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public VarChar(
    int maxsize
)
Visual Basic (Declaration)
Public Sub New ( _
    maxsize As Integer _
)
Visual C++
public:
VarChar(
    int maxsize
)

Parameters

maxsize
Type: System..::.Int32

See Also

DataType..::.VarChar Class
DataType..::.VarChar Overload


DataType.VarChar Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.VarChar Methods
DataType..::.VarChar Class See Also Send Feedback

The DataType..::.VarChar type exposes the following members.

Methods

Name | Description
DataTypeEquals | Overridden. See DataTypeEquals(DataType). (Inherited from DataType..::.SizedType.)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetSizePresentation | Returns string presentation of the type size. (Inherited from DataType..::.SizedType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.VarChar Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.VarChar..::.GetTypeDefinition Method
DataType..::.VarChar Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.VarChar Class


DataType.VarChar Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.VarChar Properties
DataType..::.VarChar Class See Also Send Feedback

The DataType..::.VarChar type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. Gets ". (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
MaxSize | Gets or sets maximum size for the sizing types. (Inherited from DataType..::.SizedType.)
SupportCollation | Override. See SupportCollation. (Overrides DataType..::.SupportCollation.)

See Also

DataType..::.VarChar Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.VarChar..::.DefaultValue Property
DataType..::.VarChar Class See Also Send Feedback
Override. See DefaultValue. Gets ".

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.VarChar Class


SupportCollation Property

[image]

SQL Schema Sync API Class reference
DataType..::.VarChar..::.SupportCollation Property
DataType..::.VarChar Class See Also Send Feedback
Override. See SupportCollation.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool SupportCollation { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SupportCollation As Boolean
Visual C++
public:
virtual property bool SupportCollation {
    bool get () override;
}

See Also

DataType..::.VarChar Class


DataType.Xml Class

[image]

SQL Schema Sync API Class reference
DataType..::.Xml Class
DataType Class Members See Also Send Feedback
Represents the xml data type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Xml : DataType
Visual Basic (Declaration)
Public NotInheritable Class Xml _
    Inherits DataType
Visual C++
public ref class Xml sealed : public DataType

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.DataType
PerpetuumSoft.DataModel.MsSql..::.DataType..::.Xml

See Also

DataType..::.Xml Members


DataType.Xml Members

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Xml Members
DataType..::.Xml Class Constructors Methods Properties See Also Send Feedback

Abstract base class for all column types.

The DataType..::.Xml type exposes the following members.

Constructors

Name | Description
DataType..::.Xml | Overloaded.

Methods

Name | Description
DataTypeEquals | Override. See DataTypeEquals(DataType). (Overrides DataType..::.DataTypeEquals(DataType).)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
IsXmlDocument | Gets or sets true value if xml content is a document.
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)
XmlSchemaCollection | Gets or sets XmlSchemaCollection for the xml type.

See Also

DataType..::.Xml Class


DataType.Xml Constructor

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Xml Constructor
DataType..::.Xml Class See Also Send Feedback

Overload List

Name | Description
DataType..::.Xml()()() | Initializes a new instance of the DataType..::.Xml class.
DataType..::.Xml(XmlSchemaCollection, Boolean) | Creates new instance of the DataType..::.Xml class.

See Also

DataType..::.Xml Class
DataType..::.Xml Members


DataType.Xml Constructor

[image]

SQL Schema Sync API Class reference
DataType..::.Xml Constructor
DataType..::.Xml Class See Also Send Feedback
Initializes a new instance of the DataType..::.Xml class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Xml()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Xml()

See Also

DataType..::.Xml Class
DataType..::.Xml Overload


DataType.Xml Constructor (XmlSchemaCollection, Boolean)

[image]

SQL Schema Sync API Class reference
DataType..::.Xml Constructor (XmlSchemaCollection, Boolean)
DataType..::.Xml Class See Also Send Feedback
Creates new instance of the DataType..::.Xml class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Xml(
    XmlSchemaCollection xmlSchemaCollection,
    bool isXmlDocument
)
Visual Basic (Declaration)
Public Sub New ( _
    xmlSchemaCollection As XmlSchemaCollection, _
    isXmlDocument As Boolean _
)
Visual C++
public:
Xml(
    XmlSchemaCollection^ xmlSchemaCollection,
    bool isXmlDocument
)

Parameters

xmlSchemaCollection
Type: PerpetuumSoft.DataModel.MsSql..::.XmlSchemaCollection
isXmlDocument
Type: System..::.Boolean

See Also

DataType..::.Xml Class
DataType..::.Xml Overload


DataType.Xml Methods

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Xml Methods
DataType..::.Xml Class See Also Send Feedback

The DataType..::.Xml type exposes the following members.

Methods

Name | Description
DataTypeEquals | Override. See DataTypeEquals(DataType). (Overrides DataType..::.DataTypeEquals(DataType).)
Equals | Overridden. See Equals(Object). (Inherited from DataType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from DataType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeDefinition | Overridden. See GetTypeDefinition()()(). (Overrides DataType..::.GetTypeDefinition()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DataType.)

See Also

DataType..::.Xml Class


DataTypeEquals Method

[image]

SQL Schema Sync API Class reference
DataType..::.Xml..::.DataTypeEquals Method
DataType..::.Xml Class See Also Send Feedback
Override. See DataTypeEquals(DataType).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool DataTypeEquals(
    DataType dt
)
Visual Basic (Declaration)
Public Overrides Function DataTypeEquals ( _
    dt As DataType _
) As Boolean
Visual C++
public:
virtual bool DataTypeEquals(
    DataType^ dt
) override

Parameters

dt
Type: PerpetuumSoft.DataModel.MsSql..::.DataType

See Also

DataType..::.Xml Class


GetTypeDefinition Method

[image]

SQL Schema Sync API Class reference
DataType..::.Xml..::.GetTypeDefinition Method
DataType..::.Xml Class See Also Send Feedback
Overridden. See GetTypeDefinition()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string GetTypeDefinition()
Visual Basic (Declaration)
Public Overrides Function GetTypeDefinition As String
Visual C++
public:
virtual String^ GetTypeDefinition() override

See Also

DataType..::.Xml Class


DataType.Xml Properties

[image] [image]

SQL Schema Sync API Class reference
DataType..::.Xml Properties
DataType..::.Xml Class See Also Send Feedback

The DataType..::.Xml type exposes the following members.

Properties

Name | Description
BaseType | Gets DataType (Inherited from DataType.)
DefaultValue | Override. See DefaultValue. (Overrides DataType..::.DefaultValue.)
IsUserDefinedType | Gets if a type is declared as a user defined one. (Inherited from DataType.)
IsXmlDocument | Gets or sets true value if xml content is a document.
SupportCollation | Gets true value if a type supports collation. (Inherited from DataType.)
XmlSchemaCollection | Gets or sets XmlSchemaCollection for the xml type.

See Also

DataType..::.Xml Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
DataType..::.Xml..::.DefaultValue Property
DataType..::.Xml Class See Also Send Feedback
Override. See DefaultValue.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string DefaultValue { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As String
Visual C++
public:
virtual property String^ DefaultValue {
    String^ get () override;
}

See Also

DataType..::.Xml Class


IsXmlDocument Property

[image]

SQL Schema Sync API Class reference
DataType..::.Xml..::.IsXmlDocument Property
DataType..::.Xml Class See Also Send Feedback
Gets or sets true value if xml content is a document.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsXmlDocument { get; set; }
Visual Basic (Declaration)
Public Property IsXmlDocument As Boolean
Visual C++
public:
property bool IsXmlDocument {
    bool get ();
    void set (bool value);
}

See Also

DataType..::.Xml Class


XmlSchemaCollection Property

[image]

SQL Schema Sync API Class reference
DataType..::.Xml..::.XmlSchemaCollection Property
DataType..::.Xml Class See Also Send Feedback
Gets or sets XmlSchemaCollection for the xml type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public XmlSchemaCollection XmlSchemaCollection { get; set; }
Visual Basic (Declaration)
Public Property XmlSchemaCollection As XmlSchemaCollection
Visual C++
public:
property XmlSchemaCollection^ XmlSchemaCollection {
    XmlSchemaCollection^ get ();
    void set (XmlSchemaCollection^ value);
}

See Also

DataType..::.Xml Class


DdlTrigger Class

[image]

SQL Schema Sync API Class reference
DdlTrigger Class
Members See Also Send Feedback
Represents DLL trigger in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class DdlTrigger : DatabaseObject
Visual Basic (Declaration)
Public NotInheritable Class DdlTrigger _
    Inherits DatabaseObject
Visual C++
public ref class DdlTrigger sealed : public DatabaseObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.DdlTrigger

See Also

DdlTrigger Members


DdlTrigger Members

[image] [image]

SQL Schema Sync API Class reference
DdlTrigger Members
DdlTrigger Class Constructors Methods Properties See Also Send Feedback

The DdlTrigger type exposes the following members.

Constructors

Name | Description
DdlTrigger | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Override. See RelatesTo(Element). (Overrides Element..::.RelatesTo(Element).)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets the DLL trigger extended properties.
FullName | Gets the element full name. (Inherited from Element.)
IsDisabled | Gets or sets true value if DLL trigger is not active.
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Text | Gets or sets DLL trigger text.

See Also

DdlTrigger Class


DdlTrigger Constructor

[image] [image]

SQL Schema Sync API Class reference
DdlTrigger Constructor
DdlTrigger Class See Also Send Feedback

Overload List

Name | Description
DdlTrigger()()() | Creates new instance of the DdlTrigger class.
DdlTrigger(String) | Creates new instance of the DdlTrigger class.

See Also

DdlTrigger Class
DdlTrigger Members


DdlTrigger Constructor

[image]

SQL Schema Sync API Class reference
DdlTrigger Constructor
DdlTrigger Class See Also Send Feedback
Creates new instance of the DdlTrigger class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DdlTrigger()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DdlTrigger()

See Also

DdlTrigger Class
DdlTrigger Overload


DdlTrigger Constructor (String)

[image]

SQL Schema Sync API Class reference
DdlTrigger Constructor (String)
DdlTrigger Class See Also Send Feedback
Creates new instance of the DdlTrigger class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DdlTrigger(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
DdlTrigger(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

DdlTrigger Class
DdlTrigger Overload


DdlTrigger Methods

[image] [image]

SQL Schema Sync API Class reference
DdlTrigger Methods
DdlTrigger Class See Also Send Feedback

The DdlTrigger type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Override. See RelatesTo(Element). (Overrides Element..::.RelatesTo(Element).)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

DdlTrigger Class


RelatesTo Method

[image]

SQL Schema Sync API Class reference
DdlTrigger..::.RelatesTo Method
DdlTrigger Class See Also Send Feedback
Override. See RelatesTo(Element).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool RelatesTo(
    Element element
)
Visual Basic (Declaration)
Public Overrides Function RelatesTo ( _
    element As Element _
) As Boolean
Visual C++
public:
virtual bool RelatesTo(
    Element^ element
) override

Parameters

element
Type: PerpetuumSoft.DataModel.MsSql..::.Element

See Also

DdlTrigger Class


DdlTrigger Properties

[image] [image]

SQL Schema Sync API Class reference
DdlTrigger Properties
DdlTrigger Class See Also Send Feedback

The DdlTrigger type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets the DLL trigger extended properties.
FullName | Gets the element full name. (Inherited from Element.)
IsDisabled | Gets or sets true value if DLL trigger is not active.
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Text | Gets or sets DLL trigger text.

See Also

DdlTrigger Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
DdlTrigger..::.ExtendedProperties Property
DdlTrigger Class See Also Send Feedback
Implements ExtendedProperties()()(). Gets the DLL trigger extended properties.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

DdlTrigger Class


IsDisabled Property

[image]

SQL Schema Sync API Class reference
DdlTrigger..::.IsDisabled Property
DdlTrigger Class See Also Send Feedback
Gets or sets true value if DLL trigger is not active.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsDisabled { get; set; }
Visual Basic (Declaration)
Public Property IsDisabled As Boolean
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

See Also

DdlTrigger Class


Text Property

[image]

SQL Schema Sync API Class reference
DdlTrigger..::.Text Property
DdlTrigger Class See Also Send Feedback
Gets or sets DLL trigger text.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTrigger Class


Default Class

[image]

SQL Schema Sync API Class reference
Default Class
Members See Also Send Feedback
Represents default value.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Default : SchemaObject
Visual Basic (Declaration)
Public NotInheritable Class Default _
    Inherits SchemaObject
Visual C++
public ref class Default sealed : public SchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.Default

See Also

Default Members


Default Members

[image] [image]

SQL Schema Sync API Class reference
Default Members
Default Class Constructors Methods Properties See Also Send Feedback

The Default type exposes the following members.

Constructors

Name | Description
Default | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DefaultObjects | Collection of objects this default value is set to.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets default value text.

See Also

Default Class


Default Constructor

[image] [image]

SQL Schema Sync API Class reference
Default Constructor
Default Class See Also Send Feedback

Overload List

Name | Description
Default()()() | Creates new instance of the Default class.
Default(String) | Creates new instance of the Default class.

See Also

Default Class
Default Members


Default Constructor

[image]

SQL Schema Sync API Class reference
Default Constructor
Default Class See Also Send Feedback
Creates new instance of the Default class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Default()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Default()

See Also

Default Class
Default Overload


Default Constructor (String)

[image]

SQL Schema Sync API Class reference
Default Constructor (String)
Default Class See Also Send Feedback
Creates new instance of the Default class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Default(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
Default(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Default Class
Default Overload


Default Methods

[image] [image]

SQL Schema Sync API Class reference
Default Methods
Default Class See Also Send Feedback

The Default type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Default Class


Default Properties

[image] [image]

SQL Schema Sync API Class reference
Default Properties
Default Class See Also Send Feedback

The Default type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DefaultObjects | Collection of objects this default value is set to.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets default value text.

See Also

Default Class


DefaultObjects Property

[image]

SQL Schema Sync API Class reference
Default..::.DefaultObjects Property
Default Class See Also Send Feedback
Collection of objects this default value is set to.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public RuleDefaultObjectCollection DefaultObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultObjects As RuleDefaultObjectCollection
Visual C++
public:
property RuleDefaultObjectCollection^ DefaultObjects {
    RuleDefaultObjectCollection^ get ();
}

See Also

Default Class


Text Property

[image]

SQL Schema Sync API Class reference
Default..::.Text Property
Default Class See Also Send Feedback
Gets or sets default value text.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Default Class


DefaultConstraint Class

[image]

SQL Schema Sync API Class reference
DefaultConstraint Class
Members See Also Send Feedback
Represents default constraint in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class DefaultConstraint : Constraint
Visual Basic (Declaration)
Public NotInheritable Class DefaultConstraint _
    Inherits Constraint
Visual C++
public ref class DefaultConstraint sealed : public Constraint

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Constraint
PerpetuumSoft.DataModel.MsSql..::.DefaultConstraint

See Also

DefaultConstraint Members


DefaultConstraint Members

[image] [image]

SQL Schema Sync API Class reference
DefaultConstraint Members
DefaultConstraint Class Constructors Methods Properties See Also Send Feedback

The DefaultConstraint type exposes the following members.

Constructors

Name | Description
DefaultConstraint | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Column | Gets or sets column the default value is set for.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
Expression | Gets or sets an expression for a default value.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)

See Also

DefaultConstraint Class


DefaultConstraint Constructor

[image] [image]

SQL Schema Sync API Class reference
DefaultConstraint Constructor
DefaultConstraint Class See Also Send Feedback

Overload List

Name | Description
DefaultConstraint()()() | Initializes a new instance of the DefaultConstraint class.
DefaultConstraint(String, Table, TableColumn, String) | Creates new instance of the DefaultConstraint class.

See Also

DefaultConstraint Class
DefaultConstraint Members


DefaultConstraint Constructor

[image]

SQL Schema Sync API Class reference
DefaultConstraint Constructor
DefaultConstraint Class See Also Send Feedback
Initializes a new instance of the DefaultConstraint class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DefaultConstraint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DefaultConstraint()

See Also

DefaultConstraint Class
DefaultConstraint Overload


DefaultConstraint Constructor (String, Table, TableColumn, String)

[image]

SQL Schema Sync API Class reference
DefaultConstraint Constructor (String, Table, TableColumn, String)
DefaultConstraint Class See Also Send Feedback
Creates new instance of the DefaultConstraint class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DefaultConstraint(
    string name,
    Table table,
    TableColumn column,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    table As Table, _
    column As TableColumn, _
    expression As String _
)
Visual C++
public:
DefaultConstraint(
    String^ name,
    Table^ table,
    TableColumn^ column,
    String^ expression
)

Parameters

name
Type: System..::.String
table
Type: PerpetuumSoft.DataModel.MsSql..::.Table
column
Type: PerpetuumSoft.DataModel.MsSql..::.TableColumn
expression
Type: System..::.String

See Also

DefaultConstraint Class
DefaultConstraint Overload


DefaultConstraint Methods

[image] [image]

SQL Schema Sync API Class reference
DefaultConstraint Methods
DefaultConstraint Class See Also Send Feedback

The DefaultConstraint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

DefaultConstraint Class


DefaultConstraint Properties

[image] [image]

SQL Schema Sync API Class reference
DefaultConstraint Properties
DefaultConstraint Class See Also Send Feedback

The DefaultConstraint type exposes the following members.

Properties

Name | Description
Column | Gets or sets column the default value is set for.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
Expression | Gets or sets an expression for a default value.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)

See Also

DefaultConstraint Class


Column Property

[image]

SQL Schema Sync API Class reference
DefaultConstraint..::.Column Property
DefaultConstraint Class See Also Send Feedback
Gets or sets column the default value is set for.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableColumn Column { get; set; }
Visual Basic (Declaration)
Public Property Column As TableColumn
Visual C++
public:
property TableColumn^ Column {
    TableColumn^ get ();
    void set (TableColumn^ value);
}

See Also

DefaultConstraint Class


Expression Property

[image]

SQL Schema Sync API Class reference
DefaultConstraint..::.Expression Property
DefaultConstraint Class See Also Send Feedback
Gets or sets an expression for a default value.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

DefaultConstraint Class


DefaultCursor Enumeration

[image]

SQL Schema Sync API Class reference
DefaultCursor Enumeration
See Also Send Feedback
DefaultCursor.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum DefaultCursor
Visual Basic (Declaration)
Public Enumeration DefaultCursor
Visual C++
public enum class DefaultCursor

Members

Member name | Description
Global | Global.
Local | Local.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


Dependency Class

[image]

SQL Schema Sync API Class reference
Dependency Class
Members See Also Send Feedback
Represents dependency beetween sql objects.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Dependency
Visual Basic (Declaration)
Public NotInheritable Class Dependency
Visual C++
public ref class Dependency sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Dependency

See Also

Dependency Members


Dependency Members

[image] [image]

SQL Schema Sync API Class reference
Dependency Members
Dependency Class Constructors Methods Properties See Also Send Feedback

The Dependency type exposes the following members.

Constructors

Name | Description
Dependency | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Element | Gets or sets an element on which the current element depends.

See Also

Dependency Class


Dependency Constructor

[image] [image]

SQL Schema Sync API Class reference
Dependency Constructor
Dependency Class See Also Send Feedback

Overload List

Name | Description
Dependency()()() | Initializes a new instance of the Dependency class.
Dependency(Element) | Initializes a new instance of the Dependency class.

See Also

Dependency Class
Dependency Members


Dependency Constructor

[image]

SQL Schema Sync API Class reference
Dependency Constructor
Dependency Class See Also Send Feedback
Initializes a new instance of the Dependency class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Dependency()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Dependency()

See Also

Dependency Class
Dependency Overload


Dependency Constructor (Element)

[image]

SQL Schema Sync API Class reference
Dependency Constructor (Element)
Dependency Class See Also Send Feedback
Initializes a new instance of the Dependency class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Dependency(
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As Element _
)
Visual C++
public:
Dependency(
    Element^ element
)

Parameters

element
Type: PerpetuumSoft.DataModel.MsSql..::.Element

See Also

Dependency Class
Dependency Overload


Dependency Methods

[image] [image]

SQL Schema Sync API Class reference
Dependency Methods
Dependency Class See Also Send Feedback

The Dependency type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Dependency Class


Dependency Properties

[image] [image]

SQL Schema Sync API Class reference
Dependency Properties
Dependency Class See Also Send Feedback

The Dependency type exposes the following members.

Properties

Name | Description
Element | Gets or sets an element on which the current element depends.

See Also

Dependency Class


Element Property

[image]

SQL Schema Sync API Class reference
Dependency..::.Element Property
Dependency Class See Also Send Feedback
Gets or sets an element on which the current element depends.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Element Element { get; set; }
Visual Basic (Declaration)
Public Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
    void set (Element^ value);
}

See Also

Dependency Class


DependencyCollection Class

[image]

SQL Schema Sync API Class reference
DependencyCollection Class
Members See Also Send Feedback
Represents a collection of Dependency .

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class DependencyCollection : Collection<Dependency>
Visual Basic (Declaration)
Public NotInheritable Class DependencyCollection _
    Inherits Collection(Of Dependency)
Visual C++
public ref class DependencyCollection sealed : public Collection<Dependency^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( Dependency >)>)
PerpetuumSoft.DataModel.MsSql..::.DependencyCollection

See Also

DependencyCollection Members


DependencyCollection Members

[image] [image]

SQL Schema Sync API Class reference
DependencyCollection Members
DependencyCollection Class Methods Properties See Also Send Feedback

The DependencyCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Dependency >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Dependency >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Dependency >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Dependency >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Dependency >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)

See Also

DependencyCollection Class


DependencyCollection Methods

[image] [image]

SQL Schema Sync API Class reference
DependencyCollection Methods
DependencyCollection Class See Also Send Feedback

The DependencyCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Dependency >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Dependency >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Dependency >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Dependency >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DependencyCollection Class


DependencyCollection Properties

[image] [image]

SQL Schema Sync API Class reference
DependencyCollection Properties
DependencyCollection Class See Also Send Feedback

The DependencyCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Dependency >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Dependency >)>).)

See Also

DependencyCollection Class


DestinyEnum Enumeration

[image]

SQL Schema Sync API Class reference
DestinyEnum Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.DestinyEnum"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum DestinyEnum
Visual Basic (Declaration)
Public Enumeration DestinyEnum
Visual C++
public enum class DestinyEnum

Members

Member name | Description
Low |
Medium |
High |

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


Element Class

[image]

SQL Schema Sync API Class reference
Element Class
Members See Also Send Feedback
Abstract base class for all definition cleaases of the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class Element
Visual Basic (Declaration)
Public MustInherit Class Element
Visual C++
public ref class Element abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.ColumnBase
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.ParameterBase

See Also

Element Members


Element Members

[image] [image]

SQL Schema Sync API Class reference
Element Members
Element Class Methods Properties See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database.
ToString | Override. See ToString()()(). Gets element name. (Overrides Object..::.ToString()()().)

Properties

Name | Description
DependOn | Gets a collection of the element dependencies.
FullName | Gets the element full name.
IsSystem | Gets or sets true value if the object is of system type.
Name | Gets or sets an element name.

See Also

Element Class


Element Methods

[image] [image]

SQL Schema Sync API Class reference
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database.
ToString | Override. See ToString()()(). Gets element name. (Overrides Object..::.ToString()()().)

See Also

Element Class


RelatesTo Method

[image]

SQL Schema Sync API Class reference
Element..::.RelatesTo Method
Element Class See Also Send Feedback
Checks if an argument represents the same element in the compared database.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool RelatesTo(
    Element element
)
Visual Basic (Declaration)
Public Overridable Function RelatesTo ( _
    element As Element _
) As Boolean
Visual C++
public:
virtual bool RelatesTo(
    Element^ element
)

Parameters

element
Type: PerpetuumSoft.DataModel.MsSql..::.Element

See Also

Element Class


ToString Method

[image]

SQL Schema Sync API Class reference
Element..::.ToString Method
Element Class See Also Send Feedback
Override. See ToString()()(). Gets element name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Element Class


Element Properties

[image] [image]

SQL Schema Sync API Class reference
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

Name | Description
DependOn | Gets a collection of the element dependencies.
FullName | Gets the element full name.
IsSystem | Gets or sets true value if the object is of system type.
Name | Gets or sets an element name.

See Also

Element Class


DependOn Property

[image]

SQL Schema Sync API Class reference
Element..::.DependOn Property
Element Class See Also Send Feedback
Gets a collection of the element dependencies.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DependencyCollection DependOn { get; }
Visual Basic (Declaration)
Public ReadOnly Property DependOn As DependencyCollection
Visual C++
public:
property DependencyCollection^ DependOn {
    DependencyCollection^ get ();
}

See Also

Element Class


FullName Property

[image]

SQL Schema Sync API Class reference
Element..::.FullName Property
Element Class See Also Send Feedback
Gets the element full name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public virtual string FullName { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property FullName As String
Visual C++
public:
virtual property String^ FullName {
    String^ get ();
}

See Also

Element Class


IsSystem Property

[image]

SQL Schema Sync API Class reference
Element..::.IsSystem Property
Element Class See Also Send Feedback
Gets or sets true value if the object is of system type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsSystem { get; set; }
Visual Basic (Declaration)
Public Property IsSystem As Boolean
Visual C++
public:
property bool IsSystem {
    bool get ();
    void set (bool value);
}

See Also

Element Class


Name Property

[image]

SQL Schema Sync API Class reference
Element..::.Name Property
Element Class See Also Send Feedback
Gets or sets an element name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

See Also

Element Class


ExecuteAsClause Enumeration

[image]

SQL Schema Sync API Class reference
ExecuteAsClause Enumeration
See Also Send Feedback
Represents possible values of the function security context.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum ExecuteAsClause
Visual Basic (Declaration)
Public Enumeration ExecuteAsClause
Visual C++
public enum class ExecuteAsClause

Members

Member name | Description
Caller | Caller.
Self | Self.
Owner | Owner.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


ExtendedProperty Class

[image]

SQL Schema Sync API Class reference
ExtendedProperty Class
Members See Also Send Feedback
Represents extended properties in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class ExtendedProperty
Visual Basic (Declaration)
Public Class ExtendedProperty
Visual C++
public ref class ExtendedProperty

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.ExtendedProperty

See Also

ExtendedProperty Members


ExtendedProperty Members

[image] [image]

SQL Schema Sync API Class reference
ExtendedProperty Members
ExtendedProperty Class Constructors Methods Properties See Also Send Feedback

The ExtendedProperty type exposes the following members.

Constructors

Name | Description
ExtendedProperty | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Gets or sets the extended property name.
Value | Gets or sets the extended property value.

See Also

ExtendedProperty Class


ExtendedProperty Constructor

[image] [image]

SQL Schema Sync API Class reference
ExtendedProperty Constructor
ExtendedProperty Class See Also Send Feedback

Overload List

Name | Description
ExtendedProperty()()() | Creates new instance of the ExtendedProperty class.
ExtendedProperty(String) | Creates new instance of the ExtendedProperty class.
ExtendedProperty(String, String) | Creates new instance of the ExtendedProperty class.

See Also

ExtendedProperty Class
ExtendedProperty Members


ExtendedProperty Constructor

[image]

SQL Schema Sync API Class reference
ExtendedProperty Constructor
ExtendedProperty Class See Also Send Feedback
Creates new instance of the ExtendedProperty class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedProperty()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExtendedProperty()

See Also

ExtendedProperty Class
ExtendedProperty Overload


ExtendedProperty Constructor (String)

[image]

SQL Schema Sync API Class reference
ExtendedProperty Constructor (String)
ExtendedProperty Class See Also Send Feedback
Creates new instance of the ExtendedProperty class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedProperty(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
ExtendedProperty(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

ExtendedProperty Class
ExtendedProperty Overload


ExtendedProperty Constructor (String, String)

[image]

SQL Schema Sync API Class reference
ExtendedProperty Constructor (String, String)
ExtendedProperty Class See Also Send Feedback
Creates new instance of the ExtendedProperty class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedProperty(
    string name,
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    value As String _
)
Visual C++
public:
ExtendedProperty(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::.String
value
Type: System..::.String

See Also

ExtendedProperty Class
ExtendedProperty Overload


ExtendedProperty Methods

[image] [image]

SQL Schema Sync API Class reference
ExtendedProperty Methods
ExtendedProperty Class See Also Send Feedback

The ExtendedProperty type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtendedProperty Class


ExtendedProperty Properties

[image] [image]

SQL Schema Sync API Class reference
ExtendedProperty Properties
ExtendedProperty Class See Also Send Feedback

The ExtendedProperty type exposes the following members.

Properties

Name | Description
Name | Gets or sets the extended property name.
Value | Gets or sets the extended property value.

See Also

ExtendedProperty Class


Name Property

[image]

SQL Schema Sync API Class reference
ExtendedProperty..::.Name Property
ExtendedProperty Class See Also Send Feedback
Gets or sets the extended property name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedProperty Class


Value Property

[image]

SQL Schema Sync API Class reference
ExtendedProperty..::.Value Property
ExtendedProperty Class See Also Send Feedback
Gets or sets the extended property value.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

ExtendedProperty Class


ExtendedPropertyCollection Class

[image]

SQL Schema Sync API Class reference
ExtendedPropertyCollection Class
Members See Also Send Feedback
Represents the extended properties collection.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ExtendedPropertyCollection : Collection<ExtendedProperty>
Visual Basic (Declaration)
Public NotInheritable Class ExtendedPropertyCollection _
    Inherits Collection(Of ExtendedProperty)
Visual C++
public ref class ExtendedPropertyCollection sealed : public Collection<ExtendedProperty^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( ExtendedProperty >)>)
PerpetuumSoft.DataModel.MsSql..::.ExtendedPropertyCollection

See Also

ExtendedPropertyCollection Members


ExtendedPropertyCollection Members

[image] [image]

SQL Schema Sync API Class reference
ExtendedPropertyCollection Members
ExtendedPropertyCollection Class Methods Properties See Also Send Feedback

The ExtendedPropertyCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ExtendedProperty >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ExtendedProperty >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( ExtendedProperty >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)

See Also

ExtendedPropertyCollection Class


ExtendedPropertyCollection Methods

[image] [image]

SQL Schema Sync API Class reference
ExtendedPropertyCollection Methods
ExtendedPropertyCollection Class See Also Send Feedback

The ExtendedPropertyCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ExtendedProperty >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ExtendedProperty >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( ExtendedProperty >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtendedPropertyCollection Class


ExtendedPropertyCollection Properties

[image] [image]

SQL Schema Sync API Class reference
ExtendedPropertyCollection Properties
ExtendedPropertyCollection Class See Also Send Feedback

The ExtendedPropertyCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ExtendedProperty >)>).)

See Also

ExtendedPropertyCollection Class


Item Property

[image] [image]

SQL Schema Sync API Class reference
ExtendedPropertyCollection..::.Item Property
ExtendedPropertyCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( ExtendedProperty >)>).)
Item[([(String])]) | Gets ExtendedProperty by name.

See Also

ExtendedPropertyCollection Class
ExtendedPropertyCollection Members


Item Property (String)

[image]

SQL Schema Sync API Class reference
ExtendedPropertyCollection..::.Item Property (String)
ExtendedPropertyCollection Class See Also Send Feedback
Gets ExtendedProperty by name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedProperty this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As ExtendedProperty
Visual C++
public:
property ExtendedProperty^ default[String^ name] {
    ExtendedProperty^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

ExtendedPropertyCollection Class
Item Overload


ForeignKey Class

[image]

SQL Schema Sync API Class reference
ForeignKey Class
Members See Also Send Feedback
Represents a foreign key in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ForeignKey : Constraint
Visual Basic (Declaration)
Public NotInheritable Class ForeignKey _
    Inherits Constraint
Visual C++
public ref class ForeignKey sealed : public Constraint

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Constraint
PerpetuumSoft.DataModel.MsSql..::.ForeignKey

See Also

ForeignKey Members


ForeignKey Members

[image] [image]

SQL Schema Sync API Class reference
ForeignKey Members
ForeignKey Class Constructors Methods Properties See Also Send Feedback

The ForeignKey type exposes the following members.

Constructors

Name | Description
ForeignKey | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Columns | Gets columns associated with a foreign key.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DeleteAction | Gets or sets an action performed on delete.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ForeignColumns | Gets columns in a foreign table.
ForeignTable | Gets or sets a foreign table.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)
UpdateAction | Gets or sets an action performed on update.

See Also

ForeignKey Class


ForeignKey Constructor

[image] [image]

SQL Schema Sync API Class reference
ForeignKey Constructor
ForeignKey Class See Also Send Feedback

Overload List

Name | Description
ForeignKey()()() | Initializes a new instance of the ForeignKey class.
ForeignKey(String, Table, Table) | Creates new instance of the ForeignKey class.

See Also

ForeignKey Class
ForeignKey Members


ForeignKey Constructor

[image]

SQL Schema Sync API Class reference
ForeignKey Constructor
ForeignKey Class See Also Send Feedback
Initializes a new instance of the ForeignKey class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ForeignKey()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ForeignKey()

See Also

ForeignKey Class
ForeignKey Overload


ForeignKey Constructor (String, Table, Table)

[image]

SQL Schema Sync API Class reference
ForeignKey Constructor (String, Table, Table)
ForeignKey Class See Also Send Feedback
Creates new instance of the ForeignKey class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ForeignKey(
    string name,
    Table table,
    Table foreignTable
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    table As Table, _
    foreignTable As Table _
)
Visual C++
public:
ForeignKey(
    String^ name,
    Table^ table,
    Table^ foreignTable
)

Parameters

name
Type: System..::.String
table
Type: PerpetuumSoft.DataModel.MsSql..::.Table
foreignTable
Type: PerpetuumSoft.DataModel.MsSql..::.Table

See Also

ForeignKey Class
ForeignKey Overload


ForeignKey Methods

[image] [image]

SQL Schema Sync API Class reference
ForeignKey Methods
ForeignKey Class See Also Send Feedback

The ForeignKey type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

ForeignKey Class


ForeignKey Properties

[image] [image]

SQL Schema Sync API Class reference
ForeignKey Properties
ForeignKey Class See Also Send Feedback

The ForeignKey type exposes the following members.

Properties

Name | Description
Columns | Gets columns associated with a foreign key.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DeleteAction | Gets or sets an action performed on delete.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ForeignColumns | Gets columns in a foreign table.
ForeignTable | Gets or sets a foreign table.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)
UpdateAction | Gets or sets an action performed on update.

See Also

ForeignKey Class


Columns Property

[image]

SQL Schema Sync API Class reference
ForeignKey..::.Columns Property
ForeignKey Class See Also Send Feedback
Gets columns associated with a foreign key.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ColumnRefCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As ColumnRefCollection
Visual C++
public:
property ColumnRefCollection^ Columns {
    ColumnRefCollection^ get ();
}

See Also

ForeignKey Class


DeleteAction Property

[image]

SQL Schema Sync API Class reference
ForeignKey..::.DeleteAction Property
ForeignKey Class See Also Send Feedback
Gets or sets an action performed on delete.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ForeignKeyAction DeleteAction { get; set; }
Visual Basic (Declaration)
Public Property DeleteAction As ForeignKeyAction
Visual C++
public:
property ForeignKeyAction DeleteAction {
    ForeignKeyAction get ();
    void set (ForeignKeyAction value);
}

See Also

ForeignKey Class


ForeignColumns Property

[image]

SQL Schema Sync API Class reference
ForeignKey..::.ForeignColumns Property
ForeignKey Class See Also Send Feedback
Gets columns in a foreign table.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ColumnRefCollection ForeignColumns { get; }
Visual Basic (Declaration)
Public ReadOnly Property ForeignColumns As ColumnRefCollection
Visual C++
public:
property ColumnRefCollection^ ForeignColumns {
    ColumnRefCollection^ get ();
}

See Also

ForeignKey Class


ForeignTable Property

[image]

SQL Schema Sync API Class reference
ForeignKey..::.ForeignTable Property
ForeignKey Class See Also Send Feedback
Gets or sets a foreign table.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Table ForeignTable { get; set; }
Visual Basic (Declaration)
Public Property ForeignTable As Table
Visual C++
public:
property Table^ ForeignTable {
    Table^ get ();
    void set (Table^ value);
}

See Also

ForeignKey Class


UpdateAction Property

[image]

SQL Schema Sync API Class reference
ForeignKey..::.UpdateAction Property
ForeignKey Class See Also Send Feedback
Gets or sets an action performed on update.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ForeignKeyAction UpdateAction { get; set; }
Visual Basic (Declaration)
Public Property UpdateAction As ForeignKeyAction
Visual C++
public:
property ForeignKeyAction UpdateAction {
    ForeignKeyAction get ();
    void set (ForeignKeyAction value);
}

See Also

ForeignKey Class


ForeignKeyAction Enumeration

[image]

SQL Schema Sync API Class reference
ForeignKeyAction Enumeration
See Also Send Feedback
Enumerates foreign key action types.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum ForeignKeyAction
Visual Basic (Declaration)
Public Enumeration ForeignKeyAction
Visual C++
public enum class ForeignKeyAction

Members

Member name | Description
NoAction | No Action.
CascadeDelete | Cascade delete.
SetNull | Set null.
SetDefault | Set default.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


FunctionBase Class

[image]

SQL Schema Sync API Class reference
FunctionBase Class
Members See Also Send Feedback
Basic class for all functions in the data base structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class FunctionBase : SchemaObject
Visual Basic (Declaration)
Public MustInherit Class FunctionBase _
    Inherits SchemaObject
Visual C++
public ref class FunctionBase abstract : public SchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.CLRFunctionBase
PerpetuumSoft.DataModel.MsSql..::.TextFunction

See Also

FunctionBase Members


FunctionBase Members

[image] [image]

SQL Schema Sync API Class reference
FunctionBase Members
FunctionBase Class Methods Properties See Also Send Feedback

The FunctionBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context.
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters.
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

FunctionBase Class


FunctionBase Methods

[image] [image]

SQL Schema Sync API Class reference
FunctionBase Methods
FunctionBase Class See Also Send Feedback

The FunctionBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

FunctionBase Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
FunctionBase..::.SetExecuteAsClause Method
FunctionBase Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context.
SetExecuteAsClause(String) | Sets the function security context.

See Also

FunctionBase Class
FunctionBase Members


SetExecuteAsClause Method (ExecuteAsClause)

[image]

SQL Schema Sync API Class reference
FunctionBase..::.SetExecuteAsClause Method (ExecuteAsClause)
FunctionBase Class See Also Send Feedback
Sets the function security context.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void SetExecuteAsClause(
    ExecuteAsClause executeAsClause
)
Visual Basic (Declaration)
Public Sub SetExecuteAsClause ( _
    executeAsClause As ExecuteAsClause _
)
Visual C++
public:
void SetExecuteAsClause(
    ExecuteAsClause executeAsClause
)

Parameters

executeAsClause
Type: PerpetuumSoft.DataModel.MsSql..::.ExecuteAsClause

See Also

FunctionBase Class
SetExecuteAsClause Overload


SetExecuteAsClause Method (String)

[image]

SQL Schema Sync API Class reference
FunctionBase..::.SetExecuteAsClause Method (String)
FunctionBase Class See Also Send Feedback
Sets the function security context.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void SetExecuteAsClause(
    string userName
)
Visual Basic (Declaration)
Public Sub SetExecuteAsClause ( _
    userName As String _
)
Visual C++
public:
void SetExecuteAsClause(
    String^ userName
)

Parameters

userName
Type: System..::.String

See Also

FunctionBase Class
SetExecuteAsClause Overload


FunctionBase Properties

[image] [image]

SQL Schema Sync API Class reference
FunctionBase Properties
FunctionBase Class See Also Send Feedback

The FunctionBase type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context.
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters.
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

FunctionBase Class


ExecuteAsClauseString Property

[image]

SQL Schema Sync API Class reference
FunctionBase..::.ExecuteAsClauseString Property
FunctionBase Class See Also Send Feedback
Gets or sets the function secure context.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string ExecuteAsClauseString { get; set; }
Visual Basic (Declaration)
Public Property ExecuteAsClauseString As String
Visual C++
public:
property String^ ExecuteAsClauseString {
    String^ get ();
    void set (String^ value);
}

See Also

FunctionBase Class


Parameters Property

[image]

SQL Schema Sync API Class reference
FunctionBase..::.Parameters Property
FunctionBase Class See Also Send Feedback
Gets function parameters.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ParameterBaseCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterBaseCollection
Visual C++
public:
property ParameterBaseCollection^ Parameters {
    ParameterBaseCollection^ get ();
}

See Also

FunctionBase Class


Grant Class

[image]

SQL Schema Sync API Class reference
Grant Class
Members See Also Send Feedback
Represents grant of permission on the securable object in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class Grant
Visual Basic (Declaration)
Public Class Grant
Visual C++
public ref class Grant

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Grant

See Also

Grant Members


Grant Members

[image] [image]

SQL Schema Sync API Class reference
Grant Members
Grant Class Constructors Methods Properties See Also Send Feedback

The Grant type exposes the following members.

Constructors

Name | Description
Grant | Creates new instance of the Grant class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action | Gets or sets GrantAction.
Mode | Gets or sets GrantMode.

See Also

Grant Class


Grant Constructor

[image]

SQL Schema Sync API Class reference
Grant Constructor
Grant Class See Also Send Feedback
Creates new instance of the Grant class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Grant()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Grant()

See Also

Grant Class


Grant Methods

[image] [image]

SQL Schema Sync API Class reference
Grant Methods
Grant Class See Also Send Feedback

The Grant type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Grant Class


Grant Properties

[image] [image]

SQL Schema Sync API Class reference
Grant Properties
Grant Class See Also Send Feedback

The Grant type exposes the following members.

Properties

Name | Description
Action | Gets or sets GrantAction.
Mode | Gets or sets GrantMode.

See Also

Grant Class


Action Property

[image]

SQL Schema Sync API Class reference
Grant..::.Action Property
Grant Class See Also Send Feedback
Gets or sets GrantAction.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public GrantAction Action { get; set; }
Visual Basic (Declaration)
Public Property Action As GrantAction
Visual C++
public:
property GrantAction Action {
    GrantAction get ();
    void set (GrantAction value);
}

See Also

Grant Class


Mode Property

[image]

SQL Schema Sync API Class reference
Grant..::.Mode Property
Grant Class See Also Send Feedback
Gets or sets GrantMode.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public GrantMode Mode { get; set; }
Visual Basic (Declaration)
Public Property Mode As GrantMode
Visual C++
public:
property GrantMode Mode {
    GrantMode get ();
    void set (GrantMode value);
}

See Also

Grant Class


GrantAction Enumeration

[image]

SQL Schema Sync API Class reference
GrantAction Enumeration
See Also Send Feedback
Represents action on granting permission on the securable object.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum GrantAction
Visual Basic (Declaration)
Public Enumeration GrantAction
Visual C++
public enum class GrantAction

Members

Member name | Description
None | None.
Select | Select.
Update | Update.
References | References.
Insert | Insert.
Delete | Delete.
Execute | Execute.
Receive | Receive.
ViewDefinition | View definition.
Alter | Alter.
TakeOwnership | Take ownership.
Control | Control.
AlterAnyApplicationRole | Alters Any Application Role.
AlterAnyAssembly | Alters Any Assembly.
AlterAnyAsymmetricKey | Alters Any Asymmetric Key.
AlterAnyCertificate | Alters Any Certificate.
AlterAnyContract | Alters Any Contract.
AlterAnyDatabaseDdlTrigger | Alters Any Database Ddl Trigger.
AlterAnyDatabaseEventNotification | Alters Any Database Event Notification.
AlterAnyDataspace | Alters Any Dataspace.
AlterAnyFulltextCatalog | Alters Any Fulltext Catalog.
AlterAnyMessageType | Alters Any Message Type.
AlterAnyRemoteServiceBinding | Alters Any Remote Service Binding.
AlterAnyRole | Alters Any Role.
AlterAnyRoute | Alters Any Route.
AlterAnySchema | Alters Any Schema.
AlterAnyService | Alters Any Service.
AlterAnySymmetricKey | Alters Any Symmetric Key.
AlterAnyUser | Alters Any User.
Authenticate | Authenticates.
BackupDatabase | Backups Database.
BackupLog | Backups Log.
Checkpoint | Checkpoint.
Connect | Connect.
ConnectReplication | Connects Replication.
CreateAggregate | Creates Aggregate.
CreateAssembly | Creates Assembly.
CreateAsymmetricKey | Creates Asymmetric Key.
CreateCertificate | Creates Certificate.
CreateContract | Creates Contract.
CreateDatabase | Creates Database.
CreateDatabaseDdlEventNotification | Creates Database Ddl Event Notification.
CreateDefault | Creates Default Value of a Column.
CreateFulltextCatalog | Creates Fulltext Catalog.
CreateFunction | Creates Function.
CreateMessageType | Creates Message Type.
CreateProcedure | Creates Procedure.
CreateQueue | Creates Queue.
CreateRemoteServiceBinding | Creates Remote Service Binding.
CreateRole | Creates Role.
CreateRoute | Creates Route.
CreateRule | Creates Rule.
CreateSchema | Creates Schema.
CreateService | Creates Service.
CreateSymmetricKey | Creates Symmetric Key.
CreateSynonym | Creates Synonym.
CreateTable | Creates Table.
CreateType | Creates Type.
CreateView | Creates View.
CreateXmlSchemaCollection | Creates Xml Schema Collection.
Showplan | Showplan.
SubscribeQueryNotifications | Subscribes Query Notifications.
ViewDatabaseState | Displays Database State.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


GrantCollection Class

[image]

SQL Schema Sync API Class reference
GrantCollection Class
Members See Also Send Feedback
Represents collection of permission grants in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class GrantCollection : Collection<Grant>
Visual Basic (Declaration)
Public NotInheritable Class GrantCollection _
    Inherits Collection(Of Grant)
Visual C++
public ref class GrantCollection sealed : public Collection<Grant^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( Grant >)>)
PerpetuumSoft.DataModel.MsSql..::.GrantCollection

See Also

GrantCollection Members


GrantCollection Members

[image] [image]

SQL Schema Sync API Class reference
GrantCollection Members
GrantCollection Class Methods Properties See Also Send Feedback

The GrantCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Grant >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Grant >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Grant >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Grant >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)

See Also

GrantCollection Class


GrantCollection Methods

[image] [image]

SQL Schema Sync API Class reference
GrantCollection Methods
GrantCollection Class See Also Send Feedback

The GrantCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Grant >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Grant >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Grant >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Grant >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GrantCollection Class


Contains Method

[image] [image]

SQL Schema Sync API Class reference
GrantCollection..::.Contains Method
GrantCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
Contains(GrantAction) | Gets true value if the collection contains permission type.

See Also

GrantCollection Class
GrantCollection Members


Contains Method (GrantAction)

[image]

SQL Schema Sync API Class reference
GrantCollection..::.Contains Method (GrantAction)
GrantCollection Class See Also Send Feedback
Gets true value if the collection contains permission type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Contains(
    GrantAction type
)
Visual Basic (Declaration)
Public Function Contains ( _
    type As GrantAction _
) As Boolean
Visual C++
public:
bool Contains(
    GrantAction type
)

Parameters

type
Type: PerpetuumSoft.DataModel.MsSql..::.GrantAction

See Also

GrantCollection Class
Contains Overload


Remove Method

[image] [image]

SQL Schema Sync API Class reference
GrantCollection..::.Remove Method
GrantCollection Class See Also Send Feedback

Overload List

Name | Description
Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
Remove(GrantAction) | Removes permission granting action from the collection.

See Also

GrantCollection Class
GrantCollection Members


Remove Method (GrantAction)

[image]

SQL Schema Sync API Class reference
GrantCollection..::.Remove Method (GrantAction)
GrantCollection Class See Also Send Feedback
Removes permission granting action from the collection.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void Remove(
    GrantAction type
)
Visual Basic (Declaration)
Public Sub Remove ( _
    type As GrantAction _
)
Visual C++
public:
void Remove(
    GrantAction type
)

Parameters

type
Type: PerpetuumSoft.DataModel.MsSql..::.GrantAction

See Also

GrantCollection Class
Remove Overload


GrantCollection Properties

[image] [image]

SQL Schema Sync API Class reference
GrantCollection Properties
GrantCollection Class See Also Send Feedback

The GrantCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Grant >)>).)

See Also

GrantCollection Class


Item Property

[image] [image]

SQL Schema Sync API Class reference
GrantCollection..::.Item Property
GrantCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Grant >)>).)
Item[([(GrantAction])]) | Gets the permissions granting mode for the specified permission type.

See Also

GrantCollection Class
GrantCollection Members


Item Property (GrantAction)

[image]

SQL Schema Sync API Class reference
GrantCollection..::.Item Property (GrantAction)
GrantCollection Class See Also Send Feedback
Gets the permissions granting mode for the specified permission type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public GrantMode this[
    GrantAction type
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    type As GrantAction _
) As GrantMode
Visual C++
public:
property GrantMode default[GrantAction type] {
    GrantMode get (GrantAction type);
}

Parameters

type
Type: PerpetuumSoft.DataModel.MsSql..::.GrantAction

See Also

GrantCollection Class
Item Overload


GrantMode Enumeration

[image]

SQL Schema Sync API Class reference
GrantMode Enumeration
See Also Send Feedback
Represents mode to grant permission on the securable object .

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum GrantMode
Visual Basic (Declaration)
Public Enumeration GrantMode
Visual C++
public enum class GrantMode

Members

Member name | Description
None | None.
Deny | Deny.
Grant | Grant.
GrantWithGrantOption | Grant with grant option.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


GridDestiny Class

[image]

SQL Schema Sync API Class reference
GridDestiny Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.GridDestiny"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class GridDestiny
Visual Basic (Declaration)
Public Class GridDestiny
Visual C++
public ref class GridDestiny

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.GridDestiny

See Also

GridDestiny Members


GridDestiny Members

[image] [image]

SQL Schema Sync API Class reference
GridDestiny Members
GridDestiny Class Constructors Methods Properties See Also Send Feedback

The GridDestiny type exposes the following members.

Constructors

Name | Description
GridDestiny | Initializes a new instance of the GridDestiny class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEquals |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Level1 |
Level2 |
Level3 |
Level4 |

See Also

GridDestiny Class


GridDestiny Constructor

[image]

SQL Schema Sync API Class reference
GridDestiny Constructor
GridDestiny Class See Also Send Feedback
Initializes a new instance of the GridDestiny class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public GridDestiny()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridDestiny()

See Also

GridDestiny Class


GridDestiny Methods

[image] [image]

SQL Schema Sync API Class reference
GridDestiny Methods
GridDestiny Class See Also Send Feedback

The GridDestiny type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEquals |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridDestiny Class


IsEquals Method

[image]

SQL Schema Sync API Class reference
GridDestiny..::.IsEquals Method
GridDestiny Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.GridDestiny.IsEquals(PerpetuumSoft.DataModel.MsSql.GridDestiny)"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEquals(
    GridDestiny otherGridDestiny
)
Visual Basic (Declaration)
Public Function IsEquals ( _
    otherGridDestiny As GridDestiny _
) As Boolean
Visual C++
public:
bool IsEquals(
    GridDestiny^ otherGridDestiny
)

Parameters

otherGridDestiny
Type: PerpetuumSoft.DataModel.MsSql..::.GridDestiny

See Also

GridDestiny Class


GridDestiny Properties

[image] [image]

SQL Schema Sync API Class reference
GridDestiny Properties
GridDestiny Class See Also Send Feedback

The GridDestiny type exposes the following members.

Properties

Name | Description
Level1 |
Level2 |
Level3 |
Level4 |

See Also

GridDestiny Class


Level1 Property

[image]

SQL Schema Sync API Class reference
GridDestiny..::.Level1 Property
GridDestiny Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.GridDestiny.Level1"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DestinyEnum Level1 { get; set; }
Visual Basic (Declaration)
Public Property Level1 As DestinyEnum
Visual C++
public:
property DestinyEnum Level1 {
    DestinyEnum get ();
    void set (DestinyEnum value);
}

See Also

GridDestiny Class


Level2 Property

[image]

SQL Schema Sync API Class reference
GridDestiny..::.Level2 Property
GridDestiny Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.GridDestiny.Level2"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DestinyEnum Level2 { get; set; }
Visual Basic (Declaration)
Public Property Level2 As DestinyEnum
Visual C++
public:
property DestinyEnum Level2 {
    DestinyEnum get ();
    void set (DestinyEnum value);
}

See Also

GridDestiny Class


Level3 Property

[image]

SQL Schema Sync API Class reference
GridDestiny..::.Level3 Property
GridDestiny Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.GridDestiny.Level3"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DestinyEnum Level3 { get; set; }
Visual Basic (Declaration)
Public Property Level3 As DestinyEnum
Visual C++
public:
property DestinyEnum Level3 {
    DestinyEnum get ();
    void set (DestinyEnum value);
}

See Also

GridDestiny Class


Level4 Property

[image]

SQL Schema Sync API Class reference
GridDestiny..::.Level4 Property
GridDestiny Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.GridDestiny.Level4"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DestinyEnum Level4 { get; set; }
Visual Basic (Declaration)
Public Property Level4 As DestinyEnum
Visual C++
public:
property DestinyEnum Level4 {
    DestinyEnum get ();
    void set (DestinyEnum value);
}

See Also

GridDestiny Class


Identity Class

[image]

SQL Schema Sync API Class reference
Identity Class
Members See Also Send Feedback
Stores identity settings of a table column.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Identity
Visual Basic (Declaration)
Public NotInheritable Class Identity
Visual C++
public ref class Identity sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Identity

See Also

Identity Members


Identity Members

[image] [image]

SQL Schema Sync API Class reference
Identity Members
Identity Class Constructors Methods Properties See Also Send Feedback

The Identity type exposes the following members.

Constructors

Name | Description
Identity | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Increment | Gets or sets increment.
Seed | Gets or sets a seed.

See Also

Identity Class


Identity Constructor

[image] [image]

SQL Schema Sync API Class reference
Identity Constructor
Identity Class See Also Send Feedback

Overload List

Name | Description
Identity()()() | Initializes a new instance of the Identity class.
Identity(Int64, Int64) | Creates new instance of the Identity class.

See Also

Identity Class
Identity Members


Identity Constructor

[image]

SQL Schema Sync API Class reference
Identity Constructor
Identity Class See Also Send Feedback
Initializes a new instance of the Identity class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Identity()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Identity()

See Also

Identity Class
Identity Overload


Identity Constructor (Int64, Int64)

[image]

SQL Schema Sync API Class reference
Identity Constructor (Int64, Int64)
Identity Class See Also Send Feedback
Creates new instance of the Identity class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Identity(
    long seed,
    long increment
)
Visual Basic (Declaration)
Public Sub New ( _
    seed As Long, _
    increment As Long _
)
Visual C++
public:
Identity(
    long long seed,
    long long increment
)

Parameters

seed
Type: System..::.Int64
increment
Type: System..::.Int64

See Also

Identity Class
Identity Overload


Identity Methods

[image] [image]

SQL Schema Sync API Class reference
Identity Methods
Identity Class See Also Send Feedback

The Identity type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

Identity Class


ToString Method

[image]

SQL Schema Sync API Class reference
Identity..::.ToString Method
Identity Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Identity Class


Identity Properties

[image] [image]

SQL Schema Sync API Class reference
Identity Properties
Identity Class See Also Send Feedback

The Identity type exposes the following members.

Properties

Name | Description
Increment | Gets or sets increment.
Seed | Gets or sets a seed.

See Also

Identity Class


Increment Property

[image]

SQL Schema Sync API Class reference
Identity..::.Increment Property
Identity Class See Also Send Feedback
Gets or sets increment.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public long Increment { get; set; }
Visual Basic (Declaration)
Public Property Increment As Long
Visual C++
public:
property long long Increment {
    long long get ();
    void set (long long value);
}

See Also

Identity Class


Seed Property

[image]

SQL Schema Sync API Class reference
Identity..::.Seed Property
Identity Class See Also Send Feedback
Gets or sets a seed.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public long Seed { get; set; }
Visual Basic (Declaration)
Public Property Seed As Long
Visual C++
public:
property long long Seed {
    long long get ();
    void set (long long value);
}

See Also

Identity Class


Index Class

[image]

SQL Schema Sync API Class reference
Index Class
Members See Also Send Feedback
Represents an index in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class Index : IndexBase
Visual Basic (Declaration)
Public Class Index _
    Inherits IndexBase
Visual C++
public ref class Index : public IndexBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.IndexBase
PerpetuumSoft.DataModel.MsSql..::.Index
PerpetuumSoft.DataModel.MsSql..::.IndexSql10

See Also

Index Members


Index Members

[image] [image]

SQL Schema Sync API Class reference
Index Members
Index Class Constructors Methods Properties See Also Send Feedback

The Index type exposes the following members.

Constructors

Name | Description
Index | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from IndexBase.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
AllowPageLocks | Gets or sets the ALLOWPAGEROCK option.
AllowRowLocks | Gets or sets the ALLOWROWLOCK option.
Clustered | Gets or sets if an index is clustered.
Columns | Gets columns associated with this index.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). (Inherited from IndexBase.)
FillFactor | Gets or sets the fill factor option.
FullName | Gets the element full name. (Inherited from Element.)
IgnoreDupKey | Gets or sets the IGNOREDUPKEY option.
IncludedColumns | Gets columns included with this index.
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MaxDop | Gets or sets the MAXDOP option.
Name | Gets or sets an element name. (Inherited from Element.)
Online | Gets or sets the ONLINE option.
PadIndex | Gets or sets the Pad Index option.
Schema | Implements Schema. (Inherited from IndexBase.)
SortInTempDb | Gets or sets the SORTINTEMPDB option.
StatisticNoRecompute | Gets or sets the STATISTICNORECOMPUTE option.
Table | Gets or sets TableBase. (Inherited from IndexBase.)
Unique | Gets or sets if an index is unique.

See Also

Index Class


Index Constructor

[image] [image]

SQL Schema Sync API Class reference
Index Constructor
Index Class See Also Send Feedback

Overload List

Name | Description
Index()()() | Initializes a new instance of the Index class.
Index(String, TableBase) | Creates new instance of the Index class.

See Also

Index Class
Index Members


Index Constructor

[image]

SQL Schema Sync API Class reference
Index Constructor
Index Class See Also Send Feedback
Initializes a new instance of the Index class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Index()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Index()

See Also

Index Class
Index Overload


Index Constructor (String, TableBase)

[image]

SQL Schema Sync API Class reference
Index Constructor (String, TableBase)
Index Class See Also Send Feedback
Creates new instance of the Index class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Index(
    string name,
    TableBase table
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    table As TableBase _
)
Visual C++
public:
Index(
    String^ name,
    TableBase^ table
)

Parameters

name
Type: System..::.String
table
Type: PerpetuumSoft.DataModel.MsSql..::.TableBase

See Also

Index Class
Index Overload


Index Methods

[image] [image]

SQL Schema Sync API Class reference
Index Methods
Index Class See Also Send Feedback

The Index type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from IndexBase.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Index Class


Index Properties

[image] [image]

SQL Schema Sync API Class reference
Index Properties
Index Class See Also Send Feedback

The Index type exposes the following members.

Properties

Name | Description
AllowPageLocks | Gets or sets the ALLOWPAGEROCK option.
AllowRowLocks | Gets or sets the ALLOWROWLOCK option.
Clustered | Gets or sets if an index is clustered.
Columns | Gets columns associated with this index.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). (Inherited from IndexBase.)
FillFactor | Gets or sets the fill factor option.
FullName | Gets the element full name. (Inherited from Element.)
IgnoreDupKey | Gets or sets the IGNOREDUPKEY option.
IncludedColumns | Gets columns included with this index.
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MaxDop | Gets or sets the MAXDOP option.
Name | Gets or sets an element name. (Inherited from Element.)
Online | Gets or sets the ONLINE option.
PadIndex | Gets or sets the Pad Index option.
Schema | Implements Schema. (Inherited from IndexBase.)
SortInTempDb | Gets or sets the SORTINTEMPDB option.
StatisticNoRecompute | Gets or sets the STATISTICNORECOMPUTE option.
Table | Gets or sets TableBase. (Inherited from IndexBase.)
Unique | Gets or sets if an index is unique.

See Also

Index Class


AllowPageLocks Property

[image]

SQL Schema Sync API Class reference
Index..::.AllowPageLocks Property
Index Class See Also Send Feedback
Gets or sets the ALLOWPAGEROCK option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowPageLocks { get; set; }
Visual Basic (Declaration)
Public Property AllowPageLocks As Boolean
Visual C++
public:
property bool AllowPageLocks {
    bool get ();
    void set (bool value);
}

See Also

Index Class


AllowRowLocks Property

[image]

SQL Schema Sync API Class reference
Index..::.AllowRowLocks Property
Index Class See Also Send Feedback
Gets or sets the ALLOWROWLOCK option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowRowLocks { get; set; }
Visual Basic (Declaration)
Public Property AllowRowLocks As Boolean
Visual C++
public:
property bool AllowRowLocks {
    bool get ();
    void set (bool value);
}

See Also

Index Class


Clustered Property

[image]

SQL Schema Sync API Class reference
Index..::.Clustered Property
Index Class See Also Send Feedback
Gets or sets if an index is clustered.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Clustered { get; set; }
Visual Basic (Declaration)
Public Property Clustered As Boolean
Visual C++
public:
property bool Clustered {
    bool get ();
    void set (bool value);
}

See Also

Index Class


Columns Property

[image]

SQL Schema Sync API Class reference
Index..::.Columns Property
Index Class See Also Send Feedback
Gets columns associated with this index.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexColumnCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As IndexColumnCollection
Visual C++
public:
property IndexColumnCollection^ Columns {
    IndexColumnCollection^ get ();
}

See Also

Index Class


FillFactor Property

[image]

SQL Schema Sync API Class reference
Index..::.FillFactor Property
Index Class See Also Send Feedback
Gets or sets the fill factor option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int FillFactor { get; set; }
Visual Basic (Declaration)
Public Property FillFactor As Integer
Visual C++
public:
property int FillFactor {
    int get ();
    void set (int value);
}

See Also

Index Class


IgnoreDupKey Property

[image]

SQL Schema Sync API Class reference
Index..::.IgnoreDupKey Property
Index Class See Also Send Feedback
Gets or sets the IGNOREDUPKEY option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IgnoreDupKey { get; set; }
Visual Basic (Declaration)
Public Property IgnoreDupKey As Boolean
Visual C++
public:
property bool IgnoreDupKey {
    bool get ();
    void set (bool value);
}

See Also

Index Class


IncludedColumns Property

[image]

SQL Schema Sync API Class reference
Index..::.IncludedColumns Property
Index Class See Also Send Feedback
Gets columns included with this index.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ColumnRefCollection IncludedColumns { get; }
Visual Basic (Declaration)
Public ReadOnly Property IncludedColumns As ColumnRefCollection
Visual C++
public:
property ColumnRefCollection^ IncludedColumns {
    ColumnRefCollection^ get ();
}

See Also

Index Class


MaxDop Property

[image]

SQL Schema Sync API Class reference
Index..::.MaxDop Property
Index Class See Also Send Feedback
Gets or sets the MAXDOP option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int MaxDop { get; set; }
Visual Basic (Declaration)
Public Property MaxDop As Integer
Visual C++
public:
property int MaxDop {
    int get ();
    void set (int value);
}

See Also

Index Class


Online Property

[image]

SQL Schema Sync API Class reference
Index..::.Online Property
Index Class See Also Send Feedback
Gets or sets the ONLINE option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Online { get; set; }
Visual Basic (Declaration)
Public Property Online As Boolean
Visual C++
public:
property bool Online {
    bool get ();
    void set (bool value);
}

See Also

Index Class


PadIndex Property

[image]

SQL Schema Sync API Class reference
Index..::.PadIndex Property
Index Class See Also Send Feedback
Gets or sets the Pad Index option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool PadIndex { get; set; }
Visual Basic (Declaration)
Public Property PadIndex As Boolean
Visual C++
public:
property bool PadIndex {
    bool get ();
    void set (bool value);
}

See Also

Index Class


SortInTempDb Property

[image]

SQL Schema Sync API Class reference
Index..::.SortInTempDb Property
Index Class See Also Send Feedback
Gets or sets the SORTINTEMPDB option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool SortInTempDb { get; set; }
Visual Basic (Declaration)
Public Property SortInTempDb As Boolean
Visual C++
public:
property bool SortInTempDb {
    bool get ();
    void set (bool value);
}

See Also

Index Class


StatisticNoRecompute Property

[image]

SQL Schema Sync API Class reference
Index..::.StatisticNoRecompute Property
Index Class See Also Send Feedback
Gets or sets the STATISTICNORECOMPUTE option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool StatisticNoRecompute { get; set; }
Visual Basic (Declaration)
Public Property StatisticNoRecompute As Boolean
Visual C++
public:
property bool StatisticNoRecompute {
    bool get ();
    void set (bool value);
}

See Also

Index Class


Unique Property

[image]

SQL Schema Sync API Class reference
Index..::.Unique Property
Index Class See Also Send Feedback
Gets or sets if an index is unique.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Unique { get; set; }
Visual Basic (Declaration)
Public Property Unique As Boolean
Visual C++
public:
property bool Unique {
    bool get ();
    void set (bool value);
}

See Also

Index Class


IndexBase Class

[image]

SQL Schema Sync API Class reference
IndexBase Class
Members See Also Send Feedback
Abstract base class for the index objects.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class IndexBase : DatabaseObject,
    ISchemaObject
Visual Basic (Declaration)
Public MustInherit Class IndexBase _
    Inherits DatabaseObject _
    Implements ISchemaObject
Visual C++
public ref class IndexBase abstract : public DatabaseObject,
    ISchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.IndexBase
PerpetuumSoft.DataModel.MsSql..::.Index
PerpetuumSoft.DataModel.MsSql..::.SpatialIndexSql10
PerpetuumSoft.DataModel.MsSql..::.XmlIndex

See Also

IndexBase Members


IndexBase Members

[image] [image]

SQL Schema Sync API Class reference
IndexBase Members
IndexBase Class Constructors Methods Properties See Also Send Feedback

The IndexBase type exposes the following members.

Constructors

Name | Description
IndexBase | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Overrides Element..::.RelatesTo(Element).)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()().
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema.
Table | Gets or sets TableBase.

See Also

IndexBase Class


IndexBase Constructor

[image] [image]

SQL Schema Sync API Class reference
IndexBase Constructor
IndexBase Class See Also Send Feedback

Overload List

Name | Description
IndexBase()()() | Initializes a new instance of the IndexBase class
IndexBase(String, TableBase) | Initializes a new instance of the IndexBase class

See Also

IndexBase Class
IndexBase Members


IndexBase Constructor

[image]

SQL Schema Sync API Class reference
IndexBase Constructor
IndexBase Class See Also Send Feedback
Initializes a new instance of the IndexBase class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected IndexBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
IndexBase()

See Also

IndexBase Class
IndexBase Overload


IndexBase Constructor (String, TableBase)

[image]

SQL Schema Sync API Class reference
IndexBase Constructor (String, TableBase)
IndexBase Class See Also Send Feedback
Initializes a new instance of the IndexBase class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected IndexBase(
    string name,
    TableBase table
)
Visual Basic (Declaration)
Protected Sub New ( _
    name As String, _
    table As TableBase _
)
Visual C++
protected:
IndexBase(
    String^ name,
    TableBase^ table
)

Parameters

name
Type: System..::.String
table
Type: PerpetuumSoft.DataModel.MsSql..::.TableBase

See Also

IndexBase Class
IndexBase Overload


IndexBase Methods

[image] [image]

SQL Schema Sync API Class reference
IndexBase Methods
IndexBase Class See Also Send Feedback

The IndexBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Overrides Element..::.RelatesTo(Element).)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

IndexBase Class


RelatesTo Method

[image]

SQL Schema Sync API Class reference
IndexBase..::.RelatesTo Method
IndexBase Class See Also Send Feedback
Overridden. See RelatesTo(Element).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool RelatesTo(
    Element element
)
Visual Basic (Declaration)
Public Overrides Function RelatesTo ( _
    element As Element _
) As Boolean
Visual C++
public:
virtual bool RelatesTo(
    Element^ element
) override

Parameters

element
Type: PerpetuumSoft.DataModel.MsSql..::.Element

See Also

IndexBase Class


IndexBase Properties

[image] [image]

SQL Schema Sync API Class reference
IndexBase Properties
IndexBase Class See Also Send Feedback

The IndexBase type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()().
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema.
Table | Gets or sets TableBase.

See Also

IndexBase Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
IndexBase..::.ExtendedProperties Property
IndexBase Class See Also Send Feedback
Implements ExtendedProperties()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

IndexBase Class


Schema Property

[image]

SQL Schema Sync API Class reference
IndexBase..::.Schema Property
IndexBase Class See Also Send Feedback
Implements Schema.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Schema Schema { get; }
Visual Basic (Declaration)
Public ReadOnly Property Schema As Schema
Visual C++
public:
virtual property Schema^ Schema {
    Schema^ get () sealed;
}

Implements

ISchemaObject..::.Schema

See Also

IndexBase Class


Table Property

[image]

SQL Schema Sync API Class reference
IndexBase..::.Table Property
IndexBase Class See Also Send Feedback
Gets or sets TableBase.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableBase Table { get; set; }
Visual Basic (Declaration)
Public Property Table As TableBase
Visual C++
public:
property TableBase^ Table {
    TableBase^ get ();
    void set (TableBase^ value);
}

See Also

IndexBase Class


IndexColumn Class

[image]

SQL Schema Sync API Class reference
IndexColumn Class
Members See Also Send Feedback
Represents a column in the index.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class IndexColumn
Visual Basic (Declaration)
Public NotInheritable Class IndexColumn
Visual C++
public ref class IndexColumn sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.IndexColumn

See Also

IndexColumn Members


IndexColumn Members

[image] [image]

SQL Schema Sync API Class reference
IndexColumn Members
IndexColumn Class Constructors Methods Properties See Also Send Feedback

The IndexColumn type exposes the following members.

Constructors

Name | Description
IndexColumn | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Column | Gets or sets ColumnBase.
Order | Gets or sets IndexColumnOrder.

See Also

IndexColumn Class


IndexColumn Constructor

[image] [image]

SQL Schema Sync API Class reference
IndexColumn Constructor
IndexColumn Class See Also Send Feedback

Overload List

Name | Description
IndexColumn()()() | Initializes a new instance of the IndexColumn class.
IndexColumn(ColumnBase) | Creates new instance of the IndexColumn class.

See Also

IndexColumn Class
IndexColumn Members


IndexColumn Constructor

[image]

SQL Schema Sync API Class reference
IndexColumn Constructor
IndexColumn Class See Also Send Feedback
Initializes a new instance of the IndexColumn class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexColumn()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IndexColumn()

See Also

IndexColumn Class
IndexColumn Overload


IndexColumn Constructor (ColumnBase)

[image]

SQL Schema Sync API Class reference
IndexColumn Constructor (ColumnBase)
IndexColumn Class See Also Send Feedback
Creates new instance of the IndexColumn class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexColumn(
    ColumnBase column
)
Visual Basic (Declaration)
Public Sub New ( _
    column As ColumnBase _
)
Visual C++
public:
IndexColumn(
    ColumnBase^ column
)

Parameters

column
Type: PerpetuumSoft.DataModel.MsSql..::.ColumnBase

See Also

IndexColumn Class
IndexColumn Overload


IndexColumn Methods

[image] [image]

SQL Schema Sync API Class reference
IndexColumn Methods
IndexColumn Class See Also Send Feedback

The IndexColumn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexColumn Class


IndexColumn Properties

[image] [image]

SQL Schema Sync API Class reference
IndexColumn Properties
IndexColumn Class See Also Send Feedback

The IndexColumn type exposes the following members.

Properties

Name | Description
Column | Gets or sets ColumnBase.
Order | Gets or sets IndexColumnOrder.

See Also

IndexColumn Class


Column Property

[image]

SQL Schema Sync API Class reference
IndexColumn..::.Column Property
IndexColumn Class See Also Send Feedback
Gets or sets ColumnBase.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ColumnBase Column { get; set; }
Visual Basic (Declaration)
Public Property Column As ColumnBase
Visual C++
public:
property ColumnBase^ Column {
    ColumnBase^ get ();
    void set (ColumnBase^ value);
}

See Also

IndexColumn Class


Order Property

[image]

SQL Schema Sync API Class reference
IndexColumn..::.Order Property
IndexColumn Class See Also Send Feedback
Gets or sets IndexColumnOrder.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexColumnOrder Order { get; set; }
Visual Basic (Declaration)
Public Property Order As IndexColumnOrder
Visual C++
public:
property IndexColumnOrder Order {
    IndexColumnOrder get ();
    void set (IndexColumnOrder value);
}

See Also

IndexColumn Class


IndexColumnCollection Class

[image]

SQL Schema Sync API Class reference
IndexColumnCollection Class
Members See Also Send Feedback
Represents a collection of IndexColumn .

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class IndexColumnCollection : Collection<IndexColumn>
Visual Basic (Declaration)
Public NotInheritable Class IndexColumnCollection _
    Inherits Collection(Of IndexColumn)
Visual C++
public ref class IndexColumnCollection sealed : public Collection<IndexColumn^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( IndexColumn >)>)
PerpetuumSoft.DataModel.MsSql..::.IndexColumnCollection

See Also

IndexColumnCollection Members


IndexColumnCollection Members

[image] [image]

SQL Schema Sync API Class reference
IndexColumnCollection Members
IndexColumnCollection Class Methods Properties See Also Send Feedback

The IndexColumnCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( IndexColumn >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( IndexColumn >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( IndexColumn >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( IndexColumn >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( IndexColumn >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)

See Also

IndexColumnCollection Class


IndexColumnCollection Methods

[image] [image]

SQL Schema Sync API Class reference
IndexColumnCollection Methods
IndexColumnCollection Class See Also Send Feedback

The IndexColumnCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( IndexColumn >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( IndexColumn >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( IndexColumn >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( IndexColumn >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexColumnCollection Class


IndexColumnCollection Properties

[image] [image]

SQL Schema Sync API Class reference
IndexColumnCollection Properties
IndexColumnCollection Class See Also Send Feedback

The IndexColumnCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( IndexColumn >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( IndexColumn >)>).)

See Also

IndexColumnCollection Class


IndexColumnOrder Enumeration

[image]

SQL Schema Sync API Class reference
IndexColumnOrder Enumeration
See Also Send Feedback
Represents an order of the index elements.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum IndexColumnOrder
Visual Basic (Declaration)
Public Enumeration IndexColumnOrder
Visual C++
public enum class IndexColumnOrder

Members

Member name | Description
Ascending | Ascending order.
Descending | Descending order.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


IndexFilter Class

[image]

SQL Schema Sync API Class reference
IndexFilter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.IndexFilter"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class IndexFilter
Visual Basic (Declaration)
Public Class IndexFilter
Visual C++
public ref class IndexFilter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.IndexFilter

See Also

IndexFilter Members


IndexFilter Members

[image] [image]

SQL Schema Sync API Class reference
IndexFilter Members
IndexFilter Class Constructors Methods Properties See Also Send Feedback

The IndexFilter type exposes the following members.

Constructors

Name | Description
IndexFilter | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FilterDefinition |

See Also

IndexFilter Class


IndexFilter Constructor

[image] [image]

SQL Schema Sync API Class reference
IndexFilter Constructor
IndexFilter Class See Also Send Feedback

Overload List

Name | Description
IndexFilter()()() | Initializes a new instance of the IndexFilter class
IndexFilter(String) | Initializes a new instance of the IndexFilter class

See Also

IndexFilter Class
IndexFilter Members


IndexFilter Constructor

[image]

SQL Schema Sync API Class reference
IndexFilter Constructor
IndexFilter Class See Also Send Feedback
Initializes a new instance of the IndexFilter class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IndexFilter()

See Also

IndexFilter Class
IndexFilter Overload


IndexFilter Constructor (String)

[image]

SQL Schema Sync API Class reference
IndexFilter Constructor (String)
IndexFilter Class See Also Send Feedback
Initializes a new instance of the IndexFilter class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexFilter(
    string filterDefinition
)
Visual Basic (Declaration)
Public Sub New ( _
    filterDefinition As String _
)
Visual C++
public:
IndexFilter(
    String^ filterDefinition
)

Parameters

filterDefinition
Type: System..::.String

See Also

IndexFilter Class
IndexFilter Overload


IndexFilter Methods

[image] [image]

SQL Schema Sync API Class reference
IndexFilter Methods
IndexFilter Class See Also Send Feedback

The IndexFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexFilter Class


IndexFilter Properties

[image] [image]

SQL Schema Sync API Class reference
IndexFilter Properties
IndexFilter Class See Also Send Feedback

The IndexFilter type exposes the following members.

Properties

Name | Description
FilterDefinition |

See Also

IndexFilter Class


FilterDefinition Property

[image]

SQL Schema Sync API Class reference
IndexFilter..::.FilterDefinition Property
IndexFilter Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.IndexFilter.FilterDefinition"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string FilterDefinition { get; set; }
Visual Basic (Declaration)
Public Property FilterDefinition As String
Visual C++
public:
property String^ FilterDefinition {
    String^ get ();
    void set (String^ value);
}

See Also

IndexFilter Class


IndexSql10 Class

[image]

SQL Schema Sync API Class reference
IndexSql10 Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.IndexSql10"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class IndexSql10 : Index
Visual Basic (Declaration)
Public Class IndexSql10 _
    Inherits Index
Visual C++
public ref class IndexSql10 : public Index

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.IndexBase
PerpetuumSoft.DataModel.MsSql..::.Index
PerpetuumSoft.DataModel.MsSql..::.IndexSql10

See Also

IndexSql10 Members


IndexSql10 Members

[image] [image]

SQL Schema Sync API Class reference
IndexSql10 Members
IndexSql10 Class Constructors Methods Properties See Also Send Feedback

The IndexSql10 type exposes the following members.

Constructors

Name | Description
IndexSql10 | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from IndexBase.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
AllowPageLocks | Gets or sets the ALLOWPAGEROCK option. (Inherited from Index.)
AllowRowLocks | Gets or sets the ALLOWROWLOCK option. (Inherited from Index.)
Clustered | Gets or sets if an index is clustered. (Inherited from Index.)
Columns | Gets columns associated with this index. (Inherited from Index.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). (Inherited from IndexBase.)
FillFactor | Gets or sets the fill factor option. (Inherited from Index.)
Filter |
FullName | Gets the element full name. (Inherited from Element.)
IgnoreDupKey | Gets or sets the IGNOREDUPKEY option. (Inherited from Index.)
IncludedColumns | Gets columns included with this index. (Inherited from Index.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MaxDop | Gets or sets the MAXDOP option. (Inherited from Index.)
Name | Gets or sets an element name. (Inherited from Element.)
Online | Gets or sets the ONLINE option. (Inherited from Index.)
PadIndex | Gets or sets the Pad Index option. (Inherited from Index.)
Schema | Implements Schema. (Inherited from IndexBase.)
SortInTempDb | Gets or sets the SORTINTEMPDB option. (Inherited from Index.)
StatisticNoRecompute | Gets or sets the STATISTICNORECOMPUTE option. (Inherited from Index.)
Table | Gets or sets TableBase. (Inherited from IndexBase.)
Unique | Gets or sets if an index is unique. (Inherited from Index.)

See Also

IndexSql10 Class


IndexSql10 Constructor

[image] [image]

SQL Schema Sync API Class reference
IndexSql10 Constructor
IndexSql10 Class See Also Send Feedback

Overload List

Name | Description
IndexSql10()()() | Initializes a new instance of the IndexSql10 class
IndexSql10(String, TableBase) | Initializes a new instance of the IndexSql10 class

See Also

IndexSql10 Class
IndexSql10 Members


IndexSql10 Constructor

[image]

SQL Schema Sync API Class reference
IndexSql10 Constructor
IndexSql10 Class See Also Send Feedback
Initializes a new instance of the IndexSql10 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexSql10()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IndexSql10()

See Also

IndexSql10 Class
IndexSql10 Overload


IndexSql10 Constructor (String, TableBase)

[image]

SQL Schema Sync API Class reference
IndexSql10 Constructor (String, TableBase)
IndexSql10 Class See Also Send Feedback
Initializes a new instance of the IndexSql10 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexSql10(
    string name,
    TableBase table
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    table As TableBase _
)
Visual C++
public:
IndexSql10(
    String^ name,
    TableBase^ table
)

Parameters

name
Type: System..::.String
table
Type: PerpetuumSoft.DataModel.MsSql..::.TableBase

See Also

IndexSql10 Class
IndexSql10 Overload


IndexSql10 Methods

[image] [image]

SQL Schema Sync API Class reference
IndexSql10 Methods
IndexSql10 Class See Also Send Feedback

The IndexSql10 type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from IndexBase.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

IndexSql10 Class


IndexSql10 Properties

[image] [image]

SQL Schema Sync API Class reference
IndexSql10 Properties
IndexSql10 Class See Also Send Feedback

The IndexSql10 type exposes the following members.

Properties

Name | Description
AllowPageLocks | Gets or sets the ALLOWPAGEROCK option. (Inherited from Index.)
AllowRowLocks | Gets or sets the ALLOWROWLOCK option. (Inherited from Index.)
Clustered | Gets or sets if an index is clustered. (Inherited from Index.)
Columns | Gets columns associated with this index. (Inherited from Index.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). (Inherited from IndexBase.)
FillFactor | Gets or sets the fill factor option. (Inherited from Index.)
Filter |
FullName | Gets the element full name. (Inherited from Element.)
IgnoreDupKey | Gets or sets the IGNOREDUPKEY option. (Inherited from Index.)
IncludedColumns | Gets columns included with this index. (Inherited from Index.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MaxDop | Gets or sets the MAXDOP option. (Inherited from Index.)
Name | Gets or sets an element name. (Inherited from Element.)
Online | Gets or sets the ONLINE option. (Inherited from Index.)
PadIndex | Gets or sets the Pad Index option. (Inherited from Index.)
Schema | Implements Schema. (Inherited from IndexBase.)
SortInTempDb | Gets or sets the SORTINTEMPDB option. (Inherited from Index.)
StatisticNoRecompute | Gets or sets the STATISTICNORECOMPUTE option. (Inherited from Index.)
Table | Gets or sets TableBase. (Inherited from IndexBase.)
Unique | Gets or sets if an index is unique. (Inherited from Index.)

See Also

IndexSql10 Class


Filter Property

[image]

SQL Schema Sync API Class reference
IndexSql10..::.Filter Property
IndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.IndexSql10.Filter"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexFilter Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As IndexFilter
Visual C++
public:
property IndexFilter^ Filter {
    IndexFilter^ get ();
    void set (IndexFilter^ value);
}

See Also

IndexSql10 Class


InlineTableValuedFunction Class

[image]

SQL Schema Sync API Class reference
InlineTableValuedFunction Class
Members See Also Send Feedback
Represents the inline table valued function in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class InlineTableValuedFunction : TableValuedFunction
Visual Basic (Declaration)
Public NotInheritable Class InlineTableValuedFunction _
    Inherits TableValuedFunction
Visual C++
public ref class InlineTableValuedFunction sealed : public TableValuedFunction

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.TextFunction
PerpetuumSoft.DataModel.MsSql..::.TableValuedFunction
PerpetuumSoft.DataModel.MsSql..::.InlineTableValuedFunction

See Also

InlineTableValuedFunction Members


InlineTableValuedFunction Members

[image] [image]

SQL Schema Sync API Class reference
InlineTableValuedFunction Members
InlineTableValuedFunction Class Constructors Methods Properties See Also Send Feedback

The InlineTableValuedFunction type exposes the following members.

Constructors

Name | Description
InlineTableValuedFunction | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure. (Inherited from TextFunction.)

See Also

InlineTableValuedFunction Class


InlineTableValuedFunction Constructor

[image] [image]

SQL Schema Sync API Class reference
InlineTableValuedFunction Constructor
InlineTableValuedFunction Class See Also Send Feedback

Overload List

Name | Description
InlineTableValuedFunction()()() | Creates new instance of the InlineTableValuedFunction class.
InlineTableValuedFunction(String, String) | Creates new instance of the InlineTableValuedFunction class.

See Also

InlineTableValuedFunction Class
InlineTableValuedFunction Members


InlineTableValuedFunction Constructor

[image]

SQL Schema Sync API Class reference
InlineTableValuedFunction Constructor
InlineTableValuedFunction Class See Also Send Feedback
Creates new instance of the InlineTableValuedFunction class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public InlineTableValuedFunction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InlineTableValuedFunction()

See Also

InlineTableValuedFunction Class
InlineTableValuedFunction Overload


InlineTableValuedFunction Constructor (String, String)

[image]

SQL Schema Sync API Class reference
InlineTableValuedFunction Constructor (String, String)
InlineTableValuedFunction Class See Also Send Feedback
Creates new instance of the InlineTableValuedFunction class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public InlineTableValuedFunction(
    string name,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
InlineTableValuedFunction(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
text
Type: System..::.String

See Also

InlineTableValuedFunction Class
InlineTableValuedFunction Overload


InlineTableValuedFunction Methods

[image] [image]

SQL Schema Sync API Class reference
InlineTableValuedFunction Methods
InlineTableValuedFunction Class See Also Send Feedback

The InlineTableValuedFunction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

InlineTableValuedFunction Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
InlineTableValuedFunction..::.SetExecuteAsClause Method
InlineTableValuedFunction Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context. (Inherited from FunctionBase.)
SetExecuteAsClause(String) | Sets the function security context. (Inherited from FunctionBase.)

See Also

InlineTableValuedFunction Class
InlineTableValuedFunction Members


InlineTableValuedFunction Properties

[image] [image]

SQL Schema Sync API Class reference
InlineTableValuedFunction Properties
InlineTableValuedFunction Class See Also Send Feedback

The InlineTableValuedFunction type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure. (Inherited from TextFunction.)

See Also

InlineTableValuedFunction Class


InParameter Class

[image]

SQL Schema Sync API Class reference
InParameter Class
Members See Also Send Feedback
Represents input parameter for the function and stored procedure in a data base structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class InParameter : ParameterBase
Visual Basic (Declaration)
Public NotInheritable Class InParameter _
    Inherits ParameterBase
Visual C++
public ref class InParameter sealed : public ParameterBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.ParameterBase
PerpetuumSoft.DataModel.MsSql..::.InParameter

See Also

InParameter Members


InParameter Members

[image] [image]

SQL Schema Sync API Class reference
InParameter Members
InParameter Class Constructors Methods Properties See Also Send Feedback

The InParameter type exposes the following members.

Constructors

Name | Description
InParameter | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets the input parameter description. (Overrides ParameterBase..::.ToString()()().)

Properties

Name | Description
DefaultValue | Gets or sets default value for an input parameter.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the input parameter.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets the FunctionBase class to which a parameter belongs. (Inherited from ParameterBase.)
Readonly | (Inherited from ParameterBase.)
Type | Gets or sets DataType of a parameter. (Inherited from ParameterBase.)

See Also

InParameter Class


InParameter Constructor

[image] [image]

SQL Schema Sync API Class reference
InParameter Constructor
InParameter Class See Also Send Feedback

Overload List

Name | Description
InParameter()()() | Creates new instance of the InParameter class.
InParameter(String, DataType) | Creates new instance of the InParameter class.
InParameter(String, DataType, String) | Creates new instance of the InParameter class.

See Also

InParameter Class
InParameter Members


InParameter Constructor

[image]

SQL Schema Sync API Class reference
InParameter Constructor
InParameter Class See Also Send Feedback
Creates new instance of the InParameter class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public InParameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InParameter()

See Also

InParameter Class
InParameter Overload


InParameter Constructor (String, DataType)

[image]

SQL Schema Sync API Class reference
InParameter Constructor (String, DataType)
InParameter Class See Also Send Feedback
Creates new instance of the InParameter class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public InParameter(
    string name,
    DataType type
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    type As DataType _
)
Visual C++
public:
InParameter(
    String^ name,
    DataType^ type
)

Parameters

name
Type: System..::.String
type
Type: PerpetuumSoft.DataModel.MsSql..::.DataType

See Also

InParameter Class
InParameter Overload


InParameter Constructor (String, DataType, String)

[image]

SQL Schema Sync API Class reference
InParameter Constructor (String, DataType, String)
InParameter Class See Also Send Feedback
Creates new instance of the InParameter class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public InParameter(
    string name,
    DataType type,
    string defaultValue
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    type As DataType, _
    defaultValue As String _
)
Visual C++
public:
InParameter(
    String^ name,
    DataType^ type,
    String^ defaultValue
)

Parameters

name
Type: System..::.String
type
Type: PerpetuumSoft.DataModel.MsSql..::.DataType
defaultValue
Type: System..::.String

See Also

InParameter Class
InParameter Overload


InParameter Methods

[image] [image]

SQL Schema Sync API Class reference
InParameter Methods
InParameter Class See Also Send Feedback

The InParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets the input parameter description. (Overrides ParameterBase..::.ToString()()().)

See Also

InParameter Class


ToString Method

[image]

SQL Schema Sync API Class reference
InParameter..::.ToString Method
InParameter Class See Also Send Feedback
Override. See ToString()()(). Gets the input parameter description.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

InParameter Class


InParameter Properties

[image] [image]

SQL Schema Sync API Class reference
InParameter Properties
InParameter Class See Also Send Feedback

The InParameter type exposes the following members.

Properties

Name | Description
DefaultValue | Gets or sets default value for an input parameter.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the input parameter.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets the FunctionBase class to which a parameter belongs. (Inherited from ParameterBase.)
Readonly | (Inherited from ParameterBase.)
Type | Gets or sets DataType of a parameter. (Inherited from ParameterBase.)

See Also

InParameter Class


DefaultValue Property

[image]

SQL Schema Sync API Class reference
InParameter..::.DefaultValue Property
InParameter Class See Also Send Feedback
Gets or sets default value for an input parameter.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string DefaultValue { get; set; }
Visual Basic (Declaration)
Public Property DefaultValue As String
Visual C++
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

See Also

InParameter Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
InParameter..::.ExtendedProperties Property
InParameter Class See Also Send Feedback
Implements ExtendedProperties()()(). Gets extended properties for the input parameter.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

InParameter Class


ISchemaObject Interface

[image]

SQL Schema Sync API Class reference
ISchemaObject Interface
Members See Also Send Feedback
Unites all schema-related objects.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public interface ISchemaObject
Visual Basic (Declaration)
Public Interface ISchemaObject
Visual C++
public interface class ISchemaObject

See Also

ISchemaObject Members


ISchemaObject Members

[image] [image]

SQL Schema Sync API Class reference
ISchemaObject Members
ISchemaObject Interface Properties See Also Send Feedback

The ISchemaObject type exposes the following members.

Properties

Name | Description
Name | Gets object name.
Schema | Gets Schema to which the object belongs.

See Also

ISchemaObject Interface


ISchemaObject Properties

[image] [image]

SQL Schema Sync API Class reference
ISchemaObject Properties
ISchemaObject Interface See Also Send Feedback

The ISchemaObject type exposes the following members.

Properties

Name | Description
Name | Gets object name.
Schema | Gets Schema to which the object belongs.

See Also

ISchemaObject Interface


Name Property

[image]

SQL Schema Sync API Class reference
ISchemaObject..::.Name Property
ISchemaObject Interface See Also Send Feedback
Gets object name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

ISchemaObject Interface


Schema Property

[image]

SQL Schema Sync API Class reference
ISchemaObject..::.Schema Property
ISchemaObject Interface See Also Send Feedback
Gets Schema to which the object belongs.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
Schema Schema { get; }
Visual Basic (Declaration)
ReadOnly Property Schema As Schema
Visual C++
property Schema^ Schema {
    Schema^ get ();
}

See Also

ISchemaObject Interface


ISecurable Interface

[image]

SQL Schema Sync API Class reference
ISecurable Interface
Members See Also Send Feedback
Unites all securable objects.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public interface ISecurable
Visual Basic (Declaration)
Public Interface ISecurable
Visual C++
public interface class ISecurable

See Also

ISecurable Members


ISecurable Members

[image] [image]

SQL Schema Sync API Class reference
ISecurable Members
ISecurable Interface Properties See Also Send Feedback

The ISecurable type exposes the following members.

Properties

Name | Description
FullName | Gets full name of the securable object.

See Also

ISecurable Interface


ISecurable Properties

[image] [image]

SQL Schema Sync API Class reference
ISecurable Properties
ISecurable Interface See Also Send Feedback

The ISecurable type exposes the following members.

Properties

Name | Description
FullName | Gets full name of the securable object.

See Also

ISecurable Interface


FullName Property

[image]

SQL Schema Sync API Class reference
ISecurable..::.FullName Property
ISecurable Interface See Also Send Feedback
Gets full name of the securable object.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
string FullName { get; }
Visual Basic (Declaration)
ReadOnly Property FullName As String
Visual C++
property String^ FullName {
    String^ get ();
}

See Also

ISecurable Interface


ISupportRulesDefaults Interface

[image]

SQL Schema Sync API Class reference
ISupportRulesDefaults Interface
See Also Send Feedback
Unites all objects supporting default values and rules.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public interface ISupportRulesDefaults
Visual Basic (Declaration)
Public Interface ISupportRulesDefaults
Visual C++
public interface class ISupportRulesDefaults

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


KeyConstraint Class

[image]

SQL Schema Sync API Class reference
KeyConstraint Class
Members See Also Send Feedback
Abtsract base class for the primary key and unique key objects.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class KeyConstraint : Constraint
Visual Basic (Declaration)
Public MustInherit Class KeyConstraint _
    Inherits Constraint
Visual C++
public ref class KeyConstraint abstract : public Constraint

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Constraint
PerpetuumSoft.DataModel.MsSql..::.KeyConstraint
PerpetuumSoft.DataModel.MsSql..::.PrimaryKey
PerpetuumSoft.DataModel.MsSql..::.UniqueConstraint

See Also

KeyConstraint Members


KeyConstraint Members

[image] [image]

SQL Schema Sync API Class reference
KeyConstraint Members
KeyConstraint Class Methods Properties See Also Send Feedback

The KeyConstraint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
AllowPageLocks | Gets or sets the ALLOWPAGEROCK option.
AllowRowLocks | Gets or sets the ALLOWROWLOCK option.
Clustered | Gets or sets if a key index is clustered.
Columns | Gets columns associated with the constraint.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FillFactor | Gets or sets a fill factor value.
FullName | Gets the element full name. (Inherited from Element.)
IgnoreDupKey | Gets or sets if the key index should ignore the duplicated keys.
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
PadIndex | Gets or sets a pad index value.
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
StatisticNoRecompute | Gets or sets the StatisticNoRecompute option.
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)

See Also

KeyConstraint Class


KeyConstraint Methods

[image] [image]

SQL Schema Sync API Class reference
KeyConstraint Methods
KeyConstraint Class See Also Send Feedback

The KeyConstraint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

KeyConstraint Class


KeyConstraint Properties

[image] [image]

SQL Schema Sync API Class reference
KeyConstraint Properties
KeyConstraint Class See Also Send Feedback

The KeyConstraint type exposes the following members.

Properties

Name | Description
AllowPageLocks | Gets or sets the ALLOWPAGEROCK option.
AllowRowLocks | Gets or sets the ALLOWROWLOCK option.
Clustered | Gets or sets if a key index is clustered.
Columns | Gets columns associated with the constraint.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FillFactor | Gets or sets a fill factor value.
FullName | Gets the element full name. (Inherited from Element.)
IgnoreDupKey | Gets or sets if the key index should ignore the duplicated keys.
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
PadIndex | Gets or sets a pad index value.
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
StatisticNoRecompute | Gets or sets the StatisticNoRecompute option.
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)

See Also

KeyConstraint Class


AllowPageLocks Property

[image]

SQL Schema Sync API Class reference
KeyConstraint..::.AllowPageLocks Property
KeyConstraint Class See Also Send Feedback
Gets or sets the ALLOWPAGEROCK option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowPageLocks { get; set; }
Visual Basic (Declaration)
Public Property AllowPageLocks As Boolean
Visual C++
public:
property bool AllowPageLocks {
    bool get ();
    void set (bool value);
}

See Also

KeyConstraint Class


AllowRowLocks Property

[image]

SQL Schema Sync API Class reference
KeyConstraint..::.AllowRowLocks Property
KeyConstraint Class See Also Send Feedback
Gets or sets the ALLOWROWLOCK option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowRowLocks { get; set; }
Visual Basic (Declaration)
Public Property AllowRowLocks As Boolean
Visual C++
public:
property bool AllowRowLocks {
    bool get ();
    void set (bool value);
}

See Also

KeyConstraint Class


Clustered Property

[image]

SQL Schema Sync API Class reference
KeyConstraint..::.Clustered Property
KeyConstraint Class See Also Send Feedback
Gets or sets if a key index is clustered.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Clustered { get; set; }
Visual Basic (Declaration)
Public Property Clustered As Boolean
Visual C++
public:
property bool Clustered {
    bool get ();
    void set (bool value);
}

See Also

KeyConstraint Class


Columns Property

[image]

SQL Schema Sync API Class reference
KeyConstraint..::.Columns Property
KeyConstraint Class See Also Send Feedback
Gets columns associated with the constraint.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexColumnCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As IndexColumnCollection
Visual C++
public:
property IndexColumnCollection^ Columns {
    IndexColumnCollection^ get ();
}

See Also

KeyConstraint Class


FillFactor Property

[image]

SQL Schema Sync API Class reference
KeyConstraint..::.FillFactor Property
KeyConstraint Class See Also Send Feedback
Gets or sets a fill factor value.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int FillFactor { get; set; }
Visual Basic (Declaration)
Public Property FillFactor As Integer
Visual C++
public:
property int FillFactor {
    int get ();
    void set (int value);
}

See Also

KeyConstraint Class


IgnoreDupKey Property

[image]

SQL Schema Sync API Class reference
KeyConstraint..::.IgnoreDupKey Property
KeyConstraint Class See Also Send Feedback
Gets or sets if the key index should ignore the duplicated keys.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IgnoreDupKey { get; set; }
Visual Basic (Declaration)
Public Property IgnoreDupKey As Boolean
Visual C++
public:
property bool IgnoreDupKey {
    bool get ();
    void set (bool value);
}

See Also

KeyConstraint Class


PadIndex Property

[image]

SQL Schema Sync API Class reference
KeyConstraint..::.PadIndex Property
KeyConstraint Class See Also Send Feedback
Gets or sets a pad index value.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool PadIndex { get; set; }
Visual Basic (Declaration)
Public Property PadIndex As Boolean
Visual C++
public:
property bool PadIndex {
    bool get ();
    void set (bool value);
}

See Also

KeyConstraint Class


StatisticNoRecompute Property

[image]

SQL Schema Sync API Class reference
KeyConstraint..::.StatisticNoRecompute Property
KeyConstraint Class See Also Send Feedback
Gets or sets the StatisticNoRecompute option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool StatisticNoRecompute { get; set; }
Visual Basic (Declaration)
Public Property StatisticNoRecompute As Boolean
Visual C++
public:
property bool StatisticNoRecompute {
    bool get ();
    void set (bool value);
}

See Also

KeyConstraint Class


MultistatementTableValuedFunction Class

[image]

SQL Schema Sync API Class reference
MultistatementTableValuedFunction Class
Members See Also Send Feedback
Represents the multistatement table valued function in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class MultistatementTableValuedFunction : TableValuedFunction
Visual Basic (Declaration)
Public NotInheritable Class MultistatementTableValuedFunction _
    Inherits TableValuedFunction
Visual C++
public ref class MultistatementTableValuedFunction sealed : public TableValuedFunction

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.TextFunction
PerpetuumSoft.DataModel.MsSql..::.TableValuedFunction
PerpetuumSoft.DataModel.MsSql..::.MultistatementTableValuedFunction

See Also

MultistatementTableValuedFunction Members


MultistatementTableValuedFunction Members

[image] [image]

SQL Schema Sync API Class reference
MultistatementTableValuedFunction Members
MultistatementTableValuedFunction Class Constructors Methods Properties See Also Send Feedback

The MultistatementTableValuedFunction type exposes the following members.

Constructors

Name | Description
MultistatementTableValuedFunction | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure. (Inherited from TextFunction.)

See Also

MultistatementTableValuedFunction Class


MultistatementTableValuedFunction Constructor

[image] [image]

SQL Schema Sync API Class reference
MultistatementTableValuedFunction Constructor
MultistatementTableValuedFunction Class See Also Send Feedback

Overload List

Name | Description
MultistatementTableValuedFunction()()() | Creates new instance of the MultistatementTableValuedFunction class.
MultistatementTableValuedFunction(String, String) | Creates new instance of the MultistatementTableValuedFunction.

See Also

MultistatementTableValuedFunction Class
MultistatementTableValuedFunction Members


MultistatementTableValuedFunction Constructor

[image]

SQL Schema Sync API Class reference
MultistatementTableValuedFunction Constructor
MultistatementTableValuedFunction Class See Also Send Feedback
Creates new instance of the MultistatementTableValuedFunction class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public MultistatementTableValuedFunction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MultistatementTableValuedFunction()

See Also

MultistatementTableValuedFunction Class
MultistatementTableValuedFunction Overload


MultistatementTableValuedFunction Constructor (String, String)

[image]

SQL Schema Sync API Class reference
MultistatementTableValuedFunction Constructor (String, String)
MultistatementTableValuedFunction Class See Also Send Feedback
Creates new instance of the MultistatementTableValuedFunction.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public MultistatementTableValuedFunction(
    string name,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
MultistatementTableValuedFunction(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
text
Type: System..::.String

See Also

MultistatementTableValuedFunction Class
MultistatementTableValuedFunction Overload


MultistatementTableValuedFunction Methods

[image] [image]

SQL Schema Sync API Class reference
MultistatementTableValuedFunction Methods
MultistatementTableValuedFunction Class See Also Send Feedback

The MultistatementTableValuedFunction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

MultistatementTableValuedFunction Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
MultistatementTableValuedFunction..::.SetExecuteAsClause Method
MultistatementTableValuedFunction Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context. (Inherited from FunctionBase.)
SetExecuteAsClause(String) | Sets the function security context. (Inherited from FunctionBase.)

See Also

MultistatementTableValuedFunction Class
MultistatementTableValuedFunction Members


MultistatementTableValuedFunction Properties

[image] [image]

SQL Schema Sync API Class reference
MultistatementTableValuedFunction Properties
MultistatementTableValuedFunction Class See Also Send Feedback

The MultistatementTableValuedFunction type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure. (Inherited from TextFunction.)

See Also

MultistatementTableValuedFunction Class


NullInputOption Enumeration

[image]

SQL Schema Sync API Class reference
NullInputOption Enumeration
See Also Send Feedback
Represents options of function execution subject to the input values.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum NullInputOption
Visual Basic (Declaration)
Public Enumeration NullInputOption
Visual C++
public enum class NullInputOption

Members

Member name | Description
ReturnsNullOnNullInput | Returns null on null input.
CalledOnNullInput | Called on null input.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


OutParameter Class

[image]

SQL Schema Sync API Class reference
OutParameter Class
Members See Also Send Feedback
Represents the function output parameter in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class OutParameter : ParameterBase
Visual Basic (Declaration)
Public NotInheritable Class OutParameter _
    Inherits ParameterBase
Visual C++
public ref class OutParameter sealed : public ParameterBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.ParameterBase
PerpetuumSoft.DataModel.MsSql..::.OutParameter

See Also

OutParameter Members


OutParameter Members

[image] [image]

SQL Schema Sync API Class reference
OutParameter Members
OutParameter Class Constructors Methods Properties See Also Send Feedback

The OutParameter type exposes the following members.

Constructors

Name | Description
OutParameter | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets the parameter description. (Inherited from ParameterBase.)

Properties

Name | Description
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets the FunctionBase class to which a parameter belongs. (Inherited from ParameterBase.)
Readonly | (Inherited from ParameterBase.)
Type | Gets or sets DataType of a parameter. (Inherited from ParameterBase.)

See Also

OutParameter Class


OutParameter Constructor

[image] [image]

SQL Schema Sync API Class reference
OutParameter Constructor
OutParameter Class See Also Send Feedback

Overload List

Name | Description
OutParameter()()() | Creates new instance of the OutParameter class.
OutParameter(String, DataType) | Creates new instance of the OutParameter class.

See Also

OutParameter Class
OutParameter Members


OutParameter Constructor

[image]

SQL Schema Sync API Class reference
OutParameter Constructor
OutParameter Class See Also Send Feedback
Creates new instance of the OutParameter class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public OutParameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OutParameter()

See Also

OutParameter Class
OutParameter Overload


OutParameter Constructor (String, DataType)

[image]

SQL Schema Sync API Class reference
OutParameter Constructor (String, DataType)
OutParameter Class See Also Send Feedback
Creates new instance of the OutParameter class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public OutParameter(
    string name,
    DataType type
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    type As DataType _
)
Visual C++
public:
OutParameter(
    String^ name,
    DataType^ type
)

Parameters

name
Type: System..::.String
type
Type: PerpetuumSoft.DataModel.MsSql..::.DataType

See Also

OutParameter Class
OutParameter Overload


OutParameter Methods

[image] [image]

SQL Schema Sync API Class reference
OutParameter Methods
OutParameter Class See Also Send Feedback

The OutParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets the parameter description. (Inherited from ParameterBase.)

See Also

OutParameter Class


OutParameter Properties

[image] [image]

SQL Schema Sync API Class reference
OutParameter Properties
OutParameter Class See Also Send Feedback

The OutParameter type exposes the following members.

Properties

Name | Description
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets the FunctionBase class to which a parameter belongs. (Inherited from ParameterBase.)
Readonly | (Inherited from ParameterBase.)
Type | Gets or sets DataType of a parameter. (Inherited from ParameterBase.)

See Also

OutParameter Class


PageVerify Enumeration

[image]

SQL Schema Sync API Class reference
PageVerify Enumeration
See Also Send Feedback
PageVerify.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum PageVerify
Visual Basic (Declaration)
Public Enumeration PageVerify
Visual C++
public enum class PageVerify

Members

Member name | Description
TornPageDetection | TornPageDetection.
Checksum | Checksum.
None | None.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


ParameterBase Class

[image]

SQL Schema Sync API Class reference
ParameterBase Class
Members See Also Send Feedback
Basic class for function parameters.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class ParameterBase : Element
Visual Basic (Declaration)
Public MustInherit Class ParameterBase _
    Inherits Element
Visual C++
public ref class ParameterBase abstract : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.ParameterBase
PerpetuumSoft.DataModel.MsSql..::.InParameter
PerpetuumSoft.DataModel.MsSql..::.OutParameter

See Also

ParameterBase Members


ParameterBase Members

[image] [image]

SQL Schema Sync API Class reference
ParameterBase Members
ParameterBase Class Methods Properties See Also Send Feedback

The ParameterBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets the parameter description. (Overrides Element..::.ToString()()().)

Properties

Name | Description
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets the FunctionBase class to which a parameter belongs.
Readonly |
Type | Gets or sets DataType of a parameter.

See Also

ParameterBase Class


ParameterBase Methods

[image] [image]

SQL Schema Sync API Class reference
ParameterBase Methods
ParameterBase Class See Also Send Feedback

The ParameterBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets the parameter description. (Overrides Element..::.ToString()()().)

See Also

ParameterBase Class


ToString Method

[image]

SQL Schema Sync API Class reference
ParameterBase..::.ToString Method
ParameterBase Class See Also Send Feedback
Override. See ToString()()(). Gets the parameter description.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ParameterBase Class


ParameterBase Properties

[image] [image]

SQL Schema Sync API Class reference
ParameterBase Properties
ParameterBase Class See Also Send Feedback

The ParameterBase type exposes the following members.

Properties

Name | Description
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets the FunctionBase class to which a parameter belongs.
Readonly |
Type | Gets or sets DataType of a parameter.

See Also

ParameterBase Class


Owner Property

[image]

SQL Schema Sync API Class reference
ParameterBase..::.Owner Property
ParameterBase Class See Also Send Feedback
Gets or sets the FunctionBase class to which a parameter belongs.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public FunctionBase Owner { get; internal set; }
Visual Basic (Declaration)
Public Property Owner As FunctionBase
Visual C++
public:
property FunctionBase^ Owner {
    FunctionBase^ get ();
    void set (FunctionBase^ value);
}

See Also

ParameterBase Class


Readonly Property

[image]

SQL Schema Sync API Class reference
ParameterBase..::.Readonly Property
ParameterBase Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.ParameterBase.Readonly"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Readonly { get; set; }
Visual Basic (Declaration)
Public Property Readonly As Boolean
Visual C++
public:
property bool Readonly {
    bool get ();
    void set (bool value);
}

See Also

ParameterBase Class


Type Property

[image]

SQL Schema Sync API Class reference
ParameterBase..::.Type Property
ParameterBase Class See Also Send Feedback
Gets or sets DataType of a parameter.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DataType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As DataType
Visual C++
public:
property DataType^ Type {
    DataType^ get ();
    void set (DataType^ value);
}

See Also

ParameterBase Class


ParameterBaseCollection Class

[image]

SQL Schema Sync API Class reference
ParameterBaseCollection Class
Members See Also Send Feedback
Represents collection of function parameters in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ParameterBaseCollection : Collection<ParameterBase>
Visual Basic (Declaration)
Public NotInheritable Class ParameterBaseCollection _
    Inherits Collection(Of ParameterBase)
Visual C++
public ref class ParameterBaseCollection sealed : public Collection<ParameterBase^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( ParameterBase >)>)
PerpetuumSoft.DataModel.MsSql..::.ParameterBaseCollection

See Also

ParameterBaseCollection Members


ParameterBaseCollection Members

[image] [image]

SQL Schema Sync API Class reference
ParameterBaseCollection Members
ParameterBaseCollection Class Methods Properties See Also Send Feedback

The ParameterBaseCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( ParameterBase >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ParameterBase >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ParameterBase >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( ParameterBase >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
Owner | Gets the FunctionBase class to which parameters belong.

See Also

ParameterBaseCollection Class


ParameterBaseCollection Methods

[image] [image]

SQL Schema Sync API Class reference
ParameterBaseCollection Methods
ParameterBaseCollection Class See Also Send Feedback

The ParameterBaseCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( ParameterBase >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ParameterBase >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( ParameterBase >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( ParameterBase >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterBaseCollection Class


ParameterBaseCollection Properties

[image] [image]

SQL Schema Sync API Class reference
ParameterBaseCollection Properties
ParameterBaseCollection Class See Also Send Feedback

The ParameterBaseCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( ParameterBase >)>).)
Owner | Gets the FunctionBase class to which parameters belong.

See Also

ParameterBaseCollection Class


Item Property

[image] [image]

SQL Schema Sync API Class reference
ParameterBaseCollection..::.Item Property
ParameterBaseCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( ParameterBase >)>).)
Item[([(String])]) | Gets ParameterBase by name.

See Also

ParameterBaseCollection Class
ParameterBaseCollection Members


Item Property (String)

[image]

SQL Schema Sync API Class reference
ParameterBaseCollection..::.Item Property (String)
ParameterBaseCollection Class See Also Send Feedback
Gets ParameterBase by name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ParameterBase this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As ParameterBase
Visual C++
public:
property ParameterBase^ default[String^ name] {
    ParameterBase^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

ParameterBaseCollection Class
Item Overload


Owner Property

[image]

SQL Schema Sync API Class reference
ParameterBaseCollection..::.Owner Property
ParameterBaseCollection Class See Also Send Feedback
Gets the FunctionBase class to which parameters belong.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public FunctionBase Owner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Owner As FunctionBase
Visual C++
public:
property FunctionBase^ Owner {
    FunctionBase^ get ();
}

See Also

ParameterBaseCollection Class


Parameterization Enumeration

[image]

SQL Schema Sync API Class reference
Parameterization Enumeration
See Also Send Feedback
Parameterization.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum Parameterization
Visual Basic (Declaration)
Public Enumeration Parameterization
Visual C++
public enum class Parameterization

Members

Member name | Description
Forced | Forced.
Simple | Simple.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


ParameterOrderRef Class

[image]

SQL Schema Sync API Class reference
ParameterOrderRef Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.ParameterOrderRef"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class ParameterOrderRef
Visual Basic (Declaration)
Public Class ParameterOrderRef
Visual C++
public ref class ParameterOrderRef

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.ParameterOrderRef

See Also

ParameterOrderRef Members


ParameterOrderRef Members

[image] [image]

SQL Schema Sync API Class reference
ParameterOrderRef Members
ParameterOrderRef Class Constructors Methods Properties See Also Send Feedback

The ParameterOrderRef type exposes the following members.

Constructors

Name | Description
ParameterOrderRef | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDescending |
Order |
Parameter |

See Also

ParameterOrderRef Class


ParameterOrderRef Constructor

[image] [image]

SQL Schema Sync API Class reference
ParameterOrderRef Constructor
ParameterOrderRef Class See Also Send Feedback

Overload List

Name | Description
ParameterOrderRef()()() | Initializes a new instance of the ParameterOrderRef class
ParameterOrderRef(ParameterBase, Int32) | Initializes a new instance of the ParameterOrderRef class
ParameterOrderRef(ParameterBase, Int32, Boolean) | Initializes a new instance of the ParameterOrderRef class

See Also

ParameterOrderRef Class
ParameterOrderRef Members


ParameterOrderRef Constructor

[image]

SQL Schema Sync API Class reference
ParameterOrderRef Constructor
ParameterOrderRef Class See Also Send Feedback
Initializes a new instance of the ParameterOrderRef class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ParameterOrderRef()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterOrderRef()

See Also

ParameterOrderRef Class
ParameterOrderRef Overload


ParameterOrderRef Constructor (ParameterBase, Int32)

[image]

SQL Schema Sync API Class reference
ParameterOrderRef Constructor (ParameterBase, Int32)
ParameterOrderRef Class See Also Send Feedback
Initializes a new instance of the ParameterOrderRef class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ParameterOrderRef(
    ParameterBase parameter,
    int order
)
Visual Basic (Declaration)
Public Sub New ( _
    parameter As ParameterBase, _
    order As Integer _
)
Visual C++
public:
ParameterOrderRef(
    ParameterBase^ parameter,
    int order
)

Parameters

parameter
Type: PerpetuumSoft.DataModel.MsSql..::.ParameterBase
order
Type: System..::.Int32

See Also

ParameterOrderRef Class
ParameterOrderRef Overload


ParameterOrderRef Constructor (ParameterBase, Int32, Boolean)

[image]

SQL Schema Sync API Class reference
ParameterOrderRef Constructor (ParameterBase, Int32, Boolean)
ParameterOrderRef Class See Also Send Feedback
Initializes a new instance of the ParameterOrderRef class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ParameterOrderRef(
    ParameterBase parameter,
    int order,
    bool isDescending
)
Visual Basic (Declaration)
Public Sub New ( _
    parameter As ParameterBase, _
    order As Integer, _
    isDescending As Boolean _
)
Visual C++
public:
ParameterOrderRef(
    ParameterBase^ parameter,
    int order,
    bool isDescending
)

Parameters

parameter
Type: PerpetuumSoft.DataModel.MsSql..::.ParameterBase
order
Type: System..::.Int32
isDescending
Type: System..::.Boolean

See Also

ParameterOrderRef Class
ParameterOrderRef Overload


ParameterOrderRef Methods

[image] [image]

SQL Schema Sync API Class reference
ParameterOrderRef Methods
ParameterOrderRef Class See Also Send Feedback

The ParameterOrderRef type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterOrderRef Class


ParameterOrderRef Properties

[image] [image]

SQL Schema Sync API Class reference
ParameterOrderRef Properties
ParameterOrderRef Class See Also Send Feedback

The ParameterOrderRef type exposes the following members.

Properties

Name | Description
IsDescending |
Order |
Parameter |

See Also

ParameterOrderRef Class


IsDescending Property

[image]

SQL Schema Sync API Class reference
ParameterOrderRef..::.IsDescending Property
ParameterOrderRef Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.ParameterOrderRef.IsDescending"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsDescending { get; set; }
Visual Basic (Declaration)
Public Property IsDescending As Boolean
Visual C++
public:
property bool IsDescending {
    bool get ();
    void set (bool value);
}

See Also

ParameterOrderRef Class


Order Property

[image]

SQL Schema Sync API Class reference
ParameterOrderRef..::.Order Property
ParameterOrderRef Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.ParameterOrderRef.Order"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int Order { get; set; }
Visual Basic (Declaration)
Public Property Order As Integer
Visual C++
public:
property int Order {
    int get ();
    void set (int value);
}

See Also

ParameterOrderRef Class


Parameter Property

[image]

SQL Schema Sync API Class reference
ParameterOrderRef..::.Parameter Property
ParameterOrderRef Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.ParameterOrderRef.Parameter"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ParameterBase Parameter { get; set; }
Visual Basic (Declaration)
Public Property Parameter As ParameterBase
Visual C++
public:
property ParameterBase^ Parameter {
    ParameterBase^ get ();
    void set (ParameterBase^ value);
}

See Also

ParameterOrderRef Class


Permission Class

[image]

SQL Schema Sync API Class reference
Permission Class
Members See Also Send Feedback
Represents permission in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Permission
Visual Basic (Declaration)
Public NotInheritable Class Permission
Visual C++
public ref class Permission sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Permission

See Also

Permission Members


Permission Members

[image] [image]

SQL Schema Sync API Class reference
Permission Members
Permission Class Constructors Methods Properties See Also Send Feedback

The Permission type exposes the following members.

Constructors

Name | Description
Permission | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PermissionList | Gets list of permissions on the object.
Securable | Gets or sets the secured object.

See Also

Permission Class


Permission Constructor

[image] [image]

SQL Schema Sync API Class reference
Permission Constructor
Permission Class See Also Send Feedback

Overload List

Name | Description
Permission()()() | Creates new instance of the Permission class.
Permission(ISecurable) | Creates new instance of the Permission class.

See Also

Permission Class
Permission Members


Permission Constructor

[image]

SQL Schema Sync API Class reference
Permission Constructor
Permission Class See Also Send Feedback
Creates new instance of the Permission class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Permission()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Permission()

See Also

Permission Class
Permission Overload


Permission Constructor (ISecurable)

[image]

SQL Schema Sync API Class reference
Permission Constructor (ISecurable)
Permission Class See Also Send Feedback
Creates new instance of the Permission class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Permission(
    ISecurable securable
)
Visual Basic (Declaration)
Public Sub New ( _
    securable As ISecurable _
)
Visual C++
public:
Permission(
    ISecurable^ securable
)

Parameters

securable
Type: PerpetuumSoft.DataModel.MsSql..::.ISecurable

See Also

Permission Class
Permission Overload


Permission Methods

[image] [image]

SQL Schema Sync API Class reference
Permission Methods
Permission Class See Also Send Feedback

The Permission type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Permission Class


Permission Properties

[image] [image]

SQL Schema Sync API Class reference
Permission Properties
Permission Class See Also Send Feedback

The Permission type exposes the following members.

Properties

Name | Description
PermissionList | Gets list of permissions on the object.
Securable | Gets or sets the secured object.

See Also

Permission Class


PermissionList Property

[image]

SQL Schema Sync API Class reference
Permission..::.PermissionList Property
Permission Class See Also Send Feedback
Gets list of permissions on the object.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public GrantCollection PermissionList { get; }
Visual Basic (Declaration)
Public ReadOnly Property PermissionList As GrantCollection
Visual C++
public:
property GrantCollection^ PermissionList {
    GrantCollection^ get ();
}

See Also

Permission Class


Securable Property

[image]

SQL Schema Sync API Class reference
Permission..::.Securable Property
Permission Class See Also Send Feedback
Gets or sets the secured object.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ISecurable Securable { get; set; }
Visual Basic (Declaration)
Public Property Securable As ISecurable
Visual C++
public:
property ISecurable^ Securable {
    ISecurable^ get ();
    void set (ISecurable^ value);
}

See Also

Permission Class


PermissionCollection Class

[image]

SQL Schema Sync API Class reference
PermissionCollection Class
Members See Also Send Feedback
Represents collection of permissions in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class PermissionCollection : Collection<Permission>
Visual Basic (Declaration)
Public NotInheritable Class PermissionCollection _
    Inherits Collection(Of Permission)
Visual C++
public ref class PermissionCollection sealed : public Collection<Permission^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( Permission >)>)
PerpetuumSoft.DataModel.MsSql..::.PermissionCollection

See Also

PermissionCollection Members


PermissionCollection Members

[image] [image]

SQL Schema Sync API Class reference
PermissionCollection Members
PermissionCollection Class Methods Properties See Also Send Feedback

The PermissionCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
AddPermission | Adds the securable object permission.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Permission >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Permission >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Permission >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
RevokePermission | Revokes permission on the securable object.
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Permission >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
Securables | Gets collection of securable objects.

See Also

PermissionCollection Class


PermissionCollection Methods

[image] [image]

SQL Schema Sync API Class reference
PermissionCollection Methods
PermissionCollection Class See Also Send Feedback

The PermissionCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
AddPermission | Adds the securable object permission.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( Permission >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Permission >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( Permission >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
RevokePermission | Revokes permission on the securable object.
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( Permission >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PermissionCollection Class


AddPermission Method

[image]

SQL Schema Sync API Class reference
PermissionCollection..::.AddPermission Method
PermissionCollection Class See Also Send Feedback
Adds the securable object permission.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void AddPermission(
    ISecurable securable,
    GrantAction grantAction,
    GrantMode grantMode
)
Visual Basic (Declaration)
Public Sub AddPermission ( _
    securable As ISecurable, _
    grantAction As GrantAction, _
    grantMode As GrantMode _
)
Visual C++
public:
void AddPermission(
    ISecurable^ securable,
    GrantAction grantAction,
    GrantMode grantMode
)

Parameters

securable
Type: PerpetuumSoft.DataModel.MsSql..::.ISecurable
grantAction
Type: PerpetuumSoft.DataModel.MsSql..::.GrantAction
grantMode
Type: PerpetuumSoft.DataModel.MsSql..::.GrantMode

See Also

PermissionCollection Class


Contains Method

[image] [image]

SQL Schema Sync API Class reference
PermissionCollection..::.Contains Method
PermissionCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
Contains(String) | Gets true value if the collection contains securable object.

See Also

PermissionCollection Class
PermissionCollection Members


Contains Method (String)

[image]

SQL Schema Sync API Class reference
PermissionCollection..::.Contains Method (String)
PermissionCollection Class See Also Send Feedback
Gets true value if the collection contains securable object.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Contains(
    string securableFullName
)
Visual Basic (Declaration)
Public Function Contains ( _
    securableFullName As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ securableFullName
)

Parameters

securableFullName
Type: System..::.String

See Also

PermissionCollection Class
Contains Overload


RevokePermission Method

[image]

SQL Schema Sync API Class reference
PermissionCollection..::.RevokePermission Method
PermissionCollection Class See Also Send Feedback
Revokes permission on the securable object.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void RevokePermission(
    ISecurable securable,
    GrantAction permissionType
)
Visual Basic (Declaration)
Public Sub RevokePermission ( _
    securable As ISecurable, _
    permissionType As GrantAction _
)
Visual C++
public:
void RevokePermission(
    ISecurable^ securable,
    GrantAction permissionType
)

Parameters

securable
Type: PerpetuumSoft.DataModel.MsSql..::.ISecurable
permissionType
Type: PerpetuumSoft.DataModel.MsSql..::.GrantAction

See Also

PermissionCollection Class


PermissionCollection Properties

[image] [image]

SQL Schema Sync API Class reference
PermissionCollection Properties
PermissionCollection Class See Also Send Feedback

The PermissionCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( Permission >)>).)
Securables | Gets collection of securable objects.

See Also

PermissionCollection Class


Item Property

[image] [image]

SQL Schema Sync API Class reference
PermissionCollection..::.Item Property
PermissionCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( Permission >)>).)
Item[([(String])]) | Gets collection of permissions on the specified object.

See Also

PermissionCollection Class
PermissionCollection Members


Item Property (String)

[image]

SQL Schema Sync API Class reference
PermissionCollection..::.Item Property (String)
PermissionCollection Class See Also Send Feedback
Gets collection of permissions on the specified object.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public GrantCollection this[
    string securableFullName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    securableFullName As String _
) As GrantCollection
Visual C++
public:
property GrantCollection^ default[String^ securableFullName] {
    GrantCollection^ get (String^ securableFullName);
}

Parameters

securableFullName
Type: System..::.String

See Also

PermissionCollection Class
Item Overload


Securables Property

[image]

SQL Schema Sync API Class reference
PermissionCollection..::.Securables Property
PermissionCollection Class See Also Send Feedback
Gets collection of securable objects.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IEnumerable<ISecurable> Securables { get; }
Visual Basic (Declaration)
Public ReadOnly Property Securables As IEnumerable(Of ISecurable)
Visual C++
public:
property IEnumerable<ISecurable^>^ Securables {
    IEnumerable<ISecurable^>^ get ();
}

See Also

PermissionCollection Class


PermissionSet Enumeration

[image]

SQL Schema Sync API Class reference
PermissionSet Enumeration
See Also Send Feedback
Represents set of assembly permissions in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum PermissionSet
Visual Basic (Declaration)
Public Enumeration PermissionSet
Visual C++
public enum class PermissionSet

Members

Member name | Description
Safe | Safe.
ExternalAccess | External access.
Unsafe | Unsafe.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


PrimaryKey Class

[image]

SQL Schema Sync API Class reference
PrimaryKey Class
Members See Also Send Feedback
Represents a primary key in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class PrimaryKey : KeyConstraint
Visual Basic (Declaration)
Public NotInheritable Class PrimaryKey _
    Inherits KeyConstraint
Visual C++
public ref class PrimaryKey sealed : public KeyConstraint

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Constraint
PerpetuumSoft.DataModel.MsSql..::.KeyConstraint
PerpetuumSoft.DataModel.MsSql..::.PrimaryKey

See Also

PrimaryKey Members


PrimaryKey Members

[image] [image]

SQL Schema Sync API Class reference
PrimaryKey Members
PrimaryKey Class Constructors Methods Properties See Also Send Feedback

The PrimaryKey type exposes the following members.

Constructors

Name | Description
PrimaryKey | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
AllowPageLocks | Gets or sets the ALLOWPAGEROCK option. (Inherited from KeyConstraint.)
AllowRowLocks | Gets or sets the ALLOWROWLOCK option. (Inherited from KeyConstraint.)
Clustered | Gets or sets if a key index is clustered. (Inherited from KeyConstraint.)
Columns | Gets columns associated with the constraint. (Inherited from KeyConstraint.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FillFactor | Gets or sets a fill factor value. (Inherited from KeyConstraint.)
FullName | Gets the element full name. (Inherited from Element.)
IgnoreDupKey | Gets or sets if the key index should ignore the duplicated keys. (Inherited from KeyConstraint.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
PadIndex | Gets or sets a pad index value. (Inherited from KeyConstraint.)
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
StatisticNoRecompute | Gets or sets the StatisticNoRecompute option. (Inherited from KeyConstraint.)
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)

See Also

PrimaryKey Class


PrimaryKey Constructor

[image] [image]

SQL Schema Sync API Class reference
PrimaryKey Constructor
PrimaryKey Class See Also Send Feedback

Overload List

Name | Description
PrimaryKey()()() | Initializes a new instance of the PrimaryKey class.
PrimaryKey(String, Table) | Creates new instance of the PrimaryKey class.

See Also

PrimaryKey Class
PrimaryKey Members


PrimaryKey Constructor

[image]

SQL Schema Sync API Class reference
PrimaryKey Constructor
PrimaryKey Class See Also Send Feedback
Initializes a new instance of the PrimaryKey class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public PrimaryKey()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrimaryKey()

See Also

PrimaryKey Class
PrimaryKey Overload


PrimaryKey Constructor (String, Table)

[image]

SQL Schema Sync API Class reference
PrimaryKey Constructor (String, Table)
PrimaryKey Class See Also Send Feedback
Creates new instance of the PrimaryKey class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public PrimaryKey(
    string name,
    Table table
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    table As Table _
)
Visual C++
public:
PrimaryKey(
    String^ name,
    Table^ table
)

Parameters

name
Type: System..::.String
table
Type: PerpetuumSoft.DataModel.MsSql..::.Table

See Also

PrimaryKey Class
PrimaryKey Overload


PrimaryKey Methods

[image] [image]

SQL Schema Sync API Class reference
PrimaryKey Methods
PrimaryKey Class See Also Send Feedback

The PrimaryKey type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

PrimaryKey Class


PrimaryKey Properties

[image] [image]

SQL Schema Sync API Class reference
PrimaryKey Properties
PrimaryKey Class See Also Send Feedback

The PrimaryKey type exposes the following members.

Properties

Name | Description
AllowPageLocks | Gets or sets the ALLOWPAGEROCK option. (Inherited from KeyConstraint.)
AllowRowLocks | Gets or sets the ALLOWROWLOCK option. (Inherited from KeyConstraint.)
Clustered | Gets or sets if a key index is clustered. (Inherited from KeyConstraint.)
Columns | Gets columns associated with the constraint. (Inherited from KeyConstraint.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FillFactor | Gets or sets a fill factor value. (Inherited from KeyConstraint.)
FullName | Gets the element full name. (Inherited from Element.)
IgnoreDupKey | Gets or sets if the key index should ignore the duplicated keys. (Inherited from KeyConstraint.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
PadIndex | Gets or sets a pad index value. (Inherited from KeyConstraint.)
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
StatisticNoRecompute | Gets or sets the StatisticNoRecompute option. (Inherited from KeyConstraint.)
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)

See Also

PrimaryKey Class


Principal Class

[image]

SQL Schema Sync API Class reference
Principal Class
Members See Also Send Feedback
Represents principal in the database structure. Base class for users and roles.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class Principal : DatabaseObject,
    ISecurable
Visual Basic (Declaration)
Public MustInherit Class Principal _
    Inherits DatabaseObject _
    Implements ISecurable
Visual C++
public ref class Principal abstract : public DatabaseObject,
    ISecurable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Principal
PerpetuumSoft.DataModel.MsSql..::.Role
PerpetuumSoft.DataModel.MsSql..::.User

See Also

Principal Members


Principal Members

[image] [image]

SQL Schema Sync API Class reference
Principal Members
Principal Class Methods Properties See Also Send Feedback

The Principal type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualsTo | Gets true value if principals are equal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Permissions | Gets permissions on all securable objects for this Principal.

See Also

Principal Class


Principal Methods

[image] [image]

SQL Schema Sync API Class reference
Principal Methods
Principal Class See Also Send Feedback

The Principal type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualsTo | Gets true value if principals are equal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Principal Class


IsEqualsTo Method

[image]

SQL Schema Sync API Class reference
Principal..::.IsEqualsTo Method
Principal Class See Also Send Feedback
Gets true value if principals are equal.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool IsEqualsTo(
    Principal principal
)
Visual Basic (Declaration)
Public Overridable Function IsEqualsTo ( _
    principal As Principal _
) As Boolean
Visual C++
public:
virtual bool IsEqualsTo(
    Principal^ principal
)

Parameters

principal
Type: PerpetuumSoft.DataModel.MsSql..::.Principal

See Also

Principal Class


Principal Properties

[image] [image]

SQL Schema Sync API Class reference
Principal Properties
Principal Class See Also Send Feedback

The Principal type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Permissions | Gets permissions on all securable objects for this Principal.

See Also

Principal Class


Permissions Property

[image]

SQL Schema Sync API Class reference
Principal..::.Permissions Property
Principal Class See Also Send Feedback
Gets permissions on all securable objects for this Principal.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public PermissionCollection Permissions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Permissions As PermissionCollection
Visual C++
public:
property PermissionCollection^ Permissions {
    PermissionCollection^ get ();
}

See Also

Principal Class


Role Class

[image]

SQL Schema Sync API Class reference
Role Class
Members See Also Send Feedback
Represents role in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Role : Principal
Visual Basic (Declaration)
Public NotInheritable Class Role _
    Inherits Principal
Visual C++
public ref class Role sealed : public Principal

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Principal
PerpetuumSoft.DataModel.MsSql..::.Role

See Also

Role Members


Role Members

[image] [image]

SQL Schema Sync API Class reference
Role Members
Role Class Constructors Methods Properties See Also Send Feedback

The Role type exposes the following members.

Constructors

Name | Description
Role | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualsTo | Override. See IsEqualsTo(Principal). (Overrides Principal..::.IsEqualsTo(Principal).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets the role extended properties.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Members | Gets collection of the role members.
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets Principal which is the owner of this role.
Permissions | Gets permissions on all securable objects for this Principal. (Inherited from Principal.)
RoleType | Gets or sets RoleType which is this role type.

See Also

Role Class


Role Constructor

[image] [image]

SQL Schema Sync API Class reference
Role Constructor
Role Class See Also Send Feedback

Overload List

Name | Description
Role()()() | Creates new instance of the Role class.
Role(String) | Creates new instance of the Role class.
Role(String, Principal) | Creates new instance of the Role class.

See Also

Role Class
Role Members


Role Constructor

[image]

SQL Schema Sync API Class reference
Role Constructor
Role Class See Also Send Feedback
Creates new instance of the Role class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Role()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Role()

See Also

Role Class
Role Overload


Role Constructor (String)

[image]

SQL Schema Sync API Class reference
Role Constructor (String)
Role Class See Also Send Feedback
Creates new instance of the Role class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Role(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
Role(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Role Class
Role Overload


Role Constructor (String, Principal)

[image]

SQL Schema Sync API Class reference
Role Constructor (String, Principal)
Role Class See Also Send Feedback
Creates new instance of the Role class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Role(
    string name,
    Principal owner
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    owner As Principal _
)
Visual C++
public:
Role(
    String^ name,
    Principal^ owner
)

Parameters

name
Type: System..::.String
owner
Type: PerpetuumSoft.DataModel.MsSql..::.Principal

See Also

Role Class
Role Overload


Role Methods

[image] [image]

SQL Schema Sync API Class reference
Role Methods
Role Class See Also Send Feedback

The Role type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualsTo | Override. See IsEqualsTo(Principal). (Overrides Principal..::.IsEqualsTo(Principal).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Role Class


IsEqualsTo Method

[image]

SQL Schema Sync API Class reference
Role..::.IsEqualsTo Method
Role Class See Also Send Feedback
Override. See IsEqualsTo(Principal).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool IsEqualsTo(
    Principal principal
)
Visual Basic (Declaration)
Public Overrides Function IsEqualsTo ( _
    principal As Principal _
) As Boolean
Visual C++
public:
virtual bool IsEqualsTo(
    Principal^ principal
) override

Parameters

principal
Type: PerpetuumSoft.DataModel.MsSql..::.Principal

See Also

Role Class


Role Properties

[image] [image]

SQL Schema Sync API Class reference
Role Properties
Role Class See Also Send Feedback

The Role type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets the role extended properties.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Members | Gets collection of the role members.
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets Principal which is the owner of this role.
Permissions | Gets permissions on all securable objects for this Principal. (Inherited from Principal.)
RoleType | Gets or sets RoleType which is this role type.

See Also

Role Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
Role..::.ExtendedProperties Property
Role Class See Also Send Feedback
Implements ExtendedProperties()()(). Gets the role extended properties.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

Role Class


Members Property

[image]

SQL Schema Sync API Class reference
Role..::.Members Property
Role Class See Also Send Feedback
Gets collection of the role members.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public RoleMemberCollection Members { get; }
Visual Basic (Declaration)
Public ReadOnly Property Members As RoleMemberCollection
Visual C++
public:
property RoleMemberCollection^ Members {
    RoleMemberCollection^ get ();
}

See Also

Role Class


Owner Property

[image]

SQL Schema Sync API Class reference
Role..::.Owner Property
Role Class See Also Send Feedback
Gets or sets Principal which is the owner of this role.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Principal Owner { get; set; }
Visual Basic (Declaration)
Public Property Owner As Principal
Visual C++
public:
property Principal^ Owner {
    Principal^ get ();
    void set (Principal^ value);
}

See Also

Role Class


RoleType Property

[image]

SQL Schema Sync API Class reference
Role..::.RoleType Property
Role Class See Also Send Feedback
Gets or sets RoleType which is this role type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public RoleType RoleType { get; set; }
Visual Basic (Declaration)
Public Property RoleType As RoleType
Visual C++
public:
property RoleType RoleType {
    RoleType get ();
    void set (RoleType value);
}

See Also

Role Class


RoleMember Class

[image]

SQL Schema Sync API Class reference
RoleMember Class
Members See Also Send Feedback
Represents role member in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class RoleMember
Visual Basic (Declaration)
Public NotInheritable Class RoleMember
Visual C++
public ref class RoleMember sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.RoleMember

See Also

RoleMember Members


RoleMember Members

[image] [image]

SQL Schema Sync API Class reference
RoleMember Members
RoleMember Class Constructors Methods Properties See Also Send Feedback

The RoleMember type exposes the following members.

Constructors

Name | Description
RoleMember | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Member | Gets or sets role member.

See Also

RoleMember Class


RoleMember Constructor

[image] [image]

SQL Schema Sync API Class reference
RoleMember Constructor
RoleMember Class See Also Send Feedback

Overload List

Name | Description
RoleMember()()() | Creates new instance of the RoleMember class.
RoleMember(Principal) | Creates new instance of the RoleMember class.

See Also

RoleMember Class
RoleMember Members


RoleMember Constructor

[image]

SQL Schema Sync API Class reference
RoleMember Constructor
RoleMember Class See Also Send Feedback
Creates new instance of the RoleMember class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public RoleMember()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoleMember()

See Also

RoleMember Class
RoleMember Overload


RoleMember Constructor (Principal)

[image]

SQL Schema Sync API Class reference
RoleMember Constructor (Principal)
RoleMember Class See Also Send Feedback
Creates new instance of the RoleMember class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public RoleMember(
    Principal member
)
Visual Basic (Declaration)
Public Sub New ( _
    member As Principal _
)
Visual C++
public:
RoleMember(
    Principal^ member
)

Parameters

member
Type: PerpetuumSoft.DataModel.MsSql..::.Principal

See Also

RoleMember Class
RoleMember Overload


RoleMember Methods

[image] [image]

SQL Schema Sync API Class reference
RoleMember Methods
RoleMember Class See Also Send Feedback

The RoleMember type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleMember Class


RoleMember Properties

[image] [image]

SQL Schema Sync API Class reference
RoleMember Properties
RoleMember Class See Also Send Feedback

The RoleMember type exposes the following members.

Properties

Name | Description
Member | Gets or sets role member.

See Also

RoleMember Class


Member Property

[image]

SQL Schema Sync API Class reference
RoleMember..::.Member Property
RoleMember Class See Also Send Feedback
Gets or sets role member.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Principal Member { get; set; }
Visual Basic (Declaration)
Public Property Member As Principal
Visual C++
public:
property Principal^ Member {
    Principal^ get ();
    void set (Principal^ value);
}

See Also

RoleMember Class


RoleMemberCollection Class

[image]

SQL Schema Sync API Class reference
RoleMemberCollection Class
Members See Also Send Feedback
Represents collection of the role members.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class RoleMemberCollection : Collection<RoleMember>
Visual Basic (Declaration)
Public NotInheritable Class RoleMemberCollection _
    Inherits Collection(Of RoleMember)
Visual C++
public ref class RoleMemberCollection sealed : public Collection<RoleMember^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( RoleMember >)>)
PerpetuumSoft.DataModel.MsSql..::.RoleMemberCollection

See Also

RoleMemberCollection Members


RoleMemberCollection Members

[image] [image]

SQL Schema Sync API Class reference
RoleMemberCollection Members
RoleMemberCollection Class Methods Properties See Also Send Feedback

The RoleMemberCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( RoleMember >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( RoleMember >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( RoleMember >)>).)
IsEqualsTo | Gets true value if the role members collections are equal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( RoleMember >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)

See Also

RoleMemberCollection Class


RoleMemberCollection Methods

[image] [image]

SQL Schema Sync API Class reference
RoleMemberCollection Methods
RoleMemberCollection Class See Also Send Feedback

The RoleMemberCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( RoleMember >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( RoleMember >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( RoleMember >)>).)
IsEqualsTo | Gets true value if the role members collections are equal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( RoleMember >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleMemberCollection Class


IsEqualsTo Method

[image]

SQL Schema Sync API Class reference
RoleMemberCollection..::.IsEqualsTo Method
RoleMemberCollection Class See Also Send Feedback
Gets true value if the role members collections are equal.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEqualsTo(
    RoleMemberCollection collection
)
Visual Basic (Declaration)
Public Function IsEqualsTo ( _
    collection As RoleMemberCollection _
) As Boolean
Visual C++
public:
bool IsEqualsTo(
    RoleMemberCollection^ collection
)

Parameters

collection
Type: PerpetuumSoft.DataModel.MsSql..::.RoleMemberCollection

See Also

RoleMemberCollection Class


RoleMemberCollection Properties

[image] [image]

SQL Schema Sync API Class reference
RoleMemberCollection Properties
RoleMemberCollection Class See Also Send Feedback

The RoleMemberCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RoleMember >)>).)

See Also

RoleMemberCollection Class


Item Property

[image] [image]

SQL Schema Sync API Class reference
RoleMemberCollection..::.Item Property
RoleMemberCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( RoleMember >)>).)
Item[([(String])]) | Возвращает члена роли по имени. Gets the role member by name.

See Also

RoleMemberCollection Class
RoleMemberCollection Members


Item Property (String)

[image]

SQL Schema Sync API Class reference
RoleMemberCollection..::.Item Property (String)
RoleMemberCollection Class See Also Send Feedback
Возвращает члена роли по имени. Gets the role member by name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public RoleMember this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As RoleMember
Visual C++
public:
property RoleMember^ default[String^ name] {
    RoleMember^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

RoleMemberCollection Class
Item Overload


RoleType Enumeration

[image]

SQL Schema Sync API Class reference
RoleType Enumeration
See Also Send Feedback
Represents role type in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum RoleType
Visual Basic (Declaration)
Public Enumeration RoleType
Visual C++
public enum class RoleType

Members

Member name | Description
DatabaseRole | Database role.
ApplicationRole | Application role.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


Rule Class

[image]

SQL Schema Sync API Class reference
Rule Class
Members See Also Send Feedback
Represents rule in database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Rule : SchemaObject
Visual Basic (Declaration)
Public NotInheritable Class Rule _
    Inherits SchemaObject
Visual C++
public ref class Rule sealed : public SchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.Rule

See Also

Rule Members


Rule Members

[image] [image]

SQL Schema Sync API Class reference
Rule Members
Rule Class Constructors Methods Properties See Also Send Feedback

The Rule type exposes the following members.

Constructors

Name | Description
Rule | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
RuleObjects | Collection of objects the rule is set for.
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets rule text.

See Also

Rule Class


Rule Constructor

[image] [image]

SQL Schema Sync API Class reference
Rule Constructor
Rule Class See Also Send Feedback

Overload List

Name | Description
Rule()()() | Creates new instance of the Rule class.
Rule(String) | Creates new instance of the Rule class.

See Also

Rule Class
Rule Members


Rule Constructor

[image]

SQL Schema Sync API Class reference
Rule Constructor
Rule Class See Also Send Feedback
Creates new instance of the Rule class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Rule()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Rule()

See Also

Rule Class
Rule Overload


Rule Constructor (String)

[image]

SQL Schema Sync API Class reference
Rule Constructor (String)
Rule Class See Also Send Feedback
Creates new instance of the Rule class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Rule(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
Rule(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Rule Class
Rule Overload


Rule Methods

[image] [image]

SQL Schema Sync API Class reference
Rule Methods
Rule Class See Also Send Feedback

The Rule type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Rule Class


Rule Properties

[image] [image]

SQL Schema Sync API Class reference
Rule Properties
Rule Class See Also Send Feedback

The Rule type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
RuleObjects | Collection of objects the rule is set for.
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets rule text.

See Also

Rule Class


RuleObjects Property

[image]

SQL Schema Sync API Class reference
Rule..::.RuleObjects Property
Rule Class See Also Send Feedback
Collection of objects the rule is set for.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public RuleDefaultObjectCollection RuleObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property RuleObjects As RuleDefaultObjectCollection
Visual C++
public:
property RuleDefaultObjectCollection^ RuleObjects {
    RuleDefaultObjectCollection^ get ();
}

See Also

Rule Class


Text Property

[image]

SQL Schema Sync API Class reference
Rule..::.Text Property
Rule Class See Also Send Feedback
Gets or sets rule text.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Rule Class


RuleDefaultObject Class

[image]

SQL Schema Sync API Class reference
RuleDefaultObject Class
Members See Also Send Feedback
Represents object containing reference to ISupportRulesDefaults

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class RuleDefaultObject
Visual Basic (Declaration)
Public Class RuleDefaultObject
Visual C++
public ref class RuleDefaultObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.RuleDefaultObject

See Also

RuleDefaultObject Members


RuleDefaultObject Members

[image] [image]

SQL Schema Sync API Class reference
RuleDefaultObject Members
RuleDefaultObject Class Constructors Methods Properties See Also Send Feedback

The RuleDefaultObject type exposes the following members.

Constructors

Name | Description
RuleDefaultObject | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Obj | Reference to ISupportRulesDefaults.

See Also

RuleDefaultObject Class


RuleDefaultObject Constructor

[image] [image]

SQL Schema Sync API Class reference
RuleDefaultObject Constructor
RuleDefaultObject Class See Also Send Feedback

Overload List

Name | Description
RuleDefaultObject()()() | Creates new instance of the RuleDefaultObject class.
RuleDefaultObject(ISupportRulesDefaults) | Creates new instance of the RuleDefaultObject class.

See Also

RuleDefaultObject Class
RuleDefaultObject Members


RuleDefaultObject Constructor

[image]

SQL Schema Sync API Class reference
RuleDefaultObject Constructor
RuleDefaultObject Class See Also Send Feedback
Creates new instance of the RuleDefaultObject class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public RuleDefaultObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RuleDefaultObject()

See Also

RuleDefaultObject Class
RuleDefaultObject Overload


RuleDefaultObject Constructor (ISupportRulesDefaults)

[image]

SQL Schema Sync API Class reference
RuleDefaultObject Constructor (ISupportRulesDefaults)
RuleDefaultObject Class See Also Send Feedback
Creates new instance of the RuleDefaultObject class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public RuleDefaultObject(
    ISupportRulesDefaults obj
)
Visual Basic (Declaration)
Public Sub New ( _
    obj As ISupportRulesDefaults _
)
Visual C++
public:
RuleDefaultObject(
    ISupportRulesDefaults^ obj
)

Parameters

obj
Type: PerpetuumSoft.DataModel.MsSql..::.ISupportRulesDefaults

See Also

RuleDefaultObject Class
RuleDefaultObject Overload


RuleDefaultObject Methods

[image] [image]

SQL Schema Sync API Class reference
RuleDefaultObject Methods
RuleDefaultObject Class See Also Send Feedback

The RuleDefaultObject type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RuleDefaultObject Class


RuleDefaultObject Properties

[image] [image]

SQL Schema Sync API Class reference
RuleDefaultObject Properties
RuleDefaultObject Class See Also Send Feedback

The RuleDefaultObject type exposes the following members.

Properties

Name | Description
Obj | Reference to ISupportRulesDefaults.

See Also

RuleDefaultObject Class


Obj Property

[image]

SQL Schema Sync API Class reference
RuleDefaultObject..::.Obj Property
RuleDefaultObject Class See Also Send Feedback
Reference to ISupportRulesDefaults.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ISupportRulesDefaults Obj { get; set; }
Visual Basic (Declaration)
Public Property Obj As ISupportRulesDefaults
Visual C++
public:
property ISupportRulesDefaults^ Obj {
    ISupportRulesDefaults^ get ();
    void set (ISupportRulesDefaults^ value);
}

See Also

RuleDefaultObject Class


RuleDefaultObjectCollection Class

[image]

SQL Schema Sync API Class reference
RuleDefaultObjectCollection Class
Members See Also Send Feedback
Represents collection of objects of the RuleDefaultObject type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class RuleDefaultObjectCollection : Collection<RuleDefaultObject>
Visual Basic (Declaration)
Public NotInheritable Class RuleDefaultObjectCollection _
    Inherits Collection(Of RuleDefaultObject)
Visual C++
public ref class RuleDefaultObjectCollection sealed : public Collection<RuleDefaultObject^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <( RuleDefaultObject >)>)
PerpetuumSoft.DataModel.MsSql..::.RuleDefaultObjectCollection

See Also

RuleDefaultObjectCollection Members


RuleDefaultObjectCollection Members

[image] [image]

SQL Schema Sync API Class reference
RuleDefaultObjectCollection Members
RuleDefaultObjectCollection Class Methods Properties See Also Send Feedback

The RuleDefaultObjectCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
IsEqualsTo | Gets true value if two collections are equal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)

See Also

RuleDefaultObjectCollection Class


RuleDefaultObjectCollection Methods

[image] [image]

SQL Schema Sync API Class reference
RuleDefaultObjectCollection Methods
RuleDefaultObjectCollection Class See Also Send Feedback

The RuleDefaultObjectCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
IsEqualsTo | Gets true value if two collections are equal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RuleDefaultObjectCollection Class


IsEqualsTo Method

[image]

SQL Schema Sync API Class reference
RuleDefaultObjectCollection..::.IsEqualsTo Method
RuleDefaultObjectCollection Class See Also Send Feedback
Gets true value if two collections are equal.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEqualsTo(
    RuleDefaultObjectCollection collection
)
Visual Basic (Declaration)
Public Function IsEqualsTo ( _
    collection As RuleDefaultObjectCollection _
) As Boolean
Visual C++
public:
bool IsEqualsTo(
    RuleDefaultObjectCollection^ collection
)

Parameters

collection
Type: PerpetuumSoft.DataModel.MsSql..::.RuleDefaultObjectCollection

See Also

RuleDefaultObjectCollection Class


RuleDefaultObjectCollection Properties

[image] [image]

SQL Schema Sync API Class reference
RuleDefaultObjectCollection Properties
RuleDefaultObjectCollection Class See Also Send Feedback

The RuleDefaultObjectCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( RuleDefaultObject >)>).)

See Also

RuleDefaultObjectCollection Class


Item Property

[image] [image]

SQL Schema Sync API Class reference
RuleDefaultObjectCollection..::.Item Property
RuleDefaultObjectCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( RuleDefaultObject >)>).)
Item[([(String])]) | Gets collection element by its name.

See Also

RuleDefaultObjectCollection Class
RuleDefaultObjectCollection Members


Item Property (String)

[image]

SQL Schema Sync API Class reference
RuleDefaultObjectCollection..::.Item Property (String)
RuleDefaultObjectCollection Class See Also Send Feedback
Gets collection element by its name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public RuleDefaultObject this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As RuleDefaultObject
Visual C++
public:
property RuleDefaultObject^ default[String^ name] {
    RuleDefaultObject^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

RuleDefaultObjectCollection Class
Item Overload


ScalarCLRFunction Class

[image]

SQL Schema Sync API Class reference
ScalarCLRFunction Class
Members See Also Send Feedback
Represents scalar CLR functions in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ScalarCLRFunction : CLRFunctionBase
Visual Basic (Declaration)
Public NotInheritable Class ScalarCLRFunction _
    Inherits CLRFunctionBase
Visual C++
public ref class ScalarCLRFunction sealed : public CLRFunctionBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.CLRFunctionBase
PerpetuumSoft.DataModel.MsSql..::.ScalarCLRFunction

See Also

ScalarCLRFunction Members


ScalarCLRFunction Members

[image] [image]

SQL Schema Sync API Class reference
ScalarCLRFunction Members
ScalarCLRFunction Class Constructors Methods Properties See Also Send Feedback

The ScalarCLRFunction type exposes the following members.

Constructors

Name | Description
ScalarCLRFunction | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Assembly | Gets or sets Assembly which contains this function. (Inherited from CLRFunctionBase.)
ClassName | Gets or sets name of the class which contains this function. (Inherited from CLRFunctionBase.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MethodName | Gets or sets name of the method which defines this method in the assembly. (Inherited from CLRFunctionBase.)
Name | Gets or sets an element name. (Inherited from Element.)
NullInputOption | Gets or sets execution options for a function subject to the input values.
Parameters | Gets function parameters. (Inherited from FunctionBase.)
ReturnValueType | Gets or sets the returned value type.
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

ScalarCLRFunction Class


ScalarCLRFunction Constructor

[image] [image]

SQL Schema Sync API Class reference
ScalarCLRFunction Constructor
ScalarCLRFunction Class See Also Send Feedback

Overload List

Name | Description
ScalarCLRFunction()()() | Creates new instance of the ScalarCLRFunction class.
ScalarCLRFunction(String, Schema) | Creates new instance of the ScalarCLRFunction class.

See Also

ScalarCLRFunction Class
ScalarCLRFunction Members


ScalarCLRFunction Constructor

[image]

SQL Schema Sync API Class reference
ScalarCLRFunction Constructor
ScalarCLRFunction Class See Also Send Feedback
Creates new instance of the ScalarCLRFunction class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ScalarCLRFunction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScalarCLRFunction()

See Also

ScalarCLRFunction Class
ScalarCLRFunction Overload


ScalarCLRFunction Constructor (String, Schema)

[image]

SQL Schema Sync API Class reference
ScalarCLRFunction Constructor (String, Schema)
ScalarCLRFunction Class See Also Send Feedback
Creates new instance of the ScalarCLRFunction class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ScalarCLRFunction(
    string name,
    Schema schema
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    schema As Schema _
)
Visual C++
public:
ScalarCLRFunction(
    String^ name,
    Schema^ schema
)

Parameters

name
Type: System..::.String
schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema

See Also

ScalarCLRFunction Class
ScalarCLRFunction Overload


ScalarCLRFunction Methods

[image] [image]

SQL Schema Sync API Class reference
ScalarCLRFunction Methods
ScalarCLRFunction Class See Also Send Feedback

The ScalarCLRFunction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

ScalarCLRFunction Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
ScalarCLRFunction..::.SetExecuteAsClause Method
ScalarCLRFunction Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context. (Inherited from FunctionBase.)
SetExecuteAsClause(String) | Sets the function security context. (Inherited from FunctionBase.)

See Also

ScalarCLRFunction Class
ScalarCLRFunction Members


ScalarCLRFunction Properties

[image] [image]

SQL Schema Sync API Class reference
ScalarCLRFunction Properties
ScalarCLRFunction Class See Also Send Feedback

The ScalarCLRFunction type exposes the following members.

Properties

Name | Description
Assembly | Gets or sets Assembly which contains this function. (Inherited from CLRFunctionBase.)
ClassName | Gets or sets name of the class which contains this function. (Inherited from CLRFunctionBase.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MethodName | Gets or sets name of the method which defines this method in the assembly. (Inherited from CLRFunctionBase.)
Name | Gets or sets an element name. (Inherited from Element.)
NullInputOption | Gets or sets execution options for a function subject to the input values.
Parameters | Gets function parameters. (Inherited from FunctionBase.)
ReturnValueType | Gets or sets the returned value type.
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

ScalarCLRFunction Class


NullInputOption Property

[image]

SQL Schema Sync API Class reference
ScalarCLRFunction..::.NullInputOption Property
ScalarCLRFunction Class See Also Send Feedback
Gets or sets execution options for a function subject to the input values.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public NullInputOption NullInputOption { get; set; }
Visual Basic (Declaration)
Public Property NullInputOption As NullInputOption
Visual C++
public:
property NullInputOption NullInputOption {
    NullInputOption get ();
    void set (NullInputOption value);
}

See Also

ScalarCLRFunction Class


ReturnValueType Property

[image]

SQL Schema Sync API Class reference
ScalarCLRFunction..::.ReturnValueType Property
ScalarCLRFunction Class See Also Send Feedback
Gets or sets the returned value type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DataType ReturnValueType { get; set; }
Visual Basic (Declaration)
Public Property ReturnValueType As DataType
Visual C++
public:
property DataType^ ReturnValueType {
    DataType^ get ();
    void set (DataType^ value);
}

See Also

ScalarCLRFunction Class


ScalarFunction Class

[image]

SQL Schema Sync API Class reference
ScalarFunction Class
Members See Also Send Feedback
Represents scalar function in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ScalarFunction : TextFunction
Visual Basic (Declaration)
Public NotInheritable Class ScalarFunction _
    Inherits TextFunction
Visual C++
public ref class ScalarFunction sealed : public TextFunction

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.TextFunction
PerpetuumSoft.DataModel.MsSql..::.ScalarFunction

See Also

ScalarFunction Members


ScalarFunction Members

[image] [image]

SQL Schema Sync API Class reference
ScalarFunction Members
ScalarFunction Class Constructors Methods Properties See Also Send Feedback

The ScalarFunction type exposes the following members.

Constructors

Name | Description
ScalarFunction | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
NullInputOption | Gets or sets execution options for a function subject to the input values.
Parameters | Gets function parameters. (Inherited from FunctionBase.)
ReturnValueType | Gets or sets the returned value type.
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure. (Inherited from TextFunction.)

See Also

ScalarFunction Class


ScalarFunction Constructor

[image] [image]

SQL Schema Sync API Class reference
ScalarFunction Constructor
ScalarFunction Class See Also Send Feedback

Overload List

Name | Description
ScalarFunction()()() | Creates new instance of the ScalarFunction.
ScalarFunction(String, String) | Creates new instance of theScalarFunction class.

See Also

ScalarFunction Class
ScalarFunction Members


ScalarFunction Constructor

[image]

SQL Schema Sync API Class reference
ScalarFunction Constructor
ScalarFunction Class See Also Send Feedback
Creates new instance of the ScalarFunction.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ScalarFunction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScalarFunction()

See Also

ScalarFunction Class
ScalarFunction Overload


ScalarFunction Constructor (String, String)

[image]

SQL Schema Sync API Class reference
ScalarFunction Constructor (String, String)
ScalarFunction Class See Also Send Feedback
Creates new instance of theScalarFunction class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ScalarFunction(
    string name,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
ScalarFunction(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
text
Type: System..::.String

See Also

ScalarFunction Class
ScalarFunction Overload


ScalarFunction Methods

[image] [image]

SQL Schema Sync API Class reference
ScalarFunction Methods
ScalarFunction Class See Also Send Feedback

The ScalarFunction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

ScalarFunction Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
ScalarFunction..::.SetExecuteAsClause Method
ScalarFunction Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context. (Inherited from FunctionBase.)
SetExecuteAsClause(String) | Sets the function security context. (Inherited from FunctionBase.)

See Also

ScalarFunction Class
ScalarFunction Members


ScalarFunction Properties

[image] [image]

SQL Schema Sync API Class reference
ScalarFunction Properties
ScalarFunction Class See Also Send Feedback

The ScalarFunction type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
NullInputOption | Gets or sets execution options for a function subject to the input values.
Parameters | Gets function parameters. (Inherited from FunctionBase.)
ReturnValueType | Gets or sets the returned value type.
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure. (Inherited from TextFunction.)

See Also

ScalarFunction Class


NullInputOption Property

[image]

SQL Schema Sync API Class reference
ScalarFunction..::.NullInputOption Property
ScalarFunction Class See Also Send Feedback
Gets or sets execution options for a function subject to the input values.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public NullInputOption NullInputOption { get; set; }
Visual Basic (Declaration)
Public Property NullInputOption As NullInputOption
Visual C++
public:
property NullInputOption NullInputOption {
    NullInputOption get ();
    void set (NullInputOption value);
}

See Also

ScalarFunction Class


ReturnValueType Property

[image]

SQL Schema Sync API Class reference
ScalarFunction..::.ReturnValueType Property
ScalarFunction Class See Also Send Feedback
Gets or sets the returned value type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DataType ReturnValueType { get; set; }
Visual Basic (Declaration)
Public Property ReturnValueType As DataType
Visual C++
public:
property DataType^ ReturnValueType {
    DataType^ get ();
    void set (DataType^ value);
}

See Also

ScalarFunction Class


Schema Class

[image]

SQL Schema Sync API Class reference
Schema Class
Members See Also Send Feedback
Represent the schema in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Schema : DatabaseObject,
    ISecurable
Visual Basic (Declaration)
Public NotInheritable Class Schema _
    Inherits DatabaseObject _
    Implements ISecurable
Visual C++
public ref class Schema sealed : public DatabaseObject,
    ISecurable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Schema

See Also

Schema Members


Schema Members

[image] [image]

SQL Schema Sync API Class reference
Schema Members
Schema Class Constructors Methods Properties See Also Send Feedback

The Schema type exposes the following members.

Constructors

Name | Description
Schema | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualsTo | Gets true value if schemas are equal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets the schema extended properties.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets Principal which is the schema owner.

See Also

Schema Class


Schema Constructor

[image] [image]

SQL Schema Sync API Class reference
Schema Constructor
Schema Class See Also Send Feedback

Overload List

Name | Description
Schema()()() | Initializes a new instance of the Schema class.
Schema(String) | Creates new instance of the Schema class.

See Also

Schema Class
Schema Members


Schema Constructor

[image]

SQL Schema Sync API Class reference
Schema Constructor
Schema Class See Also Send Feedback
Initializes a new instance of the Schema class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Schema()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Schema()

See Also

Schema Class
Schema Overload


Schema Constructor (String)

[image]

SQL Schema Sync API Class reference
Schema Constructor (String)
Schema Class See Also Send Feedback
Creates new instance of the Schema class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Schema(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
Schema(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Schema Class
Schema Overload


Schema Methods

[image] [image]

SQL Schema Sync API Class reference
Schema Methods
Schema Class See Also Send Feedback

The Schema type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualsTo | Gets true value if schemas are equal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Schema Class


IsEqualsTo Method

[image]

SQL Schema Sync API Class reference
Schema..::.IsEqualsTo Method
Schema Class See Also Send Feedback
Gets true value if schemas are equal.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEqualsTo(
    Schema schema
)
Visual Basic (Declaration)
Public Function IsEqualsTo ( _
    schema As Schema _
) As Boolean
Visual C++
public:
bool IsEqualsTo(
    Schema^ schema
)

Parameters

schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema

See Also

Schema Class


Schema Properties

[image] [image]

SQL Schema Sync API Class reference
Schema Properties
Schema Class See Also Send Feedback

The Schema type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets the schema extended properties.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets or sets Principal which is the schema owner.

See Also

Schema Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
Schema..::.ExtendedProperties Property
Schema Class See Also Send Feedback
Implements ExtendedProperties()()(). Gets the schema extended properties.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

Schema Class


Owner Property

[image]

SQL Schema Sync API Class reference
Schema..::.Owner Property
Schema Class See Also Send Feedback
Gets or sets Principal which is the schema owner.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Principal Owner { get; set; }
Visual Basic (Declaration)
Public Property Owner As Principal
Visual C++
public:
property Principal^ Owner {
    Principal^ get ();
    void set (Principal^ value);
}

See Also

Schema Class


SchemaObject Class

[image]

SQL Schema Sync API Class reference
SchemaObject Class
Members See Also Send Feedback
Base class for the schema-aware objects.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class SchemaObject : DatabaseObject,
    ISchemaObject, ISecurable
Visual Basic (Declaration)
Public MustInherit Class SchemaObject _
    Inherits DatabaseObject _
    Implements ISchemaObject, ISecurable
Visual C++
public ref class SchemaObject abstract : public DatabaseObject,
    ISchemaObject, ISecurable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.CLRType
PerpetuumSoft.DataModel.MsSql..::.Default
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.Rule
PerpetuumSoft.DataModel.MsSql..::.Synonym
PerpetuumSoft.DataModel.MsSql..::.TableBase
PerpetuumSoft.DataModel.MsSql..::.TableTypeSql10
PerpetuumSoft.DataModel.MsSql..::.UserDefinedType
PerpetuumSoft.DataModel.MsSql..::.XmlSchemaCollection

See Also

SchemaObject Members


SchemaObject Members

[image] [image]

SQL Schema Sync API Class reference
SchemaObject Members
SchemaObject Class Constructors Methods Properties See Also Send Feedback

The SchemaObject type exposes the following members.

Constructors

Name | Description
SchemaObject | Initializes a new instance of the SchemaObject class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Overrides Element..::.RelatesTo(Element).)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema.
FullName | Override. See FullName. (Overrides Element..::.FullName.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema.

See Also

SchemaObject Class


SchemaObject Constructor

[image]

SQL Schema Sync API Class reference
SchemaObject Constructor
SchemaObject Class See Also Send Feedback
Initializes a new instance of the SchemaObject class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected SchemaObject()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SchemaObject()

See Also

SchemaObject Class


SchemaObject Methods

[image] [image]

SQL Schema Sync API Class reference
SchemaObject Methods
SchemaObject Class See Also Send Feedback

The SchemaObject type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Overrides Element..::.RelatesTo(Element).)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

SchemaObject Class


RelatesTo Method

[image]

SQL Schema Sync API Class reference
SchemaObject..::.RelatesTo Method
SchemaObject Class See Also Send Feedback
Overridden. See RelatesTo(Element).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool RelatesTo(
    Element element
)
Visual Basic (Declaration)
Public Overrides Function RelatesTo ( _
    element As Element _
) As Boolean
Visual C++
public:
virtual bool RelatesTo(
    Element^ element
) override

Parameters

element
Type: PerpetuumSoft.DataModel.MsSql..::.Element

See Also

SchemaObject Class


SchemaObject Properties

[image] [image]

SQL Schema Sync API Class reference
SchemaObject Properties
SchemaObject Class See Also Send Feedback

The SchemaObject type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema.
FullName | Override. See FullName. (Overrides Element..::.FullName.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema.

See Also

SchemaObject Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
SchemaObject..::.ExtendedProperties Property
SchemaObject Class See Also Send Feedback
Implements ExtendedProperties()()(). Gets extended properties for the objects shema.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

SchemaObject Class


FullName Property

[image]

SQL Schema Sync API Class reference
SchemaObject..::.FullName Property
SchemaObject Class See Also Send Feedback
Override. See FullName.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string FullName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property FullName As String
Visual C++
public:
virtual property String^ FullName {
    String^ get () override;
}

Implements

ISecurable..::.FullName

See Also

SchemaObject Class


Schema Property

[image]

SQL Schema Sync API Class reference
SchemaObject..::.Schema Property
SchemaObject Class See Also Send Feedback
Implements Schema.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Schema Schema { get; set; }
Visual Basic (Declaration)
Public Property Schema As Schema
Visual C++
public:
virtual property Schema^ Schema {
    Schema^ get () sealed;
    void set (Schema^ value) sealed;
}

Implements

ISchemaObject..::.Schema

See Also

SchemaObject Class


SpatialIndexSql10 Class

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10 Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class SpatialIndexSql10 : IndexBase
Visual Basic (Declaration)
Public Class SpatialIndexSql10 _
    Inherits IndexBase
Visual C++
public ref class SpatialIndexSql10 : public IndexBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.IndexBase
PerpetuumSoft.DataModel.MsSql..::.SpatialIndexSql10

See Also

SpatialIndexSql10 Members


SpatialIndexSql10 Members

[image] [image]

SQL Schema Sync API Class reference
SpatialIndexSql10 Members
SpatialIndexSql10 Class Constructors Methods Properties See Also Send Feedback

The SpatialIndexSql10 type exposes the following members.

Constructors

Name | Description
SpatialIndexSql10 | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from IndexBase.)
SetOptions |
SetTesselation |
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
AllowPageLocks |
AllowRowLocks |
BoundingBox |
CellsPerObject |
Columns |
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). (Inherited from IndexBase.)
FillFactor |
FullName | Gets the element full name. (Inherited from Element.)
GridDestiny |
IgnoreDupKey |
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Online |
PadIndex |
Schema | Implements Schema. (Inherited from IndexBase.)
StatisticNoRecompute |
Table | Gets or sets TableBase. (Inherited from IndexBase.)
TessellationSchema |

See Also

SpatialIndexSql10 Class


SpatialIndexSql10 Constructor

[image] [image]

SQL Schema Sync API Class reference
SpatialIndexSql10 Constructor
SpatialIndexSql10 Class See Also Send Feedback

Overload List

Name | Description
SpatialIndexSql10()()() | Initializes a new instance of the SpatialIndexSql10 class
SpatialIndexSql10(String, TableBase) | Initializes a new instance of the SpatialIndexSql10 class

See Also

SpatialIndexSql10 Class
SpatialIndexSql10 Members


SpatialIndexSql10 Constructor

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10 Constructor
SpatialIndexSql10 Class See Also Send Feedback
Initializes a new instance of the SpatialIndexSql10 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SpatialIndexSql10()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SpatialIndexSql10()

See Also

SpatialIndexSql10 Class
SpatialIndexSql10 Overload


SpatialIndexSql10 Constructor (String, TableBase)

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10 Constructor (String, TableBase)
SpatialIndexSql10 Class See Also Send Feedback
Initializes a new instance of the SpatialIndexSql10 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SpatialIndexSql10(
    string name,
    TableBase table
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    table As TableBase _
)
Visual C++
public:
SpatialIndexSql10(
    String^ name,
    TableBase^ table
)

Parameters

name
Type: System..::.String
table
Type: PerpetuumSoft.DataModel.MsSql..::.TableBase

See Also

SpatialIndexSql10 Class
SpatialIndexSql10 Overload


SpatialIndexSql10 Methods

[image] [image]

SQL Schema Sync API Class reference
SpatialIndexSql10 Methods
SpatialIndexSql10 Class See Also Send Feedback

The SpatialIndexSql10 type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from IndexBase.)
SetOptions |
SetTesselation |
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

SpatialIndexSql10 Class


SetOptions Method

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.SetOptions Method
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.SetOptions(System.Data.IDataReader)"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void SetOptions(
    IDataReader reader
)
Visual Basic (Declaration)
Public Sub SetOptions ( _
    reader As IDataReader _
)
Visual C++
public:
void SetOptions(
    IDataReader^ reader
)

Parameters

reader
Type: System.Data..::.IDataReader

See Also

SpatialIndexSql10 Class


SetTesselation Method

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.SetTesselation Method
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.SetTesselation(System.Data.IDataReader)"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void SetTesselation(
    IDataReader reader
)
Visual Basic (Declaration)
Public Sub SetTesselation ( _
    reader As IDataReader _
)
Visual C++
public:
void SetTesselation(
    IDataReader^ reader
)

Parameters

reader
Type: System.Data..::.IDataReader

See Also

SpatialIndexSql10 Class


SpatialIndexSql10 Properties

[image] [image]

SQL Schema Sync API Class reference
SpatialIndexSql10 Properties
SpatialIndexSql10 Class See Also Send Feedback

The SpatialIndexSql10 type exposes the following members.

Properties

Name | Description
AllowPageLocks |
AllowRowLocks |
BoundingBox |
CellsPerObject |
Columns |
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). (Inherited from IndexBase.)
FillFactor |
FullName | Gets the element full name. (Inherited from Element.)
GridDestiny |
IgnoreDupKey |
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Online |
PadIndex |
Schema | Implements Schema. (Inherited from IndexBase.)
StatisticNoRecompute |
Table | Gets or sets TableBase. (Inherited from IndexBase.)
TessellationSchema |

See Also

SpatialIndexSql10 Class


AllowPageLocks Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.AllowPageLocks Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.AllowPageLocks"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowPageLocks { get; set; }
Visual Basic (Declaration)
Public Property AllowPageLocks As Boolean
Visual C++
public:
property bool AllowPageLocks {
    bool get ();
    void set (bool value);
}

See Also

SpatialIndexSql10 Class


AllowRowLocks Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.AllowRowLocks Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.AllowRowLocks"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowRowLocks { get; set; }
Visual Basic (Declaration)
Public Property AllowRowLocks As Boolean
Visual C++
public:
property bool AllowRowLocks {
    bool get ();
    void set (bool value);
}

See Also

SpatialIndexSql10 Class


BoundingBox Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.BoundingBox Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.BoundingBox"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public BoundingBox BoundingBox { get; set; }
Visual Basic (Declaration)
Public Property BoundingBox As BoundingBox
Visual C++
public:
property BoundingBox^ BoundingBox {
    BoundingBox^ get ();
    void set (BoundingBox^ value);
}

See Also

SpatialIndexSql10 Class


CellsPerObject Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.CellsPerObject Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.CellsPerObject"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int CellsPerObject { get; set; }
Visual Basic (Declaration)
Public Property CellsPerObject As Integer
Visual C++
public:
property int CellsPerObject {
    int get ();
    void set (int value);
}

See Also

SpatialIndexSql10 Class


Columns Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.Columns Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.Columns"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IndexColumnCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As IndexColumnCollection
Visual C++
public:
property IndexColumnCollection^ Columns {
    IndexColumnCollection^ get ();
}

See Also

SpatialIndexSql10 Class


FillFactor Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.FillFactor Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.FillFactor"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int FillFactor { get; set; }
Visual Basic (Declaration)
Public Property FillFactor As Integer
Visual C++
public:
property int FillFactor {
    int get ();
    void set (int value);
}

See Also

SpatialIndexSql10 Class


GridDestiny Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.GridDestiny Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.GridDestiny"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public GridDestiny GridDestiny { get; set; }
Visual Basic (Declaration)
Public Property GridDestiny As GridDestiny
Visual C++
public:
property GridDestiny^ GridDestiny {
    GridDestiny^ get ();
    void set (GridDestiny^ value);
}

See Also

SpatialIndexSql10 Class


IgnoreDupKey Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.IgnoreDupKey Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.IgnoreDupKey"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IgnoreDupKey { get; set; }
Visual Basic (Declaration)
Public Property IgnoreDupKey As Boolean
Visual C++
public:
property bool IgnoreDupKey {
    bool get ();
    void set (bool value);
}

See Also

SpatialIndexSql10 Class


Online Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.Online Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.Online"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Online { get; set; }
Visual Basic (Declaration)
Public Property Online As Boolean
Visual C++
public:
property bool Online {
    bool get ();
    void set (bool value);
}

See Also

SpatialIndexSql10 Class


PadIndex Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.PadIndex Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.PadIndex"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool PadIndex { get; set; }
Visual Basic (Declaration)
Public Property PadIndex As Boolean
Visual C++
public:
property bool PadIndex {
    bool get ();
    void set (bool value);
}

See Also

SpatialIndexSql10 Class


StatisticNoRecompute Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.StatisticNoRecompute Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.StatisticNoRecompute"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool StatisticNoRecompute { get; set; }
Visual Basic (Declaration)
Public Property StatisticNoRecompute As Boolean
Visual C++
public:
property bool StatisticNoRecompute {
    bool get ();
    void set (bool value);
}

See Also

SpatialIndexSql10 Class


TessellationSchema Property

[image]

SQL Schema Sync API Class reference
SpatialIndexSql10..::.TessellationSchema Property
SpatialIndexSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.SpatialIndexSql10.TessellationSchema"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TessellationSchema TessellationSchema { get; set; }
Visual Basic (Declaration)
Public Property TessellationSchema As TessellationSchema
Visual C++
public:
property TessellationSchema TessellationSchema {
    TessellationSchema get ();
    void set (TessellationSchema value);
}

See Also

SpatialIndexSql10 Class


SqlVersionEnum Enumeration

[image]

SQL Schema Sync API Class reference
SqlVersionEnum Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.SqlVersionEnum"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum SqlVersionEnum
Visual Basic (Declaration)
Public Enumeration SqlVersionEnum
Visual C++
public enum class SqlVersionEnum

Members

Member name | Description
Sql2005 |
Sql2008 |
Invalid |

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


StoredProcedure Class

[image]

SQL Schema Sync API Class reference
StoredProcedure Class
Members See Also Send Feedback
Represents the stored procedure in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class StoredProcedure : TextFunction
Visual Basic (Declaration)
Public NotInheritable Class StoredProcedure _
    Inherits TextFunction
Visual C++
public ref class StoredProcedure sealed : public TextFunction

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.TextFunction
PerpetuumSoft.DataModel.MsSql..::.StoredProcedure

See Also

StoredProcedure Members


StoredProcedure Members

[image] [image]

SQL Schema Sync API Class reference
StoredProcedure Members
StoredProcedure Class Constructors Methods Properties See Also Send Feedback

The StoredProcedure type exposes the following members.

Constructors

Name | Description
StoredProcedure | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure. (Inherited from TextFunction.)

See Also

StoredProcedure Class


StoredProcedure Constructor

[image] [image]

SQL Schema Sync API Class reference
StoredProcedure Constructor
StoredProcedure Class See Also Send Feedback

Overload List

Name | Description
StoredProcedure()()() | Initializes a new instance of the StoredProcedure class.
StoredProcedure(String, String) | Creates new instance of the StoredProcedure class.

See Also

StoredProcedure Class
StoredProcedure Members


StoredProcedure Constructor

[image]

SQL Schema Sync API Class reference
StoredProcedure Constructor
StoredProcedure Class See Also Send Feedback
Initializes a new instance of the StoredProcedure class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public StoredProcedure()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StoredProcedure()

See Also

StoredProcedure Class
StoredProcedure Overload


StoredProcedure Constructor (String, String)

[image]

SQL Schema Sync API Class reference
StoredProcedure Constructor (String, String)
StoredProcedure Class See Also Send Feedback
Creates new instance of the StoredProcedure class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public StoredProcedure(
    string name,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
StoredProcedure(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::.String
text
Type: System..::.String

See Also

StoredProcedure Class
StoredProcedure Overload


StoredProcedure Methods

[image] [image]

SQL Schema Sync API Class reference
StoredProcedure Methods
StoredProcedure Class See Also Send Feedback

The StoredProcedure type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

StoredProcedure Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
StoredProcedure..::.SetExecuteAsClause Method
StoredProcedure Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context. (Inherited from FunctionBase.)
SetExecuteAsClause(String) | Sets the function security context. (Inherited from FunctionBase.)

See Also

StoredProcedure Class
StoredProcedure Members


StoredProcedure Properties

[image] [image]

SQL Schema Sync API Class reference
StoredProcedure Properties
StoredProcedure Class See Also Send Feedback

The StoredProcedure type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure. (Inherited from TextFunction.)

See Also

StoredProcedure Class


Synonym Class

[image]

SQL Schema Sync API Class reference
Synonym Class
Members See Also Send Feedback
Represents synonym in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Synonym : SchemaObject
Visual Basic (Declaration)
Public NotInheritable Class Synonym _
    Inherits SchemaObject
Visual C++
public ref class Synonym sealed : public SchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.Synonym

See Also

Synonym Members


Synonym Members

[image] [image]

SQL Schema Sync API Class reference
Synonym Members
Synonym Class Constructors Methods Properties See Also Send Feedback

The Synonym type exposes the following members.

Constructors

Name | Description
Synonym | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
BaseObjectName | Name of the database object this synonym references to.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

Synonym Class


Synonym Constructor

[image] [image]

SQL Schema Sync API Class reference
Synonym Constructor
Synonym Class See Also Send Feedback

Overload List

Name | Description
Synonym()()() | Creates new instance of the Synonym class.
Synonym(String) | Creates new instance of the Synonym class.

See Also

Synonym Class
Synonym Members


Synonym Constructor

[image]

SQL Schema Sync API Class reference
Synonym Constructor
Synonym Class See Also Send Feedback
Creates new instance of the Synonym class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Synonym()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Synonym()

See Also

Synonym Class
Synonym Overload


Synonym Constructor (String)

[image]

SQL Schema Sync API Class reference
Synonym Constructor (String)
Synonym Class See Also Send Feedback
Creates new instance of the Synonym class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Synonym(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
Synonym(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Synonym Class
Synonym Overload


Synonym Methods

[image] [image]

SQL Schema Sync API Class reference
Synonym Methods
Synonym Class See Also Send Feedback

The Synonym type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Synonym Class


Synonym Properties

[image] [image]

SQL Schema Sync API Class reference
Synonym Properties
Synonym Class See Also Send Feedback

The Synonym type exposes the following members.

Properties

Name | Description
BaseObjectName | Name of the database object this synonym references to.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

Synonym Class


BaseObjectName Property

[image]

SQL Schema Sync API Class reference
Synonym..::.BaseObjectName Property
Synonym Class See Also Send Feedback
Name of the database object this synonym references to.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string BaseObjectName { get; set; }
Visual Basic (Declaration)
Public Property BaseObjectName As String
Visual C++
public:
property String^ BaseObjectName {
    String^ get ();
    void set (String^ value);
}

See Also

Synonym Class


Table Class

[image]

SQL Schema Sync API Class reference
Table Class
Members See Also Send Feedback
Represents a table in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Table : TableBase
Visual Basic (Declaration)
Public NotInheritable Class Table _
    Inherits TableBase
Visual C++
public ref class Table sealed : public TableBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.TableBase
PerpetuumSoft.DataModel.MsSql..::.Table

See Also

Table Members


Table Members

[image] [image]

SQL Schema Sync API Class reference
Table Members
Table Class Constructors Methods Properties See Also Send Feedback

The Table type exposes the following members.

Constructors

Name | Description
Table | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Columns | Gets table columns. (Inherited from TableBase.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

Table Class


Table Constructor

[image] [image]

SQL Schema Sync API Class reference
Table Constructor
Table Class See Also Send Feedback

Overload List

Name | Description
Table()()() | Initializes a new instance of the Table class.
Table(String, Schema) | Creates new instance of the Table class.

See Also

Table Class
Table Members


Table Constructor

[image]

SQL Schema Sync API Class reference
Table Constructor
Table Class See Also Send Feedback
Initializes a new instance of the Table class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Table()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Table()

See Also

Table Class
Table Overload


Table Constructor (String, Schema)

[image]

SQL Schema Sync API Class reference
Table Constructor (String, Schema)
Table Class See Also Send Feedback
Creates new instance of the Table class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Table(
    string name,
    Schema schema
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    schema As Schema _
)
Visual C++
public:
Table(
    String^ name,
    Schema^ schema
)

Parameters

name
Type: System..::.String
schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema

See Also

Table Class
Table Overload


Table Methods

[image] [image]

SQL Schema Sync API Class reference
Table Methods
Table Class See Also Send Feedback

The Table type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Table Class


Table Properties

[image] [image]

SQL Schema Sync API Class reference
Table Properties
Table Class See Also Send Feedback

The Table type exposes the following members.

Properties

Name | Description
Columns | Gets table columns. (Inherited from TableBase.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

Table Class


TableBase Class

[image]

SQL Schema Sync API Class reference
TableBase Class
Members See Also Send Feedback
Abstract superclass for the table and view objects.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class TableBase : SchemaObject
Visual Basic (Declaration)
Public MustInherit Class TableBase _
    Inherits SchemaObject
Visual C++
public ref class TableBase abstract : public SchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.TableBase
PerpetuumSoft.DataModel.MsSql..::.Table
PerpetuumSoft.DataModel.MsSql..::.View

See Also

TableBase Members


TableBase Members

[image] [image]

SQL Schema Sync API Class reference
TableBase Members
TableBase Class Constructors Methods Properties See Also Send Feedback

The TableBase type exposes the following members.

Constructors

Name | Description
TableBase | Initializes a new instance of the TableBase class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Columns | Gets table columns.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

TableBase Class


TableBase Constructor

[image]

SQL Schema Sync API Class reference
TableBase Constructor
TableBase Class See Also Send Feedback
Initializes a new instance of the TableBase class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected TableBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
TableBase()

See Also

TableBase Class


TableBase Methods

[image] [image]

SQL Schema Sync API Class reference
TableBase Methods
TableBase Class See Also Send Feedback

The TableBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

TableBase Class


TableBase Properties

[image] [image]

SQL Schema Sync API Class reference
TableBase Properties
TableBase Class See Also Send Feedback

The TableBase type exposes the following members.

Properties

Name | Description
Columns | Gets table columns.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

TableBase Class


Columns Property

[image]

SQL Schema Sync API Class reference
TableBase..::.Columns Property
TableBase Class See Also Send Feedback
Gets table columns.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ColumnBaseCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As ColumnBaseCollection
Visual C++
public:
property ColumnBaseCollection^ Columns {
    ColumnBaseCollection^ get ();
}

See Also

TableBase Class


TableColumn Class

[image]

SQL Schema Sync API Class reference
TableColumn Class
Members See Also Send Feedback
Represents table column in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class TableColumn : ColumnBase
Visual Basic (Declaration)
Public MustInherit Class TableColumn _
    Inherits ColumnBase
Visual C++
public ref class TableColumn abstract : public ColumnBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.ColumnBase
PerpetuumSoft.DataModel.MsSql..::.TableColumn
PerpetuumSoft.DataModel.MsSql..::.ComputedColumn
PerpetuumSoft.DataModel.MsSql..::.DataColumn

See Also

TableColumn Members


TableColumn Members

[image] [image]

SQL Schema Sync API Class reference
TableColumn Members
TableColumn Class Constructors Methods Properties See Also Send Feedback

The TableColumn type exposes the following members.

Constructors

Name | Description
TableColumn | Initializes a new instance of the TableColumn class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). (Inherited from ColumnBase.)
TypeEquals | Gets true value if columns types are equal. (Inherited from ColumnBase.)

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values. (Inherited from ColumnBase.)
DataType | Gets or sets DataType of a column. (Inherited from ColumnBase.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for a column. (Inherited from ColumnBase.)
FullName | Gets full name of the column. (Inherited from ColumnBase.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets TableBase which contains a column. (Inherited from ColumnBase.)

See Also

TableColumn Class


TableColumn Constructor

[image]

SQL Schema Sync API Class reference
TableColumn Constructor
TableColumn Class See Also Send Feedback
Initializes a new instance of the TableColumn class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected TableColumn()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
TableColumn()

See Also

TableColumn Class


TableColumn Methods

[image] [image]

SQL Schema Sync API Class reference
TableColumn Methods
TableColumn Class See Also Send Feedback

The TableColumn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). (Inherited from ColumnBase.)
TypeEquals | Gets true value if columns types are equal. (Inherited from ColumnBase.)

See Also

TableColumn Class


TableColumn Properties

[image] [image]

SQL Schema Sync API Class reference
TableColumn Properties
TableColumn Class See Also Send Feedback

The TableColumn type exposes the following members.

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values. (Inherited from ColumnBase.)
DataType | Gets or sets DataType of a column. (Inherited from ColumnBase.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for a column. (Inherited from ColumnBase.)
FullName | Gets full name of the column. (Inherited from ColumnBase.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets TableBase which contains a column. (Inherited from ColumnBase.)

See Also

TableColumn Class


TableTypeSql10 Class

[image]

SQL Schema Sync API Class reference
TableTypeSql10 Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.TableTypeSql10"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class TableTypeSql10 : SchemaObject
Visual Basic (Declaration)
Public Class TableTypeSql10 _
    Inherits SchemaObject
Visual C++
public ref class TableTypeSql10 : public SchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.TableTypeSql10

See Also

TableTypeSql10 Members


TableTypeSql10 Members

[image] [image]

SQL Schema Sync API Class reference
TableTypeSql10 Members
TableTypeSql10 Class Constructors Methods Properties See Also Send Feedback

The TableTypeSql10 type exposes the following members.

Constructors

Name | Description
TableTypeSql10 | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEquals |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
CheckConstraints |
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DefaultConstraints |
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
KeyConstraints |
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)
UnderlyingTable |

See Also

TableTypeSql10 Class


TableTypeSql10 Constructor

[image] [image]

SQL Schema Sync API Class reference
TableTypeSql10 Constructor
TableTypeSql10 Class See Also Send Feedback

Overload List

Name | Description
TableTypeSql10()()() | Initializes a new instance of the TableTypeSql10 class
TableTypeSql10(String, Schema) | Initializes a new instance of the TableTypeSql10 class

See Also

TableTypeSql10 Class
TableTypeSql10 Members


TableTypeSql10 Constructor

[image]

SQL Schema Sync API Class reference
TableTypeSql10 Constructor
TableTypeSql10 Class See Also Send Feedback
Initializes a new instance of the TableTypeSql10 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableTypeSql10()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableTypeSql10()

See Also

TableTypeSql10 Class
TableTypeSql10 Overload


TableTypeSql10 Constructor (String, Schema)

[image]

SQL Schema Sync API Class reference
TableTypeSql10 Constructor (String, Schema)
TableTypeSql10 Class See Also Send Feedback
Initializes a new instance of the TableTypeSql10 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableTypeSql10(
    string name,
    Schema schema
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    schema As Schema _
)
Visual C++
public:
TableTypeSql10(
    String^ name,
    Schema^ schema
)

Parameters

name
Type: System..::.String
schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema

See Also

TableTypeSql10 Class
TableTypeSql10 Overload


TableTypeSql10 Methods

[image] [image]

SQL Schema Sync API Class reference
TableTypeSql10 Methods
TableTypeSql10 Class See Also Send Feedback

The TableTypeSql10 type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEquals |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

TableTypeSql10 Class


IsEquals Method

[image]

SQL Schema Sync API Class reference
TableTypeSql10..::.IsEquals Method
TableTypeSql10 Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.TableTypeSql10.IsEquals(PerpetuumSoft.DataModel.MsSql.TableTypeSql10)"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEquals(
    TableTypeSql10 other
)
Visual Basic (Declaration)
Public Function IsEquals ( _
    other As TableTypeSql10 _
) As Boolean
Visual C++
public:
bool IsEquals(
    TableTypeSql10^ other
)

Parameters

other
Type: PerpetuumSoft.DataModel.MsSql..::.TableTypeSql10

See Also

TableTypeSql10 Class


TableTypeSql10 Properties

[image] [image]

SQL Schema Sync API Class reference
TableTypeSql10 Properties
TableTypeSql10 Class See Also Send Feedback

The TableTypeSql10 type exposes the following members.

Properties

Name | Description
CheckConstraints |
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DefaultConstraints |
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
KeyConstraints |
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)
UnderlyingTable |

See Also

TableTypeSql10 Class


CheckConstraints Property

[image]

SQL Schema Sync API Class reference
TableTypeSql10..::.CheckConstraints Property
TableTypeSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.TableTypeSql10.CheckConstraints"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public List<CheckConstraint> CheckConstraints { get; }
Visual Basic (Declaration)
Public ReadOnly Property CheckConstraints As List(Of CheckConstraint)
Visual C++
public:
property List<CheckConstraint^>^ CheckConstraints {
    List<CheckConstraint^>^ get ();
}

See Also

TableTypeSql10 Class


DefaultConstraints Property

[image]

SQL Schema Sync API Class reference
TableTypeSql10..::.DefaultConstraints Property
TableTypeSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.TableTypeSql10.DefaultConstraints"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public List<DefaultConstraint> DefaultConstraints { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultConstraints As List(Of DefaultConstraint)
Visual C++
public:
property List<DefaultConstraint^>^ DefaultConstraints {
    List<DefaultConstraint^>^ get ();
}

See Also

TableTypeSql10 Class


KeyConstraints Property

[image]

SQL Schema Sync API Class reference
TableTypeSql10..::.KeyConstraints Property
TableTypeSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.TableTypeSql10.KeyConstraints"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public List<KeyConstraint> KeyConstraints { get; set; }
Visual Basic (Declaration)
Public Property KeyConstraints As List(Of KeyConstraint)
Visual C++
public:
property List<KeyConstraint^>^ KeyConstraints {
    List<KeyConstraint^>^ get ();
    void set (List<KeyConstraint^>^ value);
}

See Also

TableTypeSql10 Class


UnderlyingTable Property

[image]

SQL Schema Sync API Class reference
TableTypeSql10..::.UnderlyingTable Property
TableTypeSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.TableTypeSql10.UnderlyingTable"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Table UnderlyingTable { get; set; }
Visual Basic (Declaration)
Public Property UnderlyingTable As Table
Visual C++
public:
property Table^ UnderlyingTable {
    Table^ get ();
    void set (Table^ value);
}

See Also

TableTypeSql10 Class


TableValuedCLRFunction Class

[image]

SQL Schema Sync API Class reference
TableValuedCLRFunction Class
Members See Also Send Feedback
Represents the table valued CLR function in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class TableValuedCLRFunction : CLRFunctionBase
Visual Basic (Declaration)
Public Class TableValuedCLRFunction _
    Inherits CLRFunctionBase
Visual C++
public ref class TableValuedCLRFunction : public CLRFunctionBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.CLRFunctionBase
PerpetuumSoft.DataModel.MsSql..::.TableValuedCLRFunction
PerpetuumSoft.DataModel.MsSql..::.TableValuedCLRFunctionSql10

See Also

TableValuedCLRFunction Members


TableValuedCLRFunction Members

[image] [image]

SQL Schema Sync API Class reference
TableValuedCLRFunction Members
TableValuedCLRFunction Class Constructors Methods Properties See Also Send Feedback

The TableValuedCLRFunction type exposes the following members.

Constructors

Name | Description
TableValuedCLRFunction | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Assembly | Gets or sets Assembly which contains this function. (Inherited from CLRFunctionBase.)
ClassName | Gets or sets name of the class which contains this function. (Inherited from CLRFunctionBase.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MethodName | Gets or sets name of the method which defines this method in the assembly. (Inherited from CLRFunctionBase.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
ReturnsTable | Gets or sets returned value for a table function.
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

TableValuedCLRFunction Class


TableValuedCLRFunction Constructor

[image] [image]

SQL Schema Sync API Class reference
TableValuedCLRFunction Constructor
TableValuedCLRFunction Class See Also Send Feedback

Overload List

Name | Description
TableValuedCLRFunction()()() | Creates new instance of the TableValuedCLRFunction class.
TableValuedCLRFunction(String, Schema) | Creates new instance of the TableValuedCLRFunction class.

See Also

TableValuedCLRFunction Class
TableValuedCLRFunction Members


TableValuedCLRFunction Constructor

[image]

SQL Schema Sync API Class reference
TableValuedCLRFunction Constructor
TableValuedCLRFunction Class See Also Send Feedback
Creates new instance of the TableValuedCLRFunction class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableValuedCLRFunction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableValuedCLRFunction()

See Also

TableValuedCLRFunction Class
TableValuedCLRFunction Overload


TableValuedCLRFunction Constructor (String, Schema)

[image]

SQL Schema Sync API Class reference
TableValuedCLRFunction Constructor (String, Schema)
TableValuedCLRFunction Class See Also Send Feedback
Creates new instance of the TableValuedCLRFunction class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableValuedCLRFunction(
    string name,
    Schema schema
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    schema As Schema _
)
Visual C++
public:
TableValuedCLRFunction(
    String^ name,
    Schema^ schema
)

Parameters

name
Type: System..::.String
schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema

See Also

TableValuedCLRFunction Class
TableValuedCLRFunction Overload


TableValuedCLRFunction Methods

[image] [image]

SQL Schema Sync API Class reference
TableValuedCLRFunction Methods
TableValuedCLRFunction Class See Also Send Feedback

The TableValuedCLRFunction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

TableValuedCLRFunction Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
TableValuedCLRFunction..::.SetExecuteAsClause Method
TableValuedCLRFunction Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context. (Inherited from FunctionBase.)
SetExecuteAsClause(String) | Sets the function security context. (Inherited from FunctionBase.)

See Also

TableValuedCLRFunction Class
TableValuedCLRFunction Members


TableValuedCLRFunction Properties

[image] [image]

SQL Schema Sync API Class reference
TableValuedCLRFunction Properties
TableValuedCLRFunction Class See Also Send Feedback

The TableValuedCLRFunction type exposes the following members.

Properties

Name | Description
Assembly | Gets or sets Assembly which contains this function. (Inherited from CLRFunctionBase.)
ClassName | Gets or sets name of the class which contains this function. (Inherited from CLRFunctionBase.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MethodName | Gets or sets name of the method which defines this method in the assembly. (Inherited from CLRFunctionBase.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
ReturnsTable | Gets or sets returned value for a table function.
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

TableValuedCLRFunction Class


ReturnsTable Property

[image]

SQL Schema Sync API Class reference
TableValuedCLRFunction..::.ReturnsTable Property
TableValuedCLRFunction Class See Also Send Feedback
Gets or sets returned value for a table function.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ParameterBaseCollection ReturnsTable { get; set; }
Visual Basic (Declaration)
Public Property ReturnsTable As ParameterBaseCollection
Visual C++
public:
property ParameterBaseCollection^ ReturnsTable {
    ParameterBaseCollection^ get ();
    void set (ParameterBaseCollection^ value);
}

See Also

TableValuedCLRFunction Class


TableValuedCLRFunctionSql10 Class

[image]

SQL Schema Sync API Class reference
TableValuedCLRFunctionSql10 Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.TableValuedCLRFunctionSql10"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public class TableValuedCLRFunctionSql10 : TableValuedCLRFunction
Visual Basic (Declaration)
Public Class TableValuedCLRFunctionSql10 _
    Inherits TableValuedCLRFunction
Visual C++
public ref class TableValuedCLRFunctionSql10 : public TableValuedCLRFunction

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.CLRFunctionBase
PerpetuumSoft.DataModel.MsSql..::.TableValuedCLRFunction
PerpetuumSoft.DataModel.MsSql..::.TableValuedCLRFunctionSql10

See Also

TableValuedCLRFunctionSql10 Members


TableValuedCLRFunctionSql10 Members

[image] [image]

SQL Schema Sync API Class reference
TableValuedCLRFunctionSql10 Members
TableValuedCLRFunctionSql10 Class Constructors Methods Properties See Also Send Feedback

The TableValuedCLRFunctionSql10 type exposes the following members.

Constructors

Name | Description
TableValuedCLRFunctionSql10 | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetParamater |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Assembly | Gets or sets Assembly which contains this function. (Inherited from CLRFunctionBase.)
ClassName | Gets or sets name of the class which contains this function. (Inherited from CLRFunctionBase.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MethodName | Gets or sets name of the method which defines this method in the assembly. (Inherited from CLRFunctionBase.)
Name | Gets or sets an element name. (Inherited from Element.)
OrderColumns |
Parameters | Gets function parameters. (Inherited from FunctionBase.)
ReturnsTable | Gets or sets returned value for a table function. (Inherited from TableValuedCLRFunction.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

TableValuedCLRFunctionSql10 Class


TableValuedCLRFunctionSql10 Constructor

[image] [image]

SQL Schema Sync API Class reference
TableValuedCLRFunctionSql10 Constructor
TableValuedCLRFunctionSql10 Class See Also Send Feedback

Overload List

Name | Description
TableValuedCLRFunctionSql10()()() | Initializes a new instance of the TableValuedCLRFunctionSql10 class
TableValuedCLRFunctionSql10(String, Schema) | Initializes a new instance of the TableValuedCLRFunctionSql10 class

See Also

TableValuedCLRFunctionSql10 Class
TableValuedCLRFunctionSql10 Members


TableValuedCLRFunctionSql10 Constructor

[image]

SQL Schema Sync API Class reference
TableValuedCLRFunctionSql10 Constructor
TableValuedCLRFunctionSql10 Class See Also Send Feedback
Initializes a new instance of the TableValuedCLRFunctionSql10 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableValuedCLRFunctionSql10()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TableValuedCLRFunctionSql10()

See Also

TableValuedCLRFunctionSql10 Class
TableValuedCLRFunctionSql10 Overload


TableValuedCLRFunctionSql10 Constructor (String, Schema)

[image]

SQL Schema Sync API Class reference
TableValuedCLRFunctionSql10 Constructor (String, Schema)
TableValuedCLRFunctionSql10 Class See Also Send Feedback
Initializes a new instance of the TableValuedCLRFunctionSql10 class

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableValuedCLRFunctionSql10(
    string name,
    Schema schema
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    schema As Schema _
)
Visual C++
public:
TableValuedCLRFunctionSql10(
    String^ name,
    Schema^ schema
)

Parameters

name
Type: System..::.String
schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema

See Also

TableValuedCLRFunctionSql10 Class
TableValuedCLRFunctionSql10 Overload


TableValuedCLRFunctionSql10 Methods

[image] [image]

SQL Schema Sync API Class reference
TableValuedCLRFunctionSql10 Methods
TableValuedCLRFunctionSql10 Class See Also Send Feedback

The TableValuedCLRFunctionSql10 type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetParamater |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

TableValuedCLRFunctionSql10 Class


GetParamater Method

[image]

SQL Schema Sync API Class reference
TableValuedCLRFunctionSql10..::.GetParamater Method
TableValuedCLRFunctionSql10 Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.TableValuedCLRFunctionSql10.GetParamater(System.Int32)"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ParameterBase GetParamater(
    int parameter_id
)
Visual Basic (Declaration)
Public Function GetParamater ( _
    parameter_id As Integer _
) As ParameterBase
Visual C++
public:
ParameterBase^ GetParamater(
    int parameter_id
)

Parameters

parameter_id
Type: System..::.Int32

See Also

TableValuedCLRFunctionSql10 Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
TableValuedCLRFunctionSql10..::.SetExecuteAsClause Method
TableValuedCLRFunctionSql10 Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context. (Inherited from FunctionBase.)
SetExecuteAsClause(String) | Sets the function security context. (Inherited from FunctionBase.)

See Also

TableValuedCLRFunctionSql10 Class
TableValuedCLRFunctionSql10 Members


TableValuedCLRFunctionSql10 Properties

[image] [image]

SQL Schema Sync API Class reference
TableValuedCLRFunctionSql10 Properties
TableValuedCLRFunctionSql10 Class See Also Send Feedback

The TableValuedCLRFunctionSql10 type exposes the following members.

Properties

Name | Description
Assembly | Gets or sets Assembly which contains this function. (Inherited from CLRFunctionBase.)
ClassName | Gets or sets name of the class which contains this function. (Inherited from CLRFunctionBase.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MethodName | Gets or sets name of the method which defines this method in the assembly. (Inherited from CLRFunctionBase.)
Name | Gets or sets an element name. (Inherited from Element.)
OrderColumns |
Parameters | Gets function parameters. (Inherited from FunctionBase.)
ReturnsTable | Gets or sets returned value for a table function. (Inherited from TableValuedCLRFunction.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

TableValuedCLRFunctionSql10 Class


OrderColumns Property

[image]

SQL Schema Sync API Class reference
TableValuedCLRFunctionSql10..::.OrderColumns Property
TableValuedCLRFunctionSql10 Class See Also Send Feedback

[Missing <summary> documentation for "P:PerpetuumSoft.DataModel.MsSql.TableValuedCLRFunctionSql10.OrderColumns"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public List<ParameterOrderRef> OrderColumns { get; set; }
Visual Basic (Declaration)
Public Property OrderColumns As List(Of ParameterOrderRef)
Visual C++
public:
property List<ParameterOrderRef^>^ OrderColumns {
    List<ParameterOrderRef^>^ get ();
    void set (List<ParameterOrderRef^>^ value);
}

See Also

TableValuedCLRFunctionSql10 Class


TableValuedFunction Class

[image]

SQL Schema Sync API Class reference
TableValuedFunction Class
Members See Also Send Feedback
Represents the table valued function in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class TableValuedFunction : TextFunction
Visual Basic (Declaration)
Public MustInherit Class TableValuedFunction _
    Inherits TextFunction
Visual C++
public ref class TableValuedFunction abstract : public TextFunction

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.TextFunction
PerpetuumSoft.DataModel.MsSql..::.TableValuedFunction
PerpetuumSoft.DataModel.MsSql..::.InlineTableValuedFunction
PerpetuumSoft.DataModel.MsSql..::.MultistatementTableValuedFunction

See Also

TableValuedFunction Members


TableValuedFunction Members

[image] [image]

SQL Schema Sync API Class reference
TableValuedFunction Members
TableValuedFunction Class Methods Properties See Also Send Feedback

The TableValuedFunction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure. (Inherited from TextFunction.)

See Also

TableValuedFunction Class


TableValuedFunction Methods

[image] [image]

SQL Schema Sync API Class reference
TableValuedFunction Methods
TableValuedFunction Class See Also Send Feedback

The TableValuedFunction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

TableValuedFunction Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
TableValuedFunction..::.SetExecuteAsClause Method
TableValuedFunction Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context. (Inherited from FunctionBase.)
SetExecuteAsClause(String) | Sets the function security context. (Inherited from FunctionBase.)

See Also

TableValuedFunction Class
TableValuedFunction Members


TableValuedFunction Properties

[image] [image]

SQL Schema Sync API Class reference
TableValuedFunction Properties
TableValuedFunction Class See Also Send Feedback

The TableValuedFunction type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure. (Inherited from TextFunction.)

See Also

TableValuedFunction Class


TessellationSchema Enumeration

[image]

SQL Schema Sync API Class reference
TessellationSchema Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PerpetuumSoft.DataModel.MsSql.TessellationSchema"]

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum TessellationSchema
Visual Basic (Declaration)
Public Enumeration TessellationSchema
Visual C++
public enum class TessellationSchema

Members

Member name | Description
Geometry |
Geopraphy |

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


TextFunction Class

[image]

SQL Schema Sync API Class reference
TextFunction Class
Members See Also Send Feedback
Basic class for functions and stored procedures.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class TextFunction : FunctionBase
Visual Basic (Declaration)
Public MustInherit Class TextFunction _
    Inherits FunctionBase
Visual C++
public ref class TextFunction abstract : public FunctionBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.FunctionBase
PerpetuumSoft.DataModel.MsSql..::.TextFunction
PerpetuumSoft.DataModel.MsSql..::.ScalarFunction
PerpetuumSoft.DataModel.MsSql..::.StoredProcedure
PerpetuumSoft.DataModel.MsSql..::.TableValuedFunction

See Also

TextFunction Members


TextFunction Members

[image] [image]

SQL Schema Sync API Class reference
TextFunction Members
TextFunction Class Methods Properties See Also Send Feedback

The TextFunction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure.

See Also

TextFunction Class


TextFunction Methods

[image] [image]

SQL Schema Sync API Class reference
TextFunction Methods
TextFunction Class See Also Send Feedback

The TextFunction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
SetExecuteAsClause | Overloaded.
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

TextFunction Class


SetExecuteAsClause Method

[image] [image]

SQL Schema Sync API Class reference
TextFunction..::.SetExecuteAsClause Method
TextFunction Class See Also Send Feedback

Overload List

Name | Description
SetExecuteAsClause(ExecuteAsClause) | Sets the function security context. (Inherited from FunctionBase.)
SetExecuteAsClause(String) | Sets the function security context. (Inherited from FunctionBase.)

See Also

TextFunction Class
TextFunction Members


TextFunction Properties

[image] [image]

SQL Schema Sync API Class reference
TextFunction Properties
TextFunction Class See Also Send Feedback

The TextFunction type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExecuteAsClauseString | Gets or sets the function secure context. (Inherited from FunctionBase.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Parameters | Gets function parameters. (Inherited from FunctionBase.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets text of the function or stored procedure.

See Also

TextFunction Class


Text Property

[image]

SQL Schema Sync API Class reference
TextFunction..::.Text Property
TextFunction Class See Also Send Feedback
Gets or sets text of the function or stored procedure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

TextFunction Class


Trigger Class

[image]

SQL Schema Sync API Class reference
Trigger Class
Members See Also Send Feedback
Represents trigger in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Trigger : DatabaseObject,
    ISchemaObject
Visual Basic (Declaration)
Public NotInheritable Class Trigger _
    Inherits DatabaseObject _
    Implements ISchemaObject
Visual C++
public ref class Trigger sealed : public DatabaseObject,
    ISchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Trigger

See Also

Trigger Members


Trigger Members

[image] [image]

SQL Schema Sync API Class reference
Trigger Members
Trigger Class Constructors Methods Properties See Also Send Feedback

The Trigger type exposes the following members.

Constructors

Name | Description
Trigger | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Overrides Element..::.RelatesTo(Element).)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets the trigger extended properties.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema.
Table | Gets or sets a trigger table.
Text | Gets or sets a trigger text.

See Also

Trigger Class


Trigger Constructor

[image] [image]

SQL Schema Sync API Class reference
Trigger Constructor
Trigger Class See Also Send Feedback

Overload List

Name | Description
Trigger()()() | Initializes a new instance of the Trigger class.
Trigger(String, TableBase) | Initializes a new instance of the Trigger class.

See Also

Trigger Class
Trigger Members


Trigger Constructor

[image]

SQL Schema Sync API Class reference
Trigger Constructor
Trigger Class See Also Send Feedback
Initializes a new instance of the Trigger class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Trigger()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Trigger()

See Also

Trigger Class
Trigger Overload


Trigger Constructor (String, TableBase)

[image]

SQL Schema Sync API Class reference
Trigger Constructor (String, TableBase)
Trigger Class See Also Send Feedback
Initializes a new instance of the Trigger class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Trigger(
    string name,
    TableBase table
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    table As TableBase _
)
Visual C++
public:
Trigger(
    String^ name,
    TableBase^ table
)

Parameters

name
Type: System..::.String
table
Type: PerpetuumSoft.DataModel.MsSql..::.TableBase

See Also

Trigger Class
Trigger Overload


Trigger Methods

[image] [image]

SQL Schema Sync API Class reference
Trigger Methods
Trigger Class See Also Send Feedback

The Trigger type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Overrides Element..::.RelatesTo(Element).)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

Trigger Class


RelatesTo Method

[image]

SQL Schema Sync API Class reference
Trigger..::.RelatesTo Method
Trigger Class See Also Send Feedback
Overridden. See RelatesTo(Element).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool RelatesTo(
    Element element
)
Visual Basic (Declaration)
Public Overrides Function RelatesTo ( _
    element As Element _
) As Boolean
Visual C++
public:
virtual bool RelatesTo(
    Element^ element
) override

Parameters

element
Type: PerpetuumSoft.DataModel.MsSql..::.Element

See Also

Trigger Class


Trigger Properties

[image] [image]

SQL Schema Sync API Class reference
Trigger Properties
Trigger Class See Also Send Feedback

The Trigger type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets the trigger extended properties.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema.
Table | Gets or sets a trigger table.
Text | Gets or sets a trigger text.

See Also

Trigger Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
Trigger..::.ExtendedProperties Property
Trigger Class See Also Send Feedback
Implements ExtendedProperties()()(). Gets the trigger extended properties.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

Trigger Class


Schema Property

[image]

SQL Schema Sync API Class reference
Trigger..::.Schema Property
Trigger Class See Also Send Feedback
Implements Schema.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Schema Schema { get; }
Visual Basic (Declaration)
Public ReadOnly Property Schema As Schema
Visual C++
public:
virtual property Schema^ Schema {
    Schema^ get () sealed;
}

Implements

ISchemaObject..::.Schema

See Also

Trigger Class


Table Property

[image]

SQL Schema Sync API Class reference
Trigger..::.Table Property
Trigger Class See Also Send Feedback
Gets or sets a trigger table.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public TableBase Table { get; set; }
Visual Basic (Declaration)
Public Property Table As TableBase
Visual C++
public:
property TableBase^ Table {
    TableBase^ get ();
    void set (TableBase^ value);
}

See Also

Trigger Class


Text Property

[image]

SQL Schema Sync API Class reference
Trigger..::.Text Property
Trigger Class See Also Send Feedback
Gets or sets a trigger text.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Trigger Class


UniqueConstraint Class

[image]

SQL Schema Sync API Class reference
UniqueConstraint Class
Members See Also Send Feedback
Represents an unique constraint.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class UniqueConstraint : KeyConstraint
Visual Basic (Declaration)
Public NotInheritable Class UniqueConstraint _
    Inherits KeyConstraint
Visual C++
public ref class UniqueConstraint sealed : public KeyConstraint

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Constraint
PerpetuumSoft.DataModel.MsSql..::.KeyConstraint
PerpetuumSoft.DataModel.MsSql..::.UniqueConstraint

See Also

UniqueConstraint Members


UniqueConstraint Members

[image] [image]

SQL Schema Sync API Class reference
UniqueConstraint Members
UniqueConstraint Class Constructors Methods Properties See Also Send Feedback

The UniqueConstraint type exposes the following members.

Constructors

Name | Description
UniqueConstraint | Initializes a new instance of the UniqueConstraint class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
AllowPageLocks | Gets or sets the ALLOWPAGEROCK option. (Inherited from KeyConstraint.)
AllowRowLocks | Gets or sets the ALLOWROWLOCK option. (Inherited from KeyConstraint.)
Clustered | Gets or sets if a key index is clustered. (Inherited from KeyConstraint.)
Columns | Gets columns associated with the constraint. (Inherited from KeyConstraint.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FillFactor | Gets or sets a fill factor value. (Inherited from KeyConstraint.)
FullName | Gets the element full name. (Inherited from Element.)
IgnoreDupKey | Gets or sets if the key index should ignore the duplicated keys. (Inherited from KeyConstraint.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
PadIndex | Gets or sets a pad index value. (Inherited from KeyConstraint.)
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
StatisticNoRecompute | Gets or sets the StatisticNoRecompute option. (Inherited from KeyConstraint.)
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)

See Also

UniqueConstraint Class


UniqueConstraint Constructor

[image]

SQL Schema Sync API Class reference
UniqueConstraint Constructor
UniqueConstraint Class See Also Send Feedback
Initializes a new instance of the UniqueConstraint class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UniqueConstraint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UniqueConstraint()

See Also

UniqueConstraint Class


UniqueConstraint Methods

[image] [image]

SQL Schema Sync API Class reference
UniqueConstraint Methods
UniqueConstraint Class See Also Send Feedback

The UniqueConstraint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from Constraint.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

UniqueConstraint Class


UniqueConstraint Properties

[image] [image]

SQL Schema Sync API Class reference
UniqueConstraint Properties
UniqueConstraint Class See Also Send Feedback

The UniqueConstraint type exposes the following members.

Properties

Name | Description
AllowPageLocks | Gets or sets the ALLOWPAGEROCK option. (Inherited from KeyConstraint.)
AllowRowLocks | Gets or sets the ALLOWROWLOCK option. (Inherited from KeyConstraint.)
Clustered | Gets or sets if a key index is clustered. (Inherited from KeyConstraint.)
Columns | Gets columns associated with the constraint. (Inherited from KeyConstraint.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
FillFactor | Gets or sets a fill factor value. (Inherited from KeyConstraint.)
FullName | Gets the element full name. (Inherited from Element.)
IgnoreDupKey | Gets or sets if the key index should ignore the duplicated keys. (Inherited from KeyConstraint.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
PadIndex | Gets or sets a pad index value. (Inherited from KeyConstraint.)
Schema | Implements Schema. Returns schema object associated with Constraint. (Inherited from Constraint.)
StatisticNoRecompute | Gets or sets the StatisticNoRecompute option. (Inherited from KeyConstraint.)
Table | Gets or sets Table associated with constraint. (Inherited from Constraint.)

See Also

UniqueConstraint Class


User Class

[image]

SQL Schema Sync API Class reference
User Class
Members See Also Send Feedback
Represents user in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class User : Principal
Visual Basic (Declaration)
Public NotInheritable Class User _
    Inherits Principal
Visual C++
public ref class User sealed : public Principal

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.Principal
PerpetuumSoft.DataModel.MsSql..::.User

See Also

User Members


User Members

[image] [image]

SQL Schema Sync API Class reference
User Members
User Class Constructors Methods Properties See Also Send Feedback

The User type exposes the following members.

Constructors

Name | Description
User | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualsTo | Override. See IsEqualsTo(Principal). (Overrides Principal..::.IsEqualsTo(Principal).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
AsymmetricKey | Gets or sets the name of the user asymmetric key.
Certificate | Gets or sets user certificate name.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DefaultSchema | Gets or sets default schema for this user.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets the user extended properties.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Login | Gets or sets the user login.
Name | Gets or sets an element name. (Inherited from Element.)
Permissions | Gets permissions on all securable objects for this Principal. (Inherited from Principal.)
UserType | Gets or sets user type.

See Also

User Class


User Constructor

[image] [image]

SQL Schema Sync API Class reference
User Constructor
User Class See Also Send Feedback

Overload List

Name | Description
User()()() | Creates new instance of the User class.
User(String) | Creates new instance of the User class.
User(String, UserType) | Creates new instance of the User class.

See Also

User Class
User Members


User Constructor

[image]

SQL Schema Sync API Class reference
User Constructor
User Class See Also Send Feedback
Creates new instance of the User class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public User()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
User()

See Also

User Class
User Overload


User Constructor (String)

[image]

SQL Schema Sync API Class reference
User Constructor (String)
User Class See Also Send Feedback
Creates new instance of the User class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public User(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
User(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

User Class
User Overload


User Constructor (String, UserType)

[image]

SQL Schema Sync API Class reference
User Constructor (String, UserType)
User Class See Also Send Feedback
Creates new instance of the User class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public User(
    string name,
    UserType userType
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    userType As UserType _
)
Visual C++
public:
User(
    String^ name,
    UserType userType
)

Parameters

name
Type: System..::.String
userType
Type: PerpetuumSoft.DataModel.MsSql..::.UserType

See Also

User Class
User Overload


User Methods

[image] [image]

SQL Schema Sync API Class reference
User Methods
User Class See Also Send Feedback

The User type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualsTo | Override. See IsEqualsTo(Principal). (Overrides Principal..::.IsEqualsTo(Principal).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

User Class


IsEqualsTo Method

[image]

SQL Schema Sync API Class reference
User..::.IsEqualsTo Method
User Class See Also Send Feedback
Override. See IsEqualsTo(Principal).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool IsEqualsTo(
    Principal principal
)
Visual Basic (Declaration)
Public Overrides Function IsEqualsTo ( _
    principal As Principal _
) As Boolean
Visual C++
public:
virtual bool IsEqualsTo(
    Principal^ principal
) override

Parameters

principal
Type: PerpetuumSoft.DataModel.MsSql..::.Principal

See Also

User Class


User Properties

[image] [image]

SQL Schema Sync API Class reference
User Properties
User Class See Also Send Feedback

The User type exposes the following members.

Properties

Name | Description
AsymmetricKey | Gets or sets the name of the user asymmetric key.
Certificate | Gets or sets user certificate name.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DefaultSchema | Gets or sets default schema for this user.
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets the user extended properties.
FullName | Gets the element full name. (Inherited from Element.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Login | Gets or sets the user login.
Name | Gets or sets an element name. (Inherited from Element.)
Permissions | Gets permissions on all securable objects for this Principal. (Inherited from Principal.)
UserType | Gets or sets user type.

See Also

User Class


AsymmetricKey Property

[image]

SQL Schema Sync API Class reference
User..::.AsymmetricKey Property
User Class See Also Send Feedback
Gets or sets the name of the user asymmetric key.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string AsymmetricKey { get; set; }
Visual Basic (Declaration)
Public Property AsymmetricKey As String
Visual C++
public:
property String^ AsymmetricKey {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


Certificate Property

[image]

SQL Schema Sync API Class reference
User..::.Certificate Property
User Class See Also Send Feedback
Gets or sets user certificate name.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Certificate { get; set; }
Visual Basic (Declaration)
Public Property Certificate As String
Visual C++
public:
property String^ Certificate {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


DefaultSchema Property

[image]

SQL Schema Sync API Class reference
User..::.DefaultSchema Property
User Class See Also Send Feedback
Gets or sets default schema for this user.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Schema DefaultSchema { get; set; }
Visual Basic (Declaration)
Public Property DefaultSchema As Schema
Visual C++
public:
property Schema^ DefaultSchema {
    Schema^ get ();
    void set (Schema^ value);
}

See Also

User Class


ExtendedProperties Property

[image]

SQL Schema Sync API Class reference
User..::.ExtendedProperties Property
User Class See Also Send Feedback
Implements ExtendedProperties()()(). Gets the user extended properties.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ExtendedPropertyCollection ExtendedProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedPropertyCollection
Visual C++
public:
virtual property ExtendedPropertyCollection^ ExtendedProperties {
    ExtendedPropertyCollection^ get () sealed;
}

See Also

User Class


Login Property

[image]

SQL Schema Sync API Class reference
User..::.Login Property
User Class See Also Send Feedback
Gets or sets the user login.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Login { get; set; }
Visual Basic (Declaration)
Public Property Login As String
Visual C++
public:
property String^ Login {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


UserType Property

[image]

SQL Schema Sync API Class reference
User..::.UserType Property
User Class See Also Send Feedback
Gets or sets user type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UserType UserType { get; set; }
Visual Basic (Declaration)
Public Property UserType As UserType
Visual C++
public:
property UserType UserType {
    UserType get ();
    void set (UserType value);
}

See Also

User Class


UserDefinedType Class

[image]

SQL Schema Sync API Class reference
UserDefinedType Class
Members See Also Send Feedback
Represents a user defined type in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class UserDefinedType : SchemaObject,
    ISupportRulesDefaults
Visual Basic (Declaration)
Public NotInheritable Class UserDefinedType _
    Inherits SchemaObject _
    Implements ISupportRulesDefaults
Visual C++
public ref class UserDefinedType sealed : public SchemaObject,
    ISupportRulesDefaults

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.UserDefinedType

See Also

UserDefinedType Members


UserDefinedType Members

[image] [image]

SQL Schema Sync API Class reference
UserDefinedType Members
UserDefinedType Class Constructors Methods Properties See Also Send Feedback

The UserDefinedType type exposes the following members.

Constructors

Name | Description
UserDefinedType | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
AllowNulls | Gets or sets if a type allows nulls.
BaseType | Gets or sets a base type.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Gets full name of the user defined type. (Overrides SchemaObject..::.FullName.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

UserDefinedType Class


UserDefinedType Constructor

[image] [image]

SQL Schema Sync API Class reference
UserDefinedType Constructor
UserDefinedType Class See Also Send Feedback

Overload List

Name | Description
UserDefinedType()()() | Initializes a new instance of the UserDefinedType class.
UserDefinedType(String, Schema, DataType) | Creates new instance of the UserDefinedType class.

See Also

UserDefinedType Class
UserDefinedType Members


UserDefinedType Constructor

[image]

SQL Schema Sync API Class reference
UserDefinedType Constructor
UserDefinedType Class See Also Send Feedback
Initializes a new instance of the UserDefinedType class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UserDefinedType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserDefinedType()

See Also

UserDefinedType Class
UserDefinedType Overload


UserDefinedType Constructor (String, Schema, DataType)

[image]

SQL Schema Sync API Class reference
UserDefinedType Constructor (String, Schema, DataType)
UserDefinedType Class See Also Send Feedback
Creates new instance of the UserDefinedType class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public UserDefinedType(
    string name,
    Schema schema,
    DataType baseType
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    schema As Schema, _
    baseType As DataType _
)
Visual C++
public:
UserDefinedType(
    String^ name,
    Schema^ schema,
    DataType^ baseType
)

Parameters

name
Type: System..::.String
schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema
baseType
Type: PerpetuumSoft.DataModel.MsSql..::.DataType

See Also

UserDefinedType Class
UserDefinedType Overload


UserDefinedType Methods

[image] [image]

SQL Schema Sync API Class reference
UserDefinedType Methods
UserDefinedType Class See Also Send Feedback

The UserDefinedType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

UserDefinedType Class


UserDefinedType Properties

[image] [image]

SQL Schema Sync API Class reference
UserDefinedType Properties
UserDefinedType Class See Also Send Feedback

The UserDefinedType type exposes the following members.

Properties

Name | Description
AllowNulls | Gets or sets if a type allows nulls.
BaseType | Gets or sets a base type.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Gets full name of the user defined type. (Overrides SchemaObject..::.FullName.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)

See Also

UserDefinedType Class


AllowNulls Property

[image]

SQL Schema Sync API Class reference
UserDefinedType..::.AllowNulls Property
UserDefinedType Class See Also Send Feedback
Gets or sets if a type allows nulls.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowNulls { get; set; }
Visual Basic (Declaration)
Public Property AllowNulls As Boolean
Visual C++
public:
property bool AllowNulls {
    bool get ();
    void set (bool value);
}

See Also

UserDefinedType Class


BaseType Property

[image]

SQL Schema Sync API Class reference
UserDefinedType..::.BaseType Property
UserDefinedType Class See Also Send Feedback
Gets or sets a base type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DataType BaseType { get; set; }
Visual Basic (Declaration)
Public Property BaseType As DataType
Visual C++
public:
property DataType^ BaseType {
    DataType^ get ();
    void set (DataType^ value);
}

See Also

UserDefinedType Class


FullName Property

[image]

SQL Schema Sync API Class reference
UserDefinedType..::.FullName Property
UserDefinedType Class See Also Send Feedback
Gets full name of the user defined type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string FullName { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property FullName As String
Visual C++
public:
virtual property String^ FullName {
    String^ get () override;
}

Implements

ISecurable..::.FullName

See Also

UserDefinedType Class


UserType Enumeration

[image]

SQL Schema Sync API Class reference
UserType Enumeration
See Also Send Feedback
Represents user type in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum UserType
Visual Basic (Declaration)
Public Enumeration UserType
Visual C++
public enum class UserType

Members

Member name | Description
SQLUser | SQL user.
WindowsUser | Windows user.
CertificateUser | Certificate user.
AsymetricKeyUser | AsymetricKeyUser.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


View Class

[image]

SQL Schema Sync API Class reference
View Class
Members See Also Send Feedback
Represents a view in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class View : TableBase
Visual Basic (Declaration)
Public NotInheritable Class View _
    Inherits TableBase
Visual C++
public ref class View sealed : public TableBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.TableBase
PerpetuumSoft.DataModel.MsSql..::.View

See Also

View Members


View Members

[image] [image]

SQL Schema Sync API Class reference
View Members
View Class Constructors Methods Properties See Also Send Feedback

The View type exposes the following members.

Constructors

Name | Description
View | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Columns | Gets table columns. (Inherited from TableBase.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets a view sql text.

See Also

View Class


View Constructor

[image] [image]

SQL Schema Sync API Class reference
View Constructor
View Class See Also Send Feedback

Overload List

Name | Description
View()()() | Initializes a new instance of the View class.
View(String, Schema) | Creates new instance of the View class.

See Also

View Class
View Members


View Constructor

[image]

SQL Schema Sync API Class reference
View Constructor
View Class See Also Send Feedback
Initializes a new instance of the View class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public View()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
View()

See Also

View Class
View Overload


View Constructor (String, Schema)

[image]

SQL Schema Sync API Class reference
View Constructor (String, Schema)
View Class See Also Send Feedback
Creates new instance of the View class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public View(
    string name,
    Schema schema
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    schema As Schema _
)
Visual C++
public:
View(
    String^ name,
    Schema^ schema
)

Parameters

name
Type: System..::.String
schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema

See Also

View Class
View Overload


View Methods

[image] [image]

SQL Schema Sync API Class reference
View Methods
View Class See Also Send Feedback

The View type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

View Class


View Properties

[image] [image]

SQL Schema Sync API Class reference
View Properties
View Class See Also Send Feedback

The View type exposes the following members.

Properties

Name | Description
Columns | Gets table columns. (Inherited from TableBase.)
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets a view sql text.

See Also

View Class


Text Property

[image]

SQL Schema Sync API Class reference
View..::.Text Property
View Class See Also Send Feedback
Gets or sets a view sql text.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

View Class


ViewColumn Class

[image]

SQL Schema Sync API Class reference
ViewColumn Class
Members See Also Send Feedback
Represents a column in a view.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ViewColumn : ColumnBase
Visual Basic (Declaration)
Public NotInheritable Class ViewColumn _
    Inherits ColumnBase
Visual C++
public ref class ViewColumn sealed : public ColumnBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.ColumnBase
PerpetuumSoft.DataModel.MsSql..::.ViewColumn

See Also

ViewColumn Members


ViewColumn Members

[image] [image]

SQL Schema Sync API Class reference
ViewColumn Members
ViewColumn Class Constructors Methods Properties See Also Send Feedback

The ViewColumn type exposes the following members.

Constructors

Name | Description
ViewColumn | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Overridden. See ToString()()(). (Overrides ColumnBase..::.ToString()()().)
TypeEquals | Override. See TypeEquals(ColumnBase). (Overrides ColumnBase..::.TypeEquals(ColumnBase).)

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values. (Inherited from ColumnBase.)
DataType | Gets or sets DataType of a column. (Inherited from ColumnBase.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for a column. (Inherited from ColumnBase.)
FullName | Gets full name of the column. (Inherited from ColumnBase.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets TableBase which contains a column. (Inherited from ColumnBase.)

See Also

ViewColumn Class


ViewColumn Constructor

[image] [image]

SQL Schema Sync API Class reference
ViewColumn Constructor
ViewColumn Class See Also Send Feedback

Overload List

Name | Description
ViewColumn()()() | Initializes a new instance of the ViewColumn class.
ViewColumn(String) | Initializes a new instance of the ViewColumn class.
ViewColumn(String, DataType) | Creates new instance of the ViewColumn class.

See Also

ViewColumn Class
ViewColumn Members


ViewColumn Constructor

[image]

SQL Schema Sync API Class reference
ViewColumn Constructor
ViewColumn Class See Also Send Feedback
Initializes a new instance of the ViewColumn class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ViewColumn()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewColumn()

See Also

ViewColumn Class
ViewColumn Overload


ViewColumn Constructor (String)

[image]

SQL Schema Sync API Class reference
ViewColumn Constructor (String)
ViewColumn Class See Also Send Feedback
Initializes a new instance of the ViewColumn class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ViewColumn(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
ViewColumn(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

ViewColumn Class
ViewColumn Overload


ViewColumn Constructor (String, DataType)

[image]

SQL Schema Sync API Class reference
ViewColumn Constructor (String, DataType)
ViewColumn Class See Also Send Feedback
Creates new instance of the ViewColumn class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ViewColumn(
    string name,
    DataType dataType
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    dataType As DataType _
)
Visual C++
public:
ViewColumn(
    String^ name,
    DataType^ dataType
)

Parameters

name
Type: System..::.String
dataType
Type: PerpetuumSoft.DataModel.MsSql..::.DataType

See Also

ViewColumn Class
ViewColumn Overload


ViewColumn Methods

[image] [image]

SQL Schema Sync API Class reference
ViewColumn Methods
ViewColumn Class See Also Send Feedback

The ViewColumn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Checks if an argument represents the same element in the compared database. (Inherited from Element.)
ToString | Overridden. See ToString()()(). (Overrides ColumnBase..::.ToString()()().)
TypeEquals | Override. See TypeEquals(ColumnBase). (Overrides ColumnBase..::.TypeEquals(ColumnBase).)

See Also

ViewColumn Class


ToString Method

[image]

SQL Schema Sync API Class reference
ViewColumn..::.ToString Method
ViewColumn Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ViewColumn Class


TypeEquals Method

[image]

SQL Schema Sync API Class reference
ViewColumn..::.TypeEquals Method
ViewColumn Class See Also Send Feedback
Override. See TypeEquals(ColumnBase).

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override bool TypeEquals(
    ColumnBase other
)
Visual Basic (Declaration)
Public Overrides Function TypeEquals ( _
    other As ColumnBase _
) As Boolean
Visual C++
public:
virtual bool TypeEquals(
    ColumnBase^ other
) override

Parameters

other
Type: PerpetuumSoft.DataModel.MsSql..::.ColumnBase

See Also

ViewColumn Class


ViewColumn Properties

[image] [image]

SQL Schema Sync API Class reference
ViewColumn Properties
ViewColumn Class See Also Send Feedback

The ViewColumn type exposes the following members.

Properties

Name | Description
AllowNulls | If the property value is true, then the column can contain Null values. (Inherited from ColumnBase.)
DataType | Gets or sets DataType of a column. (Inherited from ColumnBase.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Gets ExtendedProperties for a column. (Inherited from ColumnBase.)
FullName | Gets full name of the column. (Inherited from ColumnBase.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Owner | Gets TableBase which contains a column. (Inherited from ColumnBase.)

See Also

ViewColumn Class


XmlIndex Class

[image]

SQL Schema Sync API Class reference
XmlIndex Class
Members See Also Send Feedback
Represents xml index in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class XmlIndex : IndexBase
Visual Basic (Declaration)
Public NotInheritable Class XmlIndex _
    Inherits IndexBase
Visual C++
public ref class XmlIndex sealed : public IndexBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.IndexBase
PerpetuumSoft.DataModel.MsSql..::.XmlIndex

See Also

XmlIndex Members


XmlIndex Members

[image] [image]

SQL Schema Sync API Class reference
XmlIndex Members
XmlIndex Class Constructors Methods Properties See Also Send Feedback

The XmlIndex type exposes the following members.

Constructors

Name | Description
XmlIndex | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from IndexBase.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
AllowPageLocks | Gets or sets true value if xml-index allows pages lock.
AllowRowLock | Gets or sets the ALLOWROWLOCK option.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). (Inherited from IndexBase.)
FillFactor | Gets or sets the FILLFACTOR option.
FullName | Gets the element full name. (Inherited from Element.)
IndexType | Gets or sets an index type.
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MaxDop | Gets or sets the MAXDOP option.
Name | Gets or sets an element name. (Inherited from Element.)
PadIndex | Gets or sets the PADINDEX option.
Primary | Gets or sets whether the index is primary.
Schema | Implements Schema. (Inherited from IndexBase.)
SortInTempDb | Gets or sets the SORTINTEMPDB option.
StatisticNoRecompute | Gets or sets the STATISTICSNORECOMPUTE option.
Table | Gets or sets TableBase. (Inherited from IndexBase.)
UsingXmlIndex | Gets or sets the used xml index.
XmlColumn | Gets or sets the corresponding xml colunm.

See Also

XmlIndex Class


XmlIndex Constructor

[image] [image]

SQL Schema Sync API Class reference
XmlIndex Constructor
XmlIndex Class See Also Send Feedback

Overload List

Name | Description
XmlIndex()()() | Initializes a new instance of the XmlIndex class.
XmlIndex(String, Table) | Creates new instance of the XmlIndex class.

See Also

XmlIndex Class
XmlIndex Members


XmlIndex Constructor

[image]

SQL Schema Sync API Class reference
XmlIndex Constructor
XmlIndex Class See Also Send Feedback
Initializes a new instance of the XmlIndex class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public XmlIndex()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XmlIndex()

See Also

XmlIndex Class
XmlIndex Overload


XmlIndex Constructor (String, Table)

[image]

SQL Schema Sync API Class reference
XmlIndex Constructor (String, Table)
XmlIndex Class See Also Send Feedback
Creates new instance of the XmlIndex class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public XmlIndex(
    string name,
    Table table
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    table As Table _
)
Visual C++
public:
XmlIndex(
    String^ name,
    Table^ table
)

Parameters

name
Type: System..::.String
table
Type: PerpetuumSoft.DataModel.MsSql..::.Table

See Also

XmlIndex Class
XmlIndex Overload


XmlIndex Methods

[image] [image]

SQL Schema Sync API Class reference
XmlIndex Methods
XmlIndex Class See Also Send Feedback

The XmlIndex type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from IndexBase.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

XmlIndex Class


XmlIndex Properties

[image] [image]

SQL Schema Sync API Class reference
XmlIndex Properties
XmlIndex Class See Also Send Feedback

The XmlIndex type exposes the following members.

Properties

Name | Description
AllowPageLocks | Gets or sets true value if xml-index allows pages lock.
AllowRowLock | Gets or sets the ALLOWROWLOCK option.
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). (Inherited from IndexBase.)
FillFactor | Gets or sets the FILLFACTOR option.
FullName | Gets the element full name. (Inherited from Element.)
IndexType | Gets or sets an index type.
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
MaxDop | Gets or sets the MAXDOP option.
Name | Gets or sets an element name. (Inherited from Element.)
PadIndex | Gets or sets the PADINDEX option.
Primary | Gets or sets whether the index is primary.
Schema | Implements Schema. (Inherited from IndexBase.)
SortInTempDb | Gets or sets the SORTINTEMPDB option.
StatisticNoRecompute | Gets or sets the STATISTICSNORECOMPUTE option.
Table | Gets or sets TableBase. (Inherited from IndexBase.)
UsingXmlIndex | Gets or sets the used xml index.
XmlColumn | Gets or sets the corresponding xml colunm.

See Also

XmlIndex Class


AllowPageLocks Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.AllowPageLocks Property
XmlIndex Class See Also Send Feedback
Gets or sets true value if xml-index allows pages lock.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowPageLocks { get; set; }
Visual Basic (Declaration)
Public Property AllowPageLocks As Boolean
Visual C++
public:
property bool AllowPageLocks {
    bool get ();
    void set (bool value);
}

See Also

XmlIndex Class


AllowRowLock Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.AllowRowLock Property
XmlIndex Class See Also Send Feedback
Gets or sets the ALLOWROWLOCK option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool AllowRowLock { get; set; }
Visual Basic (Declaration)
Public Property AllowRowLock As Boolean
Visual C++
public:
property bool AllowRowLock {
    bool get ();
    void set (bool value);
}

See Also

XmlIndex Class


FillFactor Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.FillFactor Property
XmlIndex Class See Also Send Feedback
Gets or sets the FILLFACTOR option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int FillFactor { get; set; }
Visual Basic (Declaration)
Public Property FillFactor As Integer
Visual C++
public:
property int FillFactor {
    int get ();
    void set (int value);
}

See Also

XmlIndex Class


IndexType Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.IndexType Property
XmlIndex Class See Also Send Feedback
Gets or sets an index type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public XmlIndexType IndexType { get; set; }
Visual Basic (Declaration)
Public Property IndexType As XmlIndexType
Visual C++
public:
property XmlIndexType IndexType {
    XmlIndexType get ();
    void set (XmlIndexType value);
}

See Also

XmlIndex Class


MaxDop Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.MaxDop Property
XmlIndex Class See Also Send Feedback
Gets or sets the MAXDOP option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int MaxDop { get; set; }
Visual Basic (Declaration)
Public Property MaxDop As Integer
Visual C++
public:
property int MaxDop {
    int get ();
    void set (int value);
}

See Also

XmlIndex Class


PadIndex Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.PadIndex Property
XmlIndex Class See Also Send Feedback
Gets or sets the PADINDEX option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool PadIndex { get; set; }
Visual Basic (Declaration)
Public Property PadIndex As Boolean
Visual C++
public:
property bool PadIndex {
    bool get ();
    void set (bool value);
}

See Also

XmlIndex Class


Primary Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.Primary Property
XmlIndex Class See Also Send Feedback
Gets or sets whether the index is primary.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool Primary { get; set; }
Visual Basic (Declaration)
Public Property Primary As Boolean
Visual C++
public:
property bool Primary {
    bool get ();
    void set (bool value);
}

See Also

XmlIndex Class


SortInTempDb Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.SortInTempDb Property
XmlIndex Class See Also Send Feedback
Gets or sets the SORTINTEMPDB option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool SortInTempDb { get; set; }
Visual Basic (Declaration)
Public Property SortInTempDb As Boolean
Visual C++
public:
property bool SortInTempDb {
    bool get ();
    void set (bool value);
}

See Also

XmlIndex Class


StatisticNoRecompute Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.StatisticNoRecompute Property
XmlIndex Class See Also Send Feedback
Gets or sets the STATISTICSNORECOMPUTE option.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool StatisticNoRecompute { get; set; }
Visual Basic (Declaration)
Public Property StatisticNoRecompute As Boolean
Visual C++
public:
property bool StatisticNoRecompute {
    bool get ();
    void set (bool value);
}

See Also

XmlIndex Class


UsingXmlIndex Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.UsingXmlIndex Property
XmlIndex Class See Also Send Feedback
Gets or sets the used xml index.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public XmlIndex UsingXmlIndex { get; set; }
Visual Basic (Declaration)
Public Property UsingXmlIndex As XmlIndex
Visual C++
public:
property XmlIndex^ UsingXmlIndex {
    XmlIndex^ get ();
    void set (XmlIndex^ value);
}

See Also

XmlIndex Class


XmlColumn Property

[image]

SQL Schema Sync API Class reference
XmlIndex..::.XmlColumn Property
XmlIndex Class See Also Send Feedback
Gets or sets the corresponding xml colunm.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ColumnBase XmlColumn { get; set; }
Visual Basic (Declaration)
Public Property XmlColumn As ColumnBase
Visual C++
public:
property ColumnBase^ XmlColumn {
    ColumnBase^ get ();
    void set (ColumnBase^ value);
}

See Also

XmlIndex Class


XmlIndexType Enumeration

[image]

SQL Schema Sync API Class reference
XmlIndexType Enumeration
See Also Send Feedback
Represents xml index type.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum XmlIndexType
Visual Basic (Declaration)
Public Enumeration XmlIndexType
Visual C++
public enum class XmlIndexType

Members

Member name | Description
Value | Value.
Path | Path.
Property | Property.

See Also

PerpetuumSoft.DataModel.MsSql Namespace

Send comments on this topic to support@perpetuumsoft.com

(c) 2009 Perpetuum Software LLC


XmlSchemaCollection Class

[image]

SQL Schema Sync API Class reference
XmlSchemaCollection Class
Members See Also Send Feedback
Represents collection of xml schemas in the database structure.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class XmlSchemaCollection : SchemaObject
Visual Basic (Declaration)
Public NotInheritable Class XmlSchemaCollection _
    Inherits SchemaObject
Visual C++
public ref class XmlSchemaCollection sealed : public SchemaObject

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql..::.Element
PerpetuumSoft.DataModel.MsSql..::.DatabaseObject
PerpetuumSoft.DataModel.MsSql..::.SchemaObject
PerpetuumSoft.DataModel.MsSql..::.XmlSchemaCollection

See Also

XmlSchemaCollection Members


XmlSchemaCollection Members

[image] [image]

SQL Schema Sync API Class reference
XmlSchemaCollection Members
XmlSchemaCollection Class Constructors Methods Properties See Also Send Feedback

The XmlSchemaCollection type exposes the following members.

Constructors

Name | Description
XmlSchemaCollection | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualsTo | Gets true value if xml schemas are equal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets content of the XmlSchemaCollection.

See Also

XmlSchemaCollection Class


XmlSchemaCollection Constructor

[image] [image]

SQL Schema Sync API Class reference
XmlSchemaCollection Constructor
XmlSchemaCollection Class See Also Send Feedback

Overload List

Name | Description
XmlSchemaCollection()()() | Creates new instance of the XmlSchemaCollection class.
XmlSchemaCollection(String, Schema) | Creates new instance of the XmlSchemaCollection class.
XmlSchemaCollection(String, Schema, String) | Creates new instance of the XmlSchemaCollection class.

See Also

XmlSchemaCollection Class
XmlSchemaCollection Members


XmlSchemaCollection Constructor

[image]

SQL Schema Sync API Class reference
XmlSchemaCollection Constructor
XmlSchemaCollection Class See Also Send Feedback
Creates new instance of the XmlSchemaCollection class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public XmlSchemaCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XmlSchemaCollection()

See Also

XmlSchemaCollection Class
XmlSchemaCollection Overload


XmlSchemaCollection Constructor (String, Schema)

[image]

SQL Schema Sync API Class reference
XmlSchemaCollection Constructor (String, Schema)
XmlSchemaCollection Class See Also Send Feedback
Creates new instance of the XmlSchemaCollection class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public XmlSchemaCollection(
    string name,
    Schema schema
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    schema As Schema _
)
Visual C++
public:
XmlSchemaCollection(
    String^ name,
    Schema^ schema
)

Parameters

name
Type: System..::.String
schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema

See Also

XmlSchemaCollection Class
XmlSchemaCollection Overload


XmlSchemaCollection Constructor (String, Schema, String)

[image]

SQL Schema Sync API Class reference
XmlSchemaCollection Constructor (String, Schema, String)
XmlSchemaCollection Class See Also Send Feedback
Creates new instance of the XmlSchemaCollection class.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public XmlSchemaCollection(
    string name,
    Schema schema,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    schema As Schema, _
    text As String _
)
Visual C++
public:
XmlSchemaCollection(
    String^ name,
    Schema^ schema,
    String^ text
)

Parameters

name
Type: System..::.String
schema
Type: PerpetuumSoft.DataModel.MsSql..::.Schema
text
Type: System..::.String

See Also

XmlSchemaCollection Class
XmlSchemaCollection Overload


XmlSchemaCollection Methods

[image] [image]

SQL Schema Sync API Class reference
XmlSchemaCollection Methods
XmlSchemaCollection Class See Also Send Feedback

The XmlSchemaCollection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsEqualsTo | Gets true value if xml schemas are equal.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RelatesTo | Overridden. See RelatesTo(Element). (Inherited from SchemaObject.)
ToString | Override. See ToString()()(). Gets element name. (Inherited from Element.)

See Also

XmlSchemaCollection Class


IsEqualsTo Method

[image]

SQL Schema Sync API Class reference
XmlSchemaCollection..::.IsEqualsTo Method
XmlSchemaCollection Class See Also Send Feedback
Gets true value if xml schemas are equal.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEqualsTo(
    XmlSchemaCollection obj
)
Visual Basic (Declaration)
Public Function IsEqualsTo ( _
    obj As XmlSchemaCollection _
) As Boolean
Visual C++
public:
bool IsEqualsTo(
    XmlSchemaCollection^ obj
)

Parameters

obj
Type: PerpetuumSoft.DataModel.MsSql..::.XmlSchemaCollection

See Also

XmlSchemaCollection Class


XmlSchemaCollection Properties

[image] [image]

SQL Schema Sync API Class reference
XmlSchemaCollection Properties
XmlSchemaCollection Class See Also Send Feedback

The XmlSchemaCollection type exposes the following members.

Properties

Name | Description
Database | Gets the Database owner. (Inherited from DatabaseObject.)
DependOn | Gets a collection of the element dependencies. (Inherited from Element.)
ExtendedProperties | Implements ExtendedProperties()()(). Gets extended properties for the objects shema. (Inherited from SchemaObject.)
FullName | Override. See FullName. (Inherited from SchemaObject.)
IsSystem | Gets or sets true value if the object is of system type. (Inherited from Element.)
Name | Gets or sets an element name. (Inherited from Element.)
Schema | Implements Schema. (Inherited from SchemaObject.)
Text | Gets or sets content of the XmlSchemaCollection.

See Also

XmlSchemaCollection Class


Text Property

[image]

SQL Schema Sync API Class reference
XmlSchemaCollection..::.Text Property
XmlSchemaCollection Class See Also Send Feedback
Gets or sets content of the XmlSchemaCollection.

Namespace: PerpetuumSoft.DataModel.MsSql
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

XmlSchemaCollection Class


PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace

[image]

SQL Schema Sync API Class reference
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace
Send Feedback
Namespace PerpetuumSoft.DataModel.MsSql.Synchronizers contains classes used for synchronization of database objects.

Classes

Class | Description
DatabaseSynchronizer | Manages synchronizers for database objects.
Script | Represents the DDL script.
ScriptSection | Represents scritpts section.
Synchronizer | Performs comparison and builds synchronization script for database elements.
SynchronizerCollection<(Of <(T>)>) | Represents a collection of Synchronizer.

Enumerations

Enumeration | Description
SynchronizerAction | Represents synchronization action.
SynchronizerState | Represents synchronizer state.


DatabaseSynchronizer Class

[image]

SQL Schema Sync API Class reference
DatabaseSynchronizer Class
Members See Also Send Feedback
Manages synchronizers for database objects.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class DatabaseSynchronizer
Visual Basic (Declaration)
Public NotInheritable Class DatabaseSynchronizer
Visual C++
public ref class DatabaseSynchronizer sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql.Synchronizers..::.DatabaseSynchronizer

See Also

DatabaseSynchronizer Members
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


DatabaseSynchronizer Members

[image] [image]

SQL Schema Sync API Class reference
DatabaseSynchronizer Members
DatabaseSynchronizer Class Methods Properties See Also Send Feedback

The DatabaseSynchronizer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseScriptsText | Gets text of scripts synchronizing database properies, permissions, etc.
NewDatabase | Gets a new database structure.
OldDatabase | Gets an old database structure.
Options | Gets or sets database synchronization options.
Scripts | Gets the synchronization scripts collection.
Synchronizers | Get synchonizers collection.

See Also

DatabaseSynchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


DatabaseSynchronizer Methods

[image] [image]

SQL Schema Sync API Class reference
DatabaseSynchronizer Methods
DatabaseSynchronizer Class See Also Send Feedback

The DatabaseSynchronizer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseSynchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


DatabaseSynchronizer Properties

[image] [image]

SQL Schema Sync API Class reference
DatabaseSynchronizer Properties
DatabaseSynchronizer Class See Also Send Feedback

The DatabaseSynchronizer type exposes the following members.

Properties

Name | Description
DatabaseScriptsText | Gets text of scripts synchronizing database properies, permissions, etc.
NewDatabase | Gets a new database structure.
OldDatabase | Gets an old database structure.
Options | Gets or sets database synchronization options.
Scripts | Gets the synchronization scripts collection.
Synchronizers | Get synchonizers collection.

See Also

DatabaseSynchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


DatabaseScriptsText Property

[image]

SQL Schema Sync API Class reference
DatabaseSynchronizer..::.DatabaseScriptsText Property
DatabaseSynchronizer Class See Also Send Feedback
Gets text of scripts synchronizing database properies, permissions, etc.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string DatabaseScriptsText { get; }
Visual Basic (Declaration)
Public ReadOnly Property DatabaseScriptsText As String
Visual C++
public:
property String^ DatabaseScriptsText {
    String^ get ();
}

See Also

DatabaseSynchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


NewDatabase Property

[image]

SQL Schema Sync API Class reference
DatabaseSynchronizer..::.NewDatabase Property
DatabaseSynchronizer Class See Also Send Feedback
Gets a new database structure.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Database NewDatabase { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewDatabase As Database
Visual C++
public:
property Database^ NewDatabase {
    Database^ get ();
}

See Also

DatabaseSynchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


OldDatabase Property

[image]

SQL Schema Sync API Class reference
DatabaseSynchronizer..::.OldDatabase Property
DatabaseSynchronizer Class See Also Send Feedback
Gets an old database structure.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Database OldDatabase { get; }
Visual Basic (Declaration)
Public ReadOnly Property OldDatabase As Database
Visual C++
public:
property Database^ OldDatabase {
    Database^ get ();
}

See Also

DatabaseSynchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Options Property

[image]

SQL Schema Sync API Class reference
DatabaseSynchronizer..::.Options Property
DatabaseSynchronizer Class See Also Send Feedback
Gets or sets database synchronization options.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseSyncOptions Options { get; set; }
Visual Basic (Declaration)
Public Property Options As DatabaseSyncOptions
Visual C++
public:
property DatabaseSyncOptions^ Options {
    DatabaseSyncOptions^ get ();
    void set (DatabaseSyncOptions^ value);
}

See Also

DatabaseSynchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Scripts Property

[image]

SQL Schema Sync API Class reference
DatabaseSynchronizer..::.Scripts Property
DatabaseSynchronizer Class See Also Send Feedback
Gets the synchronization scripts collection.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public List<Script> Scripts { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scripts As List(Of Script)
Visual C++
public:
property List<Script^>^ Scripts {
    List<Script^>^ get ();
}

See Also

DatabaseSynchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Synchronizers Property

[image]

SQL Schema Sync API Class reference
DatabaseSynchronizer..::.Synchronizers Property
DatabaseSynchronizer Class See Also Send Feedback
Get synchonizers collection.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SynchronizerCollection<Synchronizer> Synchronizers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Synchronizers As SynchronizerCollection(Of Synchronizer)
Visual C++
public:
property SynchronizerCollection<Synchronizer^>^ Synchronizers {
    SynchronizerCollection<Synchronizer^>^ get ();
}

See Also

DatabaseSynchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Script Class

[image]

SQL Schema Sync API Class reference
Script Class
Members See Also Send Feedback
Represents the DDL script.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class Script
Visual Basic (Declaration)
Public NotInheritable Class Script
Visual C++
public ref class Script sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql.Synchronizers..::.Script

See Also

Script Members
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Script Members

[image] [image]

SQL Schema Sync API Class reference
Script Members
Script Class Methods Properties See Also Send Feedback

The Script type exposes the following members.

Methods

Name | Description
AppendFormat |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTexts | Enumerates ddl script texts in the current script instance.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Section | Gets ScriptSection.

See Also

Script Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Script Methods

[image] [image]

SQL Schema Sync API Class reference
Script Methods
Script Class See Also Send Feedback

The Script type exposes the following members.

Methods

Name | Description
AppendFormat |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTexts | Enumerates ddl script texts in the current script instance.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

Script Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


AppendFormat Method

[image]

SQL Schema Sync API Class reference
Script..::.AppendFormat Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:PerpetuumSoft.DataModel.MsSql.Synchronizers.Script.AppendFormat(System.String,System.Object[])"]

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public void AppendFormat(
    string text,
    params Object[] values
)
Visual Basic (Declaration)
Public Sub AppendFormat ( _
    text As String, _
    ParamArray values As Object() _
)
Visual C++
public:
void AppendFormat(
    String^ text,
    ... array<Object^>^ values
)

Parameters

text
Type: System..::.String
values
Type: array< System..::.Object >[]()[]

See Also

Script Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


GetTexts Method

[image]

SQL Schema Sync API Class reference
Script..::.GetTexts Method
Script Class See Also Send Feedback
Enumerates ddl script texts in the current script instance.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public IEnumerable<string> GetTexts()
Visual Basic (Declaration)
Public Function GetTexts As IEnumerable(Of String)
Visual C++
public:
IEnumerable<String^>^ GetTexts()

See Also

Script Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


ToString Method

[image]

SQL Schema Sync API Class reference
Script..::.ToString Method
Script Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Script Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Script Properties

[image] [image]

SQL Schema Sync API Class reference
Script Properties
Script Class See Also Send Feedback

The Script type exposes the following members.

Properties

Name | Description
Section | Gets ScriptSection.

See Also

Script Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Section Property

[image]

SQL Schema Sync API Class reference
Script..::.Section Property
Script Class See Also Send Feedback
Gets ScriptSection.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public ScriptSection Section { get; }
Visual Basic (Declaration)
Public ReadOnly Property Section As ScriptSection
Visual C++
public:
property ScriptSection^ Section {
    ScriptSection^ get ();
}

See Also

Script Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


ScriptSection Class

[image]

SQL Schema Sync API Class reference
ScriptSection Class
Members See Also Send Feedback
Represents scritpts section.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class ScriptSection
Visual Basic (Declaration)
Public NotInheritable Class ScriptSection
Visual C++
public ref class ScriptSection sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql.Synchronizers..::.ScriptSection

See Also

ScriptSection Members
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


ScriptSection Members

[image] [image]

SQL Schema Sync API Class reference
ScriptSection Members
ScriptSection Class Methods Fields Properties See Also Send Feedback

The ScriptSection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Create | Contains create scripts.
CreateWithoutTransaction | The Create script section which is executed without the transaction.
Database | Contains scripts executed right after prolog to synchronize database properties, permissions, etc.
Drop | Contains drop scripts.
DropWithoutTransaction | The Drop script section which is executed without the transaction.
Epilog | Contains scripts that are executed last of all within a transaction.
Prolog | Contains scripts that are executed first of all place within a transaction.

Properties

Name | Description
Index | Gets the section index.
SectionName | Gets the section name.

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


ScriptSection Fields

[image] [image]

SQL Schema Sync API Class reference
ScriptSection Fields
ScriptSection Class See Also Send Feedback

The ScriptSection type exposes the following members.

Fields

Name | Description
Create | Contains create scripts.
CreateWithoutTransaction | The Create script section which is executed without the transaction.
Database | Contains scripts executed right after prolog to synchronize database properties, permissions, etc.
Drop | Contains drop scripts.
DropWithoutTransaction | The Drop script section which is executed without the transaction.
Epilog | Contains scripts that are executed last of all within a transaction.
Prolog | Contains scripts that are executed first of all place within a transaction.

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Create Field

[image]

SQL Schema Sync API Class reference
ScriptSection..::.Create Field
ScriptSection Class See Also Send Feedback
Contains create scripts.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static readonly ScriptSection Create
Visual Basic (Declaration)
Public Shared ReadOnly Create As ScriptSection
Visual C++
public:
static initonly ScriptSection^ Create

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


CreateWithoutTransaction Field

[image]

SQL Schema Sync API Class reference
ScriptSection..::.CreateWithoutTransaction Field
ScriptSection Class See Also Send Feedback
The Create script section which is executed without the transaction.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static readonly ScriptSection CreateWithoutTransaction
Visual Basic (Declaration)
Public Shared ReadOnly CreateWithoutTransaction As ScriptSection
Visual C++
public:
static initonly ScriptSection^ CreateWithoutTransaction

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Database Field

[image]

SQL Schema Sync API Class reference
ScriptSection..::.Database Field
ScriptSection Class See Also Send Feedback
Contains scripts executed right after prolog to synchronize database properties, permissions, etc.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static readonly ScriptSection Database
Visual Basic (Declaration)
Public Shared ReadOnly Database As ScriptSection
Visual C++
public:
static initonly ScriptSection^ Database

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Drop Field

[image]

SQL Schema Sync API Class reference
ScriptSection..::.Drop Field
ScriptSection Class See Also Send Feedback
Contains drop scripts.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static readonly ScriptSection Drop
Visual Basic (Declaration)
Public Shared ReadOnly Drop As ScriptSection
Visual C++
public:
static initonly ScriptSection^ Drop

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


DropWithoutTransaction Field

[image]

SQL Schema Sync API Class reference
ScriptSection..::.DropWithoutTransaction Field
ScriptSection Class See Also Send Feedback
The Drop script section which is executed without the transaction.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static readonly ScriptSection DropWithoutTransaction
Visual Basic (Declaration)
Public Shared ReadOnly DropWithoutTransaction As ScriptSection
Visual C++
public:
static initonly ScriptSection^ DropWithoutTransaction

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Epilog Field

[image]

SQL Schema Sync API Class reference
ScriptSection..::.Epilog Field
ScriptSection Class See Also Send Feedback
Contains scripts that are executed last of all within a transaction.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static readonly ScriptSection Epilog
Visual Basic (Declaration)
Public Shared ReadOnly Epilog As ScriptSection
Visual C++
public:
static initonly ScriptSection^ Epilog

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Prolog Field

[image]

SQL Schema Sync API Class reference
ScriptSection..::.Prolog Field
ScriptSection Class See Also Send Feedback
Contains scripts that are executed first of all place within a transaction.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public static readonly ScriptSection Prolog
Visual Basic (Declaration)
Public Shared ReadOnly Prolog As ScriptSection
Visual C++
public:
static initonly ScriptSection^ Prolog

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


ScriptSection Methods

[image] [image]

SQL Schema Sync API Class reference
ScriptSection Methods
ScriptSection Class See Also Send Feedback

The ScriptSection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


ScriptSection Properties

[image] [image]

SQL Schema Sync API Class reference
ScriptSection Properties
ScriptSection Class See Also Send Feedback

The ScriptSection type exposes the following members.

Properties

Name | Description
Index | Gets the section index.
SectionName | Gets the section name.

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Index Property

[image]

SQL Schema Sync API Class reference
ScriptSection..::.Index Property
ScriptSection Class See Also Send Feedback
Gets the section index.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


SectionName Property

[image]

SQL Schema Sync API Class reference
ScriptSection..::.SectionName Property
ScriptSection Class See Also Send Feedback
Gets the section name.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string SectionName { get; }
Visual Basic (Declaration)
Public ReadOnly Property SectionName As String
Visual C++
public:
property String^ SectionName {
    String^ get ();
}

See Also

ScriptSection Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Synchronizer Class

[image]

SQL Schema Sync API Class reference
Synchronizer Class
Members See Also Send Feedback
Performs comparison and builds synchronization script for database elements.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public abstract class Synchronizer
Visual Basic (Declaration)
Public MustInherit Class Synchronizer
Visual C++
public ref class Synchronizer abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.DataModel.MsSql.Synchronizers..::.Synchronizer

See Also

Synchronizer Members
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Synchronizer Members

[image] [image]

SQL Schema Sync API Class reference
Synchronizer Members
Synchronizer Class Constructors Methods Properties See Also Send Feedback

The Synchronizer type exposes the following members.

Constructors

Name | Description
Synchronizer | Initializes a new instance of the Synchronizer class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStateAccordingAlterRealization | Gets the state subject to alter script realization.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action | Gets an action to perform in order to synchronize elements structure.
DatabaseBuilder | Gets an owner.
NeedSynchronizing | Gets or sets true value if the object is synchronized.
NewObject | Gets an element in a new database structure.
OldObject | Gets an element in an old database structure.
ScriptsText | Gets synchronization script text.
State | Gets or sets object state.

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Synchronizer Constructor

[image]

SQL Schema Sync API Class reference
Synchronizer Constructor
Synchronizer Class See Also Send Feedback
Initializes a new instance of the Synchronizer class

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected Synchronizer()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Synchronizer()

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Synchronizer Methods

[image] [image]

SQL Schema Sync API Class reference
Synchronizer Methods
Synchronizer Class See Also Send Feedback

The Synchronizer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStateAccordingAlterRealization | Gets the state subject to alter script realization.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


GetStateAccordingAlterRealization Method

[image]

SQL Schema Sync API Class reference
Synchronizer..::.GetStateAccordingAlterRealization Method
Synchronizer Class See Also Send Feedback
Gets the state subject to alter script realization.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
protected abstract SynchronizerState GetStateAccordingAlterRealization()
Visual Basic (Declaration)
Protected MustOverride Function GetStateAccordingAlterRealization As SynchronizerState
Visual C++
protected:
virtual SynchronizerState GetStateAccordingAlterRealization() abstract

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Init Method

[image]

SQL Schema Sync API Class reference
Synchronizer..::.Init Method
Synchronizer Class See Also Send Feedback
Initializes objects.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public virtual void Init(
    DatabaseSynchronizer databaseBuilder,
    Element newObject,
    Element oldObject
)
Visual Basic (Declaration)
Public Overridable Sub Init ( _
    databaseBuilder As DatabaseSynchronizer, _
    newObject As Element, _
    oldObject As Element _
)
Visual C++
public:
virtual void Init(
    DatabaseSynchronizer^ databaseBuilder,
    Element^ newObject,
    Element^ oldObject
)

Parameters

databaseBuilder
Type: PerpetuumSoft.DataModel.MsSql.Synchronizers..::.DatabaseSynchronizer
newObject
Type: PerpetuumSoft.DataModel.MsSql..::.Element
oldObject
Type: PerpetuumSoft.DataModel.MsSql..::.Element

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Synchronizer Properties

[image] [image]

SQL Schema Sync API Class reference
Synchronizer Properties
Synchronizer Class See Also Send Feedback

The Synchronizer type exposes the following members.

Properties

Name | Description
Action | Gets an action to perform in order to synchronize elements structure.
DatabaseBuilder | Gets an owner.
NeedSynchronizing | Gets or sets true value if the object is synchronized.
NewObject | Gets an element in a new database structure.
OldObject | Gets an element in an old database structure.
ScriptsText | Gets synchronization script text.
State | Gets or sets object state.

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Action Property

[image]

SQL Schema Sync API Class reference
Synchronizer..::.Action Property
Synchronizer Class See Also Send Feedback
Gets an action to perform in order to synchronize elements structure.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SynchronizerAction Action { get; }
Visual Basic (Declaration)
Public ReadOnly Property Action As SynchronizerAction
Visual C++
public:
property SynchronizerAction Action {
    SynchronizerAction get ();
}

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


DatabaseBuilder Property

[image]

SQL Schema Sync API Class reference
Synchronizer..::.DatabaseBuilder Property
Synchronizer Class See Also Send Feedback
Gets an owner.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public DatabaseSynchronizer DatabaseBuilder { get; }
Visual Basic (Declaration)
Public ReadOnly Property DatabaseBuilder As DatabaseSynchronizer
Visual C++
public:
property DatabaseSynchronizer^ DatabaseBuilder {
    DatabaseSynchronizer^ get ();
}

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


NeedSynchronizing Property

[image]

SQL Schema Sync API Class reference
Synchronizer..::.NeedSynchronizing Property
Synchronizer Class See Also Send Feedback
Gets or sets true value if the object is synchronized.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public bool NeedSynchronizing { get; set; }
Visual Basic (Declaration)
Public Property NeedSynchronizing As Boolean
Visual C++
public:
property bool NeedSynchronizing {
    bool get ();
    void set (bool value);
}

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


NewObject Property

[image]

SQL Schema Sync API Class reference
Synchronizer..::.NewObject Property
Synchronizer Class See Also Send Feedback
Gets an element in a new database structure.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Element NewObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewObject As Element
Visual C++
public:
property Element^ NewObject {
    Element^ get ();
}

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


OldObject Property

[image]

SQL Schema Sync API Class reference
Synchronizer..::.OldObject Property
Synchronizer Class See Also Send Feedback
Gets an element in an old database structure.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public Element OldObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property OldObject As Element
Visual C++
public:
property Element^ OldObject {
    Element^ get ();
}

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


ScriptsText Property

[image]

SQL Schema Sync API Class reference
Synchronizer..::.ScriptsText Property
Synchronizer Class See Also Send Feedback
Gets synchronization script text.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public string ScriptsText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScriptsText As String
Visual C++
public:
property String^ ScriptsText {
    String^ get ();
}

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


State Property

[image]

SQL Schema Sync API Class reference
Synchronizer..::.State Property
Synchronizer Class See Also Send Feedback
Gets or sets object state.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SynchronizerState State { get; internal set; }
Visual Basic (Declaration)
Public Property State As SynchronizerState
Visual C++
public:
property SynchronizerState State {
    SynchronizerState get ();
    void set (SynchronizerState value);
}

See Also

Synchronizer Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


SynchronizerAction Enumeration

[image]

SQL Schema Sync API Class reference
SynchronizerAction Enumeration
See Also Send Feedback
Represents synchronization action.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum SynchronizerAction
Visual Basic (Declaration)
Public Enumeration SynchronizerAction
Visual C++
public enum class SynchronizerAction

Members

Member name | Description
None | Do nothing.
Create | Create object.
Drop | Drop object.
Alter | Alter object.
ReCreate | Recreate object

See Also

PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


SynchronizerCollection(T) Class

[image]

SQL Schema Sync API Class reference
SynchronizerCollection<(Of <(T>)>) Class
Members See Also Send Feedback
Represents a collection of Synchronizer.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public sealed class SynchronizerCollection<T> : KeyedCollection<Element, T>
where T : Synchronizer
Visual Basic (Declaration)
Public NotInheritable Class SynchronizerCollection(Of T As Synchronizer) _
    Inherits KeyedCollection(Of Element, T)
Visual C++
generic<typename T>
where T : Synchronizer
public ref class SynchronizerCollection sealed : public KeyedCollection<Element^, T>

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:PerpetuumSoft.DataModel.MsSql.Synchronizers.SynchronizerCollection`1"]

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection<(Of <(T>)>)
System.Collections.ObjectModel..::.KeyedCollection<(Of <( Element, T>)>)
PerpetuumSoft.DataModel.MsSql.Synchronizers..::.SynchronizerCollection<(Of <(T>)>)

See Also

SynchronizerCollection<(Of <(T>)>) Members
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


SynchronizerCollection(T) Members

[image] [image]

SQL Schema Sync API Class reference
SynchronizerCollection<(Of <(T>)>) Members
SynchronizerCollection<(Of <(T>)>) Class Constructors Methods Properties See Also Send Feedback

The SynchronizerCollection<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
SynchronizerCollection<(Of <(T>)>) | Initializes a new instance of the SynchronizerCollection<(Of <(T>)>) class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
ClearItems | Removes all elements from the KeyedCollection<(Of <(TKey, TItem>)>). (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( T >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKeyForItem | When implemented in a derived class, extracts the key from the specified element. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( T >)>).)
InsertItem | Inserts an element into the KeyedCollection<(Of <(TKey, TItem>)>) at the specified index. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(TKey, TItem>)>). (Inherited from KeyedCollection<(Of <( Element, T >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(TKey, TItem>)>). (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)

See Also

SynchronizerCollection<(Of <(T>)>) Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


SynchronizerCollection(T) Constructor

[image]

SQL Schema Sync API Class reference
SynchronizerCollection<(Of <(T>)>) Constructor
SynchronizerCollection<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance of the SynchronizerCollection<(Of <(T>)>) class.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public SynchronizerCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SynchronizerCollection()

See Also

SynchronizerCollection<(Of <(T>)>) Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


SynchronizerCollection(T) Methods

[image] [image]

SQL Schema Sync API Class reference
SynchronizerCollection<(Of <(T>)>) Methods
SynchronizerCollection<(Of <(T>)>) Class See Also Send Feedback

The SynchronizerCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
ClearItems | Removes all elements from the KeyedCollection<(Of <(TKey, TItem>)>). (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <( T >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKeyForItem | When implemented in a derived class, extracts the key from the specified element. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection<(Of <( T >)>).)
InsertItem | Inserts an element into the KeyedCollection<(Of <(TKey, TItem>)>) at the specified index. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(TKey, TItem>)>). (Inherited from KeyedCollection<(Of <( Element, T >)>).)
SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SynchronizerCollection<(Of <(T>)>) Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Contains Method

[image] [image]

SQL Schema Sync API Class reference
SynchronizerCollection<(Of <(T>)>)..::.Contains Method
SynchronizerCollection<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)

See Also

SynchronizerCollection<(Of <(T>)>) Class
SynchronizerCollection<(Of <(T>)>) Members
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Remove Method

[image] [image]

SQL Schema Sync API Class reference
SynchronizerCollection<(Of <(T>)>)..::.Remove Method
SynchronizerCollection<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(TKey, TItem>)>). (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)

See Also

SynchronizerCollection<(Of <(T>)>) Class
SynchronizerCollection<(Of <(T>)>) Members
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


SynchronizerCollection(T) Properties

[image] [image]

SQL Schema Sync API Class reference
SynchronizerCollection<(Of <(T>)>) Properties
SynchronizerCollection<(Of <(T>)>) Class See Also Send Feedback

The SynchronizerCollection<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)
Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(TKey, TItem>)>). (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection<(Of <( T >)>).)

See Also

SynchronizerCollection<(Of <(T>)>) Class
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


Item Property

[image] [image]

SQL Schema Sync API Class reference
SynchronizerCollection<(Of <(T>)>)..::.Item Property
SynchronizerCollection<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Item[([(TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection<(Of <( Element, T >)>).)
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <( T >)>).)

See Also

SynchronizerCollection<(Of <(T>)>) Class
SynchronizerCollection<(Of <(T>)>) Members
PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace


SynchronizerState Enumeration

[image]

SQL Schema Sync API Class reference
SynchronizerState Enumeration
See Also Send Feedback
Represents synchronizer state.

Namespace: PerpetuumSoft.DataModel.MsSql.Synchronizers
Assembly: PerpetuumSoft.DataModel (in PerpetuumSoft.DataModel.dll) Version: 1.0.0.0

Syntax

C#
public enum SynchronizerState
Visual Basic (Declaration)
Public Enumeration SynchronizerState
Visual C++
public enum class SynchronizerState

Members

Member name | Description
Equals | Object is not changed.
Created | Object is newly created.
Droped | Object is dropped.
Altered | Object is altered.
ReCreated | An object is recreated.

See Also

PerpetuumSoft.DataModel.MsSql.Synchronizers Namespace